Curio 6.0 Release Notes

Release Date

September 7, 2009

Requirements

Curio runs on OS X Leopard (10.5) or OS X Snow Leopard (10.6) on PowerPC or Intel machines.

Editions

Unless otherwise specified any features listed are in all editions of Curio. Features only available in certain editions will be listed with color-coded words like this [ProStandard]. So, for example, [Pro], means that the feature is available only in the Professional edition of Curio.

Important Notice To Upgraders

  1. Curio 6.0 will need to upgrade project files created with earlier versions of Curio. Please note that the converted project file cannot be re-opened in earlier versions of Curio!
  2. The old Edit > Export As submenu for figure exporting has been moved and renamed to File > Export Selected Figures As.

New Features

Here's what we've added to this major update to Curio:

Tables

Curio 6 adds support for wonderful, native, integrated tables!

That's right, true tables with resizable rows and columns which, like our other collections such as lists and mind maps, can contain any Curio figure such as text, images, URLs, movies, and more!

Getting Started

To get started, simply click on the new Table button on the toolbar, or choose the Insert > Table menu item, to create a default table figure. Then check out the Table inspector under the Display tab where you can make lots of adjustments including:

  • The number of rows and columns in the "body" of the table (that is, the cells which aren't row or column headers or footers),
  • The column width and row height,
  • The row header and footer visibility,
  • The column header and footer visibility.

While here in the Table inspector you can also click a button to make the currently selected cell within the table the default figure style for all body cells, the row header cells, the row footer cells, the column header cells, or the column footer cells. And you can check the "Except for the selected figures" checkbox so the selected cells can keep their own styles and ignore any global cell style changes.

Like our other collections, customizable style support is built-in so you can easily switch table styles via the Inspector Bar or save and share your own styles using the Styles inspector panel. If you create some super-cool styles then please send them to Zengobi using the Style inspector's actions button menu so we can publish them on our Curio Community Center!

Context Menu

If you right-click on a table cell, you can also quickly add, select, or remove rows or columns with just a click.

Editing Your Table

Double-click a table cell to start editing, or select the cell and hit Enter. Press Tab or Shift-Tab to move between the cells. You can also use the left, right, up, and down arrow keys.

Figures within the table can have all the normal adornments such as checkmarks, flags, start/due dates, priorities, and ratings. All adornments are forced to be along the bottom of the cell.

Drag-and-Drop and Cut/Copy/Paste

To select a bunch of cells, click on a cell then hold the Shift key to select a rectangular block of cells. Or hold down the Command key and click on individual cells to select a discontiguous selection of cells.

Like mind maps and lists, you can easily drag figures out your table onto the idea space or another collection figure simply by dragging it out of the table. And you can drag figures directly into a table, instantly repacing the hovered-over cell.

If you drag either a selected range or a discontiguous selection from a table and then drop them within the same or a different table, Curio will automatically add the necessary number of rows or columns to accommodate the dropped figures while keeping their same relative row/column positions from each other.

Likewise, if you drag in, or paste, a selection of figures from the idea space into your table, Curio will lay them out linearly starting at the hovered-over cell, automatically adding rows as necessary to accommodate all the dropped figures.

Images

If you drag in an image or any other asset figure shown in preview mode, then it will automatically be centered vertically and horizontally within the table cell. You can control this alignment using the alignment buttons in the Text inspector.

If you want the image to be scaled to fill the entire cell then you can either turn off the proportional checkbox in the Geometry inspector, or click the "fully justified" button in the horizontal alignment buttons in the Text inspector.

Resizing

You can resize the entire table using by selecting the table figure itself and dragging one of its resize handles. When this is done all rows and columns with grow proportionally.

You can also resize individual rows and columns by moving the mouse over one of the row/column dividing lines where the mouse changes into a resize cursor then dragging.

Exporting & Importing

Click on your table and choose File > Export Selected Figures As > CSV to save your table as a Comma Separated Value file for importing into Excel, Numbers, or many other applications. You can also import a CSV file simply by drag-and-dropping a .csv file on the Curio idea space.

If you copy a selection of cells from Excel or Numbers, you can choose Curio's Edit > Paste As > Table to convert that tab-delimited info into a new or existing table. Also, when copying a table or selected items within the table, a tab-delimited representation of that data is placed onto the clipboard for pasting into Excel or Numbers.

Figure Stencils [Pro]

Curio Pro 6 adds support for figure stencils where you can create, re-use, and share frequently used figures and grouped figures.

Creating a Stencil

For instance, you can create an idea space filled with images of Apple products including Macs, iPods, etc, dragged over from Apple's website. In the idea space, add a little text caption to each image with a certain nice font and size. For each image and text item pairing, select them and group them together.

Next, drag-and-drop that idea space from the Organizer to your Stencils shelf. Ta da! The contents of that idea space have been copied into the Stencil's library and you have just created your first stencil collection.

Next, associate your new stencil collection with one or more custom collection tags such as "apple", "ipod", and "mac" using the shelf actions menu. Other collection tags you may create include "work", "home", "design", "code", etc.

Using a Stencil

Now, let's say a few days go by and you find yourself needing a quick picture of an Apple iPod touch. Just click on the Stencils shelf and find your nifty Apple collection. You can either:

  1. Drag-and-drop the entry representing the entire collection over to your idea space to copy all the figures over, or
  2. Double-click the Apple stencil collection to view the individual grouped figures which make up that collection, then drag-and-drop just the iPod touch grouped figure back to your idea space.

Stencils can be any type of figure, here are some ideas:

  • Boilerplate text items of various font size and shape enclosures.
  • Boilerplate mind map or list templates.
  • Various types of lines and arrows drawn using different colors and endpoint styles.
  • Geographic maps.
  • Network diagram elements.
  • User interface design elements.
  • Website design elements.

If you need to make some changes to your stencil simply right-click on the item and choose Edit Stencil from the popup menu.

You can also easily share your stencil collection with others either directly or via Curio's Community Center by right-clicking on the stencil collection and choosing the appropriate menu item.

Custom Flag Icons

This is a very popular request so we're happy to finally introduce it in Curio.

Using the new Flags Preference panel, users can create flag sets with custom flag images. Any type of image is supported, although scalable images such as icns files are preferred for nicer scaling, otherwise built-in bitmap scaling is used.

Since you can use any image as a flag, you can find thousands of potential flags on the web! Icon repository sites, such as IconArchive, are recommended as you can download icons as icns files for beautifully scalable flags.

But even static 16x16 png's such as FamFamFam's Silk Icons are awesome to use in lists and mind maps. Just drag and drop their folder of incredible looking icons into Curio's Flags Preference panel and you'll instantly have access to 1,000 new flags. Very cool!

Your new flags are accessible in the Inspector Bar, the Flags Inspector, and the Search shelf. Yes, you can even search on your custom flags.

Easily share your flag sets by simply dragging a flag set name out of the Flags Preferences panel directly to the Desktop. Curio will create a folder which contains all the flag set's images. You can then send that created folder to a friend or colleague and they can drag it directly into their flag set list to instantly gain access to the same flags.

Mind Map and List Branch Colors

The style inspector now supports branch colors for list and mind map collections!

When enabled, the colors — including pen color, fill color, gradient color, and text color — of the figures along a hierarchical branch will be the same. This is particularly effective in mind maps as each branch will have its own coloring to make it really stand out.

The branch colors feature will override just the colorings used along the branches while maintaining the the level-specific shape stylings. So, it works in tandem with hierarchical level styles where the hierarchical level defines the shape and the branch color defines the coloring.

While you can manually specify the pen, fill, and text coloring for each branch, Curio can help you get started, via a nifty color palette popup found in this inspector. Using each color in the selected palette, an appropriate pen, fill, and text color is created and applied to a branch. The colors in the palette are repeated as necessary to make sure each hierarchical branch is colored. (While the popup only shows the first five colors in the palette file, all colors in the palette are used before repeating when coloring branches.)

And, it's incredibly easy to add more color palettes to this popup simply by drag-and-dropping Adobe Swatch Exchange (.ase) files into the style inspector. You can find thousands of these files by exploring sites like Adobe Kuler and ColourLovers.

More Mind Map Line Styles

In addition to our standard straight mind map line style, we're happy to introduce curved, elbow, and rounded elbow line styles. The line style is switchable via the new Mind Map inspector panel. Here are examples showcasing the available styles. Click to enlarge.

Mind Map Smart Sizing

By extremely popular demand, the mind map figure will now automatically shrink or grow as the nodes within the mind map are collapsed or expanded. This default setting can be controlled via the new "mind maps shrink as nodes collapse" option in Curio's Preferences. Note, however, if you manually resize a mind map then it will not automatically shrink when collapsed.

One-Click Hierarchy Branching

Now Curio makes it incredibly easy to flesh out a list or mind map branch in a whole new tree.

You begin by right-clicking on a figure in a list or mind map collection, the "parent collection", and choosing the "Prune To Linked Collection" menu item.

Curio will then create a new list or mind map, of the same style as the current collection where the selected parent becomes the new top level item — either the title of the list or the central topic of a mind map — and all of its children will be hierarchically arranged underneath.

The children of the original parent are then removed and the original parent itself becomes a jump action which, when clicked, will zip you to the new collection. The new child collection can remain on the current idea space or it can be cut and pasted onto a different idea space, and the jump action in the parent collection will still track it down.

And, the root of your new child collection will automatically get an jump action associated with it to jump you back to the parent collection item.

This means, if your list or mind map is getting a bit too crowded or busy, you can easily prune off a branch and bring it to its own mind map perhaps off on another idea space where you have plenty of room to let your mind feel unrestricted.

Additional Mind Map and List Collection Enhancements

  • Two new list enumeration prefix styles which are commonly used in legal and scientific publications are now available:
    1. 1, 1.1, 1.1.1, 1.1.1.1 ....
    2. 1., 1.1., 1.1.1., 1.1.1.1. ....
  • You can now associate flags, priorities, and ratings with list and mind map collection figures (previously you could only do this for items within these collections). You can search on this meta data and the collections themselves with appear in the Search shelf.
  • To be more consistent with other mind mapping applications, pasting onto a node in the mind map will create children instead of siblings. However, pasting onto a list node will always create siblings to be consistent with other outlining applications.
  • You can now check the "allow full control of figure size" text inspector checkbox for figures within a mind map. This means you can stretch a mind map node to be as tall and wide as you want.
  • If you hold Shift down when clicking the Mind Map toolbar button you will get an empty mind map figure. What good is that? Now you can select a branch in another mind map, copy or cut it, then paste it into your empty mind map figure to get a new map.
  • New "Allow expanding/collapsing" checkbox in the List inspector which you can uncheck to turn off the expand/collapse disclosure triangle and bullets. By turning off this option, you choose a bullet prefix style and not see double-bullets!
  • When converting back and forth between list and mind map (via the collection’s right-click context menu), Curio will now keep track of the style used for the previous collection style and restore it when switching back.
  • You can now select items within a locked list or mind map collection. This permits copying the items for placement elsewhere.
  • When checking or unchecking a parent node in a list or mind map you can now tell Curio to suppress the warning that changing the parent will check/uncheck all of its children.
  • More accurately placed disclosure triangles and bullets make lists look much nicer!
  • Duplicating and pasting large collections such as lists is now much, much faster.
  • Fixed problems resizing mind maps when grabbing certain resize handles.
  • New keyboard shortcuts for Insert Mind Map (Command-Control-M) and for Insert List (Command-Control-L).
  • Tweak to OPML exporter so the title elements are contained within a head element so we're now fully compliant with the OPML spec.
  • Importing and exporting OPML now supports item notes by using the "_note" XML attribute quasi-standard (as per OmniOutliner).
  • Exporting or copying a mind map or list as a text outline will now include figure notes in the output. Normally the note will be rendered as a sibling of its associated figure. However, if Curio is set to use tabs to indent the outline elements (see Curio's Preferences > Idea Space > Use tabs to indent) then you can type the following in Terminal if you want the note text to be rendered as a child:
    defaults write com.zengobi.curio "Copy Text Outline Note Is Child" -bool yes

Task Management Enhancements

Task management in Curio is very popular so we're happy to add the following new features.

  • New "Include items with no start or due dates" checkmark in the Status section of the General Preferences. If unchecked, then Curio will no longer include any unchecked figures in the Status shelf that don't have a start or due date associated with them.
  • Likewise, new "Sync items with no start or due dates" checkmark in the Sync section of the Project Properties. If unchecked, then Curio will no longer sync with iCal any unchecked figures that don't have a start or due date associated with them.
  • No longer showing Status results due tomorrow in both the Tomorrow and This Week grouping.
  • No longer showing Status results that are simply associated with global tag set tags and don't have a start/due date or showing a checkmark, unless we're grouping by a tag set. The Status graphs, however, will still correctly ignore those non-task items.
  • Status shelf now correctly updates itself when modifications are made to figures when multiple projects are opened simultaneously.
  • Inserted variables, such as {%IdeaSpaceTitle}, are now replaced with their appropriate text in the Search shelf's results list.
  • Now automatically determining the correct month/day separator to use in the start/due date adornments instead of always using a slash. In Sweden, for example, they prefer a dash.
  • New Preference: Skip Weekends When Determining Due Dates, if you want Curio to ignore weekends when calculating due dates and durations.
  • Computing due dates for list or mind map parents is now more reliable if child items with due dates are either removed or disassociated with due dates.

Search Refinements

Curio's tag and search handling have been given a few useful tweaks.

  • If you use the Search shelf to search for some text that starts with a pound sign (#) then we'll look for the word as a tag. Thus, searching for #legal will do a search for a tag named legal. Note that normally text searching for just legal would return any results which contain that word in the figure's text, asset contents, notes, and tag. Thus, prefacing it with a pound sign is a fast shortcut to choosing it from the Search shelf's Tags list since it will only return an exact tag match.
  • The Curio Spotlight importer has been updated to include any used tags and #tags with a project's scanned metadata. This means if the tag legal was used in a project then legal and #legal will be in the resulting Spotlight metadata.
  • All of those changes means that if you use Spotlight to search for #legal, you'll see all projects that use the Curio tag legal, and if you then choose one of those projects from Spotlight's results list, Curio will launch and open that project and automatically do a tag search for legal.
  • If you search for some text in the Search shelf, find some results, and then double-click on an asset figure in the idea space to launch it, the search text will be sent to the launched application. This means if you search for the word fisherman using the Search shelf, and find that it's in one of your embedded PDFs, then you can double-click the PDF and the fisherman search phrase will get passed to Preview so it will automatically search for fisherman upon opening the PDF.
  • When searching in the Search shelf for a certain asset type, it will now find internal aliases to those types in addition to embedded instances of those types.
  • Added support for Apple Numbers documents to both the Search shelf and to the Flashlight shelf.

Sleuth Updates

Curio's bundled Sleuth site definitions have been refreshed.

  • Added the Photos.com site to the Images group.
  • Added the JupiterImages site to the Images group.
  • Added the Bing site to the Search Engines group.
  • Added the Bing Images site to the Images group.
  • Added the Bing News site to the News group.
  • Added the Bing Videos site to the Multimedia group.
  • Added the Wolfram Alpha site to the References group.
  • Updated the Merriam Webster dictionary and thesaurus site files to support their latest website changes.
  • Updated the Google and Google Images site files so they handle umlauts and other foreign characters in the search field.
  • Removed AbleStock since they have been merged into JupiterImages.
  • Removed ComStock since they have been merged into JupiterImages.
  • Removed BrandXPictures since they have been merged into JupiterImages.
  • Removed BigShotMedia since they have been merged into Photos.com
  • Removed Encarta since they are closing their operations on October 31, 2009.
  • Removed RocketClips since they appear to be offline.
  • Tweak to Sleuth to support sites that simply redirect to a new URL with the search term embedded within the URL, instead of doing a true GET/POST submission (like StockXPERT, for example). You can now place %%PHRASE%% on the site's URL line and it will be replaced with the current search term. So add StockXPERT to Sleuth with http://stockxpert.com/browse_image/search/text/%%PHRASE%% as the site URL.

One-Click Version Updates via Sparkle

Curio is now integrated with the super-cool Sparkle framework which can download and install Curio updates with just a single click.

Additional Enhancements and Refinements

And that's not all! Here are even more refinements to make using Curio just that much better.

Text Handling
  • New superscript and subscript buttons in the text inspector.
  • All text figures now perform automatic link detection as you type URLs into them.
  • If you paste some text which is an URL (like copied from the Safari location bar), then it is automatically converted into an URL figure instead of a text figure.
Image Figures

Say you double-click an image figure to edit it in Preview or Photoshop, to crop it for example, then save the image file. Upon returning to Curio the image figure will not only refresh itself since the underlying image data has changed, but it will now see that the proportions have changed and automatically adjust the image figure's bounds accordingly.

Line Drawing
  • Line endpoints and midpoints will now automatically snap when close to a horizontal or vertical line which makes it much easier to make nice straight lines.
  • Sticky lines are now smarter about automatically repositioning themselves if adjacent endpoints move and avoiding glow artifacts.
Pens and Brushes
  • Hold down the Shift key when scribbling to force the brush to go in a straight line either horizontally or vertically.
  • The Organizer's preview image now shows any drawn scribbles.
Scrapbook Shelf

Hold down the Option key while dragging an item in from the Scrapbook to move it into your idea space, automatically deleting it from the Scrapbook.

Evernote Shelf

Evernote tags and notebooks are now sorted in their respective popups in the Evernote shelf.

Full Screen Mode

New 'Hide Shelf' option added to the Full Screen General Preferences so the shelf can auto-hide when entering into full screen mode.

Library

Pressing Spacebar in the Library view will now activate Quick Look for the selected assets.

Insert > Instant Document

Updated Instant Document's Keynote, Pages, Numbers, and InDesign template docs so they are compatible with the latest releases of those products.

Additional Features

  • New Inspector Bar keyboard shortcut: Command-Shift-R.
  • When you launch Curio, it will now re-open all projects which were open when you last quit and not just the last active one.

Notable Fixes

  • Fixed bug trying to use the width/height edit fields and steppers in the figure's Geometry inspector if proportional sizing was enabled.
  • Fixed crazy sizes and origins from getting automatically set when the user tries to resize a shapeshifted figure using the Geometry inspector.
  • Using QuickZoom (via pressing and holding the Q key) and positioning the mouse cursor over the top-left portion of the idea space will correctly go to that area when Q is released.
  • QuickZoom mode now works even when scribbling with the brush tools.
  • If you just open the video recording window and then close it, we now turn off the iSight camera.
  • Fixed a problem where certain rare sites in a WebView or WebArchive wouldn't be displayed correctly, if at all.
  • Tweaks so the tooltip can handle Notes that have carriage returns in it.
  • Dragged-in Mail messages that have foreign characters in the From or Subject fields are now rendered correctly in Curio.
  • The adornment "display within shape" inspector item is now correctly disabled if the item is a collection or within a collection, which overrides that setting anyway.
  • Fixed problem where adding a note to a figure in a newly created list or mind map would not automatically show the note adornment.
  • Fixed the popup calendars in the Inspector Bar date pickers so they correctly jump to the currently set date of the selected figure.
  • Fixed problem where collection level styles would override link, superscript, and subscript attributes of items within the collection.
  • Fixed a printing problem where scaling and placement wasn't occurring as it should if you specified a scale factor in the Print Setup dialog (and disabled the fit onto a single printed page).
  • Fixed odd style issue where setting the default shapeshifter style for a text figure would sometimes override styles associated with hierarchies in mind maps or lists.
  • Fixed a style issue where defining a default style for a text figure wasn't working if the style was a named (aka saved) style.
  • Fixed a problem where if the default text figure style was changed to a different shapeshifter then then rectangle item in the Figures toolbar popup menu wouldn't draw a rectangle.
  • Fixed style issue where if underlining a single word in a multi-word mind map entry then all figures at that level would suddenly have black text with no underlining.
  • Fixed an odd issue where changing the appearance theme would cause problem when rendering certain objects like start/due adornment flags and sometimes some of the icons shown in in the Inspector.