Curio 11.2 Release Notes

Release Date

April 24, 2017

Requirements

Curio 11 runs on OS X Yosemite (10.10), OS X El Capitan (10.11), or macOS Sierra (10.12).

Editions

Features only available in certain editions will be listed with colored tags like , , . For example, next to a feature means that the feature is available only in the Professional edition of Curio.

Features

Sleuth and DEVONthink Pro Office

Curio's Sleuth and Sleuth shelf can now search your DEVONthink Pro Office database.

Setting up the DEVONthink Sleuth Site
  1. Launch DEVONthink Pro Office as it must be running for Sleuth to communicate with it. Note only the DEVONthink Pro Office product has the required integrated web server; other DEVONthink editions do not include this functionality.
  2. Open the database you wish to share and make sure its Share Database property (set via File > Database Properties) is checked:

  3. Next, bring up DEVONthink's Preferences and turn on its built-in server:

    • Assign a static port of 41111 that it will use even when relaunched. This is also the default port used in the bundled Sleuth site. If you'd like to specify a different port then follow these steps:
      • Choose a port number between 1024 and 49151 as those are for static ports. Ports 1 through 1023 are reserved for system services, and 49152 on up to 65535 are ephemeral ports which are generally used for temporary purposes.
      • Next you need to make a custom version of the bundled DEVONthink Sleuth site to set up the custom port. Bring up Sleuth and click the pencil icon to edit your sites. Notice the new Local Servers collection, shown on the right. Make a copy of the bundled DEVONthink site item using the new Copy button at the bottom of the window and customize the site to use the appropriate port.
    • Click the Start on Launch checkbox so the server automatically launches the next time you run DEVONthink.
    • Click the Start button to start the server.
Using the DEVONthink Sleuth Site

Now you can search your DEVONthink Pro Office database using Sleuth:

Or the Sleuth shelf:

Clicking a found item in Sleuth will reveal the file in the DEVONthink Pro Office client application, or you can drag-and-drop the item into idea space to create a special hyperlink to that file.

Technical

Behind the scenes Sleuth is taking DEVONthink Pro Office's HTML server response and cleaning up the results with some CSS overrides and tweaked links to support hyperlinks back to the DEVONthink client. Special shout-out to these two posts in the forums for encouraging this new feature.

Sleuth and YouTube/Vimeo

Both YouTube and Vimeo have been added as available Sleuth sites. They are also accessible in the Sleuth shelf as well, as shown below.

You can simply drag-and-drop a video into your idea space to create an embedded movie view.

Special shout-out to this post in the forums for encouraging this new feature.

Status Shelf: Live Export

Curio Professional's Status shelf now has a brand new, very cool feature: live export.

Panic's Status Board

You may recall that, back in Curio 8.6, we added support for Panic's amazing Status Board iOS app which gave you a very slick graphical status view of your projects... on your iPad!

It was very cool but it only ran on iPads, not macOS or generic HTML, and sadly they discontinued Status Board last fall.

Fortunately we now have something even better with Curio's new live export feature.

Setting up Live Export

Use the Status shelf's Tasks In actions menu to manage live export.

  1. Enable live export by specifying the folder where the live export reports should be saved:
  2. Click the menu again to enable each type of live export you wish to produce. RTF and HTML exports are enabled by default.
  3. You can also choose what category of projects to export:
  4. And how they should be grouped:

That's it!

Now, in the background, the Status shelf will keep those live export files automatically up-to-date as tasks and projects are changed. The export files created in the specified live export folder are named Curio Status.rtf, Curio Status.csv, and Curio Status.html. If you specify a synced folder, like Dropbox, or a network folder, then those updates will be available to everyone with access to that folder.

HTML Live Export Tour

Click here to open a sample HTML live export. We tried to mimic the look and feel of the original Status Board output with several key improvements.

At the top you see two bar charts indicating, at a glance, how many tasks are starting or due before today, today, tomorrow, within a week, within a month, or sometime later in the future.

Directly below the charts are your action items which are listed by start date unless progress has been made (via percent complete) in which case the due date is used. Notice that the rating, priority, resources, or tags associated with a task are included in small type.

Next you see all the items as grouped and displayed in the tasks area of Status shelf itself. For example, in the task area you might be grouping by due date, tag set, resource, or priority. That same result list, with more details, will appear here in the HTML report.

HTML Live Export Key Features

There are some other key features of the new HTML live export:

  • Cross Platform
    The resulting HTML is standard, compact, and runs on macOS (Safari and Chrome) and iOS (Safari and Dropbox). It should run just fine on other platforms as well as long as you use a relatively modern browser.
  • Self Contained
    The HTML does not reference any external files, images, fonts, styles, or Javascript. The animated graphs are drawn via CSS magic.
  • Customizable 🎉
    You can find the template in /Applications/Curio.app/Contents/Resources/Repository/Status Templates/Status Board.html. The template includes placeholder variables which filled out with figure data and the result is then dynamically constructed and rendered with Javascript. You can create your own Status Board.html at ~/Library/Application Support/Curio/Version 11/Repository/Status Templates/ to completely change the look of the report and Curio will use that instead. You can also use the Status Template HTML advanced setting to override the file name (sans html extension) if you want to create several report styles.
Improved RTF Export

The RTF exports — both the old static and the new live — now include more meta info including priority, rating, tags, and resources, if applicable, plus improved fonts and line spacing.

Status Shelf: Ignored Projects

Let's say you have a heavily-used project category that contains dozens of projects, including quite a few that are either on hold or simply no longer used. Perhaps your Classes category contains a Biology 101 project for that class from two years ago. Or maybe a Clients category that contains a project that is on hold until that client renews their contract. You don't want to remove those projects from their respective categories but you really don't want tasks from those projects cluttering up your Status shelf results or live exports. Fortunately, you can now tell Curio to ignore certain projects!

To Ignore a Project

Simply right-click on the project in the projects list at the top of the Status shelf and toggle the Ignore Tasks In Project setting:

The project will then appear like this in the Status shelf projects list:

And its tasks will no longer appear in the Status task results area or in live exports.

Managing Ignored Projects

To help you manage your ignored projects you can use the new filtering options available via the Projects In actions menu to hide your ignored projects or show only the ignored projects. These filtering options work even when All Categorized Projects is chosen so you can quickly see all of your ignored projects if you wish.

Override

Note that you can actually still force Status to show tasks in an ignored project if you wish by opening the project and choosing "Only This Project" from the Tasks In popup.

Focus On

You can now shift focus from the Organizer to the active content view, and between the primary and secondary content views, via new menu items and shortcuts:

Inspector Bar Improvements

It's Scrollable!

If you have a small, laptop screen or if you've resized your Curio window to a small size you can now easily reveal all the controls in the inspector bar simply by swiping horizontally within the inspector bar region.

Dedicated Back / Forward Buttons

The navigator bar now has dedicated buttons so you can navigate back or forward in history. These new buttons are next to the existing previous and next buttons, which step you through items as they are arranged in the Organizer.

(Previously when you held down the Option key Curio would replace the previous/next button with back/forward buttons; however, many customers didn't know about this behavior so now we have dedicated buttons instead.)

Print Enhancements

Print Figure as Text

You can now print a given figure as rich text via the Share menu. This can come in handy if you have a figure that contains a lot of text and you don't want to print it as a graphical figure, where it may not paginate nicely onto pages.

The new Print as Text also pays attention to the checked state of the Include Figure Notes When Copying/Sharing Text and will therefore include any figure notes with the printout.

Improved Figure Notes Support

Speaking of including notes, previously Curio would only include notes for the top-most selected figure. Thus if the mind map figure itself had notes then they were included, but if figures within the mind map had notes then they weren't.

That has been changed so figure notes for those figures within the selected figures will also be copied, exported, or printed as dictated by the Include Figure Notes When Copying/Sharing Text checked state.

Percent Complete From Resources

Changing the percent complete value for a figure's resources now updates the figure's overall percent complete value, if appropriate.

For example, here are a figure's resources:

When the resources are assigned percent complete values then the figure's Determine from assigned resources setting is automatically checked and the resulting percentage is calculated as shown here:

Notice how the 25% and 50% values assigned to the resources are used to automatically determine the figure's 37% percent complete.

If you wish to manually set a percentage for the figure simply uncheck Determine from assigned resources. You can also set the new Figure Percent Complete From Resources advanced setting to no if you never want Curio to automatically use a resource's percentages.

Tweaks

  • Search Shelf Queries Idea Space Titles
    By extraordinarily popular request, the Search shelf will query idea space titles and show them in the search results if they match the text search parameter. Note that other types of Organizer items, like documents and folders, are still not included in the results. For those you should continue to use the Organizer filter, instead.
  • Search Hash Is Tag Prefix
    Normally, as a handy shortcut, if you search for a word with a # (aka hash or pound sign) prefix then it assumes the text is a tag name and searches tags, thus #home is a shortcut for a tag named home. If you don't want the hash prefix to represent a tag then this feature can be disabled with a new advanced setting.
  • Web View Figure Previews
    When you resize a web view figure Curio will now resize the existing preview instead of re-downloading a new preview. It will re-download a new preview automatically the next time you start browsing with that figure.
  • Zoom Increments
    You can now customize the tiny, small, and big increments Curio uses to step through zooms when using a scrollwheel or pinch gesture. When zooming Curio steps through the tiny 0.01% increments below 100%, then small 0.05% increments to just under 200%, then big 0.1% at 200% and beyond. See Help > Curio Advanced Settings for more details.
  • More Notes Window Options
    Added a slew of new advanced settings for the Notes window so you can customize spelling, grammar, correct spelling, replace text, smart quotes, smart links, smart dashes, and show ruler.
  • Clipview Background Color
    If an idea space is smaller than the size of the window you see a neutral background coloring outside the idea space area. You can now customize this coloring if you wish. You must relaunch for it to take effect.
  • List Bullets
    If you have custom bullets for a level then Curio no longer shows the bullet if the list item also has disclosure triangle. This mirrors the default functionality if you simply choose a normal bullet styling.
  • Mind Map Underlines
    Fixed mind maps that use the Underline shape so connection lines connect correctly. It also now supports any pen width for the underline.
  • Speed Improvement
    Editing of text figures in large projects is now much faster, without the stuttering that was caused by an internal "is project modifed" check.

Other Notable Fixes

  • Fixed problem where editing a master stencil didn't broadcast the changes throughout the project.
  • Fixed issues with the Insert > Variable gallery window and container-related variables.
  • Insert > Instant Document gallery window is a bit wider now so you can see complete document names.
  • Fixed issue with badly drawn boundary paths for collapsed mind map nodes on idea space opening.
  • Right-clicking on various URL figure types will now show appropriate choices based on the URL scheme.
  • Using the percent complete mini popover to set 0% complete will now automatically show the checkbox if it's not visible.
  • If a master template is deleted then instances will no longer show the "masters" corner icon.
  • Now refreshing the style inspector when converting from list to mind map (or vice versa).
  • Hitting Tab or Shift-Tab to indent/outdent a list item will no longer resize the width of the list.
  • Fixed issue with export to MindNode file format not working on Sierra.
  • Fixed style shelf so it shows normal figure styles for an image figure displayed in icon mode.
  • Fixed odd clipped text on the single page Spread PDF alert which asks for the number of pages.
  • Fixed issue where a variable replacement should resize a figure and cause a containing collection to re-layout its figures.
  • Now capturing EventKit thrown exceptions if a reminder or event is not found when syncing.
  • Fixed date controls so they will only turn red, to warn if the due date is before the start date, if both the start and due dates are enabled.
  • Modifications to avoid a rare crash involving applicationKeyFlagsChanged.
  • Now skipping Syncthing conflict .curioAsset files.
  • Fixed issue where idea spaces created from personal templates weren't remembering they came from that personal template, therefore making New Idea Space with Current Style not work correctly.
  • Now compiling with Xcode 8 on Sierra which necessitated cleaning up dozens of minor compiler warnings.
  • Compling with Xcode 8 on Sierra also, oddly, fixed the strange Sierra-only issue where Control-Return in a text list within a figure's Notes window didn't insert a carriage return within the same list item.