Curio 10.3 Release Notes

Release Date

April 15, 2016

Requirements

Curio 10 runs on OS X Yosemite (10.10) or OS X El Capitan (10.11).

New Features

More features and fixes for you!

Intuitive Styling for Figures Dropped/Pasted Into Collections

The Old Way

Previously the logic Curio used to determine the appropriate styling for items dropped/pasted into a collection was pretty confusing both for customers and within the code. While in general Curio seemed to adopt the styling of the destination, in some situations it would keep the styling of the dropped/pasted figures as-is. Unfortunately it was never completely clear what it was going to do.

The New Way

This has now been greatly simplified and made much more customizable:

  1. When pasting or dropping items within or into a collection, Curio will default to adopt the styling appropriate for placement in the destination collection.
  2. However, the Shift key can be used to keep the styling instead. That is, simply hold Shift while dropping, or press Command-Shift-V, or hold Shift when choosing Edit > Paste, and Curio will keep the figure's styling as-is instead of adopting the destination's default styling.
Adopt Examples
  • If you move a list or mind map branch — via cut/copy/paste or drag-and-drop — from level 5 to level 1 then it will adopt that level 1 styling to show off its promotion.
  • Moving a figure from a mind map's "orange branch" to the "green branch" will force the node to adopt the green branch styling.
  • Moving a figure from one mind map styled with Chiclets to a different mind map styled with Chalkboard will adopt that destination's styling.
  • Dragging figures from the idea space or bringing in data (files, images, web links) from outside of Curio into a collection will adopt the destination's styling.
Keep Examples Using the Shift Key
  • If you cut a table cell and then hold down Shift while pasting then it will keep its styling, instead of adopting the styling for that destination table cell.
  • Likewise if you drag a branch in a mind map and, before releasing, you hold Shift, then the branch will keep its coloring as-is instead of adopting the default level or branch style.
Overrides

You can override the default adopt vs. keep logic based on (a) whether you're dropping/pasting within the same collection vs. into another collection, (b) the specific collection type such as List, Mind Map, or Table.

For example, you can make it so when dragging items within a table, the items keep their styling, unless Shift is pressed in which case it'll do the opposite and adopt the styling. Please see the new Default Styling for Figures Dropped/Pasted Into Collections advanced settings for more information.

Organizer

The Organizer has a few new features:

  • New Folder From Selection
    Select one or more items in the Organizer and instantly create a new folder containing those items.
  • Copy Idea Space as PNG, JPG, and PDF
    If the Organizer has focus, and a single idea space is selected, new options are available under the Edit > Copy As submenu including PNG, JPG, and PDF so you can quickly grab an image copy of your entire idea space.
  • Quickly Open Organizer Documents
    Double-click on a document dragged into the Organizer to open it with its default application.
  • Refresh Organizer Documents
    If you edit an Organizer document outside of Curio which is currently being displayed in either the primary or secondary splitview then when you return to Curio its display and Organizer thumbnail will be automatically refreshed.

Evernote

Curio's Evernote shelf has several enhancements:

  • Attribution Line
    When you drag a note from the Evernote shelf into Curio, a new attribution line will now be appended to the text so you can get back to the original note in the Evernote Mac client. This addition can be disabled with the Evernote Note URL advanced setting.
  • Source URL
    Similarly, when you drag an image from the Evernote shelf into Curio, you can now right-click on the image on the idea space and choose Reveal In Evernote to reveal the originating note that contained that image in the Evernote Mac client. However, if Evernote gives us a "source URL" indicating which website originally had that image then we'll go to that source URL instead of the Evernote note.
  • Yinxiang Biji (印象笔记, aka Evernote China) Support
    You can now force Curio's Evernote shelf to connect to the Yinxiang Biji server if you have an Evernote account there. Curio should automatically connect to the Yinxiang Biji server — based on (a) IP address located within China and, (b) a Chinese locale setting in System Preferences > Language & Region — but if this isn't working then type the following into Applications > Utilities > Terminal and re-launch Curio:

    defaults write com.zengobi.curio "Evernote Force Host" -string "app.yinxiang.com"

Notes Window

The Notes window has several enhancements:

  • Keyboard Shortcut
    By hugely popular request you can now toggle the notes window visibility via the View menu or using the ⌘\ key shortcut.
  • Background Color
    The Curio Notes window normally has a slight yellow coloring to look like a yellow notepad. You can customize this with the Notes Window Color advanced setting if you wish.
  • Inset
    The Curio Notes window now has a slight 10 pixel margin so text isn't pushed into the extreme top-left corner of the window. You can customize this with the Notes Window Inset advanced setting if you wish.

Sleuth

Sleuth has several enhancements:

  • On Top
    New on top button will make the Sleuth window float above all other application windows.
  • Transparency
    New transparent button will make the Sleuth window transparent so you can see the window behind.
  • Retina Images
    The Sleuth window toolbar buttons are all now Retina-quality images.

Curiota

Curio's Curiota integration has some enhancements:

  • Source URL
    Curiota 2.5 added the ability to record the source URL associated with an image dragged-in from a browser. When you later drag that image into Curio either directly from Curiota or from the Local shelf then Curio will now associate that URL with the created image figure so you can right-click on the image figure and open the URL in the browser.

Sparkle

Curio uses the popular Sparkle framework to handle application updates. We're now using the Sparkle version 1.14.0 which fixes a number of bugs.

Tweaks

  • Duplicate Underlying Asset
    Another very popular request: right-click on a single selected file asset figure on the idea space and you can now choose Duplicate Underlying Asset which will duplicate the figure itself and its underlying asset so it has its own copy of the original asset file. The usual Duplicate operation is also available which simply makes a copy of the figure but points it to the same underlying asset as the original.
  • Smarter Hyperlink Path Resolution
    If you have have hyperlinks to Curio items created via Copy As > Hyperlink then they contain absolute paths to a specific project, for example: curio:///Users/gbrowning/Desktop/test.curio. If a given project cannot be located Curio will now automatically determine if the user specified in the path should simply be replaced with the current user. This feature means links will continue to work if you upgrade your machine and your user path changes from /Users/gbrowning to /Users/georgebrowning or if you want to share projects containing inter-project links with another user, like /Users/gbrowning to /Users/tcook, as long as they place the projects in the same relative folder hierarchy.
  • Line Decorations
    Curio now supports additional Line Decoration advanced settings if you wish to override the default head and tail arrow head decorations.
  • Personal Repository Folder
    Curio now supports a Personal Repository Folder advanced setting so you can sync your tags, styles, idea space templates, and stencils with another machine.
  • Media Controller
    Curio is no longer dynamically adding/removing various entries to the media bar's actions menu, based on the presence of poster frames, etc. Also, you can now jump to the start or end of a movie even if overridden values aren't specified.
  • TIFF
    Support for TIFF as an option during image or HTML export has been dropped, as TIFF is not supported widely on some platforms and browsers.

Robustness Fixes

  • Fixed issue with Curio throwing exceptions when attempting to render very narrow rounded rectangle shapes. We've reverted back to custom code to draw them instead of Apple's native routine as the latter is simply too prone to crash.
  • Say while a project is opened, you switch over to the Finder and move the destination file or folder that an asset figure alias was pointing to. When you switch back to Curio, Curio will now automatically notice the move and refresh its cached resolved path to that aliased file (instead of showing a broken link).
  • Fixed issue where renaming an asset figure, which renames the underlying asset file, temporarily severed the connection to the asset file until you reloaded the project.
  • Fixed an issue where the Local shelf could run away with a seemingly non-stop query, like if you searched for all files of kind "Document" on your entire Mac. There's now a 5,000 count limit at which point Curio will automatically halt the query and show those results.

El Capitan Fixes

  • Found a file saving issue that primarily impacted El Capitan users when saving brand new, untitled projects.
  • Fixed an El Capitan issue with the mini tags and mini percent complete inspectors so that their main text fields have focus when they first appears even if the user has "full keyboard access" enabled via System Preferences > Keyboard > Shortcuts > All Controls. Previously the recently-added close button on those inspectors had focus and the user had to manually shift focus to the text field to enter a tag or percent complete value.
  • Fixed an El Capitan issue where a gap could appear under the toolbar if the toolbar is in "icons only " mode.
  • Fixed odd issue where on El Capitan the scribble brush routines may not work (due to a mouse drag event coming in with an odd pressure of 0?!).

Import/Export Fixes

  • PDF Mirror now exports Organizer aliases.
  • Fixed issue with Copy As > PDF so that Preview will see the PDF data on the clipboard (it requires the old NSPDFPboardType type on the clipboard so now we put that and the newer NSPasteboardTypePDF on the clipboard).
  • Curio can now accept single contact items dragged over from the Contacts app. This works around a bug (?) Contacts has with promised files not getting created.
  • During HTML export, Curio now appends ?nocache=timestamp to the idea space image references to prevent browsing caching when re-posted.
  • During HTML export, Curio now expands the clickable region for a figure to include any adornments so clicking a jump adornment now works.

Meta Fixes

  • Fixed issue where you couldn't delete bundled tag sets.
  • The +1 week button on the figure date inspectors previously added 7 work days, which would skip over non-workdays such as weekends, instead of simply adding 1 week. This has been fixed.

Pinboard Fixes

  • You can now expand/collapse a titled pinboard even if autoresize is disabled in its inspector.
  • If you drag all line end points so they snap to figures located within a collection, such as a pinboard, Curio will now automatically make it so the collection owns the line instead of the idea space. That way you can collapse the collection and the line will disappear.

Other Notable Fixes

  • Curio's embedded Spotlight and Quick Look plugins work, once again, on Yosemite systems instead of requiring El Capitan.
  • Updated mail AppleScript so Curio supports Microsoft Outlook 2016, while still supporting the old Outlook.
  • Fixed several issues with figure style previews so they are rendered correctly in the style gallery.
  • Fixed the Geometry inspector alignment and distribution buttons so they work correctly in the inspector popup.
  • Fixed Status shelf issue in the tasks results list where percentage complete checkmarks for unopened projects (that is, projects that aren't the currently opened project) weren't being displayed at all. Checkmarks for unopened projects now display correctly as grayed-out items, since you can't change their states, while the tasks for the opened project is displayed with normal colored images since you can right-click and set a new percent complete value.
  • Fixed some layout issues with the figure tooltip so it can't get too huge.
  • Fixed issue where editing some borderless text figures may result in a missing frame edge.
  • Replaced Curio's preferences icons with sharper, Retina-quality images.