Curio 6.1 Release Notes

Release Date

October 13, 2009

Requirements

Curio runs on OS X Leopard (10.5) or OS X Snow Leopard (10.6) on PowerPC or Intel machines.

New Features

Curio 6.1 adds some cool new features based on the feedback we received after launching Curio 6.

Index Cards

Curio 6.1 adds a new type of figure collection: Index Cards! Thanks to tremendous feedback in the Zengobi Forums we're thrilled to introduce index cards to our fans.

An index card is a fairly simple collection: it consists of a title text figure and a body figure. The body figure is, by default, a text figure as well but you can drag an image or other type of asset figure in there to replace its contents.

To create an index card, use the new Index Card toolbar button, or choose Insert > Index Card (Command-Control-I). Type in a title, and type in some body text.

An index card is resizable but not scrollable. This means any text that grows past its bounds will be automatically clipped when it's not being edited.

You can customize the look of your index card using the normal Figure and Text inspectors. In particular, while the spacing of the body's lines is based on the body text's font size, you may want to extend this a bit using the Line Height control in the Text inspector. You can also adjust the display and coloring of the title and body lines using the new Index Card inspector found under the Display tab.

Like our other collections (lists, mind maps, and tables), index cards are completely style-able so you can click the Style popup in the Inspector Bar to choose a different style. You can also change its attributes and save the resulting index card style via the Style inspector. And you can share the styles you create with your friends or send it to us for posting on the Curio Community Center. If you want a different default to appear when you click the Index Card toolbar button then use the Format > Set as Default Style for Index Card Figure menu item.

You can easily export your index cards by selecting one or more cards and choosing either Edit > Copy As > Text or File > Export Selected Figures As > Text.

Figure Decorations

You can now quickly and easily associate an image decoration with any selected figures. How? Just drag-and-drop an image into the new decoration image well in the Flags section of the Meta Inspector. Or you can double-click the image well to show the standard Apple image panel to take quick iSight picture.

This decoration image is displayed alongside your other flags and adornments, and are sized with them via the Adornment Options size slider. Note, however, unlike custom flags you create in the Preferences > Flags window, these decorations aren't searchable via our Search shelf, but they're perfect for quickly pairing a decorative image with a figure.

Exporting or Copying as Text

Curio's copying and exporting as text as gotten a whole lot smarter. First, you can now select one or more figures on your idea space. Then, Curio will nicely concatenate together all the text representations for the selected figures in a logical way. This means a nice text outline representation for lists, mind maps, and index cards, and tab-separated text representation for tables.

The result is one output file, or clipboard string when copying, that contains the contents of all selected figures for easy importing into another application.

Zipped Distribution Instead of Disk Image

Curio is now distributed as a zipped file instead of a DMG. Why? For several reasons including a much smaller download and customers will be less likely to accidentally run Curio from the mounted disk image. More discussions can be found here.

However, because of this we now have to display the Software License Agreement (aka SLA / End User License Agreement / EULA) when Curio is run for the first time. Previously the Mac's built-in DMG disk mounter displayed the SLA but since we're no longer a DMG we can't do that. We'll record that you have seen the SLA in Curio's preferences so you won't see it again.

Other Features

  • All Curio color pickers will now highlight the currently selected color. I can hear the applause now....
  • Curio's text inspector now supports discontinuous text selections (which is done by holding down the Command key and drag-selecting multiple regions of text) when applying attribute changes like font, color, bold, italics, superscript, etc.
  • Copying or exporting as png or tiff now keeps the background transparent.
  • If you copy/paste cells within a table or between tables, Curio will now keep the styling of that cell when placed at its new position instead of resetting it to the default body/header/footer cell styling.

Notable Fixes

  • Fixed the hang which could occur if you close/quit and click Yes to save the last changes. Yippee! This bug has finally been found and fixed!
  • Fixed an issue when inserting columns or rows which could result in at malformed table.
  • Now smarter about automatically disassociating a figure with its style if you change font or paragraph attributes.
  • Checking off checkmarked items in Curio will now correctly remove the associated task in iCal if iCal syncing is enabled.
  • The File > Project Properties > Resources panel now handles contact images that appear via double-clicking the image well and choosing an image from Apple's standard image chooser.
  • Fixed lists so if you have a list collection on an idea space with a notepaper grid and you use the From Grid button on the Text Inspector, the list items will now line up with the notepaper horizontal grid lines.
  • URL asset figures are now always have blue underlined text. That way it is obvious they are URLs.
  • Fixed some problems with font attributes propagating between figures in collections when they shouldn't be.
  • Fixed problems when trying to use the Search shelf to search for one or more flags. However, if you have any saved searches you will need to recreate them and save them again (sorry).
  • Double-clicking an Address Book contact in the Scrapbook, Library, or idea space will now more reliably find and select the item in the Address Book application.
  • Fixed a problem where asset figures in a collection (list, mind map, etc) displayed as icons with titles would sometimes revert back to older font styles instead of using the specified collection style.
  • Curio is no longer leaving discarded Untitled projects in the Trash.
  • The superscript and subscript buttons in the Text inspector now work correctly if there is no active text selection.
  • If a scribble region is selected, and no figures are also selected, then using the arrows keys now correctly repositions the selected scribble.