Curio 5.4 Release Notes

Release Date

January 5, 2009

Requirements

Curio runs on OS X Leopard (10.5). OS X Tiger (10.4) is no longer supported!

New Features

Evernote Integration

Curio now includes an Evernote shelf so you can easily search and drag items collected from your Evernote account.

Searching

All search terms are optional but can include one or more of the following: search text, notebook, tag, kind, and last modified date. Search text is wildcarded at the end (so searching for the word ever will find evernote, for example) unless the phrase is quoted.

Using

Simply drag an item from the Evernote shelf to your idea space to embed it within your project. You can also double-click the note to open it with the Finder or press the Spacebar to activate Quick Look to quickly see a note's contents while in the Evernote shelf.

Tags

Your Evernote tags and notebook names are automatically synchronized with two special Curio global tag sets: "Evernote Tags" and "Evernote Notebooks". These new tag sets can be found in the Curio Preferences > Tags window. Then, when a note is dragged from the Evernote shelf into the idea space, the Evernote tags and containing notebook names are mapped their Curio tag counterparts. This tag mapping feature allows you to use the Curio Inspector Bar or Search shelf to quickly find figures on your idea spaces collected via Evernote.

Character Recognition Data

The Evernote service will automatically scan any images for handwritten or typed words. When an image note is dragged into Curio, that character recognition information is embedded as meta data in the resulting Curio asset figure. This feature allows you to use Curio╩╝s Search shelf to find those images on your idea spaces using the same search phrases.

Limitations

The Evernote shelf is currently unidirectional so you cannot make changes to any of your Evernote notes from within Curio. Please use one of their free clients to make any changes.

iCal Sync Improvements

iCal synchronization with changes going from Curio to iCal will now only happen when the project is saved instead of asynchronously as you make changes within Curio. This will resolve the problems where customers were finding duplicate, mismatched, or invalid items in iCal which could happen if you created, modified, or removed figures in Curio but then closed the project without saving.

The iCal sync will also happen when the project is first loaded so the project will be immediately updated with any changes coming in from iCal. And Curio will still retrieve changes from iCal into Curio if you make changes in iCal while the project is open.

Curio now forces a save of the project when modifying any iCal sync options within the File > Project Properties window. This will insure that the created iCal entries are correctly synced with the Curio project's current figures.

We also fixed a problem where empty text figures with checkboxes (perhaps created for use as a template item in a list) were being added into iCal. Those blank items are now ignored.

Sleuth Tweaks

Lots of little tweaks to the context menu that appears when you right-click within Sleuth:

  • You can now right-click on an image and choose Send to Active Idea Space or Send to Scrapbook (previously you had to drag-select the image first for this to work).
  • The Download Linked File and Download Image menu items send the resulting file to the Mac's standard Downloads folder instead of into /tmp.
  • The Open Link in New Window menu item opens the link in a nice big window instead of a squished window.

New Shortcuts to Indent or Outdent Collection Items

Curio now supports additional ways to indent or outdent an item in a mind map or list:

  • OmniOutliner-style shortcuts: Command-Control-Right Arrow / Command-Control-Left Arrow
  • MS Word-style shortcuts: Control-Shift-Right Arrow / Control-Shift-Left Arrow

Notable Fixes

  • Fixed problem where double-clicking an idea space template would temporarily remove it from the Idea Space Templates shelf.
  • Huge speed improvements added to the mind mapping and list code with smarter buffering of pending changes.
  • The mouse cursor automatically becomes visible during presentation mode if moved to another screen.
  • Fixed issue where if you have an asset figure selected in an idea space and then start typing a name for that idea space in the Organizer then typing a space accidently triggered a QuickLook for the asset figure instead.
  • Fixed odd issue where rotated lines couldn't be moved close to the top/left edge of the idea space.
  • Fixed problems using arrow keys and moving the selection up and down over collapsed nodes.
  • Fixed problems when dragging a list item on top of a collapsed list item.
  • Fixed dragging mind map items with lots of text so they are autowrapped as appropriate when dropped at a new mind map location.
  • Fixed bug when copy/pasting a list where the bullets or numbers weren't being drawn.
  • Fixed problem when trying to use cursor keys and moving up and down in a multi-line mind map entry.
  • Fixed problem that the root of the mind map might forget its style when adding new grandchildren nodes.
  • Fixed bug where if the Organizer had several rows selected but then you chose one of those idea spaces from the Navigator toolbar popup button then nothing would happen.
  • Better support for undo/redo of convert list to/from mind map.
  • Better multi-touch support thanks to a custom undo grouping to bundle a series of gestures into a single undo group.
  • The Inspector Bar will now remember if it was visible or hidden between project re-opens.
  • Fixed undoing the Uncollect action.
  • Fixed oddity where turning on the start date for a figure would automatically assign it a due date as well.