Curio 4.1 Release Notes

Release Date

November 13, 2007

Requirements

Curio 4 runs on OS X Tiger (10.4) on Intel or PowerPC Macs.

New Features

List Titles!

By extremely popular request, lists now have titles!

List titles are enabled by default for all newly created lists. You can also selectively add or remove titles from one or more lists using the List Inspector.

You can customize the style of the title figure, and use the Inspector to set that as the figure style for that level (technically that's level 0). That means the title style attributes will be included with any saved list style you create.

Screen Snapshots

Curio now makes it even easier to grab screen snapshots from other applications.

Simply click on the Snapshot toolbar button to take a picture, or press and hold the toolbar button to see the Snapshot preferences. You can choose to take a snapshot of a window or any rectangular region. And the result can either be automatically placed in your current idea space, or added to your Snippets library, or simply stored in your Clipboard.

Leopard QuickLook Plugin for OS X Leopard (10.5)

Curio now includes a QuickLook plugin for instant CoverFlow and QuickLook previews. To assist with this, all idea space previews generated within Curio are now 512x512 images instead of 256x256. As you work on your idea spaces, all of your previews will be updated to the new larger size.

Sharing Curio Items

You can now easily share custom styles, dossiers, and Sleuth sites you create in Curio with friends and with the whole world via the new Curio Community Center. Here's what you can now easily import, export, and share:

  • Mind Map Styles
  • List Styles
  • Idea Space Notepaper / Grid Styles
  • Apperance UI Themes
  • Dossier Templates [ProK12]
  • Sleuth Sites [ProK12]
Visit the Curio Community Center to see what people are sharing!

New Bundled Saved Searches

Curio now includes a bunch of default saved searches:

  • All 5 star items
  • All high priority items
  • All images
  • Everything modified this past week
  • Everything modified today
  • To Do - all 'someday' items
  • To Do - all 'waiting on' items
  • To Do - any overdue items
  • To Do - any upcoming items
  • To Do - upcoming 'active' items
  • To Do - upcoming 'next' items
And, of course, you can still create and save your own custom searches.

Other Features

  • A new note adornment automatically displays next to any figures which have an associated note. Notes are set for a figure using the Meta inspector. Hover the mouse over the adornment to read the note.
  • New handy buttons on the Tags and Resources inspector panels to bring up their associated Project Properties windows for item editing.
  • New Edit > Export As menu item that allows you to export selected figures as PDF, TIFF, JPG, or PNG.
  • Pressing Option-` (backtick) will hide both the Organizer and the Shelf.

Notable Fixes

  • Autosave is now much smarter and, if enabled, will autosave your project at the optimal time (roughly 30 seconds after the last change). It will also no longer autosave when you close the project but will wait for you to confirm that last save. That way you can avoid saving any inadvertent (but perhaps non-undoable) changes simply by quickly closing the project window and not saving those last changes.
  • Fixed weirdly formatted dates and times when using the Insert > Date/Time command.
  • Fixed bug where the Snippets library was being shown in the Library popup menu.
  • Copying a TIFF or PDF version of a selected figure is now much more precise instead of having a larger-than-necessary empty border around it.
  • Smarter auto-selection of a figure in a list or mind map after the deletion of one or more items.
  • Fix bug when using Insert > File to insert an asset figure when the root of a mind map was selected.
  • Change to the asset library system so we always keep a backup of your asset library just in case you need to do an emergency restore of its previously saved state.
  • Optimized the logic used to determine if an empty text figure should be auto-removed.
  • Smarter use of Quick Render mode based on the complexity of the figures within the visible screen.
  • The publish to .Mac window is no longer clipped for some customers.
  • Changed the Organizer to make it harder for users to accidentally delete selected idea spaces. Also includes a note that the action is not undoable.
  • Fixed bug when trying to undo/redo an indention/outdention.
  • Fixed a prefix redraw bug when copy/pasting or duplicating lists.
  • Fixed bugs related to exporting a single idea space as an image and as HTML.
  • Fixed problem where Curio would occasionally crash when retrieving favicons for WebURLs if the project is closed before the icons were retrieved.