Curio 4.0 Release Notes

Release Date

June 26, 2007

Requirements

Curio 4 runs on OS X Tiger (10.4) on Intel or PowerPC Macs.
OS X Panther (10.3) is no longer supported!

Editions

Unless otherwise specified any features listed are in all editions of Curio. Features only available in certain editions will be listed with color-coded words like this [ProK12Home]. So, for example, [ProK12], means that the feature is available only in the Professional and K-12 editions of Curio.

New File Format

If you open a Curio project file created with earlier versions of Curio, you will be asked if it can be updated for Curio 4. This is required to take advantage of Curio 4's new features and capabilities. Once converted to Curio 4 format, you cannot open it with an older version of Curio, so make a backup first if necessary.

New Features

We primarily concentrated on adding project management and brainstorming features to Curio 4. But, don't worry, we added a ton of cool, fun features in there as well!

Mind Mapping

Mind mapping has always been our most requested feature, and something we've been aching to add since Day 1, so we are extremely happy to finally include mind map functionality within Curio 4.

Mind maps within Curio can contain any type of figure including images, file assets, movies, songs, and of course text.

And those figures can include any associated meta elements such as flags, checkboxes, tags, and assigned resources and due dates.

And, of course, those figures can be stylized with all the usual options including shape, border color/thickness/dash pattern, fills and gradients, and various text attributes.

On an idea space, a mind map is just another type of collection figure, just like a list. So, on an idea space, you can have a mind map sitting next to other mind maps, and lists, and perhaps some other files, notes, and sketches. You aren't restricted in any way.

You can easily drag items into and out of a mind map. Hold down the Option key before dragging an item out of a mind map to make a copy of the item.

You can also drag items within a mind map to rearrange their ordering. Helpful guides appear as you hover over a target figure so you know if you'll be adding a new previous or next sibling, or creating a child.

We've included several bundled styles of mind maps which you can find in the Inspector. You can also quickly create your own styles and save them for later use. You can set a default style for all added figures, as well as an override style for each level of the mind map.

Definitely check out the section below on New Return Key Handling to see how you can add siblings and children to your mind map via the keyboard.

The layout for the mind map is entirely controlled by Curio, although you can of rearrange the ordering of the items via drag-and-drop as described above.

Now, create a mind map and let the brainstorming begin!

Modern Interface

When you first launch Curio 4, you'll notice that the user interface has been updated and modernized. See below to read more about the biggest changes — Shelf and Appearance Preferences.

Curio Shelf

One of the biggest changes you'll see in Curio is the new Curio Shelf: a fixed-width pane on the right side of your window. The shelf contains and manages multiple shelf modules which can be selected via the buttons on the top of the shelf pane.

We're extremely excited about the Shelf and see it as a platform to extend Curio with lots of cool features in the future!

With Curio 4, we include several shelf modules which are discussed in detail below.

Since the shelf is now taking up screen real estate, the Organizer can automatically hide and show itself if you move the mouse over to the left side of your window. This autohide feature is enabled by default on smaller screens. You can toggle the setting via the View popup button on the toolbar.

Inspector Shelf Module

The old Inspector palette window has been replaced with the new Inspector shelf module.

The new shelf layout gives the Inspector more room to spread out, allowing you to see several inspector panes simultaneously. And the individual inspector panes are collapsible and expandable as needed to maximize what you see on your screen.

Search Shelf Module

Like the old Inspector window, the old Search Bar was quite constraining. With the new Search shelf module, we have room for many more options plus all search criteria are now grouped into logical collapsible sections.

New Search Criteria

New search criteria options include tons of additional flags, tag set support, priority setting, task start and due dates, and task resources.

Saved Searches

And, that's not all, you can now save and re-use your search criteria! For example, with a single click you can find all incomplete high-priority items due in the next two weeks. Curio comes bundled with several useful saved searches for easy one-click instant searching.

Snippets Shelf Module & Snippets Service

Curio now includes an awesome Snippets shelf module and associated service. The service is automatically installed the first time you launch Curio.

Perhaps you are web surfing, reading an email, or checking out some documents, and you discover something you wanted to later file into a Curio project.

Simply select that file, URL, text, Mail message, or image and choose Services > Add to Curio Snippets from the application's menu (or just press Command-Shift-X) to have that selection instantly added to your Curio Snippets repository.

Note that Curio does not have to be running for snippet collection to work.

Later, from within Curio, you can choose the new Snippets shelf module and see all your collected snippets.

Drag-and-drop those items from Snippets into an idea space to move the items out of Snippets. Alternatively, you can hold down the Option key while dragging to leave a copy in Snippets. Or, press Delete to delete the items out of Snippets.

Snippet grabbing works in all applications — including Curio and Curio's built-in Sleuth Internet search assistant.

Snippets makes it easy to collect notes and ideas whenever inspiration strikes!

Print to Curio Snippets

But Curio's Snippets doesn't stop there. From any application, you can now print directly to Snippets via an installed PDF Service.

After choosing File > Print, click the PDF popup button and select the Save PDF to Curio Snippets option. The document will be printed and automatically added as a snippet.

Flashlight Shelf Module

Apple's Spotlight is cool, but Curio 4 includes a wonderful addition to make it even better: the new Flashlight Shelf module.

Now, within Curio, if you need a file to include in your project, you can find it instantly with Flashlight. Switch to the Flashlight Shelf module and you can construct your search criteria which can include any of the following:

  • Title
    This is case-insensitive, and you can type any portion of the file's title.
  • Kind
    We include many popular kinds such as TextEdit, Word, and Photoshop files.
  • Last modified date
    Choose from Today, Since Yesterday, This Week, Within Last Two Weeks, This Month, Within Last Two Months.
  • Whether to include file contents
    Click on this checkbox if you want to search the contents for the text specified above.

Then, click the Search button to begin the search. Curio won't start searching as you are typing or filling out fields. You tell Curio when to begin.

Your results are listed below the seach criteria, with previews displayed if appropriate.

You can then easily drag-and-drop the files from the results list directly into your Curio project either as aliases to the files or, if Option is pressed, as embedded copies of the files.

Think of Flashlight as Sleuth for your local hard disk. Find the files you need quickly and easily.

Sticky Line Enhancements

Previously, Curio allowed sticking line endpoints to a figure. By default, the line would stick towards the center of the figure, unless the Command key was held down then it would stick to a specific location on the figure.

We call this feature "sticky lines" since the line endpoint remains stuck to the figure, even if it is moved.

Now, Curio expands its sticky line support by allowing users to stick to a logical connection point on the figure, which are generally the vertices and the edge centers. Each type of shape has its own logical connection points, meaning that the triangle has different connection points than the rounded rectangle, for example.

Sticking to the Closest Connection Point

Drag a line endpoint into a target figure, once just inside the figure you will see a purple glow indicating the connection points around the figure. By default, the endpoint will stick to the connection point closest to the opposite line endpoint. As you resize, move, or rotate the figure or move around the opposite line endpoint, Curio will automatically find the new closest connection point and snap to it.

Sticking to a Specific Connection Point

However, you can also move the mouse over a specific connection point to stick that point in particular.

Sticking towards a Figure Center

If you drag the mouse a bit further into the figure, the figure will glow green letting you know that you are sticking towards the center of the figure.

Sticking to a Position

And, at any time, if you hold the Command key down, you will see the figure glow orange so you can snap to a specific point anywhere on the figure. A little orange target appears so you know what position it will stick to.

Disable Sticking

Holding down the Option key will disable sticky lines, allowing you to place the endpoint anywhere and not have it follow the figure. You can also disable sticky lines by default through Curio's Preferences, in which case the Option key can be held to turn it back on temporarily.

Resources

You can associate resources with your project via the Project Properties dialog. Resources can be manually entered or drag-and-dropped from the Address Book or vCard file, which will automatically grab the contact's name, email, and picture.

Assigning Resources

After associating resources with your project, you can then assign one or more resources to figures along with a percent complete value for each resource. Curio will show the individual images of up to five resources as figure adornments, if you have more than five resources then a single representative icon is used instead.

Priorities

You can assign a priority to a figure: a value from 1 (Urgent) to 5 (Very Low). The priority is displayed as a color-coded figure adornment.

Percent Complete

You can assign a percent complete to a figure. This can be entered manually or automatically rolled-up from assigned Resources or child figures. The percent complete value is displayed as a figure adornment which shows it pie chart-style rounded down to 0%, 25%, 50%, 75%, or 100% complete.

Task Settings in a Collection

You can assign a start date, due date, duration, and percent complete to a figure. Here are some important notes about how they are handled:

  1. If a figure has children, then the percent complete will be computed via its children. Else, if any resources have assigned percent complete values then they will be used in the computation. Else, the user can specify a percent complete value directly.
  2. If a figure's start date is specified as "as early as possible" and the figure has a parent with a start date, then the start date will come from the parent figure, else "today" is used. If no options are set, the user can specify a start date directly.
  3. If a figure has children, then the due date will be set to the greatest due date of its children. Else, if the due date can be specified as "determine from start date and duration" then it wil be computed for the user using those values (note that end dates will automatically skip weekends if durations are specified in days). Otherwise, a user-specified value is used.
  4. If a figure has children, then the duration will be computed from the figure's start and due dates which were determined as described above. This is a great way to see, at a glance, how long a project will take. The units will automatically be in days, thus will be adjusted to not include weekend days.

Tags and Tag Sets

You can now create global collections of tags which are accessible from any project via the new Tags Preferences. Curio includes several bundled tag sets including Getting Things Done (GTD) ® tags.

Tags Context Menu

By popular request, you can now set tags via the figure context menu.

Associating Tags with Idea Spaces

Also, you can now associate tags with idea spaces via the Inspector. When searching, if you have tags associated with an idea space, then all figures in that idea space automatically adopt those tags as well.

New Adornment Features

  • Curio now includes a ton of new, super-fantastic looking flags thanks to Pixel Art Association!
  • Adornments can now be placed anywhere around the selected figures using the Inspector (except in lists where they have to be on the left).
  • The max adornment size has been increased to 128 pixels.
  • A new 'money' flag automatically switches between a dollar, a UK pound, a Japanese yen, and a European euro symbol based on the user's locale (the default is a dollar).
  • If an action, such as a jump action, has been associated with a figure then an adornment can be drawn to make it obvious that an action has been set. Clicking the action adornment will perform the action.
  • The checkmark flag will be automatically displayed as a percent complete pie-chart icon if appropriate.

List Level Styles

You can click on a figure within a list and use the List Inspector to set that figure's style as the style for all figures in the entire list, or just on that level.

As items are added, or indented/outdented, they will automatically adopt that level's style.

This allows you to set up some interesting styles such as big blue fonts for "level 1" entries and smaller black fonts with checkboxes for "level 2" entries.

The prefix itself will automatically adopt the figure's style and size if set, thus matching the figure's font size and attributes. This fuctionality can be turned off if you wish.

Lastly, you can also optionally turn off prefixes altogether for a particular level.

List Rendering Cleanup

The list rendering code has been changed so that the lists now look much, much nicer. Here is a list of refinements:

  • Indentions of child figures are now lined up to be precisely under the parent list item, instead of using a hardcoded indention amount.
  • The hardcoded 20 pixel inner margin is now a user-changeable margin via the figure Inspector.
  • The spacing between lines is tighter (5 pixels instead of 10 pixels).
  • The distance between the enumerator prefix and the list item itself is now tighter.
  • If the prefix is smaller than the figure then it is centered vertically next to the figure, instead of awkwardly sitting in the upper corner.

New Return Key Handling

With Curio, we support free-standing text figures, plus figures in lists, plus figures in mind maps. All of those situations have specifial needs when the Return key is pressed, so we've constructed the following rules:

  • Return
    If an item is selected, then it is put into edit mode. Otherwise, if its not selected, you must be editing it so...
    • If editing a free-standing text figure, then a carriage return is simply entered.
    • If editing a free-standing asset figure, then the editing session is ended since it can only have one line of text.
    • If editing a mind map item or childless list item then a next sibling is created.
    • If editing a list item with children then a first child is inserted.
  • Option-Return
    If editing an item, this will enter a carriage return (except on one-line asset figures of course).
  • Shift-Return
    If editing a list or mind map item, this will create a previous sibling.
  • Control-Return
    If editing a list or mind map item, this will split the text at the current cursor position and move the split part to a next sibling, or first child in the case of a list item which has children.
  • Command-Return
    A new text figure will be created either below a free-standing item, or as a next sibling for mind map items or childless list items, or a first child is inserted for a list item that has children.
  • Command-Shift-Return
    A new text figure will be created either above a free-standing item, or as a previous sibling for list and mind map items.
  • Command-Option-Return
    A new text figure will be created either as a new first child of the selected list item or a new last child of the selected mind map item.

New Import and Export Features

  • Import OPML Files
    Drag-and-drop OPML files (with .opml extensions) directly into Curio, or via the new Insert > File menu, and those files can optionally be automatically converted into Curio lists.
  • Edit > Paste As > List
    If the contents of the clipboard contain a carriage-return-delimited and tab-or-space-indented list (copied from OmniOutliner for example), then it can be pasted and auto-converted into a Curio list. The dashes and other decorations OmniOutliner adds by default will be automatically stripped.
  • Edit > Export As OPML
    Export a selected list in OPML format.

Links to Mail Messages

You can now copy mail messages from Apple's Mail application into Curio. Simply select one or more messages in Mail, choose Edit > Copy, then go into Curio and choose Edit > Paste. (Unfortunately, Mail does not allow you to drag-and-drop messages outside of Mail, so you have to use Copy/Paste.)

The mail messages are automatically embedded into Curio, which is a great way to back up important project-related messages if the originals are deleted or lost due to mailbox corruption.

Double-click a message in Curio to cause the message to appear in a new Mail window for easy viewing, forwarding, or replying. And you can search specifically for Mail messages using the Search shelf module's Asset Types popup.

You can turn off this new way of handling Mail messages via Preferences. When disabled, pasted Mail messages will simply appear as text figures.

Permissions Inspector

You can now mark an idea space or a figure on an idea space as private via the new Permissions Inspector. That means it will not be printed, presented, exported, or published to .Mac.

The one exception is if you mail the Curio project itself via File > Mail As > Curio Project, then those items will still be included.

Support for Bigger Idea Spaces

We no longer impose an idea space size limitation of 5000x5000. In its place, we show you how much memory Curio will need if you activate the pen and brush tools (which are quite memory intensive). But you can now make your idea spaces as big as you want!

New Figure Shapes

A couple of new additions to our available figure shapes: jaggy rectangle and a simple underline.

Copy Style / Paste Style

Under the Format menu you'll find new Copy Style / Paste Style menu items which makes it easy to copy a figure's style and, you guessed it, paste it "onto" one or more selected figures.

This works for text figures, asset figures, images, lists, lines, etc.

Speaking of which: you can now set a default style for lines via the Format > Set Default Style for Line Figure. So, if you don't like shadows enabled by default or would rather have a certain dash pattern, then set it and Curio will now remember it!

Presentation Mode Transitions [ProK12]

You can now take advantage of native, Core Image Filter, and Quartz Composer transitions when using presentation mode via the new Transition preference panel. You can even create your own custom Quartz Composer compositions and place them in your ~/Application Support/Curio/Transitions directory and they'll be available within Curio.

Customizable Inspector Colors

The border, fill, gradient, text color, text highlight, and scribble color matrices are all user-customizable! Simply double-click a color cell to change the color using the standard color picker.

Super Easy Idea Space Hyperlinks

It's now even easier to make it so double-clicking an item will jump to a particular idea space. Just select 'Choose Idea Space' from the Actions inspector and pick the idea space. No more copy/pasting jump target info!

And, as mentioned above, an action adornment can be drawn to make it obvious that an action has been set for a figure. Clicking the action adornment will perform the action.

Scribble Improvements

The scribble inspector has new 'color is pressure-sensitive' and 'size is pressure-sensitive' options. And, the most recent dozen colors used in the session are displayed so you can easily switch between recently-used colors.

When using a brush or eraser you now see a circular or rectangular mouse cursor, respectively, sized to the size of the brush or erase to show you where your drawing or erasing will occur.

Scribbles <-> Image Figures

You can also now convert selected scribble regions to an image figure and vice versa via the Edit menu. This allows you to convert scribbles into image figures so they can be grouped with other figures or added to lists, mind maps, etc.

New Text Attribute - Strikethrough

You can now click the strikethrough button in the Text inspector to strikethrough selected text (like this).

Appearance Preference

You can now choose the look-and-feel of Curio via our new Appearance Preference panel.

Aqua vs. Unified

The first change you can make is Aqua (like TextEdit or old Curio) versus the new Unified look (like iTunes). After making a change, you will need to relaunch Curio for it to take effect.

Custom Color Themes

Then you can get down and dirty by customizing many of the colors used to draw Curio's user interface. These can be changed on the fly and several bundled appearance themes are included with Curio. You can even share themes with your friends and simply drag-and-drop them into the Appearance panel for the new theme to take effect.

Other Notable Features

  • New Organizer preview size: a new smaller Small is the new Small, the old Small is now Medium. Large still exists as well.
  • Hold the Option button while spinning the scroll wheel on your mouse to quickly zoom in and out of your document.
  • New Insert > File... menu to multi-select several files and import them as figures in a single step.
  • New Insert > Date and Time menu items to quickly insert date, time, or both. This can be used anywhere you can type such as while naming an idea space, or inserting text into a list.
  • Curio now remembers the scroll position and zoom setting for each idea space, and restores them when the project is re-loaded.
  • The default font size for all figure types is 12 point. And the default style for lines is now unshadowed. You can set these figure styles to any style you want via the Format > Set as Default Style for Figure menu item.

Notable Fixes

  • Grabbing huge web pages as web archives now works reliably.
  • Text figures now correctly resize their bounds when entering multibyte international characters which require multiple keystrokes to complete (aka "marked text").
  • We are no longer deleting Subversion ".svn" or CVS "CVS" directories found within our asset library.
  • Fixed bug with our Spotlight plugin not finding text found in text tables within Curio text figures.
  • Fixed drawing bug where flags and checkboxes sometimes appeared on top of other images.
  • Fixed drag-and-drop bug when dropping items into the margin area of a list collection.
  • You can no longer choose Grab Web Archives if the project is read-only, or the URL to grab points to a PDF. This function has always been tweaked to exit gracefully if it encounters a web site that it is unable to archive.
  • If a text figure is currectly selected then a newly created text item will only inherit the current item's text attributes if those attributes are used throughout the entire text figure.
  • You can now have web link Actions with foreign characters in them.
  • Fixed problem where grouping a figure would result in a "ghost" asset instance getting created internally.
  • If you press Backspace while editing an empty list figure then Curio will now delete that empty item and move to the end of the previous item.
  • You can now drag-and-drop items within a list which is grouped with other figures.
  • File > Create Archive should now be quite a bit faster and more reliable when archiving directly to a remotely mounted machine.
  • If Shift is held down while resizing a line, thus snapping to 0, 45, 90, etc. angles, then we don't try to snap to figures that you move over.
  • When lists were deleted, any asset figures within the list were not getting removed from the project if they should have been and they were no longer used anywhere.
  • More robust saving of the asset library, so if something happens during the save, we can recover very easily. If a crash occurs during the save, we can still recover your data.
  • Clicking in the Library is now less likely to trigger the editing of the file name.
  • Entering into mini mode with the window initially on a secondary screen now works as expected.
  • Partially opaque line arrowheads are now drawn correctly.
  • Rewrote routines which handle the creation of temporary files and directories to hopefully avoid the exceedingly rare case of sketchpad and image files appearing on the root directory.