Curio 3.2 Release Notes

Release Date

June 28, 2006

Requirements

Curio 3 runs on OS X Panther (10.3) or OS X Tiger (10.4) on PowerPC Macs, OS X Tiger (10.4) on Intel Macs.

Editions

Unless otherwise specified any features listed are in all editions of Curio. Features only available in certain editions will be listed with color-coded words like this [ProK12HomeBasic]. So, for example, [ProK12], means that the feature is available only in the Professional and K-12 editions of Curio.

New Features

iPhoto Exporting [ProK12Home]

You can now export your idea spaces to an iPhoto album for easy photocasting to colleagues or syncing to iPods for presentations on-the-go! Requires iLife '06.

New Idea Space Toolbar Popup

The new idea space toolbar button is now a popup allowing you to choose a specific notepaper style for your new page! You can even create a new idea space which uses the same style as the current idea space.

Support for Tiger's Integrated Text Lists and Tables

OS X Tiger (10.4) added new List Support and Table Support features to the built-in text editor control. This control is used in Apple's TextEdit application and in the text figure within Curio. Curio 3.2 now fully supports these new features in our text figures via the new Format > Text submenu.

Create Archive

New File > Create Archive feature allows you to easily create copies of your current project with, optionally, all assets embedded and the resulting project file zipped and compressed.

More Idea Space Backgrounds

We have bundled in several new idea space backgrounds (thanks Oliver!) plus we now let you easily choose images found in the standard Desktop Pictures and its subfolders.

Speed Improvements

  • Selecting and creating new idea spaces is now a half second faster.
  • Faster project loading if lots of assets are in your project.
  • Much faster when switching from another app back to Curio if you have lots of assets in your project.
  • Now resolving aliases by not trying to either automatically mount a volume or by bringing up a UI asking the user to mount the volume. This means opening projects while disconnected from the network is instantaneous instead of waiting for each mount to timeout (which was 60 seconds per asset!).

Samples Gallery

New Help > What Can I Do With Curio menu item shows a gallery of cool things you can do with Curio. Be sure to check it out!

Other Features

  • New toolbar buttons for Send to Front and Bring to Back.
  • New 'Share when copied' checkbox in the Extras Inspector allows you to create text figures that are linked together so changing the text in one will be reflected in all others.
  • Select All only selects highlighted (non-dimmed) items so, if a search is active, only those found items matching the search criteria will get selected.
  • New preference which lets you change the Organizer's behavior so the Enter key edits the current idea space's title instead of creating a new idea space. Holding the Option key down reverses this logic.
  • Robust saving of asset library contents as the integrity of the file is double-checked after the save and restored with a backup automatically if necessary.
  • Replaced previous OmniOutliner instant document template file with OmniOutliner 3 format file.
  • If you select a list figure, then modify the font via the Format > Show Fonts panel or via many of the Text Inspector's controls, the font used for the list enumerator will also be modified along with the figures contained within the list.
  • If you set a rating for a figure which was unrated then ratings will now automatically become visible.

Notable Fixes

  • Fixed selecting items in a list so clicking an item will first select it, clicking again will enter it into edit mode.
  • Fixed bug so that flags and other adornments are drawn at the same opacity as the associated figure.
  • Fixed problem with Address Book entries with accent markes dragged into Curio suddenly disappearing from within Curio when the project is re-opened.
  • Fixed crash which could occur when grabbing a Web Archive of a page that has a QuickTime movie running on it (like many of Apple's pages).
  • The Action inspector shows the correct path to the aliased file instead of always saying (Embedded Asset).
  • Fixed slight grid snapping problem when dragging items around that have adornments like flags drawn within the shape boundaries.
  • Better handling of escape, tab, and shift-key tabs when editing an idea space title in the Organizer.
  • Option-clicking on a project in Project Center which was already opened in another window, now brings that window to focus.