Overview
Introducing Curio
What is Curio?
Curio provides an innovative, freeform, notebook-like environment with all the integrated tools you need to take notes, brainstorm
ideas, collect research, and organize your tasks and documents.
Curio's intuitive interface and tools encourage effective note gathering, research, and creative exploration. Its freeform, open
environment encourages you to more easily visualize, associate, and recall information.
All of this within a single application so you can be more productive, more creative, and focus on getting things done.

About This Manual
Because of its open and freeform environment, Curio can be utilized for a variety of tasks. This manual will guide you through the
many features of our application so you can decide how to use them best to accomplish your goals.

Editions
Core ➠ Standard ➠ Pro
Curio Editions
Curio is available in three different product editions to match your feature requirements.

Curio Core
We start with Curio Core. As its name implies, it contains all of Curio’s core functionality including its amazing idea spaces; text,
image, multimedia, and file figures; numerous collections such as lists and mind maps; and much more. Core is a great way to get
started with the world of Curio. Note that Core is only available at our website and not at the Mac App Store.

Curio Standard
Next step up is Curio Standard. Dive into more features to really help you take your productivity to the next level with reusable
stencils and templates; brushes & pens for quick sketching; more advanced PDF features; Calendar and Reminder syncing;
Evernote integration; and our Sleuth internet assistant.

Curio Professional
For our power-users, we proudly offer Curio Professional. Truly a premiere product with figure layers; cross-references; master
styles, stencils, and templates; consolidated task tracking with the Status shelf; presentation mode; regular expression support in
the Search shelf; project password and advanced settings; plus much more.

Edition Tags
Throughout this document we will make it clear if a feature is only available in the Standard or Professional editions either using
floating figures like those shown below, or inline text notations [Standard] [Pro], or we’ll color the idea space itself in the Organizer
with a red or blue color label.

Assistance
Learn more about Curio
What’s New
The release notes for major Curio versions, such as Curio 9, Curio 10, etc., include fantastic in-depth explanations and screenshots
of all the new features, so it’s definitely worth reading. Simply choose the Help > What’s New in Curio menu item.

Release Notes
Minor versions, such as Curio 10.1 or Curio 10.1.2, will include another menu item to quickly access their detailed release notes.
Choose the Help > Curio Release Notes menu item and make sure to step backwards in history when viewing the release notes to
see what else has been changed recently.

Keyboard Shortcuts
Choose the Help > Curio Keyboard Shortcuts menu item to see all of Curio’s shortcuts.

Advanced Settings
For the adventurous power-user, choose the Help > Curio Advanced Settings menu item to see all of Curio’s advanced options
when you want to fine tune your environment.

Zengobi’s Blog
Choose the Help > Zengobi Blog menu item to read the latest news from Zengobi.

Zengobi’s Forums
Choose the Help > Zengobi Forums to chat and share with other Curio customers.

Zengobi is Social
Choose the Help > Zengobi on Facebook or Help > Zengobi on Twitter menu item to join us on those popular social networks.

Contacting Zengobi
Using the options available at the end of the Help menu you can send Zengobi feedback or ask us a question. We’ll write back as
quickly as possible!
You may also want to visit www.zengobi.com/support for more information.

Installation
Let’s get started!
Downloading
Curio is available from the Zengobi website. Clicking the appropriate download link will cause your browser to download the Curio
application to its Downloads folder.

Installing
Drag the Curio application from your browser’s Downloads folder to your Mac’s Applications folder to install. Optionally, to create a
shortcut on your Dock, drag Curio from your Applications folder to the Dock to create the shortcut.

Updating Curio
Curio uses the very popular Sparkle framework to periodically determine if updates are available. If an update is available, a
window will appear showing the release notes and giving you an opportunity to have Curio download and install the update with just
a single click.
Curio will only check for updates available for your current major version. For instance, Curio 10 will find Curio 10.1 and 10.1.2, etc.
But moving up to new major versions, say from Curio 10 to Curio 11, requires the purchase of an upgrade license so Sparkle
doesn’t show those as available updates. We’ll send you an email when new major versions appear. We’re always hard at work on
more productivity features!

Trials and Licenses
Taking a test drive of Curio
Trial Period
Curio initially launches as a 2-week, fully functioning trial of Curio Professional showing off all of its amazing features, with no
limitations. At the end of the trial you can request a trial extension if you haven't already.

License Key
At any time you can purchase a license key from our online store which you can then enter into Curio’s License dialog, via the Curio
> License menu item.
After entering your license key, Curio’s features and functionality may change as appropriate for the entered key. For example if you
purchase a Curio Standard license then Professional features will be removed from the interface. Likewise, entering a Curio Core
license will remove Standard and Professional functionality. As a note, you can always purchase a crossgrade license if you wish to
upgrade your Curio edition.

Reader Mode
If you decide not to purchase a license, you can continue using the product as Curio Reader for read-only browsing, printing,
presenting, and exporting of Curio project files. The toolbar and interface will change to reflect this simplified functionality. At any
time you can still purchase and enter a Professional, Standard, or Core license key and the interface will refresh itself to enable the
appropriate functionality.

First Launch
Let the games begin!
Welcome to Curio
When you first launch Curio, this “Welcome to Curio” project will automatically open and display the contents of the Getting Started
section. This is an excellent tour of Curio’s major features. We wholeheartedly encourage you to step through the slides to learn the
basics of Curio in a fun, interactive manner. Use the Help > Open Welcome to Curio menu item to re-open this project at any time.

Documentation
The Curio product documentation is actually within the “Welcome to Curio” project as well, within the Documentation section.
Keeping the documentation with the product ensures that it remains up-to-date and can directly reference actual Curio interface
elements instead of relying on embedded screenshots.Use the Help > Curio Documentation menu item to access this
documentation directly.

A Living Document
The “Welcome to Curio” project takes full advantage of Curio’s features so it’s completely unlike the usual static product
documentation you generally encounter.
For instance, many of the idea spaces in the Getting Started will ask you to interact with the figures on the idea space and settings
in the inspector to completely understand what’s going on and how a particular feature works.
Likewise the Documentation includes Organizer items which are actually live web views to video tutorials located on Zengobi’s
website. This way we can continuously add new content to those pages and you’ll see the results immediately in this project.

Curiota
Curio’s amazingly talented little buddy
Extend Curio’s Capabilities
Curiota is a free companion app that opens up even more productivity with Curio. Curiota runs silently in the background, consumes
very little memory, and has a minimal user interface: you just see a simple icon up in the menu bar. Click on that icon to create
quick notes, or drag files and links to the icon to quickly add files.
The most important thing is that Curiota uses an open system for storing notes and files. There’s no proprietary file format or
database that could be corrupted. It’s your data and you will be always able to access it, even outside of Curiota, for decades to
come.
Curiota also supports print services (so you can “print” to Curiota), works as an macOS Share extension, is accessible via your
Services menu, and is easily scriptable. All of the submitted notes and files are accessible and searchable using Curio’s Local
library shelf, discussed below. More information about Curiota can be found at www.zengobi.com/curiota.

Backups
A quick note about backups
Project Backups
We have thousands of Curio customers around the world who use Curio for their important notebooks: work projects, personal
projects, client designs, doctoral dissertations, class notes, and much, much more. We couldn’t be more thrilled and proud at what
you’re able to create and achieve with Curio.
With such important data please be sure to create project backups. Accidents happen, laptops are dropped or stolen, lightning can
strike, bugs exist, and disk drives do die. Backups are easy to do, take only 5 minutes to implement, and are quite inexpensive for
the peace of mind they provide. Please check out one or more of the options below.
Curio Automatic Backups [Standard] [Pro]
Curio Standard and Professional customers should take advantage of its built-in support for automatic backups. After setup,
backups are stored in the destination folder of your choice.
Curio PDF Mirroring [Standard] [Pro]
Curio Standard and Professional support a feature called PDF Mirror which will create an automatic, cross-platform PDF
representation of your entire project and store it in a specified destination folder. This special publishing feature can even optionally
include all embedded and aliased assets.
Time Machine
For years macOS has supported a wonderfully integrated backup solution called Time Machine. Every hour all your important
documents and applications are backed up to an external drive which is useful if your primary drive dies.
Whole Disk Backups
You can also implement a whole-disk backup plan with either Carbon Copy Cloner or SuperDuper. Either application can create a
bootable backup disk on an external drive—basically an exact, up-to-date copy of your internal drive.
Cloud Backups
A remote, cloud backup service is inexpensive and easy to configure, for example BackBlaze.

Syncing
Some tips for syncing your projects
Syncing Tips
A Curio project file is actually saved as an macOS package file. On the Mac this appears as a single file, however it's a actually a
special kind of folder containing files (such as project assets) and other folders. Package files are natively supported by macOS and
is a technique used by many other applications as well. In the Finder, right-click on a Curio project file and choose Show Package
Contents to see what's inside.
By far the most popular sync service used by Curio customers seems to be Dropbox. Thus the tips presented here will primarily be
for Dropbox users, however, these guidelines apply to any of the 3rd party sync services such as Google Drive, Microsoft OneDrive,
Box Sync, etc.
Issues with Syncing
In the past, when customers have had errors with Curio and a sync service, it was generally due to a incomplete sync where only a
portion of the files within the project package were completely downloaded or uploaded to the sync service. If this occurs then Curio
may not be able to reconstruct the parent-child ownership that’s key to constructing and rendering your Curio project notebook.
The guidelines presented here should be followed to minimize the chance of a project corruption due to partial sync.

Dropbox Guidelines
1. Make sure you're running the latest Dropbox Mac client! It should update itself automatically but it doesn’t hurt to check. To find our what version you have simply
hover your mouse over the Dropbox menu icon and the version number should appear in a tooltip. You can grab the latest Dropbox client at https://
www.dropbox.com/install. Their latest release notes are listed at https://www.dropbox.com/release_notes.
2. Never, ever open the same Curio project on more than one computer at a time! Curio can detect if you’re storing to the standard ~/Dropbox location and
automatically use a lock file to make sure only one person (or computer) at a time has the project open. If you use another sync service then you may want to
enable the Lock File feature in the project inspector, if you have Curio Standard or Professional.
3. Completely quit Curio on one machine before opening it on another! This will guarantee that all file changes have been committed to disk.
4. Make sure Dropbox has an opportunity to completely sync the changes up to the cloud! If you made lots of changes, added large assets, or have a huge project
then this can take a while. The Dropbox icon in the menu bar will show an incredibly tiny animating graphic when it is syncing changes to the cloud. Wait for it to
finish animating before putting your machine to sleep or shutting it down.
5. Do not open the project before your Dropbox folder is fully synced! When you start your machine or wake it from sleep make sure Dropbox is done syncing the
changes back down from the cloud. Once again, just watch their little animating menu icon before launching Curio and opening your projects.

Dropbox
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iCloud Drive Guidelines
1. Never, ever open the same Curio project on more than one computer at a time! Curio can detect if you’re storing to the standard ~/iCloud Drive location and
automatically use a lock file to make sure only one person (or computer) at a time has the project open. However, if you have enabled iCloud’s “Desktop &
Documents Folders” syncing, and you own Curio Standard or Professional, then you may want to enable the Lock File feature in the project inspector.
2. Completely quit Curio on one machine before opening it on another! This will guarantee that all file changes have been committed to disk.
3. Make sure iCloud has an opportunity to completely sync the changes up to the cloud! If you made lots of changes, added large assets, or have a huge project
then this can take a while. You can open a Finder window and see if the iCloud Drive sidebar item has an animating graphic which fills as a sync occurs.
4. Do not open the project before your iCloud Drive folder is fully synced! When you start your machine or wake it from sleep make sure iCloud Drive is done
syncing the changes back down from the cloud. Once again, just watch their little animating icon next to the iCloud Drive sidebar item before launching Curio and
opening your projects.
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iCloud Drive Status Bar (if Finder’s View > Show Status Bar is enabled)
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Projects
One document that contains everything
What is a Project?
Looking to the real-world for a metaphor, a Curio project can be a simple notebook or a stuffed binder, depending on the complexity
of your project.
For example, you may create a relatively simple project for a family vacation trip containing itineraries, flight and hotel details, maps,
photos, web clippings, reviews, and notes.
Or, you may have a complex client design project with a project dossier and multiple sections each containing hundreds of idea
spaces organized within dozens of folders.
Your project is represented in the Finder as a package file. A package file is a special type of file in macOS which can contain any
number of files within it. It’s technically a folder or subdirectory but the Mac shows it as a normal file.
This means that your Curio project file can be stored anywhere on your hard disk or network server. The usual spot is your personal
Documents folder. However, you may have a user folder on a shared network server. Or you may want to store your project in a
automatically synced folder such as a Dropbox folder (see www.dropbox.com) so all changes to the project are instantly synced
between multiple Macs (if so we have some important tips regarding Dropbox in Appendix B).
A real-world project is your class, your thesis, your ad
campaign, your next product release, your lab
experiment, or your next sermon. Your Curio project is
the same thing on your Mac. It contains everything
related to your project including notes, sketches, files,
web links, images, brainstormings, ..., everything!

With a Curio project you keep all that stuff in one easyto-manage file in the Finder. Everything is stored within
that file package. This means backups are a piece of
cake and you don’t have to hunt all of your hard disk
looking for all the related items.

Working with Projects
Creating a Curio project
Create a New Curio Project with an Initial Idea Space
1. Choose File > New, or hold Shift and click the Projects toolbar button.
2. Choose a personal or bundled idea space style or template to use as your initial idea space.
3. Click the Choose button.

Create a New Curio Project with a Blank Initial Idea Space
! Choose File > New Blank Project, or choose File > New and choose the blank bundled idea space style or click the Blank button.

Create a New Curio Project Which Is Absolutely Empty
1. Choose File > New.
2. Hold the Option key and the Blank button will change to Empty. Click the Empty button.

Create a New Curio Project Based on a Project Template
1. Choose File > New From Project Template, or hold Shift-Option and click the Projects toolbar button. This New Project From Template Gallery is described in
detail below.
2. Choose a personal or bundled project template. Or choose the Blank template to create a project with a blank initial idea space.
3. Click the Choose button. Alternatively you can click the Blank Project button to create a project with a blank initial idea space.

Create a New Curio Project with Master Idea Space Templates
1. Choose File > New.
2. Select a template tag name and click the Use Tagged Set as Masters button.
3. A new project will be created where all of the idea spaces in the tagged set will be added to the project as master idea space templates.

Open an Existing Curio Project
1. Click the Projects button and choose a previous project. When choosing a project from the Projects popup menu it will be opened in place of the current project,
thus acting as a fast project switcher. Hold Option when choosing a project to open it in a separate tab within the current project window.
2. Choose File > Open menu to see the standard Open dialog. The project will be opened into a new tab or window depending on your System Preferences > Dock
> “Prefer tabs when opening projects” setting.
3. Choose File > Open Recent to instantly choose a recently-opened project. The project will be opened into a new tab or window depending on your System
Preferences > Dock > “Prefer tabs when opening projects” setting.
4. Choose File > Open From Gallery or click the Projects toolbar button to see Curio’s Open Project Gallery, which is explained in detail below. The project will be
opened into a new tab or window depending on your System Preferences > Dock > “Prefer tabs when opening projects” setting.

Save a Curio Project
! Your projects will save themselves automatically using the macOS native autosave feature, however you can also choose File > Save at any time to save your
project immediately.

Save a Curio Project as a Project Template
! Choose File > Save As Project Template.

Delete a Curio Project
! Within the Finder, drag the Curio project from wherever you saved it to the Trash.

Archive a Curio Project
1. Choose the File > Create Archive menu item.
2. This will create a copy of your current project with all aliased assets converted into embedded assets, suitable for backup or storage.

Project Gallery
Manage your Curio projects
The Projects Toolbar Button
Clicking the Projects toolbar button shows a quick pick list of all your projects organized into categories. You also have options to
bring up the open project gallery, where you can create and organize your project categories, or create a new project with a blank
idea space, an initial idea space from the idea space gallery, or from a project template. For Curio Professional users, the Status
shelf will organize your projects with the same categories.

The Open Project Gallery
After clicking the Projects toolbar button the Open Project Gallery window appears showing your existing projects. Your projects can
be categorized in one or more custom categories located along the left side of the window. The projects within the selected
category are displayed on the right side.
Note the Smart Categories which will automatically list projects based on various criteria. For example, the Recently Opened smart
category lists all projects you’ve opened recently which are also listed in the File > Open Recent menu.
Notice you can magically turn the Open Project Gallery into the New Project Gallery by clicking the button on the bottom left corner
of the window.
The Open Project Gallery window displays useful information about your project under its title. By default it will display the date it
was last modified but, if status information about the project exists, it will tell you if a project has a task which is due soon.

Project Category Finder Tags
Any projects that you associate with categories will automatically have associated Finder tags as well. For instance, if you associate
a project with the categories Active and Personal, then Curio will create “Curio Active” and “Curio Personal” Finder tags and
associate them with the projects as well.
With category Finder tags, you can now search for categories of projects in the Finder, outside of Curio. Just enter the search tag,
such as Curio Active in a Finder window search field and you'll find all projects associated with that category. Click the Save button
in the Finder window to save the search and even add it to your sidebar for one-click access to those projects. See the "Finding
Tagged Files" section on Apple's site for more information on using Finder tags.

Open Project Gallery
Opening your previously created projects
Show the Open Project Gallery Window
1. Choose the File > Open From Gallery menu, or...
2. Hold Option and click the Projects button on the toolbar.

Open a Project
! Double-click the project in the gallery window, or select it and click Open.

See a Quick View of a Project
! Select the project in the gallery window then press spacebar.

Open a Project Not Listed in the Gallery
! Click the Open Other button to show the normal macOS open dialog.

Create a New Project Category
! Right-click in the category list and choose Add Category.

Rename a Project Category
! Double-click the category in the list and rename it. All affected projects will be associated with the renamed category Finder tag as well.

Delete a Project Category
! Select a category in the list and press the Delete key. This will remove the category but not delete the projects within that category. The corresponding category
Finder tag will be dissociated with those projects as well.

Associate a Project with a Project Category
1. Select the category then drag-and-drop a file from the Finder to the right side of the window, or...
2. Drag a project listed in another category (such as the Recently Opened category) and drop it on top of the target category on the left side of the window, or...
3. Right-click on the project as shown on the right side of the window and choose the target category from the popup menu that appears.

Disassociate a Project from a Project Category
1. Right-click on the project itself and choose the category that the project should be removed from, or...
2. Select the project and press Delete on your keyboard. You will then be asked if it should be simply disassociated from the current category or if it should be sent
to your computer’s Trash.

Change How Projects Are Sorted in Gallery
! Right-click on the background of the right side of the window and choose a sort order from any of the following: status, title, last modified date, or date created.

See the Category Finder Tags Associated with a Project
! Right-click on the the project in the gallery and choose Display Category Finder Tags. From the alert that appears you can also remove or reapply those tags.

Add Missing Project Categories to the Gallery
! Right-click in the category list and choose Add Categories Via Category Finder Tags. Curio will use Spotlight to find all Curio projects, checking each for any
associated category Finder tags, and then re-add any missing categories and re-associate the projects associated with each category. This is useful if you
installed Curio on a brand new machine and didn't bring the Application Support folder from your old machine.

New Project Gallery
Working with the File > New gallery window
Copying Styles and Templates
! You can drag-and-drop styles and templates to your Personal repository or, if using Curio Professional, the Master repository.

Organizing Idea Space Templates with Tags
1. Right-click in the Personal repository area on the Personal > Templates item and choose Add Tag.
2. Enter a collection tag name. For example, you might organize your idea space templates into “Favorites”, “Work”, and “School”.

New Project from Template
Create and reuse project templates
Create a New Project from a Project Template
1. Choose the File > New From Project Template menu, or...
2. Click the Projects button on the toolbar then click the Switch To New Project Gallery button, or...
3. Option-Shift-Click the Projects button on the toolbar.

Create a New, Blank Project
1. Choose the File > New Blank Project menu, or...
2. From the New Project Gallery window click the Blank Project button.

See a Quick View of a Project Template
! Select the project template in the gallery window then press spacebar.

Create a Personal Template Folder
! Right-click in the template list and choose Add Template Folder. Curio will create an actual folder on your hard disk with the given name within the ~/Library/
Application Support/Curio/Version XX/Repository/Project Templates directory. This is where your templates will be stored on disk.

Rename a Personal Template Folder
! Double-click the template folder in the list and rename it.

Delete a Personal Template Folder
! Select the template folder in the list and press the Delete key. After confirming the template folder and any templates it contains will be sent to the Trash.

Copy a Template to a Personal Template Folder
! Drag a template from another template folder and drop it on the target folder.

Remove a Template to a Personal Template Folder
! Select a template then press the Delete key to send the template to the Trash.

Save the Currently Opened Project as a New Project Template
! Choose File > Save As Project Template.

Project Image
Give your project a custom image
To view the project inspector panel, click on the background of the current idea space
then either (a) click the little briefcase icon in the inspector bar or (b) click the Inspector
toolbar button to open the inspector shelf then look at the Project tab.

Project Image
Set an optional image for your project by copying an image and pasting into the provided
image well. This image will be used as the project thumbnail in the Finder, the Open
Project Gallery window, and the Status shelf.
Next to the image well is a helpful “image assistants” popup menu. Here you will find
quick access to popular textures and sample images via Google Image Search which you
can drag and drop into the project image. Then you can use the assistance popup menu
to apply a binder or journal appearance to the image.
Alternatively, the assistants popup also includes a number of template icons you can use
for your project image. A color control sits alongside the assistants popup which you can
use to tint the template to any color you wish.

Calendar Sync
Sync with Calendar & Reminders
To view the project inspector panel, click on the background of the current idea space
then either (a) click the little briefcase icon in the inspector bar or (b) click the Inspector
toolbar button to open the inspector shelf then look at the Project tab.

Calendar Sync
If you’re running Curio Standard or Professional you can sync your Curio tasks with the
Calendar and Reminders apps, allowing you to manage your tasks even on iOS devices.

Enable Sync
Enable the synchronization of project tasks with your Calendar and Reminders apps by
clicking the on/off checkbox.

Choose the Calendar and Reminder List
In the Events popup choose a calendar to sync your event tasks to. By default, an event
task is a figure in Curio that has a start date and, optionally, a due date. You need to
create the calendar via Calendar app’s New Calendar menu. You can create and use an
iCloud-based calendar if you wish.
In the To Dos popup choose a reminder list to sync your to-do tasks to. By default, a to-do
task is a figure in Curio that only has a due date or simply a checkboxed item with no
dates at all. You need to create the calendar via Reminder app’s New Reminder List
menu. You can create and use an iCloud-based list if you wish.
As you noticed the Calendars and Reminders apps require type-specific calendars. This
means one calendar for events and one for to-do’s (aka reminders). You cannot use the
same calendar for both types of data.
The event and to-do calendars you create must have different names. In other words they
can’t both be called “Curio”. Instead perhaps “Curio” for your events and “Curio Tasks”
for your reminders. You can either share a calendar list and reminder list between all your
projects or create and use a separate list for each of your projects, it’s up to you.

Alerts
For calendar event alerts, check the “Enable event alert before start date” checkbox and
select when the alarm should go off.
For reminder task alerts, check the “Enable to-do alert before due date” checkbox and
select when the alarm should go off.

Advanced Options
Click the actions button to see a popup menu appear with various options.
Reset Events and To Dos — this will remove then re-create all events and to-do items
associated with the project in the selected calendar and reminder lists.
Remove Events and To Dos — this will remove all events and to-do items associated with
the project in the selected calendar and reminder lists.
Figures with start dates map into — choosing Calendar Events or Reminders will
determine what these types of figures will turn into. Calendar Events is the default.
Else figures with only due dates map into — choosing Calendar Events or Reminders will
determine what these types of figures will turn into. Reminders is the default.
Sync unchecked figures with no start or due dates — this will create reminder tasks for
checked items that have no start or due dates.
Prefix each synced item with project name — this will prefix the name of your project in
front of the title of each synced item. Thus the task “Finish UI design” in the “Cool App”
project will become “Cool App: Finish UI design” in Calendar/Reminders. This is a useful
feature if you share a common calendar/reminder lists with all your Curio projects.

Additional Notes
If the Curio figure has a start and/or due date but is checked — that is, completed — then
it is not synchronized to Calendar.
When syncing if an event begins and ends at 12:00 midnight then it is considered an allday event, otherwise the specific times are used when creating the event.
All times are considered floating times, therefore they are time zone independent. This
means that a task ending at 4:00 PM will end at that time regardless of where you were
when you created the task or where you are currently.

When Does the Sync Occur?
Changes made within Curio will be synchronized only when the project is saved or
autosaved.
However, when you first open a project, it will immediately synchronize to retrieve any
changes made from within Calendar/Reminders. And while the project is open, if changes
continue to be made in Calendar/Reminders, Curio will immediately reflect those changes
within the project.
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A mirror of your project in PDF form
PDF Mirror
Curio can publish a mirror or replica of your project in PDF form to a specified location.
This is very different than a normal PDF export in that each idea space is converted into an unscaled PDF image, with no page
breaks or fit-to-page scaling, then all the resulting images are merged into a single PDF document. In addition, this published PDF
can include clickable file links as any embedded or aliased assets can optionally be exported into a folder hierarchy alongside the
PDF document.
This publishing event can occur either manually via a File > Update PDF Mirror command, or automatically every time an updated
project is closed.
This can be useful for several reasons including for backup purposes or, if published to a Dropbox or similar synced folder, a
method for you to access your project while on your iPad, iPhone, or another computer.
Please note that the resulting PDF mirror is not password protected even if your project is password protected.

PDF Outline
The PDF generated by PDF Mirror includes embedded PDF document outline for easy navigation using PDF viewers that support
that standard PDF feature. In Apple's Preview app, for example, choose View > Table of Contents to see the PDF's hierarchical
document outline.
The PDF outline is part of the PDF standard so most standards-following PDF readers should support it. Zengobi has tested it with
the macOS Preview and Adobe Reader apps as well as the following iOS apps: Dropbox, Readdle's PDF Export and PDF Viewer,
Good.iWare's GoodReader, Branchfire's iAnnotate PDF, and LiquidText.

Clickable Links
When you export idea spaces via Export as PDF or PDF Mirror, the resulting PDF will have clickable links for:
! Weblink figures, like a URL dropped from a browser into an idea space.
! Figures with URL actions.
! Weblinks and figure URL actions that are inner project hyperlinks (ex: curio://?ideaspace=062...).
! Idea space links to other inner project idea spaces.
! Jump anchors to inner project locations.
! Figures with jump actions to inner project locations.
! Figures with first, last, previous, or next idea space jump directions.
! For PDF Mirror, you have the option of exporting assets as well, such as images and documents, so those figures would have
links to their corresponding exported asset files. See the note below for compatibility details.

Limitations
Curio doesn't generate PDF links for a selection of text within a text figure that has a link attribute. This is a tricky one to solve as (a)
Curio would have to scan all text figures when exporting to find any NSLinkAttribute attributes which could be very slow, (b) the
resulting selection may consist of wrapped lines of text complicating the generation of potential PDF annotation link(s).

Supported PDF Viewers
The generated PDF's have been tested using a number of PDF viewers on both macOS and iOS. Here are some notes regarding
their ability to handle various PDF features.

Text
In general, all PDF viewers, regardless of platform, should display the PDF itself just fine, with text being rendered beautifully. Text
should be searchable and selectable allowing you to quickly find and access information anywhere in your project.

Figure Notes
All PDF viewers should also provide some ability to view figure note annotations usually via a hover, click, or tap of the figure's note
adornment. In Preview, for example, you can hover over a note adornment or bring up the Inspector window (via Tools > Show
Inspector) then click the Annotations tab to see all note annotations.

Web Links
Likewise, all PDF viewers should allow you to launch any web links associated with Curio web link figures or web link actions.

Clickable Asset Links
Producing clickable assets is a bit tricky. The file links within the PDF are relative links, which means they are relative to the current
location of the PDF document itself and should continue to work even if the document is moved to another location/platform either
manually or via sync.
Here are some notes about specific apps both on macOS and iOS:
Clickable Asset Links - Mac Apps
PDF Expert from Readdle works very well with file links.
Acrobat and Acrobat Reader on the Mac both support relative file links. We recommend the following modify file link paths
preferences: URL encode. Alternatively, if you wish to also be compatible with iOS readers which don't support URL encoding yet
you may use these instead: Strip all potentially unsafe characters, Convert characters to ASCII only, Convert spaces to
underscores. For images they will open in a browser window, otherwise Acrobat simply reveals the file in a Finder window.
Presumably for security purposes it doesn’t automatically launch the file.
Apple Preview on the Mac doesn't appear to support file links of any kind, perhaps for security reasons.
Skim on the Mac doesn't appear to support relative file links.
Clickable Asset Links - iOS Apps
Important Note about Synced PDF Export Folders on iOS
If your designated PDF Mirror export folder is synced via a cloud service like Dropbox, iCloud Drive, Box, etc, then iOS PDF viewing
apps are limited by Apple’s API so they can’t dynamically fetch a clicked-on file link, presumably for security reasons. The only way
file links will work is if all the files in local storage — not simply downloaded but On My iPad/iPhone. To do this, use the iOS Files
app to select your PDF Mirror cloud-based sync folder and tap Copy to copy it to On My iPad/iPhone which downloads all the files
and places them within local storage. You can then use the Files app to go to On My iPad and open the PDF file there and relative
file links will work.
PSPDFKit is the leading PDF framework used by many iOS apps for PDF viewing including their own class-leading PDF Viewer
app, as well as Dropbox, Box, Evernote, and much more. Their framework works very well with file links.
PDF Expert from Readdle works very well with file links.
GoodReader works relatively well with file links. Unfortunately, however, they only support opening other PDF files or plain text files.
Additionally, they require a file:// scheme for these relative links which, technically, should only be used for absolute paths. We have
been in contact with their developers so this may change. We recommend the following modify file link paths preferences: Strip all
potentially unsafe characters, Convert characters to ASCII only, Convert spaces to underscores, Prefix asset links with file://
scheme.
iAnnotate PDF doesn't appear to support relative file links.

PDF Mirroring Options
Control mirroring options
To view the project inspector panel, click on the background of the current idea space
then either (a) click the little briefcase icon in the inspector bar or (b) click the Inspector
toolbar button to open the inspector shelf then look at the Project tab.

PDF Mirror
If you’re running Curio Standard or Professional you can have Curio create and manage a
PDF mirror of your project, which can be stored at any location including a synced
Dropbox folder for easy access via your iOS devices.

Enable PDF Mirror
Enable the PDF mirror feature by clicking the on/off checkbox.

Location
Specify the folder location for the resulting PDF by clicking the Choose button. This
location is where Curio will create a single PDF for each section in your project, if you
have multiple sections enabled.
The form of the file names for the resulting PDF's is ProjectName-SectionName.pdf file,
where the section name is only appended if necessary. Curio will create a manifest file
alongside each PDF file so it can track what’s inside each PDF.

Options
Enable the exporting of embedded and aliased assets into a folder alongside the
resulting PDF. Curio will also modify the PDF so that clicking or tapping on the asset figure
on the PDF will launch and view the exported asset. However, this is highly dependent
upon the abilities of the PDF viewer you use so see below for additional notes.
Normally all idea spaces are mirrored but you can direct Curio to obey the idea space's
exporting privacy restriction if you wish so that some idea spaces are not exported when
mirroring. This restriction can be enabled for individual idea spaces via the Options panel
of the Info inspector.
Enable automatic publishing when a changed project is closed (or Curio is quit).
You can click the Publish Now button to instantly publish your project or use the File >
Update PDF Mirror menu item to publish.

Advanced Options
Click the actions button to see a popup menu appear with various options. Note that if
you change any preferences you will need to manually remove any previously published
files. We don't do this automatically for safety reasons.
Compress resulting PDF — by default Curio will perform a compression on the resulting
PDF, although not as extreme as Apple's Reduce File Size PDF compressor. You can also
create your own compressor using the ColorSync application and an advanced
preference.
Keep prior PDF as backup — Curio can optionally make a copy of a preceding day's PDF
as a backup which is useful if you make a catastrophic change and need to recapture
that information.
Modify file link paths — the file paths for published asset files can be modified to strip out
characters that may interfere with certain PDF viewers, as discussed below.
URL encode — this is a standard technique for encoding spaces, international
characters, and other symbols so they turn into numerical codes preceded with a percent
sign. Some PDF viewers (like Acrobat) work with URL encoded file path names but others
don’t. Ideally all would support this and we wouldn’t need the other character conversions
at all.
Strip all potentially unsafe characters — remove any characters from the file name that
might not be cross platform such as slashes.
Convert characters to ASCII only — changes foreign characters to their simple ASCII
equivalents such as á to a. File links with simple characters don’t need to be escaped
(such as percent-encoded) which provides greater compatibility with various PDF
viewers.
Convert spaces to underscores — converts a spacebar character into the _ underscore
character.
Remove spaces — simple removes any spaces from the file name.
Prefix asset links with file:// scheme — technically Curio creates relative links paths, which
means paths to the asset files are relative to the location of the PDF file itself. Relative
paths shouldn’t need a scheme but some PDF viewers require it.
When exporting assets — you can optionally include aliased assets (enabled by default)
and image assets (disabled by default). Image assets are normally not exported since the
images themselves are visible within the PDF itself so probably will not need the actual
standalone image files exported.
IMPORTANT NOTE: For safety, you will need to manually remove older files and folders
from the PDF mirror location if you change preferences or export options.
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Advanced Project Options
For power users only!
To view the project inspector panel, click on the background of the current idea space
then either (a) click the little briefcase icon in the inspector bar or (b) click the Inspector
toolbar button to open the inspector shelf then look at the Project tab.

Project Password
Set a password for your project so that it cannot be opened unless the password is reentered. The contents of your idea spaces and many ancillary files within the project
package are then encrypted and decrypted using the AES-128 algorithm.
Note when a project is encrypted you cannot see the status of the project in the Projects
Gallery or Status shelf until the project is opened, or use Quick Look in the Finder to see a
preview or thumbnail, or use Spotlight to search for items in the project.
Encrypting and decrypting a large project will take a few moments to complete, do not
force quit Curio when this is occurring!
IMPORTANT NOTE
Any embedded assets, including documents, images, and audio and video recordings,
will not be encrypted. If you need to encrypt everything in your Curio project — including
all embedded assets — we'd recommend using either a volume protected with FileVault,
or an encrypted disk image that you use to store your Curio projects (perhaps one disk
image per client, for example). Alternatively, you can use an application such as Knox
which can automate the creation and sizing of encrypted disk images.
WARNING
If you forget your password, your data will be lost. Zengobi cannot decrypt the project.

Project Backups
Override the global backup settings specified in Curio’s preferences so this project has
unique backup properties. For instance, you might specify that an especially large project
is backed up every 3 days.

Asset Library Location
You can tell Curio to use an external asset library folder so it can be indexed by Spotlight.
Normally embedded assets are stored within a file folder located within the project file
package, which you can see if you right-click on the project file in the Finder and choose
Show Package Contents. However, Spotlight cannot index within package files therefore
you can’t use Spotlight to search their contents.
You can choose whether Curio should store your project’s asset library within the project
file or external to the project file, in a .curioLibrary folder which sits alongside your .curio
project file.
Operations within Curio automatically support external library folders such as File > Save
As, Save To, Duplicate, and Rename, File > Create Archive, Quick Look, and the
automatic project backup feature described elsewhere.
IMPORTANT NOTE:
You must make sure both the .curio and .curioLibrary files have the same file name and
are kept together, otherwise Curio will be unable to open the project file.

Lock File
A project lock file is useful when sharing a project using a service such as Dropbox or a
network file server to make sure more than one person doesn’t attempt to make changes
to the project at the same time.
When set to automatic Curio will determine on its own if a lock file should be created.
Alternatively, you can force a lock file to be used or not used if you wish.

Mac App Store Restriction
Note that due to sandboxing restrictions both the external asset library and lock file features are
only supported for projects stored in the Projects folder specified in Curio’s Preferences.
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The Organizer
Manage all the project notes and docs
What's the Organizer?
Your Curio project can contain hundreds of idea spaces and documents all neatly organized in the Organizer.
Curio allows you to organize your idea spaces and other Organizer documents hierarchically. You can also group items into
lightweight folders or heavyweight project sections for maximum flexibility.

Terminology
Curio’s Organizer contains the main “pages” of your project notebook.
There are two main types of items the Organizer can store and organize:
1) An idea space is like an amazingly magical piece of paper that can contain notes, files, sketches, images, movies, mind maps,
tables, and much, much more.
2) An Organizer document is a file dragged in from the Finder, thus turning the Organizer into a versatile binder of notes and
documents.
These two types of Organizer items can be arranged, grouped, and hierarchically organized using the Organizer.

Show or Hide the Organizer
! Click the Organizer toolbar button to toggle the display of the Organizer.

Create a New Item in the Organizer
! Click the Add Organizer Item toolbar button and, from the popup that appears, choose whether you want:
a. a blank idea space,
b. a new idea space using the same style or template as the current idea space,
c. an idea space from the Idea Space Gallery,
d. a blank rich text document (technically RTFD so it can contain graphics, too),
e. a folder, used as a lightweight grouping of other Organizer items,
f. a section, used as a heavyweight division within your project [Standard] [Pro],
g. an instance of a master idea space template [Pro].

Instantly Create an Idea Space with the Same Style as the Current Item
! Hold Shift and press the New Organizer Item toolbar button, or choose Organizer > New Idea Space With Current Style, or right-click in the Organizer and
choose New Idea Space With Current Style.

Instantly Create a Blank Idea Space
! Choose Organizer > New Blank Idea Space, or right-click in the Organizer and choose New Blank Idea Space.

Rename an Organizer Item
! Within the Organizer, double-click on the item, or select an item and press Return, or right-click and choose Rename.

Create a Duplicate of an Existing Organizer Item
! There are many ways to duplicate an existing item: Choose Edit > Duplicate, right-click on the Organizer item and choose Duplicate, Copy/Paste, or hold down
the Option key while drag-and-dropping Organizer items.

Create an Organizer Alias to an Existing Organizer Item
! Drag-and-drop a selection of Organizer items (e.g. idea spaces, Organizer documents, Organizer folders) to another location within the Organizer while holding
down the ⌥⌘ (Option-Command) keys on your keyboard. When you release the mouse, aliases for all of those items will be created at the drop location. Here
are some notes on Organizer aliases:
a. You'll know it's an alias because its title is italicized and its preview icon has a little alias curl in the corner.
b. The title of the alias can be renamed to anything you wish and it will not change the original.
c. Everything else is linked to the original: preview, color label, tags, notes, etc. If you change either the original or an alias then they all change.
d. You can right-click on an alias and jump to the original.
e. Duplicating an alias creates another alias to the original, it doesn't create an alias to the alias.
f. You can hierarchically organize aliases just as you would any other Organizer item, including adding idea spaces as children under the alias.
g. You can delete an alias and this will not impact the original.
h. However, if you attempt to delete the original, Curio will warn you that aliases exist and will be broken if you continue. Curio will not auto-remove aliases
because they themselves might have children. The alert will also give you the option of jumping to the alias so you can delete it manually.

Delete an Organizer Item
! Within the Organizer, press the Delete key to delete the idea space, or right-click and choose Delete.

Rearrange Organizer Items
! Simply drag-and-drop idea spaces around within the Organizer to re-organize them.

Indent or Outdent an Organizer Item
! Select the idea space within the Organizer and press the Tab key to indent the item or Shift-Tab to outdent. You may also drag-and-drop the idea space into
position. You can have any number of hierarchical levels within the Organizer.

Expand or Collapse Organizer Item Hierarchies
! Click the disclosure triangle to expand or collapse an idea space hierarchy or use the Organizer menu’s Expand, Expand All, Collapse, and Collapse All menu
items.

Open an Organizer Item in the Secondary View
! Option-click on the item or right-click and choose Open in Secondary View. The secondary view can be placed to the side or under the primary view. Use the
View > Secondary View Below / Secondary View On Side menu to configure its placement. You can also Option-click on the splitter control in the Navigator Bar to
do this.

Display Options
1. Change the size of the Organizer’s displayed previews by right-clicking in the Organizer and choosing a new size. This new preview size can be global across the
entire project or just for the current section.
2. Sort Organizer items by right clicking on an item then choosing a sort method from under the Sort Siblings By submenu.

Organizer Documents
Collect other materials in the Organizer
What's an Organizer Document?
Normally the Organizer contains idea spaces, however it can also act as a flexible binder containing any document type. Simply
drag files from the Finder directly to the Organizer to make it available for viewing and editing (if appropriate) within the full bounds
of the Curio window.
RTF, RTFD, or plain text documents
Upon viewing, the inspector bar will reveal the appropriate font and text controls. As mentioned above, an RTFD document can also
be added via the Add Organizer Item toolbar button.
Image files
Such as JPEG and PNG.
PDF files
Upon viewing, the inspector bar will reveal PDF page and annotation controls.
Web links
Drag them in from your browser, upon viewing, the inspector bar will reveal web surfing controls. Note that Curio from the Mac App
Store does not support viewing remote, insecure http links in the Organizer.
All other document types
Will be displayed using a Quick Look viewer which will pull in the appropriate plugin as necessary. For instance, iWork files are
displayed so that you can easily browse their contents directly within Curio.

Embed or Alias
By default a copy of the dragged-in file will be embedded into your project. If you hold Command down then the original file with be
removed thus moving the file into your project. If Option is held then an alias to the original file is stored instead.

Saving Changes
Changes made to editable documents will be saved automatically when you switch to another item in the Organizer or when you
close the project. Renaming the title in the Organizer will rename the underlying file as well, if embedded.

Searching
For Organizer text documents and Organizer web views, pressing ⌘F to will bring up a Find bar so you can search within the
document.

Exporting, Printing, and Presenting
One important note is that these Organizer documents cannot be exported or presented from within Curio. The Organizer is simply
acting as a binder to collect these documents in your project. However, you can right-click on the item in the Organizer to open or
reveal the file in the Finder using the context menu. Curio can selectively print specific Organizer documents via right-click or File >
Print Document. Curio will then launch the documents using the applications appropriate for the selected document types, and
direct those applications to immediately print.

Sections

STANDARD

PRO

For serious project divisions
What is a Section?
To reflect a real-world metaphor, if a Curio project is a binder, then a Curio section is a tabbed section within that binder. However,
unlike a real-world section, a Curio section can be arranged into a limitless hierarchy.
For example, let’s say you have a Curio project called “Biology” for a class in college. You could create the following sections to
organize your project:
Classes
Labs
Papers
For a more complex example, let’s say you are a product manager in charge of “Super Product”. You could create the following
section hierarchy to organize your project:
General Notes
Development
Meetings
Specs
Focus Groups
QA
Meetings
Resources
Marketing
Meetings
Analysis
Sales
Meetings
Data
Support
Meetings
Customer Feedback
An important point to consider is that you can’t print or export multiple sections simultaneously. A section really is like a mini-project
within your overall project. Even child sections are independent of their parents.
You will see the section name in several places within Curio such as the title bar, the Status shelf task list, and the Search shelf’s
result list. You can search within the entire project or just a specific section.
Working with sections listed in the Organizer is just like working with other Organizer items. Thus renaming, deleting, rearranging,
indenting, etc, are managed in the same way.

Display the Sections Panel of the Organizer:
! Click the sections icon on the top of the Organizer (it looks like little tabbed notebook) or choose View > Show Sections. The Sections panel will appear in a split
view at the top part of the Organizer. To hide the Sections panel simply click the sections icon again.

Create a New Section
! Use the Add Organizer Item toolbar button and choose Section, or choose the Organizer > New Section menu, or right-click in the Sections panel and choose
New Section.

Open a Section
! Click on the section within the Sections panel. The Organizer will refresh itself and display the idea spaces and folders contained in the selected section.

Moving or Copying Items into a Section
! You can use cut/copy/paste to move Organizer items into a section. You can also drag-and-drop those items into a section, holding Option down if you wish to
create copies. If you release a drag on top of section then the dropped items will be appended to the end of the section. However, if you pause while hovering
over the section then it will automatically open allowing you to place the dropped items into a specific location within that section’s idea space hierarchy.

Folders
Easy grouping of Organizer contents
What is a Folder?
To continue the real-world metaphor started above, if a Curio project is a binder and a Curio section is a tabbed section within that
binder, then a Curio folder is a folder within a section.
So, if a section is a heavyweight division of your project and is displayed in Status and Search results, a folder is extremely
lightweight and is essentially invisible outside of the Organizer.
For example, use a folder to group a series of meeting note idea spaces created on a given day. Or to collect several idea spaces
that reflect rough design drafts.
Clicking on a folder won’t display anything within the idea space view because there’s nothing to display. And, if you click on a folder
to print or export it, Curio will automatically assume you want to print or export the contents of the folder.
Working with sections listed in the Organizer is just like working with other Organizer items. Thus renaming, deleting, rearranging,
indenting, etc, are managed in the same way.

Create a New Folder
! Use the Add Organizer Item toolbar button and choose Folder, or choose the Organizer > New Folder menu, or right-click in the Organizer and choose New
Folder or New Folder From Selection.

Moving or Copying Items into a Folder
! You can use cut/copy/paste to move idea spaces or other folders into a folder. You can also drag-and-drop those items into a folder, holding Option down if you
wish to create copies.

Trash
A temporary area for deleted items
The Organizer Trash
When you select and delete any item from the Organizer, including sections, idea spaces, Organizer documents, and folders, they
will be moved to a new Trash section in the Organizer. Items in the Trash will be automatically discarded when the project is closed.
Important
The Trash will automatically empty when you close your project. It is only a temporary Trash for the current editing session.
The purpose of this temporary, session Trash is for quick recovery of idea spaces or sections that you may have inadvertently
deleted.

Why Not Undo?
When you delete an item from the Organizer, Curio asks you to confirm the deletion, then deletes the item. This is not an undoable
action because Curio's undo systems are independently managed by each idea space. That way you can undo actions performed
in one idea space without undoing actions made in another. There is no "global" undo manager. (This is identical to the way Xcode
operates, for those familiar with that app.)
Apple's Keynote app, on the other hand, offers a single, global undo stack. This means undoing will step you back in time changing
items in the current slide, other slides, plus slide creations, rearrangements, and deletions. It's all one big undo stack so you can't
undo only the slide arrangement changes, or only changes to a specific slide, without undoing unrelated actions.

Our Solution
The session Trash is Curio's solution to this issue. It offers the flexibility of giving the user a way to "undo" a mistaken deletion while
still maintaining independent undo stacks for each idea space.
It is important to note this isn't an ever-growing Trash, like the Finder's, that would quickly bloat your project requiring you to
periodically remember to empty it. Nor is it one that automatically deletes items that are more than x days old, as that adds a
number of complexities. For that you might want to learn more about the new Archive section discussed below.
Its purpose is simply for the recovery of Organizer items inadvertently deleted during this session.

Delete Items from the Organizer and Send Them to the Trash
1. Select the items you wish to delete then press the Delete key. Alternatively, you can also drag items directly to the Trash section.
2. A confirmation alert will appear so you can confirm the deletion, noting that the selected items and any any child items will be moved to the Trash then
permanently deleted when you close the project. In this alert you can choose to move items to the Archive section instead, which is discussed below.
3. If you confirm the deletion then the items are moved to the Trash and both the Trash icon in the Organizer header area and the Trash section icon will become
tinted red to indicate that the Trash now contains items.

Recovering Items from the Trash
1. Click the Trash button in the Organizer header area to open the sections display and automatically select the Trash section.
2. Drag items out of the Trash and into any section of your project. While dragging you can hover over a section to jump into the section for more precise placement
within that section's contents.

Characteristics of Items in the Trash
1. The Search shelf will ignore items in the Trash unless you specifically choose the Trash via the Search shelf's scope popup.
2. The Project Library shelf will ignore items in the Trash unless you specifically choose the Trash via the Library shelf's scope popup.
3. Trashed items are not listed in the Navigator bar's popup list of project idea spaces.
4. Trashed items are not exported or synced along with other project items.
5. Trashed items cannot be rearranged, renamed, assigned a color label, or deleted within the section or Organizer areas.
6. New Organizer items cannot be created in the Trash.

What Happens to Items in the Trash?
! When you close the project, the project Trash is automatically emptied and everything is sent to the Finder Trash.

Emergency Recovery
! In emergency situations where you've deleted idea spaces, confirmed the deletion, and closed the project so the project Trash is emptied, you can now drag an
idea space .curioAsset file from the Finder Trash into the Organizer and Curio will be able to restore the idea space and any text figures. However, any other
asset figures that existed on the idea space, such as files or images, cannot be restored, as they are not a part of that single .curioAsset file (unless they still exist
in the project if another existing idea space references them), but you can drag them out of the Finder Trash as well if you wish.

Archive
Put old Organizer items in cold storage
The Organizer Archive
Curio now includes a special Archive section which can be used for long term storage of items that you may have been tempted to
delete but want to hold onto just in case.
The Archive is a perfect long term storage place for items you want to keep around, just in case you need to reference them, but
they aren’t active components of your project and therefore don’t need to turn up in searches, exports, etc.

Move Items to the Archive
1. Right-click on selected Organizer items and choose Move to Archive.
2. Or, drag one or more Organizer items directly to the Archive section.
3. Or, press the Delete key then click the Move to Archive button in the confirmation dialog that appears.

Characteristics of Items in the Archive
1. Archive items are not loaded into memory on project load but only as needed.
2. The Search shelf will ignore items in the Archive unless you specifically choose the Archive via the Search shelf's scope popup.
3. The Project Library shelf will ignore items in the Archive unless you specifically choose the Archive via the Library shelf's scope popup.
4. Archived items are not listed in the Navigator bar's popup list of project idea spaces.
5. Archived items are not exported or synced along with other project items

Filter
Searching the Organizer
The Organizer Filter
You can quickly search the Organizer for specific items using the Organizer Filter.
The filter panel appears at the bottom of the Organizer and allows you to enable one or more filtering criteria to the items displayed
in the Organizer.
For instance, you can use the filter bar to show all idea spaces modified in the past 2 weeks; or all with a the label Needs Client
Approval; or tagged with the Important tag; or with a title containing the word lecture.

Search Shelf vs Organizer Filter
The Search shelf can search figures and idea space titles. Use the Filter to filter the list of displayed items in the Organizer.

Show the Organizer Filter
! Click the filter button at the top of the Organizer table, or choose View > Show Filter.

Hide/Clear the Organizer Filter
! Click the Filter button in the Organizer header area, or choose View > Hide Filter. This will also clear any specified filter criteria.

Set Filter Criteria
1. Date — click the Date icon to filter the Organizer by when they were last modified.
a. You can also select or create a project milestone, like “First Client Demo”, to filter using a specific date.
b. Those same project milestones can be selected or created in the Search shelf’s date modified popup, as well.
2. Label — click the Label icon to filter the Organizer by label color.
3. Tag — click the Tag icon to filter the Organizer by tag.
4. Title — enter some text to filter the Organizer by title.

Navigator Bar
Helping you traverse through your project
What is the Navigator Bar
At the far right corner of the inspector bar you’ll find the navigator bar: a series of controls to help you move around your project and
manage what you see in the main content area of the window.

The Splitter Button
! The splitter button is used to open up or close the secondary idea space split view. Option-click on this button to switch the secondary view between the side-byside and above-below layouts

The Bookmarks Button
1. The bookmarks popup button can be used to create bookmarks to easily jump to points within your project. You can either create a bookmark to an Organizer
item such as an idea space, or you can create a bookmark figure. A bookmark figure is a positionable figure which is placed into the current idea space and is
useful if you want to mark a specific location within an idea space.
2. Both bookmarks and bookmark figures can be named and assigned one of eight colors for quick identification. All bookmarks are listed in the bookmarks popup
in the navigator bar and can either be sorted by name or color
3. To jump to a bookmark or a bookmark figure simply select the item in the bookmarks popup.
4. Option-clicking a bookmark figure’s adornment will cycle through the available bookmark colors.
5. To remove a bookmark, choose Remove Bookmark from the bookmarks menu. To remove a bookmark figure, select it on the idea space and press Delete.

The Navigator Button
! The navigator is a popup display showing the complete hierarchy of the current section or project so you can select and instantly jump to another Organizer item.
In many cases you can leave the Organizer hidden and simply use the Navigator popup instead.

The Back/Forward Buttons
! The back/forward buttons are available to move back in history, to the idea space or Organizer item you were recently viewing, or forward in history. Just like a
browser’s back/forward buttons. You can also hold Option while swiping left/right with your mouse or trackpad.

The Previous/Next Buttons
1. The previous/next buttons are available to move to the previous or next item in the Organizer. You can also swipe left/right with your mouse or trackpad.
2. If you hold Command down then the buttons change to indicate that clicking will move you to the first or last item in the Organizer.

Tags
Tracking with tags
To view the tags associated with the selected item either click the Meta button in the
inspector bar, or see the Meta tab in the Inspector shelf.

Tags
Tags are words or phrases that you can define and associate with your items as
searchable meta information. A tag can be local to a particular project, and used perhaps
like a handy keyword, or it can be a global tag set available for use within all of your
projects.
For instance, if you have a project for a research paper, then you may use local project
tags to quickly tag and find documents, notes, and images you bring into your Curio
project.
On the other hand, you may create a tag set titled “Tasks” containing tags such as
“Possible”, “On Hold”, “Started”, “Working On”, and “Completed”, that you use to tag
items in all of your projects. Then you can use the Status shelf to quickly search across all
of your projects to see what figures are “On Hold”, for example.

Sharing Global Tags with Others via Extracted Tags
On a related note, if you share a project you created with others then obviously those
users would have access to the local tags, but what about your global tags?
Fortunately, Curio will embed an “extract” of any global tag sets you have referenced in
the project so your colleagues will see those same tag associations. When they view the
Meta inspector on their Macs those extracted tag sets will be available but grayed out to
indicate they cannot delete or otherwise modify those tag sets. However, they can change
tag associations from that set — for example, they can change a figure from “On Hold” to
“Working On”.

Assign Tags via Typing with Tag Name Completion
You can associate tags with the selected items simply by typing the tag name. A
completion list will appear as you type so you can choose an existing tag, or you can
continue typing and press the Return key to create an on-the-fly local project tag.

Assign Tags via Hierarchical List or Image
You can also associate tags using the tags hierarchical list or click the button to turn it into
a handy matrix showing only those tags with images.

Working with Tag Sets and Tags
Use the gear button and tag properties at the bottom of the inspector to modify or create
new tag sets and tags. These tags can either be local to your project or global and
available across projects and for grouping purposes in the Status shelf.
•
•
•
•
•

•

•

•

•

Create a new tag set or tag in the current tag set using the gear button.
Tag sets and tags within a tag set can be arranged in a specific ordering, or you can
use gear button to sort them.
Change a tag name by double-clicking it.
To delete a tag, select it and press the Delete key.
Use the gear button to sort the tag sets and tags within the current set. You can also
import an extracted tag set from a foreign project into your own shareable global tag
sets. For instance, from the example above, if you’re viewing a colleague’s project with
that “Tasks” extracted tag set then you can select it and use the gear button to import
it into your own global tag sets. All internal identifiers are kept the same so you can
continue to share projects with your colleagues that use that same tag set.
Click the ‘Click to Record’ field to record a keyboard shortcut to quickly apply certain
tags to figures. All shortcuts must include Control-Shift to avoid conflicts with existing
Curio shortcuts.
Assign an emoji or character symbol to a tag by clicking in the emoji field and
pressing Control-Command-Space to bring up the standard macOS Character Viewer.
Double-click on an emoji or text symbol and instantly it will be entered as the “image”
for the tag. Emoji are great because they’re perfectly scalable and consume very little
disk space for the project. If you choose a text symbol then use the little color well
next to the emoji field to specify a tinting color for the symbol. This way you can turn a
boring black down arrow symbol into a noticeable red down arrow.
Alternatively you can drag in or paste an actual image into the tag’s image well. As a
note, you can drag multiple images (icns, png, or jpg) from the Finder into the tags
panel to add lots of image tags to an existing tag set, where their tag names are
derived from their file names. Download perfect tag images from sites like IconFinder
or search SmashingBuzz or Google for icon sets for more recommendations.
When a tag has an image (emoji or actual) then it is displayed as an adornment next
to the figure’s other adornments. Use the adornment size slider to change its size.

One Tag Active
When a tag set is selected, note the ‘only one tag in the tag set can be active’ checkbox.
Checking this option is perfect for those tag sets which represent a specific state or
status. Choosing a tag in this set will automatically turn off the previously associated tag
from this set.
For example, with the Detailed Tasks tag set you are specifying a GTD-style state for that
task like pending, active, or done. If the current state of a figure is active then setting a
tag of done will automatically turn off active.
These types of tag sets have a couple of extra ways to assign tags to a figure:
• If your tag set has 3 or fewer tags with images then clicking the tag's image
adornment will cycle through the tags in the set.
• If your tag set has more than 3 tags, then clicking the tag's image adornment reveals
a popup so you can quickly choose the new tag.

Assign Figure Tags via Context Menu
Right-click on a figure and choose a tag from the context menu that appears to toggle the
tag association.

Assign Figure Tags via Mini Popover
Curio has a handy mini popover for setting tags which can be handy when you don’t want
to bring up the inspector.
To show the tags mini popover: Option-click an existing tag adornment, or press the
Comma key when a figure is selected. As a hint to remember this keyboard shortcut, think
of a comma-separated list of tags.
When the mini popover appears type in a tag name. A completion list will appear as you
type to help you choose an existing tag if you wish.
To hide the popover press the Escape key, or click its little close button

Labels
Visually organize with color
To view label associated with the selected Organizer item either click the Meta button in
the inspector bar, or see the Meta tab in the Inspector shelf. You can also right-click on the
Organizer item to make a quick label assignment.

Using Labels
Similar to the Finder’s Label feature, you can associate a label and color with your idea
spaces, Organizer documents, sections, and folders. When an item is labeled, the
preview or icon displayed in the Organizer displays a border using the label color. This
allows you to visually flag certain idea spaces, sections, or folders.
Remember you can also use the Organizer filter to display only Organizer items with an
associated label color.
Use the label inspector panel to work with labels.

Assigning Labels
Click on a label row to set the selected Organizer item to that label. A checkmark will
appear next to the label associated with the selected Organizer item. You can also assign
a label by right-clicking on an Organizer item and choosing one from the Labels
submenu.

Changing Label Color
Click on the label color well to change the color.

Changing Label Text
Double-click on the label text to change the text.

Defaults
Click “Copy to Defaults” to make these labels the new global defaults.
Click “Restore Defaults” to restore this project’s labels using the global settings.

Notes
Add associated notes and images
To view the notes associated with the selected Organizer item or figure click the Notes
button in the inspector bar.

Notes
The notes inspector allows you to enter miscellaneous notes that will be associated with
the selected item.

Entering a Note
The notes inspector window allows you to enter any rich text, with full support for multiple
fonts, sizes, colors, paragraph formatting, and even images.

Note Adornment
When a note is associated with a figure then a little note adornment is displayed next to
the figure. If you click the adornment, the notes inspector window will appear allowing you
to change notes. If you remove all the contents of the note then the note is deleted entirely
and the adornment is removed.

Searching Notes
For figures, notes are searched when using the Search shelf. For Organizer items, notes
are searched when using the filter.

Printing Figure Notes
You can print the notes associated with the selected figure via the File > Share menu or
Share toolbar button. Note the Include Figure Notes When Copying/Sharing Text item in
the Share menu which is useful when you want to include notes with copied or exported
figures.

Info
Tidbits of info about an item
To view info associated with the selected Organizer item or figure click the Info button in
the inspector bar.

Item Info
Organizer items and figures can have various miscellaneous bits of info that Curio
collections under the info inspector.

Title
View and edit the title of the selected Organizer item or asset figure.

Identifier
A identifier that you can assign to the item. Currently its only use is with the Master
Templates feature in Curio Professional, but we more plans in the future.

Filename and Location
If the item has an underlying file then its name and location appears here.

Date Stats
View the date the item was created, added to Curio, and last modified.

Actions Popup
The gear button allows you open or reveal the underlying asset file using the Finder. If the
asset is an alias then you can choose to convert the asset into an embed asset by
copying the original file into the project’s internal asset library. You can also choose to
swap the underlying file with a new file which you will choose using a standard Mac open
dialog.

Restrictions
Specify restrictions such as whether a folder, idea space, or figure is printed, exported, or
presented.
Restrictions are automatically inherited by the children of Organizer folders and idea
spaces.
For example, say you have an Organizer folder with the "exporting allowed" checkbox
unchecked. Any idea spaces or folders hierarchically contained within that folder will
automatically inherit that restriction as well. And, since they inherit that restriction, and
cannot override it, the restriction checkbox is disabled in their Info inspector.
As another example, if you have an idea space with a "no presenting" restriction, then any
child idea spaces hierarchically under that idea space will also be skipped when
presenting.
This makes it very easy to quickly restrict or un-restrict an entire hierarchy of items just by
nesting the items appropriately.

Advanced Options
An advanced option is whether the underlying file is copied or shared when the asset
figure is copied. Normally Curio will share the underlying file thus you can have ten
references or instances of a giant Photoshop image file scatter throughout your project,
but the underlying file will exist only once within the asset library.
On the other hand, you could specify that when the figure is copied then a unique copy of
the underlying file should also be made, thus you’d end up with ten separate copies of
the Photoshop file stored internally.

The Idea Space
Curio’s amazing freeform “page”
What’s an Idea Space?
The Curio idea space is the most flexible and magical notebook page you’ve ever used. Idea spaces are wonderfully freeform and
allow you to place anything anywhere on the page.

Terminology
An idea space is just a blank canvas. Like a giant whiteboard, you can write or draw anything anywhere within an idea space.
However, unlike a whiteboard, you can also add images, documents, web links, movies, sounds, contacts, mail messages, and
calendar events.
The key feature is the amazing, freeform environment supported by Curio’s idea spaces. An idea space can be as structured or
messy as you wish emphasizing that it’s your project notebook and it can look exactly the way you like it.
An idea space style defines just the look of the idea space. You can apply a style to a new or existing idea space. The style
includes color and grid information, for example, but does not include boilerplate text or other figure elements.
On the other hand, an idea space template is a re-usable idea space that defines the look and includes boilerplate figure
elements, such as text figures, collections, and images. You cannot apply a template to an existing idea space, as that would wipe
out your existing figures. When you use a template you are creating a copy of that original template.
If you change or update the original style or template Curio does not change any instances either in the current project or in projects
stored on your hard disk. The change will only be reflected in new instances that you create or apply in the future. However, Curio
Professional users have access to a new feature called masters that allow this functionality which we’ll discuss later.

Working with Idea Spaces
Since an idea space is simply an item in the Organizer, see the pages above that detail how to use the Organizer for more
information on adding, deleting, and managing idea space Organizer items.

Idea Space Styles
Customize the look of your idea space
Working with Idea Space Styles
You can easily create new idea space styles containing its background color, texture, and notepaper or grid settings.

Create a New Personal Idea Space Style
1. Click on an an idea space in the Organizer.
2. Configure its attributes how you want them using its inspectors. For example, change the background color, grid settings, etc.
3. Right-click on the idea space in the Organizer or on the idea space background then choose “Save As Idea Space Style”. Alternatively, you can also do this by
choosing the Organizer > Save As Idea Space Style menu item.
4. In the dialog that appears give the style a name. If you save a style with the same name as an existing style then it will simply be replaced.
5. If you then make more changes to the idea space you can right-click and choose Update Style or you can create a new style if you wish.

Apply a Style to an Existing Idea Space
1. Select an idea space in the Organizer to open it.
2. Click the style button in the far left side of the the inspector bar to see the style gallery, or choose a style from the inspector shelf, or right-click on the idea space
background and choose Apply Idea Space Style to bring up style gallery.

Create a Brand New Idea Space Based on an Existing Style
1. Click the Add Organizer Item toolbar button then choose Idea Space Gallery.
2. Choose a style from the gallery window that appears.

Managing Idea Space Styles Within the Idea Space Gallery
1. Copy a style simply by drag-and-dropping it into your Personal or, for Professional users, their Master repository.
2. Delete a personal or master style by selecting the style and pressing the Delete key.
3. Share or copy a personal or master style via the right-click context menu.

Idea Space Templates

STANDARD

Includes styling info plus placeholder figures
Working with Idea Space Templates
Curio Standard and Curio Professional users can easily create new idea space templates containing not only its look but also
placeholder or boilerplate items such as text figures, mind maps, lists, and images. You can create new idea spaces based on a
template.

Create a New Idea Space Template
1.

Click on an an idea space in the Organizer which you would like to copy as a template.

2.

Right-click on the idea space in the Organizer or on the idea space background then choose “Save As Idea Space Template”. Alternatively, you can also do this
by choosing the Organizer > Save As Idea Space Template menu item.

3.

In the dialog that appears give the template a name.

Create a Brand New Idea Space Based on an Existing Template
1.

Click the Add Organizer Item toolbar button then choose Idea Space Gallery.

2.

Choose a template from the gallery window that appears.

Managing Idea Space Templates in the Idea Space Gallery
1.

Create personal template tags by right-clicking in the Personal area in the repositories list on the left and choosing “Add Tag”. These tags are unique to the idea
space templates repository and won’t conflict with tags created for figures in the stencils repository, for example.

2.

Organize your personal templates by drag-and-dropping them into different tags. A template can be associated with more than one tag. So, a template can be in
your “Favorites” and “Work” tagged collections.

3.

Curio Professional users will also see their project’s master repository of templates.

4.

You can also associate or disassociate a personal template with a tag by right-clicking on the template and choosing a tag in the menu that appears.

5.

Rename a personal or master template tag by double-clicking it and entering a new name.

6.

Delete a personal or master template tag by selecting it and pressing the Delete key.

7.

Copy a template from another repository simply by drag-and-dropping it into your personal or master collection.

8.

Edit a personal or master template by right-clicking on the template and choosing Edit Template.

9.

Delete a personal or master template by selecting the template and pressing the Delete key.

10. Share a personal or master template by right-clicking on the template and choosing Send to Friend or Send to Zengobi.

PRO

Zooming
Get a better view of your idea space
Zooming In and Out
Curio has many way to zoom in and out of the idea space.

With the Zoom Popup
! The default toolbar has a zoom popup which you can use to pick a specific zoom level.

With the Zoom Slider
1. Right-click and customize the toolbar to add the zoom slider.
2. Double-clicking or Option-clicking the slider will zoom to Actual Size.
3. While hovering over the slider use the scroll area of your mouse to zoom.

With the Menu Bar
1. The View menu offers several menu items with keyboard shortcuts to control idea space zoom.
2. If you hold down the Option key and then click the View menu you’ll notice that Zoom to Fit, Zoom to Width, and Actual Size dynamically change to Zoom All to
Fit, Zoom All to Width, and Zoom All to Actual Size, respectively, so you can easily change the zoom of all your idea spaces in the current section.

With a Mouse
! Zoom with the mouse by pressing and holding the Option-Command key and then scrolling your mouse or trackpad up and down over the idea space area.

With a Trackpad
! Use the standard pinch gesture.

Via Smart Zoom
! If not currently at Actual Size then a double-tap on your Magic Mouse or a 2-finger double-tap on a trackpad will zoom to Actual Size. Otherwise, if already Actual
Size, that double-tap will zoom such that the current contents of the idea space fill the display, subtracting out any blank whitespace and centering the view on
those contents. Note that you have to have Smart Zoom enabled in your System Preferences Mouse and/or Trackpad settings.

With the Keyboard
1. Like Photoshop, you can press the Spacebar and Command keys simultaneously and then click the mouse to zoom in.
2. To zoom out, press the Spacebar and Option keys simultaneously and then click the mouse to decrease the zoom level.
3. The pointer will change to a magnifying glass with either a plus sign or a minus sign to indicate whether you’re increasing or decreasing the zoom level.

Quick Zoom
1. You can also quickly zoom to fit the idea space within the view by holding down the Q key.
2. When you release the Q key, the view will return to its previous zoom level centered where the mouse was last positioned.
3. This mechanism provides a quick way to navigate a large idea space.

Inserting Space
Make some room!
Expand Your Work Area
In addition to the Dimensions inspector, described below, you can quickly add space to your idea space.

Insert Space to the Bottom or to the Right of the Idea Space
! With no figures selected choose either “Space at Bottom of Idea Space” or “Space to the Right of Idea Space” from the Insert menu.

Insert Space Below or to the Right of the Selected Figures
1. Select one or more figures then choose either “Space Below Selected Figures” or “Space to the Right of Selected Figures” from the Insert menu.
2. With these options, Curio will add some space to the bottom or right side of the selected figures pushing all figures on the idea space that are located below or to
the right of the selected figures. This is useful when you want to add a big gap in the middle of a complex idea space, scooting everything down starting at this
location

Insert Space Directly Below or to the Right of the Selected Figures
1. Select one or more figures then while holding the Shift key choose either “Space Directly Below Selected Figures” or “Space Directly to the Right of Selected
Figures” from the Insert menu.
2. Now Curio will add some space to the bottom or right side of the selected figures pushing only those figures directly affected (recursively) by moving the selected
figures below or to the right of the selected figures. For example, if you just want to scoot figures directly below the selected figures down, leaving figures to the
sides as-is, then hold down Shift and choose the menu item.

Background
Change the look of your idea space
To change the background properties of the selected idea space either click the
Background button on the inspector bar, or see the Background tab in the Inspector shelf.

Style
From a simple white background, to a piece of notebook or grid paper, to a colorful
textured backdrop, you can completely customize the look of your idea space. You can
even save these looks as personal styles to use them again and again.
At the far left of inspector bar you’ll find a Style button which displays a quick, popup
gallery for the current idea space. Simply click on a style to update the look of your idea
space.
You can also use the mini style gallery at the top of the inspector shelf to do the same
thing. And, lastly, you can right-click on an idea space and choose Apply Style to choose
a style from the gallery that appears.
All of these interfaces give you an opportunity to choose either a bundled or personal
style that you have created. Curio Professional users can also select a master style.

Color
Set the fill color with the Solid, Gradient, or Radial gradient button.
•
•

•

For solid fills, click on the color well to choose a color from the matrix that appears. Or,
Option-click on the color well to go directly to the standard color chooser.
For linear gradient fills, drag the color stops to adjust the gradient ramping. Doubleclick on a color stop to edit its color. Double-click on the gradient to insert a new color
stop. Drag a color stop down and off the gradient control to remove the stop from the
gradient. The resulting gradient will be rendered along the angle specified by the
angle slider.
For radial gradient fills, drag the color stops to adjust the gradient ramping. Doubleclick on a color stop to edit its color. Double-click on the gradient to insert a new color
stop. Drag a color stop down and off the gradient control to remove the stop from the
gradient. The resulting gradient will be rendered with a center point located as
specified in the point locator control.

You can change the color used to display page breaks by clicking on the page break
color well and choosing a new color. To show page breaks, choose View > Show Page
Breaks.

Image
Paste or drop an image into the image control or choose an image or texture from the
image collection browser. Curio includes several bundled textures, or you can choose
one of your system’s desktop pictures, or select a custom folder for Curio to search for
images. Curio now includes a sampling of textures from SubtlePatterns.com, as well.
Thanks to Subtle Patterns for allowing us to include some of their textures within Curio.
You can adjust the opacity of the selected background image using the opacity slider.
That way the image can appear on top of a solid or gradient background color.
You can also change the way the background image is scaled. You can choose to have
the image tiled over the whole idea space, centered within each page of idea space, or
stretched to fit each page of the idea space either proportionally or not.

Grid
Your idea spaces can have visible (or hidden) lined or dotted grids. Adjust the spacing
and colors of the major and minor grid lines or dots. You can also independently toggle
the visibility and snapping of the vertical and horizontal grid lines.

Transitions
For presentation mode
To change the transition associated with the selected idea space either click the Idea
Space tab in the inspector bar then click the Transitions tab, or see the Transitions panel in
the Inspector shelf under the Idea Space tab.

Idea Space Transitions
For Curio Professional customers, you can specify a default transition to use when
stepping through idea spaces during presentation mode.
However, this can be customized for a specific idea space if you wish using the transition
inspector.
Choose the type of transition you’d like to use, or none if you don’t want any animation
between slides. Your choices include Apple's standard Core Animation transitions.
Once you choose the type the available transitions will be displayed so you can choose
the desired transition.

PRO

Dimensions
Set the size of your idea space
To change the dimensions associated with the selected idea space either click the Idea
Space tab in the inspector bar then click the Dimensions tab, or see the Dimensions panel
in the Inspector shelf under the Idea Space tab.

Idea Space Dimensions
The idea space dimension inspector allows you to set the size of the idea space and
control whether the idea space can automatically adjust its size for its content.

Orientation
By default the portrait versus landscape orientation for the idea space is inherited from
the setting specified in the Page Setup dialog. This orientation is used when printing or
exporting to PDF. You can override the default and force either portrait or landscape.

Margins
The margins button will bring you to the project inspector so you can specify the margins
used on your idea spaces when printing or exporting to PDF. These margins are global for
all idea spaces in the project.

Units
At the top you can choose the units used to display the dimensions. You can choose
either points, printed pages, or screens.

Width and Height
Enter a width and height and, when you press Return, they will immediately take effect.
You can also use the stepper control next to each field to increase or decrease the value.
The stepper generally moves in increments of 1 but, if the units are set to points, you can
hold Option to increment by 10, or hold Option+Shift to increment by 100.
Click Resize to Contents to reduce the size of the idea space to its minimum values
based on the content currently displayed in the idea space. This calculation takes into
consideration the chosen unit of measurement. For example, if you choose Pages as your
unit of measurement, then Shrink to Minimum will reduce the idea space to the fewest
whole number of pages required to display the current content..
If an idea space is set to automatically grow in size, then as content is placed beyond the
current borders of the idea space, it will automatically grow to accommodate it. If you do
not wish for the idea space to grow automatically then set both the vertical and horizontal
popups to Manually.

Defaults
Click Restore Defaults to reset the current dimensions to their default settings. Click Copy
to Defaults to save the current dimensions and automatic resizing options as your new
defaults for future idea spaces in this project and other projects.

The Figure
Curio’s most basic element
What’s a Figure?
In Curio, anything placed on an idea space is a figure. It can represent a basic flowcharting shape such as a square or octagon. Or
more complex items such as text, images, web links, movies, music, or any type of document. A figure can also represent a
collection of contained figures. For example, a mind map or a list outline.
With any type of figure, not only can you specify its look through fonts and colors, you can also specify meta information such as
tags, and start/due dates.

Terminology
A figure is the most basic entity within Curio such as a text figure, an image figure, a document figure, and a line figure.
A collection figure is a special type of figure that contains, manages, and positions figures within it. Examples include Curio’s list,
mind map, table, index card, pinboard, and album collection figures. While a collection figure can contain other figures it cannot
contain another collection. For example, you can’t place a table into a mind map or an index card into a list.
A figure style defines the look of the figure including properties such as color, border, font, and shading. You can apply a style to a
new or existing figure.
On the other hand, a figure stencil is a re-usable figure that can includes richer data such as placeholder or boilerplate text. You
create a copy of a stencil.
A simple figure stencil is a stencil that is a single figure. Even if that figure itself is a collection figure such as a mind map or list it
and therefore contains figures within it, the collection figure itself is just a single figure, thus it is a simple figure stencil.
A complex figure stencil is a stencil made up of multiple figures. A perfect example is a landscaping stencil where flowers, shrubs,
and trees are represented by individual figures, images, or grouped figures.
If you change or update the original style or stencil Curio does not change any instances either in the current project or in projects
stored on your hard disk. The change will only be reflected in new instances that you create or apply in the future. However, Curio
Professional users have access to a new feature called masters that allow this functionality which we’ll discuss later.

Insert Popover
An incredibly diverse set of figure options
The Insert Popover
The insert popover can appear in one of two ways:
1. Click the Insert toolbar button.
2. Press the i key on your keyboard.

Using the Insert Popover
In the popover that appears Curio shows you all the types of figures you can insert into your idea space.
You can select an item with the mouse or trackpad, or use the arrow keys to move around, or press the first letter of the item (note
that some items have different key shortcuts, like Stack = k, due to conflicts with other entries).
Some of the figure types will show you a gallery of options, others may show a pick list of choices, or a field to fill in.

Basic Shapes
A gallery appears showing off many of the basic figure shapes that can be inserted included simple text figures, lines, and various
geometric shapes.
Clicking an item will insert a shape of that style into the idea space.
Double-click the resulting text or geometric figure to add text.

Styled Shape or Stencil
A gallery appears with all figure styles and stencils available within your personal repository, Curio’s bundled repository, and any
shared repositories you have configured in Preferences.
Double-clicking a style or simple stencil will insert that figure into your idea space, or you can select the item and click the Insert
button.
Complex stencils, which are stencils that contains multiple figures, are displayed in the gallery with the number of figures it contains
in parentheses. Selecting a complex stencil and clicking the Insert button will insert the entire stencil into your idea space. However,
double-clicking will drill down into the stencil so you can choose a specific figure within the stencil to insert. You can click the Back
button to come back out. For example, say you have a landscaping complex stencil with figures for various types of trees, plants,
and hardscape. You can insert the entire stencil where all of the figures are inserted, or you can double-click and drill down to
choose a specific tree figure to insert.
Regarding stencils, see more information about the Stencils Library, detailed below, if you’re a frequent user of figure stencils.

List / Mind Map / Table / Index Card / Album / Pinboard
A gallery appears with all appropriate styles and stencils available within your personal repository, Curio’s bundled repository, and
any shared repositories you have configured in Preferences.
Clicking an item will insert that figure into your idea space.
These specific Insert choices have a sneaky feature. If, in the list that appears when you click the Insert toolbar button, you click on
the icon next to the item name (like “List” or “Mind Map”) then Curio will instantly insert the appropriate collection with its default
styling without showing the gallery.
Note that your toolbar can also have a dedicated button for a specific collection type. For instance, a List button that brings you
instantly to the List gallery. Right-click on the toolbar and choose Customize to add or remove these toolbar buttons.

Insert Popover (2)
More items in the insert popover
Audio Recording
A panel appears where you can configure the audio input and check the audio input level.
Click the Insert button to begin recording.
To stop and play the recording use the Media Bar in the inspector bar.

Video Recording
A panel appears where you can configure the audio and video inputs and check the audio input level.
Click the Insert button to begin recording.
While recording a floating video preview window will appear so you can see what is being recorded. You can position or close that
preview window. Curio will restore the last-saved preview position the next time you record.
To stop and play the recording use the Media Bar in the inspector bar.

YouTube / Vimeo Video
A panel appears where you can paste in the URL to a YouTube or Vimeo video (such as https://www.youtube.com/watch?
v=NQ7kqwbqeiI or https://vimeo.com/35396305) and then click Insert.
Curio will then parse the URL to extract out the actual movie name then turn it into an embed URL. A WebView with a nice default
size is then created, the embed URL is set, and the resulting WebView is placed on your idea space ready for viewing.
Note, for faster embedded videos, simply drag-and-drop a YouTube or Vimeo URL from your browser directly to the Curio idea
space and Curio can instantly turn that into an embedded video figure.
You can resize the resulting embedded video if you wish by dragging on the figure’s selection handles. By default the figure will
resize proportionally maintaining the video’s aspect ratio, although you can hold Shift while dragging to resize non-proportionally.

Insert Popover (3)
More items in the insert popover
Instant Document
A panel appears where you can choose a personal or bundled instant document for inserting. An instant document is a blank or
boilerplate document for another application that you can create and install within Curio. Examples include Word documents,
OmniGraffle diagrams, or Photoshop drawings. See the From Instant Document Templates section below for details.

Equation [Standard] [Pro]
An equation editor appears so you can enter your equation using either LaTeX, AsciiMath, or MathML and see an instant, real-time
preview. Pressing the Insert button places a high-resolution PDF rendering of the equation on your idea space.

WebView
A new WebView is instantly inserted into your idea space. Use the web surfing inspector bar to specify and save a specific URL for
the new WebView.

Google Doc
A new WebView is instantly inserted into your idea space going directly to the Google Docs web URL. Use the web surfing
inspector bar to specify and save a specific URL if you wish to point to a specific document within Google Docs.

Date and Time
A panel appears where you can choose a pre-formatted date and time. The selected item will appear as a new text figure or
inserted into an existing text figure being edited.

Variable
A panel appears where you can choose a special variable which will be dynamically filled out by Curio. For instance, you can insert
a variable for the current project name, idea space name, and its last modified date and time. A variable can be inserted as a new
text figure or into an existing text figure being edited.
One item of note is the Organizer Container Title variable. It will output the title of the parent containing item that contains the
current idea space. This could be a parent idea space, a containing folder, or the current section. If the current section is simply the
default section and no other sections exist then the title of the project itself will be output.
Another useful variable is the Figure Tag Name which will be dynamically replaced with the tag associated with a figure. One use for
this is to construct Stack figure titles which dynamically change based on what tag is associated with the title figure.

List/Mind Map/Table From File
A standard Mac open panel will appears allowing you to select a file which will be converted into a native Curio list, mind map, or
table collection figure, as appropriate. You can also perform this conversion simply by drag-and-dropping a file into your idea space
from the Finder.
The import formats currently supported are as follows:
Lists: OPML.
Mind Maps: OPML, Mindjet MindManager, iThoughts, MindNode, iMindMap.
Tables: CSV.
Curio can also export collections in those same formats. Collection import and export conversions are discussed in greater detail in
that collection’s section later in this documentation.

File
A standard Mac open panel will appears allowing you to select a file to insert into your idea space. Use the popup at the bottom of
the dialog to specify whether Curio should (a) copy and embed the selected files into your project, (b) store aliases to the selected
files in your project, or (c) move and embed the selected files into your project.

Insert Menu
For quick access to popular items
Using the Insert Menu
To quickly insert certain types of figures without going through a gallery window you should check out the Insert menu in the main
menu bar.
With the menu, as opposed to the Insert popover, you won’t see a gallery. Instead the figure will be inserted instantly into the idea
space with its default styling.
There are options for the collection figures such as lists and mind maps, as well as menu items for Web Views and Google Docs
views. Plus submenus for variables and date/time options.

Insert Other Content
Insert other content into Curio
From the Finder
You can drag files from the Finder or your Desktop directly to your Curio idea space.
By default Curio copies the file and embeds it within your project’s internal asset library. Then appropriate asset figures are created
on the idea space itself, like an image asset figure if you drag in an image file.
If you hold ⌘ (Command) down while dragging you will move the file into your project, therefore removing the file from its original
location.
If you hold down the ⌥ (Option) key while dragging then Curio will create an alias to the original file. When you later double-click
the file to open it on the idea space you will be opening the original file, not an embedded copy. You can always convert aliases to
embedded files at a future date using the Info inspector.
If the dragged-in file has a csv extension Curio will ask if it should be converted into a native Curio table. If the extension is opml,
Curio can convert it to a list or mind map. If the extension is a popular mind mapping file format then Curio can convert it into a mind
map. More details on supported mind map import files are in the mind map section of this manual.

From Curiota
Curiota is a free companion app from Zengobi that opens up even more productivity with Curio. Curiota runs silently in the
background, consumes very little memory, and has a minimal user interface: you just see a simple icon up in the menu bar. Click on
that icon to create quick notes, or drag files and links to the icon to quickly add files. Curiota also supports print services (so you can
“print” to Curiota), works as an macOS Share extension, is accessible via your Services menu, and is easily scriptable. All of the
submitted notes and files are accessible and searchable using Curio’s Local library shelf, discussed below. More information about
Curiota can be found at www.zengobi.com/curiota.

From the Web
If you are running Safari or another web browser you can select images and text and drag them to your Curio idea space.
In most cases, especially for Safari, Curio can determine where the selection came from so we can associate that web URL with the
text or image. In the case of text, Curio will add an attribution line at the bottom of the text stating the source URL for the text.
For images, you can right-click on the image and choose Open URL with Browser to jump to its source location.
If you drag in a YouTube or Vimeo video URL from the browser to your idea space, Curio will ask if an embedded video figure
should be created for easy playback.
You can also drag in selections from Sleuth, Curio’s built-in internet research assistant, as it uses Safari’s same web rendering
engine (WebView).

From Mail
You can drag in a message from Mail to embed a copy of the message into your project. When you double-click the message it will
be opened and viewed with Mail. Currently you can’t drag in multiple messages at the same time.
Generally what Curio receives is a file with an eml extension. If you are having problems with the mail client app that opens the
message, say you’d like it to be Outlook for example, then drag a message to your Desktop, use the Finder to Get Info on it and
make sure the ‘Open With’ selection is set to your mail client. Click ‘Change All’ so that all files with that extension are opened with
the appropriate client app.
The IBM Notes email client is a bit odd so we have a workaround. First drag the mail message to your Desktop and a dialog will
appear asking if you want the full file or a link. Choose a link which will create a inetloc file on your Desktop. Then hold down the
Command key and drag that file into Curio which will move the item from your Desktop into your project.

Insert Other Content (2)
Insert other content into Curio
From Contacts
You can drag in people and other contacts from Contacts (or Lion’s Address Book) to embed copies of the contact information into
your project. When you double-click the contact it will be found and viewed within Contacts, if not found then Contacts will ask if you
want to add it.

From Calendar
You can drag in events from Calendar and copies of the event will be embedded into your Curio project.
Curio will maintain a link to the original event in Calendar, if possible. Double-click the Calendar event figure to open Calendar and
display details about the event. If Calendar cannot find the event, it will offer to add it as a new event. This is useful if you want to
share events with other users by sending your Curio project to them.
Note: Calendar entries are found via the event name. To ensure correct operation, entries in Calendar that are added to Curio
should have unique event names. Once added to Curio you can rename the title of the figure Curio creates to anything you want,
but the event in Calendar must keep its original name.

From a LinkBack Application
You can paste content copied from any application that supports LinkBack, such as OmniGraffle, directly into your idea space. The
content will be displayed in the idea space as it would appear in the other application and when you double-click the figure, Curio
will automatically launch the other application to allow you to edit the content.
In the LinkBack-enabled application, copy the content you wish to add to an idea space. then, in Curio, choose Edit > Paste from
the main menu to paste the content into the selected idea space of the active project.
The LinkBack data was passed in on the clipboard and is stored with the figure itself—there is no file to import or export.
A visual representation of the content will be added to the idea space. Double-click on the figure to launch the other application and
edit the related-content. When you save your changes within the other application, they will automatically be reflected within your
idea space.

From an Equation/Formula Editor
There are many popular equation and formula editors that work quite well with Curio.
Grapher
/Applications/Utilities/Grapher.app - Grapher is actually bundled with macOS and does a very good job creating equations as well
as 2D and 3D graphs. Enter equations into the main formula area of the Grapher window. Use the Equation Palette (via the Window
menu) to assist with this process, and choose Help > Grapher Help > Shortcuts to learn about their handy equation-entering
keyboard shortcuts. Once you have entered your equation you can select the equation itself and copy it to the clipboard where it is
stored as a PDF image. Paste that PDF image into Curio and you have a perfectly rendered equation which can be scaled to any
size while maintaining full legibility. You can also graph your equation in Grapher, of course, and then copy that as PDF and place
that into your Curio idea space, as well.
LaTeXiT http://www.chachatelier.fr/latexit/
LaTeXiT uses the LaTeX engine to generate equations. Simply generate your equation in LaTeXiT and use Edit > Copy to copy it to
the clipboard then paste it into Curio. The result is actually a PDF image so it resizes cleanly to any dimension. LaTeXiT supports
LinkBack so you can double-click your equation in Curio to continue editing it in LaTeXiT and save the equation to automatically
update its rendering within Curio. Note that drag-and-dropping the equation from LaTeXiT into Curio does not include the LinkBack
information.
MathType http://www.dessci.com/en/products/mathtype/
MathType can copy PDF renderings of the equation which can be pasted into Curio. The free MathType Lite can generate PNG
images for pasting, although resizing isn’t as clean as PDF.
MathMagic http://www.mathmagic.com
MathMagic is available in several editions. Like MathType, generating and pasting a PDF representation of an equation is always
preferable to a bitmap such as JPG or PNG.

Inserting from OneNote
Bring in your OneNote lists!
OneNote List Support
Via Paste As > List and Paste As > Mind Map, Curio can create lists and mind maps from lists copied in from Microsoft's popular
OneNote product. To do this, Curio's parser carefully strips out OneNote's existing prefixes so you end up with just the list items
themselves.
For example, if you copy a numbered list from OneNote that used with roman numerals surrounded by parentheses, like (iii), then
Curio's Paste As > List will now cleanly remove those prefixes so that Curio's list code can take over the enumeration.

Supported OneNote List Prefixes
Examples: 1., 1), (1), 1st, 1Rule:
An optional "(" then a 1 to 3 digit number then an optional "st", "nd", "rd", or "th", then an optional ")" or "." or "-" then
whitespace.
Examples: i., iv), (X), xxviii.
Rule:
An optional "(" then a 1 to 6 digit roman numeral then an optional ")" or "." then whitespace.
Examples: a., b), (C), DD.
Rule:
An optional "(" then a 1 to 3 digit letter then an optional ")" or "." then whitespace.
Examples: -, •, ○, §, ·
Rule:
A single punctuation then whitespace.

Inserting from TaskPaper

STANDARD

PRO

We love TaskPaper!
Import a TaskPaper File
Drag-and-drop a TaskPaper file directly into Curio Standard or Professional and it can be converted into a list or mind map, or
simply inserted as a file asset figure, including any meta tags as mentioned in Importing Meta. In addition, any TaskPaper line
entries that aren't tasks (that is, don't start with a -) will be considered as figure notes for the previous line item.

Dragging in a TaskPaper Project Outline
In TaskPaper, drag a project line's dot (located on the left side of the project's title) directly into your Curio idea space to instantly
create a Curio to-do list, akin to importing a TaskPaper file described above. You can optionally right-click on the list to turn it into a
mind map, if you wish.

Pasting a TaskPaper List
You can also do this via copy and paste. In TaskPaper, simply copy a list of task items then paste into Curio using Edit > Paste As >
List. If a project line is copied then it will become the title of the resulting list, and task items will turn into Curio list items. Any meta
tags will be handled automatically.

OmniFocus Tip
OmniFocus supports TaskPaper integration so that means it plays well with Curio's new TaskPaper features as well!
Specifically, if you use OmniFocus's Copy as TaskPaper feature to copy a selection of tasks as TaskPaper tasks, then Curio will
parse the @defer tag as an alternate to the usual @start tag.

Exporting as TaskPaper
Curio can export to TaskPaper as well!

Inserting from OmniOutliner

STANDARD

PRO

The Omni Group’s awesome outliner!
Working with OmniOutliner via OPML
Drag an OmniOutliner-generated OPML export file into your Curio idea space and it can be converted into a list or mind map figure.

OmniOutliner Pro Super Powers
OmniOutliner Pro supports custom named columns and, when exported as OPML, those turn into data fields that Curio can import!
Curio will look for specifically named columns in that OPML export and convert that info into meta data.

Notes
•
•
•
•

•

Curio also parses OmniOutliner's _status="checked" entry that indicates a checked figure.
Each column name can be customized by clicking on its link below.
Specified tags and resources must already exist in the project. They will not be automatically added.
The default date format is the "short" format listed in System Preferences > Language & Region > Advanced > Dates, thus like
12/25/18 for US but 25/12/18 for Europe, but can be customized. A time is optional, but the default time format is the 24-hour
format like 15:45, but can be customized.
Duration abbreviations for year, month, week, day, hour, minute can also be customized.

Column Name

Values

Description

Progress

A number from 0 to 100.

The figure’s percent complete. As a note, if a node has children then Curio
ignores its Progress value and instead rolls it up from the Progress values
set to its child nodes.

Rating

A number from 1 to 5.

The figure’s rating value (number of stars).

Priority

A number from 1 to 5.

The figure’s priority value from 1 meaning urgent priority to 5 meaning very
low priority.

Start

A date with or without time value.

The figure’s start date.

Due

A date with or without time value.

The figure’s due date.

Duration

A duration string, like 2w.

The figure’s duration.

Tags

A comma separated list of tags.

The figure’s tags. Tag name only or with tag set prefix:
Like, Context.Home, detailed tasks.in flight.

Resources

A comma separated list of resources.

The figure’s resources. First or full name:
george, steve jobs

Importing Meta

STANDARD

PRO

Automatically importing meta info
Importing Meta
Special meta text tags are now parsed and extracted when:
• Importing markdown lists and tables via .markdown files or the Edit > Paste As Markdown > menu (disable).
• Pasting any type of non-markdown text as lists, mind maps, or tables via the Edit > Paste As > menu (disable).
While a meta tag can appear anywhere in the text, a space must prefix each @meta item!
For example, if you Edit > Paste As > List some text that looks like this:
Dev Tasks
Code product. @progress(75) @priority(1) @due(2018-02-28) @resources(George)
Then Curio will create the following list:

Dev Tasks
7/28
1.

Code product.

Meta Output

Values

Description

@progress(50)

A number from 0 to 100

The figure's percent complete.

@done

None

From TaskPaper, indicates the task is 100% complete (enable).

@done(2018-04-25)

A date with or without a time value

The figure’s done date.

@rating(3)

A number from 1 to 5

The figure's rating value (number of stars).

@priority(1)

A number from 1 to 5

The figure's priority value from 1 meaning urgent priority to 5 meaning very low priority.

@start(2018-04-15)

A date with or without a time value

The figure's start date (custom date and time format).
Note that @defer is also supported as an alternate for OmniFocus support.
The date determination is set to manually specified since you are specifying a specific date.

@due(2018-04-25 20:00)

A date with or without a time value

The figure's due date (same customizations).
The date determination is set to manually specified since you are specifying a specific date.

@duration(2w)

A duration string

The figure's duration. Normally the duration is simply extracted out of the text and not used to set the duration
value, since Curio usually uses the start and due dates to automatically determine durations. However you can
enable durations and the duration will be set for the figure. The abbreviations for year, month, week, day, hour,
minute can all be customized.

@tags(Home, NextAction)

A comma separated list of tags

The figure's tags. You can specify a tag either with just its name (Home), and Curio will find it, or the tag set and
the tag name (Context.Home). Curio ignores case when searching. Note that tags must already exist and will not
be added dynamically. You can also enable tag parsing for @-signed tags like @Home @NextAction or #-signed
tags like #Home #NextAction. However note that no spaces are allowed in a tag so you need to concatenate
them together, like @DetailedTasks.InFlight.

@resources(George, Greg)

A comma separated list of resources

The figure's resources. You can enter your resource names either with just first names or full names, with or
without spaces or underscores, and Curio ignores case when searching, so all of these would work: george,
george_browning, George Browning, GeorgeBrowning. Note that resources must already exist and will not be
added dynamically. You can also enable tag parsing for @-signed tags like @George @Greg. However note that
no spaces are allowed in a name so concatenate or use an underscore.

Insert from Library
Bring in files from Curio’s Library shelf
The Library Shelf
Files stored in Library shelf can be dragged into your idea space, as well.
Project Library
When dragging items in from the Project library, the result will be another asset figure instance of the dragged asset, that is the
asset will only exist once in the project’s internal library and your new asset figure will simply point to it.
Local Library
When dragging items in from the Local library, the file is copied into your idea space. If you hold down the ⌘ (Command) key while
dragging then the file will be moved into your idea space, therefore removed from its original location.
Sleuth Library [Standard] [Pro]
Once you complete a search in the Sleuth library you may be able to drag the results, say an image or some text, into your idea
space, depending on the site being searched.
Evernote Library [Standard] [Pro]
When dragging items in from the Evernote cloud library, the file is downloaded and copied into your local asset library. If you hold
down the ⌘ (Command) key while dragging then the file will moved into your idea space, therefore removed from the Evernote
cloud. If you hold ⌥ (Option) while dragging then an alias to the Evernote note will be created such that double-click the alias will
open the note within the Evernote Mac app.

Spread PDF

STANDARD

PRO

Supercharge your PDF annotations
Using Spread PDF
Curio Standard and Professional have a special feature you can use with PDF assets called Spread PDF. If you have a multipage
PDF file that you would like to spread across a single idea space or across multiple idea spaces, Curio makes it super simple. This
feature is mainly used when taking notes alongside slides or annotating the slides in a PDF presentation.
You can spread a PDF across a single idea space. This is useful when spreading a short PDF or only the first few pages of a longer
PDF to prepare it for spreading across multiple idea spaces.
You can also continue a spread across multiple idea spaces if you have an especially long PDF.

Spread PDF Within This Idea Space
1. Create a new idea space or use an existing idea space.
2. Drag the PDF into the idea space.
3. Resize and position the PDF figure any way you wish. If you wish, create a text figure for text annotations and/or a list figure for key points or questions then
place those next to the PDF with some placeholder text.
4. Select those figures then right-click on the selected figures and choose Spread PDF Within This Idea Space.
5. You can then enter in how many columns and rows of the pages you’d like to create, plus the spacing gap between those columns and rows.
6. Curio will duplicate the figures and spread them across then down the idea space, growing the idea space as necessary, where each PDF figure instance shows
the subsequent page in the PDF document. After the process is completed you can move the figures around manually if you wish.

Spread PDF Across Idea Spaces
1. Begin just like spreading a PDF file across a single idea space, as described above. Note that this idea space you create will be used as a template when
creating the subsequent idea spaces. Any other figures that you add to this idea space will be replicated on all the other idea spaces.
2. Right-click on the idea space in the Organizer and choose Spread PDF Across Idea Spaces.
3. Curio will generate a copy of the idea space as many times as needed to show all the pages in the PDF.

Instant Document Templates
Insert frequent documents as templates
Using Instant Document Templates
You can insert new documents of any type from within an idea space using document templates. This comes in handy when you
want to quickly expand upon some ideas in a new TextEdit document or perform some advanced drawing in a new Photoshop
document.

Create a New Instant Document in an Idea Space
1. Choose the document you wish to create from the Insert > Instant Document submenu.
2. A copy of the chosen template document is automatically embedded in your project and added to the current idea space. Simply double-click the document to
launch it in its native application.

Add Custom Entries to the Instant Document Menu
1. You first need to create a document that you wish to use as a template. Launch the appropriate application, such as Photoshop or Word, then create a new
document and save it anywhere on your hard disk. The name of this file will be used as the template name later in step #3. Alternatively, if there’s an existing
document you wish to use as a template then you can skip this step.
2. Choose Insert > Instant Document > Add File as Instant Document from the main menu.
3. In the Open dialog, locate and select the document you wish to add as a template and click the Add button.
4. A copy of the document you selected is created in your Home directory's Library/Application Support/Curio/External Document Templates folder. The document's
name is also added to the document templates submenu.
5. You can create multiple template documents of the same type, but make sure they have descriptive names so you can tell them apart in the document templates
submenu.

Remove Custom Entries from the Instant Document Menu
! Choose Insert > Instant Document > Remove Instant Document from the main menu, and then choose the template to remove and click Remove.

Select Tool
Use Select to select figures and more
Using the Select Tool
In the toolbar you’ll find a small palette of tools, appropriately labeled “Tools”. This palette contains the toolbar you’ll use to
manipulate figures on the idea space and easily create a few new items as well.
The select button looks looks like a standard mouse pointer. This is the default tool and is automatically chosen if you press the
Escape key on your keyboard.
With the select tool you can click on figures and select them for modification.

Selecting a Figure
! With the Select tool active simply click on a figure. A glow will appear around the figure and resizing handles will appear on the figure if appopriate.

Selecting Multiple Figures
1. Generally you can hold down the ⌘ (Command) key while selecting items.
2. If you have a collection with a series of items, like the siblings in a list or mind map, then you can select one then hold Shift and select another and you will select
the range between the first and last selected item.

Drag Selecting Figures
! Normally when you drag out a region with the select tool Curio will select both figures and any sketches you made with the brushes or pens. However, if you hold
the ⌥ (Option) key then only figures will be selected. Hold both ⌘ (Command) and ⌥ (Option) and then only sketches will be selected in the resulting region.

Insert a New Text Figure Using the Select Tool
! Double-click anywhere in the idea space to create an automatically sized text figure, or double-click-drag the mouse to define a specific width for the new figure.
Press Escape when you’re done editing the text figure.

Edit an Existing Text Figure Using the Select Tool
! Double-click on the text figure to begin editing. Press Escape when you’re done editing the text figure.

Text Tool
Use the Text tool for text creation and editing
Using the Text Tool
In the toolbar you’ll find a small palette of tools, appropriately labeled “Tools”. This palette contains the toolbar you’ll use to
manipulate figures on the idea space and easily create a few new items as well.
The text tool button looks like a little ‘A’. You can press the T key on your keyboard to quickly choose this tool.
While the Select tool can be used to edit figure, if you plan to edit lots of text figures using the text tool may be more convenient as
you only need to click once to create and edit text figures.

Session Style
If, after clicking the text tool but before clicking on the idea space, you change any text attributes using the various inspectors then
those attributes will be stored in-memory as the session style for the text tool.
For example, click the text tool then use the inspector to make the text bold with a red color. Then when you click on the idea space
you’ll create a new bold-red text figure. Later, when you use the text tool again, you can create another bold-red text figure.
These style changes are just for the current session of Curio, they aren’t stored to disk. To make permanent styles you should use
Curio’s figure style feature.

Insert a New Text Figure Using the Text Tool
! Click anywhere in the idea space to create an automatically sized text figure, or click and drag the mouse to define a specific width for the new figure.

Edit an Existing Text Figure Using the Text Tool
! Click on the text figure to begin editing. Press Escape when you’re done editing the text figure or click on another to begin editing that figure.

Line Tool
Super fast line creation
Using the Line Tool
The line tool button looks like an angled line. Click and hold on the line tool button to bring up a quick list of common lines including
nondirectional, unidirectional, and bidirectional. You can press the L key on your keyboard to quickly choose the line tool; repeatedly
press L to cycle through the line choices.
Use the line tool to go into a line drawing mode useful when drawing lots of lines, for example when connecting several figures
together with the sticky lines feature.

Drawing a Line
1. Click on the Line tool in the toolbar.
2. Change any attributes such as color or arrowhead shape that you wish to make the default for this line using the Shape inspector, discussed below.
3. Click and drag an area on the idea space to draw the line.
4. Repeat step 3 to draw multiple lines using the same style.

Drawing a Multipoint Line
1. Draw a line as described above, however, before you release the mouse button hold down the ⌥ (Option) key. When you release the mouse you'll find that
you've dropped a midpoint and now you're placing a new endpoint. Continue holding down Option to keep dropping midpoints as you release the mouse. If you're
done, just release the Option key before you drop your last point.
2. Repeat step 1 to draw multiple multipoint lines using the same style.

Adding and Removing Midpoints
! Right-click on a line to quickly add a midpoint at the given click location. Right-click on a midpoint to remove it.

Styling a Line
1. Use the Shape inspector to change the pen color (aka border color) and pen pattern.
2. Use the Line inspector with more options specific to lines such as scaling, and head and tail arrowheads.
3. Right-clicking on a line allows you to quickly change multipoint lines between straight, curved, and orthogonal line styles.

Sticky Lines
1. Make sure Sticky Lines is checked in the Arrange menu. If not, select it to enable the sticky lines feature.
2. Drag the endpoint or midpoint on the line.
3. As you hover that point over another figure, the figure will glow. The glow determines how the line will stick:
a. Closest Connection Point
If you hover the point near the edge of the figure, you’ll see the figure glow purple and the connection points for that figure will be displayed along the edges.
Releasing the mouse will dynamically connect the line to the closest connection point even if the figure is rotated or moved.
b. Specific Connection Point
Hover over a specific connection point to stick it directly to that point even if the figure is rotated or moved.
c. Towards the Center
If you hover the point closer to the center of the figure, it will glow green indicating that the line will be connected against the edge of the figure pointing
towards the figure’s center.
d. Specific Position
If you press the Command key while hovering the point over the figure, it will glow orange and you can connect the line to a specific position on the figure.
Note the position will scale appropriately if the figure itself is scaled. Also note that if you stick a line to a position on another line it will also scale if the line is
scaled.
e. Non-Sticky Point
If you press the Control key the figure will stop glowing and the line will not stick to the figure at all. The Control key temporarily disables the sticky feature.
4. As described above for multipoint lines, if you also hold down the ⌥ (Option) key during the creation of a new line then you can create a multipoint line on-the-fly
where any of the points on that line can be stuck to other figures using the normal sticky techniques. Note this Option key trick only works when dragging out
brand new lines, not editing existing lines.

Adding a Label to a Line
1. Double-click on a line figure to create one or more text figures which can act as line labels. These text figures are just like regular Curio text figures, thus they
support the same formatting features, but they are stuck to the line.
2. You can slide a text figure up and down along the line using the mouse or the arrow keys to reposition it. Using the arrow keys on the keyboard is generally more
accurate especially for curved lines. You can also hold Shift while pressing the arrow keys to move the label in larger steps.
3. To remove the label, select it and press the Delete key.

Shapes Tool
Dozens of geometric shapes
Using the Shapes Tool
The shape tool button looks a geometric shape. You can press the F key on your keyboard to quickly choose this tool.
With the shape tool you can easily create figures such as rectangles, rounded rectangles, circles, octagons, hexagons, trapezoids,
brackets, vertical brackets, triangles, diamonds, semicircles, ovals, underline, speech bubbles, and clouds.
Using the shape inspector you can always change a shape to any other geometric figure, as we’ll detail in the sections ahead.
The shape tool on the toolbar has an arrow located in the lower right portion of the button. When you click and hold the mouse on
the button a menu displays the list of predefined shapes you can choose. Once you choose a shape, your choice is reflected by the
button's image. Simply clicking the button will reselect the displayed shape.

Adding Text
You can add text to a shape simply by double-clicking it. Note that these figures are considered freeform shapes where you control
the width and height. Therefore text can be clipped if the figure dimensions are not large enough. Any contained text is centered
both horizontally and vertically within the shape. You can toggle off the freeform sizing using the figure’s right-click context menu or
the the Paragraph inspector.

Additional Shapes
As you’ll learn more about later, the shape inspector allows you to modify a corners attribute of the figure. For a rectangle, this turns
it into a rounded rectangle. But for other shapes the change may be more dramatic. More details later when we discuss the shape
inspector.

Drawing a Shape
1. Click on the Shape tool in the toolbar (hold the button down to display a popup menu of shape choices).
2. Change any style attributes that you wish to make the default for this shape using the Shape inspector.
3. Click and drag an area on the idea space to draw the shape.
4. Repeat step 3 to draw multiple shapes using the same style.

Scribble Tools
Freeform sketching within Curio
Using Brushes, Pens, and the Eraser
These tools are covered in greater detail in Scribbles.
Scribbles

STANDARD

PRO

Freeform sketching
Using Brushes, Pens, and the Eraser
For Curio Standard and Professional customers, the tools palette includes a brush and eraser tool so you can sketch out an idea or
drawing.
Inevitably, while brainstorming or thinking through an idea, you may need to sketch something out when the keyboard just won’t do.
Fortunately, Curio has a scribble mode with sketching tools built right in, so you don’t have to stop and launch another application
when inspiration strikes.
Curio comes with several pens and brushes to use when drawing, including a pencil, ballpoint, felt tip, paint brush, and highlighter.
Each stylus has different settings for color, line thickness, and opacity that have been configured to mimic the real world object that
it represents. Using the inspector you can change the color, brush thickness, and opacity of any stylus.
Many of the styluses are also fully pressure-sensitive when used with a graphics tablet, such as a Wacom or an iPad with Apple
Pencil connected via the macOS Sidecar feature, whereby the brush size and color saturation may change while you are drawing
based on the pressure applied to the pen.
You can press the B key on your keyboard to quickly choose the brush tool. Press E to choose the eraser.

The Scribble “Onionskin”
While sketching, your scribbles will appear on top of all other figures and items on the idea space. The scribble layer acts as an
onionskin appearing on top of your idea space.

Draw with a Pen or Brush
1. Click on the Brush tool in the toolbar and choose the brush or pen you want to use. Note for super-responsive mouse handling the idea space will temporarily go
into Quick Render mode where shadows are hidden and text rendering is optimized.
2. You can quickly choose a color from the narrow color palette in the inspector bar or the much larger color palette in the inspector shelf. On the far left of the
inspector bar’s color palette, or at the top of the inspector shelf’s palette, you can see the current, active color. If you click that color control then you can bring up
Apple’s standard color picker to choose any color.
3. Begin drawing in the idea space. While in scribble mode, you can continue to change the brush attributes or choose a different brush or pen from the inspector
bar.

Erase a Portion of Your Drawing
1. Click on the Eraser tool in the toolbar or inspector bar and “draw” where you want to erase. You can even change the size of the eraser using the inspector.
2. Alternatively, you can use the Select tool in the toolbar to drag-select a region then press the Delete key to delete it. You can hold down the ⌥ (Option) and ⌘
(Command) keys while dragging to select only your scribble and not any figures or other items on the idea space.
3. Lastly, if you are using a graphics tablet that has a pen with an eraser tip, you can simply turn the pen over to erase a portion of your drawing.

Convert a Scribble to an Image Figure
1. Using the Select tool in the toolbar drag-select a region. You can hold down the ⌥ (Option) and ⌘ (Command) keys while dragging to select only your scribble
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Workflow

Basic Operations
Working with figures
Select One or More Figures
! Using the Select tool, click on a figure. Select additional figures by holding ⌘ (Command) or use the Shift key to select a range of figures in a collection. Or use
the Edit > Select All menu item to select all figures on the idea space or within the active collection figure.

Adjust a Figure Location
1. Simply drag the figure using the mouse to the new location on the idea space.
2. Or use the arrow keys to move figures around. Hold Shift to move in greater increments. If an idea space grid is active then the figures will move based on the
grid spacing.
3. Or use the Geometry inspector to set a specific value.

Adjust a Figure Size
1. Drag on the handles that appear around the border of a selected figure.
2. Or use the Geometric inspector to set a specific height or width.
3. If a scaled image figure then you can press the N key or click the Natural Size in the Geometry inspector to reset the image to its unscaled size.
4. If an image figure then by default resizing is proportional. This can be toggled in the Geometry inspector or by holding down the Shift key while resizing.

Rotation
1. Hold ⌘ (Command) while dragging a resize handle to rotate the figure.
2. Or, to quickly rotate a figure in 45° increments, simply press the R key (hold down the Shift key to rotate the figure in a clockwise direction).
3. To quickly set the rotation angle of a figure to 0°, press the Z key.
4. You can exert more control over the exact rotation angle and rotate multiple figures at once by using the controls of the Geometry Inspector.

Image Flipping
1. Select an image figure.
2. In the Geometry inspector, in the Arrange panel, click the “Flip Horizontal” or “Flip Vertical” button.

Moving a Figure in Front to Back Ordering
1. Select the figure.
2. Choose Arrange > Send Backward or Arrange > Bring Forward to move a figure one position closer to the front or back of the stack. Choose Arrange > Send to
Back or Arrange > Bring to Front to move a figure to the very bottom or top of the stack. Toolbar buttons are also available for this via Customize Toolbar.

Grouping and Ungrouping Figures
1. Select the figures you wish to group.
2. Choose Arrange > Group from the main menu.
3. To ungroup figures, select the group and choose Arrange > Ungroup from the main menu.

Locking and Unlocking Figures
1. Select the figures you wish to lock.
2. Choose Arrange > Lock from the main menu. This will lock both the content and position by default.
3. Alternatively, you could choose a subitem — Content or Position — to lock just one of those attributes.
4. When a figure with any lock attribute is selected it will have a thin, gray glow. If only the text content is locked, it will show selection handles as well, since the
figure can still be moved and resized.
5. To unlock a figure choose Arrange > Unlock to remove all lock restrictions.

Using Snap Guides
! Choose Arrange > Show Snap Guides from the main menu. You can toggle the appearance of edge and center snap guides independently by choosing Arrange
> Edge Snap and Arrange > Center Snap from the main menu.

Align Figures
1. Select the figures you wish to align.
2. Choose one of the alignment options from the Arrange > Align submenu, or use the buttons in the Geometry inspector.
3. If only a single figure is selected then it will be aligned within the idea space itself.

Distribute Figures
1. Select the figures you wish to distribute.
2. Choose one of the distribution options from the Arrange > Distribute submenu, or use the buttons in the Geometry inspector.

Text Figures
Let’s add some text
Create a Text Figure
1. With the Select tool, double-click anywhere in the idea space to create an automatically sized text figure, or double-click-drag the mouse to define a specific width
for the new figure.
2. Or, with the Text tool, single click anywhere in the idea space to create an automatically sized text figure, or click-drag the mouse to define a specific width for the
new figure.

Style a Text Figure
1. Using the controls on the inspector bar or inspector shelf to style your figure.
2. You can also set options such as enabling a minimum height or freeform sizing.

Stop Editing a Text Figure
! Press Escape or click on the Select tool when you’re done editing the text figure.

Access the macOS Ruler
! While editing text figures you can use the standard macOS ruler for additional options. Toggle the ruler visibility using the View > Show Ruler menu item. The
ruler includes tab stops and controls for text styles, alignment, spacing, and simple text lists.

Text Figures with Markdown
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Curio supports markdown syntax!
Markdown
Curio can render markdown rich text syntax if the markdown button on the inspector bar or inspector shelf is enabled.
While editing the text figure you will see the raw markdown syntax, but when you finish editing Curio will render it on the fly.
Markdown's escaping syntax is supported via the backslash character. So, for example, \*this will not be in italics\*.
Curio supports on-the-fly rendering of the following markdown rich text syntax:
Attribute

Example

Markdown Rendering Enabled

Here is an example

Italic

*italic* or _italic_

italic or italic

Bold

**bold**

bold

Double-click this figure so you can see the raw
markdown syntax.

Bold and Italic

***bold and italic*** or ___bold and italic___

bold and italic or bold and italic

Underline

__underline__

underline

Strikethrough

~~strikethrough~~

strikethrough

Monospace

`monospace`

monospace

Inline Links

[Zengobi](https://www.zengobi.com)

Zengobi

Headers

# header 1
## header 2
### header 3
#### header 4
##### header 5
###### header 6

header 1
header 2
header 3
header 4
header 5
header 6

Here is some text.

Block quotes

> This should be quoted. Here is more of this
quote.
> And this is with it.
That’s it!

Code blocks

```
// Hello world!
import Swift
print(“Hello world!”)
```

Here is some text.
This should be quoted.
Here is more of this quote.

Press Escape when you’re done and Curio will
render the markdown on the fly!

A Simple List
! Flight tickets
◦ Are we on Southwest this time?
! Hotel confirmation number
◦ 83729293
! Don’t forget passports!

A Mixed List
1. Pack bags
1. Get new swimsuit
2. Sunscreen
2. Reserve rental car
◦ Ask Dan for suggestions
◦ Get a convertible!
3. Put newspaper and mail on hold.

Curio Professional
customers check
out Master
Markdown Styles!

Note you can mix your markdown’s rich text syntax
with text with normal styled text. For example, use
markdown’s bold or bold the text directly.

And this is with it.
That’s it!
// Hello world!
import Swift
print(“Hello world!”)

Curio Markdown Limitations
1. Curio's text figures cannot render inline markdown tables or images.
a. However, Curio's native list, mind map, stack, table, and image figures can import and export as markdown directly!
2. Curio’s link parsing cannot handle URL’s with parentheses, as those are nested within markdown’s link syntax parentheses.
a. This is a complex problem to resolve as inner parens may not be paired - that is, you could have an uneven number of left vs.
right parens - and regex parsers can’t handle this very easily. A workaround is to escape the left and right parenthesis with
%28 and %29, respectively. Thus instead of this markdown:
[Set](https://en.wikipedia.org/wiki/Set_(mathematics))
You would do this instead:
[Set](https://en.wikipedia.org/wiki/Set_%28mathematics%29)
3. Please note that Curio's text figures are not meant to be a replacement for a full-featured markdown editor like Marked and
MultiMarkdown Composer. Those apps can convert much more complex markdown into HTML, apply customizable CSS style
sheets, and render the results in a web view, as opposed to a text view.
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Text Figure Attachments
Adding attachments to text figures
Text Figure Attachments
Curio allows you to attach a file to a text figure.
If the file attachment is an image file type, then the resulting attachment will be displayed as a preview image, otherwise for other
file types a thumbnail icon will be displayed for the attachment image. The size of the image or icon is controlled using the Icon Size
slider in the Shape inspector popover's Options tab.
As with preview captions, the attachment is an actual component of the text figure, not a trick using a grouped figure. This feature is
particularly useful in mind maps where an attachment can be associated with an existing node in the mind map instead of added as
a separate child node.

Attach an External File Located on Your Hard Disk to a Text Figure
! Right-click on a text figure and choose Attach File then choose a file from anywhere on your hard disk in the dialog that appears. This file can be copied or moved
into the project as an embedded asset or referenced as an alias.

Attach an Image from Outside of Curio to a Text Figure
1. Copy an image from outside of Curio, perhaps from Safari for example.
2. Right-click on a text figure and choose Paste As > Attachment For Selected Text Figure. The image will be added as a new asset to your project and will be
displayed as an attachment for the text figure.

Attach a Existing Asset to a Text Figure
1. Select an existing asset figure on an idea space or an asset in the Library and copy it to the clipboard.
2. Right-click on a text figure and choose Paste As > Attachment For Selected Text Figure. Here the attachment will simply reference the same underlying asset.

Change the Size of the Attachment Icon
! Use the icon size slider in the Display panel of the shape popover inspector.

Remove a Text Figure Attachment
! Right-click on a text figure and choose Remove Attachment.

Multimedia Figures
Movie and audio figures
Working with Multimedia Figures
You can play back QuickTime movies, VR animations, music, and sounds directly within an idea space.

Media Bar
When you click on a multimedia figure notice the media bar that appears on the right side of the inspector bar next to the navigator
bar.
The media bar can be used to control playback of the multimedia figure with common operations like play, pause, fast forward, and
rewind. If you need more control of the playback then right-click and choose Open With Finder to open the media file in QuickTime
Player.

During Playback
If the media asset figure is rotated, then it will automatically change to a 0º angle of rotation for playback, then return to its original
rotation angle when playing stops.

Inline Movie Controls
Inline movie controls appear briefly on top of the media playback when it first starts and if you move the mouse over it. You can use
these controls to scrub to a specific location.

AVKit and Legacy Media Formats
Curio uses Apple’s modern AVKit framework to handle media playback. While AVKit supports most modern media types it may not
support older formats supported by QuickTime or installed QuickTime extensions, so you may have to open those media files via
the right-click context menu's Open with Finder option. Alternatively, you can use the macOS tool qtmodernizer to convert your
legacy media files to a modern, supported format and then add those converted files into your Curio projects.

Media Bar Actions Menu
The media bar also has an actions menu with additional functionality:
•

•
•
•
•

Start Time
During playback of a movie or audio file, pause the playback then, if necessary, use the time scrubber (or arrow keys) in the
media player's overlay controls to find a precise moment. Then use the Media Bar actions menu to set the current time as the
new starting time for the media file.
Stop Time
Similarly you can specify a stop time for the movie or sound file.
Loop
You can specify that the media playback continuously loops during playback.
Poster Frame
You can set a new poster frame for a movie, which is displayed before the movie begins playing.
Copy Frame
You can use the Media Bar actions menu to grab the current frame of a movie as an image for pasting within your idea space or
elsewhere.

Playing a Video or Audio Multimedia Figure
1. Double-click the figure to begin playback, or click the Play button on the media bar.
2. To stop playback, click the Stop button on the media bar.

Web Figures
So many ways to add info from the web
Weblink Figures (aka URL Figures)
Drag a weblink from your browser’s location bar directly to an idea space to create a weblink figure.
By default it is displayed with the website’s icon and title.

Content Menu Options
Right-click on the weblink figure and you some special options:
•
•

•

Web View
You can convert the weblink figure to a live web view of the site. More details below.
Open URL in Browser
You can choose to open the weblink your default browser. This might be handy if you need a full, large browser experience for a
specific site.
Grab Web Archive
Sadly, it looks like Apple pulled support for this functionality from their web view framework when they released macOS 10.15.4.
It worked perfectly here during the 10.15.4 betas but I guess there were some issues. Hopefully it'll come back in a future
macOS update and we can re-enable support for it. For customers on macOS Catalina or above, you can download the
contents of the weblink as a paginated PDF, a PDF image, or a web archive (which can be opened with Safari). Curio is unable
to grab a web archive for sites that require a user name and password entered via popup dialog. Also note that Curio from the
Mac App Store doesn’t support remote, insecure http web links when retrieving web archives.

Web View Figures
If a weblink figure is displayed as a WebView then Curio will construct a live web browser embedded within the idea space render
the web content and permit browsing. If a WebView figure is selected, the inspector bar displays the appropriate web browsing
controls.
Note: The following is for web view figures that exist on an idea space. If you drag a URL to the Organizer then the browsing tools
on the inspector bar are always available as the web view completely fills the content area of the Curio window. For more
information, see the section on Organizer Documents.

Deactivated state
Normally the WebView displays a slightly faded preview of the web URL so you realize that it’s not a live connection to the web site.
The preview was generated and stored the last time you surfed to that location. When in this mode it acts as a normal figure where
it can be easily moved, resized, and various figure attributes can be changed in the inspectors.

Activated state
After clicking the Start Browsing button or by double-clicking the WebView, the WebView is activated and the view is rendered live.
By carefully grabbing the border area the WebView can still be moved and resized. However, you can now interact with the web site
by clicking, dragging, and typing within the WebView. Click Stop Browsing when you are done surfing to the site, this will happen
automatically if you go to another idea space or close the project.

Notes
You are able to browse around within the live WebView and even surf to different locations. However, the default URL associated
with the WebView will stay as-is unless you click the Save URL button in the inspector bar.
You can right-click on the WebView and choose Open URL in Browser to launch the URL in your default web browsing application.
Mac App Store Restriction
Remote, insecure http connections are not supported in embedded web view figures, as Organizer
documents, as Sleuth sites, or during web archive or favicon retrieval. However, you can create
insecure http web link figures and figure actions, which will open in your default browser.

PDF Figures
Annotate PDF’s directly within Curio
Working with PDF Figures
When you drag a PDF file to your idea space Curio will construct a PDFView to render the PDF and permit annotation. If a PDF
figure is selected, the inspector bar displays the appropriate PDF navigation and annotation controls.
Note: The following is for PDF figures that exist on an idea space. If you drag a PDF to the Organizer then the annotation tools on
the inspector bar are always available as the PDF completely fills the content area of the Curio window. For more information, see
the section on Organizer Documents in this user manual.

Viewing State
Normally the PDFView displays the contents of the PDF but the annotation tools in the inspector bar are not enabled. When in this
mode it acts as a normal figure where it can be easily moved, resized, and various figure attributes can be changed in the
inspectors.

Activated State
After clicking the Start Annotating button the PDFView is activated and the annotation controls become available in the inspector
bar. By carefully grabbing the border area the PDFView can still be moved and resized. However, you can now interact with the
PDF by clicking and dragging within the PDFView. Click Stop Annotating or pressing the Escape key when you are done annotating
the page and the updated PDF will be saved to disk.
If you need more annotation tools than what Curio offers you can double-click on the PDF figure to launch the PDF file in your
default PDF viewing application. After annotations are made, returning back to Curio will cause the PDF to refresh itself on the idea
space to reveal those new annotations.

What’s an Annotation?
Only the PDF annotation tools on the inspector bar can create annotations that are embedded within the PDF itself. Anything you
create on top of or around the PDF figure using any other Curio features — such as text figures, images, scribbles, lists, mind
maps, etc. — are not stored within the PDF and only exist on the idea space.

Equation Figures
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Using Curio’s integrated equation editor
Equation Editing in Curio
Curio Professional and Standard customers can create and edit equations using LaTeX, AsciiMath, or MathML syntax. Previews are
instantly rendered as you type your equation. The final high quality and scalable PDF rendering occurs in just a few seconds via a
secure process running on Zengobi's server.
(During the macOS Catalina 10.15.4 betas we were able to support instant, local PDF rendering but apparently there were some
issues as Apple pulled support for this functionality from their web framework when they released macOS 10.15.4. Hopefully it'll
come back in a future macOS update and we can re-enable support for it soon.)

Inserting an Equation
To insert an equation into the current idea space:
! Choose the Insert > Equation menu item (⌃⌘E).
! Or click the Insert toolbar button then choose the Equation item.
The equation editor will then appear for you to enter your new equation. As you type, the preview area instantly updates with a
quick rendering of your equation. Use the Help button in the equation editor to see examples and browse references.

Supported Syntaxes
Curio renders your typed equations using MathJax, the de facto standard in web-based equation typesetting for mathematics,
science, and engineering. MathJax allows you to type that in one of three standard equation syntaxes:
! LaTeX → x=\frac{-b\pm\sqrt{b^2-4ac}}{2a}
! AsciiMath → `x=-b+- sqrt(b^2-4ac}/(2a)`
! MathML → <math ...</math>
Of the three, LaTeX is the most popular by far and MathML is the most verbose.

Delimiters
Curio will assume an entered equation is LaTeX unless it finds one of the following in your typed equation:
! $$ → Thus it assumes a LaTeX (technically TeX) equation of the format $$..$$
! \[ or \( → Thus it assumes a LaTeX equation of the format \[..\] or \(..\)
! `` → Thus it assumes an AsciiMath equation of the format ``..``
! <math → Thus it assumes a MathML equation of the format <math ...</math>

Inline Equations
To enter an inline equation use the newer \(..\) syntax like this:
When (a \ne 0), there are two solutions to (ax^2 + bc + c = 0) and they are…

Final Rendering
When you click to insert or update the equation on your idea space the equation is instantly rendered in PDF form on macOS
Catalina or above.
Otherwise, for customers on macOS Mojave, the equation is quickly and securely broadcast to a complimentary service running on
Zengobi's server to perform the final PDF rendering and then inserted into your idea space. Some key points about this procedure:
! This requires a connection to the Internet.
! This is generally very fast, like 1 or 2 seconds, although depends on your connection speed, equation complexity, etc.
! All communication occurs over a secure, encrypted https connection.
! After processing your equation is not stored on the server.

Editing an Equation
Simply double-click your equation on the idea space to bring it back into the equation editor. Then click the Update button when you
finish your changes.

Help with Equations
Click the help button in the equation editor window to see the popup menu displayed here. It includes several examples in LaTeX,
AsciiMath, and MathML form, and includes links to several useful websites for more information.

Idea Graphs
Easy freeform flowcharting
Working with Idea Graphs
Sometimes you need more flexibility than a mind map. Fortunately Curio makes it incredibly easy to quickly create a flowchart or
graph of connected figures.
The automatically created lines described in the following section are true Curio line figures so you can change the line color, dash
pattern, width, and arrowheads using the inspector controls. You can also double-click on a line to add line labels, or right-click on a
line and add one or more midpoints to make it a curved or orthogonal line.

Collection Figures
If the currently selected item is a collection figure (such as a list, mind map, table, or index card) then the created connected figure
will be that same type of collection, assuming the Select tool is active in the toolbar. Using this technique you can quickly create a
connected graph of index cards, for example.
However, if the Text tool is active instead then the created connected figure will always be a text figure. This way you can easily
create a text figure connected to a collection.

Create a New Figure Automatically Connected to a Selected Figure
1. Edit or select an existing figure.
2. Click on the idea space background while pressing one of the following modifier key combinations:
a. ⌘ (Command): directional line (one arrowhead, →)
b. ⌘⇧ (Command-Shift): bidirectional line (two arrowheads, ⟷)
c. ⌘⌥ (Command-Option): nondirectional line (no arrowheads, —)
d. ⌘⌥⇧ (Command-Option-Shift): nondirectional dashed line (no arrowheads,

)

3. A new figure will be created and joined to the currently selected figure with the appropriate line

To Instantly Connect Two Existing Figures with a Line (Non-Collections Only)
1. Drag figure A on top of figure B and, while dragging, press and hold one of the following modifier key combinations:
a. ⌘ (Command): directional line (one arrowhead, →)
b. ⌘⇧ (Command-Shift): bidirectional line (two arrowheads, ⟷)
c. ⌘⌥ (Command-Option): nondirectional line (no arrowheads, —)
d. ⌘⌥⇧ (Command-Option-Shift): nondirectional dashed line (no arrowheads,

)

2. Release the mouse and figure A will move back to its original position and the appropriate line will be created connecting figure A to figure B.

Linking Figures
Connect figures with jump & hyperlinks
Linking Figures Together
Curio has several methods for linking figures together including jump actions, jump anchors, idea space links, and hyperlinks.

Jump Actions
You can assign a jump action to a figure so that double-clicking that figure can navigate to a specific idea space or even a specific
figure — even in another project! The figure will also get a little jump image adornment so it’s clear that a jump action is associated
with the item. You can use the Actions inspector to hide this adornment if you wish.

Jump Anchors
As an alternative to assigning a figure a jump action, you can use a jump anchor to jump to different locations. A jump anchor is a
simple icon you can place anywhere on an idea space. When double-clicked the user will jump to the destination location.

Idea Space Link Figures
You can also create links between idea spaces even from different projects by adding an idea space link figure. When doubleclicked the user will go to the destination idea space.
The new figure will display a preview of the represented idea space unless the represented idea space is the same as the idea
space on which it was placed or is from a different Curio project. If the represented idea space is the same as the idea space on
which it was placed, Curio will display a distinctive “you are here” icon. If the represented idea space is from a different Curio
project, Curio will display a distinctive “external project” icon.

Hyperlinks
You can easily create hyperlinks to figures or idea spaces within a Curio project for use outside of Curio, for example in a browser
web page or another application. These are of the form “curio://“. Clicking one of these links will launch Curio, open the appropriate
project, jump to a specific idea space, and even scroll to a specific figure. Note that since the project path is embedded in the
resulting hyperlink it won’t work if the project is moved or renamed. Instead Curio will ask you to locate that particular project and
then continue with the jump. It will store this prior path to new path mapping so it won’t ask you for the new location in the future.
If you use a Curio hyperlink within the same project then it will store a relative hyperlink without project path information.

Set a Jump Action for a Figure
1. Select your jump destination: either a target figure within an idea space or a target idea space within the Organizer.
2. Choose Edit > Copy from the main menu.
3. Select the figure(s) to which you wish to assign the jump action.
4. Choose Edit > Paste As > Jump Action to set the jump action.
5. If the figure is moved, Curio will still be able to find it and jump to its new location.

Clear a Jump Action for a Figure
1. Remove a jump action by using the Actions inspector and click "Restore Default".
2. This will remove the jump target action and allow the figure to operate like normally (that is, if an image figure double-clicking would open the image, etc).

Add a Jump Anchor
1. Select your jump destination: either a target figure within an idea space or a target idea space within the Organizer.
2. Choose Edit > Copy from the main menu.
3. Go to the idea space where you want to place the anchor.
4. Choose Edit > Paste As > Jump Anchor from the main menu.
5. Curio will create a jump anchor figure. You can click and drag this figure anywhere. You can also copy & paste it, duplicate it, or change its attributes in the
Inspector.

Add an Idea Space Link Figure
1. Drag the idea space from the Organizer of a project window and drop it onto an idea space.
2. A new idea space link figure will be created with a preview of the represented idea space.
3. You can right-click on the resulting figure and choose “Show As Icon” then give the figure an appropriate title like “Click here to learn more”.
4. The icon or preview image will automatically update as the destination idea space changes.
5. When displayed as icon, the title automatically reflects the idea space’s title and dynamically updates if that title is changed. You are able to manually override the
figure's title with your own text if you wish and Curio won't replace it. Later, if you'd like it to reflect that actual idea space title again, simply remove all text from
the figure's title and Curio will replace it.

Create a Hyperlink to an Idea Space or Figure
1. Select an idea space in the Organizer or figure within an idea space and choose Edit > Copy As > Hyperlink.
2. The hyperlink will be added to your clipboard.
3. Use it outside of Curio or even within Curio by selecting text and using the Format > Text > Add Link menu (⌘K). If you use it within a text figure in the same
project then the project path is removed automatically turning it into relative link so it will work even if the project is moved or renamed.

See All References to a Jump Destination
1. Right-click on the jump destination: either the target figure within an idea space or the target idea space within the Organizer.
2. In the context menu, look within the Jumps From submenu to see all originating source figures. These are listed by their name but they also include,
parenthetically, the figure type, owning idea space title, and, if necessary, section path information.
3. Choose one of those referencing figures and you will promptly jump to that figure within the project.
4. Note these references won’t include hyperlinks since those can be placed anywhere even outside of Curio.

References
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Advanced cross referencing
Working with References
Curio Professional customers can create cross references from Curio figures and Organizer items to other Curio figures, Organizer
items, and even web sites using a sophisticated new feature we call references.
These reference connections can be of a specified type, such as a Rebuttal or Evidence, allowing you to create a number of typed
connections between your Curio items, even if they're scattered throughout a project or in different projects.
Compared to regular jumps, a reference is much more advanced, where instead of a simple one-way jump, you can create multiple
types of connections between figures and even Organizer items, creating a graph of typed connections.
A single figure might have references to multiple figures such as two Source figures, three Rebuttal figures, and one Example
figure. Likewise, a figure can have multiple figures that all point to it, such as a figure which is an Agree reference for some figures
(thus a support for those statements), and Disagree reference for others (thus a counterargument).

Defining Reference Types
1. Using the inspector shelf, click the Project tab and then use the new Reference Types inspector panel to see all the available reference types.
2. At the top use the popup to specify whether you want to view and modify (a) bundled reference types that are included with Curio and available to all projects, (b)
custom reference types for all projects, or (c) custom reference types for this project, specifically.
3. Bundled reference types are read-only, however, if there are types you don't think you'll ever use you can uncheck the visible checkbox and they won't clutter
your interface when creating references.
4. With custom types you can edit these names and colors at any time. Uncheck a type if you no longer want it to be available for new references, or delete it via the
Delete key or Delete Type button to remove it permanently.

Adding a Reference
1. Select and copy the figure or Organizer item you want to reference. This is the item you want to refer to.
2. Next select one or more other figures where you want to add a new reference which points to that copied item. Right-click, and in the context menu that appears
choose a reference type in the Add Reference to Copied Item As submenu to create your new reference.
3. The reference connection has now been created, and a reference adornment will then appear beside both the source and destination figure, if within the same
project.

Adding a URL Reference
1. In your browser:
a. Right-click on a link and choose Copy Link, which should also give Curio the title of the page.
b. Or copy the URL location itself (ex: www.zengobi.com/support).
2. Next select one or more other figures where you want to add a new reference which points to that copied URL. Right-click, and in the context menu that appears
choose a reference type in the Add URL Reference As submenu to create your new reference.

Viewing an Item’s References
1. If a figure either has references or is a reference (in the same project) then it will have a special references link adornment. Clicking it will list all references,
grouped and color coded by reference type, and allow you to add or remove references.
2. Alternatively, right-click on a figure or an Organizer item which either has references or is a reference and its context menu will contain a References submenu
identical to the one displayed when clicking an adornment.
3. If you select a reference either referred to or referenced from then you will instantly jump to that figure or Organizer item.

Removing a Reference
1. Click on the references adornment or right-click and choose the References submenu.
2. Within that menu you should see a Remove Reference option so you can select a reference to remove.

Search References
1. You can use the Search shelf to find all figures which include any reference or just those with a specific reference type, such as Agree.
2. When you use the export button on the search results screen, any references associated with a figure are included in the resulting rich text, markdown, or CSV
export.
3. By default, references are included in CSV exports under named columns such as "Agree Reference" and "Disagree Reference". As each figure's row entry is
exported, if the figure includes one or more references of that type then those jump URLs are exported in that column. The search results export button also has
a new menu option, Export Resulting References as CSV, which can be used to export only figure reference information to a separate CSV file with reference
named columns.

Overview
Incredible collections for managing figures
What’s a Collection Figure?
As mentioned above, a collection figure is a special type of figure that contains, manages, and positions figures within it. Curio
includes several bundled collection figures such as list, mind map, table, index card, pinboard, and album collections.
While a collection figure can contain other figures it cannot contain another collection. For example, you can’t place a table into a
mind map or an index card into a list.

Styles
Items created, dropped, or pasted within or into a collection will adopt the style appropriate for destination as determined by the
collection figure. For example, a table style’s information will include the style associated with body cells vs header cells. Likewise,
a mind map style will include stylings for the various hierarchical levels in the mind map. If you drag an item from one location in the
mind map to another location, then it will adopt the styling appropriate for that location.
However, if you want the items to keep their existing styling then hold Shift while dropping or pasting.
See the Help > Curio Advanced Settings if you’d like to change this default styling logic. For example, you can make it so dragging
within a table keeps existing styling but dragging items into a table, from elsewhere, will adopt the appropriate styling.

List
Introducing the list collection
Working with Lists
Making to-do lists and outlining ideas is a natural part of brainstorming. Curio's List tool makes it a breeze to generate lists and
outlines of any kind right on an idea space. And Curio's lists can contain more than just text; you can add images, documents,
movies, sound clips, and any other type of figure that Curio supports.

Context Menu
Right-clicking on a list or a list item will show a context menu with lots of frequent operations so be sure to check it out!

Create a List
! Use the Insert popover to create a list via its style and stencil gallery, or use the Insert menu.

Insert a New Text Figure as a Next Sibling
1. Select a list item.
2. Insert a next sibling by choosing Insert > Text Next Sibling or typing Command-Return. However, following a convention used in other outliners, if the selected
item has a child then this will actually create a new first child.
3. As a shortcut, if you are current editing a list item, you can simply type Return to create a new next sibling. If you want to actually insert a carriage return within
the edited text figure, then type Option-Return.

Insert a New Text Figure as a Previous Sibling
1. Select a list item.
2. Insert a previous sibling by choosing Insert > Text Previous Sibling or typing Command-Shift-Return.
3. As above, you can simply type Shift-Return to create a new previous sibling.

Insert a New Text Figure as a Child
1. Select a list item.
2. Insert a new first child by choosing Insert > Text Child or typing Command-Option-Return.

Remove List Items
1. Select the list items you wish to remove.
2. Press the Delete or Backspace key or choose Edit > Delete.
3. Any children will automatically be removed as well.

Indenting List Items Via Keyboard
1. Select one or more list figures.
2. Press the Tab key to indent the figures one level.
3. To move a set of figures contained by a list figure to a higher level in the hierarchy, follow the same steps listed above but press Shift-Tab on the keyboard.
4. If you want to actually insert a tab within an edited text figure, then type Option-Tab.

Rearranging List Items Via Keyboard
1. Select or edit an item.
2. Press ⌃⇧↑ or ⌃⇧↓ to move the item up or down through its siblings.

Rearranging List Items Via Drag-And-Drop
1. Select one or more list figures and begin to drag them.
2. As you drag the items around, a line will appear showing you where they will be placed in the list, including their hierarchical level. Notice that rearranging an item
with children also moves the children.
3. Release the mouse button to drop the items into the list. If the Option key was held down during the drag then a copy of the selected figures will be created.

Sort List Items
1. By default, you can manually rearrange the child nodes of a list parent via drag-and-drop as described above.
2. However, you can also tell Curio to keep those children automatically sorted by title, creation date, modification date, due date, start date, start date or end date if
already started, percent completed, priority, or rating, in either ascending or descending order. You can specify a secondary sort as well. Make a change to a
figure and instantly the figures rearrange based on the sorting rule.
3. Select one or more sibling items in a list then use the list inspector to select a primary and secondary sort option.

Select Multiple Figures Within the List
! Either use the Shift or Command click to click on individual items, or hold Shift or Command and select a range of figures by clicking and holding on the
background of the list and dragging a rubber band selection region around figures.

Collapse or Expand a List
1. Select the list itself or a branch in the list.
2. Do a quick tap of the spacebar to collapse or expand the list. Alternatively, for branches, you can also click the little expand/collapse widget.

List Import/Export
Getting data into and out of a list
Add New Items to a List Via Drag-And-Drop
1. Select figures from elsewhere in Curio, the Finder, or another application and drag them into Curio onto the list figure.
2. As you drag the items around a line will appear showing you where they will be placed in the list, including their hierarchical level.
3. Release the mouse button to drop the items into the list. If the drag began within Curio, and the Option key was held down during the drag, then a copy of the
selected figures will be created.
4. List figures also support cut, copy, paste, and duplicate for adding and removing figures.

Collect a Selection of Figures into a List
1. Select one or more unlocked figures.
2. Choose Arrange > Collect Into > List, or hold the Option key down while pressing the List toolbar button.
3. A new list figure containing the selected figures will be created and centered in the visible portion of the idea space.

Convert a Mind Map into a List
1. Select the list figure.
2. Choose Arrange > Convert Into > List.

Prune off a Branch in the List into a Brand New Linked-To List
1. Right-click on a figure in the list and choose Prune To Linked Collection.
2. Curio will then create a new list, of the same style as the current list, where the selected parent becomes the title of the new list and all of its children will be
hierarchically arranged underneath.
3. The children of the original parent are then removed and the original parent itself becomes a jump action which, when clicked, will zip you to the new collection.
The new collection can remain on the current idea space or it can be cut and pasted onto a different idea space, and the jump action will still track it down. The
root of the new collection will automatically gain a jump action to jump you back to the parent collection when clicked.

Import an OPML File as a Curio List
1. If you are working with a 3rd party outlining application, such as OmniOutliner, you can bring a list into Curio as a list collection via OPML import.
2. Choose Insert > File, or drag-and-drop an OPML file from the Finder into Curio.
3. Curio will ask you if you which to convert the file into a list figure. Click the “Convert to List“ button; otherwise Curio will simply treat the file as a normal document
asset.

Paste a Text List from the Clipboard as a Curio List
1. Within the 3rd party application, select one or more lines of text and choose Edit > Copy.
2. Within Curio, choose Edit > Paste As > List. When parsing the list Curio will assume carriage-returns separate items and tabs indent items.

Export a Curio List as an OPML, Mind Map Format, Text, or Rich Text File
1. Make sure the list figure itself is selected, not a figure within the list.
2. Use the Share toolbar button and choose to export the selected figure as OPML, one of several supported 3rd party mind mapping formats, text, or RTF. For text
and RTF Curio will use carriage-returns and tabs to separate and indent items.

Copy a Curio List as Carriage Return Delimited, Tab-Indented Text
1. Make sure the list figure itself is selected, not a figure within the list.
2. Choose Edit > Copy As > Text. Both RTF and plain text versions of the text are placed onto the clipboard.

List Inspector Bar
Change list properties via inspector bar
To view the list inspector bar changes and inspector panel make sure you have a list
selected, like the one below, then use the List buttons on the inspector bar or the List tab
in the inspector shelf.

A List
1. Select this list so you can see the changes to the
inspector bar and inspector shelf.

Inspector Bar
When a list figure is selected, the inspector bar will reveal some additional controls:
•

•
•

List
Click this button to display the list inspector popover. The same panels are available in
the List tab in the inspector shelf.
Insert Child
Click this button to insert a child text figure under the current figure.
Insert Sibling
Click this button to insert a next sibling after the current figure. Note if you hold the
Option key down the button will change subtly to indicate that clicking will insert a
previous sibling before the current figure.

List Inspector
Change list properties
To view the list inspector bar changes and inspector panel make sure you have a list
selected, like the one below, then use the List buttons on the inspector bar or the List tab
in the inspector shelf.

A List
1. Select this list so you can see the changes to the
inspector bar and inspector shelf.

Layout
Lists can be bulleted, numbered, or with no prefixes whatsoever.

Format
Set the bullets & numbering format for the list and the indented children it contains. By
specifying this single property, Curio can neatly enumerate all the items within your list,
regardless of hierarchical level.

Level
The current level of the currently selected items is based on how many steps away it is
from the root. Immediate children of the central node is at level 1, their children are at
level 2. You can specify certain options of all items that exist at a hierarchical level.

Line Spacing
You can increase or decrease the line spacing between siblings. Note that if the list itself
is selected then spacing changes impacts all items in the list. If, however, you have an
item within the list selected then the spacing changes will only impact list items at that
hierarchical level.

Custom Numbering/Bullet Format
You can enable a custom number or bullet format for a specific level if you wish. This will
override the default. You can enter an optional prefix character, like a left-parenthesis or
bracket, then choose the bullet or number element, then enter a suffix character, like a
right-parenthesis, bracket, or period.

Options
Title
The title for the list is displayed by default but you can turn this off if you wish.

Expanding/Collapsing
Child hierarchical levels can normally be expanded or collapsed via handle disclosure
triangles. Those can be disabled as well whereby the list is always displayed fully
expanded.

Siblings
Styling
Select a item within the list then you can copy that selected figure’s style to all of its
siblings under the same parent. You can also perform this action via the right-click
context menu on a list item.
Alternatively you can specify that the selected figure’s style should be applied to all
figures at this hierarchical level (meaning the selected figure’s siblings and cousins). This
means all items at the same hierarchical level will instantly have the same style. You can
also perform this action via the right-click context menu on a node.
As a note, if you wish to manually style the list items don’t forget about the very handy
Format > Copy Style and Format > Paste Style menu items. This is a quick way to
selectively apply a style to one or more figures.

Start Number
Select one or more siblings and you can then specify the number that should start these
nodes under the current parent.

Sorting
You can specify that siblings should be sorted by title, creation date, modification date,
due date, start date, start date or end date if already started, done date, added date,
percent completed, priority, or rating.
You can optionally specify a secondary sort criteria, as well.
If you check the "recursively" checkbox then children of the children will sort themselves
with the same sort criteria.
Note, however, if any figure uses a Start Date calculation based on a sibling then sorting
will not occur with those children. Why? If, based on sorting rules, figures jumped around
based on title or priority, then at could have an unintended consequence on all your figure
dates! Basically, we're assuming you placed those figures in specific precedence
ordering — buy groceries then make dinner — and we don't want an automatic sorting to
spontaneously ruin that ordering.

List Inspector - Children
Change list properties
To view the list inspector bar changes and inspector panel make sure you have a list
selected, like the one below, then use the List buttons on the inspector bar or the List tab
in the inspector shelf.

A List
1. Select this list so you can see the changes to the
inspector bar and inspector shelf.

Children
Colors
Select an item within the list then you can copy that selected figure’s colorings to all of its
children. This means the rest of the child’s style, like the shape borders and font size, will
all stay the same but the border color, fill color, and font color will all be replaced with the
colors of its parent. This is a wonderfully quick way to make an entire branch of nodes all
have the same color.
You can mark a child item so that it will automatically update its colors if its parent
changes at any time. So, unlike the manual color copying above, this will happen
automatically if the parent changes.
Alternatively, if you have a parent selected, you can click a checkbox to make it so
children of the selected parent automatically inherit the colors of their parent. Basically
the same effect as #2 above but instead of marking a specific child you can instantly
mark all children, and future children that you add to that parent. Uncheck this option to
disable this functionality. You can also perform this action via the right-click context menu
on a list item.

Spread Color Palette
Curio can instantly spread a color palette across all main branches, so that each branch
has its own color. Curio includes several palettes of colors to make it fun to experiment
with various palettes. See more notes below regarding branch coloring.
You can also use the actions menu to import and manage color palette files such as
Adobe Swatch Exchange (.ase) swatch files from Adobe Color CC or ColourLovers.
While Adobe Color requires a free Adobe account, once you’ve created the account you
can use their site to create, manage, and download color swatches.
You’ll need to register with ColourLovers, as well, if you’d like to downloaded created
color palettes from their site.
The color swatches popup also supports a Curio Color Swatch (.curioColorSwatch) file
with a carriage-return delimited list of hex color values (like #aa22ff) that you can create if
you’d like.

Branch
A branch is the current node and all of its children, grandchildren, etc.

Apply Default Style to Selected Branch
Re-apply the default style information to the selected figure and to all of its children with
just a single click. Useful if a branch has a mix of styles and formatting.

A Note about Branch Coloring
You can create list styles that include branch coloring!
If you apply branch colors to the top branches (the main branches under the title) of your
list using the list inspector's automatic child coloring controls, for example perhaps you
spread a color palette, then that branch information will now be stored as a part of the
collection's style.
After creating new list styles which include branch colors, you can then apply those styles
to your existing lists or to new lists and the top branches will be colored appropriately.
When branch coloring is part of the style, the order of the branch coloring is maintained
as you insert or delete top branches. So if the branches should be red, green, blue, and
orange — in that order — then those colors will be enforced as you modify the number
and ordering of branches under the central topic.

Mind Map
Introducing the mind map collection
Working with Mind Maps
Mind mapping is a wonderful technique for discovering connections between words and ideas, and encourages an easy
brainstorming approach starting with just one idea. This one idea — be it a word, phrase, or image — is expanded upon by adding
associated ideas in a radial fashion around the central idea. You then take each of those associated phrases and list ideas
associated with them.
A mind map’s central figure is called the central topic. This is the main idea or focus of the mind map.
Surrounding the central topic, are the main topics or branches. These are your initial, primary topics or ideas that come to mind
when thinking about the central topic. For example, if the central topic is “Apple” then the branches surrounding it might include
“Mac”, “iPad”, and “iPhone”.
In general, you want to have only a few main branches under the central topic. If you have over a dozen main branches then
consolidating them into 4 to 10 branches would make the resulting mind map much more readable and organized and allow Curio
to optimize the mind map’s layout.
Subtopics can have subtopics, and those can have subtopics, etc, so your resulting branches can be quite large.
Topics and subtopics within Curio can be almost anything, not simply text. For example: images, videos, files, web links, audio
recordings, Mail messages, and more! And, like any figure within Curio, each figure within a mind map can include one or more tags
and other meta data information.

Context Menu
Right-clicking on a mind map or a mind map item will show a context menu with lots of frequent operations so be sure to check it
out!

Mind Map Basics
Let’s get started with mind mapping
To Create a Mind Map:
! Use the Insert popover to create a mind map via its style and stencil gallery, or use the Insert menu.

To Insert a New Text Figure as a Next Sibling:
! Select an item in the mind map.

Insert a Next Sibling by Choosing Insert > Text Next Sibling or by Typing Command-Return.
1. As a shortcut, if you are current editing a mind map item, you can simply type Return to create a new next sibling. If you want to actually insert a carriage return
within the edited text figure, then type Option-Return.
2. Note that the root figure cannot have a sibling, so a new last child will be created instead.

To Insert a New Text Figure as a Previous Sibling:
1. Select an item in the mind map.
2. Insert a previous sibling by choosing Insert > Text Previous Sibling or by typing Command-Shift-Return.
3. As above, you can simply type Shift-Return to create a new previous sibling.

To Insert a New Text Figure as a Child:
1. Select an item in the mind map.
2. Insert a new last child by choosing Insert > Text Child or by typing Command-Option-Return.

To Add New Sibling Items to a Mind Map Via Keyboard:
1. Select an item in the mind map.
2. Press the Command-Return key to create a new next sibling or Command-Shift-Return to create a previous sibling of the selected figure. If you are currently
editing an existing figure then you can just press Return or Shift-Return.

To Add New Child Items to a Mind Map Via Keyboard:
1. Select an item in the mind map.
2. Press the Tab key to create a new child of the selected figure.

To Add New Items to a Mind Map Via Drag-And-Drop:
1. Select figures from elsewhere in Curio, the Finder, or another application and drag them into Curio onto the mind map figure.
2. As you drag the items around the guides described above will appear showing you where they will be placed in the mind map.
3. Release the mouse button to drop the items into the mind map. If the drag began within Curio, and the Option key was held down during the drag, then a copy of
the selected figures will be created.
4. Mind Map figures also support cut, copy, paste, and duplicate for adding and removing figures.

To Remove Mind Map Items:
1. Select the mind map items you wish to remove.
2. Press the Delete or Backspace key or choose Edit > Delete.
3. Any children will automatically be removed as well.

Mind Map Basics (2)
Let’s get started with mind mapping
To Select Multiple Figures Within the Mind Map:
! Either use the Shift or Command click to click on individual items, or hold Shift or Command and select a range of figures by clicking and holding on the
background of the mind map and dragging a rubber band selection region around figures.

Rearranging Mind Map Items Via Keyboard
1. Select or edit an item.
2. Press ⌃⇧↑ or ⌃⇧↓ to move the item up or down through its siblings.

Rearranging Mind Map Items Via Drag-And-Drop:
1. Select one or more mind map figures and begin to drag them.
2. As you drag the items around, and hover over an existing figure, guides will help you determine where they (and their children) will be placed.
a. If you hover the mouse near the top of an existing figure, any red line will appear indicating that, if you drop the items, they will be inserted as previous siblings
to this figure.
b. If you hover the mouse near the bottom of an existing figure, a red line will appear indicating that, if you drop the items, they will be inserted as next siblings to
this figure.
c. If you hover over the middle of an existing figure, it will glow to indicate that, if you drop the items, they will be added as new children to this figure.
3. Release the mouse button to drop the items into the mind map. If the Option key was held down during the drag then a copy of the selected figures will be
created.
4. As mentioned in the collection figures overview, when moving figures around they will adopt the styling appropriate for that location by the collection figure’s style
information. If you wish to keep a figure’s existing styling then hold Shift before dropping the figure.

Working with Transparent Mind Maps
1. If your mind map has no fill color, Curio supports a kind of transparent selection so you can directly manipulate the mind map nodes more easily.
2. If either the mind map is unselected or if a node within the mind map is selected, then you can now directly click and drag on the background of the mind map to
"rubber band-select" a range of nodes.
3. If you click and release within the mind map figure but not on a node, then the mind map figure itself will be selected. Once selected you can then change its
inspector properties, or copy it, or drag it, etc.
4. You can now directly click and drag on a node, even if the mind map itself was not already selected, and just start dragging to immediately move it to a new
location.
5. Another way to move the entire mind map is to click and drag the central topic node.

Rearranging List Items Via Keyboard
1. Select or edit an item.
2. Press ⌃⇧↑ or ⌃⇧↓ to move the item up or down through its siblings.

Sort Mind Map Items
1. By default, you can manually rearrange the child nodes of a mind map parent via drag-and-drop as described above.
2. However, you can also tell Curio to keep those children automatically sorted by title, creation date, modification date, due date, start date, start date or end date if
already started, percent completed, priority, or rating, in either ascending or descending order. You can specify a secondary sort as well. Make a change to a
figure and instantly the figures rearrange based on the sorting rule.
3. Select one or more sibling items in a mind map then use the mind map inspector to select a primary and secondary sort option.

Manually Positioning Branches Via Drag-And-Drop:
1. In Curio you can manually position the top, main branches of a radial mind map. That is, those nodes directly under the central topic. However, Curio will
automatically control the positioning of the nodes under each branch.
2. Select the topic figure at the top of a branch under the central topic and drag it.
3. As you drag the item around a target symbol will appear showing you where it will be manually positioned in the mind map. Other branches that remain as
automatically positioned items will automatically adjust their placement to ensure no overlap occurs.

To Add an Attachment to an Existing Mind Map Text Figure:
1. Right-click on a text figure within your mind map and choose Attach File then choose a file from anywhere on your hard disk in the dialog that appears. This file
can be copied or moved into the project as an embedded asset or referenced as an alias.
2. More information can be found in the Text Figure Attachments section.

To Add a Caption to an Existing Mind Map Image or Asset Figure:
1. Right-click on an asset figure displayed as a preview within your mind map and choose Show Caption.
2. More information can be found in the Display panel of the figure shape inspector section.

To Show a Relationship Line Between Two Different Figures in the Mind Map:
1. Select a figure in the mind map then press ⌘ (Command) and select a second figure in the mind map.
2. Right-click and choose Add Relationship Line, or click the Add Relationship Line button in the mind map popover.
3. A new line — a true Curio line figure in fact — will connect the two figures. This line will be set with a handy midpoint and have a curved line style so you can grab
that midpoint and move it around to bend it any way you wish. As a real line figure you can completely customize its style using the inspectors.
4. Once you have styled the relationship line the way you like you can create a saved style for it by right-clicking on the line and choosing Save As Line Style. You
can also make this the default relationship line style via the Format > Save as Default Style for Relationship Line Figure menu item.
5. You can also double-click the line to give it a line label. Don't forget, the easiest and most accurate way to move a relationship line label is using the arrow keys
on your keyboard. Hold Shift with the arrow keys to move in greater steps.

Mind Map Import/Export Formats
Getting data into and out of a mind map
3rd Party Mind Map File Formats
Curio supports several 3rd party mind mapping file formats for easy import/export.
Note that formatting and layout information such as fonts, shapes, coloring, and positions are not imported or exported. Instead a
default Curio mind map style is applied and the mind map is automatically laid out.

iThoughts
iThoughts is available for both iOS and macOS and Curio supports its .itmz file format. Curio supports many iThoughts properties
including title, note, flags (at least the ones that map to Curio flags), checkmark, percent complete, priority, start date, due date, and
hyperlinks. Curio will also import or export images or other files attached to mind map nodes. Currently, Curio doesn’t support
iThoughts floating topics.
Special Note: After exporting from Curio into iThoughts, you may need to force a re-layout by tapping the Gear icon > Map Layout
then tapping Vertical then Horizontal.

Mindjet MindManager
Mindjet MindManager .mmap format is one of the most popular mind mapping formats and supported by most 3rd party mind
mapping apps on macOS, iOS, and Windows. Curio supports MindManager properties including title, link, note, flags (at least the
ones that map to Curio flags), checkmark, percent complete, priority, start date, due date, and duration. Currently Curio doesn’t
import or export asset files (aka attachments).

MindNode
MindNode is available for both iOS and macOS and Curio supports its .mindnode file format. As of this writing, the MindNode file
format only includes the title of the nodes which Curio can import and export. Currently Curio doesn’t import or export images or
other asset files (aka attachments).
Special Note: After exporting from Curio into MindNode, you will need to force a re-layout by selecting the central topic node and
clicking the Fold toolbar button then the Unfold button.

iMindMap
iMindMap is available for both iOS and macOS and Curio supports its .imx file format. Curio can import iMindMap title, start/due
date, percent complete, and priority information. Curio can export title, start/due date, and a handful of flags. Currently Curio doesn’t
import or export images or other asset files (aka attachments).
Special Note: After exporting from Curio into iMindMap, you will need to force a re-layout by clicking the Clean Up button in the
toolbar.

OPML
Most 3rd party outlining applications, such as OmniOutliner, can export to the simple OPML format. Curio’s import process can
retrieve the title, note, and checkmark.

Mind Map Import/Export
Getting data in and out of mind maps
Import a Mind Map File as a Curio Mind Map
1. Choose Insert > File, or drag-and-drop a supported mind map or outlining file format from the Finder into Curio.
2. Curio will ask you if you which to convert the file into a mind map figure. Click the “Convert to Mind Map“ button; otherwise Curio will simply treat the file as a
normal document asset.

Import a Carriage-Return Separated and Tab-Indented List from the Clipboard as a Curio Mind Map
1. Within the 3rd party application, select one or more lines of text and choose Edit > Copy.
2. Within Curio, choose Edit > Paste As > Mind Map.

Export a Curio Mind Map
1. Make sure the mind map figure itself is selected, not a figure within the mind map.
2. Use the Share toolbar button and choose to export the selected figure as OPML, Mindjet MindManager, iThoughts, MindNode, iMindMap, text, or RTF. For text
and RTF Curio will use carriage-returns and tabs to separate and indent items.

Collect a Selection of Figures into a Mind Map
1. Select one or more unlocked figures.
2. Choose Arrange > Collect into Mind Map, or hold the Option key down while pressing the Mind Map toolbar button.
3. A new mind map figure containing the selected figures will be created and centered in the visible portion of the idea space.
4. If only one figure was selected, then the new mind map will use that figure as the central topic. If more than one figure was selected, then the new mind map will
have a placeholder text figure as the central topic, and all selected figures will be added as children to that central figure.

Convert a List into a Mind Map
1. Select the mind map figure.
2. Choose Arrange > Convert Into > Mind Map.

Prune off a Branch in the Mind Map into a New Mind Map
1. Right-click on a figure in the mind map and choose Prune To Linked Collection.
2. Curio will then create a new mind map, of the same style as the current mind map, where the selected parent becomes the central topic of the new mind map and
all of its children will be hierarchically arranged underneath.
3. The children of the original parent are then removed and the original parent itself becomes a jump action which, when clicked, will zip you to the new collection.
The new collection can remain on the current idea space or it can be cut and pasted onto a different idea space, and the jump action will still track it down. The
root of the new collection will automatically gain a jump action to jump you back to the parent collection when clicked.

Import a MindMeister Mind Map
1. In MindMeister, right-click on a node and choose Copy As > Text then select the text outline that appears in the popup dialog then Edit > Copy that into the
clipboard.
2. In Curio, use the Edit > Paste As > Mind Map or Edit > Paste As > List to paste in a new mind map or list, respectively. Note that you can select a node in an
existing collection and use this same technique to paste the outline as a new branch.

Export a Curio Mind Map or List into MindMeister
1. In Curio, use the Share toolbar to export a text file containing the selected collection.
2. In MindMeister, click the Import on the main screen and choose the file you created on your hard disk.

Import a FreeMind Mind Map
1. In FreeMind, click on a node and choose Edit > Copy which will place a text outline of the branch hierarchy into the clipboard.
2. In Curio, use the Edit > Paste As > Mind Map or Edit > Paste As > List to paste in a new mind map or list, respectively. Note that you can select a node in an
existing collection and use this same technique to paste the outline as a new branch.

Export a Curio Mind Map or List into FreeMind
1. In Curio, use the Edit > Copy As > Text to copy a mind map or list hierarchy into the clipboard as a text outline.
2. In FreeMind, click on a node and choose Edit > Paste which will paste the hierarchy as a new branch in your FreeMind mind map.

Mind Map Inspector Bar
Change properties via inspector bar
To view the mind map inspector bar changes and inspector panel make sure you have a
mind map selected, like the one below, then use the Mind Map buttons on the inspector
bar or the Mind Map tab in the inspector shelf.

A Mind Map

Select this mind map so you
can see the changes to the
inspector bar and inspector
shelf.

Inspector Bar
When a mind map figure is selected, the inspector bar will reveal some additional
controls:
•

•
•

Mind Map
Click this button to display the mind map inspector popover. The same panels are
available in the Mind Map tab in the inspector shelf.
Insert Child
Click this button to insert a child text figure under the current figure.
Insert Sibling
Click this button to insert a next sibling after the current figure. Note if you hold the
Option key down the button will change subtly to indicate that clicking will insert a
previous sibling before the current figure.

Mind Map Inspector
Change mind map properties
To view the mind map inspector bar changes and inspector panel make sure you have a
mind map selected, like the one below, then use the Mind Map buttons on the inspector
bar or the Mind Map tab in the inspector shelf.

A Mind Map

Select this mind map so you
can see the changes to the
inspector bar and inspector
shelf.

Layout
Curio mind maps can have very different arrangement and line styles.

Arrangement
Set the arrangement of the mind map. Curio currently supports radial maps, right maps,
left maps, bottom-up, top-down, and org charts. You can also switch the arrangement by
right-clicking on the mind map.

Lines
Choose how the lines should be drawn between nodes: straight, curved, elbow, or
rounded elbow.

Add Relationship Line
Click the Add Relationship Line button to create a line pointing from a first selected figure
to a second selected figure.

Reset Layout
Click the Reset Layout button to reset the entire layout in case you’ve dragged branch
nodes around into odd locations.

Siblings
Styling
Select a item within the mind map then you can copy that selected figure’s style to all of
its siblings under the same parent. You can also perform this action via the right-click
context menu on a mind map item.
Alternatively you can specify that the selected figure’s style should be applied to all
figures at this hierarchical level (meaning the selected figure’s siblings and cousins). This
means all items at the same hierarchical level will instantly have the same style. You can
also perform this action via the right-click context menu on a mind map item.
As a note, if you wish to manually style the mind map items don’t forget about the very
handy Format > Copy Style and Format > Paste Style menu items. This is a quick way to
selectively apply a style to one or more figures.

Sorting
You can specify that children should be sorted by title, creation date, modification date,
due date, start date, start date or end date if already started, done date, added date,
percent completed, priority, or rating.
You can optionally specify a secondary sort criteria, as well.
If you check the "recursively" checkbox then children of the children will sort themselves
with the same sort criteria.
Note, however, if any child figure uses a Start Date calculation based on a sibling then
sorting will not occur with those children. Why? If, based on sorting rules, figures jumped
around based on title or priority, then at could have an unintended consequence on all
your figure dates! Basically, we're assuming you placed those figures in specific
precedence ordering — buy groceries then make dinner — and we don't want an
automatic sorting to spontaneously ruin that ordering.

Mind Map Inspector - Children
Change mind map properties
To view the mind map inspector bar changes and inspector panel make sure you have a
mind map selected, like the one below, then use the Mind Map buttons on the inspector
bar or the Mind Map tab in the inspector shelf.

A Mind Map

Select this mind map so you
can see the changes to the
inspector bar and inspector
shelf.

Children
Colors
Select an item within the mind map then you can copy that selected figure’s colorings to
all of its children. This means the rest of the child’s style, like the shape borders and font
size, will all stay the same but the border color, fill color, and font color will all be replaced
with the colors of its parent. This is a wonderfully quick way to make an entire branch of
nodes all have the same color.
You can mark a child item so that it will automatically update its colors if its parent
changes at any time. So, unlike the manual color copying above, this will happen
automatically if the parent changes.
Alternatively, if you have a parent selected, you can click a checkbox to make it so
children of the selected parent automatically inherit the colors of their parent. Basically
the same effect as #2 above but instead of marking a specific child you can instantly
mark all children, and future children that you add to that parent. Uncheck this option to
disable this functionality. You can also perform this action via the right-click context menu
on a node.

Spread Color Palette
Curio can instantly spread a color palette across all main branches, so that each branch
has its own color. Curio includes several palettes of colors to make it fun to experiment
with various palettes. See more notes below regarding branch coloring.
You can also use the actions menu to import and manage color palette files such as
Adobe Swatch Exchange (.ase) swatch files from Adobe Color CC or ColourLovers.
While Adobe Color requires a free Adobe account, once you’ve created the account you
can use their site to create, manage, and download color swatches.
You’ll need to register with ColourLovers, as well, if you’d like to downloaded created
color palettes from their site.
The color swatches popup also supports a Curio Color Swatch (.curioColorSwatch) file
with a carriage-return delimited list of hex color values (like #aa22ff) that you can create if
you’d like.

Branch
A branch is the current node and all of its children, grandchildren, etc.

Branch Boundary
You can enable a boundary region to be drawn around the selected mind map parent and
around its children. A boundary is a wonderful way to highlight a particular branch or subbranch of your mind map. The color of the boundary is automatically determined based
on the color of the parent figure itself.
Note that boundaries can contain other boundaries if you wish.

Apply Default Style to Selected Branch
Re-apply the default style information to the selected figure and to all of its children with
just a single click. Useful if a branch has a mix of styles and formatting.

A Note about Branch Coloring
You can create mind map styles that include branch coloring!
If you apply branch colors to the top branches (the main branches under the central
topic) of your mind map using the mind map inspector's automatic child coloring controls,
for example perhaps you spread a color palette, then that branch information will now be
stored as a part of the collection's style.
After creating new mind map styles which include branch colors, you can then apply
those styles to your existing mind maps or to new mind maps and the top branches will
be colored appropriately.
When branch coloring is part of the style, the order of the branch coloring is maintained
as you insert or delete top branches. So if the branches should be red, green, blue, and
orange — in that order — then those colors will be enforced as you modify the number
and ordering of branches under the central topic.

Table
Introducing the table collection
Working with Tables
Curio’s table feature is an excellent way to show a grid or matrix of data. The data could be several text figures, numbers, or even
complex figures such as images and movies. When you need to show tabular data, tables are the answer.

Context Menu
Right-clicking on the table or a table cell will show a context menu with lots of frequent operations so be sure to check it out!

Create a Table
! Use the Insert popover to create a table via its style and stencil gallery, or use the Insert menu.

Edit a Figure Cell
! Double-click the cell or select it and press the Return key.

Move Between Figure Cells
! Press Tab or Shift-Tab or move forwards or backwards. You can also use the arrow keys on your keyboard to navigate around the cells.

Select Specific Figure Cells
1. Select the first cell then hold Shift while clicking the last cell and all the cells within the rectangular region defined by those two cells will be selected.
2. Or, click on the first cell, then hold Command while clicking other cells to select a disjointed number of cells.

Select Specific Rows or Columns
1. Select the figure cells in the rows or columns you wish to select.
2. Right-click and choose Select Row or Select Column, as appropriate.

Resize Rows or Columns
1. Select the table — or specific rows and columns — and enter values into the Column Width and Row Height fields in the table Inspector if you want all row and
columns to have the same sizing. You can also use the Fit and Distribute to fit or distribute sizes for selected rows or columns, or for the entire table.
2. Or, hover the mouse over the row and column separating lines such that the mouse pointer becomes a resize pointer. Then click and drag to resize that row or
column. When you resize a row or column using the mouse by default the table itself is resized as well. However, if you hold the Option key down while resizing,
the table will maintain its size and just the individual row or column will be resized.
3. Or, click on the table then drag one of its resize handles. While the table resizes all rows and columns will resize proportionally. Note that certain cells may have
minimum sizes due to the display of adornments such as checkboxes and tags.

Fit and Distribute
1. Use the Fit buttons to size the row height or column width to the minimum necessary to show the content on that row or column.
2. Use the Distribute buttons to make all rows heights or column widths the same.
3. Check the automatically adjust row heights checkbox if you’d like Curio to adjust row heights as necessary to avoid clipping cell content

Add Rows or Columns
1. Select the table.
2. Use the table inspector to change the number or rows or columns in a table. By default Curio will maintain the table's current size. However, if you hold the Shift
key while clicking the steppers to change the number of rows or columns, Curio will allow the table to grow or shrink as needed

Insert Rows or Columns
1. Select the figure cells in the rows or columns you wish the insert to occur.
2. Right-click and choose Add Row Above, Add Row Below, Add Column Before, or Add Column After, as appropriate.
3. As a note, you can also use the Option-ArrowKey to insert rows and columns if a cell is selected (although not being actively edited), where ArrowKey is the up,
down, left, or right arrow keys on your keyboard. Hold the Shift key as well to modify the table size during the insertion, as described above.

Delete the Contents of Figure Cells
1. Select the figure cells you wish to clear.
2. Press the Delete or Backspace key or choose Edit > Delete.

Delete Specific Rows or Columns
1. Select the figure cells in the rows or columns you wish to delete.
2. Right-click and choose Delete Row or Delete Column, as appropriate.
3. When the deletion occurs the remaining row/columns will increase in size to fill the existing table dimensions. However, if you hold down the Shift while when
choosing the context menu option then Curio will shrink the table figure itself instead.

Table Import/Export
Getting data into and out of a table
Add New Items to a Table or Rearranging Table Items Via Drag-And-Drop
1. Select figures from elsewhere in Curio, the Finder, or another application and drag them into Curio onto the table figure.
2. As you drag the items around the table, the current cell you are hovering over will highlight so you know where the dropped items will be placed. Note you will be
replacing the contents of the hovered-over item with the dropped figures or data.
3. Release the mouse button to drop the items into the table. If the drag started from this table or another table then the added items will retain their same row and
column separation from each other, and Curio will automatically increase the number or rows or columns as necessary to fit the newly placed items.
4. If the drag started from figures selected on the idea space or from the Finder, then Curio will ask if the items should be filled into a single column (adding rows as
needed), a single row (adding columns as needed), or spread across and then down (adding rows as needed).
5. Table figure cells also support cut, copy, paste, and duplicate for adding and removing figures.
6. As mentioned in the collection figures overview, when moving figures around they will adopt the styling appropriate for that location by the collection figure’s style
information. For tables this means moving items will adopt the appropriate default cell style based on the cell type: body, header, etc. If you wish to keep a figure’s
existing styling then hold Shift before dropping the figure.

Drag a Figure out of the Table
! Simply drag the figure out of the table and you can drop it on the idea space or directly into another collection such as a list or mind map. The table cell is cleared
and replaced with a boilerplate text figure unless Option is held down in which a copy was generated.

Import a CSV File as a Curio Table
1. You can import tabular data from Apple Numbers, Microsoft Excel, or many other 3rd party applications, directly into Curio as a table collection.
2. Just use that application’s export to CSV (Comma Separated Value) functionality to create an export file, which Curio can import.
3. Choose Insert > File, or drag-and-drop a CSV file from the Finder into Curio.
4. Curio will ask you if you which to convert the file into a table figure. Click the “Convert to Table“ button; otherwise Curio will simply treat the file as a normal
document asset.

Paste a Tab Delimited Information from the Clipboard into a Curio Table
1. Within the 3rd party application, select a range of rows and columns and choose Edit > Copy.
2. Within Curio, choose Edit > Paste As > Table to paste into the currently selected table or it can automatically create a new table.

Export a Curio Table
1. Make sure the table figure itself is selected, not a figure within the table.
2. Click the Share toolbar button then, under Share Selected Figure, choose the export format you wish to use, such as text or CSV.

Copy a Curio Table as Tab Delimited Text
1. Make sure the table figure itself is selected, or a range of cells within the table is selected.
2. Choose Edit > Copy.

Index Card
Introducing the index card collection
Working with Index Cards
Curio’s index cards are a fantastic new way to create snippets of ideas, thoughts, and notes. You can even place images and other
asset figures on an index card.
Note that an index card is resizable but not scrollable. This means any text that grows past its bounds will be automatically clipped
when it's not being edited.
This was done on purpose in the design of the index card feature. The strength of the real-world index card is its static size, in
contrast to a multipage notebook. It forces you to make brief notes and think concisely, then to review and arrange your thoughts
with the resulting stack of cards.

Create a an Index Card
! Use the Insert popover to create a index card via its style and stencil gallery, or use the Insert menu.

Edit an Index Card Title or Body Figure
! Double-click the figure within the index card. You can press tab to jump between the title and body areas.

Replace the Contents of an Index Card
! You can drag-and-drop or paste another figure into the body area of an index card. Using this technique an index card can contain images or any other type of
asset figure.

Collapse or Expand an Index Card
1. Select the index card figure.
2. Do a quick tap of the spacebar to collapse or expand the index card.

Export a Curio Index Card
1. Make sure the index card figure itself is selected, not a figure within the index card.
2. Click the Share toolbar button then, under Share Selected Figure, choose the export format you wish to use.

Copy a Curio Index Card as Text
1. Make sure the index card figure itself is selected, not a figure within the index card.
2. Choose Edit > Copy As > Text.

Index Card Inspector
Change index card properties
To view the index card inspector panel make sure you have an index card selected, like the
one below, then use the Index Card button on the inspector bar or the Index Card tab in
the inspector shelf.

An Index Card
Select this index card so you can see the changes to the
inspector bar and inspector shelf.

Line Coloring
Set the color of the line drawn under the index card title. If you set a none color in the
popup color palette then no title line will be drawn.
Set the color of the lines drawn in the body area of the index card. If you set a none color
in the popup color palette then no body lines will be drawn.
Note you can set other properties such as fonts, font colors, fill colors, etc, using the other
inspectors. The index card is made up of two distinct figures which you can style using
the various inspectors: a title figure and a body figure.

Album
Introducing the album collection
Working with Albums
Curio’s albums are a great way to create flexible collections of image figures and other asset figures displayed as previews, such as
PDF’s. With the new preview caption feature mentioned above your images can have notes and other annotations directly under
the image or preview feature is an excellent way to show a grid or matrix of data.
An album lays out all contained items in fixed-width columns. Unlike a table which has fixed-height rows, albums simply stack items
within the columns based on the height of each item. The number of columns is based on the overall width of the album collection
figure. As you resize the album figure, the number of columns will be dynamically changed and items will wrap accordingly.

Context Menu
Right-clicking on a list or a list item will show a context menu with lots of frequent operations so be sure to check it out!

Create an Album
! Use the Insert popover to create an album via its style and stencil gallery, or use the Insert menu.

Convert a Selection of Figures into an Album
1. Select one or more figures on the idea space.
2. Choose Arrange > Collect Into > Album.

Edit a Figure Within an Album
! Double-click the figure or select it and press the Return key.

Move Between Figures Within an Album
! Use the arrow keys on your keyboard to navigate around the album.

Add New Items to an Album or Rearranging Items Via Drag-And-Drop
1. Select figures from elsewhere in Curio, the Finder, or another application and drag them into Curio onto the album figure.
2. As you drag the items around the album, a red drop indicator will indicate whether the items will be placed before or after the current item.
3. Release the mouse button to drop the items into the album.
4. Items within albums also support cut, copy, paste, and duplicate for adding and removing figures.

Drag a Figure out of the Album
! Simply drag the figure out of the album and you can drop it on the idea space or directly into another collection such as a list or mind map.

Change the Number of Columns
! Simply resize the album figure itself and the number of columns will dynamically change to accommodate the new width of the album.

Delete the Items Within an Album
1. Select the figures you wish to delete.
2. Press the Delete or Backspace key or choose Edit > Delete.

Toggle the Display of an Album Title
! Select the album — or an item within the album — and use the album Inspector to turn on or off the album title.

Change the Column Size or Spacing
! Select the album — or an item within the album — and use the album Inspector to modify those properties.

Album Inspector
Change album properties
To view the album inspector panel make sure you have an album selected, like the one
below, then use the Album button on the inspector bar or the Album tab in the inspector
shelf.

Zengobi Pets

Gobi our mascot
Peanut, the sleepy dog, helped us start
Zengobi many moons ago!

The venerable Peabody

Our newest addition: Butternut

Marshmallow with her treats!

Yes, it’s Orangey!

Album Arrangement
Choose either:
1. Columns: a packed columns of images. You specify a column width and the contained
figures are proportionally sized to that width then arranged into a packed layout, similar
to Pinterest's.
2. Columns (unpacked): Unpacked columns of images. Like Columns you specify a
column width, but instead of packing the contained figures, each row's height is based
on the tallest item in that row. The result is more like a matrix of images in tidy columns
and rows.
3. Rows: Packed rows of images. You specify a row height and the contained figures are
proportionally sized to that height then arranged into a packed layout. This works very
well with uncaptioned images, but can be a bit finicky with captioned images as text
wrapping can jump items between sizes, although Curio attempts to counter this via
iterative refinement.

Album Options
● Set the horizontal and vertical gap spacing between items within the album.
● Toggle the display of the album title.

Pinboard
Introducing the pinboard collection
Working with Pinboards
Think of a pinboard as a container of figures where no layout or style is imposed on the figures within the collection. You can place
items anywhere within the collection and the collection itself will automatically grow, if necessary, to handle dropped or pasted
figures. It's almost like a free-floating mini idea space in terms of flexibility. And it's more flexible than a group figure since you can
move and resize the contained figures freely and the collection will simply resize to hold the new items.
Pinboards really shine when used during brainstorming sessions. You and your team will quickly produce dozens of ideas, perhaps
created using Curio’s sticky note figure styles. Afterwards, or during breaks, collect common ideas together in pinboard collections
to quickly organize and visualize the results of your brainstorm. You can even add ratings, tags, and priorities or use color coding to
quickly identify key ideas.
A pinboard is a collection figure, like a list, mind map, or table collection figure. It’s important to remember that a collection cannot
contain another collection.

Create a Pinboard
! Use the Insert popover to create a pinboard via its style and stencil gallery, or use the Insert menu.

Convert a Selection of Figures into a Pinboard
1. Select one or more figures on the idea space.
2. Choose Arrange > Collect Into > Pinboard.

Edit a Figure Within a Pinboard
! Double-click the figure or select it and press the Return key.

Create a Text Figure Within a Pinboard
! Double-click the background of the pinboard.

Add New Items to a Pinboard or Rearranging Items Via Drag-And-Drop
1. Select figures from elsewhere in Curio, the Finder, or another application and drag them into Curio onto the pinboard figure.
2. As you drag the items around the pinboard, you can see exactly where the items will be placed.
3. Release the mouse button to drop the items into the pinboard.
4. Items within pinboard also support cut, copy, paste, and duplicate for adding and removing figures.
5. The pinboard will automatically expand if necessary to accommodate the added items, unless you disable this feature in the inspector.

Select Multiple Figures Within the Pinboard
! Either use the Shift or Command click to click on individual items, or hold Shift or Command and select a range of figures by clicking and holding on the
background of the pinboard and dragging a rubber band selection region around figures.

Insert a New Figure into a Pinboard
! Use the Insert toolbar button to insert a new figure such as a Styled Shape directly into the pinboard. Note, like all collection figures, a collection figure cannot
contain another collection figure. So you can’t add a list to a pinboard, for example.

Drag a Figure out of the Pinboard
! Simply drag the figure out of the pinboard and you can drop it on the idea space or directly into another collection such as a list or mind map.

Delete the Items Within a Pinboard
1. Select the figures you wish to delete.
2. Press the Delete or Backspace key or choose Edit > Delete.

Collapse or Expand a Pinboard
1. Select the pinboard figure.
2. Do a quick tap of the spacebar to collapse or expand the pinboard. Note that the pinboard has to have a title to be able to collapse it.

Toggle the Display of a Pinboard Title
! Select the pinboard — or an item within the pinboard — and use the pinboard Inspector to turn on or off the pinboard title.

Toggle the Pinboard Auto Resize
! Select the pinboard — or an item within the pinboard — and use the pinboard Inspector to toggle pinboard automatic resize.

Pinboard Inspector
Change pinboard properties
To view the pinboard inspector panel make sure you have a pinboard selected, like the one
below, then use the Pinboard button on the inspector bar or the Pinboard tab in the
inspector shelf.

A Pinboard
This is Peanut!

Pinboard Options
Toggle the display of the pinboard title.
Toggle the automatic resize of the pinboard when new items are added to it.

Stack
Introducing the stack collection
Working with Stacks
A stack collection collects all of its contained figures in a neat, vertical stack which is perfect for organizing tasks in a visual manner.
The widths of all contained figures will be increased to the width of the stack, appropriately sizing images proportionally. If you
resize the stack, the widths of all figures within will resize as well.
Stacks are best suited for organizing text, image, and file asset figures.

Smart Tag Inheritance on Search and Status
Stacks have two special, very important characteristics when tasks are viewed on the Search and Status shelf:
1. Curio will ignore stack titles in the Status shelf (when grouping by tag) or on the Search shelf (when searching for tags).
2. On both the Status and Search shelves, items within the stack will automatically inherit the title's tags.
This means you can construct a series of stacks, where the title of the stack has an associated tag, and simply drag-and-drop items
from one stack to another. Those items will instantly inherit the title's tag and appear in the Status shelf with the correct
associations.

Create a Stack
! Use the Insert popover to create a stack via its style and stencil gallery, or use the Insert menu.

Convert a Selection of Figures into a Stack
1. Select one or more figures on the idea space.
2. Choose Arrange > Collect Into > Stack.

Edit a Figure Within a Stack
! Double-click the figure or select it and press the Return key.

Create a Text Figure Within a Stack
! Double-click the background of the stack or select an existing figure and press Command-Return to create a next sibling or Shift-Command-Return to create a
previous sibling.

Move Between Figures Within a Stack
! Use the arrow keys on your keyboard to navigate around the stack.

Add New Items to a Stack or Rearranging Items Via Drag-And-Drop
1. Select figures from elsewhere in Curio, the Finder, or another application and drag them into Curio onto the stack figure.
2. As you drag the items around the stack, you can see exactly where the items will be placed. Note that if the stack is sorted, see below, then you won’t be able to
place an item precisely in the stack as it will be automatically sorted into place once you release the mouse.
3. Release the mouse button to drop the items into the stack.
4. Items within stack also support cut, copy, paste, and duplicate for adding and removing figures.
5. The stack will automatically expand if necessary to accommodate the added items.

Select Multiple Figures Within the Stack
! Either use the Shift or Command click to click on individual items, or hold Shift or Command and select a range of figures by clicking and holding on the
background of the stack and dragging a rubber band selection region around figures.

Insert a New Figure into a Stack
! Use the Insert toolbar button to insert a new figure such as a Styled Shape directly into the stack. Note, like all collection figures, a collection figure cannot contain
another collection figure. So you can’t add a list to a stack, for example.

Drag a Figure out of the Stack
! Simply drag the figure out of the stack and you can drop it on the idea space or directly into another collection such as a list or mind map.

Delete the Items Within a Stack
1. Select the figures you wish to delete.
2. Press the Delete or Backspace key or choose Edit > Delete.

Collapse or Expand a Stack
1. Select the stack figure.
2. Do a quick tap of the spacebar to collapse or expand the stack. Note that the stack has to have a title to be able to collapse it.

Toggle the Display of a Stack Title
! Select the stack — or an item within the stack — and use the stack Inspector to turn on or off the stack title.

Change the Stack Sorting
1. By default, you can manually rearrange items in the stack. Just drag items up and down the stack to arrange them in any order you wish.
2. However, you can also tell Curio to keep the stack automatically sorted by title, creation date, modification date, due date, start date, start date or end date if
already started, percent completed, priority, or rating, in either ascending or descending order. You can specify a secondary sort as well. Make a change to a
figure and instantly the figures rearrange based on the sorting rule.
3. Select the stack — or an item within the stack — then use the stack Inspector to select a primary and secondary sort option.

Export a Curio Stack
1. Make sure the stack figure itself is selected, not a figure within the stack.
2. Click the Share toolbar button then, under Share Selected Figure, choose the export format you wish to use, such as text, OPML, or a mind map format.

Stack Inspector
Change stack properties
To view the stack inspector panel make sure you have a stack selected, like the one
below, then use the Stack button on the inspector bar or the Stack tab in the inspector
shelf.

A Stack
Select this stack so you can see the changes to the inspector bar
and inspector shelf.

Another item in the stack.

Stack Options
Toggle the display of the stack title.

Automatically Size
The stack will automatically grow as you add new items, but via this option it can
automatically shrink as items are removed.

Sorting
Change the automatic sort ordering. By default, you can manually rearrange items in the
stack. Just drag items up and down the stack to arrange them in any order you wish.
However, you can also tell Curio to keep the stack automatically sorted by title, creation
date, modification date, due date, start date, start date or end date if already started,
done date, added date, percent completed, priority, or rating. You can specify a
secondary sort as well.

Table of Contents

STANDARD

PRO

Insert an automatic table of contents
Table of Contents
Curio Professional and Standard customers can now insert a Table of Contents as a native Curio list or mind map collection. This
collection is dynamically generated and dynamically updates if changes are made to your project's Organizer hierarchy.
Dynamic Content
It's important to remember that the information in the Table of Contents is dynamic and not a static snapshot. If you modify any
items within the Table of Contents or their expand/collapse states then this will be reset the next time it has to regenerate.
If you drag the idea space containing the Table of Contents to a different location in the Organizer it will regenerate itself based on
its new placement. Similarly, a duplicate or copy/paste of the idea space containing the Table of Contents will regenerate based on
its new placement.
Of course, the specified Table of Contents style will be kept between regenerations.

Working with Table of Contents
1. Insert a Table of Contents either via the Insert main menu or the Insert toolbar button.
2. A list or mind map collection is inserted into the current idea space and automatically populated. The collection is comprised of idea space link figures, displayed
in icon mode, to all Organizer items after the idea space that contains the Table of Contents itself.
3. Clicking a link will jump to that idea space in your project. If you export your project as PDF, then clicking a link in the exported Table of Contents will jump to the
appropriate page within the PDF.

Managing the Contents of the Table of Contents
! The hierarchy included in the Table of Contents is based on where its containing idea space is located in the Organizer:
a. If the next Organizer item after this idea space is a child, thus this idea space is a parent, then the Table of Contents is of those children, recursively. This
option, in particular, is useful if you'd like to create multiple Table of Contents within the same project or section.
b. Else the Table of Contents is made up of the siblings that come after this idea space and the children of those siblings, recursively.

Styling the Table of Contents
1. Table of Contents collection is made up of standard idea space link figures, displayed in icon mode. The containing list or mind map collection can be styled with
any bundled or personal list or mind map style simply by choosing the style from the inspector style galleries.
2. You can also customize the collection then use Format > Set as Default Style to store that as the new default style. For example, choosing Format > Set as
Default Style for List (Table of Contents) Figure will make it the new default for list Table of Contents.

Updating the Table of Contents
1. The titles and previews of the idea space link figures which make up the Table of Contents will update automatically if changes are made to their destination idea
spaces.
2. And, when the Table of Contents idea space is revisited, either manually or when exported or printed, the Table of Contents will automatically determine if it
contains an out of date hierarchy and regenerate itself, if necessary.
3. You can also press the Regenerate button in the Table of Contents inspector to force a regeneration.

Using the Inspector
1. Select a Table of Contents then click its inspector icon in the inspector bar to change the following attributes.
2. Text Only Starting at Level
By default, Curio includes previews until hierarchical level 3 when it switches to text only entries.
3. Collapse at Level
By default, Curio automatically collapses the 2nd hierarchical level in the Table of Contents. If you'd like to see more, simply click a parent's expand widget to see
those child items.
4. Include up to Level
By default, Curio includes the first 3 hierarchical levels in the Table of Contents. For complex projects, reducing the number of levels can make generation faster.
Note that Curio may throttle the specified value if a massive number of entries would be created, see below for more details.
5. The Table of Contents detects when it needs to be regenerated automatically, but you can click this button to force a refresh.

Focus

STANDARD

Avoiding distractions within Curio
Using Focus
When working within Curio Professional or Standard sometimes you'd like to focus on a specific branch in a mind map or list, or
perhaps a particular figure on a busy idea space such as an album or text figure.
With Curio’s View > Focus feature this is easy to do.

Using Focus
1. Select one or more figures and choose View > Focus or press ⇧⌘F.
2. All other figures on the idea space will become transparent. If the selected figures are parent figures in a hierarchical collection such as a list or mind map then
any existing or new child nodes inherit focus as well.
3. To turn off focus simply choose View > Focus or press ⇧⌘F again. If you switch to another idea space or re-open your project focus is restored as well.

Related Features
1. All editions of Curio support the ` (backtick) feature. Simply press ` to instantly hide or show both the Organizer and Shelf which quickly declutters the interface.
2. Likewise all editions of Curio support the standard macOS full screen mode toggled via the View menu or by pressing ⌃⌘F.

PRO

Figure Layers

PRO

Independent layers of figures
What's a Layer?
Figures on Figures
On your idea space you have one or more figures, which are arranged and drawn in a back-to-front order. For example, with two
rectangle figures, you can drag one and it will either drag behind or in front of the other. You can use the methods like the Arrange >
Send to Back menu to rearrange this figure ordering.

Layers (of Figures) on Layers (of Figures)
All of those figures currently exist on a single, default "foreground" layer on your idea space. With layers in Curio Professional, your
idea space supports multiple independent layers, themselves arranged in a back-to-front order, each containing their own figures in
back-to-front order.

Example
For example, say you have a Background layer which is located under a Foreground layer. Curio will draw all the Background
figures first in back-to-front order, then it will draw the Foreground figures in back-to-front order.
You could have a much more complex example, with a dozen layers that you use to encapsulate and order information. Layers can
be visible or hidden, or perhaps visible in general but not printed or presented.

The Active Layer
A key aspect of layers is that only one layer at a time can be active. The active layer receives all mouse clicks and user interactions,
essentially ignoring the other layers. This means you can select, create, delete, rearrange, and modify figures only on the active
layer, which safeguards your other layers from accidental changes.

Activating a Layer
1. Click the Layers popover button located in the far-right area of the inspector bar. This button may be titled “Layer 1” as that’s the default layer in all idea spaces.
2. In the popover that appears, click the layer to switch to. This will be the new active layer and you can now create and modify figures on that layer.

Renaming a Layer
1. Click the Layers popover button located in the far-right area of the inspector bar.
2. Double-click on a layer to rename it, type in the new name, then press Return.
3. Note you cannot rename a layer inherited from a master template. It can only be renamed in the master itself. An icon alongside the layer name indicates if it is
inherited from a master template.

Inserting Layers
1. Click the Layers popover button located in the far-right area of the inspector bar.
2. Click either the Insert Above or Insert Below button to insert a new layer above or below the current, active layer.

Deleting the Active Layer
1. Click the Layers popover button located in the far-right area of the inspector bar.
2. Click the Delete Layer button to delete the layer. Or, with a touchpad or Magic Mouse, you can swipe a layer's entry in the list to delete it.
3. Note you cannot delete a layer inherited from a master template. It can only be deleted in the master itself. An icon alongside the layer name indicates if it is
inherited from a master template.

Rearranging Layers
1. Click the Layers popover button located in the far-right area of the inspector bar.
2. Drag-and-drop to rearrange the front-to-back ordering of your layers.

Locking Layers
1. Click the Layers popover button located in the far-right area of the inspector bar.
2. Click the lock icon to lock a layer so its figures cannot be edited.

Changing the Visibility of Layers
1. Click the Layers popover button located in the far-right area of the inspector bar.
2. Click the visible icon to hide or show a layer. Note hiding a layer acts as a override forcing the layer to be hidden when printing, exporting, or presenting
regardless of the restrictions discussed below.

Using Restrictions to Control the Visibility of Layers
1. Click the Layers popover button located in the far-right area of the inspector bar.
2. Assuming the layer is normally visible, you can restrict a specific layer from printing, exporting, or presenting by toggling the appropriate icon.

Moving Figures Between Layers
1. Select and cut the figures in their current layer.
2. Activate the layer where you wish to place them.
3. Paste the figures into this layer. They will be pasted in the same location as they were in their original layer.

Master Templates and Layers
1. Layers that are inherited from a master idea space template will show a special masters icon.
2. This indicates the layer cannot be renamed or deleted, although you can still rearrange, hide, or change its permissions.
3. Changes made to that layer in the master template will automatically be reflected in all idea spaces that inherit that master.
4. If you change to a different master template (via Change Masters) then any layers inherited from the current master will be removed and the new master layers
added.
5. Any layers that were created just for this idea space, thus not inherited, will remain as-is.
6. Any edited figures that came from the previous master that have identifiers (via the Info inspector) will be copied over to figures with the same identifiers in the
new master. So if you changed a figure identified as title from the old master then its content will be moved to a figure from the new master with the same
identifier.

Figure Styles
Styling figures is incredibly powerful
Figure Styles
As mentioned earlier, a figure style defines the look of the figure including properties such as color, border, font, and shading. You
can apply a style to a new or existing figure.
Curio organizes figure styles based on one of these core figure types:
• Basic Figure
• Image (aka an asset figure displayed as a preview instead of an icon)
• Line
• List
• Mind Map
• Table
• Index Card
• Pinboard
• Album
• Stack
You can easily create new figures styles containing all of its display attributes.

Styles with Sizes
When you save certain types of figure styles, sizing information will automatically be saved as well. These figure types include
images, albums, index cards, pinboards, stacks, and tables.
For image figures, Curio will then apply the style's size if you save the style as a default for image figures (Format > Save as Default
Image Style) and then drag in a new image, or if you apply a style to an existing image figure that you haven't sized yet.
For the collection figures (albums, index cards, pinboards, stacks, and tables) these sizes be used when you create a new
collection using that style, or if you apply a style to a collection that doesn't have any content in it yet.

Create a New Figure Style
1. Select a figure in an idea space.
2. Configure the attributes how you want them.
3. Right-click on the figure then choose “Save As FigureType Style” where FigureType will be replaced by the type of figure that is selected such as “Basic Figure” or
“Line” or “Mind Map”.
4. In the dialog that appears give the style a name and press the Save button.

Apply a Style to a Selected Figure
1. Click on the Style inspector button or right-click on the figure and choose “Apply Style” to bring up the Style Gallery for that type of figure.
2. The style popup menu will only display the named figure styles appropriate for the selected figure. For example, if you have selected an image figure, then only
the image styles will be displayed.

Create a Brand New Non-Collection Figure Based on an Existing Style
1. Click the Figures button on the toolbar.
2. The Gallery containing basic text figure styles and all non-collection stencils will appear.
3. Choose a style then click the Choose button. You may also simply double-click the style.
4. Some boilerplate text will automatically be added to your new text figure so you can see the effects of the style more easily.

Create a Brand New Collection Figure Based on an Existing Style
1. Click the appropriate collection button on the toolbar. For instance, click the List, Mind Map, Table, or Index Card toolbar button.
2. The Gallery for that collection figure will appear.
3. Choose a style then click the Choose button. You may also simply double-click the style.

Managing Figure Styles with the Gallery
1. Within the Idea Space Style Gallery you can perform a number of operations to better manage your idea space styles.
2. Copy a style simply by drag-and-dropping it into your Personal collection.
3. Delete a Personal style by selecting the style and pressing the Delete key.
4. Share a Personal style by right-clicking on the style and choosing Send to Friend or Send to Zengobi.

Default Style
Changing the default styling for a figure type
Changing the Default Figure Style
You can change the default look for several types of figures. For instance, you want all new text figures to be 10 point Times or new
web link figures should be 14 point Helvetica with a curved, bordered, and gradient-shaded outline.
Default styles can be overridden for each of the following figure types independently:
• Text
• Each of the various geometric shapes including rectangle, rounded rectangle, triangle, circle, trapezoid, speech, cylinder, house,
etc, available from the Drawing Tools popup or the Basic Shapes gallery.
• Lines
• Mind map relationship lines
• Images
• PDF documents
• Movies
• Music and sound
• Web links
• Documents
• Groups
• Lists
• Mind maps
• Tables
• Index Cards
• Pinboards
• Albums
• Stacks
Attributes included in the stye include text attributes, border shape, color, thickness, and pattern, fill color and style, interior margin,
opacity value, corners value, the visibility of shadows, to-do checkboxes, and ratings, and icon size.
Note if you’re using Curio Professional then if a master figure is selected when following the steps below then you are
defining a default master style for the current project (since masters are local to the project) instead of a global default.

Save a New Default Style for a Figure Type
1. Select a figure of the appropriate type in an idea space.
2. Change its look using the inspector, or apply an existing personal or bundled figure style from a Style popup. This is an important point as you can simply change
the attributes directly without using a saved style if you don’t want to.
3. Choose Format > Save as Default Style for Figure from the main menu.
4. Any new figures of the given type will be created using the default style you set.

Restore the Factory Default Style for a Figure Type
1. Select a figure of the appropriate type in an idea space.
2. If you’ve overridden its default styling then the Format > Restore Default Style for Figure menu will be available.
3. Choose that menu item and the styling override will be removed from your preferences and factory default styling for that figure type will be restored.
4. Any new figures of the given type will be created using the factory default styling, and that factory styling is applied to the currently selected figure, as well.

Apply the Default Format for a Figure Type
1. Select one or more unlocked figures on the idea space.
2. Choose Format > Apply Default Style for Figure from the main menu.
3. The appropriate default styling (whether that be the factory default or a user-overridden default) will be applied to all selected figures.

Figure Stencils

STANDARD

PRO

Reusable figures that you can create
Figure Stencils
Curio Standard and Curio Professional users can easily create new figure stencils that define not only the look of the figure but can
also contain placeholder or boilerplate text or figure items.
Recall that a simple figure stencil is one that includes a single figure. Even a single collection figure such as a mind map which
can in turn contain multiple figures within it is considered a single figure.
On the other hand a complex figure stencil is a stencil made up of multiple top-level figures. A perfect example is a landscaping
stencil where flowers, shrubs, and trees are represented by individual figures, images, or grouped figures. Those figures aren’t
contained within a collection, they exist directly on the idea space.

Create a New Simple Figure Stencil
1.

Select a single figure or a single collection figure in an idea space which you would like to copy as a stencil.

2.

Right-click on the figure then choose “Save As Style”.

3.

In the dialog that appears give the stencil a name and press the Save button.

Create a New Complex Figure Stencil
1.

In an idea space, carefully arrange all the figures you would like to have in the resulting stencil. The stencil will be stored and displayed with the figures in these
exact positions. So, in the landscaping example described above, you might place the flowers on one area of the idea space, trees in another, and shrubs in
another.

2.

Select one or more figures from the idea space.

3.

Right-click and choose “Save As Complex Stencil”.

4.

In the dialog that appears give the stencil a name and press the Save button.

Create a New Complex Figure Stencil Using All Figures in an Idea Space
1.

If you want to grab all of the figures in an idea space, carefully position them as described above then right-click on the idea space in the Organizer then choose
“Save Contents As Figure Stencils”.

2.

In the dialog that appears give the stencil a name and press the Save button.

Inserting a Stencil
1.

Click the Insert toolbar button and choose either Styled Shape or Stencil, for general figure stencils, or for collection-specific stencil click on that collection type
like List or Mind Map and you will find those stencils within that gallery. More information below in the “Using the Stencils Gallery Window” topic.

2.

Drag and drop stencils from the Stencils Library shelf, which is discussed in detail below.

3.

Use the Insert main menu menu where you will find submenus for Bundled Stencil, Personal Stencil, and Master Stencil. Then choose the stencil to insert.

Using the Stencils Gallery Window
1.

You can easily manage your stencils from within the Gallery window (accessible via Insert toolbar button, then click the appropriate gallery you wish to see, like
the List gallery) you can perform a number of operations to better manage your figure stencils.

2.

Create personal stencil tags by right-clicking in the Personal area in the repositories list on the left and choosing “Add Tag”. These tags are unique to the figure
stencils repository and won’t conflict with tags created for idea spaces in the templates repository, for example. These tags are available to all types of stencils
including collection stencils (lists, mind maps, etc.) and other simple and complex stencils.

3.

Organize your personal stencils by drag-and-dropping them into different tags. A template can be associated with more than one tag. So, a template can be in
your “Favorites” and “Work” tagged collections.

4.

You can also associate or disassociate a personal stencil with a tag by right-clicking on the template and choosing a tag in the menu that appears.

5.

Rename a personal stencil tag by double-clicking it and entering a new name.

6.

Delete a personal stencil tag by selecting it and pressing the Delete key.

7.

Copy a stencil from another repository simply by drag-and-dropping it into your personal collection.

8.

Edit a personal stencil by right-clicking on the stencil and choosing Edit Stencil.

9.

Delete a personal stencil by selecting the template and pressing the Delete key.

10. Share a personal stencil by right-clicking on the template and choosing Send to Friend or Send to Zengobi.

Using the Stencils Library Shelf
!

The Stencils library shelf perfect for power users of stencils, where you can easily drag-and-drop stencils from the shelf to your idea space. Read more in the
Stencil library section below.

Style
Changing the look of your figures
Change the look of your figure with just a click via the inspector bar or inspector shelf.

Style
The style information for a figure includes coloring, borders, fill, font, and much more. With
just a click the look of your figure can change completely. You can even save these looks
as personal styles to use them again and again.
At the far left of inspector bar you’ll find a Style button which displays a quick, popup
gallery for the currently selected figure. Simply click on a style to update its look.
You can also use the mini style gallery at the top of the Shape inspector shelf to do the
same thing.
And, lastly, you can right-click on a figure and choose Apply Style to choose a style from
the gallery that appears.
All of these interfaces give you an opportunity to choose either a bundled or personal
style that you have created. Curio Professional users can also select a master style.

Text
Customize your figure’s text properties
To change your figure’s text properties either use the text controls on the inspector bar, or
see the Shape tab in the Inspector shelf.

Text via the Inspector Bar
If the figure contains text then you’ll find several controls on the inspector bar itself for fast
access to popular attributes.

Font and Font Size
Select a font for the selected figure.
Select or directly enter a font size. Tip: you can also use the standard Command+ and
Command- keys to increase or decrease the font size.

Text Color
Specify a text color. Clicking will show a quick color chooser while Option-clicking will
display the standard Apple Color picker.

Highlight/Background Color
Specify a text highlight/background color. This color control remembers the last used
color even between launches.
Clicking will show a quick color chooser while Option-clicking will display the standard
Apple Color picker. Hold the Shift key and the color well will show that previously-used
color, the default is a nice light-yellow color, and then click the color well to apply that
color to the selected text for instant highlighting.

Character Attributes
Specify attributes such as bold, italic, underline, strikethrough, superscript, and subscript.

Markdown [Standard] [Pro]
Enable markdown syntax parsing and rendering. See the next idea space for more
details.

Shadow
Click the shadow button to display a popover allowing you to customize the shadow
applied to the figure’s text. Note this is different that the shadow which can be applied to
the overall figure itself as specified in the Shape inspector.

Paragraph Attributes
Click the paragraph button to display a popover for setting several paragraph properties.
You can also set many of these options by right-clicking on the text figure and using the
context menu that appears.
Minimum Height
A text figure can have a minimum height which is used when empty or when it contains
very little text. As more text is added, it will automatically grow in height as necessary to fit
the new text. As text is removed, it will shrink down to that minimum height. This feature is
very useful if creating forms or templates and would like to use text blocks for certain
areas. After enabling this feature, just resize the figure using the selection handles to set
the minimum height. This feature is also useful in combination with the maintain spacing
feature in the Geometry inspector so that neighboring figures will push away or pull back
as content is changed.
Freeform
If a text figure is freeform then that means you are in complete control of its width and
height, clipping any text vertically if necessary. If not freeform then Curio will automatically
grow a text figure’s height as necessary to hold its contents.
Line Height
If you have an idea space with only a horizontal grid, like a notebook paper grid, then the
line height can be set to match the grid’s spacing. Or the line height can be determine
automatically based on font size.

Additional Text Options via the Inspector Shelf
The inspector shelf will show other controls since there’s a bit more room in the shelf. In
addition to the controls listed above you’ll find…

Typeface
Select a specific font typeface, such as “Light” or “Medium Oblique”.

Automatic Capitalization
If a figure is selected, not just selected text within a figure, then you can select an
automatic capitalization such as lowercase, uppercase, sentence, capitalize, and
titlecase. Your text is stored as you entered it but will be transformed right before display
with the specified capitalization.
•

•

•

•

•

•

None
Rendered as entered.
"the new macos sierra for iMAC and MACBOOK Pro integrates with IOS devices."
Uppercase
Uppercase all letters.
"THE NEW MACOS SIERRA FOR IMAC AND MACBOOK PRO INTEGRATES WITH IOS
DEVICES."
Lowercase
Lowercase all letters.
"the new macos sierra for imac and macbook pro integrates with ios devices."
Sentence
Lowercase all except first word and products.
"The new macOS Sierra for iMac and MacBook Pro integrates with iOS devices."
Capitalize
Capitalize each word except products.
"The New macOS Sierra For iMac And MacBook Pro Integrates With iOS Devices."
Titlecase
Capitalize in general but lowercase certain words like ‘for’ and ‘and’, etc.
"The New macOS Sierra for iMac and MacBook Pro Integrates with iOS Devices."

Markdown [Standard] [Pro]
Enable markdown rendering. See the next idea space for more details.

Shape
Customize your figure’s shape properties
To change your figure’s shape properties either click the Shape button on the inspector
bar, or see the Shape tab in the Inspector shelf.

Shape
The figure shape inspector allows you to change visual properties such as coloring and
border style.

Color
Set the color of the stroke. In the case of a geometric figure this is the color of the border;
in the case of a line this is the line color. Simply click on the color well to see a quick color
matrix, or Option-click on the color well to see the standard Mac OS Color Picker.

Shape
Set the stroke shape such as Rectangle, Triangle, Hexagon, or Cloud.

Dash Pattern
Set the stroke dash pattern.

Width
Set the stroke width. Tip: press the [ or ] keys on your keyboard to decrease or increase
the current thickness of the selected shape figure or line figure.

Corner
Set the corner value which determines the radius of certain shapes, like rounded
rectangles, or the complexity of other shape, like clouds. In particular, the Left and Right
Signpost shapes and the Underline shape will change their look substantially as you
change the corners value.
Tip: press the { or } keys on your keyboard to decrease or increase the current corner
value of the selected figure.

Margin
Set the margin which determines the distance between a shape’s edge and its contents.
Tip: press the Option-{ or Option-} keys on your keyboard to decrease or increase the
current margin value of the selected figure.

Smart Coloring
Several smart options can be specified.
The fill color can be determined automatically by Curio so that it matches your selected
stroke color. Likewise, the figure’s text color can be determined automatically as
appropriate based on the fill color. Curio will automatically choose a white text color when
the fill is dark, else a black text color for lighter fill colorings.

Shape - Fill
Customize your figure’s shape properties
To change your figure’s shape properties either click the Shape button on the inspector
bar, or see the Shape tab in the Inspector shelf.

Shape - Fill Options
None
None will allow the figure to be transparent.

Solid
For solid fills, click on the color well to choose a color from the matrix that appears. Or,
Option-click on the color well to go directly to the standard color chooser.

Simple Gradient
For simple gradient fills, click on the color well to choose a color from the matrix that
appears. Or, Option-click on the color well to go directly to the standard color chooser.
Curio will then make a smooth gradient using that color.

Bowed Gradient
For bowed gradient fills, click on the color well to choose a color from the matrix that
appears. Or, Option-click on the color well to go directly to the standard color chooser.
Curio will then make a smooth bowed gradient using that color.

Linear Gradient
For linear gradient fills, drag the color stops to adjust the gradient ramping. Double-click
on a color stop to edit its color. Double-click on the gradient to insert a new color stop.
Drag a color stop down and off the gradient control to remove the stop from the gradient.
The resulting gradient will be rendered along the angle specified by the angle slider.

Radial Gradient
For radial gradient fills, drag the color stops to adjust the gradient ramping. Double-click
on a color stop to edit its color. Double-click on the gradient to insert a new color stop.
Drag a color stop down and off the gradient control to remove the stop from the gradient.
The resulting gradient will be rendered with a center point located as specified in the
point locator control.

Glossy Fill
For glossy fills, you choose just a single color and Curio will automatically construct the
appropriate gradient styling to render a glossy shape.

Shape - Display
Customize your figure’s shape properties
To change your figure’s shape properties either click the Shape button on the inspector
bar, or see the Shape tab in the Inspector shelf.

Shape - Display Options
Shadow
Enable a shadow for the figure. The shadow can be customized by specifying the color,
blur, and x/y offsets.
By default, if the figure is filled, then the shape’s shadow attributes are applied to the
shape itself, otherwise if the figure is unfilled, then those shadow attributes are applied to
its text.
You can control whether the shape shadow is automatically used as a text shadow. By
controlling this feature you can specify a shadow for the shape and a different shadow
style for the text itself, using the text inspector.

Shadow Effects
Enable a shadow special effect: pinched or bulged.
A pinched shadow looks like the figure has been placed on a tabletop where only the
bottom corners of the figure are slightly raised from the surface, like you're pinching the
edges and lifting them up.
A bulged shadow, is the opposite of a pinch: here the bottom center of the figure is
slightly raised from the surface, like you're creating a bulge in the center of the photo.
These effects are only available for filled, rectangular shapes with no curved corners.

Auto Inflate
Normally certain shapes are set to auto inflate automatically to minimize the amount of
clipping that would occur to its content whether that be text or an image.
For example, the Cloud shape automatically inflates itself a few pixels so the bumps of
the cloud don’t crowd or clip the content. The result is a nicer looking resulting shape
without you having to fidget with margins. You can turn this off if you wish to have more
direct control over your shape.

Preview vs Icon
For figures representing files, you can set whether the figure is displayed with the file’s
icon & title, like the Finder, or if the figure simply exists as an image preview.
As a tip, you can also right-click on a figure to change its display mode between icon and
preview and, when in preview mode, you can toggle the display of the preview caption.
If displayed as an icon then:
• An icon size slider will appear so you can specify its size. Up through a size of
128x128 the default icon for that document type is used, continuing up to 256x256 a
Quick Look thumbnail of the file is used for the icon instead. Note that this icon size
slider is also used for text figure attachments if one has been attached to a given
figure.
• You can change the icon’s title but note that Curio will also rename the underlying
asset file’s name as well, to keep them in sync. When setting the file name Curio will
automatically strip any invalid characters from the title text so macOS doesn’t
complain.
Else, if displayed as a preview then:
• If an image file, Curio will simply display that image, else Quick Look is used to grab a
preview of the file. Previews can be displayed with an optional caption which is
displayed under the preview image.
• Your previews can have captions if you wish. By default, these captions are placed
inside the overall shape border, or you can specify that captions should be displayed
outside the border. Captions can also be enabled via right-clicking on the figure.
Initially the caption will be the same as the underlying asset file’s name. However, you
can change this to anything you wish and the asset file’s name will not be changed,
thereby allowing long, detailed captions if you’d like.
• Alternatively you can tell Curio to clip the preview image to a specified mask. This is
useful when you want your overall figure to have one shape — and perhaps it contains
other contents such as text, fill color, and adornments — but you still want your image
preview to be clipped to a specific shaped mask, such as a circle.

Opacity
Set the shape opacity making the entire shape more or less transparent. Note that this
effects the entire figure uniformly.
For more advanced transparency effects, in lieu of setting the overall opacity, you can
specify a specific opacity for the shape’s fill, gradient, and stroke colors within the
standard Mac Color Picker.

Meta
Customize your figure’s meta properties
To change your figure’s meta properties either click the Meta button on the inspector bar,
or see the Meta tab in the Inspector shelf.

Adornments
An adornment is a little image that appears next to your figure. It may represent a tag, or
a due date, or a checkbox.

Size and Position
Set the size of the adornment images. Tip: press the Option-[ or Option-] keys on your
keyboard to decrease or increase the current adornment flag size for the selected figure.
Use the radial spinner to position the adornments all around the selected figures. You can
also indicate that the adornments should be displayed inside or outside the figure’s
border. Note that some collection figures may force the position of adornments.

A Note About Adornments
Many of the adornments displayed next to figures can be clicked-on and changed:
● Checkmark Adornment. Click to check/uncheck. Option-click to display the percent
complete mini popover. Command-click an unchecked item with a due date to check it
and change its due date to today.
● Tag Image Adornment. Option-click to display the tags mini popover. If the tag set is
“only one tag in set can be active” then if the tag is in a set with 3 or fewer tags within
then clicking the tag adornment will cycle through the tags. If more than 3 then a handy
popup will appear so you can choose one of the other tags.
● Start/Due Date Adornment. Option-click to display the start/due date mini popover.
● Rating Stars Adornment. Option-click to cycle through the ratings.
● Priority Adornment. Option-click to cycle through the priorities.
● Bookmark Adornment. Option-click to cycle through the bookmark colors.
● Jump Action Adornment. Click to perform the jump action.
● Note Adornment. Click to display the Notes window.

Meta - Checks
Customize your figure’s meta properties
To change your figure’s meta properties either click the Meta button on the inspector bar,
or see the Meta tab in the Inspector shelf.

Checkmarks
Toggle the display of checkboxes using the on/off switch. Click the adornment itself to
check or uncheck the figure.

Percent Complete
You can set a percent complete value from 0% to 100%. Use the stepper arrows to
increment/decrement by 1, or hold Shift and click to change by 5.
Checking is a shortcut to setting a percent complete of 100%. Likewise, unchecking is
the same as a 0% completion.

Child Figures
By default if the figure has children under it, like in a list or mind map, then its percent
complete value is automatically computed using the percent complete values of its
children.

Resources
If the figure has assigned resources then you can specify that the percent complete value
is computed using the percent complete value assigned to each individual resource in
the Resources tab.

Keyboard Shorcuts
Tip: press Shift-X to toggle the visibility of a checkmark for the selected figure. Press X to
check or uncheck it.

Mini Popover
Curio has a handy mini popover for setting percent complete which can be handy when
you don’t want to bring up the inspector.
To show the mini popover: Option-click an existing checkmark adornment, or press the
Period key. As a hint to remember this keyboard shortcut, think of a long line of dots
indicating progress being made. Use the stepper arrows to increment/decrement by 1, or
hold Shift and click to change by 5.
To hide the mini popover: press the Escape key, or click its little close button.

Meta - Dates
Customize your figure’s meta properties
To change your figure’s meta properties either click the Meta button on the inspector bar,
or see the Meta tab in the Inspector shelf.

Dates
Your figures can have assigned dates for easy task planning. Curio even supports
automatic date calculations in collections such as lists and mind maps so that tasks can
have precedence ordering.

Start Date
Enable start dates with the on/off checkbox. Then you can set a start date. The date can
be entered directly or you can click the little calendar button to pick a date.
Optionally Curio can automatically calculate the start date if you wish. Curio’s pretty smart
about this and will check to see if it should be determined by you manually entering a
date, or based on when a previous sibling (in a list or mind map) ends, or based on when
a previous sibling starts, or when a parent starts. Or you can directly choose one of those
options if you wish. For example, if an item is the first child in a list then Curio would
automatically choose ‘based on when parent starts’. If the item is a middle child then
Curio’s chooses ‘based on when previous sibling ends’.

Due Date
Enable due dates with the on/off checkbox. Then you can set a due date. The date can
be entered directly or you can click the little calendar button to pick a date.
As with start date, Curio can automatically calculate the due date if you wish. In this case,
the due date can be determined by you manually entering a date, or automatically
determined when this figure’s children have all ended, or based on the start date plus an
entered duration.
If the due date is at midnight then the due date adornment next to the figure reports the
day before. For example, say in the date inspector for a figure you set the start date to
June 6th at midnight and the due date to June 8th at midnight, thus it a 2-day duration.
The resulting adornment will show "6/6 - 6/7" since that looks more appropriate (i.e. you
have to work on the 2-day task on 6/6 and 6/7). This change was made so it matches
what is displayed in applications such as Calendars where the task would be displayed
from 6/6 to 6/7.

Start/Due Date Gear Button Menus
Note both the start and due date areas have gear button menus which allow you to
specify if ‘manually’ should always be used as the default.
Via the gear button you can also specify your project work schedule including work days
and work hours. Curio will use this work schedule to automatically determine task end
dates based on start dates and durations within the current project. For instance, click to
turn off Saturdays and Sundays if you want Curio to ignore weekends when calculating
due dates and durations. This same work schedule is taken under consideration when
using the +1 Day, +1 Week, and +1 Month buttons.
The start date gear button also allows you to specify what time should be used: either
midnight, the current time, or the workday start.

Duration
Specify a duration for the figure in minutes, hours, days, weeks, months, or years.
Curio can use these durations when computing start and due times for siblings and
parents figures in a hierarchical collection such as a list or mind map.
Note that if the due date is determined by some means other than Start Date + Duration
then the duration and most appropriate duration units will automatically be determined
and displayed.

Done Date
The done date is completely independent of a figure's specified end date. You can think
of the former as when the task was actually done, while the latter is when the task needs
to be done.
By default the done date is automatically set when a figure is checked or marked as
100% completed. The reverse is also true, if you set a done date Curio will make sure the
figure is marked as 100% completed and checked if the figure checkmark is visible.
The done date also has an gear button menu where you can fine-tune the done date’s
automatic setting, and also specify how the done date time should be reported: start of
the day, the end-of-work day as specified by the Workday Schedule (set via the dates
meta actions menu), or the end of day.

Added Date
The added date is set by Curio automatically when you add a figure to an idea space.
However, we allow you to change the date if you're trying to mark a specific date of entry
for note-taking or research purposes.

Mini Popover
Curio has a handy mini popover for setting dates which can be handy when you don’t
want to bring up the inspector.
To show the date mini popover: Option-click an existing date adornment, or press the
Slash (“/“) key. As a hint to remember this keyboard shortcut, think of a slash used in a
date such as 12/25/2013.
To hide the popover press the Escape key, or click its little close button.

Meta - Resources
Customize your figure’s meta properties
To change your figure’s meta properties either click the Meta button on the inspector bar,
or see the Meta tab in the Inspector shelf.

Resources
Assign resources to your figures and Curio can perform more advanced task tracking.

Adding Resources to the Project
You can specify a name, email address, and image for each resource either manually or
by drag-and-dropping contacts from the macOS Contacts app directly to the Resources
inspector panel.

Deleting Resources
Select one or more resource items then click the Remove button to remove them.

Assigning Resources
Click the resource’s checkbox to actually assign a resource to a figure.
Here you can also double-click the ‘% Complete’ field to enter that person’s percentage
complete value for this task. Curio can use all of these assigned completion values to
determine the figure’s overall completion value as noted above in the Meta tab discussion
above.
The resource’s image will be displayed next to figures as an adornment.
In a hierarchical collection, such as a mind map or list, you assign resources to child
nodes and the parent nodes automatically inherit them. You cannot assign resources to a
parent node directly unless you uncheck the inherit from children checkbox in the
resources inspector.

Actions
Assign an action to your figure
To change your figure’s meta properties either click the Meta button on the inspector bar,
or see the Meta tab in the Inspector shelf.

Figure Actions
The figure actions inspector can be used to specify what happens when a figure is
double-clicked within the idea space.

Setting an Action
Choose the desired action from the popup menu at the top of the inspector. The choices
of action include:
● Default: Do the default double-click action for this figure. For example, for an image
figure it would open the image, a URL would go to the web location in the browser, an
asset figure would open the asset file.
● Go to Idea Space: Choose an absolute item like first or last; a relative item like next or
previous; or backward or forward in history.
● Open URL: Enter a URL that should be opened.
● Create Mail Message: Enter a default ‘to’ and ‘subject’ field. Note that the message will
be created and displayed but not actually sent.
● Open File: Choose a file that should be opened.
● Jump Target: Begin by copying a figure or idea space so its jump location will be on
the clipboard. then click Retrieve from Clipboard here to retrieve it.
● Run AppleScript: When you click the Edit button the script associated with the action is
dumped to a temp file then Script Editor is launched to edit it and save to that location.
When you click the Update with Edits button Curio retrieves the contents of that temp
file and stores it back into the figure's action data.
● Do Nothing: Handy when you want to override the default so nothing happens when
this figure is double-clicked.

Adornment
By default Curio will show a little adornment next to a figure that has an assigned action.
You can specify whether that adornment is displayed or not.

Mac App Store Restriction
Curio from the App Store is
unable to support AppleScript
actions.

Geometry
Set the figure’s geometry and position
To view your figure’s geometry properties either click the Shape button on the inspector
bar and then click the Geometry tab, or see the Geometry panel in the Inspector shelf
under the Figure tab.

Bounds
The bounds defines the figure’s size and position in the idea space.

X, Y, Width, Height
Set the figure’s x, y location and the width and height.

Natural Size
Clicking Natural Size will restore the figure to its natural, native size. Tip: as a shortcut you
can just hit the N key at any time to restore a selected figure to its natural size.

Constrain Proportions
Set whether the figure is resized proportionally which is enabled by default for images
and asset figures displayed as previews. For non-image figures you can resize
proportionally on-the-fly by holding Shift and resizing with the figure’s selection handles.

Rotation
Specify the rotation of the figure, or zero the rotation. Tip: use the R and Shift-R keys to
rotate a figure in increments either clockwise or counterclockwise. The Z key can be used
to zero the rotation.

Auto Layout
The layout control is a method for defining how a figure should automatically position and
size itself if the idea space changes size.

Springs and Struts
It uses the "springs and struts" method for laying out items. The smaller, inner box
represents a figure, which is contained in a larger box which represents the idea space
itself. The red and green lines determine whether its position or size is fixed (a strut,
represented by a red line) or flexible (a spring, represented by a green arrow).

Examples
For example, give a figure a flexible width and a flexible top margin and you’ve created a
footer figure. Place it down at the bottom of your idea space and as the idea space
changes size the figure will remain stuck and centered at the bottom of the idea space.
At the top of this page, click on the subheading (“Set the figure’s geometry..”) and look at
its layout. It’s set to remain stuck to the right side of the idea space while its width is
allowed to change.

Automatic Layout via Idea Space Guidelines
Idea space guidelines provide a helpful margin around an idea space you you can drag
and resize items so they snap against the margin or even against the edge of the idea
space itself. You can toggle them via the Arrange > Idea Space Guidelines menu.
Start moving or resizing a single figure then hold down the Control key. You'll notice, as
you bump against a guideline, the guideline is drawn with red! This indicates that you
have set a new strut as a layout constraint and, indeed, if you watch the Geometry
inspector as you do this you'll notice springs and struts appearing automatically.
Thanks to this feature you can quickly position and size a figure along with setting
appropriate auto layout rules, all without touching the layout control.

Maintain Spacing
You can tell Curio to maintain the spacing of figures closely underneath the selected
figure. This means that this figure is resized, either manually or by changing styles or
content, then the figures closely underneath (within 50 pixels) will automatically scoot
down or back up as the figure's size changes. By setting this attribute, which can be
saved with custom figure styles, you can have figures shift themselves down and up as
figure contents change!
● The figure being resized must have the auto spacing property enabled.
● Only resizing an auto space figure impacts lower figures, not moves.
● Only those figures within the 50 pixel boundary will be moved up or down. If those
figures also have auto spacing enabled, then Curio looks below those figures as well,
and below those, etc...
● Moving a figure completely away doesn't collapse the figures. It's simply no longer
impacting those figures previously underneath it. It still has the auto space property, of
course, so now it will impact figures in its new location when it resizes.
● Moving a figure from elsewhere into an area close to another figure doesn't
automatically scoot everything down. Curio allows you to place things where you want it
to go.
● Again, resizing is what triggers the auto spacing. This means you can still manually
move and position figures anywhere you wish, maintaining the unrestricted, freeform
nature of the idea space environment.

Arrange
Drag the slide to bring the selected figures as a group either closer to the top of the figure
stack or further back.
If multiple figures are selected then those items are moved independently up and down
the figure stack, keeping their same relative stacked distance away from each other. In
other words, bringing forward figures placed at 5 and 10 in the figure stack will move
them to place 4 and 9, where 0 is at the top of the figure stack.
You can also click on the icons on the far left and right sides of the slider to move the
items back or forward in steps.
If the Option key is held down while clicking those back/front icons the selected figures
are moved together in figure stack as a group. That means they are grouped together into
the same stack placement then moved up and down en masse.

Flip
Click the flip buttons to flip an image figure vertically or horizontally.

Align & Distribute
Use the align and distribute buttons to quickly arrange multiple selected figures.

Line
Customize your figure’s shape properties
To change your figure’s shape properties either click the Shape button on the inspector
bar, or see the Shape tab in the Inspector shelf.

Line Options
If the selected figure is a line figure then you’ll find more options available to you.

Type
Specify how multi-point lines should be drawn: either straight, curved, or orthogonal.

Midpoints
Add one or more midpoints to your line. Note you can also right-click on the line to add a
midpoint at that location.
If you right-click on a midpoint you can remove it.
To move the midpoint, you can drag it although, especially with curved or orthogonal
lines, you may find using the keyboard arrow keys more reliable. Hold Shift when using
the arrow keys to take greater steps.

Scale
Set the scale of the arrow decoration which will increase or decrease their size.

Tail and Head Arrows
From the two lists you can choose a tail and/or head arrow decoration.

Overview
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Dynamic styles, stencils, templates
What’s a Master?
In Curio you’ve been able to create your own reusable figure styles & stencils and idea space styles & templates. You can save
these in your personal repository and use them across all of your projects.
You are able to update a style and re-save it to your personal repository. You can then use the updated style with new figures and
apply it to existing figures. Likewise you can update a saved personal stencil or template and then create new instances which will
reflect those changes.
However, existing figures or idea spaces that used one of those personal styles, stencils, or templates aren’t spontaneously
updated throughout all of your projects, as that could get quite messy.

Introducing Master Styles, Stencils, and Templates
This changes in Curio Professional with master styles, stencils, and templates. These are private to a specific project which means
Curio can support dynamic updates across all the idea spaces in that project.
Create a “Heading” master figure style, use it across your project. Later change the style to a larger point size and color and the
style change is instantly reflected across all uses of the figure style.
Create a master figure stencil for an web site interface prototype and use it throughout a project, then later update that stencil with a
different fill color and font choices and instantly the change is reflected across the project.
Lastly, create a master idea space template with headings, subheading, and positioned body text. Use it as a basis for dozens of
idea spaces in your project. Later, change the master with additional elements, changed fonts, or repositioned figures, and the
changes is reflected across your project.

Styles

PRO

Dynamic figure and idea space styles
Master Styles
A master style is one that is private to your project and, if the master style is updated, then those changes are immediately
broadcast and applied to all idea spaces or figures that adopt that style. A master style can be created from scratch or from an
existing style found in a personal, bundled, or external repository.
If you're familiar with Pages, Word, or even css then master styles are similar to the style support you see in those apps, where you
can change a style, say for "Heading 1", and throughout your document all "Heading 1" text items are updated to reflect the new
style.
Note that a style only defines the look of the idea space or figure. It doesn’t include any boilerplate text or images.

Sample Workflow
1. Create a text figure that you'll use for a heading on an idea space and use the inspector to style it the way you wish with
appropriate colorings, fonts, etc.
2. Right-click on the figure and save the style as a master style named "Heading".
3. Use the "Heading" style with other text figure instances scattered on idea spaces throughout your project.
4. If you want to change its look, click on an instance, change any properties you wish using the inspector such as font size and
text color, then click the Update button in the Styles inspector. Or, if you wish, you can right-click on the instance and choose
update style from its context menu. You could also choose to reapply the style if you didn't mean to change its look.
Instantly the style change is broadcast and applied to all figures that adopted that style.

Using the Style Inspector Shelf
The Style inspector now includes a Masters option in the repository popup so you can see the styles available in that pseudorepository.
Other style inspector shelf changes related to masters include:
• Copy to Masters
Right-click on a style that isn't a master style and choose to Copy to Master to copy the style into a master style and then
associate the selected idea space or figure with that new style.
• Delete / Mail
Right-click on a master style to delete it, or mail it to a friend or Zengobi.
• Update
A new Update button allows you to instantly update a changed a master or even a personal style with changes. Note that this
performs the same action as right-clicking on the figure or idea space background and choosing Update Style.

Using the Galleries
Within the various idea space and figure galleries — via the Add or Insert button, of the Apply Style menu, or Style inspector bar
button — you'll find a new Masters pseudo-repository there which contains all applicable master styles (and stencils/templates).
Other gallery changes related to masters include:
• Copy to Masters — Right-click on an idea space template, figure stencil, or style that's not in the Masters repository and choose
Copy to Masters.
• Drag and Drop — Drag-and-drop an idea space template, figure stencil, or style from another repository into the Masters
repository folder to make a copy. You can also drag from Masters to Personal if you wish.
• Delete — Right-click on an idea space template, figure stencil, or style in Masters repository and choose Delete. You may also
simply press the Delete key. Existing instances of a template or stencil will remain as-is.
• Edit — Right-click on a master idea space template or stencil and choose Edit Template / Edit Stencil to switch the Organizer to
masters, select the appropriate master item, and display the template or stencil in the main viewing area for editing. Click the
Done button in the Organizer header area to end editing.

Using Master Styles
Dynamically updated styles
Create a Master Style
1. Right-click on an idea space in the Organizer, the idea space’s background, or on a figure within an idea space and choose Save as Style.
2. In the dialog that appears choose whether to create a personal style, a master style, or both a personal and a master style. Choosing both will allow you to use
the style as a master in this project, but also places it into your personal repository so you can use it in other projects.

Updating a Master Style
1. Make changes to the appearance of your idea space or figure.
2. Right-click on the idea space or figure and choose Update Style or click the Update button on the Style panel in the inspector shelf.

Reverting or Reapplying an Original Master Style
! If you make changes to an idea space or figure and want to reapply the original master styling for that object then right-click and choose Reapply Style.

Deleting a Master Style
! In the Style panel of the inspector shelf, right-click on the style and choose Delete Style.

Sharing a Master Style
! In the Style panel of the inspector shelf, right-click on the style and choose Send to Friend or choose Send to Zengobi if you’d like to share your style with other
Curio customers.

Copying a Master Style into Your Personal Repository
1. If you create a master style that you’d like to use in other projects then you need to copy it into your personal repository.
2. In the Style panel of the inspector shelf, right-click on the style and choose Copy to Personal.

PRO

Stencils

PRO

Dynamically updated figure stencils
Master Stencils
A master stencil is one that is private to your project and, if the master stencil is updated, then those changes are immediately
broadcast and applied to instances of the stencil.
If you're familiar with the app Sketch then master stencils are similar to that app's symbol support, where you can change a symbol,
say for an elaborate UI component, and throughout your document all instances of that component are updated to reflect the new
changes.
Note that while a style only defines the look of a figure, a stencil can be made up of several figures and include text and images, as
while as the style information associated with each item. When you use a stencil then you are essentially creating and using an
exact copy of the original figure stencil.

Sample Workflow
1. Create a text figure that you'll use as a note figure with a special flag adornment, coloring, font, freeform size, and placeholder
text.
2. Right-click on the figure and save the stencil as a master stencil named "Note".
3. Using the Stencils shelf or the Insert > Styled Shape or Stencil gallery, insert that Note stencil onto idea spaces throughout your
project.
4. Edit the stencil either by right-clicking on an instance of the stencil on the idea space, or on the stencil itself in the Stencils shelf
or insert gallery, or by finding the stencil in the new Masters Organizer, discussed below.
5. Change the look and contents of the stencil then click Done at the top of the Masters Organizer.
Instantly the changes to the stencil are broadcast throughout the project to any instances.

Overrides
You can make some changes to your stencil instance and they won't be replaced when you change the master.
•
•

•

•

Figure Position
Changes made to the positions of individual figures within a complex master stencil are not broadcast to instances.
Figure Size
Changes made to the size of a master stencil are broadcast and applied to instances, unless you manually change the size of
an instance. This is handy if you need to change the size of an instance to accommodate more text, for example.
Figure Text
Changes made to the text contents of figures on the master stencil are broadcast to instances, unless you manually change the
text of an instance.
Figure Style
Changes made to the style of figures on the master stencil are broadcast to instances, unless you manually change the style of
an instance including font and font size.

Limitations
While figure stencils are quite powerful they do have some limitations:
If you delete a figure from a complex master stencil then instances are removed elsewhere in the project. However, if top-level
figures are added to the master then those new figures do not suddenly appear elsewhere in the project.
! Key Exception: if you delete a figure within a grouped figure then that change is reflected elsewhere.
Newly added or removed items found within collection figure stencils, such as nodes within a mind map, will not be broadcast to
instances.
⁃ Key Exception: if you add a figure within a grouped figure then that change is reflected elsewhere.

Using the Masters Organizer
Click the new Masters button in the Organizer header to view the Masters Organizer. The Masters button looks like a broadcast
symbol since changes to a master are broadcast throughout your project.
The header area will change so you see the blue masters header and Done button. Underneath is pair of buttons you can use to
switch between your master idea space templates and your master figure stencils.
You can make changes to any of your stencils then click the Done button when you're ready to broadcast the changes throughout
your project.
In general working in the Masters Organizer is similar to the normal Organizer, but here are some notes:
• Master templates and stencils can be rearranged, renamed, and deleted, but they cannot be indented or color-coded.
• Right-click to copy, paste, duplicate, rename, or delete a selected item.

Using the Stencils Shelf
The Masters option also appears in the Stencils shelf so you can see the stencils available in that pseudo-repository.
Other style inspector shelf changes related to masters include:
• Copy to Masters
Right-click on a stencil that's not in the Masters repository and choose Copy to Master Stencils.

Using the Galleries
When you click the Insert toolbar button and go into the various figure galleries, you'll find a Masters pseudo-repository there which
contains all master styles and stencils. Select a master stencil and click the Insert button to insert a new instance of that master into
your idea space. If you later update the stencil then this instance will be updated as well.
Other gallery changes related to masters include:
• Copy to Masters
Right-click on an idea space template, figure stencil, or style that's not in the Masters repository and choose Copy to Masters.
• Drag and Drop
Drag-and-drop an idea space template, figure stencil, or style from another repository into the Masters repository folder to make
a copy. You can also drag from Masters to Personal if you wish.
• Delete
Right-click on an idea space template, figure stencil, or style in Masters repository and choose Delete. You may also simply
press the Delete key. Existing instances of a template or stencil will remain as-is.
• Edit
Right-click on a master idea space template or stencil and choose Edit Template / Edit Stencil to switch the Organizer to
masters, select the appropriate master item, and display the template or stencil in the main viewing area for editing. Click the
Done button in the Organizer header area to end editing.

Using Master Stencils
Dynamically updated figure stencils
Create a Master Stencil
1. Right-click on a figure within an idea space and choose Save as Figure Stencil.
2. In the dialog that appears choose whether to create a personal stencil, a master stencil, or both a personal and a master stencil. Choosing both will allow you to
use the stencil as a master in this project, but also places it into your personal repository so you can use it in other projects.

Editing a Master Stencil
1. Right-click on an instance of the stencil on the idea space and choose Edit, or…
2. Right-click on the master stencil itself in the Stencils shelf and choose Edit, or…
3. Click the Masters button in the Organizer header to find and edit the stencil manually.
4. The Organizer will switch to the Masters Organizer and you will then edit your stencil within an idea space view. Once you are done, simply click the Done button
in the Masters Organizer header to save and broadcast the changes throughout the project to any instances.

Deleting a Master Stencil
! In the stencil gallery or shelf, right-click on the stencil and choose Delete Stencil.

Sharing a Master Stencil
! In the stencil gallery or shelf, right-click on the stencil and choose Send to Friend or choose Send to Zengobi if you’d like to share your stencil with other Curio
customers.

Copying a Master Stencil into Your Personal Repository
1. If you create a master stencil that you’d like to use in other projects then you need to copy it into your personal repository.
2. In the stencil gallery or shelf, right-click on the style and choose Copy to Personal.

PRO
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Templates
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Dynamically updated idea space templates
Master Idea Space Templates
A master idea space template is one that is private to your project and, if the master template is updated, then those changes are
immediately broadcast and applied to instances of the template.
If you're familiar with Keynote or PowerPoint then master idea space templates are similar to the master slide feature in those apps,
where you can change a particular master slide and throughout your presentation all slides based on that master are updated to
reflect the new changes.
Note that while a style only defines the look of an idea space, an idea space template includes style information and any figures
located on the idea space. When you use a template then you are essentially creating and using an exact copy of the original idea
space template.

Sample Workflow
1. Create an idea space with an appearance and containing the boilerplate figures you would like to use repeatedly throughout
your project.
2. Right-click on the idea space in the Organizer and choose "convert to master" to instantly save the idea space as a master
template and then automatically convert the selected idea space into an instance of that master. Alternatively you can do the
same thing via the "save as template" option from the context menu to show the standard save template dialog.
3. Note that the icon for idea space instance now has a little master-broadcast icon so you know it inherits changes from a master
template.
4. Add new figures to this idea space instance, as you would work with a normal idea space.
5. When you want to create another instance simply click the Add toolbar button and choose the master from the pick list where all
masters are listed at the bottom with the little masters icon, or drill down in the idea space gallery and choose it from the
masters repository.
6. To edit an idea space's master template, you can
7. Change the look and contents of the master idea space template then click Done at the top of the Masters Organizer.
Instantly the changes to the template are broadcast throughout the project to any instances, which could include other master
templates that are based on this master template.

Overrides
You can make some changes to your idea space instance and they won't be replaced when you change the master.
•

•

•

•

•

Idea Space Dimensions
Changes made to the dimensions of a master idea space are broadcast and applied to instances, unless you manually change
the dimensions of an instance. Note that width and height are tracked separately so you can grow the idea space instance
vertically and still inherit the width from the master, for example.
Figure Position
Changes made to the positions of figures on the idea space master are broadcast and applied to instances, unless you
manually change the size of an instance. This is handy if you need to change the size of an instance to accommodate more text,
for example.
Figure Size
Changes made to the size of figures on the idea space master are broadcast and applied to instances, unless you manually
change the size of an instance. This is handy if you need to change the size of an instance to accommodate more text, for
example.
Figure Text
Changes made to the text contents of figures on the idea space master are broadcast to instances, unless you manually change
the text of an instance.
Figure Style
Changes made to the style of figures on the idea space master are broadcast to instances, unless you manually change the
style of an instance including font and font size.

Limitations
While master idea space templates are quite powerful they do have some limitations:
•

Newly added or removed items found within collection figures, such as nodes within a mind map, will not be broadcast to
instances.

Warning
While working on a master template it is very important to remember if you delete a top-level figure, or move a top-level figure into a
collection, then when you commit the changes those figures that have not been edited will be deleted from all idea spaces that
inherit from the master. If the inherited figure has been edited then it will remain on the idea space, even if the figure on the master
was deleted, in order to prevent accidental deletion of important data.

Using the Add Button
Assuming you're viewing the normal Organizer, click the Add toolbar button you'll notice that any master template are listed at the
very bottom of the popup, with the masters “broadcast” symbol on the right side. Choose one and a new idea space instance of that
master template will be added to your project.
Notice when you use a master template to create an idea space, the preview image for the new idea space in the Organizer will
show a little masters broadcast symbol in its lower-right corner. This way you know it’s based on a master template.

Nested Masters
If you create a new master based on an existing master, via the Add toolbar button with the Masters Organizer is active, then that
new master will inherit changes made to its "parent" master. You can continue this process so that changes to Master A go to
Master B go to Master C go to...
This might be useful if you define a "Background" idea space master then create duplicates that define "Chapter" and "Slide"
masters. Change the background of Background and instantly all masters change and thus all instances of all of those masters
change.

Using the Masters Organizer
Click the new Masters button in the Organizer header to view the Masters Organizer. The Masters button looks like a broadcast
symbol since changes to a master are broadcast throughout your project.
The header area will change so you see the blue masters header and Done button. Underneath is pair of buttons you can use to
switch between your master idea space templates and your master figure stencils.
You can make changes to any of your templates then click the Done button when you're ready to broadcast the changes throughout
your project.
In general working in the Masters Organizer is similar to the normal Organizer, but here are some notes:
• Master templates and stencils can be rearranged, renamed, and deleted, but they cannot be indented or color-coded.
• Right-click to copy, paste, duplicate, rename, or delete a selected item.

Using the Galleries
When you click the Add toolbar button and go into the idea space gallery, you'll find a Masters pseudo-repository there which
contains all master idea space styles and templates. Select a master template and click the Choose button to add a new instance of
the master to your project. If you later update the master template then this instance will be updated as well.
Other gallery changes related to masters include:
• Copy to Masters
Right-click on an idea space template, figure stencil, or style that's not in the Masters repository and choose Copy to Masters.
• Drag and Drop
Drag-and-drop an idea space template, figure stencil, or style from another repository into the Masters repository folder to make
a copy. You can also drag from Masters to Personal if you wish.
• Delete
Right-click on an idea space template, figure stencil, or style in Masters repository and choose Delete. You may also simply
press the Delete key. Existing instances of a template or stencil will remain as-is.
• Edit
Right-click on a master idea space template or stencil and choose Edit Template / Edit Stencil to switch the Organizer to
masters, select the appropriate master item, and display the template or stencil in the main viewing area for editing. Click the
Done button in the Organizer header area to end editing.

Tagged Sets of Master Idea Space Templates
If you create a whole series of master idea spaces for a project and want to re-use them it's super easy! Just select all the master
idea spaces in the Masters Organizer, right-click and choose to save them to a named tagged set in your personal repository, such
as "Portfolio". You can choose an existing tag or enter a new name.
Later when you want to use that set, simply choose File > New, select the name of your personal tag set, "Porfolio" in this case, and
click the Use Tagged Set as Masters button. A new project will be created with all the idea spaces in that tagged set preloaded as
master idea space templates.

Master Styles via Master Templates
Say you define that "Heading" master figure style then you apply it to figures on several master idea space templates. Change the
master style and then all master templates update and thus all instances of those master templates update.
Next, say you save your master idea space as a personal idea space template (or perhaps as a tagged set in your personal
repository) then you use that template in another project. If that template becomes a master template then any master styles
embedded within the template will be automatically recovered and available as master styles in the new project.
Note this only happens if the idea space template becomes a master again, simply inserting an instance of the personal template
into your Organizer won't recover the master styles. You could do this via tagged sets, described above, or the convert to master
idea space template right-click option in the Organizer.

Change Masters

PRO

Adopt a different master template
Placeholder Figures and Changing Masters
Normally you can't apply an idea space template to an existing idea space, since Curio wouldn't know what to do with the existing
figures. However, this is indeed possible with master templates and a new figure identifier property.
Recall that a master template defines the style of the idea space and contains boilerplate figures. In many instances you may want
those boilerplate figures to be placeholders (perhaps with "lorem ipsum..." text) that you'll edit and fill in with real data in the
instance of the template.
For instance, you may have master templates with "title" and "body" placeholder text figures but where the figures are positioned
and styled very differently. Perhaps these templates also contain other figures unique to themselves in addition to those placeholder
items. If you create an instance of one of these masters, edit and replace all the placeholders, then realize you wish you had used a
different master, it would be nice if you can click to switch it to the stylings of the other, without having to recreate the whole thing
from scratch.

Identifier
Using the new figure Identifier field, accessible via the figure's Info inspector, this is now possible. Curio has what it needs to map
placeholders figures from one master to another.
Edit your master templates and give the figures that represent placeholder items appropriate identifier values, such as "title" and
"body".

Identifier Glow
When you edit an idea space that has figures with locally defined identifiers (that is, not inherited from a master) then those figures
will glow green instead of blue and their tooltips will show their identifiers. This is helpful when you want to quickly make sure
appropriate figures have set identifiers.

Change Master
Click Done to exist editing masters, then create a new instance of one of those masters.
Edit and change the placeholder text as necessary. If you decide you want to change to the different master, notice that the normal
styles area of the inspector shelf shows master templates for the idea space instead. Just click on a different master in the
inspector, or right-click on the idea space in the Organizer and choose Change Master, to instantly change to that master.
Behind the scenes, Curio will style the idea space to match the new master's style, use the identifiers to map figures from the old
master to the new master thus keeping their contents intact, remove any figures that were unique to the old master, add any figures
that are a part of the new master, and leave any figures you added on your own to the instance in place, as is.
As a note, this list of master templates you can change to is filtered to only include other masters which support figures with
identifiers that the user has changed in the current idea space. Therefore if, in your instance, you have changed the "title" figure
then only other masters that contain a "title" figure will available. That way you can't switch to a master that wouldn't support your
changed figure.

Using Master Templates
Dynamically updated idea space templates
Create a Master Template
1. Right-click on an idea space and choose Save as Master Template, or…
2. In the Masters Organizer, you can create a new master template using the Add toolbar button. With this technique you can create a master template based on
another master template, thus nesting the templates. Changing a “parent” master will reflect those changes down the line to other masters (recursively), and then
refresh all impacted idea spaces that use those masters.
3. In the Masters Organizer, you can duplicate an existing master template via the Edit > Duplicate menu item. The result is another master which is an exact copy
of the original master.

Editing a Master Template
1. Hold Option and double-click the idea space instance in the Organizer, or…
2. Right-click on the idea space instance in the Organizer and choose Edit, or…
3. Click the Masters button in the Organizer header to find and edit the template manually.
4. The Organizer will switch to the Masters Organizer where you can edit your master idea space template.
5. Once you are done, simply click the Done button in the Masters Organizer header to save and broadcast the changes throughout the project to any instances.

Deleting a Master Template
1. Go to the Masters Organizer by clicking the Masters button on the Organizer header area.
2. Select the master template you wish to delete and press the Delete key. Note that all uses of this master will still remain intact in your project.

Sharing a Master Template
! In the add idea space gallery, right-click on the template and choose Send to Friend or choose Send to Zengobi if you’d like to share your template with other
Curio customers.

Copying a Master Template into Your Personal Repository
1. If you create a master template that you’d like to use in other projects then you need to copy it into your personal repository.
2. In the add idea space gallery, right-click on the style and choose Copy to Personal.

Disconnecting from a Master Template
! If you want to disconnect a master template instance from its master then right-click and choose Disconnect from Master. After confirmation, the idea space will
be independent and no longer receive updates from its former master template.

Assigning Identifiers to Figures to Support Change Master
1. When editing a master template, select a figure and click the Info inspector bar button to bring up the Info inspector popover.
2. There you can enter an identifier such as title, subheading, or body.
3. Curio uses identifiers with the same names across different masters to support the Change Master functionality.

Changing to a Different Master
1. You can change an idea space so it adopts a different master either by right-clicking on the idea space in the Organizer and choose Change to Master, or click on
the new master at the top of the inspector shelf.
2. Note this list of master templates you can change to is filtered to only include other masters which support figures with identifiers that the user has changed in the
current idea space. Therefore if, in your instance, you have changed the "title" figure then only other masters that contain a "title" figure will available. That way
you can't switch to a master that wouldn't support your changed figure.

Creating a Reusable Set of Master Templates for Use in Creating New Projects
1. Go to the Masters Organizer by clicking the Masters button on the Organizer header area.
2. Select all the masters you wish to want to include in the set.
3. Right-click and choose Save to Tagged Set.
4. Enter a new tag or choose an existing tag to add to an existing set.

Using a Tagged Set of Masters When Creating a New Project
1. Choose the File > New menu item to bring up the new project gallery.
2. On the far left, expand the list of templates available under the Personal repository.
3. Select the name of your personal tag set then click the Use Tagged Set as Masters button.
4. A new project will be created with all the idea spaces in that tagged set preloaded as master idea space templates.

PRO

Master Markdown Styles
Define your own markdown styles
Heavy users of markdown will appreciate Curio’s support for master markdown styles.
Using a specified style file, Curio can apply styling attributes to certain markdown elements within a project, specifically the six
markdown headers (#, ..., ######).
Here’s a portion of a sample master markdown style file:
# = font-family:Helvetica Neue UltraLight;font-size:32;font-color:#376098;
## = font-family:Helvetica;font-size:28;font-color:#ff00ff;font-bold:1;
It's a pretty simple text file format:
• Each header element (#, ..., ######) is defined on its own line.
• The font attributes are a semicolon-delimited collection of key/value pairings each separated by a colon.
• Spaces before and after the =, :, and ; are ignored.
When the style file is changed, the updated style changes will be broadcast throughout your project instantly updating all text
figures which use those markdown elements.
You can also create a global master markdown style file for use in all projects.

Attribute Example

Description

font-family:Helvetica

The specific font face like "Helvetica Neue UltraLight" or general font family like "Helvetica".

font-color:#ffff00

The color for the font, in hex syntax.

font-bold:1

Enable bold. Useful if a general font family is specified instead of specific font face.

font-italic:1

Enable italics. Useful if a general font family is specified instead of specific font face.

font-underline:1

Enable underline.

font-strikethrough:1

Enable strikethrough.

line-height-multiple:1.2

The natural line height will be multiplied by this value (default is 1).

line-spacing:5

The additional distance in points between lines (default is 0).

paragraph-spacing-before:5

The distance in points before this header (default is 5).

paragraph-spacing-after:2

The distance in points after this header (default is 2).

Edit a Project’s Master Markdown Style File
1. Use the Format > Edit Master Markdown Style File menu item to edit your project's master style file in the default editor for .txt files, such as TextEdit.
2. When you save your changes and switch back to Curio, Curio will automatically notice the updates and re-render your visible idea spaces and queue up preview
regeneration for all project idea spaces just in case they contain markdown as well.
3. If you remove the contents of the style file then the file itself will be automatically removed from the project package when you switch back to Curio.

Import a Master Markdown Style File
! Alternatively, if you have an existing markdown style file you wish to use, choose the Format > Import Master Markdown Style File menu item and the file will be
copied into your project and then stylings applied throughout.

Global Master Markdown Style File
! If you place a Markdown Styles.txt in your ~/Library/Application Support/Curio/Version XX/Repository folder (where XX is your Curio version, like 12) then it will
be used to define default master markdown styles for all Curio projects. Styles defined in that file will be read first, then you can override or add more styles with
your project specific master markdown styles.

PRO

Journal

STANDARD

PRO

An integrated journal to track daily activities
Curio Standard and Professional include an integrated journalling feature. Curio's project journal feature allows you to log meetings,
make class notes, keep a journal or diary, and much more! All neatly organized, sorted, and managed by Curio with automatic year
and month groupings.
Year/Month Folders and Sorting
Your Journal section is automatically sorted and arranged by Curio, with year and month folders added or removed as necessary for
your entries. Years are displayed in descending order (2021, 2020, 2019), months within each year are in ascending order (January,
February), and entries within each month are in ascending order as well (May 1, May 2, May 3).

Viewing the Journal
1. To begin, click the Journal icon in the Organizer header bar to switch to Journal mode, creating the Journal section automatically, if necessary.
2. Your project's Journal section appears under your normal sections but above the Archive and Trash sections.
3. You can only have a single Journal section per project.

Adding New Journal Entries
1. With Journal mode active, click the Add button to create a new journal entry. Bundled, personal, and master journal templates are automatically listed within the
Add button's popup or you can choose from the gallery or a blank idea space.
2. Your new journal entry will default to today. You can use the date chooser in the inspector bar to change the journal entry to a different date.
3. Within the Journal Organizer, Curio automatically creates and titles the encapsulating year and month folders, and the idea space entries.

Changing Entry Dates
! To change the date associated with a Journal entry, use the date chooser in the inspector bar.

Working with the Journal Section
1. You can rename your Journal section if you'd like, perhaps calling it Class Notes, Lab Observations, or Meetings if that makes more sense for your project.
2. You can associate a color label via the right-click context menu.
3. You are allowed to delete the Journal section, unlike the special Archive and Trash sections. Select the Journal section and press the Delete key to delete it.
4. You can also rearrange the Journal section among your other sections, although it can't be a child under another section nor can another section be a child of it,
and like other sections it has to stay above the Archive and Trash.
5. You can't rearrange the idea space entries within the Journal section, since they are automatically sorted by the entry date. Instead, if you'd like to change the
date associated with a Journal entry, use the date chooser in the inspector bar.
6. You can drag journal idea space entries and folders from the Journal of one project to the Journal of another, but you can't drag the actual Journal section from
one project to another.

Journal Entry Titles
1. You can change the date format for Journal entries displayed in the Organizer by right-clicking and choosing a new date format from the Journal Date Format
submenu.
2. Many popular date formats are included, plus the standard short, medium, long, and full date formats from System Preferences > Language & Region >
Advanced > Dates. There are also advanced options to make your own date formats as detailed via Help > Curio Advanced Settings.
3. Note if an Organizer filter is active then a different date format is used since you won't see the encapsulating year and month folders. For example, if the entry is
normally titled "March 1" then that may not help in a collection of filter results. So, when a filter is active a more verbose date format is displayed for the entry
titles, such as "Sun, Mar 1, 2020”. You can right-click and override that date format as well via the Journal Date Format submenu or directly then relaunch.

Saving Custom Journal Templates
1. To create your own journal templates, go into Journal mode, select an existing journal idea space entry that you'd like to save as a template, then right-click and
choose Save As Idea Space Template.
2. Like normal templates, it can be stored as a personal and/or a master template (the latter only if you're on Curio Professional).
3. A "Journal" template gallery collection will be created automatically for the new template, if necessary, to help keep them organized in the idea space gallery. All
personal and master journal templates in their respective "Journal" collections will appear directly in the Add button popup for quick access.
4. As a tip, you may want to use a variable such as IdeaSpaceDateAddedFull instead of IdeaSpaceTitle for your headings within your journal entry idea spaces if
you'd like a specific date format there, instead of one tied to the Organizer's setting.

Scribbles

STANDARD

PRO

Freeform sketching
Using Brushes, Pens, and the Eraser
For Curio Standard and Professional customers, the tools palette includes a brush and eraser tool so you can sketch out an idea or
drawing.
Inevitably, while brainstorming or thinking through an idea, you may need to sketch something out when the keyboard just won’t do.
Fortunately, Curio has a scribble mode with sketching tools built right in, so you don’t have to stop and launch another application
when inspiration strikes.
Curio comes with several pens and brushes to use when drawing, including a pencil, ballpoint, felt tip, paint brush, and highlighter.
Each stylus has different settings for color, line thickness, and opacity that have been configured to mimic the real world object that
it represents. Using the inspector you can change the color, brush thickness, and opacity of any stylus.
Many of the styluses are also fully pressure-sensitive when used with a graphics tablet, such as a Wacom or an iPad with Apple
Pencil connected via the macOS Sidecar feature, whereby the brush size and color saturation may change while you are drawing
based on the pressure applied to the pen.
You can press the B key on your keyboard to quickly choose the brush tool. Press E to choose the eraser.

The Scribble “Onionskin”
While sketching, your scribbles will appear on top of all other figures and items on the idea space. The scribble layer acts as an
onionskin appearing on top of your idea space.

Draw with a Pen or Brush
1. Click on the Brush tool in the toolbar and choose the brush or pen you want to use. Note for super-responsive mouse handling the idea space will temporarily go
into Quick Render mode where shadows are hidden and text rendering is optimized.
2. You can quickly choose a color from the narrow color palette in the inspector bar or the much larger color palette in the inspector shelf. On the far left of the
inspector bar’s color palette, or at the top of the inspector shelf’s palette, you can see the current, active color. If you click that color control then you can bring up
Apple’s standard color picker to choose any color.
3. Begin drawing in the idea space. While in scribble mode, you can continue to change the brush attributes or choose a different brush or pen from the inspector
bar.

Erase a Portion of Your Drawing
1. Click on the Eraser tool in the toolbar or inspector bar and “draw” where you want to erase. You can even change the size of the eraser using the inspector.
2. Alternatively, you can use the Select tool in the toolbar to drag-select a region then press the Delete key to delete it. You can hold down the ⌥ (Option) and ⌘
(Command) keys while dragging to select only your scribble and not any figures or other items on the idea space.
3. Lastly, if you are using a graphics tablet that has a pen with an eraser tip, you can simply turn the pen over to erase a portion of your drawing.

Convert a Scribble to an Image Figure
1. Using the Select tool in the toolbar drag-select a region. You can hold down the ⌥ (Option) and ⌘ (Command) keys while dragging to select only your scribble
and not any figures or other items on the idea space.
2. Choose Edit > Convert Selection to Image Figure.
3. You now have an image figure that you can treat as a normal figure on the idea space: give it a border, move it above or below other figures, or even add it to a
list or mind map.

Convert a Figure to a Scribble
1. Using the select tool in the toolbar (looks like a mouse arrow pointer) select one or more figures.
2. Choose Edit > Convert Selection to Scribble.
3. You can now use the scribble layer’s pens, brushes, and eraser to modify the figure.

Scribble Inspector
Customize your art supplies
When in scribble mode the inspector bar and inspector shelf changes to reveal handy
controls for working with the pens and brushes.

Brush Palette
Click a brush to activate it. Each brush’s color and inspector settings are independent
from each other.

Brush Color
Displays the current brush color. Click to bring up the standard Mac Colors picker.

Color Palette
The scribble inspector displays the full, large-sized 13x10 matrix displaying 10 shades
each of grays and colors. The inspector bar shows a more compact strip with only 5
shades each of grays and colors.

Brush Size, Opacity, and Pressure Sensitivity
Set the size and opacity of the currently selected brush. Tip: you can change the brush
size on-the-fly with the [ and ] keys on your keyboard.
If you’re using a pen-based graphics tablet, like a Wacom tablet or an iPad with Apple
Pencil connected via the macOS Sidecar feature, then the brush size and color can be
pressure-sensitive if those toggles are enabled. In that case the specified brush size and
opacity is the maximum size given a maximum amount of pressure.
Click the Reset Brush to reset the selected brush to its factory defaults.

Restrictions
You can choose whether the scribble on an idea space is printed, exported, or presented.

STANDARD

PRO

Overview
Find what you need on the Curio shelf
What is the Shelf?
The Curio shelf is a popup area located on the right side of the Curio window. Curio includes several shelf modules that run within
that area to help you while you’re working on your project such as the Search shelf to find information.

Inspector
View or modify properties of a selected item
Accessing the Inspector Shelf
You can access the inspector shelf by clicking on the Inspector toolbar button. Go ahead and do it now so you can look at it while
we go over some things.

Context Sensitive
The inspector shelf shows properties of the selected figure or idea space. The inspector panels that appear within the shelf are
context sensitive so, based on what’s selected, the available panels and tabs may change.
For instance, select a text figure and you will see certain tabs at the top of the inspector shelf. Click on a list and a tab titled “List”
will appear with more options. Click on the background of the idea space so no figures are selected and the inspector content will
change to show properties of the idea space, such as background color and dimensions.

Inspector Popovers
As mentioned earlier in this document, you can access many of the same panels via buttons on the inspector bar. In many cases,
those buttons will reveal popovers that appear so you can make property changes, then dismiss the popover when you’re done.
Sometimes popovers are more convenient than the inspector shelf, especially for small laptop screens, because they only take up
room temporarily.

Detachable Popovers
Inspector popovers can also be detached by clicking and dragging on their background to “tear” them off the inspector bar and turn
them into free floating windows. You can drag these small windows anywhere on the screen, or even to a separate screen attached
to your Mac.
Relaunching Curio will automatically restore those same detached popovers.

Search
Find figures in your project
Accessing the Search Shelf
You can access the search shelf by clicking on the Search toolbar button or press ⌘F. Go ahead and do it now so you can look at it
while we go over some things.
On a related note, if you want to filter the display of Organizer items based on various criteria then check out the Organizer Filter.

Search Criteria
You can choose a saved search from the popup located at the bottom of the search shelf, or perform a new search by filling out one
or more of the search criteria. Checking on the criteria checkbox will expand that panel to show its options.

Text
Text specified will be used to perform a case-insensitive search. When searching Curio will look at all text associated with a figure
including text figure content, figure notes, asset figure file name, figure tag names, etc. Curio will also search idea space asset and
other Organizer item assets by searching their titles.
You can optionally include the file content of your asset figures in the text search. Note that Apple’s SearchKit cannot search within
every type of asset, but appears to work very well with plain text, RTF, RTFD, HTML, and PDF files. For Pro users that have
external asset libraries, those file assets will be searched using Spotlight instead of SearchKit so any Spotlight plugins you have
installed will help Curio look into 3rd party application documents, as well.
You may use simple boolean expressions to search such as “zengobi or curio”, which will find any figure with the word “zengobi” or
“curio” associated with it (as whole words), while “zengobi and curio” will return those figures that have both words somewhere in
the figure’s text. Note that currently you can’t mix or and and expressions.
You can also use special prefixes, described below, so a search for “zengobi and #work” will find items with the text “zengobi” and
the tag of “work”. Another example, “#work or #home” find figures with either of those tags. And “#zengobi or@george or curio” will
return all figures with the “zengobi” tag, the “george” resource, or the word “curio”.

Tasks
You can choose to search for only unchecked or checked items.

References
You can search for figures which has references to a specific reference type, or to any reference type. See below for a note on how
to export a CSV report of all cross references.

Tags
All available tags are displayed, organized by tags local to this project or by global tag set name. Select one or more tags that must
be associated with each returned result.
You can also use text search field to search for tags if you preface it with a #. For example, searching for #legal will do a search for
a tag named legal. On a related note, the Curio Spotlight importer has been updated to include any assigned tags within the
project's scanned metadata with and without the # prefix. This means you can use Spotlight to search for legal or #legal.

Rating
Select a star rating, plus choose whether an item must have rating equal to, less than or equal to, or greater than or equal to the
specified rating.

Priority
Select a priority, plus choose whether an item must have priority equal to, less than or equal to, or greater than or equal to the
specified priority.

Asset Type
Narrow your search down to a specific type of asset.

Last Modified
Select a date range for when matching items were last modified. You can also create and select project milestones so you can see
all figures changes since a particular milestone. For instance, create a milestone for the first time you demonstrated your product
during a client visit. Then you can use the Search shelf to easily find all figures modified since that visit.

Resources
Select one or more resources that must be associated with each returned result.
You can also use the text search field to search for resources if you preface it with a @. For example, @george will find figures
associated with the resource named “George Browning”. Note that the @ prefix can search based on partial matches.

Start Date
Select a date range for when matching items will need to start as specified by their start date meta data.

End Date
Select a date range for when matching items will be due as specified by their due date meta data.

Done Date
Select a date range for when matching items were actually completed as specified by their done date meta data.

Added Date
Select a date range for when matching items were added to the idea space as specified by their added date meta data.

Search Scope
Choose a search scope to indicate whether you want to search the entire project, the current section, the current section tree
(meaning this section and any child sections), the current idea space, the current idea space tree (meaning any child items as well),
the project Archive, or the project Trash.
Note that the Archive and Trash are only searched if that scope item is selected.

Search!
Once you have set all of the options you wish to search for, click the Begin Search button. A list of the matching figures within the
current Project will be displayed. You can group the matching figures by a number of options by choosing the appropriate option
from the Group By popup menu. You can even group the results by a specified tag set.
To jump to a specific result, simply click on the item in the result list. The figure will be momentarily highlighted within its idea space.
Non-matching figures are automatically faded into the background so that the matching figures stand out better.

Saving Search Criteria
Use the actions button at the very bottom of the search shelf to save search criteria to use so you can easily reuse it again.

Canceling the Search
Click the “Cancel Search” button in the search shelf, or press ⌘F again, or press the Search toolbar button again which will also
close the Search shelf.

Exporting Results
Between the “Refine Search” and “Cancel Search” buttons you’ll find an export icon. Click that to copy your result as rich text, or
export your search results in rich text, markdown [Standard] [Pro], or CSV format. You can also export a CSV report of all figure
cross references [Pro] in those results, see References for more details.

Search - RegEx

PRO

Use regular expressions when searching!
Regular Expression Support
For Curio Professional users, the Search shelf text field now supports regular expressions.
Internally Curio uses the Mac's built-in NSRegularExpressions class for searching so it uses that syntax. For more information see
this tutorial and Apple's guide.
Here are some examples:
curio

A normal search; matches figures with 'curio' anywhere even if within another word, like 'zengobicurio' or 'curiosity'.

^curio

Matches figures only if 'curio' is the first word.

\bcurio

Matches figures only if 'curio' begins a word thus matches 'curiosity' but not 'zengobicurio'.

zengobi|curio

Matches figures with either 'zengobi' or 'curio' anywhere, even if within another word.

\bzengobi\b|\bcurio\b

Matches figures with either 'zengobi' or 'curio' as whole words.

zengobi.*curio|curio.*zengobi

Matches figures with both 'zengobi' and 'curio' anywhere, even if within another word.

\bzengobi\b.*\bcurio\b|\bcurio\b.*\bzengobi\b

Matches figures with both 'zengobi' and 'curio' as whole words.

Library
An amazing reference set
Accessing the Library Shelf
You can access the search shelf by clicking on the Library toolbar button. Go ahead and do it now so you can look at it while we go
over some things.

Library Modules
Based on the edition of Curio you own, you will find several installed library modules listed with tabs at the top of the library shelf.
Let’s begin our tour of the available library modules…

Project
The library of assets in your project
Using the Project Library
Every project has an internal asset library which manages all aliased and embedded files dragged into Curio.
Generally you use the project library to see what assets are in your library and re-use existing assets. When you use the same
asset more than once in your project it is actually only stored as a single underlying file in the asset library.
To use an asset simply drag-and-drop it out of the library and drop it onto the idea space. This will create an appropriate asset
figure to be associated with the dragged asset. Again, you can use this technique to create numerous asset figures of the same
asset and Curio will efficiently use the same single underlying asset file.
If you select and delete an asset using the Delete key the file will be removed and any asset figure instances of it on any idea
spaces will be removed from your project. You have to confirm the removal of an asset since this cannot be undone.

Context Menu
Right-click on an asset to perform one of these actions:
•
•
•
•
•
•
•
•
•
•

Open — will launch the asset file using the Finder.
Open With — where you can choose a specific application to open the asset file.
Open URL in Browser — if a URL is associated with the asset then it will be opened in the default browser such as Safari.
Reveal in Finder — will reveal the asset file within a Finder window.
Reveal in Idea Space — will show where the asset is instantiated in one or more idea spaces.
Embed within Project — is used to replace an alias to a file into an embedded copy of that file.
Copy to Curiota — will copy the asset file to the Curiota companion app.
Copy to Desktop — will copy the asset file to the Desktop.
Mail as Attachment — will create a new mail message with the selected file as an attachment. If more than one asset is
selected then a zip of all the selected assets will be added as a single attachment.
Duplicate — will create a copy of the asset and store it in the project library.

Show the Project Library
1. Click the Library shelf toolbar button, then click the Project tab at the top of the shelf.
2. You can also right-click on an asset figure on an idea space and choose Reveal in Library to see the associated asset in the project library.

Add New Files to the Project Library
! Drag-and-drop one or more files from the Finder to the Project Library view. By default a copy of each file will be embedded in your project asset library. If
Command is held during the drag then the files will be moved to the library. If Option is held then an alias to each file will be added to the library.

Search the Project Library
! Enter a search phrase in the Search field and press Return.

Filter the Results by Scope
1. Click the Scope popup to change the search scope: the entire project, the current section, the current section tree (meaning this section and any child sections),
the current idea space, the current idea space tree (meaning any child items as well), the project Archive, the project Trash, only unused (orphaned) assets that
aren’t in use in any idea space.
2. Note that the Archive and Trash are only searched if that scope item is selected.

Filter the Results by File Type
! Click the Kind popup to see only certain types of files. These can include general types such as document, images, or movies, or specific types such as PDF or
Adobe Photoshop files.

Filter the Results by Last Modified Date
! Click the Modified popup to filter the results based on when they were last modified.

Change the Sort Order
! Click the Sort By popup to change the sort: title, last modified, date added to Curio, file size.

Duplicate an Asset
! Select the asset and choose Edit > Duplicate. The new asset will be selected and the word “copy” will be appended to the end of its name.

Local
The library of files on your Mac
Using the Local Library
The Local library uses the power of Spotlight to quickly find files on your hard disk using a number of criteria including text, tags,
modification date, and kind of file. When searching for text Curio can search just file titles or also include the actual content of the
files. The results can be sorted by file title, last modified date, creation date, or file size.
For example, use Local to find all images modified in the past 2 weeks. Or all files with a tag “School” created in the past month.
Note: Since the Local shelf uses Spotlight to conduct the searches only files and folders indexed by Spotlight can be found. If you
restrict or disable Spotlight in System Preferences then certain locations may not be searchable.
You can direct Local to search your entire Mac, or restrict the scope to your Home folder and any folders it contains. Even better,
you can extend this with additional custom scope folders. For example, you might add your Dropbox folder, your Google Drive
folder, and a special project folder that you use a personal “inbox” for files and snippets to peruse later.
Assuming you have installed Curiota, the Local scope popup will also list your Curiota Inbox and any Curiota collections, including
your pre-Curio 10 Scrapbook repository which was automatically converted into a Curiota “Scrapbook” collection. More information
regarding Curiota can be found at www.zengobi.com/curiota.
To use a file simply drag-and-drop it out of the Local library and drop it onto the idea space. Doing this will embed a copy of the file
into your project. Hold Option while dragging the file to create an alias to the original file, or hold Command to move the file into
your project (therefore removing it from its original location).
If you select and delete a file from Local using the Delete key the file will be moved to the Trash.
You can double-click a file in Local results to open it, right-click to open it with a selected app or reveal it in the Finder, or press
Spacebar to get a Quick Look preview.

Context Menu
Right-click on an asset to perform one of these actions:
•
•
•

Open — will launch the asset file using the Finder.
Open With — where you can choose a specific application to open the asset file.
Reveal in Finder — will reveal the asset file within a Finder window.

Show the Local Library
! Click the Library shelf toolbar button, then click the Local tab at the top of the shelf.

Search the Local Library
! Enter a search phrase in the Search field, or change some of the other search criteria such as scoping, file kind, and modification date.

Filter the Results by Scope
! Click the Scope popup to change where Local will search for files. You can use the actions button next to this popup to add custom search folders, such as
Dropbox. Note that the scoping is normally recursive meaning that folders within the specified folder will also be searched, although you can disable this if you
wish using the checkbox located below the Scope popup.

Filter the Results by File Type
! Click the Kind popup to see only certain types of files. These can include general types such as document, images, or movies, or specific types such as PDF or
Adobe Photoshop files.

Filter the Results by Last Modified Date
! Click the Modified popup to filter the results based on when they were last modified.

Change the Sort Order
! Click the Sort By popup to change the sort: title, last modified, file size.

Stencils

STANDARD

PRO

The library of reusable figure stencils
Using the Stencil Library
Of course, you can use the Insert toolbar button to bring up the Figure Styles and Stencils gallery and click to insert a stencil.
However, if you use a lot of stencils, having a shelf where you can very easily drag-and-drop stencils from the shelf to your idea
space is invaluable.
Note that, like the Insert popover’s stencil gallery, the stencil library shelf will display both simple and complex stencils, for single
figure and multiple figure stencils, respectively. The title of the complex stencil will show the number of contained figures within in
parentheses. You can either drag the entire complex stencil into your idea space or double-click to drill into the complex stencil and
drag figures within the complex stencil out.

Context Menu
Right-click on an asset to perform one of these actions:
•
•
•
•

tag name — choose a checked or unchecked tag to toggle the tags associated with this stencil.
Edit Stencil — to edit the stencil.
Send to Friend — to email the stencil to a friend.
Send to Zengobi — to email the stencil to Zengobi if you’d like us to be able to share it with others..

Show the Stencils Library
! Click the Library shelf toolbar button, then click the Stencils tab at the top of the shelf.

Filter the Results by Repository
! Click the Repository popup to change where to find Stencils. By default Curio will look at bundled figure stencils but you can choose personal stencils or a
stencils in an external repository specified in Curio’s preferences. Curio Professional users can choose to see Master stencils, as well.

Filter the Results by Tag
! Click the Tag popup to see only those figure stencils associated with specific tags. You can use the actions menu next to this popup to create new stencil tags.
Then right-click on the stencils themselves to associate them with one or more tags. Note that tags can only be created within your Personal repository.

Change the Sort Order
! Click the Sort By popup to change the sort: title, most recently used, or date added to the repository

Add a Stencil Via the Stencils Library
1. You can drag-and-drop an idea space from the Organizer directly to the Stencils shelf to save the entire contents of the idea space as a figure stencil.
2. This is in addition to the other methods of creating a stencil such as by right-clicking on a figure and choosing Save as Figure Stencil.

Delete a Personal or Master Stencil from the Stencils Library
! Select the stencil then press the Delete key.

Sleuth

STANDARD

PRO

The library of the internet
Using the Sleuth Library
The Sleuth library is a new, more accessible method for quickly conducting research while working on your Curio project.
It provides a subset of the sites the primary Sleuth window supports, that work well within the more compact width of the shelf.
Currently there’s no way to customize the available Sleuth sites that appear in the Sleuth library shelf as they require a bit of testing
to insure smooth operations in that slim area.
To use the Sleuth library simply type in a search term and quickly find images, definitions, synonyms, videos, and much more. Then
drag-and-drop results from the Sleuth shelf directly to your idea space.

Show the Sleuth Library
1. Click the Library shelf toolbar button, then click the Sleuth tab at the top of the shelf.
2. Or, Shift-click on the Sleuth toolbar button or press ⌥⌘F (or Edit > Search in Sleuth Shelf).
a. The shelf will open if necessary and the Sleuth library will immediately become active.
b. Any text that was selected or if a selected figure contains text will immediately become the search phrase for the Sleuth library and the search will begin.
c. This is an incredibly fast way to search for phrases on the internet.

Change the Search Site
! Click the site popup to change where Sleuth is searching, or click the stepper to walk through the available Sleuth sites.

Evernote

STANDARD

PRO

The library of your Evernote cloud
Using the Evernote Library
Curio integrates seamlessly with Evernote so you can quickly search for snippets you’ve collected outside of Curio and easily drag
and drop those items into your idea spaces.

What Is Evernote?
Evernote is a multi-platform product and service from Evernote Corporation which allows you to easily capture information in any
environment using whatever device or platform you find most convenient, and makes this information accessible and searchable at
any time, from anywhere.
Evernote has client applications for macOS, iOS, Microsoft Windows, Windows Mobile, and even a web-based solution. Data
collected on any of these clients are automatically synchronized between each other via the evernote.com service.
All clients are free and the service is free with some restrictions, although incredibly full-featured for a free product. Users can also
upgrade to a premium service plan for more features. To learn more about Evernote go to http://www.evernote.com.

Yinxiang Bĳi /

/ Evernote China

Curio should connect to Yinxiang Biji, Evernote’s China-based service, automatically using the user’s (a) China-based IP address,
and (b) Chinese locale setting in System Preferences > Language & Region.
If this isn't working then type the following into Applications > Utilities > Terminal and re-launch Curio:
defaults write com.zengobi.curio "Evernote Force Host" -string "app.yinxiang.com"

Evernote Business
Curio currently does not work with Evernote Business accounts due to complexities in dealing with these types of accounts.

Log into the Evernote Service
1. Once you have your Evernote account established through their website, http://www.evernote.com, click on the Evernote shelf icon within Curio.
2. Enter your Evernote username and password. If requested, this information can be remembered for quick access in the future.
3. Click the Login button to log into Evernote.

Search for Evernote Items
1. All search terms are optional but can include one or more of the following: search text, notebook, tag, kind, and last modified date. Search text is wildcarded at
the end (so searching for the word ever will find evernote, for example) unless the phrase is quoted.
2. You can also specify how the results should be sorted when displayed and what zoom level should be used for the resulting preview images.
3. The results are automatically refreshed as you make your selection changes. You may also click the Refresh button to force a refresh.

Add an Evernote Note to an Idea Space
! Drag the note from the Evernote shelf and drop it into an idea space. When dragging an Evernote note out of the shelf into your idea space, it is normally copied
into your project. You can hold down the Command key while dragging to move it to your project, automatically removing it from the Evernote cloud.

Add a Link to an Evernote Note to an Idea Space
! Hold down the Option key and drag the note from the Evernote shelf and drop it into an idea space. This will create an “evernote://“ link that, when clicked, will
launch the Evernote Mac client and open the referenced note within that application.

Use Quick Look on an Evernote Note
! Press the Spacebar to activate Quick Look on the selected Evernote note.

Open an Evernote Note
! Double-click an Evernote note in the shelf to open it with the Finder.

Delete an Evernote Note
! Select an Evernote note and press the Delete key to delete it from the Evernote cloud.

Evernote Details
More information about the Evernote library
Tags
Your Evernote tags and notebook names are automatically synchronized into Curio with two special Curio global tag sets: “Evernote
Tags” and “Evernote Notebooks”. These new tag sets can be found in the Curio Preferences > Tags window.
Then, when a note is dragged from the Evernote shelf into the idea space, the Evernote tags and containing notebook names are
mapped their Curio tag counterparts.
This tag mapping feature allows you to use the Curio Inspector Bar or Search shelf to quickly find figures on your idea spaces
collected via Evernote.

Character Recognition Data
The Evernote service will automatically scan any images for handwritten or typed words.
When an image note is dragged into Curio, that character recognition information is embedded as meta data in the resulting Curio
asset figure. This feature allows you to use Curio’s Search shelf to find those images on your idea spaces using the same search
phrases.

Source URL
If an Evernote note item has a source URL associated with it then the resulting figure will automatically be associated with that URL
as well. Simply double-click the figure in the idea space to open the URL. If the note is a file, like an image file, then right-click and
choose Open File With Finder to open it with the Finder.

Limitations of the Evernote Shelf
The Evernote shelf is currently unidirectional so you cannot make changes to any of your Evernote notes from within Curio. Please
use one of their free clients to make any changes.

Evernote's 3rd Party App Rate Limits
Evernote imposes rate limits on all 3rd party apps which limit the number of calls an app can make to the Evernote cloud within a 1hour period. Therefore several changes were made to Curio's Evernote shelf so we greatly reduce the number of calls made to the
Evernote cloud.
•
•
•

•
•
•

Curio will no longer automatically download all notes in the selected notebook to the local cache.
Instead we will only auto-download the first 5 notes in the resulting list. There is now an advanced setting if you wish to increase
this value, although don't make it too high or you could hit the rate limit.
When you select any note in the result list, if it isn't already local, Curio will then immediately download it from the cloud. Related
to this, you can only select a single note at a time to ensure that we only download precisely what the user needs and we
minimize our connections to the Evernote servers.
A note will now clearly indicate if it is on the Evernote cloud, is being downloaded, or is in the local cache.
Instead of downloading the note's resources and recognition data as separate calls to the cloud the entire note is grabbed with a
single call which is much more efficient.
Once a note is local you can hit spacebar to preview it, double-click to open it, or drag it to an idea space to embed a copy of the
note in your project.

Evernote hasn't provided any specifics so we don't know exactly what these limits are or if the limits are the same for regular vs.
premium users. However, with these changes we have optimized Curio's Evernote integration as much as possible to greatly
reduce the chance that you'll hit the limit within 1-hour periods.

Advanced Evernote Customizations
The Evernote shelf supports a few advanced customizations. Open Terminal (found in Applications > Utilities) and type one or more
of the following preference modifications and relaunch Curio.

To enable basic logging (or click here):
defaults write com.zengobi.curio "Evernote Log Level" -int 1

To enable verbose logging (or click here):
defaults write com.zengobi.curio "Evernote Log Level" -int 2

To disable all logging (or click here):
defaults delete com.zengobi.curio "Evernote Log Level"

To disable associating a Curio tag for the note’s Evernote notebook when the note is dragged into
Curio (or click here):
defaults write com.zengobi.curio "Evernote Assign Notebook Tag" -bool no

To disable associating Curio tags for the note’s Evernote tags when the note is dragged into Curio (or
click here):
defaults write com.zengobi.curio "Evernote Assign Note Tags" -bool no

To change the number of notes that will be downloaded and cached automatically (or click here):
defaults write com.zengobi.curio "Evernote Auto Download Limit" -int 5

The maximum number of notes which can be displayed in a notebook (or click here):
defaults write com.zengobi.curio "Evernote Results Limit" -int 500

Status

PRO

Cross-project task tracking
Accessing the Status Shelf
You can access the status shelf by clicking on the Status toolbar button. Go ahead and do it now so you can look at it while we go
over some things.

Overview
Curio’s Status shelf view packs a lot of information into a compact display.

Projects Area
The top pane of the Status shelf shows your projects grouped in to the same categories that you created either in the Open Project
Gallery described earlier or by using the Add New Category gear menu selection.
Under each project title in the top pane, you will see a count of a subset of your tasks in the project. The subset is defined as tasks
that have a start date and you have not yet started or that have a due date and have you have not yet completed. When you start a
task (by setting or completing it to a certain percent) or complete a task, it is not counted in this list. When no tasks are yet to be
started or due on a project, Curio will indicate in the top pane by a statement that "No tasks to start or due". The count of tasks in
the top pane is therefore different than what you will see in the bottom pane, where tasks can appear regardless of whether they
have start or due dates and regardless of whether they have been started.
Finally, a color coded jewel to the left of the project title indicates the status of each project. Red indicates tasks are late to begin or
are overdue, magenta indicates a task is starting or due today, purple indicates a task is starting tomorrow, brown indicates a task is
starting or is due within a week, blue indicates a task is starting or is due within a month and green indicates either no tasks or a
task is starting or is due beyond a month.

Tasks Area
At the bottom you’ll find all the tasks due in either the current project or a category of projects. These tasks can be grouped by start/
due dates, priority, rating, or even a tag set such as flag or GTD state. Each task is displayed with a color-coded status jewel and a
checkmark indicating its current completion date.
Note that a task, as currently defined, is a figure with either (a) a checkbox, (b) a start or due date, or (c) an assigned tag. A tagged
item is considered a task primarily for GTD or Kanban task tracking workflows.

Toolbar Icon
The Status shelf icon displayed on the toolbar has a color-coded indicator dot as well showing the status of the current project. If
green then all’s well, but other colors would alert you so you can click the button to display the Status shelf and see what task
needs your attention.

Getting Things Done (GTD)
“Getting Things Done” is a popular method of task management in use today. Using the Meta Inspector discussed in the chapter
titled “The Idea Space” and Curio’s built-in GTD. tags, you can very easily implement the “Getting Things Done” methodology within
your Curio projects.
For example, you may have several days of meeting notes spread over multiple idea spaces within a project. At each meeting, you
made a list of action items and tagged them appropriately. Some you may have tagged as “active”, others “nextAction”, and still
others “waitingOn”.
Using the Search shelf view, you can easily find a list of all the items you tagged “active”. But even better, you can use the Status
shelf view and group your tasks by the GTD tag set. In a single list, you’ll see all the items you tagged with GTD tags, broken down
into each category appropriately. You’ll instantly know what your current active items are, what your next actions are, and what
items are on hold, waiting for input from an external source.
You can use Curio’s tagging system, Search shelf, and Status shelf to implement a wide variety of task management
methodologies.

Status - Projects
Using the projects area of the Status shelf
Change the Scope
! Use the Projects In popup to determine what projects to display either based on a smart category or custom category. See the Open Project Gallery section
described earlier for more details regarding project sections.

Change the Sorting
! Use the Sort By popup to change how the projects are listed: by status, title, last modified date, or date created.

Adding Projects
1. Drag a project from the Finder into the list to add it to the current custom category.
2. Note this only works with custom categories as the projects listed within smart categories, such as “Recently Opened Projects”, are determined automatically.

Deleting Projects
! Select a project and press the Delete key to remove a project from a category. Curio can also send the project to the Trash if you wish.

Ignoring Projects
1. You may want to ignore tasks in specific projects that are either on hold or simply no longer actively used. You don't want to remove those projects from their
respective categories but you really don't want tasks from those projects cluttering up your Status shelf results or live exports.
2. Right-click on the project in the projects list at the top of the Status shelf and toggle the Ignore Tasks In Project setting.
3. An ignored project’s tasks will no longer appear in the Status task results area or in live exports.
4. You can control whether ignored projects are displayed in the projects list at the top of Status using the the Projects In actions menu’s filtering options.

Assigning Categories to Projects
1. Right-click on a project to associate or disassociate categories with the selected project.
2. Or, use the gear button menu to add the current project or a specified project to the current category.

Creating, Modifying, and Deleting Categories
! Use the actions menu to create, rename, or remove project categories.

Switching to a Project
! Click on the project to load it within the current window.

Opening a Project in a New Window
! Option-click on a project to open it in a new window.

Finder Tags
1. As mentioned above in the overview of the Project Gallery, any project categories you associate with your projects will also have corresponding project category
Finder tags as well.
2. For instance, if you associate a project with the categories Active and Personal, then Curio will create “Curio Active” and “Curio Personal” Finder tags and
associate them with the projects.
3. With category Finder tags, you can now search for categories of projects in the Finder, outside of Curio.
4. Just enter the search tag, such as Curio Active in a Finder window search field and you'll find all projects associated with that category.
5. Click the Save button in the Finder window to save the search and even add it to your sidebar for one-click access to those projects.

PRO

Status - Tasks
Using the tasks area of the Status shelf
Change the Scope
! Use the Tasks In popup to determine what projects should be searched for tasks.

Changing the Grouping
! Choose the desired task grouping from the Group By popup:
a. Date — You can group tasks by “Action Items” (tasks with a start and/or due date assigned to them, or items that have a checkbox next to them), by “Start
Date”, or by “Due Date”.
b. Rating
c. Priority
d. Tag Set — For example, you might choose to group tasks by the GTD (“Getting Things Done”) tag set, in which case any tasks that have been tagged with
one or more of the GTD tags will appear under the appropriate tags.
e. Local Project Tags — only available if Tasks In is set to Only This Project.
f. Local Project Resources — only available if Tasks In is set to Only This Project.

Changing the Sorting
1. Choose the desired task sorting from the Sort By popup:
a. Action Date
b. Start Date
c. Due Date
d. Title
e. Percent Complete
f. Rating
g. Priority
2. If a project category or All Categorized Projects is selected then sorting by project name is also available as a sort option.

Jump to a Task
1. Click on a task to jump to its location in the project. If the task is from a different project, Curio will automatically switch to that project.
2. Hold down the Option key while clicking on the task if you want Curio to open the project in a separate window.

Changing Task Properties (For Tasks in the Opened Project Only)
1. Right-click on the task in the Status shelf and change the item’s associated tags, its percent complete value, its rating, and its priority.
2. If you're grouping your tasks by rating, priority, resource, or global/local tag set then you can drag-and-drop tasks between groups. With resources and tags,
Curio will disassociate the figure from the task's prior grouping and associate it with its new grouping

Action Menu Options
1. Copy all the displayed tasks as text or to export the tasks as an RTF document to disk. This is a very easy way to share assignments with other team members.
2. Export all task information as markdown for display in a markdown-compatible viewing app.
3. Export all raw task information as CSV file perfect for importing into Apple Numbers or Microsoft Excel. The following fields are exported: Task Title, Project,
Section, Idea Space, Start Date, Due Date, Duration, Duration Units, Percent Complete, Priority, Rating, Tags, Resources. Duration units are specified using a
numeric code: seconds=0, minutes=1, hours=2, days=3, weeks=4, months=5, years=6.
4. By default, Curio will include items with checkmarks (aka to-do items) which are unchecked but have no start or due dates. If you want to only include to-do items
that have start or due dates then uncheck the “Include items with no start or due dates” item in the actions menu.
5. By default, Curio will alert you of tasks that have a start date associated with them and it is currently past the start date and the completion percentage of the task
is zero percent. If you don’t want to be warned in this event then uncheck the “Include items late in starting that are 0% done” item in the actions menu.
6. By default, Curio doesn’t include untagged tasks when you group by tag set or local tags. However, you can enable this by checking the “Include grouping for
untagged tasks” item in the actions menu.

PRO

Status - Live Export
Real time exported task reports
Setting up Live Export
1. Use the Status shelf's Tasks In actions menu to manage live export.
a. Enable live export by specifying the folder where the live export reports should be saved.
b. Click the menu again to enable each type of live export you wish to produce. RTF and HTML exports are enabled by default.
c. Use the same menu to specify the category of projects to export and how they should be grouped.
2. In the background, the Status shelf will keep those live export files automatically up-to-date as tasks and projects are changed. The export files created in the
specified live export folder are named Curio Status.rtf, Curio Status.csv, and Curio Status.html. If you specify a synced folder, like Dropbox, or a network folder,
then those updates will be available to everyone with access to that folder.

Customizing the HTML Export
1. The resulting HTML is standard, compact, cross-platform, self-contained… and generated using a bundled template file which you can customize!
2. You can find the template in /Applications/Curio.app/Contents/Resources/Repository/Status Templates/Status Board.html.
3. The template includes placeholder variables which filled out with figure data and the result is then dynamically constructed and rendered with Javascript.
4. You can create your own Status Board.html at ~/Library/Application Support/Curio/Version 11/Repository/Status Templates/ to completely change the look of the
report and Curio will use that instead.

PRO

Sleuth

STANDARD

PRO

Curio’s integrated internet research assistant
Using Sleuth
Curio includes Sleuth, its integrated research assistant to make finding anything on the web fast and fun.
Sleuth can help you research ideas by giving you easy access to almost any search engine available on the Internet. You can
quickly look up images, definitions, rhyming words, translations, and general information related to any topic. You only have to fill in
the search field once, and then visit the sites that most interest you. When you find something you want to remember, simply drag
and drop it into an idea space.

Searching in Sleuth
1. Reveal the Sleuth window by clicking the Sleuth toolbar button or choosing the Window > Show Sleuth menu item.
2. Type a word or phrase in the search field located at the top of the Sleuth window.
3. Press Return to perform the search on the currently selected website, or choose a different site from the site popup menu located to the right of the search field.
4. The search results will be displayed in the bottom part of the Sleuth window. You can explore your search results as you would any website.
5. You can use the back and forward arrows at the top of the Sleuth window to navigate web pages.

Importing Sleuth Content into Curio
1. Drag images, selected text, and web links from the Sleuth window to any idea space or the project library to save the results you like.
2. Or right-click on an content in the Sleuth window and choose Send to Active Idea Space.
3. You can grab the URL of the currently displayed page by dragging it from the status area located at the bottom of the Sleuth window.

Changing the Sleuth Site
1. To see search results for the same word or phrase on a different site, click on the site menu and choose another site.
2. You can also click on the up and down arrows next to the site menu to perform the same search on the previous and next sites within a category respectively.

Make the Sleuth Window Always Appear on Top of All Other Windows
! Click the On Top toolbar button on the Sleuth window. Click again to turn off this feature.

Make the Sleuth Window Transparent so You Can See Through It
! Click the Transparency toolbar button on the Sleuth window. Click again to turn off this effect.

Add or Edit Sleuth Sites
! Click the Customize toolbar button on the Sleuth window, and follow the steps detailed on the next idea space.

Customizing Sleuth

STANDARD

PRO

Add your own sites to Sleuth
Adding Search Sites to Sleuth
Sleuth comes with built-in support for a number of the most popular Internet search sites. It also supports a flexible architecture that
allows you to add additional Internet search sites to its list of supported sites.
Adding your own websites to Curio's Sleuth tool can be as simple as drag and drop. It all depends on how search information is
sent to the site's server.
Note that Curio from the Mac App Store does not support remote, insecure http Sleuth sites.

GET or POST
An HTML form uses one of two methods to send information via HTTP to the server: GET or POST. When the GET method is used,
all of the search criteria are passed to the server via the request URL. This makes it easy for Sleuth to extract the information
needed directly from the request URL and automatically create a new site.
When the POST method is used, most of the search criteria are passed to the server in the body of the HTTP request. In this
situation, Sleuth is unable to extract the necessary information from the resulting request URL to automatically create a new site.
However, if you're familiar with HTML and you have access to the HTML code for the search form you want to add to Sleuth, you
can easily create a new site manually.

Add a New Search Site Based on the GET Method
1. In Sleuth’s main window, click on the Customize button (the one with the pencil icon) to switch over to the Sleuth configuration view.
2. Choose a collection from the list located along the left side of the window.
3. In a web browser of your choosing, go to the desired website’s search page and execute a search for the word “Fish”. Searching for the word “fish” will allow you
to skip step 5.
4. After the search results are returned, drag the resulting URL from your web browser’s address field and drop it into the list of sites on the right side of the Sleuth
window. You can position exactly where you’d like the new site to appear in the list.
5. If Sleuth cannot automatically determine your search phrase, a dialog will appear asking you to select which word or phrase for which you searched. Select the
word from the popup menu and click Choose. If your search phrase does not appear in the list, click None of the Above.
6. The site information form will be displayed with the information Sleuth was able to extract. Type the name you want to give this site in the Name field.
7. Click Save.

Add a New Search Site Based on the POST Method
1. In Sleuth’s main window, click on the Customize button (the one with the pencil icon) to switch over to the Sleuth configuration view.
2. Choose a collection from the list located along the left side of the window.
3. Click the “+” button located under the list of sites on the right side of the window to add a new site.
4. In the site information dialog, type a name for the site, type the action URL, select POST from the method popup menu, and add the necessary input parameters
for this search engine.
5. Click Save.
6. The value for the search phrase input parameter should always be set to "%%PHRASE%%". Sleuth will automatically replace this value with your search phrase
when you execute a search. Take a look at how other sites are configured by double-clicking on them in the sites list for other examples.

Delete a Custom Sleuth Site
! You can delete the selected site by pressing the Delete key.

Adding Search Site Collections
1. In Sleuth’s main window, click on the Customize button (the one with the pencil icon) to switch over to the Sleuth configuration view.
2. Click the “+” button located under the list of collections on the left side of the window to add a new collection.
3. Type the name for the new collection.
4. You can populate your new collection by creating new Sleuth sites or by dragging sites from another collection and dropping them onto your new collection.
5. You can delete the selected collection by pressing the Delete key.

Enabling and Disabling Search Sites and Collections
! Click the checkbox next to the item in the list.

KidSafe Sleuth

STANDARD

PRO

Making Curio’s Sleuth more family friendly
Restricting Sleuth’s Abilities
Curio’s amazing Sleuth internet research assistant is a quick and easy way to find images, videos, definitions, and other information
on the internet. Since Sleuth can configured to search specific sites and the user simply enters the search phrase, it’s a wonderful
way to restrict access to what a child can see.
Curio has a hidden option which will allow even more restrictive access via a KidSafe setting, which is perfect for school and home
environments.
These restrictions include:
• Only show KidSafe sites in its sites popup, such as Google Images with SafeSearch instead the normal Google Images.
• Disallow Sleuth site customization.
• Block any query phrase which contains profanity.
• Block any query results which contain profanity.

To Enable KidSafe Sleuth
1. Make sure Curio is not running then launch Applications > Utilities > Terminal and type the following and press Return:
defaults write com.zengobi.curio "Sleuth Is KidSafe" -bool yes
2. Or you can just click on this and relaunch.

DEVONthink

STANDARD

PRO

Integrating with the über librarian
Working with DEVONthink
Many Curio customers also use the very popular DEVONthink application to manage vast collections of notes and links.
You can now search your DEVONthink data using Curio’s Local Library shelf which uses Spotlight to scan for results. Curio keeps
an eye out for DEVONthink data specifically in the returned results to better display those result entries to you.
By default Curio’s Local search looks for all files which match the entered criteria, so you may end up with a mix of normal files and
DEVONthink data files. However, if you really want to narrow down your search specifically to DEVONthink, you can choose
“DEVONthink” from the Kind popup.

Copying
Versatile clipboard features
The Copy menu
The standard Edit > Copy command is useful in copying figures around your idea spaces. It will also place useful formats based on
the selected figure such as text, image, and link.
It also comes in handy if you want to copy a figure or idea space to use as a jump destination. Then use one of the Edit > Paste As
options such as Jump Action for Selected Figure, Idea Space Link, or Jump Anchor. More info can be found in the Linking Figures
idea space.
If you copy an image figure or image asset from the Library, then you can select another figure and choose Paste As > Attachment
for Selected Text Figure and the image will be displayed as a small attachment above the text figure. More info in the Text Figure
Attachments idea space.

The Copy As menu
Curio’s Edit > Copy As menu has many more options so you can copy precisely what you want to the clipboard, including:
•
•
•
•
•
•
•
•

Plain Text
Rich Text
Markdown [Pro] [Standard] — more info in the Markdown idea space here in the Documentation.
PDF
PNG
JPG
Hyperlink — useful when you want a curio:// hyperlink to a figure or idea space to use elsewhere, even outside of Curio.
Parent Figure Only — normally when you copy a parent node, in a list or mind map, you can children as well.

The various text copying varieties have some preferences you can set in this Copy As menu:
•
•
•

Include Notes With Text — when copying figures, any associated figure notes will be copied as well.
Include Meta With Text — when copying figures, any meta data is included. This is detailed on the next idea space.
Include Images With Rich Text — when copying figures, any images found in image figures will be copied to as well.

Here’s an example of a figure with its notes and meta copied:
Simple figure (25% complete;
; urgent priority; Feb 14, 2018 - Mar 15, 2018 3:00 PM; duration 20 days; Love, Home;
Kat, George) (Some notes for this figure.)

Including Meta in Text Exports
You can never have too much data
Including Meta in Text Exports
If you have enabled copying or exporting figure meta (via the Edit > Copy As menu or the export dialog, respectively) then Curio will
export meta entries in your plain and rich text exports.
For example:
Simple figure (25% complete; ★★★★☆; urgent priority; Feb 14, 2018 - Mar 15, 2018 3:00 PM;
duration 20 days; Love, Home; Kat, George) (Some notes for this figure.)
Here’s the meta output Curio supports:
Meta Output

Values

Description

50% complete

A number from 0 to 100

If checkmarks visible, the figure's percent complete.

A number of stars

The figure's rating value (number of stars).

urgent priority

Description of priority

The figure's priority from urgent priority to very low priority.

start 2018-04-15

A date with or without a time value

The figure's start date (custom date and time format).

due 2018-04-25 20:00

A date with or without a time value

The figure's due date (same customizations).

2 weeks

A duration string

The figure's duration is normally not exported, but can be enabled.

Home, NextAction

A comma separated list of tags

The figure's tags. Choose to export just the tag or tag set and tag: Home or Context.Home.

George, Greg

A comma separated list of resources

The figure's resources. Choose how much of the resource name to export: George, or GeorgeBrowning, or
George Browning, or George_Browning.

Sharing
Share your Curio creations with the world
Sharing in Curio
There are two main method for sharing Curio content with others:
1. The Share toolbar button.
2. The File > Share menu item.
Both show the same popup submenu with sharing options separated into three different sections:
1. Project (or currently selected section),
2. Selected idea spaces,
3. Selected figures.

Project Sharing Options
The first options you see listed are for the currently selected section or project:
• Exporting all idea spaces as individual plain text, RTF, or image files, as an HTML or PDF export. More information on HTML
exporting is below.
• Mail all idea spaces as a Curio project extract or a PDF file.
• Print all idea spaces. More information on printing is below.
• Begin a slideshow presentation. More information on presentation mode is below.

Selected Idea Spaces Sharing Options
The next options you see listed are for the currently selected idea spaces:
• The same export options mentioned above.
• Mail the selected idea spaces as a Curio project extract or a PDF file. You can also select to mail the idea space’s style or
template to a friend or to Zengobi.
• Print the selected idea spaces. More information on printing is below.

Selected Figures Sharing Options
The last options you see listed are for the currently selected figures:
• You can export the selected figures as a text or RTF file, or a combined JPEG, PNG, or non-paginated PDF image. Based on
the types of figures selected you may see additional options such as CSV exporting for tables and OPML, MindManager, and
iThoughts for mind maps
• Mail the selected figures as a combined JPEG, PNG, or non-paginated PDF image. You can also select to mail the figure’s style
or stencil to a friend or to Zengobi.
• Share the selected figures as text to any of the configured macOS sharing services such as via Email, Messages, Twitter, or
Facebook.
• Share the selected figures as an image to any of the configured macOS sharing services such as via Email, Messages, AirDrop,
Twitter, Facebook, or Flickr.
• Print the selected figures or the selected figure’s notes. More information on printing is below.

Mac App Store Restriction
Curio from the Mac App Store is required to use the macOS sharing service to support
mailing from within Curio. While this works very well with Apple’s Mail app, it may not be
compatible with all 3rd party mail clients as they have to support the
NSSharingServiceNameComposeEmail sharing service feature. As a workaround you
can export to your Desktop and add the attachment to a manually composed email.
Non-sandboxed Curio supports a customizable AppleScript technique for working
directly with most major mail clients.

Dragging
Drag items from Curio to other apps
Dragging Out of Curio
There are several ways to drag items out of Curio to another application.

Drag an Asset Figure out of Curio’s Idea Space
1. Begin by selecting a single asset figure on the idea space.
2. Hold ⌥⇧⌘ (Option-Shift-Command) and click and begin dragging the already-selected figure. Notice that instead of dragging the figure itself around the idea
space you are now dragging a file representation of that figure.
3. This is the important part: release those keys now that you've started dragging. You can continue dragging and drop it anywhere on your Desktop, a Finder
window, or any other application.
4. The sole purpose of that magic 3-key combination is to tell Curio to place the asset figure's file URL on the dragging clipboard, instead of tracking a normal figure
movement. It's important to release those keys after you've started the drag operation but while you're still dragging, otherwise the destination application will try
to interpret those keys as a forced move, alias, or copy of the file but Curio only supports a copy of the file out of the project.

Drag Assets out of Curio’s Project Library
! Select one or more assets from the Library and drag them directly to another application.

Printing
Print your Curio content
Printing
Curio supports printing your idea spaces, your figures, and your figure notes.

Customizing Print Headers and Footers
When printing idea spaces the Print dialog offers several custom Curio options you can apply. Of note is an optional header footer
that can appear at the top and bottom of the printed pages, respectively.
By default the header is:
{ %IdeaSpaceTitle }
Anything within {% and } is considered a variable by Curio. In this case, this variable is dynamically replaced with the title of the idea
space. You can add your own text anywhere outside of that variable string.
By default the footer is:
! {%IdeaSpaceNumberWithSheetInfo} This variable is dynamically replaced with the idea space number and optional sheet information. For example, if idea space #26
spans onto 9 sheets of paper then the 3rd sheet would show 26 (3 / 9) as its footer. If only one sheet was required then that
parenthetical information is not printed.
In addition to those two variables there are a few others which may be of interest:
{%IdeaSpaceNumber} - in the example above: 26, as in #26 out of the total count of idea spaces
{%IdeaSpaceSheetNumber} - in the example above: 3, as in the 3rd sheet of paper necessary to output the current idea space
{%IdeaSpaceNumberOfSheets} - in the example above: 9, as in this idea space needs 9 sheets of paper to output its content
{%IdeaSpaceCount} - this represents the total count of idea spaces that could be printed
So now you can see that If the idea space fits on a single page then {%IdeaSpaceNumberWithSheetInfo} is simply replaced with
{%IdeaSpaceNumber}. But, if the idea space spans across multiple sheets it is replaced with: {%IdeaSpaceNumber}
({%IdeaSpaceSheetNumber} / {%IdeaSpaceNumberOfSheets}).

Print Idea Spaces
1. Use the Share toolbar button or choose the File > Print menu then choose whether you want all the idea spaces in the current section or only the selected idea
spaces.
2. Modify your print options in the standard Print dialog that appears.
a. Set whether your idea spaces should be scaled to fit a single printed page.
i. Optionally rotating the orientation of the page automatically to minimize scaling.
ii. In the case of very large idea spaces, you can also tell Curio that if the scaling to fit to a single page would result in a scaling of less than 50% then it
should automatically expand to additional pages until it crosses that threshold so the results aren’t too small.
b. Set whether Curio should print the idea space background and grid.
c. Specify a header or footer that should appear on the top of each page, see the notes above for those variable options.
d. Enter values for the top, left, bottom and right print margins, or click “Use smallest margins possible” to make your margins as small as possible, for your
printer, and maximize your idea space work area.
3. Pressing the Print button will then send the job to the printer.

Print Organizer Documents
1. Select the documents in the Organizer you wish to print.
2. Choose the File > Print Document menu or right-click and choose Print Document.
3. The application responsible for editing those file types are launched and instructed to immediately print the documents.
4. The method above immediately prints the document in that application.
a. If you wish to see that application’s Print dialog first before printing then you need to follow these steps instead:
i. Right-click on the Organizer Document in the Organizer.
ii. Choose Open with Finder.
iii. Within the launched application choose the File > Print menu item.

Print Figures
1. Select which figures you would like to print.
2. Click the Share toolbar button then choose Print from the Share Selected Figures section of the popup menu.
3. Pressing the Print button will then send the job to the printer.

Print Figure Notes
1. Select one or more figures that have associated notes.
2. Click the Share toolbar button then choose Print Notes from the Share Selected Figures section of the popup menu.

Print Figure Notes from the Notes Window
1. To make the Notes window appear for a figure you can select the figure and click the Notes button in the inspector bar. Alternatively you can just click directly on
the Notes adornment on the figure itself and the Notes window will appear.
2. Click within the Notes window to make sure it has focus.
3. Choose the File > Print Notes menu item.
4. Pressing the Print button will then send the job to the printer.

Print Figure as Text
1. You may want to print a selection of figures as text, instead of an image representation. This can come in handy if you have a figure that contains a lot of text and
you don't want to print it as a graphical figure, where it may not paginate nicely onto pages.
2. Select one or more figures.
3. Click the Share toolbar button then choose Print Figure as Text from the Share Selected Figures section of the popup menu. This menu item pays attention to the
checked state of the Include Figure Notes When Copying/Sharing Text and will therefore include any figure notes with the printout.

PDF Export
Exporting idea spaces as PDF
Exporting as PDF
Curio supports exporting all or a selection of idea spaces to PDF.

Options
The same options seen in the previous idea space regarding Printing are available in the PDF export dialog as well.

PDF Outline [Standard] [Pro]
For Curio Professional and Standard, the PDF's generated using Export as PDF now have an embedded PDF document outline for
easy navigation using PDF viewers that support that standard PDF feature. In Apple's Preview app, for example, choose View >
Table of Contents to see the PDF's hierarchical document outline.
The PDF outline is part of the PDF standard so most standards-following PDF readers should support it. Zengobi has tested it with
the macOS Preview and Adobe Reader apps as well as the following iOS apps: Dropbox, Readdle's PDF Export and PDF Viewer,
Good.iWare's GoodReader, Branchfire's iAnnotate PDF, and LiquidText.

Clickable Links
When you export idea spaces via Export as PDF the resulting PDF will have clickable links for:
• Weblink figures, like a URL dropped from a browser into an idea space.
• Figures with URL actions.
• Weblinks and figure URL actions that are inner project hyperlinks (ex: curio://?ideaspace=062...).
• Idea space links to other inner project idea spaces.
• Jump anchors to inner project locations.
• Figures with jump actions to inner project locations.
• Figures with first, last, previous, or next idea space jump directions.

Limitations
Curio doesn't generate PDF links for a selection of text within a text figure that has a link attribute. This is a tricky one to solve as (a)
Curio would have to scan all text figures when exporting to find any NSLinkAttribute attributes which could be very slow, (b) the
resulting selection may consist of wrapped lines of text complicating the generation of potential PDF annotation link(s).

Note About Printing to PDF
If instead of exporting as PDF you choose to print then click the print dialog’s button to Open PDF in Preview then Curio isn't given
that temporary filename so is unable to modify the generated PDF to include the PDF outline or PDF links. So either use print to a
PDF file and then open it, or use export as PDF.

Export Idea Spaces to PDF
1. Use the Share toolbar button or choose the File > Share menu then choose whether you want export the idea spaces in the current section or only the selected
idea spaces.
2. Modify your PDF export options in the Print dialog that appears.
a. Set whether your idea spaces should be scaled to fit a single printed page.
i. Optionally rotating the orientation of the page automatically to minimize scaling.
ii. In the case of very large idea spaces, you can also tell Curio that if the scaling to fit to a single page would result in a scaling of less than 50% then it should
automatically expand to additional pages until it crosses that threshold so the results aren’t too small.
b. Set whether Curio should include the idea space background and grid.
c. Specify a header or footer that should appear on the top of each page, see the notes in the Printing documentation for those variable options.
d. Enter values for the top, left, bottom and right print margins, or click “Use smallest margins possible” to make your margins as small as possible, for your
printer, and maximize your idea space work area.
3. Press the Export button to begin the export.

HTML Export
View Curio projects in a browser
Exporting as HTML
When it's time to share your ideas with coworkers, clients, or friends, you can export your idea spaces to HTML files which can be
viewed using a web browser.

The Result
The result is a single index.html file in the specified folder along with Contents and Documents subfolders. The former contains fullsize images and thumbnail images for each exported idea space. The latter contains any exported assets.
Curio uses an image and accompanying image map to represent each idea space so they will render correctly regardless of
platform, browser, installed fonts, etc. The image maps support jump actions between idea spaces, web link action URLs, and
exported asset files.
The default HTML template Curio uses for exporting works beautifully with the latest Safari, Chrome, Firefox, and Internet Explorer
browsers on both Mac and Windows platforms. Navigation controls appear when the mouse is moved or the device is tapped.
These same controls automatically hide after a few seconds of inactivity. You can also use the arrow keys to step through the
slideshow. The integrated popup navigator allows you to quickly choose a specific idea space in the hierarchy.
The resulting HTML also works perfectly with Safari on your iPad and iPhone devices. Use your fingers to pinch and zoom or pan
around larger idea spaces. Simply tap on an asset figure to open the asset itself. Tap anywhere to show the navigation controls.
Even users on Windows XP with old IE 8 can step through the slideshow, although they can't click on image maps to open assets.
If you've exported these idea spaces to the same location before, only the modified or new idea spaces and assets will be exported.
This significantly reduces the time it takes to update a previously exported project.

Publish Your Idea Spaces as an HTML Project
1. Optionally select specific idea spaces in the Organizer that you wish to publish.
2. Choose File > Export As > HTML.
3. Click on Export All if you want to export all idea spaces, else click Export Selected to only export the selected idea spaces.
4. Choose a location to export the idea spaces. Since exporting to HTML will result in creating multiple files it's best to create a new folder for the exported files.
5. Choose the template to use.
6. Choose the image type and select whether idea spaces should be scaled to a max width. For JPEG files, you can also choose the quality of the resulting images.
The better the quality, the larger the file size.
7. Click Export.

Customizing HTML Templates
1. To create your own HTML template for exporting, check out the bundled HTML templates which can be found within the app itself: /Applications/Curio.app/
Contents/Resources/Repository/HTML Export Templates.
2. Copy one of the bundled templates to help you get started. Open the index.html file in your favorite text editor and check out the code. Note variables that start
with {curio which are dynamically replaced when the template is exported with data. Currently we're only using two: {curio_project_title} and {curio_slides_array}.
The former is replaced with the project title, the latter with a big JavaScript array of the resulting slides.
3. Now to really understand how this works, do a Curio HTML export of a simple project and check out the resulting exported index.html file. See how the project
title is replaced and the array of slides is generated?
4. For your copy of the index.html template file you can change something simple, such as the CSS style information at the very top of the file. Or perhaps you want
to dig deep and modify both the CSS and JavaScript. It's all in this index.html and you can do whatever you want with the output arrays.
5. When you're ready to test out your template you need to place it into a specific folder so Curio can find it. Look in your ~/Library/Application Support/Curio/Version
XX/Repository folder (where Version XX is replaced with your Curio version number like Version 11) and create a new folder inside called "HTML Export
Templates". Then, within that folder, create a subfolder and call it something that will identify your new template such as "Awesome Export". Then place your
custom index.html file into that subfolder.
6. When you restart Curio, the HTML Export dialog will find your custom folder and allow you to choose one of your custom templates.
7. As a note, we store the templates with that Repository subfolder because you could share a repository with your entire company or school.

Keynote Export
Export your Curio project to Keynote
Exporting to Apple Keynote
While Curio doesn't support a direct export to Keynote, you can easily create a Keynote presentation using exported images.

Export Your Idea Spaces to Keynote
1. In Curio, click the Share toolbar button then choose Export As > Image. Choose to export JPG images and also create a new folder for the output. This is also
where you might want to specify a scaled size for each exported image. Then click the Export button to fill your new folder with image versions of your idea
spaces.
2. Launch Keynote and choose the White theme and an appropriate slide size in the window that appears when it launches.
3. In the Finder, select all of the images that Curio exported and drag-and-drop them to the Slides area on the left side of the Keynote window. Drop them just above
that initial blank slide that Keynote automatically created for you.
4. Click on the first slide in the Slides area and then choose Edit > Select All to select all the slides and then click the Change Master button in the Format inspector
and choose Blank.
5. Scroll down to the very bottom of the Slides area and select the last slide, which is that initial blank slide auto-created by Keynote, and press the Delete key to
remove it.

PowerPoint Export
Export your Curio project to PowerPoint
Exporting to Microsoft PowerPoint
While Curio doesn't support a direct export to PowerPoint, we can use an Automator helper script to assist with the process.
Previously we were able to use an Automator helper script to do this. However, it looks like Apple’s sandboxing restrictions make
this a pain because PowerPoint has to ask you to grant access to every imported image! If you have 100 slides then it’d ask you
100 times for permission!
So, in lieu of that, until they can get this resolved, use this workaround:
1. Follow the 5 steps on the previous idea space to export your Curio project as a Keynote slideshow.
2. Use Keynote to export as PowerPoint.
That’s it!
Hopefully Microsoft can adjust their Create PowerPoint Picture Slide Shows Automator action to support selecting a folder instead
of multiple files and then you’d only have to grant permission once. But in the meantime you’ll need to go through Keynote.

TaskPaper Export

STANDARD

PRO

We love TaskPaper!
Exporting as TaskPaper
Via the Share menu or toolbar button, you can export a selected list, stack, or mind map as a TaskPaper document.
Figure meta information is automatically exported as well.
Note that @done is output for any completed items, and @progress() for all other items.This includes 0% done, so you will see a
@progress(0) for unchecked items, so you can perform @progress searches in TaskPaper, as described below. You can turn this
off if you'd rather only see this tag when progress has been made. If the Done Date meta information is set then that date is output
with the form @done(YYY-MM-DD).

TaskPaper Meta Search Tips
Curio will output meta information to TaskPaper using the markdown-style syntax described in Exporting Meta. Thus @progress(25)
to indicate a task is 25% done and @resources(George, Greg) to indicate resources.
TaskPaper supports advanced searching queries that can dive into this meta information.
@progress >[n] 20
Find all tasks more than 20% completed (that aren't done, which would have a @done tag instead of @progress).
@tags contains[l] home
Find all tasks with a tag of Home.
@resources contains[l] george
Find all tasks assigned to George.
@due < [d] 2018-06
Find all tasks due before June 2018 (more date tips here and here).
@due <[d] next week and @progress =[n] 0
Find all tasks due in the next week that haven't been started.
@due <[d] next week except @done
Find all tasks due in the next week that aren't done.

Importing as TaskPaper
Curio can import from TaskPaper as well!

Export a List, Mind Map, or Stack as TaskPaper
1. Select the list, mind map, or stack figure.
2. Choose the Share button or File > Share menu, then under selected figure choose Export As > TaskPaper.

Markdown Export
Step by step workflows
Exporting as Markdown
Curio can export an entire project, selected idea spaces, or specific selected figures as markdown!
The result is pretty awesome: a single markdown file (and optional accompanying assets folder) where your Curio text figures turn
in markdown rich text blocks, your Curio lists, mind maps, and stacks turn into markdown list blocks, Curio tables into markdown
tables, Curio image figures into inline markdown images, asset figures into markdown file links, link figures into markdown links, etc.
You can then view the exported markdown file with your favorite markdown app like Marked or MultiMarkdown Composer.

Export Your Project, Selected Idea Spaces, or Selected Figures as Markdown
1. In Curio, select what you want to export then click the Share toolbar button then choose Export As > Markdown.
2. In the dialog that appears you can choose the location for the export and give it a file name for your export. Note that a single .markdown file will be created with
that name containing everything you selected to export.
3. In that same dialog you can optionally specify if you want figure notes and meta exported.
4. You can also specify that images and files should be exported as well. If so, Curio will create folder alongside your markdown export file which will contain those
images and files stored within uniquely named subfolders.
5. Click the Export button and your export will be generated.

Export as Markdown Text

STANDARD

PRO

Using markdown’s rich text syntax
Markdown Rich Text
Curio's markdown converter will convert your rich text figures directly into markdown! Curio uses each figure's markdown setting in
the text inspector is to determine how to perform this conversion:
Markdown Rendering Off
If the markdown inspector button is off then this is a figure which doesn't contain any entered markdown. So Curio will automatically
convert any rich text attributes to the supported markdown rich text syntax described earlier. For example, if Curio finds bold text it
is turned into **bold**. As a note, to determine if a line of rich text should be a markdown header (ex: "# header 1") Curio looks for
text where the entire line is bold and of a certain font size. Headers 1 through 6 (i.e. #, ##, ###, ####, #####, ######) will be
created with bold text of size 32, 24, 18, 16, 13, 11, respectively.
Markdown Rendering On
If you set the markdown inspector button is on then Curio will take the text figure's text and leave any existing markdown that you
entered as-is, but it will also conveniently convert any attributed text it finds to markdown's rich text syntax. So, if a text figure
contains the following text: "This is a mix of *italicized* markdown syntax and bold attributed text." then will take that italicized
markdown as-is but convert the bold text to **bold**.

Export as Markdown Lists

STANDARD

PRO

Using markdown’s list syntax
Markdown Lists
Curio exports hierarchical data such as lists, mind maps, and stacks as markdown lists, with the following considerations:
•
•
•
•
•
•

While basic markdown doesn't support nested lists, many extensions such as MultiMarkdown and CommonMark use tab
indentions to indicate nesting, so Curio supports this as well.
Markdown only supports simple bullets (via the * markup) and numbering (via the 1. 2. 3. markup) so Curio's extensive perlevel prefixing is automatically narrowed to those two available options during export.
The individual text figures that make up the Curio collection figure are converted into markdown's rich text syntax as described
above.
If a list item has line breaks within then those are merged into a single text line for the export.
Curio will output the * as the list marker for bullets. You can optionally change this to the - marker if you wish.
List titles have to be output with a blank line between the title and the actual markdown list, as per markdown rules. Personally I
wish it didn't need this but, if it's not there, then lists won't render correctly.

**Tasks**
* Plan vacation
* Contact hotel
* Find restaurants
* Pack bags
* Do kids need new bags?
* Have fun!

Tasks
1. Plan vacation
a. Contact hotel
b. Find restaurants
2. Pack bags
a. Do kids need new bags?
3. Have fun!

Export as Markdown Tables

STANDARD

PRO

Using markdown’s table syntax
Markdown Tables
Curio exports its tables as markdown tables, with the following considerations:
•
•
•
•

While basic markdown doesn't support tables, many extensions such as MultiMarkdown support a common syntax for
markdown tables which Curio uses.
Markdown only supports a header row, so Curio's footer row and header & footer columns are simply rendered in markdown as
normal cells.
Markdown column alignment syntax is not output since Curio's can be individually specified per cell.
Each row has a leading and trailing pipe ("|"), which some markdown viewers require, but can be disabled.

| Region | 2017 | 2018 | 2019 |
| --- | --- | --- | --- |
| US | $14,832 | $18,799 | $20,703 |
| Europe | $11,633 | $13,452 | $16,879 |

Region

2017

2018

2019

US

$14,832

$18,799

$20,703

Europe

$11,633

$13,452

$16,879

Export as Markdown Links

STANDARD

PRO

Using markdown’s link syntax
Markdown Image and File Links
In the markdown export dialog you can choose whether to export images and other figure assets. These are exported to a folder
created alongside the resulting markdown file. Each exported figure asset will be contained within uniquely named subfolder to
avoid file name collisions.
By default this assets folder will be named based on the markdown file name. For example, if you specified "Project" for the
exported markdown file, then the assets folder will be named "Project Assets". You can customize this format string, where a %@
token in the format string, if found, is replaced with the markdown file's name.
Note the resulting markdown links, like [An image](Project%20Assets/7832-3982/Notes.pages), will reference this folder location so
you can't rename it in the Finder later! Instead you will need to delete the previous export and re-export.
Will this work? Zengobi. Maybe.

Inline Image Links
For simple image types (png, jpg, etc... but not pdf), Curio will use the ![title](path) markdown syntax to show the image inline on the
markdown page (note the exclamation point prefix). Or, if you don't want to see the inline image, you can export as a normal
markdown link instead. Curio will scale the exported image so it's the same size as rendered on the idea space, but you can export
the full size image if you wish.

File and URL Links
For all other asset types, Curio will use the [title](path) markdown link syntax thus creating a clickable link to the asset.
Of course weblink figures use the [title](path) markdown link syntax as well thus creating a clickable link to the site.

Compatibility
The ability to render and handle these links depends on your markdown viewer, although Marked and MultiMarkdown Composer
seem to handle them beautifully.

Limitations
Note that this feature works for images and files that exist as asset figures. Curio will not parse, extract, and export images that
exist within the rich text content of a Curio text figure.

Export as Markdown Footnotes

STANDARD

Using markdown’s footnotes syntax
Markdown Footnotes
If you have enabled copying or exporting figure notes (via the Edit > Copy As menu or the export dialog, respectively) then Curio
will export those notes as markdown inline footnotes that MultiMarkdown supports.
For example:
This is a figure.[^And this is its note as an inline footnote.]
And here's how it appears in a markdown renderer (Marked):

PRO

Exporting Meta in Markdown

STANDARD

PRO

Special meta tags in markdown exports
Markdown Meta Tags
If you have enabled copying or exporting figure meta (via the Edit > Copy As menu or the export dialog, respectively) then Curio will
export meta data in some tag-like entities.
For example:
Simple figure[^Some notes for this figure.] @progress(25) @rating(4) @priority(1)
@start(2018-02-14) @due(2018-03-15 15:00) @duration(20d) @tags(Love, Home) @resources(Kat,
George)
Optionally, when exporting markdown, you can specify that the normal plain text output is used for meta if you'd rather use the
normal text formatting for meta export as detailed in the Including Meta in Text Exports idea space. So the export text above would
look like this instead:
Simple figure (25% complete; ★★★★☆; urgent priority; Feb 14, 2018 - Mar 15, 2018 3:00 PM;
duration 20 days; Love, Home; Kat, George) (Some notes for this figure.)
Here’s the meta output Curio supports:

Meta Output

Values

Description

@progress(50)

A number from 0 to 100

If checkmarks visible, the figure's percent complete (or @done for 100% if enabled).

@rating(3)

A number from 1 to 5

The figure's rating value (number of stars).

@priority(1)

A number from 1 to 5

The figure's priority value from 1 meaning urgent priority to 5 meaning very low priority.

@start(2018-04-15)

A date with or without a time value

The figure's start date (custom date and time format).

@due(2018-04-25 20:00)

A date with or without a time value

The figure's due date (same customizations).

@duration(2w)

A duration string

The figure's duration is normally not exported, but can be enabled. The abbreviations for year, month, week, day,
hour, minute can all be customized, note that month uses "x" by default like TaskPaper.

@tags(Home, NextAction)

A comma separated list of tags

The figure's tags. Choose to export just the tag or tag set and tag: Home or Context.Home. You can also choose
the format: @tags(Home, NextAction), or @Home @NextAction, or #Home #NextAction.

@resources(George, Greg)

A comma separated list of resources

The figure's resources. Choose how much of the resource name to export: George, or GeorgeBrowning, or
George Browning, or George_Browning. You can also choose the format: @resources(George, Greg) or
@George @Greg.

Presentations

PRO

Integrated slide show for easy presentations
Presentation Mode
You can show your idea spaces on your computer’s display, or use a projector to share it with a large group. Curio’s integrated
presentation mode with custom transitions is perfect for group brainstorming sessions.

Begin the Presentation
Begin by clicking the Presentation toolbar button, the View > Begin Presentation menu, or using the Share toolbar button.

End the Presentation
Press the Escape key.

Context Menu
Right-click on the idea space to show the presentation mode context menu.
There you can switch to a different active layer, perhaps to select figures on that layer, or toggle the visibility of a layer. Choosing an
already active layer will hide it, choosing one that isn't active but hidden will make it active and visible. The visibility toggles only
persist while showing that slide. Moving forward or back, or restarting the slideshow will restore visibility to their normal values.
Action

Key

End Presentation

Esc

Next idea space

Right Arrow, Down Arrow, Page Down, Spacebar, Swipe Down (see
gesture handling notes below)

Previous idea space

Left Arrow, Up Arrow, Page Up, Swipe Up (see gesture handling
notes below)

First idea space

Home

Last idea space

End

Back in history

[, Backspace, Cmd-Left Arrow, Swipe Left

Forward in history

], Cmd-Right Arrow, Swipe Right

Toggle scaling on and off

S

Select a figure

Click (when pointer is visible)

Toggle the expand/collapse of a selected mind map branch.

Quick Spacebar Tap

Toggle the expand/collapse of a branch and its children.

Quick Option-Spacebar Tap

Toggle the expand/collapse all branches at this level.

Quick Shift-Spacebar Tap

Open a figure's asset or perform the figure's action

Double-Click (when pointer is visible)

Set a rating

0 through 5 (when a figure is selected)

Scroll the idea space

Click and drag the background (when pointer is visible)

General
Curio’s general preferences
Appearance
If running on macOS Mojave or newer, Curio’s window chrome, toolbar, inspectors, shelf, Organizer and other interface elements
will now change dynamically based on the Mojave's dark mode setting in System Preferences > General. You can however,
override the system setting here within Curio’s Preferences and force a light or dark appearance.
It's important to note that the idea space content will still abide by the specified coloring and styles set for your idea spaces and
figures. Those styles won't invert or change on-the-fly based on the dark mode setting

Default Projects Folder
Specify a default folder used when saving Curio projects. The default is ~/Documents/Curio.

Mac App Store Notice
Sandboxed Curio is unable to set a default projects folder so you must specify it
manually by clicking the Choose button. Note that Curio will have access to all files in
the folder you choose.
If you have Curio Professional, then certain advanced feature like external asset
libraries and project lock files are only supported in this default projects folder because
Curio needs full access to the files in the folder to support these features.

Backups

PRO

Curio’s general preferences
Automatic Backups
Projects
Curio Standard and Professional can make automatic backups of your Curio projects! This feature can be enabled in the
Preferences window, where you can also specify the frequency of the backups and the location where the backups are placed.
If this is enabled then projects found in the specified Projects Folder will be automatically backed up.
During project load Curio will see if the backup needs to be refreshed and, if so, copy the current project to the backup folder.

Location of the Backups
By default the backups are stored within a Backups subfolder created under the Curio projects folder. The default Curio projects
folder is ~/Documents/Curio therefore the resulting default folder for backups is ~/Documents/Curio/Backups.
However, you can tell Curio to use a specific backup folder if you wish. This may be handy if you wish to create backups in a very
different location, like a Dropbox folder, for instance.

Per Project Override [Pro]
Curio Professional customer can override the backup settings for a particular project via its project properties inspector. For
instance, you might have a particularly large project that only needs a backup every 7 days. Or perhaps you have automatic
backups disabled and instead you enable it only for specific projects, even those not located in the standard Projects folder.

Application Support and Personal Repository Folders
Curio will now automatically make periodic backups of its application support and personal repository folders, to ensure the safety
of your styles, stencils, templates, project lists, custom Sleuth sites, saved searches, and much more.
By default this will occur every 5 days although you can change this frequency via the Backup App Support Frequency advanced
setting (see the Help > Curio Advanced Settings menu item). If set to 0 then no backups will occur.
Assuming you're using the default ~/Library/Application Support/Curio/Version XX location then the backup will be named ~/Library/
Application Support/Curio/Version XX Backup.
If you have overridden the application support folder location and/or personal repository folder, using their respective advanced
settings, then Curio will still make sure those folders are backed up, as well.

Mac App Store Notice
Sandboxed Curio is unable to set a default project backups folder so you must
specify it manually by clicking the Choose button. Note that Curio will have access to
all files in the folder you choose.

Repositories

PRO

Curio’s general preferences
Repositories
Curio supports a powerful, extensible shared repository system.
A repository is a folder structure that contains resources such as project templates, idea space templates & styles, figure stencils &
styles, color swatches, external document templates (for Insert > Instant Document), HTML export templates, and Sleuth modules.
Curio includes a bundled repository and your personal repository is automatically created in ~/Library/Application Support/Curio/
Version XX/Repository as you create and save personal styles and templates.
Copying your repository to a publicly available server, such as a using a public Dropbox folder or a network file server, allows you to
share your resources with others. They simply need to add an entry pointing to that repository in their Preferences window, relaunch Curio, and all of your styles and templates will appear in the appropriate galleries and popups.

Adding a Repository
1. Click the plus button to add a new repository.
2. Select a repository and press the Delete key to delete it.
3. Double-click a repository to edit its path.
4. Rearrange the order order of the list repositories via drag-and-drop.
5. Clicking the Reveal button will display the repository in a Finder window.
6. All changes to the repositories require a relaunch to take effect.

Presentation

PRO

Curio’s presentation preferences
Scaling Options
Choose whether the idea spaces should be scaled to fit the screen, or if scroll bars should appears as needed to scroll around the
window. If the mouse pointer is visible then you can click anywhere in the idea space to scroll around, as well. You can toggle this
on-the-fly during the presentation by pressing the S key.
Check “Use minimum idea space bounds” if the unused bottom and right portions of the idea space should be cropped off when the
idea space is displayed. If unchecked, then the entire idea space is displayed including unused portions.

When Done Options
Check “Exit presentation after last slide” if the presentation should immediately end if you try to progress past the last slide,
otherwise the presentation will remain on the last slide.

Selection Options
Click the color well to change the selection color that is used to highlight any selected figures (note that the pointer must be visible
to select figures).

Transition Options
You can specify a default transition to use between idea spaces during the presentation. This can be overridden for specific idea
spaces using the idea space’s Transition inspector.

Advanced Options
Curio can automatically pre-collapse mind maps before displaying an idea space in a slideshow presentation. If this would be of
interest to you check out the Presentation PreCollapse Mind Maps setting via Curio’s Help > Curio Advanced Settings menu.

Gesture Handling
Using trackpad or Magic Mouse gestures
In Gallery Windows
•

Pinch/expand zooms the gallery (as does Option-Scroll with mouse or trackpad).

In Idea Spaces
•
•

•
•

Pinch/expand zooms the idea space (as does Option-Command-Scroll with mouse or trackpad).
If not currently at Actual Size then a double-tap on your Magic Mouse or a 2-finger double-tap on a trackpad will zoom to Actual
Size. Otherwise, if already Actual Size, that double-tap will zoom such that the current contents of the idea space fill the display,
subtracting out any blank whitespace and centering the view on those contents. Note that you have to have Smart Zoom
enabled in your System Preferences Mouse and/or Trackpad settings.
3-finger swipe up/down goes to the previous/next Organizer item.
3-finger swipe left/right goes backwards/forwards in history.

In Presentation Mode
•
•
•

Pinch/expand enables or disables scaling.
3-finger swipe up/down goes to the previous/next Organizer item.
3-finger swipe left/right goes backwards/forwards in history.

System Preferences
•

You’ll need to make a change in System Preferences > Trackpad > More Gestures so that Curio can actually receive 3-finger
swipes, otherwise the Mac’s system receives them instead.

Managing Windows
Helpful shortcuts for window management
Instantly Resize and Position the Active Window
1. Center Window (⌃⌥⌘C) centers and expands the window on the screen.
2. Left Half (⌃⌥⌘←) resizes the window so it's half the width of the screen then scoots it to the left side of the screen.
3. Right Half (⌃⌥⌘→) resizes the window so it's half the width of the screen then scoots it to the right side of the screen.
4. Top Half (⌃⌥⌘↑) resizes the window so it's half the height of the screen then scoots it to the top of the screen.
5. Bottom Half (⌃⌥⌘↓) resizes the window so it's half the height of the screen then scoots it to the bottom of the screen.

Place the Active Window Above or Below All Other Windows
1. Window On Top (⌃⌥⌘T) makes the window always on top of all other windows, even other application windows.
2. Window On Bottom makes the window appear underneath all other windows, even other application windows.

