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Introducing Curio

Introducing Curio

Curio provides an innovative, freeform, notebook-like environment with all the
integrated tools you need to take notes, brainstorm ideas, collect research, and
organize your tasks and documents.

Curio’s intuitive interface and tools encourage effective note gathering, research,
and creative exploration. Its freeform, open environment encourages you to more
easily visualize, associate, and recall information.

All of this within a single application so you can be more productive, more
creative, and focus on getting things done.

Curio Editions

Curio is available in two different product editions to match your workflow needs.

Curio Standard

Curio Standard has an amazingly vast collection of brainstorming and notetaking functionality to kickstart your productivity. View the
complete feature details here on our website.

Curio Professional

For our power-users, we proudly offer Curio Professional which includes everything in Standard plus our most advanced features for
power-users and productivity gurus. View the complete feature details here on our website. This is, by far, our most popular edition

of Curio.

Note
If a feature is only available in Curio Professional then it will be marked in this documentation with (PRo J.

Curio Free?!
If your Curio application isn’t licensed, doesn’t have an active subscription, and isn’t in a trial mode then it enters into “free” mode.

In this state, it has the same features and functionality as Curio Standard however:

* You can only create and edit projects that contain up to 5 idea spaces.
« Larger projects are opened read-only for viewing, exporting, and printing.

At any time you can purchase and enter a Professional or Standard license key (if your Curio app was downloaded from our
website) or begin a subscription (if your Curio was downloaded via the Mac App Store) to re-enable the appropriate functionality.

In the meantime, your Curio app can still be updated as new releases roll out. Curio downloaded from our website will ask if it
should update itself, and Curio downloaded from the Mac App Store will automatically keep itself up to date silently in the
background.
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Availability

Curio Core (Deprecated)

In the past we offered Curio Core from our website as a starter version of Curio with a greatly simplified feature set. It was originally
conceived of as an intro to Curio for customers that didn’t need many bells and whistles. However, in the end it sustained a very low
and ever-decreasing percentage of overall sales.

It was discontinued at the end of 2022 which allows us to simplify our offerings, code, and documentation.

Existing Curio Core customers will continue to receive updates and new features during their year of free updates. After that time
customers can elect to upgrade to Curio Standard or Pro.

Availability

Curio is available in two ways:

1. From Zengobi’s website, using traditional license keys and optional periodic license renewal upgrade purchases.
2. From Apple’s Mac App Store, as a monthly or yearly subscription.

Curio From the Zengobi Website

Curio traditional licenses are available from the Zengobi website. Clicking the download link will cause your browser to download
the Curio application to your Downloads folder.

Important
The Zengobi website version of Curio only works with traditional license keys, not subscriptions.

License Agreement / Privacy Policy

Curio purchased from the Zengobi website is covered by this License Agreement.
Our Privacy Policy details what personal information we collect, why we collect it, and how we use it.

Frequently Asked Questions
We invite you to check out our Curio Traditional Licenses FAQ to learn everything about traditional licenses.

Installing

Once downloaded, drag the Curio application from your browser’s Downloads folder to your Mac’s Applications folder to install.
Optionally, to create a shortcut on your Dock, drag Curio from your Applications folder to the Dock to create the shortcut.
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Curio From the Zengobi Website

Important

You must use the Finder to drag Curio from Downloads to Applications, as only the Finder can clear the macOS Gatekeeper
check. You can’t use another utility to move the application (or move the .zip file into Applications then unzip) as macOS
wants to see you drag the application into Applications to ensure a user-initiated install. Otherwise, macOS will launch Curio
from a randomized, read-only location created on-the-fly, which will prevent Curio from being able to update itself if updates
are available.

Trials and Purchasing
Curio initially launches as a 2-week, fully functioning trial with all Professional features enabled. On the very first launch, the bundled

Welcome to Curio project will automatically open with a guided tour and sample gallery showing off Curio’s amazing features.

At any time before or after the trial expires, you can purchase a license key from our online store to activate your installation using
Curio’s License dialog, discussed below.

Once the trial expires, if you decide not to purchase a license, you can continue to use Curio with the Standard feature set to
explore the bundled Welcome to Curio project and to create and edit your own projects each with up to 5 idea spaces. Larger
projects are opened read-only for viewing, exporting, and printing.

At any time you can still purchase and enter a Professional or Standard license key to re-enable the appropriate functionality.

Sharing With Friends

It’s worth noting that this functionality means you can easily share Curio projects with friends and colleagues that don’t own Curio,
as they can simply download Curio for free from our website or the Mac App Store and view your projects in read-only mode.

Updates
When you purchase a license, you get one free year of app updates including major and minor features, fixes, and updates for

macOS compatibility. Curio will notice the available update and download and install the new release automatically.

At the end of this period, your Curio app continues working normally — it does not expire or deactivate — however, you will no
longer receive app updates. Whenever you wish, you can purchase a license renewal to update to the latest version and receive
another year of app updates.

Learn more about the year of free updates in our Curio Traditional Licenses FAQ.

Note

In the future when you decide to purchase a license renewal, Curio will notice your existing license has been extended and
update itself to the latest release if necessary. There’s no need to download or install anything or even type in a new license
key. It will all happen automatically.

License Dialog

The License dialog (via the Curio > License menu):

» Shows your current trial state (if in a trial),
+ Allows you to enter or paste a purchased license key to activate your installation,
« Shows your current license details.
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Curio From the Mac App Store

Entering Your License Key

After entering your license key, Curio’s features and functionality may change as appropriate for the entered key. For example if you
purchase a Curio Standard license then Professional features will be removed from the interface. Likewise, if you currently own
Curio Standard and purchase a crossgrade to Curio Professional then Professional features will be dynamically added to the
interface the next time you launch Curio.

License Details

If a licensed installation, the License dialog shows your current license details including the last date for free updates and the
number of installations using your license (plus the ability to deactivate those installations and retrieve an updated license if
something seems amiss).

Available Free Updates

The License dialog will let you know if your license allows you to freely update to a newer version of Curio on your current macOS or
even on a newer macOS.

Available Updates If You Renew Your License

If your year of free updates has ended, it will report what Curio versions are available, both on your current macOS and on a more
recent macOS, if you were to purchase a license renewal to extend your license and receive another year of free updates.

Activating

When you enter a license key into Curio, or click the instant activation link on the purchase page, Curio activates your installation by
confirming your license with Zengobi’s server and retrieves the properties associated with your license such as edition (e.g. Pro vs
Standard) and free updates end date. It will also send you an email letting you know that a new installation was activated with this
license.

On every launch, in the background, Curio tries to check in again with the Zengobi server to see if new updates to Curio are
available or if your license has been updated, perhaps giving you access to a different edition of Curio or extending your date for
free updates if you’ve recently renewed your license. If it can’t reach the server, it simply uses the results from the last successful

query.

Curio From the Mac App Store

You can install Curio from the Mac App Store and use it with a monthly or yearly subscription handled by Apple.

Important
The Mac App Store version of Curio only works with subscriptions, not traditional license keys.

License Agreement / Privacy Policy
Curio purchased from the Mac App Store is covered by Apple’s standard License Agreement.

Apple’s Privacy Policy details what personal information they collect, why they collect it, and how they use it. You may also
want to read Zengobi’s Privacy Policy which details what personal information we collect, why we collect it, and how we use it.

Frequently Asked Questions
We invite you to check out our Curio Subscriptions FAQ to learn everything about subscriptions.
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Curio Sustainers

Trials and Purchasing

Curio can be used without a subscription with the Standard feature set to explore the bundled Welcome to Curio project and to
create and edit your own projects each with up to 5 idea spaces. Larger projects are opened read-only for viewing, exporting, and
printing.

When you’re ready to dive in and create larger projects or work with Professional’s features, start a 2 week free trial by subscribing
to a Standard or Professional monthly or yearly plan from within Curio, which instantly unlocks the appropriate features.

Once the trial expires, if you decide not to purchase a subscription, you can continue to use Curio with the Standard feature set to
explore the bundled Welcome to Curio project and to create and edit your own projects each with up to 5 idea spaces. Larger
projects are opened read-only for viewing, exporting, and printing.

Updates

The Mac App Store app will make sure the Curio application is always up to date, even if you don’t subscribe, automatically
downloading and installing major and minor updates silently in the background.

Sharing With Friends

It’s worth noting that this functionality means you can easily share Curio projects with friends and colleagues that don’t own Curio,
as they can simply download Curio for free from our website or the Mac App Store and view your projects in read-only mode.

Sandboxing

All apps from the Mac App Store are sandboxed for tighter security which can impose a few limitations. For Curio those limitations
include:

» AppleScript actions cannot be assigned to figures.

« Custom app icons only appear in the Dock while Curio is running.

* Both the external asset library and lock file features are only supported for projects stored in the Projects folder specified in

Curio’s Settings.

* Insecure nttp connections are not supported in embedded web view figures, as Organizer documents, as Sleuth sites, or
during web archive or favicon retrieval. Only secure nhttps URLSs can be used. However, you can create insecure http
web link figures and figure actions, which will open in your default browser.

Mac App Store Restriction
Throughout the documentation you may notice these special “Mac App Store Restriction” notices to highlight a feature
limitation due to sandboxing.

Curio Sustainers

Curio sustainers are those that have a purchased a traditional Curio license and are still within their period of free updates, or those
that have an active Mac App Store subscription to Curio. These customers and their ongoing payments help support and sustain
Curio’s development with a reliable revenue stream that we can use to plan releases and development cycles.

If you purchased Curio from our website and your year of free updates has ended then please renew your license via the License
dialog to continue sustaining Curio’s development.
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Getting Help

We sincerely thank all sustainers for their ongoing support! i

Getting Help

The Help menu in Curio provides one-click access to more information:

What’s New in Curio

See what’s new in the current major version release of Curio.

Keyboard Shortcuts

Choose the Help > Curio Keyboard Shortcuts menu item to see all of Curio’s shortcuts.

Zengobi’s Blog

Choose the Help > Zengobi Blog menu item or visit blog.zengobi.com to read the latest news from Zengobi.

Zengobi’s Forums

Choose the Help > Zengobi Forums menu item or visit forums.zengobi.com to chat and share with other Curio customers.

Zengobi on Social Media

+ Choose Help > Zengobi on Bluesky menu item or visit bsky.app/profile/zengobi.com.

» Choose Help > Zengobi on Mastodon menu item or visit mastodon.social/@zengobi.

» Choose Help > Zengobi on Threads menu item or visit www.threads.net/@zengobi.

» Choose Help > Zengobi on X menu item or visit www.x.com/zengobi.

« Choose Help > Zengobi on Facebook menu item or visit www.facebook.com/zengobi.

Contacting Zengobi

Lastly, at the end of the Help menu you can send Zengobi feedback or ask us a question. We'll write back as quickly as possible!

You may also want to visit www.zengobi.com/support for more assistance such as:

* Retrieving a lost license key.

» Downloading a specific version of Curio.

+ Uploading a file for us to check out, like a crash log or template to share.
* Managing your Curio Mac App Store subscription.

+ Finding links to Traditional License and Subscription FAQ’s.

Curiota

Curiota is a free companion app, available via the Mac App Store, that opens up even more productivity with Curio. Curiota runs

silently in the background, consumes very little memory, and has a minimal user interface: you just see a simple icon up in the menu
bar. Click on that icon to create quick notes, or drag files and links to the icon to quickly add files.
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Curiota

The most important thing is that Curiota uses an open system for storing notes and files. There’s no proprietary file format or
database that could be corrupted. It’s your data and you will be always able to access it, even outside of Curiota, for decades to
come.

Curiota also supports print services (so you can “print” to Curiota), works as an macOS Share extension, is accessible via your
Services menu, and is easily scriptable. All of the submitted notes and files are accessible and searchable using Curio’s Local library
shelf, discussed below. More information about Curiota can be found at www.zengobi.com/curiota.

Visit our website to learn more about Curiota.
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Feature Roundup

Feature Roundup

Curio has scores of features that you can use to maximize your productivity!

Here’s a central index of all of Curio’s key features with links to details elsewhere in the documentation, separated by our Standard
and Professional editions.

Curio Standard

Kickstart your productivity with an amazing collection of features and functionality with projects unlimited in size.

Notebook Environment

* Project notebook environment with intuitive freeform idea spaces.

+ Rich text figures with support for bundled and personal figure styles.
» Markdown text figures with extensive syntax support for bold, italics, underline, strikethrough, highlight, inline code, links,

wikilinks, headers, emoji, images, lists, checklists, dashed lists, tables, block quotes, and code blocks.
« Embedded and aliased files, images, PDF’s, audio, videos, Mail messages, web links, web preview cards, and embedded

live web views.
+ Wikilinks and backlinks, markdown links, links to selected text or embedded PDF text, jump actions, jump anchors, idea

space link figures, and hyperlinks.
« Custom idea space templates and figure stencils plus Stencils shelf for quick access.

« Hierarchical Organizer sections for independent divisions in larger projects.
« Integrated Journal for a project diary, meeting notes, or class notes.

* Follow Figures and Bundle Figures for lightweight figure groupings.

+ Automatic project backups for peace of mind.

+ Bundled appearance themes to change the look of your Curio interface.

» Multiple project windows open for the same project.

« Custom app icons, a fun new perk for sustainers to enjoy.

Collections

« Compositions provide flexible, dynamically-sized arrangements of contained figures including text, images, files, plus lists,
mind maps, tables, and more. Tabloid compositions create newspaper-style layouts with flexible rows and columns, while
matrix compositions provide structured, simplified grids.

« Mind mapping with left, right, top-down, right-down, tree, and org chart arrangements; branch boundary shading;
relationship lines; date calculations.

- Lists from simple to-do’s to complex hierarchical lists, numbered or bulleted, checkboxes, level styles, date calculations.

» Albums of photos or documents, such as PDFs, with optional captions.

» Index cards for organizing your notes.

« Tables with headers, footers, and numeric formatting.

+ Pinboards for freeform collections of text and images.

« Stacks for Kanban-style task tracking.

+ Table of Contents list or mind map.
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Meta

» Focus mode to help you concentrate on specific figures or branches.

Meta

» Figure meta including checkmarks; percent complete; local project tags, cross project tags, and nested tag sets; start, due,
duration, done, plus smart date calculations; priorities; ratings; resources; notes; custom click actions.

*Inline  #tags and eresources .

* Organizer meta flags column

« Status bar to view and edit figure meta data.
« Search and Quick Find to quickly find and jump to idea spaces and figures with simple or complex queries including regular

expressions and boolean logic.
* Query-based Organizer Filters, dynamic Smart Filters, and Pinned Organizer ltems.

Multimedia and PDFs

+ Create and embed audio and video recordings.

* Embed YouTube and Vimeo videos.

+ SVG images.
« Placeholder images for easy swapping, perfect for stencils.

» Resample image to optimize format, compression, dimensions, and/or DPI.

» Markup image to annotate, highlight, and scribble on an image.

+ Brush and pen sketching with support for iPad+Apple Pencil via Sidecar.

« Integrated equation editor for LaTeX, AsciiMath, or MathML rendering of inline or standalone equations.

« Spread PDF to spread the pages of a PDF across multiple idea spaces for inline annotations and note-taking alongside the
PDF page.

Flowcharting

+ Flowcharting shapes for idea graphs, diagrams, and prototyping.

- Sticky lines with arrowhead styles; straight, curved, or orthogonal.

Research

« Sleuth window and Sleuth sidebar shelf for integrated Internet searching via popular research and image sites like Google,
Wikipedia, and more.

« Al Services including ChatGPT, Gemini, Copilot, Claude, Perplexity, Poe, Groq, Grok, Mistral, DeepSeek, Qwen, and local
LLM chat servers are also available from within Sleuth.

Import / Export

« Import/Export as text, markdown, image, PDF, HTML, CSV, OPML, and 3rd party mind map formats.
» Extensive markdown export and import.
« PDF Mirror live export of your project as a PDF to any specified location, including synced cloud services.

+ PDF Table of Contents in exports.
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Curio Professional

« Sync tasks to Calendar and Reminders.

« Local library shelf to easily list, find, preview, open, and drag in files anywhere on your Mac or within custom scope folders,
including support for DEVONthink items.

+ TaskPaper import and export and OmniOutliner Pro OPML import.

« Works with Curiota our free, always available menu bar app for quickly jotting down ideas, taking notes, or collecting files

when inspiration strikes.

Curio Professional

Curio’s most advanced features for power-users and productivity gurus.

+ Synced figure instances where copies of figures across a project share content and meta (transclusion) across an entire

project.

+ Synced files where figures can sync the contents of text figures and list, mind map, stack, and table collection figures to
external local or cloud-hosted files, either bidirectionally, export only, or import only.

» File-backed text figures display the content of embedded or aliased rich text or markdown files, located anywhere on disk,

as editable text figures.

« Figure layers allow for more flexible layouts and arrangements.

« Cross references, with custom types like Agree and Evidence, can be created between figures, idea spaces, and web
locations for more organized research.

« Status shelf for easy cross-project task tracking at a glance.

» Query-based collections allow you to create list, mind map, or stack collections that contain the dynamic results of a query,

like due<2w or #active .

+ Master figure styles and stencils, master idea space styles and templates, and master markdown styles for dynamic updates
throughout a project.

+ Presentation mode for group brainstorming sessions, plus Present in Window for remote window sharing.

+ Custom figure data allows custom keys and formatted values to be associated with your project figures and available for
search queries.

+ Custom variables for use throughout your project for dynamic text replacements.

+ Custom sharing actions to export data to other apps via 3rd party app URL schemes.

+ Custom appearance themes to fine-tune the look of your Curio interface.

+ Custom project backup settings.

« External project library to support Spotlight searching of project assets.

» External repositories for sharing styles, stencils, and templates with colleagues.

« Project password for project security.
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Projects

Projects

A real-world project is your class, your thesis, your ad campaign, your next product release, your lab experiment, or your next
sermon. Your Curio project is the same thing on your Mac. It contains everything related to your project including notes, sketches,
files, web links, images, brainstormings, ..., everything!

With a Curio project you keep all that stuff in one easy-to-manage file in the Finder. Everything is stored within that file package. This
means backups are a piece of cake and you don’t have to hunt all of your hard disk looking for all the related items.

Create a New Curio Project with an Initial Idea Space

1. Choose the File > New menu item, or hold Shift and click the Projects toolbar button.
2. Choose a personal or bundled idea space style or template to use as your initial idea space.
3. Click the Choose button.

Create a New Curio Project with a Blank Initial Idea Space

* Choose the File > New Blank Project menu item, or choose File > New and choose the blank bundled idea space style or
click the Blank button.

Create a New Curio Project Which Is Absolutely Empty

1. Choose the File > New menu item.
2. Hold the Option key and the Blank button will change to Empty. Click the Empty button.

Create a New Curio Project Based on a Project Template

1. Choose the File > New From Project Template menu item, or hold Shift-Option and click the Projects toolbar button. This
New Project From Template Gallery is described in detail below.

2. Choose a personal or bundled project template. Or choose the Blank template to create a project with a blank initial idea
space.

3. Click the Choose button. Alternatively you can click the Blank Project button to create a project with a blank initial idea
space.

Create a New Curio Project with Master Idea Space Templates

1. Choose File > New.

2. Select a template tag name and click the Use Tagged Set as Masters button.

3. A new project will be created where all of the idea spaces in the tagged set will be added to the project as master idea space
templates.

Open an Existing Curio Project

1. Click the Projects button and choose a previous project. When choosing a project from the Projects popup menu it will be
opened in place of the current project, thus acting as a fast project switcher. Hold Option when choosing a project to open it
in a separate tab within the current project window.

2. Choose the File > Open menu item to see the standard Open dialog. The project will be opened into a new tab or window
depending on your System Settings > General > “Prefer tabs when opening projects” setting.

3. Choose the File > Open Recent menu to instantly choose a recently-opened project. The project will be opened into a new
tab or window depending on your System Settings > General > “Prefer tabs when opening projects” setting.
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Projects

4. Choose the File > Open From Gallery menu item or click the Projects toolbar button to see Curio’s Open Project Gallery,
which is explained in detail below. The project will be opened into a new tab or window depending on your System Settings
> General > “Prefer tabs when opening projects” setting.

Save a Curio Project

* Your projects will save themselves automatically using the macOS native autosave feature, however you can also choose
File > Save at any time to save your project immediately.

Save a Curio Project as a Project Template

» Choose the File > Save As Project Template menu item.

Delete a Curio Project

+ Within the Finder, drag the Curio project from wherever you saved it to the Trash.

Archive a Curio Project

1. Choose the File > Create Archive menu item.
2. This will create a copy of your current project with all aliased assets converted into embedded assets, suitable for backup or
storage.

Automatic Opening of Previous Projects

Normally Curio will automatically open any project windows that were up when you last quit, although this can be disabled if you
wish.

However, note that macOS also has an auto open feature in System Settings > General via the Close windows when quitting app
checkbox. So even if Curio’s own setting is turned off, if this macOS feature is unchecked then macOS will tell Curio to auto open
the last opened projects.

Curio and macOS will also attempt to auto open any unsaved, untitled projects that were up when the application quit either due to
a system shutdown or crash.

To prevent Curio from auto opening any previously opened projects

+ Hold Shift while launching Curio. This handles 99% of all cases, especially for projects that you have saved at least once.

To prevent Curio from auto opening any previously opened, untitled projects

These untitled projects have never been saved by the user and were perhaps up when you lost power or a crash occurred. Curio
stores untitled projects in a special Application Support folder. If you want to prevent these projects from opening then you would
need to drag the files in this folder to the Trash and Empty Trash:

+ For Curio downloaded from the Zengobi website the folder is:
~/Library/Application Support/Curio/Version XX/Untitled
* For sandboxed Curio from the Mac App Store the folder is:

~/Library/Containers/com.zengobi.curio/Data/Library/Application Support/Curio
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Project Window

macOS itself can also store a list of any autosaved projects that were up at the time of a crash. To prevent macOS from auto
opening those you’d need to drag that file to the Trash and Empty Trash:

« For Curio downloaded from the Zengobi website the file to remove is:
~/Library/Autosave Information/com.zengobi.curio.plist
* For sandboxed Curio from the Mac App Store the file to remove is:

~/Library/Library/Containers/com.zengobi.curio/Data/Library/Autosave Information/com.zengobi.curio.plist

Project Window

The main windows in Curio are project windows. These can either be separate windows with each window showing a separate

project or, thanks to macOS, combined into a single window using window tabs.

Toolbar

Depending on your version of macOS and your screen resolution the toolbar could look very different.

By default, there are no text labels on toolbar buttons, although you can enable this by right-clicking on the toolbar and choosing
Icon and Text.

The toolbar arrangement itself could look unified, with buttons right-aligned on the toolbar and a left-aligned title, or traditional with
old-school buttons spread out all across the toolbar and the title centered at the top. The former is what Apple is moving towards
with their newer macOS releases, but the latter is actually more compact for smaller displays or lots of buttons. Based on your
screen resolution Curio will choose an appropriate default although you can change this via the View > Use Unified Toolbar Style

menu item.
Welcome to Curio = S - . = = =
©® ®® . ing Started » Welcome to Curio! [ 100% 5] N T B2 + = < B B £ = M Q L Q @m
@ BEma B HEHBEO O Layer 1 mAN= 4 Idea Space Meta Project
e style Bundled e
17} Getting Started
E Samples

You can customize the toolbar by right-clicking on the toolbar and choosing Customize Toolbar. In the palette that appears you can
drag-and-drop to add new items or remove existing items.

Opening Additional Project Windows

Use the Window > New Window menu item to open additional windows looking at the same project. These are full windows
complete with Organizer, shelf, inspector bar, toolbar, etc.

Changes you make in one will be reflected in the other. Each idea space has its own undo stack, regardless of how many windows
are open, so can undo changes to an idea space from any window.

Project Gallery

The project gallery is where you can manage and organize all of your Curio projects.
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Using the Project Gallery

Using the Project Gallery

To reveal the project gallery, click the Projects toolbar button and choose Open From Project Gallery, or choose File > Open From
Gallery.

* Your projects can be categorized in one or more custom project categories located along the left side of the window. These

same categories are used to organize projects in the Status shelf as well.
* Then, on the right side of the window, you will find the projects within the selected category.

Notes

« Smart Categories automatically list projects based on various criteria. For example, the *Recently Opened- smart category
lists all projects you’ve opened recently which are also listed in the File > Open Recent menu.

* You can magically turn the Open Project Gallery into the New Project Gallery by clicking the button on the bottom left corner
of the window.

* The project gallery window displays useful information about your project under its title. By default it will display the date it
was last modified but, if status information about the project exists, it will tell you if a project has a task which is due soon.

Working with the Open Project Gallery

Details on how to use the project gallery.

Show the Open Project Gallery Window

1. Choose the File > Open From Gallery menu, or...
2. Hold Option and click the Projects button on the toolbar.

Open a Project

» Double-click the project in the gallery window, or select it and click Open.

See a Quick View of a Project

« Select the project in the gallery window then press spacebar.

Open a Project Not Listed in the Gallery

« Click the Open Other button to show the normal macOS open dialog.

Create a New Project Category

+ Click the Add Project Category button then enter the name for your new category.

Rename a Project Category

» Double-click the category in the list and rename it. All affected projects will be associated with the renamed category Finder
tag as well.
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The New Project Gallery

Delete a Project Category

« Select a category in the list and press the Delete key. This will remove the category but not delete the projects within that
category. The corresponding category Finder tag will be dissociated with those projects as well.

Associate a Project with a Project Category

1. Select the category then drag-and-drop a file from the Finder to the right side of the window, or...

2. Drag a project listed in another category (such as the Recently Opened category) and drop it on top of the target category on
the left side of the window, or...

3. Right-click on the project as shown on the right side of the window and choose the target category from the popup menu

that appears.

Disassociate a Project from a Project Category

1. Right-click on the project itself and choose the category that the project should be removed from, or...
2. Select the project and press Delete on your keyboard. You will then be asked if it should be simply disassociated from the
current category or if it should be sent to your computer’s Trash.

Change How Projects Are Sorted in Gallery

+ Right-click on the background of the right side of the window and choose a sort order from any of the following: status, title,
last modified date, or date created.

See the Category Finder Tags Associated with a Project

+ Right-click on the project in the gallery and choose Display Category Finder Tags. From the alert that appears you can also
remove or reapply those tags.

Reapply Category Finder Tags Associated with a Project

+ Right-click on the project in the gallery and choose Reapply Category Finder Tags. This will reapply appropriate Finder tags
given this project’s associated categories.

Add Missing Project Categories to the Gallery

This feature is very useful if you’re moving to a new machine or replacing a drive for your projects.

+ Right-click in the category list and choose Add Categories Via Category Finder Tags. Curio will use Spotlight to find all Curio
projects, checking each for any associated category Finder tags, and then re-add any missing categories and re-associate
the projects associated with each category. This is useful if you installed Curio on a brand new machine and didn’t bring the
Application Support folder from your old machine.

The New Project Gallery

When creating a new project via File > New, the gallery that appears supports a number of organization features.

Copying Styles and Templates

* You can drag-and-drop styles and templates to your Personal repository or, if using Curio Professional, the Master
repository.
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Projects Toolbar Button

Organizing ldea Space Templates with Tags

1. Right-click in the Personal repository area on the Personal > Templates item and choose Add Tag.
2. Enter a collection tag name. For example, you might organize your idea space templates into “Favorites”, “Work”, and

“School”.

Projects Toolbar Button

The Projects toolbar button allows you to quickly create or open your organized projects. Clicking Projects reveals a popup menu

with several options:

« Create a new project (with an initial idea space), or a blank project, or one based on a saved project template.

+ Open a project from the Open Project Gallery.

+ Quickly open a recently opened project.

* Quickly open a project categorized in your project categories such as Active or Work. You create these categories in the
Open Project Gallery or in the Status shelf.

Keyboard Shortcuts When Clicking Button

The Projects button supports some shortcuts to bypass the menu and jump straight to a particular gallery:

« Click Projects: you see the normal menu choices described above.

« Click Projects while holding Option: immediately see the Open Project Gallery.

« Click Projects while holding Shift: immediately see the New Project with Initial Idea Space Gallery.

« Click Projects while holding Shift+Option: immediately see the New Project with Project Template Gallery.

You can make it so those first items reverse their Option logic via an advanced preference. After making that change the result

would be:

« Click Projects: immediately see the Open Gallery.
« Click Projects while holding Option: you see the normal menu choices described above.

Keyboard Shortcuts When Selecting Project

When the Projects button menu is up there are two ways to open a selected project:

« Select a project: replaces the current project with the selected project, essentially acting as a quick project switcher.
« Select a project while holding Option: opens the project in a new window or tab, depending on your System Settings >
General > “Prefer tabs when opening projects” setting.

Project Categories

Creating custom project categories, such as active and personal , and assigning your projects to one or more those categories

is a great way to organize your projects in the Project Gallery window and the Status shelf.
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Categories and Finder Tags

Working with Project Categories

To get started, show the Project Gallery via the File > Open From Gallery menu. Next, click the Add Project Gallery button to create
a new category, such as classes .

A project can be associated with multiple categories. For example, you may have a Chemistry 101 project associated with

Classes , Freshman Year ,and Active .

To associate a project with a category you can drag-and-drop a project file from the Finder into a category, or right-click on a project
in the gallery and choose a category.

You can then open your projects using the File > Open From Gallery menu to see your neatly organized projects, or use the Projects
Toolbar Button to open a project with a single click, or track the status of all your project categories using the Status shelf.

Learn more about creating, modifying, and deleting project categories using the Project Gallery and the Status shelf.

Categories and Finder Tags

Project categories and Finder tags can be used together to supercharge your project organization.

Tip

Project categories and automatic Finder tags for those categories can help manage your projects and your project gallery. As
mentioned below, this combination can be especially useful if you’re moving to a new machine or replacing a drive for your
projects.

Categories — Finder Tags

Any projects that you associate with categories will automatically have associated Curio Finder tags as well.

For instance, if you associate a project with the categories active and personal , then Curio will create and associate the Finder
tags curio Active and curio personal With the project.

In addition, on launch Curio will go through all projects tracked in the Gallery and, based on their assigned project categories ( activ
e ), make sure they are correctly associated with their corresponding Curio Finder tags ( curio active ).

Finder Tags — Categories

The reverse will also work: setting Curio Finder tags via the project window title bar dropdown or the Finder itself will automatically
associate project categories used in the Project Gallery and Status shelf.

On launch Curio will go through all projects tracked in the Gallery and, based on their Curio Finder tags ( curio active ), make sure
they are correctly associated with their corresponding assigned project categories ( active ), automatically creating categories if
necessary (this can be disabled). Note this verification will not remove any category associations if a Finder tag is missing, just to
play it safe.

In addition, during each save or autosave of a project Curio will assign or remove category associations based on any Curio Finder
tags you set.
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Categories and Finder Tags

For example, here we'’re setting the curio Home and curio active Finder tags via the title bar dropdown, which automatically
associates the rHome and active categories with the project the next time we save the project.

'Y X ¥ Sort Test Vv

J ,,,,,, A, Default Section ades —
Name: | Sort Test OE
i}
Tags:  Curio Home Curio Active
Where: = Curio Projects Locked
=

Next, we remove the curio active Finder tag and setthe curio Ho1d tag. The next time we save, the new w014 association is
made and the active one is removed (removal is disabled by default but can be enabled).

J XK ) ¥ Sort Test Vv

~_Default Section” ades

Name: | Sort Test ; oE
om
Tags:  Curio Home Curio Hold
Where: = Curio Projects Locked
o

If you enter a new Curio Finder tag, like curio Banana , and the corresponding sanana category doesn’t already exist then Curio
can automatically create it for you (category creation is enabled by default but can be disabled).

- B Sort Test v
) ed
J, i.i & ! _____Default Section” ades —
Name: | Sort Test V om
]
Tags:  Curio Home Curio Hold Curio Banana
Where: = Curio Projects Locked
|

And here’s what the resulting categories look like for the project in the Project Gallery.
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Project Templates
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Restoring Categories and Projects

As mentioned above, the Project Gallery has a useful Add Missing Project Categories to the Gallery feature that uses automatic
Finder tags for project categories to search your hard disk to re-create your project categories and project-to-category associations.

This is very useful if you’re moving to a new machine or replacing a drive for your projects.

Finder Search

With category Finder tags, you can now search for categories of projects in the Finder, outside of Curio. Just enter the search tag,
such as curio active in a Finder window search field and you’ll find all projects associated with that category. Click the Save
button in the Finder window to save the search and even add it to your sidebar for one-click access to those projects. See the use
tags to organize files on Mac section on Apple’s site for more information on using Finder tags.

Project Templates

You can create and reuse your own project templates.

Save the Current Project as a Project Template

+ Choose File > Save As Project Template.

Create a New Project from a Project Template

+ Choose the File > New From Project Template menu, or...
» Click the Projects button on the toolbar then click the Switch To New Project Gallery button, or...
+ Option-Shift-Click the Projects button on the toolbar.

See a Quick View of a Project Template

+ Select the project template in the gallery window then press the Spacebar.
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Project Inspector

Create a Personal Template Folder

+ Right-click in the template list and choose Add Template Folder. Curio will create an actual folder on your hard disk with the
given name within the ~/Library/Application Support/Curio/Version XX/Repository/Project Templates directory. This is where
your templates will be stored on disk.

Rename a Personal Template Folder

» Double-click the template folder in the list and rename it.

Delete a Personal Template Folder

+ Select the template folder in the list and press the Delete key. After confirming the template folder and any templates it
contains will be sent to the Trash.

Copy a Template to a Personal Template Folder

* Drag a template from another template folder and drop it on the target folder.

Delete a Project Template

« Select a template then press the Delete key to send the template to the Trash.

Project Inspector

To view the project inspector panel, click on the background of the current idea space then either:

« Click the little briefcase icon in the inspector bar, or
« Click the Inspector toolbar button to open the inspector shelf then look at the Project tab.

Icon

Set an optional icon image for your project by copying an image and pasting into the provided image well. This icon will be used as
the project thumbnail in the Finder, the Open Project Gallery window, and the Status shelf.

Next to the image well is a helpful “image assistants” popup menu. Here you will find quick access to popular textures and sample
images via Google Image Search which you can drag and drop into the project image. Then you can use the assistance popup
menu to apply a binder or journal appearance to the image.

Alternatively, the assistants popup also includes a number of template icons you can use for your project image. A color control sits
alongside the assistants popup which you can use to tint the template to any color you wish.

Home

You can set the current idea space as the Home idea space then use the {}3H (or Organizer > Go to Home Idea Space) to quickly
go to the specified idea space.

If a Home idea space is not set Go to Home will go to the first Organizer item in the project.
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With a Home idea space set the Finder thumbnail for the project will be that idea space, instead of the first idea space in the project.
Of course if you specified a project image in the Project inspector then that overrides the thumbnail.

On Open
When Curio first opens a project it can automatically open either:
* The last viewed idea space,

« The first idea space,
» The Home idea space,

» Today’s entry in Journal. In this case, if a default Journal idea space style or template is set then Curio will automatically
create a new idea space entry for today using that default. This auto-creation can be disabled.

If set to last viewed idea space then Curio will also open the secondary split view to whatever was last displayed there, if
appropriate. However, for all other settings Curio will not restore the secondary split, but this can be overridden.

Milestones

You can create project milestones, like Client Demo or Beta 1 and use those milestone names in place of dates in a Quick Find or
Search query or Organizer filter.

In the inspector panel:

* The popup shows the current milestones.
« Click the plus button to add a new milestone where you specify a name for the milestone and its date and optional time.
+ Click the minus button to remove the currently selected milestone.

As an example, after defining the Beta 7 milestone to the date May 1, 2023 you can enter a Quick Find query like due < betal
instead of typing due < 2023-05-01 . You can also use the Organizer filter to find all modified idea spaces since that date by simply
choosing that milestone from the filter popup.

Idea Space Margins
Set the top, left, bottom, and right margins for your idea spaces.

You can also check to use the smallest margins possible, given the specified printer in Page Setup. Certain printers may have a
minimum margin where they can’t print.

Calendar Sync

You can sync your Curio tasks with the Calendar and Reminders apps, allowing you to manage your tasks even on iOS devices.

Enable Sync

Using the project inspector, enable the synchronization of project tasks with your Calendar and Reminders apps by clicking the on/
off checkbox.
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Calendar Sync

Pick a Calendar and Reminder List

In the Events popup choose a calendar to sync your event tasks to. By default, an event task is a figure in Curio that has a start
date and, optionally, a due date. You need to create the calendar via Calendar app’s New Calendar menu. You can create and use
an iCloud-based calendar if you wish.

In the To Dos popup choose a reminder list to sync your to-do tasks to. By default, a to-do task is a figure in Curio that only has a
due date or simply a checkbox item with no dates at all. You need to create the calendar via Reminder app’s New Reminder List
menu. You can create and use an iCloud-based list if you wish.

As you noticed the Calendars and Reminders apps require type-specific calendars. This means one calendar for events and one for
to-do’s (aka reminders). You cannot use the same calendar for both types of data.

The event and to-do calendars you create must have different names. In other words they can’t both be called “Curio”. Instead
perhaps “Curio” for your events and “Curio Tasks” for your reminders. You can either share a calendar list and reminder list between
all your projects or create and use a separate list for each of your projects, it’s up to you.

Troubleshooting

If you don’t see any calendars in the popup then macOS has stuck Curio with Add Only Access permission to Calendar, which
makes syncing rather difficult. To fix it go into Settings > Privacy & Security > Calendar, and click the Options button next to Curio to

enable Full Calendar Access, then relaunch Curio.

[ NON { > Calendars

Q Search Allow the applications below to access your calendars.

& siri & Spotlight ) '
Curio @ Options...

m Privacy & Security Add Only Access

Allow Curio to access your calendar:

Access to your calendar will give applications access to all associated
metadata. Choose between full access to your entire calendar, or add only
access.

© Full Calendar access
Add Only Access

Alerts

For calendar event alerts check the “Enable event alert before start date” checkbox and select when the alarm should go off.

For reminder task alerts check the “Enable to-do alert before due date” checkbox and select when the alarm should go off.
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Advanced Options

Click the action button to see a popup menu appear with various options.

* Reset Events and To Dos will remove then re-create all events and to-do items associated with the project in the selected
calendar and reminder lists.

* Remove Events and To Dos this will remove all events and to-do items associated with the project in the selected calendar
and reminder lists.

* Figures with start dates map into will determine what these types of figures will turn into. Calendar Events is the default.

* Else figures with only due dates map into will determine what these types of figures will turn into. Reminders is the default.

* Sync unchecked figures with no start or due dates will create reminder tasks for checked items that have no start or due
dates.

* Prefix each synced item with project name will prefix the name of your project in front of the title of each synced item.
Thus the task “Finish Ul design” in the “Cool App” project will become “Cool App: Finish Ul design” in Calendar/Reminders.
This is a useful feature if you share a common calendar/reminder lists with all your Curio projects.

Important
For safety, you will need to manually remove older files and folders from the PDF mirror location if you change preferences or
export options.

Additional Notes

If the Curio figure has a start and/or due date but is checked — that is, completed — then it is not synchronized to Calendar.

When syncing if an event begins and ends at 12:00 midnight then it is considered an all-day event, otherwise the specific times are
used when creating the event.

All times are considered floating times, therefore they are time zone independent. This means that a task ending at 4:00 PM will end
at that time regardless of where you were when you created the task or where you are currently.

When Does the Sync Occur?

Changes made within Curio will be synchronized only when the project is saved or autosaved.

However, when you first open a project, it will immediately synchronize to retrieve any changes made from within Calendar/
Reminders. And while the project is open, if changes continue to be made in Calendar/Reminders, Curio will immediately reflect
those changes within the project.

PDF Mirror

Curio can publish a mirror or replica of your project in PDF form to a specified location.

This is very different than a normal PDF export in that each idea space is converted into an unscaled PDF image, with no page
breaks or fit-to-page scaling, then all the resulting images are merged into a single PDF document. In addition, this published PDF
can include clickable file links as any embedded or aliased assets can optionally be exported into a folder hierarchy alongside the
PDF document.

This publishing event can occur either manually via a File > Update PDF Mirror command, or automatically every time an updated
project is closed.
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This can be useful for several reasons including for backup purposes or, if published to a Dropbox or similar synced folder, a method
for you to access your project while on your iPad, iPhone, or another computer.

Important
Please note that the resulting PDF mirror is not password protected even if your project is password protected.

Enable PDF Mirror
Using the project inspector, enable the PDF mirror feature by clicking the on/off checkbox.

Location

Specify the folder location for the resulting PDF by clicking the Choose button. This location is where Curio will create a single PDF

for each section in your project, if you have multiple sections enabled.

The form of the file names for the resulting PDF’s is ProjectName-SectionName.pdf file, where the section name is only appended if

necessary. Curio will create a manifest file alongside each PDF file so it can track what’s inside each PDF.

Options

+ Enable the exporting of embedded and aliased assets into a folder alongside the resulting PDF. Curio will also modify the
PDF so that clicking or tapping on the asset figure on the PDF will launch and view the exported asset. However, this is
highly dependent upon the abilities of the PDF viewer you use so see below for additional notes.

* Normally all idea spaces are mirrored but you can direct Curio to obey the idea space’s exporting privacy restriction if you
wish so that some idea spaces are not exported when mirroring. This restriction can be enabled for individual idea spaces
via the Options panel of the Info inspector.

+ Enable automatic publishing when a changed project is closed (or Curio is quit).

You can click the Publish Now button to instantly publish your project or use the File > Update PDF Mirror menu item to publish.
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Advanced Options

Click the action button to see a popup menu appear with various options. Note that if you change any settings you will need to

manually remove any previously published files. We don’t do this automatically for safety reasons.

« Compress resulting PDF

By default Curio will perform a compression on the resulting PDF, although not as extreme as Apple’s Reduce File Size PDF
compressor. You can also create your own compressor using the ColorSync application and an advanced preference.
Keep prior PDF as backup

Curio can optionally make a copy of a preceding day’s PDF as a backup which is useful if you make a catastrophic change
and need to recapture that information.

* Modify file link paths

The file paths for published asset files can be modified to strip out characters that may interfere with certain PDF viewers, as
discussed below.

* URL encode

This is a standard technique for encoding spaces, international characters, and other symbols so they turn into numerical
codes preceded with a percent sign. Some PDF viewers (like Acrobat) work with URL encoded file path names but others
don’t. Ideally all would support this and we wouldn’t need the other character conversions at all.

« Strip all potentially unsafe characters

Remove any characters from the file name that might not be cross platform such as slashes.

Convert characters to ASCII only

Changes foreign characters to their simple ASCII equivalents such as & to a. File links with simple characters don’t need to
be escaped (such as percent-encoded) which provides greater compatibility with various PDF viewers.

» Convert spaces to underscores

Converts a spacebar character into the _ underscore character.

* Remove spaces

simple removes any spaces from the file name.

* Prefix asset links with file:// scheme

Technically Curio creates relative links paths, which means paths to the asset files are relative to the location of the PDF file
itself. Relative paths shouldn’t need a scheme but some PDF viewers require it.

* When exporting assets

You can optionally include aliased assets (enabled by default) and image assets (disabled by default). Image assets are
normally not exported since the images themselves are visible within the PDF itself so probably will not need the actual
standalone image files exported.

Additional Details
Embedded PDF Outline

The PDF generated by PDF Mirror includes embedded PDF document outline for easy navigation using PDF viewers that support

that standard PDF feature. In Apple’s Preview app, for example, choose View > Table of Contents to see the PDF’s hierarchical

document outline.

The PDF outline is part of the PDF standard so most standards-following PDF readers should support it. Zengobi has tested it with

the macOS Preview and Adobe Reader apps as well as the following iOS apps: Dropbox, Readdle’s PDF Export and PDF Viewer,
Good.iWare’s GoodReader, Branchfire’s iAnnotate PDF, and LiquidText.
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Clickable Links

When you export idea spaces via Export as PDF or PDF Mirror, the resulting PDF will have clickable links for:

* Weblink figures, like a URL dropped from a browser into an idea space.

* Figures with URL actions.

» Weblinks and figure URL actions that are inner project hyperlinks (ex: curio://?ideaspace=062...).

« Idea space links to other inner project idea spaces.

« Jump anchors to inner project locations.

* Figures with jump actions to inner project locations.

« Figures with first, last, previous, or next idea space jump directions.

+ For PDF Mirror, you have the option of exporting assets as well, such as images and documents, so those figures would
have links to their corresponding exported asset files. See the note below for compatibility details.

Limitations

Curio doesn’t generate PDF links for a selection of text within a text figure that has a link attribute. This is a tricky one to solve as (a)
Curio would have to scan all text figures when exporting to find any NSLinkAttribute attributes which could be very slow, (b) the
resulting selection may consist of wrapped lines of text complicating the generation of potential PDF annotation link(s).
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Supported PDF Viewers

The generated PDF’s have been tested using a number of PDF viewers on both macOS and iOS. Here are some notes regarding
their ability to handle various PDF features.

* Text. In general, all PDF viewers, regardless of platform, should display the PDF itself just fine, with text being rendered
beautifully. Text should be searchable and selectable allowing you to quickly find and access information anywhere in your
project.

* Figure Notes. All PDF viewers should also provide some ability to view figure note annotations usually via a hover, click, or
tap of the figure’s note adornment. In Preview, for example, you can hover over a note adornment or bring up the Inspector
window (via Tools > Show Inspector) then click the Annotations tab to see all note annotations.

* Web Links. Likewise, all PDF viewers should allow you to launch any web links associated with Curio web link figures or
web link actions.

* Clickable Asset Links. Producing clickable assets is a bit tricky. The file links within the PDF are relative links, which means
they are relative to the current location of the PDF document itself and should continue to work even if the document is
moved to another location/platform either manually or via sync.

o Mac Apps
= PDF Viewer from PSPDFKit works very well with file links.
= PDF Expert from Readdle works very well with file links.
= Acrobat Reader supports relative file links. You may need the following modify file link paths preferences: URL
encode. Alternatively, if you wish to also be compatible with iOS readers which don’t support URL encoding
yet you may use these instead: Strip all potentially unsafe characters, Convert characters to ASCII only,
Convert spaces to underscores. For images they will open in a browser window, otherwise Acrobat simply
reveals the file in a Finder window. Presumably for security purposes it doesn’t automatically launch the file.
= Apple Preview on the Mac doesn’t appear to support file links of any kind, perhaps for security reasons.
> iOS Apps
= PDF Expert from Readdle works very well with file links if you store files in their iCloud app-specific folder,
called “Documents by Readdle”, as they auto-sync the entire folder hierarchy ensuring access to all linked-to
files.
= Otherwise, iOS apps which have adopted Apple’s “document browser” APl introduced in iOS 11 to access
synced services such as Dropbox, iCloud Drive, Box, etc, may have some issues:
= Apple’s API currently doesn’t give developers access to easily sync a folder hierarchy which is required

to handle file links.

= Previously a workaround was to use the File app to copy the PDF file and the subfolder containing the
linked-to files into “On My iPad” or “On My iPhone”.

= Then, you could use an app such as PDF Viewer to look into “On My iPad” and open the PDF file and
the links would work!

= However, now it seems they either do nothing or show a “no handler found” error.

= So we may need to wait until Apple expands the API with the additional support developers need.

Reference Types

References are detailed in the section on creating reference links.
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Custom Variables

Custom Variables

Using the project inspector, Curio Professional users can create their own global and per-project custom variables, such as Author
and Class, which can then be used within Curio using the variable markup syntax when editing, such as {{author}} . Those
variables are then replaced dynamically when rendered.

Custom Variables vs Custom Data

A related feature is custom figure data. In short:

+ Custom variables are text replacements for variables you create and use throughout your project. For example, you can
create a custom variable named Author and give it a value of George, then use the ({author}} variable markup syntax in
your project’s text figures.

» Custom data allows you to create project-wide formatted keys, such as Price or Score, and then assign values to those
keys for each figure, adding custom meta data to every figure for searching and export purposes.

Viewing Custom Variables
Use the scope popup to view and create custom variables that are just for this specific project, or that are globally available for all

projects.

The variables are always displayed sorted by name.

Adding a Custom Variable

1. Choose the scope of the variable: either just for this project, or globally available for all projects.
2. Click the Add Variable button and type in a variable name.
3. Press Tab to move to the value field and then enter its value.

Custom Variables v
Show this project's custom variables
Key Value
Class Computer Science 101
ClassYear 2021
Semester Fall

Add Variable
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Custom Variables

Custom Variables v

Show the custom variables available to all projects

Key Value

Author George

School Butternut College
Add Variable

Naming Conventions

Local project variables will take precedence over globals that have the same. For example, a project variable named author
will override a global author variable, created in the past or even in the future. This precedence can come in handy if you
want to override a global on purpose for a specific project, essentially making the global a default value. However, if you use a
lot of global variables that you don’t want to accidentally override, then you may want to come up with a naming convention to
make sure those are distinct.

Editing a Custom Variable

To edit a custom variable’s name or value, double-click its name or value field, change the text, and press Return.

Important
Note that changing a variable’s name does not replace any uses of that variable in your project or in other projects. You would
still need to manually change those text figures as necessary.

Deleting a Custom Variable

To delete a custom variable, select the variable and click Delete Variable or press the Delete key.

Warning
You cannot undo the deletion of a custom variable, although you can simply re-create it. Any uses of that variable in text figures
in this project or other projects will still remain in place.

Importing Custom Variables

1. From the popup choose either this project’s variables or the variables available to all projects.

2. Click the Import button and choose a comma-separated value (CSV) file of variable names and values. Each name, value
pairing must be separated by a new line. If a name or value contains a comma then enclose the text with quotes: course
Instructor, "Al Einstein, PhD"

3. New variable entries will be made using the contents of that file.

4. If a variable name already exists then that existing entry will be updated with the new value for that variable name from the
file.
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[ N N ) % test.csvv

Course Instructor, "Al Einstein, PhD"
Topic Title, "Physics: 1, 2, 3"

Custom Variables

Show the custom variables available to all projects &

Key Value

Course Instructor Al Einstein, PhD

Topic Title Physics: 1, 2, 3

Add Variable : Import...

Using a Custom Variable

You can use your custom variables in several locations within Curio.

Within Text Figures
When editing a text figure use the {{variableName}} sSyntax suchas ((author}} .
Helpfully Curio will show you an autocomplete popover as you start typing within a Curio text figure. For example type ((a and the

popover will show all the custom variables that start with a such as author . Use the arrow keys to choose one and press Return
and the word is autocompleted for you and the ending 1) appended if necessary.

o {Author}} - {J o

ClassYear

Insert > Custom Variable

You can also select the variable from the Insert > Custom Variable main menu submenu, which will insert the syntax for you, creating
a new text figure if one is not currently being edited.

Within Figure Notes

You can also use the {{variablename}} Syntax (as well as normal Curio variables like {s1deaspacename} ) in figure notes. These
variables are dynamically replaced when the figure tooltip is displayed, when figure notes are copied or exported as text, and as
popup tooltips in PDF exports.
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Within Print Headers and Footers

Simply use the {(variablename}} syntax suchas ({author}} . Note that autocomplete doesn’t assist here.

Within Idea Space Template Titles

You can also use the {(variablename}} Syntax in personal and master idea space template titles which are then replaced when you
add an idea space to your project using one of those templates. They aren’t replaced dynamically after that point, however.

Optional Casing

You can optionally append one of the following casing extras to the variable preceded by a / symbol:

* uppercase
 lowercase
- capitalize

For example, {{class/uppercase}} Will resultin covpuTER scIENCE 101 .

Advanced Project Options

Using the project inspector you can set up a number of advanced options for your project.

Project Password

Set a password for your project so that it cannot be opened unless the password is re-entered. The contents of your idea spaces
and many ancillary files within the project package are then encrypted and decrypted using the AES-128 algorithm.

Note when a project is encrypted you cannot see the status of the project in the Projects Gallery or Status shelf until the project is
opened, or use Quick Look in the Finder to see a preview or thumbnail, or use Spotlight to search for items in the project.

Encrypting and decrypting a large project will take a few moments to complete, do not force quit Curio when this is occurring!

Warning

Any embedded assets, including documents, images, and audio and video recordings, will not be encrypted. If you need to
encrypt everything in your Curio project — including all embedded assets — we’d recommend using either a volume protected
with FileVault, or an encrypted disk image that you use to store your Curio projects (perhaps one disk image per client, for
example). Alternatively, you can use an application such as Knox which can automate the creation and sizing of encrypted disk
images.

If you forget your password, your data will be lost. Zengobi cannot decrypt the project.

Project Backups

Override the global backup settings specified in Curio’s Settings so this project has unique backup properties. For instance, you

might specify that an especially large project is backed up every 3 days.

Asset Library Location

You can tell Curio to use an external asset library folder so it can be indexed by Spotlight.
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Normally embedded assets are stored within a file folder located within the project file package, which you can see if you right-click
on the project file in the Finder and choose Show Package Contents. However, Spotlight cannot index within package files therefore
you can’t use Spotlight to search their contents.

You can choose whether Curio should store your project’s asset library within the project file or external to the project file, in a
.curioLibrary folder which sits alongside your .curio project file. Operations within Curio automatically support external library folders
such as File > Save As, Save To, Duplicate, and Rename, File > Create Archive, Quick Look, and the automatic project backup
feature described elsewhere.

Important
You must make sure both the .curio and .curioLibrary files have the same file name and are kept together, otherwise Curio will
be unable to open the project file.

Lock File

A project lock file is useful when sharing a project using a cloud-synced service such as Dropbox or a network file server to make
sure more than one person doesn’t attempt to make changes to the project at the same time.

When set to automatic Curio will determine on its own if a lock file should be created. Alternatively, you can force a lock file to be
used or not used if you wish.

Tip
Tips on storing your projects in a cloud-synced folder such as iCloud and Dropbox can be found in Cloud Syncing.

Mac App Store Restriction
Note that due to sandboxing restrictions both the external asset library and lock file features are only supported for projects
stored in the Projects folder specified in Curio’s Settings.

Project ID
Every Curio project has an internal unique identifier which is used for a number of purposes:
1. curio:// hyperlinks to figures and idea spaces.

2. Cross-project jump actions.
3. Calendar/Reminders syncing to uniquely identify all synced events tied to a given project.

4. When resolving a hyperlink or cross-project jump if Curio can’t find the project it can use Spotlight to search for the project
since that unique identifier is stored within the project’s Finder meta data.

5. When resolving a hyperlink or cross-project jump if Curio can’t find the project even using Spotlight then it will ask you to
find it. Then Curio will store a project identifier to path mapping, so it can resolve this automatically next time.

When you create a new project or create a project based on a project template then Curio will assign the project a unique identifier
automatically.

However, if you duplicate a project, either via File > Duplicate or using the Finder, then that copy will have a the same identifier as
the original. In that case, you can reset the identifier in the copy using its project inspector to ensure correct linking and syncing.
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The Organizer

Your Curio project can contain hundreds of idea spaces and documents all neatly organized in the Organizer. Curio allows you to
organize your idea spaces and other Organizer documents hierarchically. You can also group items into lightweight folders or
heavyweight project sections for maximum flexibility.

Curio’s Organizer contains the main “pages” of your project notebook.
There are two main types of items the Organizer can store and organize:

1. An idea space is like an amazingly magical piece of paper that can contain notes, files, sketches, images, movies, mind
maps, tables, and much, much more.

2. An Organizer document is a file dragged in from the Finder, thus turning the Organizer into a versatile binder of notes and
documents.

These two types of Organizer items can be arranged, grouped, and hierarchically organized using the Organizer.

Show or Hide the Organizer

The Organizer sidebar toolbar button can be used to toggle the display of the Organizer or open a specific section or feature within
the Organizer:

+ Click the Organizer sidebar toolbar button to instantly toggle the display of the sidebar.
« Click and hold on the Organizer sidebar toolbar button to see the menu of display options.

There are also a couple of keyboard modifier shortcuts that may be useful:

« If you Option-click the Organizer sidebar toolbar button you will instantly toggle the display of sections.
« If you Shift-click the Organizer sidebar toolbar button you will instantly toggle the display of masters.

Create a New Item in the Organizer

Click the Add Organizer Item toolbar button and, from the popup that appears, choose whether you want:

. A blank idea space,
. A new idea space using a user-specified default idea space style or template,

. A new idea space using the same style or template as the current idea space,
. An idea space from the Idea Space Gallery,

. A blank rich text document (technically RTFD so it can contain graphics, too),
. A folder, used as a lightweight grouping of other Organizer items,

. A section, used as a heavyweight division within your project,

. An instance of a master idea space template (PR ).

0 N O Ok WD =

Instantly Create an Idea Space with the Same Style as the Current ltem

+ Hold Shift and press the New Organizer Item toolbar button, or choose the Organizer > New Idea Space With Current Style,
or right-click in the Organizer and choose New Idea Space With Current Style.

Instantly Create a Blank Idea Space

+ Choose the Organizer > New Blank Idea Space menu item, or right-click in the Organizer and choose New Blank Idea Space.
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Instantly Create a Blank or Default Idea Space

« Option-clicking the Add button will add a blank idea space, or a default idea space if one is specified.

Instantly Create and Link to an ldea Space via Text Figure

1. Right-click on an existing text figure.

2. Choose Create Linked Idea Space.

3. A new idea space will be created as a next sibling of the current idea space with the same title as the text figure.
4. A jump action to that new idea space will be created and associated with the text figure.

O Interview =~
Text Options >

Show Checkmark
Attach File...

Create Linked Idea Space...

This feature supports several customizations that can be applied via advanced settings.

Rename an Organizer ltem

+ Within the Organizer, double-click on the item, or select an item and press Return, or right-click and choose Rename.

Pinning an Organizer Iltem

You can pin an Organizer item so it will appear in the bundled Pinned Smart Filter which is always displayed at the very top of the

list of Smart Filters so you can quickly see and access your pinned idea spaces and other Organizer items.
+ Right-click on an item within the Organizer and choose Pin to pin the item, else Unpin to remove the pin.

When you pin an item, if the Smart Filters are not visible, the Organizer filter panel is made visible and sized so you can see your
Smart Filters.

Assigning a Label

In addition to using the Labels panel in the meta inspector panel described below, you can also change the associated label via the
Organizer context menu.

+ Right-click on an item within the Organizer and choose a label from the Label submenu. Only one label can be associated
with an Organizer item.
* You can use the Organizer filter and Smart Filters to keep track of Organizer items that are associated with specific labels.

Assigning Tags

In addition to using the Tags panel in the meta inspector panel described below, you can also change tags via the Organizer context
menu.

+ Right-click on an item within the Organizer and choose a tag from the Tags submenu. One or more tags can be associated
with an Organizer item.
* You can use the Organizer filter and Smart Filters to keep track of Organizer items that are associated with specific tags.
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Create a Duplicate of an Existing Organizer Iltem

« There are many ways to duplicate an existing item: Choose the Edit > Duplicate menu item, right-click on the Organizer item
and choose Duplicate, Copy/Paste, or hold down the Option key while drag-and-dropping Organizer items.

Create an Organizer Alias to an Existing Organizer ltem

Drag-and-drop a selection of Organizer items (e.g. idea spaces, Organizer documents, Organizer folders) to another location within
the Organizer while holding down the ~\c§ (Option-Command) keys on your keyboard. When you release the mouse, aliases for all of
those items will be created at the drop location. Here are some notes on Organizer aliases:

1. You’ll know it’s an alias because its title is italicized and its preview icon has a little alias curl in the corner.

2. The title of the alias can be renamed to anything you wish and it will not change the original.

3. Everything else is linked to the original: preview, color label, tags, notes, etc. If you change either the original or an alias then
they all change.

4. You can right-click on an alias and jump to the original.

5. Duplicating an alias creates another alias to the original, it doesn’t create an alias to the alias.

6. You can hierarchically organize aliases just as you would any other Organizer item, including adding idea spaces as children
under the alias.

7. You can delete an alias and this will not impact the original.

8. However, if you attempt to delete the original, Curio will warn you that aliases exist and will be broken if you continue. Curio
will not auto-remove aliases because they themselves might have children. The alert will also give you the option of jumping
to the alias so you can delete it manually.

Delete an Organizer Item

» Within the Organizer, press the Delete key to delete the idea space, or right-click and choose Delete.

Rearrange Organizer ltems

+ Simply drag-and-drop idea spaces around within the Organizer to re-organize them.

Indent or Outdent an Organizer Iltem

+ Select the idea space within the Organizer and press the Tab key to indent the item or Shift-Tab to outdent. You may also
drag-and-drop the idea space into position. You can have any number of hierarchical levels within the Organizer.

Expand or Collapse Organizer Iltem Hierarchies

« Click the disclosure triangle to expand or collapse an idea space hierarchy or use the Organizer menu’s Expand, Expand All,

Collapse, and Collapse All menu items.

Open an Organizer Item in the Secondary View

+ Option-click on the item or right-click and choose Open in Secondary View. The secondary view can be placed to the side or
under the primary view. Use the View > Secondary View Below / Secondary View On Side menu to configure its placement.
You can also Option-click on the splitter control in the navigation area of the inspector bar to do this.

Display Options

1. Change the size of the Organizer’s displayed previews by right-clicking in the Organizer and choosing a new size. This new
preview size can be global across the entire project or just for the current section.
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2. Sort Organizer items by right clicking on an item then choosing a sort method from under the Sort Siblings By submenu.

Organizer Meta Flags Column
A new meta flags column will appear on the right-side of the Organizer if you associate certain meta attributes with your Organizer

items including:

* The assigned label color.
» Whether the item has any associated meta notes.
+ One or more tag images for any associated tags.

Clicking on a flag will allow you to change that related item:

« Clicking a label color flag allows you to choose a different label coloring.

+ Clicking a note flag reveals the notes floating window for editing. Clicking the note flag again for the same item will hide the
notes window.

« Clicking a tag image flag shows a popup of other tags in the same tag set so you can uncheck the current tag or choose a
different tag. Holding Option when clicking the flag shows all available tag sets and tags.

The flags column can display up to 7 flags for an item and will automatically size itself as needed. You can hide the flags column via
the View > Hide Organizer Meta Flags menu item.

Organizer Numbering Column

You can reveal an Organizer column which shows the numbering of the items in the Organizer. This feature, plus the Organizer > Go
to Organizer ltem Number menu item, is useful when you would like others to jump to a specific Organizer item number in a shared
project, for example.

You can toggle the display of the count column via the View > Show/Hide Organizer Count Column menu item.

Note the displayed number is simply based on the flattened, sequential ordering of items in the Organizer. It is not based on print or
export restrictions, page setup settings, printed or PDF exported idea space page spans, etc.

Idea Spaces

We’ll go into great detail on how idea spaces work here.

Organizer Documents

Normally the Organizer contains idea spaces, however it can also act as a flexible binder containing any document type. Simply
drag files from the Finder directly to the Organizer to make it available for viewing and editing (if appropriate) within the full bounds
of the Curio window.
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RTF, RTFD, or plain text documents

Upon viewing, the inspector bar will reveal the appropriate font and text controls. As mentioned above, an RTFD document can also
be added via the Add Organizer Item toolbar button.

» Image files. Such as JPEG and PNG.

* PDF files. Upon viewing, the inspector bar will reveal PDF page and annotation controls.

* Web links. Drag them in from your browser, upon viewing, the inspector bar will reveal web surfing controls. Note that Curio
from the Mac App Store does not support viewing remote, insecure nttp links in the Organizer.

+ All other document types. Will be displayed using a Quick Look viewer which will pull in the appropriate plugin as
necessary. For instance, iWork files are displayed so that you can easily browse their contents directly within Curio.

Embed or Alias

By default a copy of the dragged-in file will be embedded into your project. If you hold Command down then the original file with be
removed thus moving the file into your project. If Option is held then an alias to the original file is stored instead.

Important
Please note that some sync servers, like Synology Cloud Station servers, do not support aliases to files so any aliases created
in Curio will break!

Saving Changes

Changes made to editable documents will be saved automatically when you switch to another item in the Organizer or when you
close the project. Renaming the title in the Organizer will rename the underlying file as well, if embedded.

Searching

For Organizer text documents and Organizer web views, pressing $F to will bring up a Find bar so you can search within the
document.

Exporting, Printing, and Presenting

One important note is that these Organizer documents cannot be exported or presented from within Curio. The Organizer is simply
acting as a binder to collect these documents in your project. However, you can right-click on the item in the Organizer to open or
reveal the file in the Finder using the context menu. Curio can selectively print specific Organizer documents via right-click or File >
Print Document. Curio will then launch the documents using the applications appropriate for the selected document types, and
direct those applications to immediately print.

Sections

To reflect a real-world metaphor, if a Curio project is a binder, then a Curio section is a tabbed section within that binder. However,

unlike a real-world section, a Curio section can be arranged into a limitless hierarchy.
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For example, let’s say you have a Curio project called “Biology” for a class in college. You could create the following sections to
organize your project:

Classes
Labs
Papers

For a more complex example, let’s say you are a product manager in charge of “Super Product”. You could create the following
section hierarchy to organize your project:

General Notes
Development
Meetings
Specs
Focus Groups
QA
Meetings
Resources
Marketing
Meetings
Analysis
Sales
Meetings
Data
Support
Meetings
Customer Feedback

An important point to consider is that you can’t print or export multiple sections simultaneously. A section really is like a mini-project
within your overall project. Even child sections are independent of their parents.

You will see the section name in several places within Curio such as the title bar, the Status shelf task list, and the Search shelf’s
result list. You can search within the entire project or just a specific section.

Working with sections listed in the Organizer is just like working with other Organizer items. Thus renaming, deleting, rearranging,
indenting, etc, are managed in the same way.

Important

On very rare occasions, a Recovered ltems section can appear on project load if Curio finds orphaned Organizer items (idea

spaces, folders, documents) in the project’s internal asset library. Generally this only occurs if a project is corrupted perhaps

due to an incomplete cloud sync. You can drag items out of this section into another section so they are no longer orphaned.

Toggle the Display of the Sections Panel of the Organizer:

« Click and hold on the Organizer sidebar toolbar button and choose the Show Sections item in the menu that appears.
« Alternatively you can also Option-click the Organizer sidebar toolbar button to instantly toggle the display of sections.

Create a New Section

+ Use the Add Organizer ltem toolbar button and choose Section, or choose the Organizer > New Section menu, or right-click
in the Sections panel and choose New Section.
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Open a Section

- Click on the section within the Sections panel. The Organizer will refresh itself and display the idea spaces and folders
contained in the selected section.

Moving or Copying Items into a Section

* You can use cut/copy/paste to move Organizer items into a section. You can also drag-and-drop those items into a section,
holding Option down if you wish to create copies. If you release a drag on top of section then the dropped items will be
appended to the end of the section. However, if you pause while hovering over the section then it will automatically open
allowing you to place the dropped items into a specific location within that section’s idea space hierarchy.

Folders

To continue the real-world metaphor started above, if a Curio project is a binder and a Curio section is a tabbed section within that

binder, then a Curio folder is a folder within a section.

So, if a section is a heavyweight division of your project and is displayed in Status and Search results, a folder is extremely
lightweight and is essentially invisible outside of the Organizer.

For example, use a folder to group a series of meeting note idea spaces created on a given day. Or to collect several idea spaces
that reflect rough design drafts.

Clicking on a folder won’t display anything within the idea space view because there’s nothing to display. And, if you click on a
folder to print or export it, Curio will automatically assume you want to print or export the contents of the folder.

Working with sections listed in the Organizer is just like working with other Organizer items. Thus renaming, deleting, rearranging,
indenting, etc, are managed in the same way.

Create a New Folder

+ Use the Add Organizer Item toolbar button and choose Folder, or choose the Organizer > New Folder menu, or right-click in
the Organizer and choose New Folder or New Folder From Selection.

Moving or Copying Items into a Folder

* You can use cut/copy/paste to move idea spaces or other folders into a folder. You can also drag-and-drop those items into
a folder, holding Option down if you wish to create copies.

Trash

When you select and delete any item from the Organizer, including sections, idea spaces, Organizer documents, and folders, they

will be moved to a new Trash section in the Organizer. ltems in the Trash will be automatically discarded when the project is closed.

Important
The Trash will automatically empty when you close your project. It is only a temporary Trash for the current editing session.
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The purpose of this temporary, session Trash is for quick recovery of idea spaces or sections that you may have inadvertently
deleted.

Why Not Undo?

When you delete an item from the Organizer, Curio asks you to confirm the deletion, then deletes the item. This is not an undoable
action because Curio’s undo systems are independently managed by each idea space. That way you can undo actions performed in
one idea space without undoing actions made in another. There is no “global” undo manager. (This is identical to the way Xcode
operates, for those familiar with that app.)

Apple’s Keynote app, on the other hand, offers a single, global undo stack. This means undoing will step you back in time changing
items in the current slide, other slides, plus slide creations, rearrangements, and deletions. It’s all one big undo stack so you can’t
undo only the slide arrangement changes, or only changes to a specific slide, without undoing unrelated actions.

Our Solution

The session Trash is Curio’s solution to this issue. It offers the flexibility of giving the user a way to “undo” a mistaken deletion while
still maintaining independent undo stacks for each idea space.

It is important to note this isn’t an ever-growing Trash, like the Finder’s, that would quickly bloat your project requiring you to
periodically remember to empty it. Nor is it one that automatically deletes items that are more than x days old, as that adds a
number of complexities. For that you might want to learn more about the new Archive section discussed below.

Its purpose is simply for the recovery of Organizer items inadvertently deleted during this session.

Delete Items from the Organizer and Send Them to the Trash

1. Select the items you wish to delete then press the Delete key. Alternatively, you can also drag items directly to the special
Trash section.

2. A confirmation alert will appear so you can confirm the deletion, noting that the selected items and any child items will be
moved to the Trash then permanently deleted when you close the project. In this alert you can choose to move items to the
Archive section instead, which is discussed below.

3. If you confirm the deletion then the items are moved to the Trash and the Trash section icon will become tinted red to
indicate that the Trash now contains items.

Recovering Items from the Trash

1. Open the Trash section either by clicking its icon the sections area or by choosing the Show Trash Section from the
Organizer sidebar toolbar button.

2. Drag items out of the Trash and into any section of your project. While dragging you can hover over a section to jump into
the section for more precise placement within that section’s contents.

Characteristics of Items in the Trash

1. The Search shelf will ignore items in the Trash unless you specifically choose the Trash via the Search shelf’s scope popup.

N

. The Project Library shelf will ignore items in the Trash unless you specifically choose the Trash via the Library shelf’s scope
popup.

. Trashed items are not listed in the Navigator bar’s popup list of project idea spaces.

. Trashed items are not exported or synced along with other project items.

. Trashed items cannot be rearranged, renamed, assigned a color label, or deleted within the section or Organizer areas.

. New Organizer items cannot be created in the Trash.

o O~ W
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What Happens to Iltems in the Trash?

* When you close the project, the project Trash is automatically emptied and everything is sent to the Finder Trash.

Emergency Recovery

* In emergency situations where you’ve deleted idea spaces, confirmed the deletion, and closed the project so the project
Trash is emptied, you can now drag an idea space .curioAsset file from the Finder Trash into the Organizer and Curio will be
able to restore the idea space and any text figures. However, any other asset figures that existed on the idea space, such as
files or images, cannot be restored, as they are not a part of that single .curioAsset file (unless they still exist in the project if
another existing idea space references them), but you can drag them out of the Finder Trash as well if you wish.

Archive

Curio includes a special Archive section which can be used for long term storage of items that you may have been tempted to

delete but want to hold onto just in case.

The Archive is a perfect long term storage place for items you want to keep around, just in case you need to reference them, but
they aren’t active components of your project and therefore don’t need to turn up in searches, exports, etc.

Move ltems to the Archive

1. Right-click on selected Organizer items and choose Move to Archive.
2. Or, drag one or more Organizer items directly to the Archive section.
3. Or, press the Delete key then click the Move to Archive button in the confirmation dialog that appears.

Characteristics of Items in the Archive

1. Archive items are not loaded into memory on project load but only as needed.

2. The Search shelf will ignore items in the Archive unless you specifically choose the Archive via the Search shelf’s scope
popup.

3. The Project Library shelf will ignore items in the Archive unless you specifically choose the Archive via the Library shelf’s
scope popup.

4. Archived items are not listed in the Navigator bar’s popup list of project idea spaces.

5. Archived items are not exported or synced along with other project items

Filter

Filter the items displayed in your project’s Organizer with the filter panel, located at the bottom of the Organizer.

Examples:

* Everything modified in the last 2 weeks: modified last 2 weeks

« Everything with the label Needs Client Approval: #1abel/NeedsClientApproval
* Everything associated with the Important tag: #important

* Everything a title containing the word lecture: 1ecture
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Filter Scope
By default the filter searches only the current section and will refresh the results if you choose a different section. Alternatively you

can use a scope parameter to change the scope to the current section tree ( scope:s/ ) or even the entire project ( scope:/ ).

A more advanced option is to override the default scope for all filters so instead of the current section, it can be the current section

tree or the entire project.

Organizer Filter vs Search Shelf

The Organizer filter panel filters the list of displayed items in the Organizer; the Search shelf is used to search for figures and idea

spaces and presents the results in a list.

Show the Filter

« Click and hold on the Organizer sidebar toolbar button and choose Show Filter, or choose the View > Show Filter item from

the main menu.

Tip

If the filter is not visible, press ~=%F (Edit > Organizer Filter) and the filter will reveal itself, you can do a filter query, then press
~\“¥F to clear and autohide the filter. Otherwise if the filter was already visible then ~“&F simply brings focus to the filter’s
search field.

Cancel the Filter

- If a filter is active then click the little x in the filter search field to clear it.
« Alternatively to clear the filter and hide the filter panel click and hold on the Organizer sidebar toolbar button and choose
Hide Filter, or choose the View > Hide Filter item from the main menu.

Entering Filter Criteria

« Enter your search criteria into the filter search field and press Return.
* You can also use helpful keyboard button next to the query field to choose meta parameters to help build your query
expression.

The Organizer will refresh to display the Organizer items that match your query expression.

Smart Filters

Smart Filters are saved filter queries that you can create.

They are displayed within the filter panel under the filter query. You can resize the filter panel if necessary to reveal any Smart Filters.
These Smart Filters are dynamic, constantly updating themselves as you work in your project.

Alongside each Smart Filter is the count of found items, allowing you to see at a glance how many idea spaces are labeled Hot
( #1apel/not ), or tagged Urgent ( #urgent ), or modified in the last week ( modified 1ast 1w ). With a quick click you can view those

results and jump to specific idea spaces.
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Smart Filters

Smart Filters are displayed in sorted groups in this order: project-specific filters, global filters, and then bundled filters. An exception
is made for the Pinned bundled Smart Filter which is always displayed at the very top.

Creating a Smart Filter

1. Enter your a filter query as described above and perform the search.
2. Click the + button alongside the query field to save the current filter as a Smart Filter. Give it a name and choose whether this
Smart Filter is only for this project, or if it should be made available in all projects.

The filter panel will expand vertically, if necessary, to reveal your Smart Filters.
You will note that the color of the icon alongside each Smart Filter indicates if it is a project, global, or bundled Smart Filter.

Optionally, you can intermix all the Smart Filters together, or hide the bundled Smart Filters.

Revealing Smart Filters

» The Smart Filters are in the filter panel. If you can’t see the filter panel click and hold on the Organizer sidebar toolbar button
and choose Show Filter, or choose the View > Show Filter item from the main menu.
* You can resize the filter panel upwards by dragging on its splitter to reveal the scrollable list of Smart Filters.

Using a Smart Filter

« Click a Smart Filter to make it the active filter, automatically filtering and refreshing the contents of the Organizer based on its
query parameters.

Canceling a Smart Filter

« Click the little x in the filter search field to clear it.
« Alternatively to clear the filter and hide the filter panel click and hold on the Organizer sidebar toolbar button and choose
Hide Filter, or choose the View > Hide Filter item from the main menu.

Editing a Smart Filter

+ Double-click a Smart Filter to edit its title, query expression, or project vs. global setting.

Deleting a Smart Filter

+ Select a Smart Filter and press the Delete key to delete it.

Pinned Smart Filter

Curio includes a Pinned Smart Filter (with a #meta/pinned query) which is always displayed at the very top of the list of Smart
Filters so you can quickly see and access your pinned idea spaces and other Organizer items. You can pin an item in the Organizer
via the right-click context menu.

By default the Pinned Smart Filter only searches the current section, however, you can make it show all pinned items in the entire
project if you wish.
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Navigation Controls

Navigation Controls

At the far right corner of the inspector bar you’ll find a series of navigation controls to help you move around your project and

manage what you see in the main content area of the window.

The Splitter Button

« The splitter button is used to open up or close the secondary idea space split view. Option-click on this button to switch the
secondary view between the side-by-side and above-below layouts

The Bookmarks Button

1. The bookmarks popup button can be used to create bookmarks to easily jump to points within your project. You can either
create a bookmark to an Organizer item such as an idea space, or you can create a bookmark figure. A bookmark figure is a
positionable figure which is placed into the current idea space and is useful if you want to mark a specific location within an
idea space.

2. Both bookmarks and bookmark figures can be named and assigned one of eight colors for quick identification. All
bookmarks are listed in the bookmarks popup in the navigator bar and can either be sorted by name or color

3. To jump to a bookmark or a bookmark figure simply select the item in the bookmarks popup.

4. Option-clicking a bookmark figure’s adornment will cycle through the available bookmark colors.

5. To remove a bookmark, choose Remove Bookmark from the bookmarks menu. To remove a bookmark figure, select it on the
idea space and press Delete.

The Navigator Button

» The navigator is a popup display showing the complete hierarchy of the current section or project so you can select and
instantly jump to another Organizer item. In many cases you can leave the Organizer hidden and simply use the Navigator
popup instead.

The Back/Forward Buttons

» The back/forward buttons are available to move back in history, to the idea space or Organizer item you were recently
viewing, or forward in history. Just like a browser’s back/forward buttons. You can also hold Option while swiping left/right
with your mouse or trackpad.

The Previous/Next Buttons

1. The previous/next buttons are available to move to the previous or next item in the Organizer. You can also swipe left/right
with your mouse or trackpad.

2. If you hold Command down then the buttons change to indicate that clicking will move you to the first or last item in the
Organizer.
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Inspector

To view the inspector panel for the selected Organizer item, make sure a figure on the idea space isn’t selected (click on the

background of the current idea space if necessary) then either:

« Click an appropriate icon in the inspector bar, or
« Click the Inspector toolbar button to open the inspector shelf.

Tags

You can associate one or more tags with your Organizer items using the Tags inspector panel. Note you can also assign tags by
right-clicking on an Organizer item and choosing one from the Tags submenu.

Working with the tags inspector for Organizer items is identical to the figure tags inspector.
After assigning tags to your Organizer items you may want to learn more about:

+ The Organizer Meta Flags Column allows you to easily see which items have associated image tags.

» The Organizer filter and Smart Filters which can be used to keep track of Organizer items that are associated with specific

tags.

Labels

A colored label can be associated with your Organizer items, akin to the Finder’s color tags.

You can use the Label inspector to make the label association but also customize the global color and text associated with that
label.

When an item is labeled, the preview or icon displayed in the Organizer displays a border using the label color. This allows you to
visually flag certain idea spaces, sections, or folders.

After assigning tags to your Organizer items you may want to learn more about:

* The Organizer Meta Flags Column allows you to easily see which items have color labels.

+ The Organizer filter and Smart Filters which can be used to keep track of Organizer items that are associated with specific

labels.

Assigning Labels

+ Click on a label row to set the selected Organizer item to that label. A checkmark will appear next to the label associated
with the selected Organizer item. You can also assign a label by right-clicking on an Organizer item and choosing one from
the Labels submenu.

Changing Label Color

« Click on the label color well to change the color.
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Changing Label Text

* Double-click on the label text to change the text.

Defaults

+ Click “Copy to Defaults” to make these labels the new global defaults.
» Click “Restore Defaults” to restore this project’s labels using the global settings.

Notes

To view the notes associated with the selected Organizer item or figure click the Notes button in the inspector bar.

The notes inspector allows you to enter miscellaneous notes that will be associated with the selected item.

Entering a Note

The notes inspector window allows you to enter any rich text, with full support for multiple fonts, sizes, colors, paragraph formatting,
and even images.

Note Adornment

When a note is associated with a figure then a little note adornment is displayed next to the figure. If you click the adornment, the
notes inspector window will appear allowing you to change notes. If you remove all the contents of the note then the note is deleted
entirely and the adornment is removed.

Searching Notes

For figures, notes are searched when using the Search shelf. For Organizer items, notes are searched when using the filter.

Printing Figure Notes

You can print the notes associated with the selected figure via the File > Share menu or Share toolbar button. Note the Include
Figure Notes When Copying/Sharing Text item in the Share menu which is useful when you want to include notes with copied or
exported figures.

Info

To view info associated with the selected Organizer item or figure click the Info button in the inspector bar.

Organizer items and figures can have various miscellaneous bits of info that Curio collections under the info inspector.

Title

View and edit the title of the selected Organizer item or asset figure.
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Identifier

A identifier that you can assign to the item. This field has a few use cases:

« Curio Professional’s Master Templates feature uses this identifier to map between figures when changing master templates.

« If a text figure has an identifier of (21deaspaceritie} then the figure’s content and the idea space’s title in the Organizer will
automatically stay in sync regardless of which one you change.

Filename and Location

If the item has an underlying file then its name and location appears here.

If an asset file is embedded within the project then renaming an asset figure here will rename the underlying asset file.

Date Stats

View the date the item was created, added to Curio, and last modified.

Action Button

The action button allows you open or reveal the underlying asset file using the Finder. If the asset is an alias then you can choose to
convert the asset into an embed asset by copying the original file into the project’s internal asset library. You can also choose to
swap the underlying file with a new file which you will choose using a standard Mac open dialog.

Custom Organizer Icon

You can change the icon displayed for items in the Organizer. Simply paste or drag in an image into the image control, or choose an
emoji by clicking the character palette button and double-clicking on an appropriate emoji.

Emoji characters are stored as PDF images so can be resized perfectly to any Organizer preview size.

When dragging in your own images, PDF images are best as they can be perfectly scaled. Next PNG’s are a good choice as they
support transparency. Lastly JPEG images can be used although they are best if they fill the entire image area as JPEG’s don’t
support transparently so are entirely opaque.

Advanced Options

An advanced option is whether the underlying file is copied or shared when the asset figure is copied. Normally Curio will share the
underlying file thus you can have ten references or instances of a giant Photoshop image file scatter throughout your project, but the
underlying file will exist only once within the asset library.

On the other hand, you could specify that when the figure is copied then a unique copy of the underlying file should also be made,
thus you’d end up with ten separate copies of the Photoshop file stored internally.

Restrictions
Specify restrictions such as whether a folder, idea space, or figure is printed, exported, or presented.
Restrictions are automatically inherited by the children of Organizer folders and idea spaces.

For example, say you have an Organizer folder with the “exporting allowed” checkbox unchecked. Any idea spaces or folders
hierarchically contained within that folder will automatically inherit that restriction as well. And, since they inherit that restriction, and
cannot override it, the restriction checkbox is disabled in their Info inspector.
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As another example, if you have an idea space with a “no presenting” restriction, then any child idea spaces hierarchically under

that idea space will also be skipped when presenting.
This makes it very easy to quickly restrict or un-restrict an entire hierarchy of items just by nesting the items appropriately.

Image Text Recognition

Curio uses Apple’s Vision framework ( vnrecognizeTextrequest )to automatically scan imported image assets for text (aka OCR)
which can then be searched for using Quick Find or the Search shelf.

This area of the Info inspector allows you to see what words were recognized from the underlying asset image. You can also use the
actions button to choose a different language for detection if the wrong one was selected by default. A Rescan button can be used

to then rescan the image for text.

Curio will remember the selected language as the preferred language for future automatic scans when images are added to an idea

space.
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The Idea Space

The Idea Space

The Curio idea space is the most flexible and magical notebook page you’ve ever used. Idea spaces are wonderfully freeform and
allow you to place anything anywhere on the page.

Terminology

An idea space is just a blank canvas. Like a giant whiteboard, you can write or draw anything anywhere within an idea space.
However, unlike a whiteboard, you can also add images, documents, web links, movies, sounds, contacts, mail messages, and
calendar events.

The key feature is the amazing, freeform environment supported by Curio’s idea spaces. An idea space can be as structured or
messy as you wish emphasizing that it’s your project notebook and it can look exactly the way you like it.

An idea space style defines just the look of the idea space. You can apply a style to a new or existing idea space. The style
includes color and grid information, for example, but does not include boilerplate text or other figure elements.

On the other hand, an idea space template is a re-usable idea space that defines the look and includes boilerplate figure elements,
such as text figures, collections, and images. You cannot apply a template to an existing idea space, as that would wipe out your
existing figures. When you use a template you are creating a copy of that original template.

If you change or update the original style or template Curio does not change any instances either in the current project or in projects
stored on your hard disk. The change will only be reflected in new instances that you create or apply in the future. However, Curio
Professional users have access to master styles and master templates that allow this functionality which we discuss here.

Working with Idea Spaces

Since an idea space is simply an item in the Organizer, see that section in the Documentation for more information on adding,

deleting, and managing idea spaces in the Organizer.

Idea Space Gallery

The idea space gallery shows all your bundled, personal, and master (if Pro) idea space styles and templates.

Show the Idea Space Gallery

1. Click the Add button on the toolbar then choose Idea Space Gallery, or choose the Organizer > New Idea Space From
Gallery menu item.

2. On the left you can see your bundled and personal repositories of styles and templates, plus master styles and templates if
you’re running Curio Professional.

3. On the right Curio shows the styles or templates that are in the selected repository.

See below on managing styles and templates within the gallery.
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Idea Space Styles

You can easily create new idea space styles containing its background color, texture, and notepaper or grid settings.

Create a New Personal Idea Space Style

1. Click on an idea space in the Organizer.

2. Configure its attributes how you want them using its inspectors. For example, change the background color, grid settings,
etc.

3. Right-click on the idea space in the Organizer or on the idea space background then choose “Save As Idea Space Style”.
Alternatively, you can also do this by choosing the Organizer > Save As Idea Space Style menu item.

4. In the dialog that appears give the style a name. If you save a style with the same name as an existing style then it will simply
be replaced.

5. If you then make more changes to the idea space you can right-click and choose Update Style or you can create a new style

if you wish.

Apply a Style to an Existing Idea Space

1. Select an idea space in the Organizer to open it.
2. Click the style button in the far left side of the the inspector bar to see the style gallery, or choose a style from the inspector
shelf, or right-click on the idea space background and choose Apply Idea Space Style to bring up style gallery.

Create a Brand New Idea Space Based on an Existing Style

1. Click the Add Organizer ltem toolbar button then choose Idea Space Gallery.
2. Choose a style from the gallery window that appears.

Managing Idea Space Styles Within the Idea Space Gallery

1. Copy a style simply by drag-and-dropping it into your Personal or, for Professional users, their Master repository.
2. Delete a personal or master style by selecting the style and pressing the Delete key.
3. Share or copy a personal or master style via the right-click context menu.

ldea Space Templates

Curio users can easily create new idea space templates containing not only its look but also placeholder or boilerplate items such

as text figures, mind maps, lists, and images. You can create new idea spaces based on a template.

Create a New Idea Space Template

1. Click on an idea space in the Organizer which you would like to copy as a template.

2. Right-click on the idea space in the Organizer or on the idea space background then choose “Save As Idea Space
Template”. Alternatively, you can also do this by choosing the Organizer > Save As Idea Space Template menu item.

3. In the dialog that appears give the template a name.

Create a Brand New Idea Space Based on an Existing Template

1. Click the Add Organizer ltem toolbar button then choose Idea Space Gallery.
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2. Choose a template from the gallery window that appears.

Managing Idea Space Templates in the Idea Space Gallery

1. Create personal template tags by right-clicking in the Personal area in the repositories list on the left and choosing “Add
Tag”. These tags are unique to the idea space templates repository and won’t conflict with tags created for figures in the
stencils repository, for example.

2. Organize your personal templates by drag-and-dropping them into different tags. A template can be associated with more
than one tag. So, a template can be in your “Favorites” and “Work” tagged collections.

3. Curio Professional users will also see their project’s master repository of templates.

4. You can also associate or disassociate a personal template with a tag by right-clicking on the template and choosing a tag in
the menu that appears.
5. Rename a personal or master template tag by double-clicking it and entering a new name.
6. Delete a personal or master template tag by selecting it and pressing the Delete key.
7. Copy a template from another repository simply by drag-and-dropping it into your personal or master collection.
8. Edit a personal or master template by right-clicking on the template and choosing Edit Template.
9. Delete a personal or master template by selecting the template and pressing the Delete key.
10. Share a personal or master template by right-clicking on the template and choosing Send to Friend or Send to Zengobi.

Default Idea Space

Using the idea space gallery you can specify a default idea space template or style to use in the current project, this project’s

Journal, or as a global default for any project or any project’s Journal.

Setting a Default Idea Space

1. Reveal the Idea Space Gallery via the Add toolbar button or Organizer > New ldea Space From Gallery menu item.

2. In the gallery, right-click a template or style and choose Set as Default Idea Space to set it as the new default for the project
or, if the Journal section is active, this project’s Journal. You can also specify if this should be the default just for this project,
or if it’s the global default for all projects.

Note that a master style or template can’t be a global default for all projects because a master only exists within a project so other
projects can’t see it.

Once a default idea space is set

* The current default style or template’s title will be shown in italics within the gallery.

+ A special item is added at the top of the Add popover and the Organizer’s right-click context menu, allowing you to quickly
add the default idea space or Journal entry to your Organizer.

» The Add toolbar button changes so Option-clicking it will now add a new idea space based on the default template or style
instead of adding a blank idea space.

Once a global default idea space is set

« Creating a new project will automatically add that as the first initial idea space instead of a blank one.

Once a Journal default idea space is set

« Clicking on the Journal’s Go to Today inspector bar button will go to today and create a new entry with the default style.
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Reset the Default Idea Space

To reset the default, right-click on any style or template and choose Set as Default Idea Space then click the Reset Default button.

If the make global checkbox is checked then it is cleared within the global preferences file.

Zooming

Curio has many way to zoom in and out of the idea space.

With the Zoom Popup

« The default toolbar has a zoom popup which you can use to pick a specific zoom level.

With the Zoom Slider

1. Right-click and customize the toolbar to add the zoom slider.
2. Double-clicking or Option-clicking the slider will zoom to Actual Size.
3. While hovering over the slider use the scroll area of your mouse to zoom.

With the Menu Bar

1. The View menu offers several menu items with keyboard shortcuts to control idea space zoom.

2. If you hold down the Option key and then click the View menu you’ll notice that Zoom to Fit, Zoom to Width, and Actual Size
dynamically change to Zoom All to Fit, Zoom All to Width, and Zoom All to Actual Size, respectively, so you can easily
change the zoom of all your idea spaces in the current section.

With a Mouse

« Zoom with the mouse by pressing and holding the Option-Command key and then scrolling your mouse or trackpad up and
down over the idea space area.

With a Trackpad

+ Use the standard pinch gesture.

Via Smart Zoom

Smart Zoom is a feature supported by macOS, if enabled via System Settings > Mouse/Trackpad > Point & Click > Smart Zoom.
Double-tap on your mouse or trackpad to zoom. Then double-tap again to restore the zoom.

By default, Curio will Smart Zoom to the figure you’re hovering over, else the point you’re hovering over, similar to how Smart Zoom

works in Safari.

This can be customized in advanced settings.

With the Keyboard

1. Like Photoshop, you can press the Spacebar and Command keys simultaneously and then click the mouse to zoom in.
2. To zoom out, press the Spacebar and Option keys simultaneously and then click the mouse to decrease the zoom level.
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3. The pointer will change to a magnifying glass with either a plus sign or a minus sign to indicate whether you’re increasing or
decreasing the zoom level.

Quick Zoom

1. You can also quickly zoom to fit the idea space within the view by holding down the Q key.
2. When you release the Q key, the view will return to its previous zoom level centered where the mouse was last positioned.
3. This mechanism provides a quick way to navigate a large idea space.

Similarly you can temporarily zoom in for a quick close-up of content under your mouse pointer:

1. Hover your mouse pointer over the figure you want to zoom into then hold down the Shift-Q key combination.
2. When you release that combination, the view will return to its previous zoom level.

Gestures

The following gestures can be performed on a trackpad:

* Pinch/expand zooms the idea space (as does ~“#Scroll with mouse or trackpad).

« If not currently at Actual Size then a double-tap on your Magic Mouse or a 2-finger double-tap on a trackpad will zoom to
Actual Size. Otherwise, if already Actual Size, that double-tap will zoom such that the current contents of the idea space fill
the display, subtracting out any blank whitespace and centering the view on those contents. Note that you have to have
Smart Zoom enabled in your System Settings Mouse and/or Trackpad settings.

« 3-finger swipe up/down goes to the previous/next Organizer item.

« 3-finger swipe left/right goes backwards/forwards in history.

Note that you’ll need to make a change in System Settings > Trackpad > More Gestures so that Curio can actually receive 3-finger
swipes, otherwise the Mac’s system receives them instead.

Inserting Space

In addition to the Dimensions inspector, described below, you can quickly add space to your idea space.

Insert Space to the Bottom or to the Right of the Idea Space

+ With no figures selected choose either “Space at Bottom of Idea Space” or “Space to the Right of Idea Space” from the
Insert menu.

Insert Space Below or to the Right of the Selected Figures

1. Select one or more figures then choose either “Space Below Selected Figures” or “Space to the Right of Selected Figures”
from the Insert menu.

2. With these options, Curio will add some space to the bottom or right side of the selected figures pushing all figures on the
idea space that are located below or to the right of the selected figures. This is useful when you want to add a big gap in the
middle of a complex idea space, scooting everything down starting at this location
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Insert Space Directly Below or to the Right of the Selected Figures

1. Select one or more figures then while holding the Shift key choose either “Space Directly Below Selected Figures” or “Space
Directly to the Right of Selected Figures” from the Insert menu.

2. Now Curio will add some space to the bottom or right side of the selected figures pushing only those figures directly affected
(recursively) by moving the selected figures below or to the right of the selected figures. For example, if you just want to
scoot figures directly below the selected figures down, leaving figures to the sides as-is, then hold down Shift and choose
the menu item.

Inspector

To view the inspector panel for the selected idea space, make sure a figure on the idea space isn’t selected (click on the

background of the current idea space if necessary) then either:

« Click an appropriate icon in the inspector bar, or
» Click the Inspector toolbar button to open the inspector shelf.

Background

To change the background properties of the selected idea space either click the Background button on the inspector bar, or see the
Background tab in the inspector shelf.

Style

From a simple white background, to a piece of notebook or grid paper, to a colorful textured backdrop, you can completely
customize the look of your idea space. You can even save these looks as personal styles to use them again and again.

At the far left of inspector bar you’ll find a Style button which displays a quick, popup gallery for the current idea space. Simply click
on a style to update the look of your idea space.

You can also use the mini style gallery at the top of the inspector shelf to do the same thing. And, lastly, you can right-click on an
idea space and choose Apply Style to choose a style from the gallery that appears.

All of these interfaces give you an opportunity to choose either a bundled or personal style that you have created. Curio Professional
users can also select a master style.
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Color

Set the fill color with the Solid, Gradient, or Radial gradient button.

« For solid fills, click on the color well to choose a color from the matrix that appears. Or, Option-click on the color well to go
directly to the standard color chooser.

« For linear gradient fills, drag the color stops to adjust the gradient ramping. Double-click on a color stop to edit its color.
Double-click on the gradient to insert a new color stop. Drag a color stop down and off the gradient control to remove the
stop from the gradient. The resulting gradient will be rendered along the angle specified by the angle slider.

« For radial gradient fills, drag the color stops to adjust the gradient ramping. Double-click on a color stop to edit its color.
Double-click on the gradient to insert a new color stop. Drag a color stop down and off the gradient control to remove the
stop from the gradient. The resulting gradient will be rendered with a center point located as specified in the point locator
control.

You can change the color used to display page breaks by clicking on the page break color well and choosing a new color. To show
page breaks, choose View > Show Page Breaks.

Image

Paste or drop an image into the image control or choose an image or texture from the image collection browser. Curio includes
several bundled textures, or select a custom folder for Curio to search for images.

You can adjust the opacity of the selected background image using the opacity slider. That way the image can appear on top of a
solid or gradient background color.

You can also change the way the background image is scaled. You can choose to have the image tiled over the whole idea space,
centered within each page of idea space, or stretched to fit each page of the idea space either proportionally or not.

Grid
Your idea spaces can have visible (or hidden) lined or dotted grids. Adjust the spacing and colors of the major and minor grid lines
or dots. You can also independently toggle the visibility and snapping of the vertical and horizontal grid lines.

Transitions

For Curio Professional customers, via the Curio > Settings window you can specify a default transition to use when stepping
through idea spaces during presentation mode.

However, this can be customized for a specific idea space if you wish using the transition inspector.

Choose the type of transition you’d like to use, or none if you don’t want any animation between slides. Your choices include
Apple’s standard Core Animation transitions.

Once you choose the type the available transitions will be displayed so you can choose the desired transition.

Dimensions

The idea space dimension inspector allows you to set the size of the idea space and control whether the idea space can

automatically adjust its size for its content.
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Orientation

By default the portrait versus landscape orientation for the idea space is inherited from the setting specified in the Page Setup
dialog. This orientation is used when printing or exporting to PDF. You can override the default and force either portrait or landscape.

Margins

The margins button will bring you to the project inspector so you can specify the margins used on your idea spaces when printing or
exporting to PDF. These margins are global for all idea spaces in the project.

Units

At the top you can choose the units used to display the dimensions. You can choose either points, printed pages, or screens.

Width and Height

Enter a width and height and, when you press Return, they will immediately take effect.

You can also use the stepper control next to each field to increase or decrease the value. The stepper generally moves in increments
of 1 but, if the units are set to points, you can hold Option to increment by 10, or hold Option+Shift to increment by 100.

Click Resize to Contents to reduce the size of the idea space to its minimum values based on the content currently displayed in the
idea space. This calculation takes into consideration the chosen unit of measurement. For example, if you choose Pages as your
unit of measurement, then Shrink to Minimum will reduce the idea space to the fewest whole number of pages required to display
the current content.

If an idea space is set to automatically grow in size, then as content is placed beyond the current borders of the idea space, it will
automatically grow to accommodate it. If you do not wish for the idea space to grow automatically then set both the vertical and
horizontal popups to Manually.

A small warning icon will appear next to the width or height field if your idea space is very large — more than 7200 points by default,
which is over 100 inches at 72dpi. This is just a subtle warning to remind you that you can spread your work across idea spaces
instead of filling a single idea space. While there’s no hardcoded limit to the size of an idea space, very large idea spaces can be
slow to render or work with depending on the content and your machine hardware.

Defaults

Click Restore Defaults to reset the current dimensions to their default settings. Click Copy to Defaults to save the current
dimensions and automatic resizing options as your new defaults for future idea spaces in this project and other projects.
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Figures

In Curio, anything placed on an idea space is a figure. It can represent a basic flowcharting shape such as a square or octagon. Or
more complex items such as text, images, web links, movies, music, or any type of document. A figure can also represent a
collection of contained figures. For example, a mind map or a list outline.

With any type of figure, not only can you specify its look through fonts and colors, you can also specify meta information such as
tags, and start/due dates.

Terminology

A figure is the most basic entity within Curio such as a text figure, an image figure, a document asset figure, and a line figure.

A collection figure is a special type of figure that contains, manages, and positions figures within it. Examples include Curio’s list,
mind map, table, index card, pinboard, and album collection figures. While a collection figure can contain other figures it cannot
contain another collection. For example, you can’t place a table into a mind map or an index card into a list.

A figure style defines the look of the figure including properties such as color, border, font, and shading. You can apply a style to a
new or existing figure.

On the other hand, a figure stencil is a re-usable figure that can includes richer data such as placeholder or boilerplate text. You
create a copy of a stencil.

A simple figure stencil is a stencil that is a single figure. Even if that figure itself is a collection figure such as a mind map or list it
and therefore contains figures within it, the collection figure itself is just a single figure, thus it is a simple figure stencil.

A complex figure stencil is a stencil made up of multiple figures. A perfect example is a landscaping stencil where flowers, shrubs,
and trees are represented by individual figures, images, or grouped figures.

If you change or update the original style or stencil Curio does not change any instances either in the current project or in projects
stored on your hard disk. The change will only be reflected in new instances that you create or apply in the future. However, Curio
Professional users have access to master styles and master stencils that allow this functionality which we’ll discuss here.

Selection Glow Colors

Figures will glow when selected:

* Blue: A normal figure.
* Gray: A locked figure.
+ Purple: An original figure which has synced figure instances elsewhere in the project.

* Pink: A synced figure instance of an original figure.

+ Green: A figure which has a local identifier.

* Orange: A leading figure.
* Yellow: A following figure or a bundle figure.
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Insert Popover

The insert popover can appear in one of two ways:

1. Click the Insert toolbar button.
2. Pressthe i key on your keyboard.

In the popover that appears Curio shows you all the types of figures you can insert into your idea space.

You can select an item with the mouse or trackpad, or use the arrow keys to move around, or press the first letter of the item such
as m for mind maps (note that some items have different key shortcuts, like Stack = x , due to conflicts with other entries).

Basic Shapes

A gallery appears showing off many of the basic figure shapes that can be inserted including simple text figures, lines, and various
geometric shapes.

Clicking an item will insert a shape of that style into the idea space.

Double-click the resulting text or geometric figure to add text.

Styled Shape or Stencil

A gallery appears with all figure styles and stencils available within your personal repository, Curio’s bundled repository, and any
shared repositories you have configured in Settings.

Double-clicking a style or simple stencil will insert that figure into your idea space, or you can select the item and click the Insert
button.

Complex Stencils
Complex stencils, which are stencils that contains multiple figures, are displayed in the gallery with the number of figures it contains

in parentheses.

Selecting a complex stencil and clicking the Insert button will insert the entire stencil into your idea space. However, double-clicking
will drill down into the stencil so you can choose a specific figure within the stencil to insert. You can click the Back button to come
back out.

For example, say you have a landscaping complex stencil with figures for various types of trees, plants, and hardscape. You can
insert the entire stencil where all of the figures are inserted, or you can double-click and drill down to choose a specific tree figure to
insert.

Stencils Library

If you’re a frequent user of figure stencils you should definitely check out the Stencils Library shelf module.
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List / Mind Map / Table / Index Card / Album / Pinboard

List / Mind Map / Table / Index Card / Album / Pinboard

These are all of Curio collection figures which we go into great detail here.

A gallery appears with all appropriate styles and stencils available within your personal repository, Curio’s bundled repository, and
any shared repositories you have configured in Settings.

Clicking an item will insert that figure into your idea space.

These specific Insert choices have a sneaky feature. If, in the list that appears when you click the Insert toolbar button, you click on
the icon next to the item name (like “List” or “Mind Map”) then Curio will instantly insert the appropriate collection with its default
styling without showing the gallery.

Note that your toolbar can also have a dedicated button for a specific collection type. For instance, a List button that brings you
instantly to the List gallery. Right-click on the toolbar and choose Customize to add or remove these toolbar buttons.

Audio Recording

A panel appears where you can configure the audio input and check the audio input level.
Click the Insert button to begin recording.

To stop and play the recording use the media controls in the inspector bar.

Video Recording

A panel appears where you can configure the audio and video inputs and check the audio input level.
Click the Insert button to begin recording.

While recording a floating video preview window will appear so you can see what is being recorded. You can position or close that
preview window. Curio will restore the last-saved preview position the next time you record.

To stop and play the recording use the media controls in the inspector bar.

YouTube / Vimeo Video

A panel appears where you can paste in the URL to a YouTube or Vimeo video (such as https://www.youtube.com/watch?
v=NQ7kqwbaqeil or https://vimeo.com/35396305) and then click Insert.

Curio will then parse the URL to extract out the actual movie name then turn it into an embed URL. A web view with a nice default
size is then created, the embed URL is set, and the resulting web view is placed on your idea space ready for viewing.

Note
For faster embedded videos, simply drag-and-drop a YouTube or Vimeo URL from your browser directly to the Curio idea
space and Curio can instantly turn that into an embedded video figure.
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YouTube Start/End Parameters

This YouTube video insertion feature supports mapping various flavors of YouTube URL start time parameters, like t=60 or t=60s ,
to a valid embedded URL start= parameter, like start=60 . You can edit the URL in the inspector bar and manually add an end
time if you wish with the ena= parameter where you specify the seconds value when playback should stop.

Resizing and Moving
You can resize the resulting embedded video by dragging on the figure’s selection handles. The figure will resize proportionally

maintaining the video’s aspect ratio.

Since clicks within the video bounds are processed by the embedded video controller, it’s a bit tricky to move the figure, so here are
some tips:

* You can move the video if you click and drag on the very edge of the frame, or
» First click Stop Playing in the inspector bar, which deactivates the embedded playback control, and then you can click and
drag from anywhere in the figure bounds. Click Start Playing or double-click the figure to activate the video player again.

Instant Document

A panel appears where you can choose a personal or bundled instant document for inserting. An instant document is a blank or
boilerplate document for another application that you can create and install within Curio. Examples include Word documents,
OmniGraffle diagrams, or Photoshop drawings. See more details below.

Equation

An equation editor appears so you can enter your equation using either LaTeX, AsciiMath, or MathML and see an instant, real-time
preview. Pressing the Insert button places a high-resolution, resizable PDF rendering of the equation on your idea space or into a
currently editing text figure as an inline equation.

Web View

A new web view is instantly inserted into your idea space. Use the controls on the inspector bar to surf within the web view, and to
specify and save a specific URL for the new web view.

Sign In Via Passkeys

Unfortunately passkeys aren’t supported in web views (an Apple WKWebView limitation), so you have to use a password to gain
access to any service. Lots of developers are hoping Apple adds support for passkeys to web views one day soon.

Resizing and Moving

You can resize the resulting embedded web view by dragging on the figure’s selection handles. The figure will resize proportionally
maintaining the video’s aspect ratio.
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Since clicks within the web view bounds are processed by the embedded web content, it’s a bit tricky to move the figure, so here
are some tips:

+ You can move the web view if you click and drag on the very edge of the frame, or

« First click Stop Browsing in the inspector bar, which deactivates the embedded web view control, and then you can click and
drag from anywhere in the figure bounds. Click Start Browsing or double-click the figure to activate the web view control
again.

Google Doc

A new web view is instantly inserted into your idea space going directly to the Google Docs web URL. Use the web surfing inspector
bar to specify and save a specific URL if you wish to point to a specific document within Google Docs.

See above for tips on resizing and moving this web view control.

Note
Google is making it a bit more difficult to embed Google docs web views so please see some of the advanced settings you

may need to change depending on what Google web apps you’d like to use.

Date and Time

A panel appears where you can choose a pre-formatted date and time. The selected item will appear as a new text figure or inserted
into an existing text figure being edited.

Variable

A panel appears where you can choose a special variable which will be dynamically filled out by Curio. For instance, you can insert
a variable for the current project name, idea space name, and its last modified date and time. A variable can be inserted as a new
text figure or into an existing text figure being edited.

The resulting variable looks like (s1deaspaceTitle} in your text.

Note
Curio Professional customers can create their own custom variables!

Optional Date Styles

You can optionally append one of the following styles to the date and time related variables:

* Short

* Medium
* Long

« Full

+ 1SO8601
+ RFC3339
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Variable

The first few correspond to the Short, Medium, Long, and Full styles found in the Dates and Times tabs in System Settings >
Language & Region > Advanced.

ISO 8601 is a standard date and time format which includes time zone information, such as 2021-12-25115:00:00-0500 indicating
the -5 hour EST offset from GMT.

RFC 3339 is similar to ISO 8601 but with GMT/Zulu times such as 2021-12-25120:00:00z , S0 it adds 5 hours to our EST example to
bring it up to GMT/Zulu.

Some examples:

* {%IdeaSpaceDateAddedShort} — 1/25/22

* {%IdeaSpaceDateAddedMedium} — Jan 25, 2022

* {%IdeaSpaceDateAddedLong} — January 25, 2022

* {%IdeaSpaceDateAddedFull} — Tuesday, January 25, 2022

* {%IdeaSpaceDateAddedIsoss01l} — 2022-01-25

Dates With Time

The various date-related variables can include the phrase witnhrime before the style and the date will include the time in the
resulting output.

So, instead of using the separate (sprojectpatecreatedvedium} date and (sprojectTimeCreatedMedium} time variables, you can

just say (sProjectDateCreatedwithTimeMedium} .
Some examples:

* {%IdeaSpaceDateAddedWithTimeLong} — January 25, 2022 at 2:45:24 PM
* {%FigureStartDateWithTimeIS08601} — 2021-12-25T20:12:45-05:00

Custom Format

Curio has basic support for custom date formatting via a rormat: style with a specified date pattern.
For example:

* {%ProjectDateCreatedFormat:yyyy-MM-dd'T'HH:mm:ssZ} — 2021-11-16T18:51:41-0500

Optional Casing

You can optionally append one of the following casing extras to the variable preceded by a / symbol:

* uppercase
* lowercase
* capitalize

For example, (%1deaspaceTitle/uppercase} mMmight resultin umy 1TINERARY .
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All Variables

Project Variables

* {%ProjectTitle}

* {%ProjectURL} -a curio:// hyperlink to the project
* {%ProjectFilePath}

* {%ProjectDateCreated}

®* {%ProjectTimeCreated}

* {%ProjectDateSaved}

* {%ProjectTimeSaved}
Section Variables

* {%sectionTitle} - the immediate section which owns this item
* {%RootSectionTitle} - the root, top-most section which owns this item

Folder Variables

* (sFolderTitle} -the immediate folder which owns this item
* (%RootFolderTitle} - the root, top-most folder which owns this item

Organizer Hierarchy Variables

Variable

* (scontainerTitle} - the title of the parent containing item that contains the current idea space. This could be a parent idea

space, a containing folder, or the current section. If the current section is simply the default section and no other sections

exist then the title of the project itself will be output.

Idea Space Variables

®* {%IdeaSpaceTitle}

* {(%IdeaspaceURL} -a curio:// hyperlink to the idea space
* {%IdeaSpaceDateAdded}

* {%IdeaSpaceTimeAdded}

* {%IdeaSpaceDateModified}

* {%IdeaSpaceTimeModified}

* {sJournalSubtitle} - inserts a Journal entry’s custom subtitle
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List/Mind Map/Table From File

Figure Variables

* {%FigureURL}

* ({%FigureDateAdded}

* {%FigureTimeAdded}

* {%FigureDateModified}

* {%FigureTimeModified}

* {%FigureStartDate}

* ({%FigureDueDate}

* ({%FigureDoneDate}

* (sFigureTagName} - replaced with the name of the tag associated with a figure, ex: a Stack figure title which dynamically
changes based on what tag is associated with the title figure

* (sFigureTagNames} - replaced with a comma separated list of all the associated tags (remove tag set prefix, remove spaces)

®* {%FigurePercentComplete}

* {%FigureCustomData} OF {%FigureCustomData:KeyName} - See Custom Data Variables for details

* {%FigureCustomDataDelimited}
Container Figure Variables

* {%ContainerFigureltemCount} - replaced with the number of items in the collection figure
* {%ContainerFigureDateModified}

* {%ContainerFigureTimeModified}
Asset Variables

* {%AssetDateCreated}
®* {%AssetTimeCreated}
* {%AssetDateModified}

* {%AssetTimeModified}
Other Variables

+ Use the Info inspector to give a figure an identifier of {s1deaspaceritle} and the figure’s content and the idea space’s title
in the Organizer will automatically stay in sync regardless of which one you change.

+ Use the Info inspector to give a figure an identifier of (s1deaspaceragnames} and the figure’s content and the idea space’s
associated tags will automatically stay in sync regardless of which one you change.

List/Mind Map/Table From File

A standard Mac open panel will appears allowing you to select a file which will be converted into a native Curio list, mind map, or
table collection figure, as appropriate. You can also perform this conversion simply by drag-and-dropping a file into your idea space
from the Finder.

The import formats currently supported are as follows:

« Lists: OPML.
* Mind Maps: OPML, Mindjet MindManager, iThoughts, MindNode, iMindMap.
* Tables: CSV.
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File

Curio can also export collections in those same formats. Collection import and export conversions are discussed in greater detail in
that collection’s section later in this documentation.

File
A standard Mac open panel will appears allowing you to select a file to insert into your idea space. Use the popup at the bottom of
the dialog to specify whether Curio should:

» Copy and embed the selected files into your project,
« Store aliases to the selected files in your project,
* Move and embed the selected files into your project.

As mentioned below, you can also simply drag files from the Finder into an idea space, which will copy and embed by default. Hold
~\- while dragging to store an alias. Hold & while dragging to move and embed.

Important
Please note that some sync servers, like Synology Cloud Station servers, do not support aliases to files so any aliases created
in Curio will break!

Insert Menu

To quickly insert certain types of figures without going through a gallery window you should check out the Insert menu in the main

menu bar.

With the menu, as opposed to the Insert popover, you won't see a gallery. Instead the figure will be inserted instantly into the idea
space with its default styling.

There are options for the collection figures such as lists and mind maps, as well as menu items for Web Views and Google Docs
views. Plus submenus for variables and date/time options.

Insert Other Content

From the Finder

You can drag files from the Finder or your Desktop directly to your Curio idea space.

By default Curio copies the file and embeds it within your project’s internal asset library. Then appropriate asset figures are
created on the idea space itself, like an image asset figure if you drag in an image file.

If you hold 3 down while dragging you will move the file into your project, therefore removing the file from its original location.
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From Curiota

If you hold down the ~ key while dragging then Curio will create an alias to the original file. When you later double-click the file to
open it on the idea space you will be opening the original file, not an embedded copy. You can always convert aliases to embedded
files at a future date using the Info inspector.

Important
Please note that some sync servers, like Synology Cloud Station servers, do not support aliases to files so any aliases created
in Curio will break!

If the dragged-in file has a csv extension Curio will ask if it should be converted into a native Curio table. If the extensionis opm1 ,
Curio can convert it to a list or mind map. If the extension is ma or markdown , Curio can handle it as a markdown insert. If the
extension is a popular mind mapping file format then Curio can convert it into a mind map. More details on supported mind map
import files are in the mind map section of this manual.

Image Text Recognition

Curio uses Apple’s Vision framework ( virecognizeTextrequest )to automatically scan imported images for text (aka OCR) which can
then be searched for using Quick Find or the Search shelf. The resulting found image figures are highlighted, although the

recognized text within the images are not.

See the Image Text Recognition area of the figure’s Info inspector to view the recognized text and change the detection language.

Experimentally it looks like very neat handwriting is recognized although isn’t nearly as accurate as printed text.

As a reminder, if an image figure is selected then press the Spacebar to see the Quick Look preview. Apple’s Live Text feature allows
you to select and copy text directly off that image preview.

From Curiota

Curiota is a free companion app from Zengobi that opens up even more productivity with Curio.

Curiota runs silently in the background, consumes very little memory, and has a minimal user interface: you just see a simple icon up
in the menu bar. Click on that icon to create quick notes, or drag files and links to the icon to quickly add files.

Curiota also supports print services (so you can “print” to Curiota), works as an macOS Share extension, is accessible via your

Services menu, and is easily scriptable.

All of the submitted notes and files are accessible and searchable using Curio’s Local library shelf, discussed below. More
information about Curiota can be found at www.zengobi.com/curiota.

From the Web

If you are running Safari or another web browser you can select images and text and drag them to your Curio idea space. In most
cases, especially for Safari, Curio can determine where the selection came from so we can associate that web URL with the text or
image. In the case of text, Curio will add an attribution line at the bottom of the text stating the source URL for the text.
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From Mail

For images, you can right-click on the image and choose Open Link with Browser to jump to its source location. If you drag in a
YouTube or Vimeo video URL from the browser to your idea space, Curio will ask if an embedded video figure should be created for
easy playback.

You can also drag in selections from Sleuth, Curio’s built-in internet research assistant, as it uses Safari’s same web rendering
engine (WKWebView).

From Malil

You can drag in a message from Mail to embed a copy of the message into your project. When you double-click the message it will
be opened and viewed with Mail. Currently you can’t drag in multiple messages at the same time.

Generally what Curio receives is a file with an eml extension. If you are having problems with the mail client app that opens the
message, say you’d like it to be Outlook for example, then drag a message to your Desktop, use the Finder to Get Info on it and
make sure the Open With selection is set to your mail client. Click Change All so that all files with that extension are opened with the
appropriate client app.

The IBM Notes email client is a bit odd so we have a workaround. First drag the mail message to your Desktop and a dialog will
appear asking if you want the full file or a link. Choose a link which will create a inetloc file on your Desktop. Then hold down the
Command key and drag that file into Curio which will move the item from your Desktop into your project.

From Contacts

You can drag in people and other contacts from Contacts (or Lion’s Address Book) to embed copies of the contact information into
your project. When you double-click the contact it will be found and viewed within Contacts, if not found then Contacts will ask if
you want to add it.

From Calendar

You can drag in events from Calendar and copies of the event will be embedded into your Curio project.

Curio will maintain a link to the original event in Calendar, if possible. Double-click the Calendar event figure to open Calendar and
display details about the event. If Calendar cannot find the event, it will offer to add it as a new event. This is useful if you want to
share events with other users by sending your Curio project to them.

Note that Calendar entries are found via the event name. To ensure correct operation, entries in Calendar that are added to Curio
should have unique event names. Once added to Curio you can rename the title of the figure Curio creates to anything you want,
but the event in Calendar must keep its original name.

From a LinkBack Application

Deprecation Notice
As a notice, Curio’s support for LinkBack will cease at some point. The LinkBack API relies on system calls that Apple
deprecated way back in MacOS X 10.13 High Sierra.
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From an Equation/Formula Editor

You can paste content copied from any application that supports LinkBack, such as OmniGraffle, directly into your idea space. The
content will be displayed in the idea space as it would appear in the other application and when you double-click the figure, Curio
will automatically launch the other application to allow you to edit the content.

In the LinkBack-enabled application, copy the content you wish to add to an idea space. then, in Curio, choose Edit > Paste from
the main menu to paste the content into the selected idea space of the active project.

The LinkBack data was passed in on the clipboard and is stored with the figure itself—there is no file to import or export.

A visual representation of the content will be added to the idea space. Double-click on the figure to launch the other application and
edit the related-content. When you save your changes within the other application, they will automatically be reflected within your
idea space.

From an Equation/Formula Editor

In addition to Curio’s integrated equation editor, there are many popular equation and formula editors that work quite well with

Curio.

Grapher

/Applications/Utilities/Grapher.app - Grapher is actually bundled with macOS and does a very good job creating equations as well
as 2D and 3D graphs. Enter equations into the main formula area of the Grapher window. Use the Equation Palette (via the Window
menu) to assist with this process, and choose Help > Grapher Help > Shortcuts to learn about their handy equation-entering
keyboard shortcuts. Once you have entered your equation you can select the equation itself and copy it to the clipboard where it is
stored as a PDF image. Paste that PDF image into Curio and you have a perfectly rendered equation which can be scaled to any
size while maintaining full legibility. You can also graph your equation in Grapher, of course, and then copy that as PDF and place
that into your Curio idea space, as well.

LaTeXiT https://www.chachatelier.fr/latexit/

LaTeXiT uses the LaTeX engine to generate equations. Simply generate your equation in LaTeXiT and use Edit > Copy to copy it to
the clipboard then paste it into Curio. The result is actually a PDF image so it resizes cleanly to any dimension. LaTeXiT supports
LinkBack so you can double-click your equation in Curio to continue editing it in LaTeXiT and save the equation to automatically
update its rendering within Curio. Note that drag-and-dropping the equation from LaTeXiT into Curio does not include the LinkBack
information.

MathType https://www.dessci.com/en/products/mathtype/

MathType can copy PDF renderings of the equation which can be pasted into Curio. The free MathType Lite can generate PNG
images for pasting, although resizing isn’t as clean as PDF.

From OneNote

Curio can create lists and mind maps from lists copied in from Microsoft’s popular OneNote product via Curio’s Paste As > List and
Paste As > Mind Map. To do this, Curio’s parser carefully strips out OneNote’s existing prefixes so you end up with just the list items
themselves.

For example, if you copy a numbered list from OneNote that used with roman numerals surrounded by parentheses, like (iii) ,
then Curio’s Paste As > List will now cleanly remove those prefixes so that Curio’s list code can take over the enumeration.
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From TaskPaper

Supported OneNote List Prefix Format #1

Examples: 1., 1), (1), 1st, 1-

Rule: An optional “(” then a 1 to 3 digit number then an optional “st”, “nd”, “rd”, or “th”, then an optional “)” or “.” or “-” then
whitespace.

Supported OneNote List Prefix Format #2
Examples: i., iv), (x), =xviii.
Rule: An optional “(” then a 1 to 6 digit roman numeral then an optional “)” or “.” then whitespace.

Supported OneNote List Prefix Format #3

Examples: a., »v), (), bp.

Rule: An optional “(” then a 1 to 3 digit letter then an optional “)” or “.” then whitespace.

Supported OneNote List Prefix Format #4

Examples: -, -, o, s,

Rule: A single punctuation then whitespace.

From TaskPaper

There are a couple of ways to bring TaskPaper tasks into Curio.

Import a TaskPaper File

Drag-and-drop a TaskPaper file directly into Curio and it can be converted into a list or mind map, or simply inserted as a file asset
figure, including any meta tags as mentioned in Importing Meta. In addition, any TaskPaper line entries that aren’t tasks (that is,
don’t start with a -) will be considered as figure notes for the previous line item.

Dragging in a TaskPaper Project Outline

In TaskPaper, drag a project line’s dot (located on the left side of the project’s title) directly into your Curio idea space to instantly
create a Curio to-do list, akin to importing a TaskPaper file described above. You can optionally right-click on the list to turn it into a
mind map, if you wish.

Pasting a TaskPaper List

You can also do this via copy and paste. In TaskPaper, simply copy a list of task items then paste into Curio using Edit > Paste As >
List. If a project line is copied then it will become the title of the resulting list, and task items will turn into Curio list items. Any meta
tags will be handled automatically.

OmniFocus Tip

OmniFocus supports TaskPaper integration so that means it plays well with Curio’s new TaskPaper features as well!

Specifically, if you use OmniFocus’s Copy as TaskPaper feature to copy a selection of tasks as TaskPaper tasks, then Curio will
parse the @defer tag as an alternate to the usual @start tag.
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From OmniOutliner

Exporting as TaskPaper

Note that Curio can export to TaskPaper as well! More details below.

From OmniOQutliner

Drag an OmniOutliner-generated OPML export file into your Curio idea space and it can be converted into a list or mind map figure.

OmniOutliner Pro Super Powers

OmniOutliner Pro supports custom named columns and, when exported as OPML, those turn into data fields that Curio can import!
Curio will look for specifically named columns in that OPML export and convert that info into meta data.

« Curio also parses OmniOutliner’s status="checked" entry that indicates a checked figure.

» Each column name can be customized by clicking on its link below.

« Specified tags and resources must already exist in the project. They will not be automatically added.

* The default date format is the “short” format listed in System Settings > Language & Region > Advanced > Dates, thus like
12/25/18 for US but 25/12/18 for Europe, but can be customized. A time is optional, but the default time format is the 24-
hour format like 15:45, but can be customized via Advanced Settings.

« Duration abbreviations for year, month, week, day, hour, minute can also be customized via Advanced Settings.

Column Name Values Description
The figure’s percent complete. As a note, if a node
A number from 0 has children then Curio ignores its Progress value

Progress to 100. and instead rolls it up from the Progress values set
to its child nodes.
. A number from 1 , )
Rating 05, The figure’s rating value (number of stars).
Priority A number from 1 The figure’s priority value from 1 meaning urgent
to 5. priority to 5 meaning very low priority.
A date with or
Start without time The figure’s start date.
value.
A date with or
Due without time The figure’s due date.
value.
. A duration , ,
Duration ) i The figure’s duration.
string, like 2w.
A comma The figure’s tags. Tag name only or with tag set
Tags separated list of prefix:
tags. Like, Context.Home, detailed tasks.in flight.
A comma

, The figure’s resources. First or full name:
Resources separated list of ]
george, steve jobs
resources.
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Insert from Library

Insert from Library

Files stored in Library shelf can be dragged into your idea space, as well.

Project Library

When dragging items in from the Project library, the result will be another asset figure instance of the dragged asset, that is the
asset will only exist once in the project’s internal library and your new asset figure will simply point to it.

Local Library

When dragging items in from the Local library, the file is copied into your idea space. If you hold down the % key while dragging then
the file will be moved into your idea space, therefore removed from its original location.

Sleuth Library

Once you complete a search in the Sleuth library you may be able to drag the results, say an image or some text, into your idea
space, depending on the site being searched.

Evernote Library

When dragging items in from the Evernote cloud library, the file is downloaded and copied into your local asset library. If you hold
down the & key while dragging then the file will moved into your idea space, therefore removed from the Evernote cloud. If you hold
~- while dragging then an alias to the Evernote note will be created such that double-click the alias will open the note within the
Evernote Mac app.

Spread PDF

Curio includes a special feature you can use with PDF assets called Spread PDF. If you have a multipage PDF file that you would like

to spread across a single idea space or across multiple idea spaces, Curio makes it super simple. This feature is mainly used when
taking notes alongside slides or annotating the slides in a PDF presentation.

You can spread a PDF across a single idea space. This is useful when spreading a short PDF or only the first few pages of a longer
PDF to prepare it for spreading across multiple idea spaces.

You can also continue a spread across multiple idea spaces if you have an especially long PDF.

Spread PDF Within This Idea Space

1. Create a new idea space or use an existing idea space.

2. Drag the PDF into the idea space.

3. Resize and position the PDF figure any way you wish. If you wish, create a text figure for text annotations and/or a list figure
for key points or questions then place those next to the PDF with some placeholder text.

4. Select those figures then right-click on the selected figures and choose Spread PDF Within This Idea Space. A single idea
space has a 20 page spread limit primarily for performance reasons.

5. You can then enter in how many columns and rows of the pages you’d like to create, plus the spacing gap between those
columns and rows.
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Instant Document Templates

6. Curio will duplicate the figures and spread them across then down the idea space, growing the idea space as necessary,
where each PDF figure instance shows the subsequent page in the PDF document. After the process is completed you can
move the figures around manually if you wish.

Tip
Read the tips below for more information on working with PDF figures.

Spread PDF Across Idea Spaces

1. Begin just like spreading a PDF file across a single idea space, as described above. Note that this idea space you create will
be used as a template when creating the subsequent idea spaces. Any other figures that you add to this idea space will be
replicated on all the other idea spaces.

2. Right-click on the idea space in the Organizer and choose Spread PDF Across Idea Spaces.

3. Curio will generate a copy of the idea space as many times as needed to show all the pages in the PDF.

Instant Document Templates

You can insert new documents of any type from within an idea space using document templates. This comes in handy when you

want to quickly expand upon some ideas in a new TextEdit document or perform some advanced drawing in a new Photoshop
document.

Create a New Instant Document in an Idea Space

1. Choose the document you wish to create from the Insert > Instant Document submenu.
2. A copy of the chosen template document is automatically embedded in your project and added to the current idea space.
Simply double-click the document to launch it in its native application.

Add Custom Entries to the Instant Document Menu

1. You first need to create a document that you wish to use as a template. Launch the appropriate application, such as
Photoshop or Word, then create a new document and save it anywhere on your hard disk. The name of this file will be used
as the template name later in step #3. Alternatively, if there’s an existing document you wish to use as a template then you
can skip this step.

2. Choose Insert > Instant Document > Add File as Instant Document from the main menu.

3. In the Open dialog, locate and select the document you wish to add as a template and click the Add button.

4. A copy of the document you selected is created in your Home directory’s ~/nibrary/Application Support/Curio/Version XX/
Repository/External Document Templates folder. The document’s name is also added to the document templates submenu.

5. You can create multiple template documents of the same type, but make sure they have descriptive names so you can tell
them apart in the document templates submenu.

Remove Custom Entries from the Instant Document Menu

« Choose Insert > Instant Document > Remove Instant Document from the main menu, and then choose the template to
remove and click Remove.
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Tools Palette

Tools Palette

In the toolbar you’ll find a small palette of tools, appropriately labeled “Tools”. This palette contains the toolbar you’ll use to

manipulate figures on the idea space and easily create a few new items as well.

The Select Tool

The select button looks like a standard mouse pointer. This is the default tool and is automatically chosen if you press the Escape
key on your keyboard.

With the select tool you can click on figures and select them for modification.

Selecting a Figure

+ With the Select tool active simply click on a figure. A glow will appear around the figure and resizing handles will appear on
the figure if appropriate.

Selecting Multiple Figures

1. Generally you can hold down the & key while selecting items.
2. If you have a collection with a series of items, like the siblings in a list or mind map, then you can select one then hold Shift
and select another and you will select the range between the first and last selected item.

Drag Selecting Figures

» Normally when you drag out a region with the select tool Curio will select both figures and any sketches you made with the
brushes or pens. However, if you hold the ~\- key then only figures will be selected. Hold both § and ~- and then only
sketches will be selected in the resulting region.

Insert a New Text Figure Using the Select Tool

» Double-click anywhere in the idea space to create an automatically sized text figure, or double-click-drag the mouse to
define a specific width for the new figure. Press Escape when you’re done editing the text figure.

Edit an Existing Text Figure Using the Select Tool

* Double-click on the text figure to begin editing. Press Escape when you’re done editing the text figure.

The Text Tool

In the toolbar you’ll find a small palette of tools, appropriately labeled “Tools”. This palette contains the toolbar you’ll use to
manipulate figures on the idea space and easily create a few new items as well.

The text tool button looks like a little “T’. You can press the T key on your keyboard to quickly choose this tool.

While the Select tool can be used to edit figure, if you plan to edit lots of text figures using the text tool may be more convenient as
you only need to click once to create and edit text figures.
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Session Styles
If, after clicking the text tool but before clicking on the idea space, you change any text attributes using the various inspectors then

those attributes will be stored in-memory as the session style for the text tool.

For example, click the text tool then use the inspector to make the text bold with a red color. Then when you click on the idea space
you’ll create a new bold-red text figure. Later, when you use the text tool again, you can create another bold-red text figure.

These style changes are just for the current session of Curio, they aren’t stored to disk. To make permanent styles you should use
Curio’s figure style feature.

Insert a New Text Figure Using the Text Tool

+ Click anywhere in the idea space to create an automatically sized text figure, or click and drag the mouse to define a specific
width for the new figure.

Edit an Existing Text Figure Using the Text Tool

+ Click on the text figure to begin editing. Press Escape when you’re done editing the text figure or click on another to begin
editing that figure.

The Line Tool

The line tool button looks like an angled line. Click and hold on the line tool button to bring up a quick list of common lines including
nondirectional, directional, and bidirectional. You can press the L key on your keyboard to quickly choose the line tool; repeatedly
press L to cycle through the line choices.

Use the line tool to go into a line drawing mode useful when drawing lots of lines, for example when connecting several figures
together with the sticky lines feature.

Tip
You may also want to read about Idea Graphs which use line figures to connect figures together.

Drawing a Line

1. Click on the Line tool in the toolbar.

2. Change any attributes such as color or arrowhead shape that you wish to make the default for this line using the Shape
inspector, discussed below.

3. Click and drag an area on the idea space to draw the line. Repeat this step as needed to draw multiple lines using the same
style.

Drawing a Multipoint Line

1. Draw a line as described above, however, before you release the mouse button hold down the ~- key. When you release the
mouse you’ll find that you’ve dropped a midpoint and now you’re placing a new endpoint. Continue holding down Option to
keep dropping midpoints as you release the mouse. If you're done, just release the Option key before you drop your last
point.

2. Repeat step 1 to draw multiple multipoint lines using the same style.
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Tip
Read more about line figures below.

The Shapes Tool

The shape tool button looks a geometric shape. You can press the F key on your keyboard to quickly choose this tool.

With the shape tool you can easily create figures such as rectangles, rounded rectangles, circles, octagons, hexagons, trapezoids,
brackets, vertical brackets, triangles, diamonds, semicircles, ovals, underline, speech bubbles, and clouds.

Using the shape inspector you can always change a shape to any other geometric figure, as we’ll detail in the sections ahead.

The shape tool on the toolbar has an arrow located in the lower right portion of the button. When you click and hold the mouse on
the button a menu displays the list of predefined shapes you can choose. Once you choose a shape, your choice is reflected by the
button’s image. Simply clicking the button will reselect the displayed shape.

Adding Text

You can add text to a shape simply by double-clicking it. Note that these figures are considered freeform shapes where you control
the width and height. Therefore text can be clipped if the figure dimensions are not large enough. Any contained text is centered
both horizontally and vertically within the shape. You can toggle off the freeform sizing using the figure’s right-click context menu or
the the Paragraph inspector.

Additional Shapes

As you’ll learn more about later, the shape inspector allows you to modify a corners attribute of the figure. For a rectangle, this turns
it into a rounded rectangle. But for other shapes the change may be more dramatic. More details later when we discuss the shape
inspector.

Drawing a Shape

1. Click on the Shape tool in the toolbar (hold the button down to display a popup menu of shape choices).
2. Change any style attributes that you wish to make the default for this shape using the Shape inspector.
3. Click and drag an area on the idea space to draw the shape.

4. Repeat step 3 to draw multiple shapes using the same style.

The Scribble Tools

These brush and pen tools are covered in greater detail in the section on Scribbles.

-94/423 - Copyright © 2025 Zengobi, Inc.



Working with Figures

Working with Figures

Select One or More Figures

* Using the Select tool, click on a figure. Select additional figures by holding § or use the Shift key to select a range of figures
in a collection. Or use the Edit > Select All menu item to select all figures on the idea space or within the active collection
figure.

Adjust a Figure Location

1. Simply drag the figure using the mouse to the new location on the idea space.

2. Or use the arrow keys to move figures around. Hold Shift to move in greater increments. If an idea space grid is active then
the figures will move based on the grid spacing.

3. Or use the Geometry inspector to set a specific value.

Adjust a Figure Size

1. Drag on the handles that appear around the border of a selected figure.

2. Or use the Geometric inspector to set a specific height or width.

3. If a scaled image figure then you can press the N key or click the Natural Size in the Geometry inspector to reset the image
to its unscaled size.

4. If an image figure then by default resizing is proportional. This can be toggled in the Geometry inspector or by holding down
the Shift key while resizing.

Rotation

1. Hold % while dragging a resize handle to rotate the figure.

2. Or, to quickly rotate a figure in 45° increments, simply press the R key (hold down the Shift key to rotate the figure in a
clockwise direction).

3. To quickly set the rotation angle of a figure to 0°, press the Z key.

4. You can exert more control over the exact rotation angle and rotate multiple figures at once by using the controls of the
Geometry Inspector.

Image Flipping

1. Select an image figure.
2. In the Geometry inspector, in the Arrange panel, click the “Flip Horizontal” or “Flip Vertical” button.

Moving a Figure in Front to Back Ordering

1. Select the figure.

2. Choose Arrange > Send Backward or Arrange > Bring Forward to move a figure one position closer to the front or back of
the stack. Choose Arrange > Send to Back or Arrange > Bring to Front to move a figure to the very bottom or top of the
stack. Toolbar buttons are also available for this via Customize Toolbar.

Locking and Unlocking Figures

1. Select the figures you wish to lock.
2. Choose Arrange > Lock from the main menu. This will lock both the content and position by default.
3. Alternatively, you could choose a subitem — Content or Position — to lock just one of those attributes.
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4. When a figure with any lock attribute is selected it will have a thin, gray glow. If only the text content is locked, it will show
selection handles as well, since the figure can still be moved and resized.
5. To unlock a figure choose Arrange > Unlock to remove all lock restrictions.

Using Snap Guides

» Choose Arrange > Show Snap Guides from the main menu. You can toggle the appearance of edge and center snap guides
independently by choosing Arrange > Edge Snap and Arrange > Center Snap from the main menu.

Align Figures

1. Select the figures you wish to align.
2. Choose one of the alignment options from the Arrange > Align submenu, or use the buttons in the Geometry inspector.
3. If only a single figure is selected then it will be aligned within the idea space itself.

Distribute Figures

1. Select the figures you wish to distribute.
2. Choose one of the distribution options from the Arrange > Distribute submenu, or use the buttons in the Geometry inspector.

Grouping Figures

A grouped figure converts a selection of several figures into a single figure. Once within a grouped figure the individual figures can
no longer be selected, resized, or re-styled.

1. Select the figures you wish to group.
2. Choose Arrange > Group from the main menu.
3. To ungroup figures, select the group and choose Arrange > Ungroup from the main menu.

Groups vs Followers vs Bundles

* A group figure encapsulates figures within itself. You can even create nested groups. The end result is a single figure so can
be used in places that take a single figure, like a mind map node. Accessing figures deep within a group hierarchy can be
difficult.

« A follow figure is a figure that follows the movements of an assigned leader figure. Move the leader and all the followers
move, too. Followers are otherwise completely independent and can be selected, moved, resized, styled, edited, deleted,
copied, etc. A leading figure could have many followers scattered anywhere on an idea space. Right-clicking a leader or
follower gives you quick access to related actions.

+ A bundle figure is almost identical to the following figures but they all follow each other if any of them is moved. You can
temporarily disable the bundle to move one or more then re-enable the bundle to track movements again. Right-clicking a
bundled figure gives you quick access to related actions.

Following Figures

You can create a loose collection of figures which follow the movements of their assigned leading figure. The followers are
independent and can be easily repositioned, edited, deleted, styled, and sized, but will move with the main figure.
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Any figure on the idea space can be a leader or follower including collection figures. However, figures within a collection are
excluded since the collection itself manages the layout of its contained items.

These are very useful in many situations:

* You want to create a bunch of annotation figures alongside a main figure, pointing out or discussing areas of interest. You
can easily reposition, add, or remove annotations, yet they move with the main figure.

* You want to create a large title or caption figure above or below a main figure that can be positioned and sized independently
yet moves with the main figure.

Tip
Learn more about groups vs followers vs bundles.

Video
Watch a following figures demonstration video on our YouTube channel.

Follow a Figure

1. Select a figure that will act as the leading figure.

2. Hold Shift and continue selecting figures that will be the followers of that first selected figure.

3. Choose Arrange > Follow > Follow First Selected from the main menu or via the right-click context menu.
4. You can add more followers at any time by repeating this process.

When you move a leading figure, its followers will move as well. However, you can move followers independently to reposition them
around the leader. All figures are independent and can be edited, selected, deleted, cut, copied, exported, printed, etc without
impacting the others.

Adding More Followers

There are several ways to add more followers to an existing leading figure.

1. You can follow the steps above and select the leading figure, then the figures you wish to follow that figure, and choose
Arrange > Follow > Follow First Selected.

2. You can select a mix of existing followers and figures you want to become followers and choose Arrange > Follow > Follow
Same Leader.

3. You can copy/paste, duplicate, or ~cdrag an existing follower and the new created figure will also be a follower of that same
leader.

Glow Colors for Leaders and Followers

* When you select a leading figure its followers will have a yellow glow.
* When you select a follower its leader will have an orange glow.

Note these associated glowing figures aren’t selected, the glow is only used to indicate the leading/following relationship.
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Bundling Figures

Unfollow a Figure

At any time you can specify that one or more figures should no longer follow a figure:

« Select one or more figures and choose Arrange > Follow > Unfollow from the main menu or via the right-click context menu.

Selecting Leaders and/or Followers

1. Select either the leading figure or one of the following figures.
2. Choose Arrange > Follow > Select Leader, or Arrange > Follow > Select Followers, or Arrange > Follow > Select Leader and
Followers from the main menu.

Context Menu

If you right-click on figures to show the figure context menu a handy Follow submenu will be available to give access to common
follow figure actions.

Toolbar Button
If you right-click on the toolbar and choose Customize Toolbar you can drag a Follow button onto your toolbar.

This button acts as a toggle based on the selected figures to easily follow or unfollow a leading figure.

Bundling Figures

Similar to the following figures described above, you can create a loose collection of figures but instead of following a single leading
figure, they follow each other. Move any figure in the bundle and they all move, yet you can still resize and edit individual figures
within the bundle.

So, how do you move a single item? You can temporarily toggle off the bundle (described below), reposition the figures within the
bundle, then turn it back on.

Any figure on the idea space can be in a figure bundle including collection figures. However, figures within a collection are excluded
since the collection itself manages the layout of its contained items.

Tip
Learn more about groups vs followers vs bundles.

Video
Watch a bundling figures demonstration video on our YouTube channel.

Bundling a Figure

1. Select several figures.

2. Choose Arrange > Bundle > Bundle from the main menu or via the right-click context menu.

3. If any of the selected figures are already in a bundle then the unbundled figures will be added to the same bundle, else a new
bundle will be created with all selected figures.
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Bundling Figures

Note that if you select several figures in a mix of existing bundles then you can’t bundle them together, as a safety precaution. You
would first need to unbundle those figures, then bundle them in a new bundle.

When you move any figure in the bundle, all figures in the bundle will also move. Yet those individual figures can still be
independently edited, resized, selected, deleted, cut, copied, exported, printed, etc without impacting the others.

Adding More Bundled Figures
There are several ways to add more figures to an existing bundle.

1. You can select a mix of existing bundled figures and figures you want to to add to the bundle and choose Arrange > Bundle
> Bundle.

2. You can right-click to temporarily disable the bundle, then copy/paste, duplicate, or ~-drag an existing bundled figure and
the new created figure will also be in the same bundle. You can then right-click to re-enable the bundle via the context menu.

Glow Colors for Bundled Figures

When you select any figure in a bundle the other figures in the bundle will have a yellow glow so you know they’re associated with
each other.

Note these associated glowing figures aren’t selected, the glow is only used to indicate the bundle relationship.
Unbundle a Figure
If you want to remove one or more figures from the bundle then:
« Select one or more figures and choose Arrange > Bundle > Unbundle from the main menu or the right-click context menu.
Select Bundle
To select all the figures in a bundle:

1. Select any figure in a bundle.
2. Choose Arrange > Bundle > Select Bundle from the main menu.

Temporarily Disable Bundle
To temporarily disable a bundle:

+ Select any figure in the bundle and choose Arrange > Bundle > Temporarily Disable Bundle or via the right-click context
menu.

You can now freely reposition any of the figures in the bundle.

The bundle will be re-enabled automatically if you go to another idea space or close the project, or you can manually do this by
toggling toff the Temporarily Disable Bundle menu item or via the right-click context menu.

Context Menu

If you right-click on figures to show the figure context menu a handy Bundle submenu will be available to give access to common
follow bundle actions.
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Toolbar Button

If you right-click on the toolbar and choose Customize Toolbar you can drag a Bundle button onto your toolbar.

This button acts as a toggle based on the selected figures to easily create or add figures to a bundle, or unbundle the selected
items.

Asset Figures

Creating Asset Figures

Drag a file from the Finder or your browser into an idea space to create an asset figure.

In general the asset figure is rendered as a simple icon and file title. If an image or video file, it is rendered in preview form so you
see the image and can interact with the video.

Opening/Editing

Double-click the figure to open its corresponding asset file in the appropriate editing application.

If it's opening in the wrong application you may want to right-click and choose Reveal In Finder, then use the Finder’s Get Info to see
what application is associated with that file extension. Choose a more appropriate application then click the Change All button so all
files with that extension open with that app.

Alternatively right-click on the asset figure and choose Open With and select an application on-the-fly.

Quick Look Preview

Press Spacebar to see a popup Quick Look preview of the file.

Show As Icon or Preview

Right-click on an asset figure and choose Show As Icon or Show As Preview, to change how the asset figure is rendered. If you
choose preview then, for image types, the image itself is rendered, otherwise a Quick Look preview is retrieved and rendered.

Default Show As Per File Type

You can set the default state for whether a type of file dragged into Curio shows as icon or preview. First, drag in a representative
file (image, PDF, video file, or other document) then select the figure and use the Format > Default Figure Settings submenu to set
the default show as format as either icon or preview for that specific file type.

Show As Text Figure
(Also known as file-backed text figures.)

When you drag a text file into Curio it is normally displayed as an asset figure with simple icon. To get a read-only view of the
contents of the file, you could press Spacebar or right-click and choose Show as Preview. To edit those contents, you have to
double-click the asset figure to open the text file in its appropriate editing application.
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A much more powerful feature is to right-click on the asset figure and choose Show As Text Figure. The result looks and acts like a
normal Curio text figure, however instead of storing the text figure’s contents in the figure’s internal data, it is stored within the asset
text file, thus a file-backed text figure.

1. Drag any text file into Curio and insert it as a normal file asset figure, displayed with its icon.
2. Right-click and choose Show As Text Figure.

O 81 Here s an asset figure that points to a markdown file. O

Show as Text Figure

Show as Preview

Important

If you don’t see a normal asset figure when you drag in a markdown file then it may be that you’ve told Curio to always insert
markdown files as text figures directly, where Curio extracts the content of the file and inserts it into a new figure. To fix this
click here to reset the alert then drag a markdown figure into Curio again. This time make sure to choose “As File” from the alert
that appears so it comes in as a normal embedded or aliased file. Now you should be able to right-click on it and choose Show
as Text Figure.

Now the asset figure looks like a normal text figure:

Markdown: Syntax

e Overview

o Philosophy.

o |nline HTML

o Automatic Escaping for Special Characters
e Block Elements
Paragraphs and Line Breaks
Headers
Blockquotes
Lists

Block

Horizontal Rules

O O 0O 0O O O

To change it back to a normal asset figure with icon:
+ Right-click on the figure and choose Show As Icon.

Plain text, rich text, markdown, and even simple HTML files are supported. If the file has @ markdown Or ma extension then
markdown rendering will automatically be enabled for the figure. For rich text, if images are added to or removed from the figure
then the file will automatically be converted between rtfda and rtf formats.

Video

Watch a file-backed text figures demonstration video on our YouTube channel.
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Asset Figures

Duplicates Share Contents

As with any asset figure, if you duplicate the figure, all copies share the same underlying asset file. So all copies of the figure will
render and modify the contents of that same underlying file. This means editing any text figure will dynamically update all the
others.

Copies of a file-backed text figure can all be styled independently. The styling associated with a figure is applied to the shared text
content right before rendering.

Using File Aliases

This asset file can be an embedded file, or an aliased file that you Option-dragged into the idea space.

In the case of an alias, changing that text file outside of Curio will cause all the text figures that use that file to dynamically update
themselves.

For instance, you could store the results of a lab experiment in a separate file elsewhere on your hard disk, and those results can be
included in multiple text figures within your project.

This file, if located within a folder synced by a cloud service like iCloud or Dropbox, could even be edited on an iOS device which
will then sync back to your Mac for rendering within Curio!

Tip
If focus is on Curio and you use another device to change an underlying cloud-synced text file, you may need to either go to
another idea space and back or switch to another app and back to force Curio to refresh the idea space.

Important
Please note that some sync servers, like Synology Cloud Station servers, do not support aliases to files so any aliases created
in Curio will break!

Opening Associated Text File

If you press and hold the Option key while double-clicking the text figure then the associated text file will be launched for editing.

Alternatively you can right-click on the text figure and choose to open the file, or open it with a specified editing application.
Styling File-Backed Text Figures
The contents of the text backing file are used as the contents of the text figure. So how is that text styled within Curio’s figures?

Plain Text Files

If the text file is a plain text file, then the figure’s style such as font, font size, text color, etc, is applied to that content.

Similarly markdown files, which are simply plain text files, are styled the same way, then the markdown-specific attributes, such as
those for headings and list items, are then applied.

Duplicates of the figure, which share the same underlying text file, are handled by applying that figure’s text syling right before
rendering. Thus the same plain text content can look vastly different in various figure instances as those instances apply their figure
stylings to it.
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Rich Text Files

Rich text files add a wrinkle since they already contain text stylings. Characters, words, and paragraphs may already have certain
fonts, font sizes, traits such as bold and italics, foreground text colorings, and background highlight colorings. And there may be
duplicates of a figure, each independely styled.

How are figure styles applied to those rich text contents?

Curio tries its best to adopt as much of each figure’s style to the figure without impacting the contained text using the following
logic:

1. Same Font and Font Size Throughout
If the entire text content shares the same font and font size (and ignoring traits like bold and italics) then the figure’s font and
font size are applied to those contents right before rendering. Subtext containing bold and italic attributes remain intact after
applying the new font.

2. Same Font Size Thoughout
Else, if the entire text content has a mix of fonts but they’re all the same font size, then the figure’s font size is applied to
those contents right before rendering. So the mix of fonts remains intact but they all adjust in size. Bold and italic attributes
also remain intact.

3. Text Coloring
Curio will then apply the figure style’s foreground text coloring to the text, while making sure colored subtext remains intact.

If there’s a mix of fonts and sizes then Curio leaves the text formatting as-is as it doesn’t want to jeopardize your rich text formatting
by applying a new syling erroneously.

Lastly, after editing a figure and making changes to the text, then the reverse happens: the original font, font size, and text coloring
based on the original styling from the rich text file when it was first read in, is then re-applied to the text before saving, using the
same logic as detailed above. That way the figure’s styling is independent of the styling saved to disk. However, if you've edited the
figure and, using Curio’s text inspectors, modified the text so it’s a mix of fonts and sizes, then Curio will keep all of this intact when
saving to disk, so it doesn’t jeopardize your applied formatting.

Compared to Synced Figure Instances

Curio has a similar feature called Synced Figure Instances which you can read about below. With that feature, you can copy a text

figure then paste synced instances throughout your project.

Like asset figures displayed as text figures changing the contents of any copy will be reflected to the others throughout your project.
However, there are some key differences:

1. Synced figure instances store their text data within the figure data itself, not to a separate text file.

2. Synced figure instances will also sync figure meta information. Checking off or changing the due date on one will change all
the others. With file-backed text figures each figure is independent and only the content is synced since they share the same
underlying asset file. (Technically, for historical reasons, tags are synced between file-backed text figures as they are
associated with the asset, not the figure.)

3. Synced figure instances allow you to easily jump between the original and instances of that original.
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Cool Trick

You can actually create a synced figure instance of a file-backed text figure to get the best of both worlds: synced figure meta
with synced text contents stored to a file which can be embedded within the projet or even aliased to a file possibly synced via
a cloud service to your other Macs and devices.

Text Figures

Create a Text Figure

1. With the Select tool, double-click anywhere in the idea space to create an automatically sized text figure, or double-click-
drag the mouse to define a specific width for the new figure.

2. Or, with the Text tool, single click anywhere in the idea space to create an automatically sized text figure, or click-drag the
mouse to define a specific width for the new figure.

Style a Text Figure

1. Using the controls on the inspector bar or inspector shelf to style your figure.
2. You can also set options such as enabling a minimum height or freeform sizing.

Stop Editing a Text Figure

* Press Escape or click on the Select tool when you’re done editing the text figure.

Access the macOS Ruler

» While editing text figures you can use the standard macOS ruler for additional options. Toggle the ruler visibility using the
View > Show Ruler menu item. The ruler includes tab stops and controls for text styles, alignment, spacing, and simple text
lists.

Syncing with External Files
Curio Pro supports two methods for syncing text figures with external files which may be useful:

1. File-Backed Text Figures.
2. Sync Files.

Sync Figure Text to Organizer Title

+ Use the Info inspector to give a figure an identifier of (s1deaspaceritie} and the figure’s content and the idea space’s title
in the Organizer will automatically stay in sync regardless of which one you change.

Image Figures

Drag any image from the Finder, a browser, or an app like Photos directly into your Curio idea space.

Images can be resized, rotated, and styled using the style inspector.
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Markup Image
You can right-click on a jpeg or png image figure and choose File > Markup Image to bring up the standard macOS markup

popover. This allows you to crop, annotate, highlight, and scribble on the image then instantly see the result on your idea space.

Note that while markup operations, including crop, are undoable during your run session in Curio, once you close the project the
changes cannot be undone.

Resample Image

Large jpg and png images, Retina (144 DPI) screenshots, and iOS photos in Apple’s new HEIC image file format can all be slow to
load and manipulate on an idea space, and consume lots of disk space in your project.

Resample Image

Name: ScreenShot

Format: jpg

Quality:

Width: 2,559

Points
Height: 1,483
DPI: | 72| ']

Original png: Resulting jpg:

2559 x 1483 points 5 2559 x 1483 points

5118 x 2966 pixels at 144 DPI 2559 x 1483 pixels at 72 DPI
1.7 MB 437 KB

Resampling an image so it has smaller dimensions, a 72 DPI resolution, and/or a more efficient format is an easy way to boost this

performance and save some disk space.

1. Right-click on a jpg, png, or heic image figure.

2. In the sheet that appears you can choose the jpg or png format, a jpg compression factor, new width and height dimensions,
new DPI resolution, and optionally change its file name as well.

3. While you make changes the resulting dimensions and file size are displayed so you can see the impact.

After committing the resample you can undo the operation if you don’t like the changes.

Optimized Image Loads

When Curio loads the image for an image figure from disk, it uses the Mac’s Core Graphics method to retrieve an image for a given
file no larger than 1500 x 1500, proportionally sized, which allows much faster inital rendering and reduced memory usage.
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If you resize the image figure to a size larger than that, Curio will simply scale that initially loaded image. Resizing to a smaller size
will cause Curio to re-render from that initial image, consuming even less memory.

Of course, double-clicking the image figure opens the full-sized image in the appropriate application.

You can customize that 1500 x 1500 size via Curio’s advanced settings if you’d like to retrieve full-size images no matter how large.
Natural Size

After importing the image, Curio may size the loaded image to a smaller size if going into a mind map or list, for example.

You can use the Natural Size button in the Geometry inspector (or press the N shortcut) and the image figure will grow to its natural
size, but remain constrained by the current width of the idea space.

When clicking Natural Size or pressing N, you hold one these key modifiers:

+ Hold the Shift key and the idea space will expand if necessary.
+ Hold the Option key and the full, non-optimized image will be reloaded, in case a size constraint was imposed on a large

image for optimization reasons, and the idea space will expand if necessary.

SVG Images

Curio includes support for SVG image figures. Simply dragina .svg file or paste a raw text SVG and a scalable, vector-based

image will be rendered.

Note that the SVG format itself defines the various fills, gradients, and stroke colors for the internal vector paths within the image.

The Curio figure inspector’s stroke and fill color settings can’t override those internal values.

Also, the ISVG library that Curio may not support every feature of SVG. For instance, currently the text element is not supported
in SVG images.
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Popular SVG image libraries

Several of these SVG image repositories include an integrated editor. You can either download the SVG file and drag it in or, even
faster, click the Copy button to copy it then paste it into Curio.

+ SVG Repo - can change the stroke coloring on the site before copying

» Phosphor - can change the stroke coloring on the site before copying/downloading

« Remix - can change the stroke coloring on the site before copying/downloading

+ Iconify - can change the stroke coloring on the site before copying/downloading

+ Lucide - can change the stroke coloring on the site before copying/downloading

- Tabler

« Feather - can change the stroke coloring on the site before downloading

» Huge - stroke icons are free, can change stroke color before downloading but have to manually edit svg text file and tweak
the currentcolor attribute with the actual color from the <svg> line.

« Framer Shapes - cool gradient shapes

« Sketch Shapes - several massive collections of colored icons

* Bootstrap

+ SVG Viewer - you edit the svg code live on the site to tweak shape and colors with preview before copying or downloading

» SVG Shape Generator - random, organic blobs

» ssshape - more absract organic blobs
+ SVG Backgrounds - interesting shape collections, can change the stroke coloring on the site before copying/downloading

Online graphics editors that support SVG editing

You can either download the SVG file and drag it in or click the Copy button to copy it then paste it into Curio.

* SVG Viewer

+ Fun editor by Amelia Wattenberger (example)
+ Mediamodifier's SVG Editor

* vectormixer

« DEEditor for simple stroke and color tweaking
« vectormaker to convert JPEG or PNG images to SVG

Commercial online graphics editors that support SVG editing

» Canva
+ Figma

Commercial Mac apps that support SVG editing

« Affinity Designer
» Adobe lllustrator
* Flying Meat Acorn

Markdown

Markdown is a simple markup language to add formatting to plain text.
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Using Markdown

For example typing this:

Here is a xsimplex example of skmarkdownxx with a list of pets:

— Butternut is a skkdogiekk.
— Marshmallow is a skkkcatxskxk,

And a numbered list:

1. The first has a link to [Zengobi] (https://zengobi.com).
1. The second has "monospace’ and ~~strikethrough~~.

Will turn into this when you’re done editing:

Here is a simple example of markdown. And here is a list:

* Butternut is a dog.
* Marshmallow is a cat.

And a numbered list:

1. The first has a link to Zengobi.
2. The second has monospace and strikethrough.

Curio’s text figures support a number of markdown syntax elements. While editing the text figure you will see the raw markdown
syntax, but when you finish editing Curio will render it on the fly.

Using Markdown

Markdown Detection

The first time you edit a text figure and use markdown syntax Curio will ask if automatic markdown detection should be enabled.
You can also control whether markdown is enabled or disabled for a specific figure, regardless of the global default.

If you never or rarely use markdown then perhaps disable it by default, and only enable it for specific figures when you need it. On
the other hand, if you’re a fan of markdown, enable automatic detection and enjoy using markdown in any figure.

* Global Default
Use the Format > Default Figure Settings > Detect Markdown menu item to toggle the global setting. This setting is applied
to a figure when you first create it, so existing figures won’t suddenly change if you change the global.

* Per Figure
If a text figure is selected or being edited, you can use the markdown button on the inspector bar or text inspector to

explictly enable or disable markdown rendering just for this figure.

Mixing Markdown and Rich Text

Within a text figure you can mix markdown syntax with normal attributed text. The latter comes in handy when you’d like to use
attributes not supported by markdown, such as text and background coloring.
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Rich Text Syntax

Curio supports on-the-fly rendering of the following markdown rich text syntax:

Attribute

Italic

Bold

Bold and ltalic
Underline
Strikethrough
Highlight
Inline Code

Inline Links

Images

Wikilinks

Headers

Intra-word Italics

Example

*italic* or _italic_

“*pold*™

***pold and italic*™* or ___bold and italic___
__underline__

~~strikethrough~~

==highlight== or A highlightA" or ::highlight::
“printf()

Visit [Zengobi](https://www.zengobi.com)
[[Curiota icon](https://www.zengobi.com/
images/curiota32x32.png)

Read [[Overview]]

Read [[Overview|Alt Title]]

# header 1

## header 2

### header 3
#### header 4
##### header 5
###### header 6

Rich Text Syntax

Markdown Rendering
Enabled

italic or italic

bold

bold and italic

underline

strikethrough
highlight
printf ()

Visit Zengobi

w

Read Overview
Read Alt Title

header 1

header 2

header 3

header 4

header 5

header 6

For intra-word italics, like if you wanted to say magnificent, use the asterisk, not the underscore. Underscores for italics can only be

used at the start and end of a word. This allows you to enter text with intra-word underscores like Steven_Paul_Jobs without

rendering any italics.

Escaping Markdown

The backslash character can be used to escape text so it won’t be interpreted as markdown syntax. So, for example, \*this will not

be in italics\*.
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Markdown Links

Markdown Links

The markdown link syntax of the form [titie] (1ink) is supported within Curio.

The Smart Paste URL feature make it easy to create links. Simply paste a copied link on selected text to turn it into a markdown link

of the form [selection] (1ink) .

Given that pasting on selected text could also create a rich text clickable link, when does paste create a rich text link vs a

markdown link?

- If a text figure has markdown explicily disabled (via the inspector bar) then a rich text link is created, and if explicity enabled
then it will create a markdown link.

+ If markdown hasn’t been explicity enabled or disabled and Detect Markdown is enabled (via the Format > Default Figure
Settings menu) then it’s still unclear if you want paste to create a rich text link or a markdown link. This is solved with the
Prefer Markdown Formatting option under that same menu. Enabling this option means Curio should assume you prefer

markdown formatting so a markdown link will be created.

Markdown Link Limitations

Curio’s link parsing cannot handle URL’s with parentheses, as those are nested within markdown’s link syntax parentheses. This is a
complex problem to resolve as inner parens may not be paired - that is, you could have an uneven number of left vs. right parens -

and regex parsers can’t handle this very easily.
An easy workaround is to escape the left and right parenthesis with 28 and =229 , respectively.
Thus instead of this markdown:
[Set] (https://en.wikipedia.org/wiki/Set (mathematics))
You would do this instead:

[Set] (https://en.wikipedia.org/wiki/Set_%$28mathematics%29)

Markdown Emoji

While editing a markdown text figure, you can type in over 800 markdown emoji cheat codes, such as :1aughing:
and :heart eyes cat: and many of the others published at the Emoji Cheat Sheet they’ll be converted into the appropriate emoji

character, like @ and ¥ when you finish editing.
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Markdown Images

0 :smj o
% smile_cat
& smiley

% smiley_cat
W smiling_imp
G5 smirk

&2 smirk_cat

Helpfully Curio will show you an autocomplete popover as you start typing. For example type :s and the popover will show all the
markdown emojis codes that start with s , type an « after, so you’ve typed :sm , and you’ll see options like smile and

smiley cat . Use the arrow keys to choose one and press Return and the word is autocompleted for you and the ending
appended if necessary.

Markdown Images

Curio supports markdown’s image syntax like this:
! [Curiota icon] (https://www.zengobi.com/images/curiota32x32.png)

When you finish editing your markdown, the specified image references are rendered into the resulting rich text figure that appears
on the idea space.

You can also specify a local file-based image reference like this:

Here is an image ! [Butternut] (file:///Users/gbrowning/Desktop/Butternut.jpeqg)

Mac App Store Restriction
Only secure nttps links are supported for images as insecure nttp links are not allowed.

Image Size

While there isn’t an official standard method for overriding an image’s size in markdown, Curio supports this popular syntax:

* I[title|20x50] (image.png) = Size the image to 20x50
* 1[title|20] (image.png) = proportionally size the image to a 20 pixel width
* 1[title|x50] (image.png) = proportionally size the image to a 50 pixel height

Image Retrieval

It is important to note that a text figure’s markdown syntax is parsed and rendered dynamically by Curio when it loads an idea space
or when the text content is changed. Any referenced markdown images are retrieved during rendering, as there are no embedded
images within the text figure.
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Markdown Lists

This retrieval is a synchronous action, with a 15 second timeout, as it could impact the layout of other figures on the idea space, and

needs to be completed before exporting, printing, or presenting, as well. You can remove the timeout to wait indefinitely, or set a
negative timeout if you don’t want it to retrieve any images.

Curio uses a standard shared URLCache configured with a 10MB memory cache and 50MB disk cache to minimize repeated
downloads from the internet. For markdown image retrieval Curio uses the default caching policy, thus paying attention to HTTP

caching and expiry headers from the server, although there are other options which you can set. You can enable logging to learn
more.

If you wish to statically store an embedded image into a Curio text figure, instead of dynamically retrieving it via a markdown image
URL, then it would be better to simply copy the image from a browser page or elsewhere and then paste it into text figure,
permanently embedding it within the stored rich text.

Markdown Lists

Curio text figures support bulleted and numbered inline markdown lists, like these:

#### Simple
- Flight tickets
- Are we on Southwest this time?
— Hotel confirmation number
- 783729293
- Don’'t forget *passportsx!

#### A Mixed List
1. Pack bags
1. Get new swimsuit
1. Sunscreen
1. Reserve rental car
* Ask Dan for suggestions
* Get a convertible!
1. Put newspaper and mail on hold.

And here are the results when rendered:

Simple

* Flight tickets

> Are we on Southwest this time?
* Hotel confirmation number

° 83729293

» Don’t forget passports!

A Mixed List

1. Pack bags
1. Get new swimsuit
2. Sunscreen
2. Reserve rental car
> Ask Dan for suggestions
> Get a convertible!
3. Put newspaper and mail on hold.
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Markdown Checklists

Tip
Use the handy Format > Markdown > Bulleted List / Numbered List menu to convert selected lines of text (even another type of
list) into a bulleted or numbered list.

Markdown List Notes

Curio’s markdown list rendering matches match popular renderers such as Obsidian and Github-Flavored Markdown apps:

« If spaces are used for indention Curio now dynamically determines the number of spaces instead of assuming 4 (based on
the number of spaces used for the first indented item it finds). For example, ChatPT outputs lists with 2 spaces. Note that
tabs are also supported, of course.

« List items can now have subsequent following lines lines that are rendered with “soft returns” directly under the current item.
Any preceding whitespace is ignored for these lines.

« Lists will be rendered with gaps between list items if any markdown list item has a blank line between them.

Markdown Checklists

Curio supports the markdown extended syntax for checklists as either an inline checklist within a text figure or converted into a

native Curio list collection figure.

A markdown checklist looks like a normal bulleted list but uses [ ;7 and [x] to indicate unchecked and checked items,
respectively.

- [ ] Checklists are fun.
- [x] A checked item.
- [ 1 An unchecked item.

Inline Checklist

You can create a text figure which includes one or more inline checklists and Curio willrender [ 1 asOand [x] as . You can
even click to toggle the rendered checkmarks and it will change the underlying markdown syntax.

Here is a very cool markdown text figure,

Here is a *very* cool markdown text with i cheeklist]

figure, with an inline checklist!

“Things We Need** Things'We Neexd
- - [X] We need *one* dog IR We need one dog
- [ ] Perhaps *two* cats O Perhaps two cats
- [ 1 *Three* fish can fit in the tank O Three fish can fit in the tank
- [X] Plus *four* chickens in thel coop Plus four chickens in the coop
Pretty nifty, huh? Pretty nifty, huh?

Since any text figure can include an inline checklist this means nodes in a mind map figure or cells in a table figure can include
checklists as well!
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Markdown Dashed Lists

Checklist Shortcuts

Instead of typing - [ 1 and - (x] you can type this instead:
+ Begin a new line with x then press spacebar and it will be replaced with - [ 1 (disable).
* Begin a new line with ] then press spacebar and it will be replaced with - [ | (disable).

« Begin a new line with (x] then press spacebar and it will be replaced with - [x1 (disable).

Tip
Use the handy Format > Markdown > Checklist menu to convert selected lines of text (even another type of list) into a
checklist. There’s also a menu item and shortcut to toggle the checked state of selected lines.

Limitations

* The checklist line items aren’t treated as individual figures within Curio so can’t be tracked by the Status shelf or synced to
Calendar, but they’re perfect for simple checklists mixed in with other markdown content.
+ To abide by the markdown extended syntax, prefixes like bullets and numbering are ignored for checklists.

Inline Checklist Styling

If you have Curio Professional you can customize the style of lists by using master markdown styles.

Native List

Alternatively you can paste or import a markdown list onto the idea space and it can be converted into a native Curio list collection
containing individual checked or unchecked text figures.

My List
00 w test.md o @ Wenecedonedog
- [x] We need *onex dog
- [ ] Perhaps xtwox cats - * @ Perhaps: two cats
- [ ] xThreex fish can fit in the tank e (O Threefish can fit in the tank

[x] Plus xfourkx chickens in the coop

And, when exporting a Curio list collection figure as markdown the appopriate checklist syntax will be used for checked/unchecked
items within the list.

Markdown Dashed Lists

Markdown traditionally renders either = or - as a bulleted list item. However, using the Format > Markdown > Support Dashed
Lists menu item you can optionally enable or disable - for dashed lists for the current project or for all projects.

Apple Notes users in particular may like this as both Notes and Curio use the same + and - characters and {787 and {738
shortcuts to create bulleted and dashed lists.

This distinction is only visible within Curio. When exporting and rendering in a traditional markdown viewer, dashes will render as
bullets as normal.
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Markdown Tables

By default, any text figures that back to an external markdown file (aka file-backed text figures or sync file figures) will continue to

render as bullets within Curio, however you can enable dashed lists for these as well.

When support for dashed lists is toggled Curio will automatically regenerate updated previews for all idea spaces in the current
project. This doesn’t happen automatically in other projects but can be forced by holding Option and choosing Help > Advanced >
Regenerate All Idea Space Previews.

On a related note, normally Format > Markdown > Bulleted List uses +* by default but this can be customized to one character
when dashed lists are disabled and a different one when dashed lists are enabled, if you wish.

Markdown Tables

Curio supports the markdown extended syntax for tables as either an inline table within a text figure or converted into a native Curio

table collection figure.

Inline Table

You can create a text figure which includes one or more inline tables:

A simple inline markdown table:
A simple inline markdown table:

N Al
| Name | Age | aine i
Ol---1--1 0O — Marshmallow 15
| Marshmallow | 15 |
| Kitty Man | 121 Kitty Man 12

Markdown tables also support column alignments.

Here’s a more sophisticated example with alignments and custom table stylings supported by Curio Professional:
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Markdown Tables

An example with alignments plus a custom style:

| Counter | Code | Name | Comment | Sold | Emotion |

RS IR R I Y R

11173630 | Smogs | **Bestseller** | 13 | :raised_hands: |
12186853 | Flogs | New release | 10 | :baby: |

12117497 | Progs | *Fast* riser! | 12 | :chart_with_upwards_trend: |
13155343 | Trogs | Lackluster | 71 :-1:1

I'1'11Totall1301 I

O

An example with alignments plus a custom style:

73630 Smogs Bestseller e

2 86853 Flogs New release 10 &

2 17497 Progs Fastriser! 12 ked

3 55343 Trogs Lackluster 7 N
Total 30

Tip

Use the handy Format > Markdown > Table menu to convert the selected tab-delimited lines of text into a markdown table
(where columns are indicated via tabs). The first line is assumed to be a header line. This technique is a much easier way to
create markdown tables! If already a markdown table then this menu will convert it back into tab-delimited lines of text.

Inline Table Styling

If you have Curio Professional you can customize the style of tables by using master markdown styles.

For instance, here is the style sheet used to style the table above:

table-cell = border-color:#d4d9dd;

table-cell-odd = cell-color:#f6f8fa

table-cell-header = cell-color:#666666; border—-color:#d4d9dd; font-color:#ffffff; font-size:14; font-bold:1
table-cell-footer = cell-color:#dddddd; font-bold:1

table-cell-left = cell-color:#eeeeee

table-cell-right = cell-color:#eeeeee

Native Table

Alternatively you can paste or import a markdown table onto the idea space and it can be converted into a native Curio table
collection containing individual text figures for each cell in the markdown table. Specified column alignments are supported.

And, when exporting a Curio table collection figure, markdown table syntax will be generated automatically.
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Markdown Block Quotes

Markdown Block Quotes

Markdown formatted block quotes using the greater than sign (“>") is also supported.
> Stay hungry, stay foolish.
And here are the results when rendered:

Stay hungry, stay foolish.

Tip
Use the handy Format > Markdown > Block Quote menu to toggle the selected lines of text into a block quote.

Block Quote Styling

If you have Curio Professional you can customize the style of block quotes ( > ) by using master markdown styles.

Markdown Code Blocks

Using a 3-backtick code fence you can define code blocks. Type the following into a text figure:

// Hello world!
import Swift
print(“Hello world!”)

And here are the results when rendered:

// Hello world!
import Swift
print("Hello world!")

Note that content within code blocks and inline code syntax is not interpreted by Curio and is simply output as-is. Thus code
containing asterisks, dashes, brackets, hash marks, etc, can all be safely used without worrying about inadvertently changing font
attributes or creating lists, wikilinks, tags, etc.

Tip
Use the handy Format > Markdown > Code Block menu to toggle the selected lines of text into a code block.

Code Block Styling

If you have Curio Professional you can customize the style of code blocks ( ) and inline code ( )by using master markdown

styles.
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Markdown YAML Front Matter

Curio’s markdown renderer ignores any YAML front matter at the beginning of your markdown.

Markdown Text Figure Limitations

While Curio’s text figures have impressive support for most common markdown syntax, they are rendered as rich text, not as HTML
content, so this limits Curio’s ability to support markdown’s more advanced features.

They aren’t meant to be a replacement for a full-featured markdown apps like Marked and MultiMarkdown Composer that render

markdown syntax into an HTML web view using more advanced parsers, apply customizable CSS style sheets, and support on-the-
fly inline equation generation.

Markdown Previews Using Marked App

Using the View > Stream Selected to Marked menu item the contents of the selected figure(s), or the currently edited figure, or the
currently edited markdown document in the Organizer, is streamed in markdown format to the Marked app for instant preview.

Text Figure Attachments

You can attach a file to a text figure which can be useful in a number of situations, such as associating a Microsoft Excel document

file with a mind map text node.

If the file attachment is an image file type, then the resulting attachment will be displayed as a preview image, otherwise for other file
types a thumbnail icon will be displayed for the attachment image. The size of the image or icon is controlled using the Icon Size
slider in the Shape inspector popover’s Options tab.

As with preview captions, the attachment is an actual component of the text figure, not a trick using a grouped figure. This feature is
particularly useful in mind maps where an attachment can be associated with an existing node in the mind map instead of added as
a separate child node.

Attach an External File Located on Your Hard Disk to a Text Figure

+ Right-click on a text figure and choose Attach File then choose a file from anywhere on your hard disk in the dialog that
appears. This file can be copied or moved into the project as an embedded asset or referenced as an alias.

Attach an Image from Outside of Curio to a Text Figure

1. Copy an image from outside of Curio, perhaps from Safari for example.
2. Right-click on a text figure and choose Paste As > Attachment For Selected Text Figure. The image will be added as a new
asset to your project and will be displayed as an attachment for the text figure.

Attach a Existing Asset to a Text Figure

1. Select an existing asset figure on an idea space or an asset in the Library and copy it to the clipboard.
2. Right-click on a text figure and choose Paste As > Attachment For Selected Text Figure. Here the attachment will simply
reference the same underlying asset.
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Multimedia Figures

Change the Size of the Attachment Icon

+ Use the icon size slider in the Display panel of the shape popover inspector.

Remove a Text Figure Attachment

* Right-click on a text figure and choose Remove Attachment.

Multimedia Figures

You can play back videos, music, and sounds directly within an idea space.

Playing a Video or Audio Multimedia Figure

1. Double-click the figure to begin playback, or click the Play button on the media bar.
2. To stop playback, click the Stop button on the media bar.

Media Controls

When you click on a multimedia figure notice media controls appear on the right side of the inspector bar next to the navigator

controls.

These media controls can be used to control playback of the multimedia figure with common operations like play, pause, fast
forward, and rewind. If you need more control of the playback then right-click and choose Open With Finder to open the media file
in QuickTime Player.

Action Button

The media controls includes an action button with additional functionality in its popup menu:

+ Start Time.
During playback of a movie or audio file, pause the playback then, if necessary, use the time scrubber (or arrow keys) in the
media player’s overlay controls to find a precise moment. Then set the current time as the new starting time for the media
file.
+ Stop Time.
Similarly you can specify a stop time for the movie or sound file.
* Loop.
You can specify that the media playback continuously loops during playback.
* Poster Frame.
You can set a new poster frame for a movie, which is displayed before the movie begins playing.
+ Copy Frame.
Grab the current frame of a movie as an image for pasting within your idea space or elsewhere.

During Playback

If the media asset figure is rotated, then it will automatically change to a 0° angle of rotation for playback, then return to its original
rotation angle when playing stops.
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Inline Movie Controls

Inline Movie Controls

Inline movie controls appear briefly on top of the media playback when it first starts and if you move the mouse over it. You can use
these controls to scrub to a specific location.

URL Figures

Curio supports URL figures which can be displayed as simple URL links with icons, as web preview figures, or as live web views so

you can surf within Curio itself.

Creating URL Figures

Copy or drag an URL from your browser’s location bar and place it directly on an idea space to create an URL figure.

Curio will attempt to download the referenced URL and parse out any specified OpenGraph meta information including image,
description, and title.

By default Curio will automatically choose how to display the URL figure based on the information retrieved from the page. If
OpenGraph meta information exists Curio will construct an image figure using the OpenGraph image with the OpenGraph
description as the image caption.

If no OpenGraph image is found then a normal link figure with icon is displayed. If the site favicon can be retrieved then that is used
in place of a generic URL icon.

You can turn off this automatic preview vs icon determination if you wish, then Curio will create URL icon figures by default, unless

overridden with styles as described below.

Double-clicking the URL figure or right-clicking and choosing Open Link in Browser will launch the URL in your browser.

URL Figure Display Options

Generally when you drag or paste an URL into Curio it will create an asset figure in preview mode, if OpenGraph meta data is found
on the page. The caption of the preview will use the OpenGraph title (no title, max length), description, and URL (no URL).

Otherwise, if no OpenGraph meta data is found it is added in icon mode.
Right-click on an URL figure to switch between icon, preview, or live web view modes.

If preview mode is specified for an URL figure with no OpenGraph meta info then a generic web icon is displayed.

@ Zengobi Curio - Note Taking, Mind Mapping, Brainstorming

-120/423 - Copyright © 2025 Zengobi, Inc.


https://ogp.me
curio://defaults-write?Auto%20WebURL%20Preview=no
curio://defaults-write?URL%20Figure%20Static%20Preview%20Use%20Description%20Title=no
curio://defaults-write?URL%20Figure%20Static%20Preview%20Use%20Description%20Title%20Len=0
curio://defaults-write?URL%20Figure%20Static%20Preview%20Use%20Description%20URL=no

URL Figure Display Options

I TTTTLEF

Zengobi Curio

Curio is an amazingly powerful note taking, mind mapping,
brainstorming, and task management digital notebook
application for macOS.

www.zengobi.com
Curio Blog Forums Support y ( What's New> (Download) (Pricing)
w

Add a Splash of
Color.

A new rainbow of custom app icons

for Curio Standard and Professional
sustainers to enjoy.

Disabling Auto Preview Mode

If you right-click on an URL figure and switch it to icon mode Curio will remember this state as the default and future pastes or
drops will also default into icon mode.

If you right-click and change an URL figure to preview mode then Curio will automatically re-enable automatic preview detection for
future pastes or drops and use it if OpenGraph data is found.

You can permanently disable auto preview mode detection.
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URL Figure Styles

URL Figure Styles

Use the Format menu to create figure styles for URL figures shown in preview mode, including caption background color and text
color. All URL figure preview styles are grouped together in their own style category.

When you set a new default style for URL figures displayed as previews Curio will also store the size of the selected figure and use
that size as the new default for future URLs dragged into Curio.

Live Web Views

If an URL figure is displayed as a live web view then Curio will construct a live web browser embedded within the idea space
allowing you to browse a site from within Curio. If a web view figure is selected, the inspector bar displays the appropriate web
browsing controls.

Note: The following is for web view figures that exist on an idea space. If you drag a URL to the Organizer then the browsing tools
on the inspector bar are always available as the web view completely fills the content area of the Curio window. For more
information, see the section on Organizer Documents.

Tip
There are some advanced settings you can use to change the live web view’s user agent if you wish.

Activated state

When you first create a live web view it is activated and rendered live.

If the web view is in a deactivated state then after clicking the Start Browsing button or by double-clicking the web view, the web
view is activated and the view is rendered live.

You can now interact with the web site by clicking, dragging, and typing within the web view.

You are able to browse around within the live web view and even surf to different locations. However, the default URL associated
with the web view will stay as-is unless you click the Save URL button in the inspector bar.

Click Stop Browsing when you are done. This will happen automatically if you go to another idea space or close the project.

Deactivated state

When in deactivate state, the web view displays a slightly faded preview of the web URL so you realize that it’s not a live connection
to the web site. The preview was generated and stored the last time you surfed to that location.

When in this mode it acts as a normal figure where it can be easily moved, resized, and various figure attributes can be changed in
the inspectors.

You can right-click and choose Open Link in Browser to launch the URL in your browser.

Resizing and Moving

You can resize the resulting embedded web view by dragging on the figure’s selection handles. The figure will resize proportionally
maintaining the video’s aspect ratio.
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Grab Web Archive

Since clicks within the live web view bounds are processed by the embedded web content, it’s a bit tricky to move the figure, so
here are some tips:

 You can move an activated, live web view if you click and drag on the very edge of the frame, or
« First click Stop Browsing in the inspector bar, which deactivates the live web view, and then you can click and drag from
anywhere in the figure bounds. Click Start Browsing or double-click the figure to activate the web view control again.

Grab Web Archive

In the right-click context menu for the URL figure you can choose Grab Web Archive to download the contents of the weblink as a
paginated PDF, a PDF image, or a web archive (which can be opened with Safari). This new figure will be created and placed
alongside the selected URL figure.

Note that Curio is unable to grab a web archive for sites that require a user name and password entered via popup dialog. Also note
that Curio from the Mac App Store doesn’t support remote, insecure nttp web links when retrieving web archives.

Mac App Store Restriction

Remote, insecure nttp connections are not supported in embedded web view figures, as Organizer documents, as Sleuth
sites, or during web archive or favicon retrieval. However, you can create insecure nttp web link figures and figure actions,
which will open in your default browser.

PDF Figures

When you drag a PDF file to your idea space Curio will construct a PDFView to render the PDF and permit annotation. If a PDF

figure is selected, the inspector bar displays the appropriate PDF navigation and annotation controls.

Note

The following is for PDF figures that exist on an idea space. If you drag a PDF to the Organizer then the annotation tools on the
inspector bar are always available as the PDF completely fills the content area of the Curio window. For more information, see
the section on Organizer Documents in this user manual.

Tip
You may also want to check out Curio’s amazing Spread PDF feature!

Deactivated State

Normally the PDFView displays the contents of the PDF but the annotation tools in the inspector bar are not enabled. When in this
mode it acts as a normal figure where it can be easily moved, resized, and various figure attributes can be changed in the
inspectors.
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Activated State

Activated State

After clicking the Start Annotating button (or Option-double-clicking) the PDFView is activated and the annotation controls become
available in the inspector bar. By carefully grabbing the border area the PDFView can still be moved and resized. However, you can
now interact with the PDF by clicking and dragging within the PDFView.

Click Stop Annotating or press the Escape key when you are done annotating the page and the updated PDF will be saved to disk.

Annotation Tools

Select text within the PDF and use the annotation tools in the inspector to apply highlighting colors, strikethrough, or underline.

Only the PDF annotation tools on the inspector bar can create annotations that are embedded within the PDF itself. Anything you
create on top of or around the PDF figure using any other Curio features — such as text figures, images, scribbles, lists, mind maps,
etc. — are not stored within the PDF and only exist on the idea space.

If you need more annotation tools than what Curio offers you can double-click on the PDF figure to launch the PDF file in your
default PDF viewing application. After annotations are made, returning back to Curio will cause the PDF to refresh itself on the idea
space to reveal those new annotations.

Resizing and Moving

You can resize the resulting embedded PDFView by dragging on the figure’s selection handles. The figure will resize proportionally
maintaining the video’s aspect ratio.

Since clicks within the PDF view bounds are processed by the embedded PDFView, it’s a bit tricky to move the figure, so here are
some tips:

* You can move the PDF view if you click and drag on the very edge of the frame, or

« First click Stop Annotating in the inspector bar, which deactivates the embedded PDFView control, and then you can click
and drag from anywhere in the figure bounds. Click Start Annotating or double-click the figure to activate the PDF view
control again.

Working with PDF Figures

Some tips when laying out and working with your PDF figures:

» Make sure to size them so they are somewhat readable, altough they don’t need to be too large because you can zoom into
them.

 For example, use the Smart Zoom feature so can double-tap to quickly zoom into a PDF figure for reading and annotating
then double-tap again to restore your zoom.

+ While PDF figures should be quick to render, keep in mind that dozens of PDF figures or PDF’s with pages containing
complex fonts or embedded graphs can be slow to render.

* You can extract a selection of text from a PDF figure and paste it on the idea space as a new text figure, complete with a
jump action link to the original selection in the PDF, via Copy As Jump Target.
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Equation Figures

Equation Figures

Create and edit equations using LaTeX, AsciiMath, or MathML syntax. Previews are instantly rendered as you type your equation.
When you click to Insert or Update the equation the final high quality and scalable PDF rendering occurs instantly.

Curio renders your typed equations using MathJax, the de facto standard in web-based equation typesetting for mathematics,
science, and engineering. MathJax allows you to type that in one of three standard equation syntaxes:

» LaTeX
x=\frac{-b\pm\sqgrt{b”*2-4ac}}{2a}
* AsciiMath
x=-b+- sqrt (b"2-4ac}/ (2a)
+ MathML

<math ...</math>

Of the three, LaTeX is the most popular by far.

Important

Curio dynamically loads the MathJax JavaScript and style sheets via the internet and renders your equation in the equation
editor’s web view. Therefore connectivity to the internet is required to render equations. Once the images have been
rendered as images and placed into the idea space the internet connection is no longer required.

Inserting an Equation Figure

To insert an equation figure:

1. Double-click a text figure to begin editing.

2. Choose the Insert > Equation menu item (~$E) or click the Insert toolbar button then choose Equation.

3. Use the equation editor to enter your equation. A preview area below shows what your equation will look like.
4. Click Insert to insert a PDF rendering of the equation on the idea space.
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Inserting an Equation Figure

Edit your LaTeX, MathML, or AsciiMath equation: = = = Mathlax ?
x=\frac{-b\pm\sqrt{b~2-4ac}}{2a}|
b+ /b — 4ac
TrT=
2a
Cancel Insert

\ J

Help with Equations

Click the help button in the equation editor window to see the popup menu displayed here. It includes several examples in LaTeX,
AsciiMath, and MathML form, and includes links to several useful websites for more information.

Tip
If you have a mix of Retina and non-Retina screens then the macOS web framework has some oddities with scaling which may
result in an empty inserted equation. The Equation Force Scale Local PDF advanced setting should fix it.

Equation Delimiters

Curio will assume an entered equation is LaTeX unless it finds one of the following in your typed equation:

S8
Indicates that this is a LaTeX (technically TeX) equation of the format ss ... ss
s \[ Or \{

Indicates that this is a LaTeX equation of the format \r ... \1 or \( ... \)
®* ‘'<br>Indicates that this is an AsciiMath equation of the format )
® <math

Indicates that this is a MathML equation of the format <math ... </math>

Alignment

By default equations are centered when rendered, although you can choose the left, center, or right alignment buttons can be used
to change this alignment.
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Inserting an Equation Figure

Complex Equations

Your equation can include other text, other equations, and even special color tags as demonstrated here:

)

Edit your LaTeX, MathML, or AsciiMath equation: = = = Ma"im

Note the use of color to highlight specific variables:

$$\color{red} X_{\color{blue} k} \color{green} = \color{orange} \frac{1}{N} \sum_{n=0}
~{N-1} \color{gray}x_n \color{purple} e~{\mathrm{i} \color{salmon} 2\pi
\color{yellowgreen}k \color{bittersweet} \frac{n}{N}}$$

These colors can be customized if you wish.|

Note the use of color to highlight specific variables:

These colors can be customized if you wish.

Cancel Update

Note that in this example the ss delimiters were explicitly used to surround that single equation in the middle of the surrounding
text so MathJax will recognize the equation.

If your equation content includes one or more inline equations mixed in with your text you should use \( ... \) delimiters, such

aS There are two solutions to \(ax”2 + bc + ¢ = 0\).

Everything entered will be rendered as a single PDF image figure that can be placed on your idea space.

Editing an Equation

Simply double-click your equation on the idea space to bring it back into the equation editor. Then click the Update button when
you finish your changes.
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Inserting an Inline Equation

Inserting an Inline Equation

To insert an inline equation within a text figure:

1. Edit a text figure and position the text cursor where you would like to place the inline equation.

2. Choose the Insert > Equation menu item (~$E) or click the Insert toolbar button then choose Equation.

3. Use the equation editor to enter your equation. A preview area below shows what your equation will look like.
4. Click Insert to insert a PDF rendering of the equation into the text figure as an inline image.

Here is an example text figure with two inline equations:

The Pythagorean equation can be written as an
equation relating the lengths of the sides a, b
and the hypotenuse c:

a’ +b* =c°

Solving for ¢ we find that the hypotenuse has

length of ¢ = v/a® + b* which will come in
handy with the following homework problems.

Inline Equation Sizing

The size of the inline equation is based on the font size of the surrounding text. lts baseline is also set to align it with the baseline of
the surrounding text.

Tip

While Curio will attempt to align the baseline as best it can, you can fine tune the baseline by selecting the equation image and
using the Format > Font > Baseline > Raise/Lower menu. If you do this often you may want to set up a keyboard shortcut via
System Settings > Keyboard > Shortcuts > App Shortcuts.

If you modify the figure’s text size using techniques such as the following, your equation will scale its size and baseline to match

automatically:

* Select the figure itself and use 8+ or &-.

* Select a range of text within the figure and use 3+ or &-.

+ Select the figure itself and use the inspector text size control.

+ Select a range of text within the figure and use the inspector text size control.

Inline Equation Limitations

+ Equation rendering is not done on-the-fly so it won’t discover and render inline equation syntax within existing markdown,
like if using file-backed text figures synchronized with Obsidian. Curio’s equation editor has to be used to create the equation
image, akin to the equation editor workflow in Pages and Keynote.

 They are not rescaled if a figure style is applied or modified or a master style is modified.

* They are not scaled within a markdown text figure based on a body master markdown font.
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Editing an Inline Equation

Editing an Inline Equation

Double-click a text figure to begin editing its text then double-click the equation image to edit the equation.Click the Update button
when you finish your changes.

Exporting Inline Equations

The inline equation is a PDF image attachment within your text figure so will be included automatically if you export as rich text. And
since we’re using the standard baseline attribute to adjust its vertical placement it should render correctly in other editors that
adhere to that standard such as TextEdit.

If you export as markdown then instead of the image the actual MathJax equation syntax will be output within ss delimiters,
unless your equation text includes its own delimiters. That way any markdown renderer with Mathdax support will render it on-the-
fly correctly.

Table of Contents Figure

Curio Professional and Standard customers can now insert a Table of Contents as a native Curio list or mind map collection. This

collection is dynamically generated and dynamically updates if changes are made to your project’s Organizer hierarchy.

Dynamic Content

It’s important to remember that the information in the Table of Contents is dynamic and not a static snapshot. If you modify any
items within the Table of Contents or their expand/collapse states then this will be reset the next time it has to regenerate.

If you drag the idea space containing the Table of Contents to a different location in the Organizer it will regenerate itself based on
its new placement. Similarly, a duplicate or copy/paste of the idea space containing the Table of Contents will regenerate based on
its new placement.

Of course, the specified Table of Contents style will be kept between regenerations.

Create a Table of Contents Figure

1. Insert a Table of Contents either via the Insert main menu or the Insert toolbar button.

2. Alist or mind map collection is inserted into the current idea space and automatically populated. The collection is comprised
of idea space link figures, displayed in icon mode, to all Organizer items after the idea space that contains the Table of
Contents itself.

3. Clicking a link will jump to that idea space in your project. If you export your project as PDF, then clicking a link in the
exported Table of Contents will jump to the appropriate page within the PDF.
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Table of Contents Inspector

Managing the Contents of the Table of Contents

The hierarchy included in the Table of Contents is based on where its containing idea space is located in the Organizer:

1. If the next Organizer item after this idea space is a child, thus this idea space is a parent, then the Table of Contents is of
those children, recursively. This option, in particular, is useful if you’d like to create multiple Table of Contents within the
same project or section.

2. Else the Table of Contents is made up of the siblings that come after this idea space and the children of those siblings,

recursively.

Styling the Table of Contents

1. Table of Contents collection is made up of standard idea space link figures, displayed in icon mode. The containing list or
mind map collection can be styled with any bundled or personal list or mind map style simply by choosing the style from the
inspector style galleries.

2. You can also customize the collection then use Format > Set as Default Style to store that as the new default style. For
example, choosing Format > Set as Default Style for List (Table of Contents) Figure will make it the new default for list Table
of Contents.

Updating the Table of Contents

1. The titles and previews of the idea space link figures which make up the Table of Contents will update automatically if
changes are made to their destination idea spaces.

2. And, when the Table of Contents idea space is revisited, either manually or when exported or printed, the Table of Contents
will automatically determine if it contains an out of date hierarchy and regenerate itself, if necessary.

3. You can also press the Regenerate button in the Table of Contents inspector to force a regeneration.

Table of Contents Inspector

Select a Table of Contents then click its inspector icon in the inspector bar to change the following attributes.

+ Text Only Starting at Level
By default, Curio includes previews until hierarchical level 3 when it switches to text only entries.

« Collapse at Level
By default, Curio automatically collapses the 2nd hierarchical level in the Table of Contents. If you’d like to see more, simply
click a parent’s expand widget to see those child items.

* Include up to Level
By default, Curio includes the first 3 hierarchical levels in the Table of Contents. For complex projects, reducing the number
of levels can make generation faster. Note that Curio may throttle the specified value if a massive number of entries would be
created, see below for more details.

The Table of Contents detects when it needs to be regenerated automatically, but you can click a button here to force a refresh.
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Line Figures

Line Figures

Creating Lines

Lines can be created in many ways including:

* The main menu’s Insert > Line submenu,
* The Line Tool,

+ [dea Graphs,
* The Insert Basic Shapes gallery.

Styling a Line

1. Use the Shape inspector to change the pen color (aka border color) and pen pattern.
2. Use the Line inspector with more options specific to lines such as scaling, and head and tail arrowheads.
3. Right-clicking on a line allows you to quickly change multipoint lines between straight, curved, and orthogonal line styles.

Sticky Lines

1. Make sure Sticky Lines is checked in the Arrange menu. If not, select it to enable the sticky lines feature.
2. Drag the endpoint or midpoint on the line.
3. As you hover that point over another figure, you can stick to specific points on the figure:
1. Specific Connection Point
If you hover and release on a specific connection point along the edge of the figure then it will stick to that specific
connection point even if the connecting figures are rotated or moved.
2. Closest Connection Point
If you hover and release close to but not on a connection point along the edge of the figure then it will dynamically
connect the line to the closest connection point, potentially connecting to a new connection point if the connecting
figures are rotated or moved.
3. Towards the Center
Otherwise if you hover and release along the edge of the figures away from any connection points then it will connect
against the edge of the figure pointing towards the figure’s center.
4. Specific Position
If you hover and release anywhere else within the figure or if you hold the Command key, then it will stick to a specific
position on the figure. Note the position will scale appropriately if the figure itself is scaled. Also note that if you stick
a line to a position on another line it will also scale if the line is scaled.
5. Non-Sticky Point
If you press the Control key the figure will stop glowing and the line will not stick to the figure at all. The Control key
temporarily disables the sticky feature.
4. As described above for multipoint lines, if you also hold down the ~\- key during the creation of a new line then you can
create a multipoint line on-the-fly where any of the points on that line can be stuck to other figures using the normal sticky
techniques. Note this Option key trick only works when dragging out brand new lines, not editing existing lines.

Sticky Curved Lines

If you use a sticky line to connect two figures, and the line is a curved type with no midpoints then Curio will internally create the
midpoints necessary to render an elegant, swoopy curved line.

If you add midpoints then Curio will curve the line through those defined points instead.
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Idea Graphs

Adding and Removing Midpoints

* Right-click on a line to quickly add a midpoint at the given click location.
* Right-click on a midpoint to remove it.

You can also use the main menu’s Insert > Line > Midpoint menu item to insert a midpoint into a selected line.

Adding a Label to a Line

1. Double-click on a line figure to create one or more text figures which can act as line labels. These text figures are just like
regular Curio text figures, thus they support the same formatting features, but they are stuck to the line.

2. You can slide a text figure up and down along the line using the mouse or the arrow keys to reposition it. Using the arrow
keys on the keyboard is generally more accurate especially for curved lines. You can also hold Shift while pressing the
arrow keys to move the label in larger steps.

3. To remove the label, select it and press the Delete key.

Idea Graphs

Sometimes you need more flexibility than a mind map. Fortunately Curio makes it incredibly easy to quickly create a flowchart or

freeform graph of figures connected together with line figures. Curio calls these Idea Graphs.

An Example Workflow

Create a text figure, hold & and click to a blank area on your idea space, and instantly a new text figure will be created at that
location with an automatic sticky line between the previous and new text figures.

These automatically created lines are true Curio line figures so you can change the line color, dash pattern, width, and arrowheads
using the inspector controls. You can also double-click on a line to add line labels, or right-click on a line and add one or more
midpoints to make it a curved or orthogonal line.

Creating Idea Graphs

There are 4 ways to create idea graphs within Curio.

Tip
There are a number of advanced settings you can set for idea graph lines to change their default style including color; dash

pattern; straight, curved, or orthogonal; auto added midpoint; head and tail decoration; and much more.

1. Via Insert > Line

1. Select two figures.

2. From the main menu choose a type of line under the Insert > Line submenu including nondirectional, directional, or
bidirectional.

3. A sticky line will be created going from the first figure you selected to the last figure you selected.
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Creating Idea Graphs

2. Via Figure Resize Handles

1. Select an existing figure.
2. Hold ~c and click and drag on any resize handle.
3. This will create a directional line (one arrowhead, —) allowing you to quickly connect it via Sticky Lines to another figure.

3. Via Command Clicks

1. Edit or select an existing figure.
2. Click on the idea space background while pressing one of the following modifier key combinations:
o 8: directional line (one arrowhead, —)
° 81" (Command-Shift): bidirectional line (two arrowheads, —)
o ¥~ (Command-Option): nondirectional line (no arrowheads, —)
° ¥ 21 (Command-Option-Shift): nondirectional dashed line (no arrowheads, )
3. A new figure will be created and joined to the currently selected figure with the appropriate line.

Pinboard Exception

Technically you can make these types of connected figures within one specific type of collection: a pinboard. Just drag one figure
on a pinboard on top of another figure while holding one of the key modifiers above.

The resulting line will connect the two figures and move if either figure is moved. If both figures are within the same pinboard then
the line itself will be owned by the collection so moving the pinboard will move the connection line, as well.

Collection Figures

Note that if the Select tool is active in the toolbar, and the currently selected item is a collection figure (such as a list, mind map,
table, or index card), then the created connected figure will be that same type of collection. Using this technique you can quickly
create a connected graph of index cards, for example.

However, if the Text tool is active instead then the created connected figure will always be a text figure. This way you can easily
create a text figure connected to a collection.

4. Via Drag and Drop

This drag-and-drop method will work on the idea space but not within collections:

1. Drag figure A on top of figure B and, before dropping, press and hold one of the following modifier key combinations and the
mouse pointer change to a little curly icon:
o 3: directional line (one arrowhead, —)
° #{ (Command-Shift): bidirectional line (two arrowheads, )
° $~- (Command-Option): nondirectional line (no arrowheads, —)
> #8~\-{} (Command-Option-Shift): nondirectional dashed line (no arrowheads, )
2. Release the mouse and figure A will move back to its original position and the appropriate line will be created connecting
figure A to figure B.

-133/423 - Copyright © 2025 Zengobi, Inc.



Linking Figures

Linking Figures

Curio has several methods for linking figures together including jump actions, jump anchors, idea space links, hyperlinks, and

references.

Jump Actions

You can assign a jump action to a figure so that double-clicking that figure can navigate to a specific idea space or even a specific
figure — even in another project!

The figure will also get a little jump image adornment so it’s clear that a jump action is associated with the item. You can use the
Actions inspector to hide this adornment if you wish.

Set a Jump Action for a Figure via the Jump Popup

1. Select the figure to which you wish to assign the jump action.
2. Choose Format > Jump or press #J to bring up the jump popup.
3. The jump popup is based on the Quick Find popup which means:
o Start typing to find a figure’s text or idea space’s title via autocomplete then choose a result.
o Enter a query like @george Or due < 2w Of #active then choose a result.
o If you’ve copied a figure or idea space from the same project you can simply paste into the jump popup and the item
will appear in the results so you can select it.
o If you’ve copied a figure or idea space from a different project you can simply paste the curio:// hyperlink into the
jump popup and click Set.
4. After choosing a destination for the jump the popup will be dismissed and a jump action assigned to your figure.

Set a Jump Action for a Figure via the Clipboard

1. Select your jump destination: either a target figure within an idea space or a target idea space within the Organizer.
2. Choose Edit > Copy from the main menu.

3. Select the figure(s) to which you wish to assign the jump action.

4. Choose Edit > Paste As > Jump Action to set the jump action.

Opening a Jump Action

« Click on a figure’s jump action adornment.

* If the jump destination is within this project it will appear in the current view, if Option (~\J) is held when clicking it will open in
the opposite split view.

« If the jump destination is in a different project, the jump will open in a separate window or tab (depending on your System
Settings > Desktop & Dock tabs setting), if Option (~\) is held when clicking it will open within the current window replacing
the current project (reverse this).

Clear a Jump Action for a Figure

1. Select the figure and choose Format > Jump or press $J to bring up the jump popup then clear the current destination and
press Set.
2. Or, open the Actions inspector and click Restore Default.
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Wikilinks

Extract PDF Selection to Text Figure with Jump Action

You can extract a selection of text from a PDF figure and paste it on an idea space as a new text figure, complete with a jump action
to the original selection in the PDF.

1. Option-double-click a PDF figure on your idea space to begin PDF annotations.

2. Select a region of text within the PDF.

3. Choose Edit > Copy As > Jump Target.

4. Elsewhere in the project choose Edit > Paste and a new text figure will appear containing the selected text from the PDF. A
jump action to the original selection in the PDF figure will be automatically associated with the new figure. Clicking the
figure’s jump adornment will jump to the idea space containing that PDF and highlight that selection of text within the PDF.

Wikilinks
A wikilink is a special extension of markdown which looks like this [(apple ivMac]] when you’re editing but turns into a clickable
link to an inner-project jump destination when rendered.

Insert a Wikilink to Existing Destination

1. Edit a text figure.
2. Type 11 and the Format > Jump (88J) popup will automatically appear allowing you to find and select a destination figure or
idea space.
3. The jump popup is based on the Quick Find popup which means:
o Start typing to find a figure’s text or idea space’s title via autocomplete then choose a result.
o Enter a query like @george OF due < 2w OF #active then choose a result.
o If you've copied a figure or idea space from the same project you can simply paste into the jump popup and the item
will appear in the results so you can select it.
o If you’ve copied a figure or idea space from a different project you can simply paste the curio:// hyperlink into the
jump popup and click Set.
4. After choosing a destination for the jump the popup will be dismissed and the wikilink will be inserted into your text figure.
5. Note that markdown rendering will be automatically enabled for your figure if necessary.

The automatic jump popup when you type [ can be disabled so you would have to press $8J to bring it up.

The automatic trailing bracket 1 when you type a leading bracket [ can be disabled.

Alternative Title

Curio supports the [[titlelalternate title]] Wikilink syntax so if you don’t like the default title (which can be customized) you
can give it an alternate which will be displayed when rendered.

Link Storage

You might wonder where Curio is storing the hyperlink to the jump destination, after all it’s not visible anywhere. When editing the
hyperlink it is stored as a hidden rich text attribute across the wikilink. When rendered that attribute is turned into a standard rich
text link attribute so you end up with a clickable link.
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Wikilinks

Insert a Wikilink to New Idea Space

For the wikilink you can enter an idea space title that doesn’t exist yet and it will be automatically created as a sibling of the current
idea space the first time you click on it.

Via Typing

1. Edit a text figure.

2. Type 11 and the Format > Jump (88J) popup will automatically appear.

3. In the Jump popup, simply type a new title for your idea space and press Return or click the Set button. You don’t have to
choose an existing destination.

4. The title will be inserted into the wikilink brackets and the text cursor will be placed just after the wikilink.

5. Continue editing your text if you’d like then press Escape when you’re done.

6. The first time you click on the wikilink Curio will see if an idea space with that title already exists as a sibling of the current
idea space. If not a new idea space with that title will be created as a sibling. The wikilink’s URL will then be refreshed to

point to this idea space using its ID, which is more robust, and Curio will jump to that idea space.

Alternatively if you disable the automatic jump popup you can manually bring it up via J or simply type the new idea space title

directly within the wikilink brackets.

Via Text Selection

1. Edit a text figure.

2. Select a range of text within the figure that you would like to turn into a wikilink.

3. Type 1 and you’ll see that the selected range gets left and right brackets on either side of the selection. Press [ again to
get the second bracket to enclose the selection with the [([wiki1ink]] syntax.

4. Press Return to skip past the wikilink.

5. Continue editing your text if you’d like then press Escape when you’re done.

6. The first time you click on the wikilink Curio will see if an idea space with that title already exists as a sibling of the current
idea space. If not a new idea space with that title will be created as a sibling. The wikilink’s URL will then be refreshed to
point to this idea space using its ID, which is more robust, and Curio will jump to that idea space.

This automatic selection bracketing can be disabled. Instead you would manually enclose the text with leading (1 and

trailing 11 .
Pressing Return within a wikilink to skip past it can also be disabled.
Edit a Wikilink

1. Edit the text figure containing the wikilink.

2. Place the text cursor anywhere within the wikilink itself and choose Format > Jump or press $J to bring up the jump popup.

3. Use the jump popup to find and select a different destination.

If the text cursor is anywhere within the wikilink then pressing Return will skip past the end of the wikilink. This feature can be
disabled.

Opening a Wikilink

1. If editing, move the text cursor anywhere within the wikilink and press Enter (not Return) to open the wikilink.
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2. If not editing, make sure the figure is selected then click the wikilink to open it.
o If the jump destination is within this project it will appear in the current view, if Option (~\J) is held when clicking it will
open in the opposite split view.
o If the jump destination is in a different project, the jump will open in a separate window or tab (depending on your
System Settings > Desktop & Dock tabs setting), if Option (~\J) is held when clicking it will open within the current
window replacing the current project (reverse this).

Pressing Enter within a wikilink to open it can be disabled.
Wikilink Limitations

Wikilinks in File-backed Markdown Text Figures

There are some key points to consider if you plan to use wikilink syntax within file-backed markdown text figures. Note this

specifically applies to markdown ( .ma ) backing files not rich text files.

The markdown file format is plain text which means Curio can’t store wikilink URL information in rich text attributes. This imposes
limitations on what kinds of wikilinks Curio can dynamically reconstruct when it needs to render the markdown.

+ W4 Wikilinks to sibling idea spaces will work. Curio will automatically try to find an idea space with the wikilink’s title as a
sibling of the current idea space. If successful, it will dynamically construct a link to that idea space. If not, a new idea space
with that title will be created as a sibling when the link is clicked.

- X Wikilinks to other non-sibling idea spaces in the project or to figures in the project will not work, as Curio doesn’t have

enough information to reconstruct the link.

- /L If syncing your file-backed markdown files with Obsidian then keep in mind Obsidian does not allow the following
characters in markdown file titles: 4 ~ [ 1 | . This means if you’re creating a wikilink to an idea space you may not want to
use those characters in the idea space’s title. For example, a wikilink like [[curio is #1711 t0 an idea space with that title
wouldn’t work in Obsidian because it doesn’t allow you to create a markdown file named Curio is #1.md.

Markdown Jump Links

In contrast to a wikilink, which is a non-standard extension to the markdown syntax, you can also insert a standard markdown link

for your jump links.

The format is a bit more verbose compared to wikilinks [titie] (1ink) where the link is a visible curio:// hyperlink, however it is

standard markdown.

Insert a Markdown Jump Link

1. Edit a text figure, markdown should be enabled if it isn’t already.
2. Choose Format > Jump or press $J to bring up the jump popup.
3. The jump popup is based on the Quick Find popup which means:
o Start typing to find a figure’s text or idea space’s title via autocomplete then choose a result.

o Enter a query like egeorge OF due < 2w OF #active then choose a result.

o If you’ve copied a figure or idea space from the same project you can simply paste into the jump popup and the item
will appear in the results so you can select it.

o If you’ve copied a figure or idea space from a different project you can simply paste the curio:// hyperlink into the
jump popup and click Set.
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4. After choosing a destination for the jump the popup will be dismissed and a markdown link will be inserted into your text
figure.

The wikilink is of the form  [tit1e] (1ink) . If you don’t like the default title (which can be customized) you can easily change it by
replacing the contents of the (tit1e] portion.

Edit a Markdown Jump Link

1. Edit the text figure containing the markdown jump link.

2. Place the text cursor anywhere within the markdown link and choose Format > Jump or press #J to bring up the jump
popup.

3. Use the jump popup to find a different destination.

Rich Text Jump Links

If you prefer rich text to markdown then you can also insert standard rich text links to jump destinations.

Insert a Rich Text Jump Link

1. Edit a text figure, markdown should be disabled if it isn’t already.
2. Choose Format > Jump or press 3J to bring up the jump popup.
3. The jump popup is based on the Quick Find popup which means:
o Start typing to find a figure’s text or idea space’s title via autocomplete then choose a result.
o Enter a query like @george OF due < 2w Of #active then choose a result.
o If you’ve copied a figure or idea space from the same project you can simply paste into the jump popup and the item
will appear in the results so you can select it.
o If you've copied a figure or idea space from a different project you can simply paste the curio:// hyperlink into the
jump popup and click Set.
4. After choosing a destination for the jump the popup will be dismissed and a rich text link will be inserted into your text figure.

If you don’t like the default title (which can be customized) you can edit the link text.

Edit a Rich Text Jump Link

1. Edit the text figure containing the rich text jump link.
2. Place the text cursor anywhere within the link text and choose Format > Jump or press $J to bring up the jump popup.
3. Use the jump popup to find a different destination.

Backlinks

Once you’ve established a number of jumps to various destination figures or idea spaces you may wonder, given a destination, what
items link to it? Backlinks are jumps from other items to a given item.

Viewing Backlinks

1. Right-click on a figure or Organizer item.
2. In the context menu that appears, the Backlinks submenu will list all originating source figures by their title and location
within the project.
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3. Choose one of those backlinks and you will promptly jump to that figure within the project, if Option (~\) is held when clicking
it will open in the opposite split view.

Note these only list jumps within the same project, not from other projects, and won’t include hyperlinks since those can be placed
anywhere even outside of Curio.

Optional Backlink Adornment

Figures with backlinks can optionally show a link adornment if you’d like to make figures with backlinks more obvious. Then you can

click on the link adornment to quickly access backlinks, in addition to the right-click context menu technique, if Option (~\J) is held
when clicking it will open in the opposite split view. If a figure has references it's already showing the link adornment so Curio will
automatically show backlinks in that popup menu as well, regardless of this setting.

Renaming a Destination

If a jump destination figure or Organizer item is edited in a way that changes their link title then that change can propagate to all
backlink figures that have inline links to that destination. However, the change will not be made if the inline link’s title has been
modified by the user.

For example, if you have an idea space titled “Butternut” then rename it to “Peanut” then here’s what will happen to backlinked
figures that have inline links to that idea space:

Inline Link Type Before Rename After Rename

Wikilink [[Butternut]] [[Peanut]]

Same wikilink but with modified title [[My Dog]] [[My Dog]]

Same wikilink with alternate display title  [[Butternut|My Dog]] [[Peanut|My Dog]]
Markdown link [Butternut](curio://?i=87) [Peanut](curio://?i=87)
Same markdown link but with modified title [My Dog](curio://?i=87) [My Dog](curio://?i=87)
Rich text link Butternut Peanut

Same rich text link but with modified title My Dog My Dog

Jump Anchors

As an alternative to assigning a figure a jump action, you can use a jump anchor to jump to different locations. A jump anchor is a
small, unassuming icon you can place anywhere on an idea space. When double-clicked the user will jump to the destination
location.

Add a Jump Anchor

1. Select your jump destination: either a target figure within an idea space or a target idea space within the Organizer.

2. Choose Edit > Copy from the main menu.

3. Go to the idea space where you want to place the anchor.

4. Choose Edit > Paste As > Jump Anchor from the main menu.

5. Curio will create a jump anchor figure. You can click and drag this figure anywhere. You can also copy & paste it, duplicate it,
or change its attributes in the Inspector.

-139/423 - Copyright © 2025 Zengobi, Inc.


curio://defaults-write?Show%20Backlinks%20In%20Link%20Adornment=yes
https://
https://
https://
https://

Idea Space Link Figures

Idea Space Link Figures

You can also create links between idea spaces even from different projects by adding an idea space link figure. When double-

clicked the user will go to the destination idea space.

The new figure will display a preview of the represented idea space unless the represented idea space is the same as the idea space
on which it was placed or is from a different Curio project. If the represented idea space is the same as the idea space on which it
was placed, Curio will display a distinctive “you are here” icon. If the represented idea space is from a different Curio project, Curio

will display a distinctive “external project” icon.

Add an Idea Space Link Figure

1. Drag the idea space from the Organizer of a project window and drop it onto an idea space.

2. A new idea space link figure will be created with a preview of the represented idea space.

3. You can right-click on the resulting figure and choose “Show As Icon” then give the figure an appropriate title like “Click here
to learn more”.

4. The icon or preview image will automatically update as the destination idea space changes.

5. When displayed as icon, the title automatically reflects the idea space’s title and dynamically updates if that title is changed.
You are able to manually override the figure’s title with your own text if you wish and Curio won’t replace it. Later, if you’d like
it to reflect that actual idea space title again, simply remove all text from the figure’s title and Curio will replace it.

Hyperlinks

You can easily create hyperlinks to figures or idea spaces within a Curio project for use outside of Curio, for example in a browser
web page or another application. These are of the form curio:// .

If you have text selected within the selected text or PDF figure then the hyperlink will deep link to that selection. Similarly if you're

playing back a video or audio figure then the hyperlink will deep link to that start location.

Clicking the resulting hyperlink, whether it’s in Curio or another application, will tell Curio to jump to that project, that idea space,
and that figure, then set the selection of that text figure or PDF figure, or start playing back the media at that location.

Relative Hyperlinks

If the hyperlink is used within the same project then it’s a relative link and doesn’t include project information, as it's not necessary.

When exporting text as PDF, rich text, or markdown, local project hyperlinks, specified via rich text link attributes or markdown links
or wikilinks, are converted into longer absolute hyperlinks that include project information suitable for use outside of Curio.

Create a Hyperlink to an Idea Space or Figure

1. Select an idea space in the Organizer or figure within an idea space. You can also select a range of text within a text figure or
PDF figure, or start playing an video or audio figure, and the link will deep link to that selection or playback location.

2. Choose Edit > Copy As > Hyperlink.

3. Use it outside of Curio or even within Curio by selecting text and using the Format > Link menu (K). If you use it within a
text figure in the same project then the project path is removed automatically turning it into relative link so it will work even if
the project is moved or renamed.
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4. Clicking the resulting hyperlink, whether it's in Curio or another application, will tell Curio to jump to that project, that idea
space, and that figure, then, if appropriate, set the selection of that text figure or PDF figure, or start playing back the media
at that location.

Hyperlink Format

Here’s an example Curio hyperlink:
curio://Biology?p=WJzoFVMoS9i1t1l5LziCxeQ&f=6SbyZLCIR16AQIQx5qdPPA

+ All Curio project hyperlinks start with curio:// , which is our custom URL scheme.

« Next, if this isn’t a relative link within the project, is the name of the project.

« Next, if this isn’t a relative link within the project, isa p= variable with the project’s unique identifier (URL-safe base64
encoded) which is stored as @ com.apple.metadata:kMpItemIdentifier Metadata extended Finder attribute on the project
file. Using that identifier we can use Spotlight to find the project if it has been moved, renamed, or is now on another volume.
Note this only works if Spotlight is indexing the volume containing the project file. If you duplicate a project then it will also
have the same unique identifier.

+ Next there may be optional variables based on the type of link.

o i= the unique identifier to a specific idea space (URL-safe base64 encoded).

o £= the unique identifier to a specific figure (URL-safe base64 encoded).

° n= the page number of a PDF figure.

o s= the starting selection range for text or time for an audio/video recording figure.
o e= the ending selection range for text or time for an audio/video recording figure.

These terms may change as Curio’s hyperlink capabilities evolve.

OId Hyperlink Format

Our hyperlink format from Curio 14 through Curio 27 included an encoded path to the original file:
curio://$Projects/Classes/Biology.curio?p=WJzoFVMoS9i1t15LziCxeQ&f=6SbyZLC1R16AQIQx5qdPPA

However, even though we used special smart variables to simplify the path, it wasn’t as robust as just using the project unique ID
technique described above.

Resolving Hyperlinks

If Curio is unable to find the project based on the supplied link information, it will ask you to locate it via a standard Open dialog,
then remember that new location so future links to that project will work automatically.

Supporting Universal Links

In the future Apple may migrate custom URL schemes, like curio:// links to a new type of link created by Apple called a Universal
Link, such as:

https://www.zengobi.com/curio/link/Biology?i=y 6ticgKT16

Universal links are more secure than custom URL schemes as they are tied to a registered Internet domain, instead of a programmer
simply claiming a scheme potentially overriding someone else’s claimed scheme.
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While Apple will presumably support custom URL schemes indefinitely, so existing app links won’t break, we’ve taken these
preemptive steps in case Apple starts encouraging developers to do so:

* On Apple’s developer portal, we’ve declared that our Curio app (with its com.zengobi.curio bundle ID) supports universal
links and our registered domain is zengobi.com .

» We’ve added the https://www.zengobi.com/.well-known/apple-app-site-association file to our website declaring that Curio
handles universal links of the form: https://www.zengobi.com/curio/link/. ..

* The Curio app itself already knows how to handle universal links of that form.

+ On a user’s machine, based on the apps installed, macOS periodically queries and locally caches this site association
information so it immediately knows to launch Curio directly when clicking on a universal link.

Apple hasn’t shifted macOS to universal links yet, as they have on iOS, but we’re ready if they do!

Hookmark Integration

By default the popular Hookmark utility creates nook:// links to the current Curio project itself, not to the selected content within
the project.

However, if you want Hookmark to track curio:// deep links to a specific idea space or figure, or even to selected range of text
within a text figure or PDF figure, then you have two options:

1. Enable Hookmark’s Curio AppleScript integration which will make Hookmark use Curio’s AppleScript interface to retrieve

curio:// deep links for selected items.

2. Or, use Curio’s Copy As > Hyperlink to place the deep link on the clipboard then use Hookmark’s Focus on Link in Clipboard.

Reference Links

Curio Professional customers can create cross references from Curio figures and Organizer items to other Curio figures, Organizer
items, and even web sites using a sophisticated new feature we call references.

These reference connections can be of a specified type, such as a Rebuttal or Evidence, allowing you to create a number of typed
connections between your Curio items, even if they're scattered throughout a project or in different projects.

Compared to normal jumps or wikilinks and backlinks, a reference link is much more advanced since it includes the type of
connection made between the two figures. Therefore you know why the items are connected.

¢ Backlinks
Reference To > Agree
Reference Backlinks > O Anderson interview on 8/26/2017 (in "Interviews")
; © On March 23rd, Janet walked to the e... (in "Backgrounder")
Add Reference to Copied Item As >
Remove Reference > isagree

After talking to Janet again on Nove... (in "Backgrounder”)

@ Weapon (in "Photographs")
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Reference Links

Sample Use Case

For example, say you’re using Curio to take notes on a research paper detailing a lab experiment. You can use references to
associate your text figures detailing your experiment, to various image figures located elsewhere in the project, with a Experiment
Snapshot reference type. They may also link to other notes which describe the results of prior experiments via Prior Data reference

type.

Then, at any time, you can view a figure’s references, via the link adornment or context menu item. It lists all figures this figure refers
to so you can jump to them with just a click.

If within the same project, you can even see all figures to point to it, thus are reference backlinks to this figure. (Note that a remote
reference in a different project can’t see all the references that point to it.)

A single figure might have references to multiple figures such as two Source figures, three Rebuttal figures, and one Example figure.
Likewise, a figure can have multiple figures that all point to it, such as a figure which is an Agree reference for some figures (thus a
support for those statements), and Disagree reference for others (thus a counterargument).

Reference Type Scopes

Using the inspector shelf, click the Project tab and then use the new Reference Types inspector panel to see all the available
reference types.

The Scope

There’s a popup at the top of this inspector panel where you can choose whether to view and modify:

» Bundled reference types that are included with Curio.
+ Custom reference types for all projects.
« Custom reference types for a specific project.

When you first launch Curio you won’t have any project or personal types, so let’s begin by looking at the bundled types.

Bundled Reference Types

Click the popup at the top to show all the bundled types. The list underneath will reveal the global reference types available to all
projects including Agree, Disagree, and Example, among many others. Each type is color coded for quick identification, such as
green for Agree and red for Disagree.
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Reference Types v
Show all bundled reference types (read only)
Visible Name Color

Evidence |
Example I
B Footnote [—
v Note  —
B Rebuttal |
v Reference [F—]
2 Response i
Source D
Editing

Bundled reference types are read-only, however, if there are types you don’t think you’ll ever use you can uncheck the visible
checkbox and they won't clutter your interface when creating references. They can be re-enabled at any time in the future if you
change your mind.

Example

As an author of mystery novels, you might decide that you’ll never need the bundled Footnote, Rebuttal, and Response types so
you uncheck them so they aren’t listed as choices when you make a reference association.

Custom Types for All Projects

At the top, switch the popup so you’re looking at the the custom types you’ve created and made available to all projects. This list is
empty by default, of course, so you’ll need to add some types to get started.

Reference Types v

Show your custom types available to all projects 7

Visible Name Color
Clue | —
Enemy [—]
Foreshadow ’ | — ‘
Friend | —
| AddType |
Example

Continuing the example above, let’s say you create a handful of custom global reference types that you’ll use as you brainstorm and
organize your novels: Clue, Enemy, Foreshadow, and Friend. You can use these to quickly link notes together as you work on your
latest mystery. These custom types will be available to all of your Curio projects.
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Editing
As custom types you can edit these names and colors at any time. Uncheck a type if you no longer want it to be available for new
references, or delete it via the Delete key or Delete Type button to remove it permanently.

Custom Types for This Project

And finally, switch the popup at the top so you can see the custom reference types you’ve created for this specific project.

Reference Types 4
Show this project's custom reference types
Visible Name Color

Persona 1
Scene [E—
Example

To continue our earlier example, in this particular project you’re working on a novel that could use a couple of project-specific types,
Persona and Scene, which you can use to help associate certain notes with specific notes and image figures which describe
important themes.

Editing
As custom types you can edit these names and colors at any time. Uncheck a type if you no longer want it to be available for new
references, or delete it via the Delete key or Delete Type button to remove it permanently.

Defining Reference Types

1. Using the inspector shelf, click the Project tab and then use the new Reference Types inspector panel to see all the available
reference types.

2. At the top use the popup to specify whether you want to view and modify (a) bundled reference types that are included with
Curio and available to all projects, (b) custom reference types for all projects, or (c) custom reference types for this project,
specifically.

3. Bundled reference types are read-only, however, if there are types you don’t think you’ll ever use you can uncheck the visible
checkbox and they won’t clutter your interface when creating references.

4. With custom types you can edit these names and colors at any time. Uncheck a type if you no longer want it to be available
for new references, or delete it via the Delete key or Delete Type button to remove it permanently.

Adding a Reference

1. Select and copy the figure or Organizer item you want to reference. This is the item you want to refer to.

2. Next select one or more other figures where you want to add a new reference which points to that copied item. Right-click,
and in the context menu that appears choose a reference type in the Add Reference to Copied Iltem As submenu to create
your new reference.

3. The reference connection has now been created, and a reference adornment will then appear beside both the source and
destination figure, if within the same project.

Adding a Link Reference

1. In your browser:
o Right-click on a link and choose Copy Link, which should also give Curio the title of the page.
> Or copy the link location itself (ex: www.zengobi.com/support).
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2. Next select one or more other figures where you want to add a new reference which points to that copied link. Right-click,
and in the context menu that appears choose a reference type in the Add Link Reference As submenu to create your new
reference.

Viewing an ltem’s References

1. If a figure either has references or is a reference (in the same project) then it will have a special references link adornment.
Clicking it will list all references, grouped and color coded by reference type, and allow you to add or remove references.
2. Alternatively, right-click on a figure or an Organizer item which either has references or is a reference and its context menu
will contain a References submenu identical to the one displayed when clicking an adornment.
3. From that menu you can select an item to instantly jump to it.
o If the jump destination is within this project it will appear in the current view, if Option (~\J) is held when clicking it will
open in the opposite split view.
o If the jump destination is in a different project, the jump will open in a separate window or tab (depending on your
System Settings > Desktop & Dock tabs setting), if Option (~\J) is held when clicking it will open within the current
window replacing the current project (reverse this).

Removing a Reference

1. Click on the references adornment or right-click and choose the References submenu.
2. Within that menu you should see a Remove Reference option so you can select a reference to remove.

Search References

Once you’ve connected figures together via references Curio includes a number of ways to use those connections.

* You can use the Quick Find popup or Search shelf to find all figures with which have references of a specific type ( ~agree ),
or even any reference type ( ~+ ).
* You can also find all items that are references of a specific type ( =~agree ) or any type ( =~+ ).

* When you use the export button on the search results screen, any references associated with a figure are included in the
resulting rich text, markdown, or CSV export.

+ By default, references are included in CSV exports under named columns such as “Agree Reference” and “Disagree
Reference”. As each figure’s row entry is exported, if the figure includes one or more references of that type then those jump
URLs are exported in that column. The search results export button also has a new menu option, Export Resulting
References as CSV, which can be used to export only figure reference information to a separate CSV file with reference
named columns.

Synced Figure Instances

You can create synced copies of a figure and Curio will sync the text contents and all meta properties (checked state, percent
complete, dates, tags, resources, priority, etc.) between the original figure and all instances.

Modify the original figure or any of the instances and those changes will be synced to all other figures.

This means you can mark one as completed, and all will be marked as completed. Change a date, and all reflect that same date
change. Modify the text context, and all have the updated text.
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The original

This is a text figure with some normal rich My List
< text bold and italics plus some ) 1. (™ I Thisis a text figure with some normal rich
“ markdown and some color. Wow! All in text bold and italics plus some

sync! Nice! markdown and some color. Wow! All in

sync! Nice!

— —r S —————

This is a text figure with \
,some normal rich text
>3 | bold and italics plus

= | some markdown and
some color. Wow! All in ‘
sync! Nice!

This is a text figure with some
normal rich text bold and italics
plus some markdown and some
color. Wow! All in sync! Nicel

o
b4l

Syncing

™3 This is a text figure with some normal rich text bold and italics plus
“  some markdown and some color. Wow! All in sync! Nice!

The screenshot above shows a rich text figure marked as 25% complete with an #cTp/onto1a tag with its associated hourglass
icon, with its content and meta synced to multiple instances each styled independently.

The figure styling is not synced and can therefore be different between all the instances. The styling associated with a figure is
applied to the shared text content right before rendering.

So you can have an instance of an original figure in a list, in a mind map, and in multiple other places on idea spaces throughout
your project, each styled independently, but their content and meta are all synced.

This is a powerful feature. A few other applications have similar functionality where it may be called transclusion or embedded block
references. Some only allow the original figure to be edited, thus all instances are read-only, while a select few allow any instances
to be edited as well (like Curio).

Video

Watch a synced figure instances demonstration video on our YouTube channel.

Creating a Synced Figure Instance

1. Select one or more figures and copy them.
2. Choose Paste As > Synced Figure Instance(s).

-147/423 - Copyright © 2025 Zengobi, Inc.


https://en.wikipedia.org/wiki/Transclusion
https://en.wikipedia.org/wiki/Transclusion
https://youtu.be/PQIg8lhOzSI

Synced Figure Instances

Some additional notes:

* You can paste into a collection or onto an idea space.

* Repeat the paste as synced figure instance as often as you wish.

« [tem order is preserved if you copy to/from collections. For example, if you copy items in a list then paste as synced figure
instances into another list then the items will be in the same order.

« If you duplicate or do a normal copy/paste of an instance then the duplicate is an instance of the original figure (it is not an
instance of an instance).

Jumping to Figure Instances
* Right-click on an original figure and choose an instance from the Synced Figure Instances submenu.

Given that the instances all have the same text content, the submenu is listed based on the containing idea space title, in
alphabetically sorted order.

Jumping to the Original Figure

+ Right-click on a figure instance and choose Jump To Original Figure.

Disconnecting from the Original Figure

* Right-click on a figure instance and choose Disconnect From Original Figure.
Deleting the Original Figure
If you attempt to delete a figure that has instances you will be warned that the syncs will no longer work.

The existing instances will maintain their text from the last sync. They will not be deleted as this could cause cascading issues if
they are parent nodes in lists, etc.

Note that you aren’t warned if you delete one or more idea spaces or entire sections that happen to contain a figure within that is an
original figure.

Glow Coloring
Instead of the normal blue selection glow color, you will see the following selection colors:

« Purple, for figures that have instances.
* Pink, for the instances themselves.

Note for performance reasons this is just a quick check. If you’ve deleted figures (or did an undo/redo of a figure deletion), or idea
spaces, or sections that have original figures or instances then the quick check won’t be updated until project reload.

Limitations of Synced Figure Instances

Currently you cannot create synced figure instances of grouped figures, line figures, or collection figures like lists and mind maps.

Styling Synced Figure Instances

Styling synced figures figures is quite similar to the logic applied to styling file-backed rich text figures.
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When you edit a figure those changes are then broadcast to each synced instance where the text contents are transformed to that
figure’s styling using the following logic:

1. Same Font and Font Size Throughout
If the entire text content shares the same font and font size (and ignoring traits like bold and italics) then the figure’s font and
font size are applied to those contents right before rendering. Subtext containing bold and italic attributes remain intact after
applying the new font.

2. Same Font Size Thoughout
Else, if the entire text content has a mix of fonts but they’re all the same font size, then the figure’s font size is applied to
those contents right before rendering. So the mix of fonts remains intact but they all adjust in size. Bold and italic attributes
also remain intact.

3. Text Coloring
Curio will then apply the figure style’s foreground text coloring to the text, while making sure colored subtext remains intact.

If there’s a mix of fonts and sizes then Curio leaves the text formatting as-is as it doesn’t want to jeopardize your rich text formatting
by applying a new syling erroneously.

Versus File-Backed Text Figures

Curio has a similar feature called File-Backed Text Figures where an asset figure that points to a text file can be displayed as a text

figure which you can read about above. With that feature, you can drag in an embedded or aliased text file then right-click on it and
choose to show it as a text figure.

Since it’s an asset figure, all copies of that figure will share the same underlying file asset. So changing the text contents of any of
the copies will modify the shared underlying text file, thus updating all the other copies of the asset figure. This sounds much like
the synced figure instance feature, right?

However, there are some key differences:

1. Synced figure instances store their text data within the figure data itself, not to a separate text file.

2. Synced figure instances will also sync figure meta information. Checking off or changing the due date on one will change all
the others. With file-backed text figures each figure is independent and only the content is synced since they share the same
underlying asset file. (Technically, for historical reasons, tags are synced between file-backed text figures as they are
associated with the asset, not the figure.)

3. Synced figure instances allow you to easily jump between the original and instances of that original.

Cool Trick

You can actually create a synced figure instance of a file-backed text figure to get the best of both worlds: synced figure meta
with synced text contents stored to a file which can be embedded within the projet or even aliased to a file possibly synced via
a cloud service to your other Macs and devices.

Focus

When working within Curio Professional or Standard sometimes you’d like to focus on a specific branch in a mind map or list, or

perhaps a particular figure on a busy idea space such as an album or text figure.
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With Curio’s View > Focus feature this is easy to do.

Using Focus

1. Select one or more figures and choose View > Focus or press ~“$F.

2. All other figures on the idea space will become transparent. If the selected figures are parent figures in a hierarchical
collection such as a list or mind map then any existing or new child nodes inherit focus as well.

3. To turn off focus simply choose View > Focus or press ~“#F again. If you switch to another idea space or re-open your
project focus is restored as well.

Related Features

1. All editions of Curio support the * (backtick) feature. Simply press " to instantly hide or show both the Organizer and Shelf
which quickly declutters the interface.
2. Likewise all editions of Curio support the standard macOS full screen mode toggled via the View menu or by pressing ~F.

Figure Layers

Figure layers are incredibly useful with more complex idea spaces where you want to neatly separate figure content into separately

manageable layers arranged in z-order.

Figures on top of Figures: On your idea space you have one or more figures, which are arranged and drawn in a back-to-front
order. For example, with two rectangle figures, you can drag one and it will either drag behind or in front of the other. You can use
the methods like the Arrange > Send to Back menu to rearrange this figure ordering.

Layers (of Figures) on top of Layers (of Figures): All of those figures currently exist on a single, default “foreground” layer on your
idea space. With layers in Curio Professional, your idea space supports multiple independent layers, themselves arranged in a back-
to-front order, each containing their own figures in back-to-front order.

Notes m n v |
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v Notes e = M
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Deciduous e @ M
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Hardscape 8 e @M
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Title Block @ A o = M
Delete Layer... Insert Above Insert Below
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Example

For example, say you have a Background layer which is located under a Foreground layer. Curio will draw all the Background figures
first in back-to-front order, then it will draw the Foreground figures in back-to-front order.

You could have a much more complex example, with a dozen layers that you use to encapsulate and order information. Layers can
be visible or hidden, or perhaps visible in general but not printed or presented.

The Active Layer

A key aspect of layers is that only one layer at a time can be active. The active layer receives all mouse clicks and user interactions,
essentially ignoring the other layers. This means you can select, create, delete, rearrange, and modify figures only on the active
layer, which safeguards your other layers from accidental changes.

Layers Popup Menu

Curio has a quick access popup menu to switch layers, just hold Option (~\°) and click the Layers button to see the layers menu
instead of the popover.

Activating a Layer

1. Click the Layers popover button located in the far-right area of the inspector bar. This button may be titled “Layer 1” as that’s
the default layer in all idea spaces.

2. In the popover that appears, click the layer to switch to. This will be the new active layer and you can now create and modify
figures on that layer.

Renaming a Layer

1. Click the Layers popover button located in the far-right area of the inspector bar.

2. Double-click on a layer to rename it, type in the new name, then press Return.

3. Note you cannot rename a layer inherited from a master template. It can only be renamed in the master itself. An icon
alongside the layer name indicates if it is inherited from a master template.

Inserting Layers

1. Click the Layers popover button located in the far-right area of the inspector bar.
2. Click either the Insert Above or Insert Below button to insert a new layer above or below the current, active layer.

Deleting the Active Layer

1. Click the Layers popover button located in the far-right area of the inspector bar.

2. Click the Delete Layer button to delete the layer. Or, with a touchpad or Magic Mouse, you can swipe a layer’s entry in the list
to delete it.

3. Note you cannot delete a layer inherited from a master template. It can only be deleted in the master itself. An icon alongside
the layer name indicates if it is inherited from a master template.

Rearranging Layers

1. Click the Layers popover button located in the far-right area of the inspector bar.
2. Drag-and-drop to rearrange the front-to-back ordering of your layers.
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Locking Layers

1. Click the Layers popover button located in the far-right area of the inspector bar.
2. Click the lock icon to lock a layer so its figures cannot be edited.

Changing the Visibility of Layers

1. Click the Layers popover button located in the far-right area of the inspector bar.
2. Click the visible icon to hide or show a layer. Note hiding a layer acts as a override forcing the layer to be hidden when
printing, exporting, or presenting regardless of the restrictions discussed below.

Like Photoshop, the Layer popover inspector supports ~c-clicking the visibility icon for a layer to instantly hide all other layers. ~=-
click the same visibility icon again and all other layers will be made visible once again.

Using Restrictions to Control the Visibility of Layers

1. Click the Layers popover button located in the far-right area of the inspector bar.
2. Assuming the layer is normally visible, you can restrict a specific layer from printing, exporting, or presenting by toggling the
appropriate icon.

Moving Figures Between Layers

« Right-click on selected figures and choose “Move Selected Figures and Switch” to move the figures to another layer and
switch to that layer.
« If Option is held when right-cilcking then it will say “Move Selected Figures and Stay” so you stay on the current layer.

You can also move figures via cut and paste:

1. Select and cut the figures in their current layer.
2. Activate the layer where you wish to place them.
3. Paste the figures into this layer. They will be pasted in the same location as they were in their original layer.

Master Templates and Layers

. Layers that are inherited from a master idea space template will show a special masters icon.
. This indicates the layer cannot be renamed or deleted, although you can still rearrange, hide, or change its permissions.
. Changes made to that layer in the master template will automatically be reflected in all idea spaces that inherit that master.

A W N =

. If you change to a different master template (via Change Masters) then any layers inherited from the current master will be
removed and the new master layers added.

[

. Any layers that were created just for this idea space, thus not inherited, will remain as-is.

6. Any edited figures that came from the previous master that have identifiers (via the Info inspector) will be copied over to
figures with the same identifiers in the new master. So if you changed a figure identified as title from the old master then its
content will be moved to a figure from the new master with the same identifier.

Figure Styles

As mentioned earlier, a figure style defines the look of the figure including properties such as color, border, font, and shading. You

can apply a style to a new or existing figure.
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Curio organizes figure styles based on the type of figure including:

+ Basic Figure

» Document Icon (an asset figure displayed as icon)
+ Image (an asset figure displayed as preview) with distinctions made for PDF Image and Equation subtypes
* URL (displayed as preview)

* Line

» List

* Mind Map

* Table

* Index Card

* Pinboard

» Album

« Stack

You can easily create new figures styles containing all of its display attributes.

Styles with Sizes
When you save certain types of figure styles, sizing information will automatically be saved as well. These figure types include

images, albums, index cards, pinboards, stacks, and tables.

For image figures, Curio will then apply the style’s size if you save the style as a default for image figures (Format > Save as Default
Image Style) and then drag in a new image, or if you apply a style to an existing image figure that you haven’t sized yet.

For the collection figures (albums, index cards, pinboards, stacks, and tables) these sizes be used when you create a new collection
using that style, or if you apply a style to a collection that doesn’t have any content in it yet.

Styles with Captions
If captions are enabled for a figure when a style is created then the style will include that caption state and applying that style to

figure will enable captions automatically.

However, by default if a style doesn’t include caption information then apply that style to a figure with existing captions will not hide
those captions, although they can be hidden if you wish.

Create a New Figure Style

1. Select a figure in an idea space.

2. Configure the attributes how you want them.

3. Right-click on the figure then choose “Save As FigureType Style” where FigureType will be replaced by the type of figure that
is selected such as “Basic Figure” or “Line” or “Mind Map”.

4. In the dialog that appears give the style a name and press the Save button.

Apply a Style to a Selected Figure

1. Click on the Style inspector button or right-click on the figure and choose “Apply Style” to bring up the Style Gallery for that
type of figure.

2. The style popup menu will only display the named figure styles appropriate for the selected figure. For example, if you have
selected an image figure, then only the image styles will be displayed.
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Figure Styles

Curio will also show the bundled, personal, and master styles in handy submenus under the Format menu, based on the selected
figures or the idea space itself if no figures are selected.

Create a Brand New Non-Collection Figure Based on an Existing Style
1. Click the Figures button on the toolbar.

2. The Gallery containing basic text figure styles and all non-collection stencils will appear.
3. Choose a style then click the Choose button. You may also simply double-click the style.

4. Some boilerplate text will automatically be added to your new text figure so you can see the effects of the style more easily.

Create a Brand New Collection Figure Based on an Existing Style

1. Click the appropriate collection button on the toolbar. For instance, click the List, Mind Map, Table, or Index Card toolbar
button.

2. The Gallery for that collection figure will appear.

3. Choose a style then click the Choose button. You may also simply double-click the style.

Creating Figures via Gallery Drag

1. Click the Insert toolbar button or appropriate collection toolbar button to bring up a gallery.
2. Drag-and-drop an item from the gallery to your idea space to create a new item.
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Detaching a Gallery

1. Click the Insert toolbar button or appropriate collection toolbar button to bring up a gallery.

2. Drag the gallery popover to create a free-floating gallery that you can drag-and-drop from to create new items. You can even
drag the Insert popover itself to turn it into a free-floating chooser.

- 154/423 - Copyright © 2025 Zengobi, Inc.



= < H
List

Mind Map  Table

= # B U Q & Q@
Index Card Album Pinboard Stack Share Present Sleuth Shelf
Layer 1 MAN=4A4>» 2 Y
Index Cards Insert
¥ Lorem Ipsum B
it Standard Blackboard
> Stencils
Bundled
Styles 23
> Stencils

Lorem ipsum dolor sit
amet,

. cor

otur
adipiscing eit. Nunc non
i

o
Pollntesaue placert
solictuin uso.
Blue Note Calm Blue
¥ Lorem Ipsum ¥ Lorem Ipsum
None Nune
wiputte ol Peterissqe non vt ol Peleresaue
Chalkboard Earl Gray Grays Light Blue
i' e s T -
x [ Mind Maps Insert
X Insert
Il Basic Shape | 5 e S
Styled Shape or Stencil . ) )
Four P's Marketi Leadership Test PEST Analysis
= LiSt Business Business Business
< Mind Map  swoT Anayis
EH Table
B Index Card SLEPT Analysis
Album
A Pinboard
B Stack
§ Audio Recording

SWOT Analysis

Business

Managing Figure Styles with the Gallery

2. Copy a style simply by drag-and-dropping it into your Personal collection.

1. Within the Idea Space Style Gallery you can perform a number of operations to better manage your idea space styles
3. Delete a Personal style by selecting the style and pressing the Delete key.

4. Share a Personal style by right-clicking on the style and choosing Send to Friend or Send to Zengobi.
Default Figure Style

You can change the default look for several types of figures. For instance, you want all new text figures to be 10 point Times or new
web link figures should be 14 point Helvetica with a curved, bordered, and gradient-shaded outline.
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Default Figure Style

Default styles can be overridden for each of the following figure types independently:

* Text

« Each of the various geometric shapes including rectangle, rounded rectangle, triangle, circle, trapezoid, speech, cylinder,
house, etc, available from the Drawing Tools popup or the Basic Shapes gallery.

* Lines

* Mind map relationship lines

* Document Icon - any asset figure displayed as an icon

+ Images and asset figures displayed as preview with distinctions made for PDF Image and Equation subtypes

+ URL figures displayed as preview

* Video

+ Audio

» Groups

» Lists

* Mind maps

* Tables

+ Index Cards

* Pinboards

* Albums

« Stacks

All asset figures displayed as icons share the same “Document Attributes included in the stye include text attributes, border shape,
color, thickness, and pattern, fill color and style, interior margin, opacity value, corners value, the visibility of shadows, to-do
checkboxes, and ratings, and icon size.

Note if you’re using Curio Professional then if a master figure is selected when following the steps below then you are defining a
default master style for the current project (since masters are local to the project) instead of a global default.

Asset Figure Default Stylings
Normally all asset figures displayed in icon mode share the same default “Document Icon” styling, so they all look similar. This

styling can be overridden via the Format > Set Default Style For Document Icon Figure menu item.

Similarly normally all images or asset figures displayed as previews share the same “Image Figure” styling, with “PDF Image” and
“Equation” as the only exceptions. This styling can be overridden via the Format > Set Default Style For Image Figure menu item.

If you switch back and forth between icon and preview, via right-click Show As Icon or Show As Preview, the appropriate default
styling will automatically be applied.

You can set the default state for whether a file dragged into Curio shows as icon or preview via the Format > Default Figure Settings
submenu.

Asset Figure Default Stylings For Specific Extensions
You can also set default stylings for specific file extensions for preview and/or icon display modes using advanced settings. For

example, a specific default styling for PNG files dragged in and displayed as icons or previews.

Save a New Default Style for a Figure Type

1. Select a figure of the appropriate type in an idea space.
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2. Change its look using the inspector, or apply an existing personal or bundled figure style from a Style popup. This is an
important point as you can simply change the attributes directly without using a saved style if you don’t want to.

3. Choose Format > Save as Default Style for Figure from the main menu.

4. Any new figures of the given type will be created using the default style you set.

List and Mind Map Styles

Hierarchical collections, like lists and mind maps, store a style per hierarchical level.

This is important because when defining your own styles you need to make sure you style at least one figure for each hierarchical
level, then save the collection style.

1. Create the list or mind map collection.

2. Quickly create a hierarchical series of child nodes: a child under the first, then a child under that child, then a child under that
child, etc.

3. Go as far as you’d like but perhaps 5 or 6 levels should do it.

4. Style the child at each level the way you’d like it: border shape, color, and fill; text font, color, size; attributes like bold, italics,
etc.

5. Once you finish your 5 or 6 levels select the collection figure itself.

6. Choose Format > Save as Default Style for Figure from the main menu.

Table Styles

Similarly tables store styles for each type of table cell, like a body cell vs a header cell, so you need to make sure you’ve defined a
style to each type before saving your table style.

1. Create a table.

2. Show color or row headers and footers as you wish.

3. Select each type of node and use the table inspector to set the style for that type of cell.
4. Once you finish select the collection figure itself.

5. Choose Format > Save as Default Style for Figure from the main menu.

Restore the Factory Default Style for a Figure Type

1. Select a figure of the appropriate type in an idea space.

2. If you’ve overridden its default styling then the Format > Restore Default Style for Figure menu will be available.

3. Choose that menu item and the styling override will be removed from your settings and factory default styling for that figure
type will be restored.

4. Any new figures of the given type will be created using the factory default styling, and that factory styling is applied to the
currently selected figure, as well.

Apply the Default Format for a Figure Type

1. Select one or more unlocked figures on the idea space.

2. Choose Format > Apply Default Style for Figure from the main menu.

3. The appropriate default styling (whether that be the factory default or a user-overridden default) will be applied to all selected
figures.
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Figure Stencils

Curio users can easily create new figure stencils that define not only the look of the figure but can also contain placeholder or

boilerplate text or figure items.

Recall that a simple figure stencil is one that includes a single figure. Even a single collection figure such as a mind map which can
in turn contain multiple figures within it is considered a single figure.

On the other hand a complex figure stencil is a stencil made up of multiple top-level figures. A perfect example is a landscaping
stencil where flowers, shrubs, and trees are represented by individual figures, images, or grouped figures. Those figures aren’t

contained within a collection, they exist directly on the idea space.

Create a New Simple Figure Stencil

1. Select a single figure or a single collection figure in an idea space which you would like to copy as a stencil.
2. Right-click on the figure then choose “Save As Style”.
3. In the dialog that appears give the stencil a name and press the Save button.

Create a New Complex Figure Stencil

1. In an idea space, carefully arrange all the figures you would like to have in the resulting stencil. The stencil will be stored and
displayed with the figures in these exact positions. So, in the landscaping example described above, you might place the
flowers on one area of the idea space, trees in another, and shrubs in another.

2. Select one or more figures from the idea space.

3. Right-click and choose “Save As Complex Stencil”.

4. In the dialog that appears give the stencil a name and press the Save button.

Create a New Complex Figure Stencil Using All Figures in an Idea Space

1. If you want to grab all of the figures in an idea space, carefully position them as described above then right-click on the idea
space in the Organizer then choose “Save Contents As Figure Stencils”.
2. In the dialog that appears give the stencil a name and press the Save button.

Inserting a Stencil

1. Click the Insert toolbar button and choose either Styled Shape or Stencil, for general figure stencils, or for collection-specific
stencil click on that collection type like List or Mind Map and you will find those stencils within that gallery. More information
below in the “Using the Stencils Gallery Window” topic.

2. Drag and drop stencils from the Stencils Library shelf, which is discussed in detail below.

3. Use the Insert main menu menu where you will find submenus for Bundled Stencil, Personal Stencil, and Master Stencil.
Then choose the stencil to insert.

Using the Stencils Gallery Window

1. You can easily manage your stencils from within the Gallery window (accessible via Insert toolbar button, then click the
appropriate gallery you wish to see, like the List gallery) you can perform a number of operations to better manage your
figure stencils.

2. Create personal stencil tags by right-clicking in the Personal area in the repositories list on the left and choosing “Add Tag”.
These tags are unique to the figure stencils repository and won’t conflict with tags created for idea spaces in the templates
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repository, for example. These tags are available to all types of stencils including collection stencils (lists, mind maps, etc.)
and other simple and complex stencils.

3. Organize your personal stencils by drag-and-dropping them into different tags. A template can be associated with more than
one tag. So, a template can be in your “Favorites” and “Work” tagged collections.

4. You can also associate or disassociate a personal stencil with a tag by right-clicking on the template and choosing a tag in

the menu that appears.

. Rename a personal stencil tag by double-clicking it and entering a new name.

. Delete a personal stencil tag by selecting it and pressing the Delete key.

. Copy a stencil from another repository simply by drag-and-dropping it into your personal collection.

. Edit a personal stencil by right-clicking on the stencil and choosing Edit Stencil.

. Delete a personal stencil by selecting the template and pressing the Delete key.

O © 0o N O O

. Share a personal stencil by right-clicking on the template and choosing Send to Friend or Send to Zengobi.

Using the Stencils Library Shelf

« The Stencils library shelf perfect for power users of stencils, where you can easily drag-and-drop stencils from the shelf to
your idea space. Read more in the Stencil library section below.
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Figure Inspectors

To view the inspector panel for the selected figure then either:

« Click an appropriate icon in the inspector bar, or
» Click the Inspector toolbar button to open the inspector shelf.

Style

The style information for a figure includes coloring, borders, fill, font, and much more. With just a click the look of your figure can

change completely. You can even save these looks as personal styles to use them again and again.

Tip
Learn more about figure styles.

Inspector Bar

At the far left of inspector bar you’ll find a Style button which displays a quick, popup gallery for the currently selected figure. Simply
click on a style to update its look.

Inspector Shelf

You can also use the mini style gallery at the top of the Shape inspector shelf to do the same thing.
And, lastly, you can right-click on a figure and choose Apply Style to choose a style from the gallery that appears.

All of these interfaces give you an opportunity to choose either a bundled or personal style that you have created. Curio Professional
users can also select a master style.

Text

Curio has loads of text options for you to tweak!

Inspector Bar

If the figure contains text then you’ll find several controls on the inspector bar itself for fast access to popular attributes.

Font and Font Size

Select a font for the selected figure.

Select or directly enter a font size. Tip: you can also use the standard Command+ and & keys to increase or decrease the font size.
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Text Color

For your text, you can specify either a solid color or a color gradient.

1. Specify a solid text color. Clicking will show a quick color chooser while ~=-Clicking will display the standard Apple Color
picker. Hold the Shift key and the color well will show that previously-used color, and then click the color well to apply that
color to the selected text. This color control remembers the last used color even between launches.

2. Specify a gradient of colors. Drag the color stops to adjust the gradient ramping. Double-click on a color stop to edit its
color. Double-click on the gradient to insert a new color stop. Drag a color stop down and off the gradient control to remove
the stop from the gradient. The resulting gradient will be rendered along the angle specified by the angle slider.

Highlight/Background Color

Specify a text highlight/background color. This color control remembers the last used color even between launches.

Clicking will show a quick color chooser while ~=-Clicking will display the standard Apple Color picker. Hold the Shift key and the
color well will show that previously-used color, the default is a nice light-yellow color, and then click the color well to apply that color

to the selected text for instant highlighting.

Character Attributes

Specify attributes such as bold, italic, underline, strikethrough, superscript, and subscript.

Markdown

Enable markdown syntax parsing and rendering. This button actually can show 3 states:

M3 - markdown syntax autodetected
. - markdown rendering enabled

M3$ - markdown rendering disabled

Shadow

Click the shadow button to display a popover allowing you to customize the shadow applied to the figure’s text. Note this is different
than the shadow which can be applied to the overall figure itself as specified in the Shape inspector.

Paragraph Attributes

Click the paragraph button to display a popover for setting several paragraph properties. You can also set many of these options by
right-clicking on the text figure and using the context menu that appears.

Minimum Height

A text figure can have a minimum height which is used when empty or when it contains very little text. As more text is added, it will
automatically grow in height as necessary to fit the new text. As text is removed, it will shrink down to that minimum height. This
feature is very useful if creating forms or templates and would like to use text blocks for certain areas. After enabling this feature,
just resize the figure using the selection handles to set the minimum height. This feature is also useful in combination with the
maintain spacing feature in the Geometry inspector so that neighboring figures will push away or pull back as content is changed.
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Freeform

If a text figure is freeform then that means you are in complete control of its width and height, clipping any text vertically if
necessary. If not freeform then Curio will automatically grow a text figure’s height as necessary to hold its contents.

Line Height

If you have an idea space with only a horizontal grid, like a notebook paper grid, then the line height can be set to match the grid’s
spacing. Or the line height can be determine automatically based on font size.

Placeholder Text

You can enter placeholder text for a text figure which is displayed if the content of the figure is empty. Note this placeholder text is
displayed with the same text coloring as specified by the figure’s style (that is, it is not grayed or dimmed) so it remains legible
regardless of figure, container, or idea space background coloring or opacity.

You may also want to read about placeholder image and asset files that can be easily swapped for other images or files via drag-
and-drop.

Inspector Shelf

The inspector shelf includes the same controls described above for the inspector bar, plus more since there’s more room available in
the shelf:

Typeface

Select a specific font typeface, such as “Light” or “Medium Oblique”.

Capitalization

If a figure is selected, not just selected text within a figure, then you can select an automatic capitalization such as lowercase,
uppercase, sentence, capitalize, and titlecase. Your text is stored as you entered it but will be transformed when rendered.

* None - Leave as-is.

Ex: “the new macos sierra for IMAC and MACBOOK Pro integrates with IOS devices.”
» Uppercase - Uppercase all letters.

Ex: “THE NEW MACOS SIERRA FOR IMAC AND MACBOOK PRO INTEGRATES WITH I0S DEVICES.”
* Lowercase - Lowercase all letters.

Ex: “the new macos sierra for imac and macbook pro integrates with ios devices.”
* Sentence - Lowercase all except first word and products.

Ex: “The new macOS Sierra for iMac and MacBook Pro integrates with iOS devices.”
+ Capitalize - Capitalize each word except products.

Ex: “The New macOS Sierra For iMac And MacBook Pro Integrates With iOS Devices.”
* Titlecase - Capitalize in general but lowercase certain words like ‘for’ and ‘and’, etc.

Ex: “The New macQOS Sierra for iMac and MacBook Pro Integrates with iOS Devices.”

Text Figure Formatters

If a text figure is selected, not just selected text within a figure, then you can specify a numeric format which will be applied to your
figure’s text when rendered.
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You can specify an optional prefix and/or suffix, which is prepended/appended to the formatted value, respectively.
Curio can perform automatic /ocalized formatting with the following formats:

* Number: 1,234.567

+ Percentage: 50%

« Scientific: 1.23E3

« Currency: $1,234.57

* Currency (Plural): 1,234.57 US dollars

+ Currency (ISO Code): USD 1,234.57

« Currency (Accounting): ($1,234.57)

+ Spell Out: one thousand two hundred thirty-four
+ Ordinal: second

Localization of the thousands separator symbol, currency symbol, decimal separator, etc, are all automatically handled by the
macOS locale specified via System Settings > Language & Region settings.

Shape

To change your figure’s shape properties either click the Shape button on the inspector bar, or see the Shape tab in the inspector
shelf.

Inspector Bar

The Shape button on the inspector bar brings up the Shape inspector popover, which contains the same inspector panels as those
found in the inspector shelf described below.

Inspector Shelf
Shape

The figure shape inspector allows you to change visual properties such as coloring and border style.

Color

Set the color of the figure stroke. In the case of a geometric figure this is the color of the border; in the case of a line this is the line
color. Simply click on the color well to see a quick color matrix, or ~=-Click on the color well to see the standard Mac OS Color
Picker.

Geometric Shape

Set the geometric shape of the figure such as Rectangle, Triangle, Hexagon, or Cloud.

Dash Pattern

Set the stroke dash pattern.
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Width

Set the stroke width. Tip: press the [ or ] keys on your keyboard to decrease or increase the current thickness of the selected shape
figure or line figure.

Corner

Set the corner value which determines the radius of certain shapes, like rounded rectangles, or the complexity of other shape, like
clouds. In particular, the Left and Right Signpost shapes and the Underline shape will change their look substantially as you change
the corners value.

Tip: press the { or } keys on your keyboard to decrease or increase the current corner value of the selected figure.

Margin

Set the margin which determines the distance between a shape’s edge and its contents.

Tip: press the ~of or ~\o} keys on your keyboard to decrease or increase the current margin value of the selected figure.

Smart Coloring

Several smart options can be specified.

The fill color can be determined automatically by Curio so that it matches your selected stroke color. Likewise, the figure’s text color
can be determined automatically as appropriate based on the fill color. Curio will automatically choose a white text color when the
fill is dark, else a black text color for lighter fill colorings.

Fill

You can fill the interior of the figure shape with a color or gradient.

None

None will allow the figure to be transparent.

Solid

For solid fills, click on the color well to choose a color from the matrix that appears. Or, ~=-Click on the color well to go directly to
the standard color chooser.

Simple Gradient

For simple gradient fills, click on the color well to choose a color from the matrix that appears. Or, ~=-Click on the color well to go
directly to the standard color chooser. Curio will then make a smooth gradient using that color.

Bowed Gradient

For bowed gradient fills, click on the color well to choose a color from the matrix that appears. Or, ~=-Click on the color well to go
directly to the standard color chooser. Curio will then make a smooth bowed gradient using that color.

Linear Gradient

For linear gradient fills, drag the color stops to adjust the gradient ramping. Double-click on a color stop to edit its color. Double-
click on the gradient to insert a new color stop.
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Drag a color stop down and off the gradient control to remove the stop from the gradient.

The resulting gradient will be rendered along the angle specified by the angle slider.

Radial Gradient

For radial gradient fills, drag the color stops to adjust the gradient ramping. Double-click on a color stop to edit its color. Double-
click on the gradient to insert a new color stop.

Drag a color stop down and off the gradient control to remove the stop from the gradient.

The resulting gradient will be rendered with a center point located as specified in the point locator control.

Glossy Fill

For glossy fills, you choose just a single color and Curio will automatically construct the appropriate gradient styling to render a
glossy shape.

Extras
Shadow

Enable a shadow for the figure. The shadow can be customized by specifying the color, blur, and x/y offsets.
By default, if the figure is filled, then the shape’s shadow attributes are applied to the shape itself, otherwise if the figure is unfilled,
then those shadow attributes are applied to its text.

You can control whether the shape shadow is automatically used as a text shadow. By controlling this feature you can specify a
shadow for the shape and a different shadow style for the text itself, using the text inspector.

Shadow Effects

Enable a shadow special effect:

* A normal shadow is just a typical drop shadow.

+ A pinched shadow looks like the figure has been placed on a tabletop where only the bottom corners of the figure are
slightly raised from the surface, like you’re pinching the edges and lifting them up. This effect requires a filled, rectangular
shape with no curved corners.

* A bulged shadow is the opposite of a pinch: here the bottom center of the figure is slightly raised from the surface, like
you’re creating a bulge in the center of the photo. This effect requires a filled, rectangular shape with no curved corners.

* A neumorphic shadow has two shadows: the specified main shadow plus a second slightly smaller highlight shadow in the
opposite corner from the main shadow, with values automatically calculated based on the primary shadow’s values.
Neumorphic shadows work best where the figure and the idea space closely match in fill color so it appears extruded from
the background:

Neumorphic
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Opacity
Set the shape opacity making the entire shape more or less transparent. Note that this effect changes the opacity of the entire figure

uniformly.

For more advanced transparency effects, in lieu of setting the overall opacity, you can specify a specific opacity for the shape’s fill,
gradient, and stroke colors within the standard Mac Color Picker.

Placeholder

You can mark certain types of asset figures as placeholder figures which makes it very easy to swap out their underlying asset file.
Replace a placeholder’s asset file using one of the following techniques:

1. Drag and Drop
Drag a file from the Finder or an image from a browser on top of the placeholder figure. Curio will show a green glow and
target indicator if the figure’s asset can be swapped with this file.
2. Paste
Copy a file or image then select the placeholder and paste.
3. Click Placeholder Icon
A selected placeholder figure displaying as preview image will show a small icon in the lower-right corner. Click that icon to

choose afile.
Note that you can only choose a file that matches the current figure type:

» PDF asset figures can only be replaced with PDF’s.

* Image figures can only be replaced with image files or image clipboard data.

« Video and audio figures can only be replaced with video or audio files, respectively.

+ Otherwise any general document asset figure can be replaced with any document file. For example, an Excel asset figure
can be replaced with a Word file if you'd like.

Important
If the Control key is held when dragging over a placeholder figure then it will not swap the file and instead the drop will create a

new figure.

Placeholders and Stencils

Placeholder images and placeholder text can come in very handle when creating figure stencils.

For example, a business card stencil would have a placeholder image for the person’s face, and placeholder text fields for their
name, email, and address. Saving it as a stencil then re-using it allows you to easy create new business cards by dragging in
images and filling out their info fields.

On-The-Fly Placeholder

Curio also suppors turning any asset figure into a pseudo, on-the-fly placeholder figure simply by holding the Control key down
when dragging a file over any asset figure.
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So, with this feature why support actual placeholder figures?

1. With placeholder figures you can simply drag-and-drop to replace without holding Control.
2. You can select the placeholder figure and paste to swap its file.
3. Placeholders show the little icon in the lower-right making it obvious and easy to replace with a file chooser.

Auto Inflate

Normally certain shapes are set to auto inflate automatically to minimize the amount of clipping that would occur to its content
whether that be text or an image.

For example, the Cloud shape automatically inflates itself a few pixels so the bumps of the cloud don’t crowd or clip the content.
The result is a nicer looking resulting shape without you having to fidget with margins. You can turn this off if you wish to have more
direct control over your shape.

Preview vs Icon

For figures representing files, you can set whether the figure is displayed with the file’s icon & title, like the Finder, or if the figure
simply exists as an image preview.

As a tip, you can also right-click on a figure to change its display mode between icon and preview and, when in preview mode, you
can toggle the display of the preview caption.

If displayed as an icon then:

+ An icon size slider will appear so you can specify its size. Up through a size of 128x128 the default icon for that document
type is used, continuing up to 256x256 a Quick Look thumbnail of the file is used for the icon instead. Note that this icon size
slider is also used for text figure attachments if one has been attached to a given figure.

* You can change the icon’s title but note that Curio will also rename the underlying asset file’s name as well (if embedded), to
keep them in sync. When setting the file name Curio will automatically strip any invalid characters from the title text so
macOS doesn’t complain.

Else, if displayed as a preview then:

« If an image file, Curio will simply display that image, else Quick Look is used to grab a preview of the file. Previews can be
displayed with an optional caption which is displayed under the preview image.

* Your previews can have captions if you wish. By default, these captions are placed inside the overall shape border, or you
can specify that captions should be displayed outside the border. Captions can also be enabled via right-clicking on the
figure. Initially the caption will be the same as the underlying asset file’s name. However, you can change this to anything you
wish and the asset file’s name will not be changed, thereby allowing long, detailed captions if you’'d like.

« Alternatively you can tell Curio to clip the preview image to a specified mask. This is useful when you want your overall figure
to have one shape — and perhaps it contains other contents such as text, fill color, and adornments — but you still want
your image preview to be clipped to a specific shaped mask, such as a circle.

Geometry

Bounds

The bounds defines the figure’s size and position in the idea space.
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X, Y, Width, Height

Set the figure’s x, y location and the width and height.

Natural Size

When the Natural Size button is clicked or the N shortcut is pressed, then a text figure or image figure will grow to its natural size,
but remain constrained by the current width of the idea space.

When clicking Natural Size or pressing N, you hold one these key modifiers:

 Hold the Shift key and the idea space will expand if necessary.
+ Hold the Option key and the full, non-optimized image will be reloaded, in case a size constraint was imposed on a large
image for optimization reasons, and the idea space will expand if necessary.

Constrain Proportions

Set whether the figure is resized proportionally which is enabled by default for images and asset figures displayed as previews. For
non-image figures you can resize proportionally on-the-fly by holding Shift and resizing with the figure’s selection handles.

Rotation

Specify the rotation of the figure, or zero the rotation. Tip: use the R and {} R keys to rotate a figure in increments either clockwise or
counterclockwise. The Z key can be used to zero the rotation.

Auto Layout

The layout control is a method for defining how a figure should automatically position and size itself if the idea space changes size.

Springs and Struts

Curio uses the “springs and struts” method for laying out items. The smaller, inner box represents a figure, which is contained in a
larger box which represents the idea space itself. The red and green lines determine whether its position or size is fixed (a strut,
represented by a red line) or flexible (a spring, represented by a green arrow).

Examples
For example, give a figure a flexible width and a flexible top margin and you’ve created a footer figure. Place it down at the bottom

of your idea space and as the idea space changes size the figure will remain stuck and centered at the bottom of the idea space.

At the top of this page, click on the subheading (“Set the figure’s geometry..”) and look at its layout. It’s set to remain stuck to the
right side of the idea space while its width is allowed to change.

Automatic Layout via Idea Space Guidelines
Idea space guidelines provide a helpful margin around an idea space you can drag and resize items so they snap against the margin

or even against the edge of the idea space itself. You can toggle them via the Arrange > Idea Space Guidelines menu.

Start moving or resizing a single figure then hold down the Control key. You’ll notice, as you bump against a guideline, the guideline
is drawn with red! This indicates that you have set a new strut as a layout constraint and, indeed, if you watch the Geometry
inspector as you do this you’ll notice springs and struts appearing automatically.

Thanks to this feature you can quickly position and size a figure along with setting appropriate auto layout rules, all without touching
the layout control.
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Autospacing With Nearby Figures

You can tell Curio to automatically scoot figures closely underneath a figure as it is being resized.

This means that as this figure is resized, either by manually resizing or by changing styles or adding/removing content, then the
figures closely underneath (within 50 pixels) will automatically scoot down or back up as the figure’s size changes. By setting this
attribute, which can be saved with custom figure styles, you can have figures shift themselves down and up as figure contents
change!

« The figure being resized must have the auto spacing property enabled.

+ Only resizing an auto space figure impacts lower figures, not moves.

+ Only those figures within the 50 pixel boundary will be moved up or down. If those figures also have auto spacing enabled,
then Curio looks below those figures as well, and below those, etc...

* Moving a figure completely away doesn’t collapse the figures. It’s simply no longer impacting those figures previously
underneath it. It still has the auto space property, of course, so now it will impact figures in its new location when it resizes.

« Moving a figure from elsewhere into an area close to another figure doesn’t automatically scoot everything down. Curio
allows you to place things where you want it to go.

« Again, resizing is what triggers the auto spacing. This means you can still manually move and position figures anywhere you
wish, maintaining the unrestricted, freeform nature of the idea space environment.

Arrange

Drag the slider to bring the selected figures as a group either closer to the top of the figure stack or further back.

If multiple figures are selected then those items are moved independently up and down the figure stack, keeping their same relative
stacked distance away from each other. In other words, bringing forward figures placed at 5 and 10 in the figure stack will move
them to place 4 and 9, where 0O is at the top of the figure stack.

You can also click on the icons on the far left and right sides of the slider to move the items back or forward in steps. If the Option
key is held down while clicking those back/front icons the selected figures are moved together in figure stack as a group. That
means they are grouped together into the same stack placement then moved up and down en masse.

Flip

Click the flip buttons to flip an image figure vertically or horizontally.

Align & Distribute

Use the align and distribute buttons to quickly arrange multiple selected figures.

Meta

Curio allows an extensive array of meta data to be associated with your figures including checked state; percent complete; priority;
rating; start, due, and done dates; tags; custom key-value data; resources; notes; and double-click actions.

There are many ways to associate this data with your figures, including the status bar, inspector bar, inspector shelf, context menus,
figure adornments, and shortcut keys.
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This meta data can be searched via Quick Find or Search shelf, collated by the Status shelf, or used to sync with Calendar/
Reminders.

Status Bar

You can use the Status Bar to view and quickly enter meta values for selected figures.

Inspector Bar

The Meta button on the inspector bar brings up the Meta inspector popover, which contains the same inspector panels as those
found in the inspector shelf described below.

Inspector Shelf

Adornments

An adornment is a little image that appears next to your figure. It may represent a tag, or a due date, or a checkbox.

Size and Position

Set the size of the adornment images. Tip: press the ~[ or ] keys on your keyboard to decrease or increase the current adornment
flag size for the selected figure.

Use the radial spinner to position the adornments all around the selected figures. You can also indicate that the adornments should
be displayed inside or outside the figure’s border. Note that some collection figures may force the position of adornments.
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Clicking on the Adornments

Many of the adornments displayed next to figures can be clicked-on and changed:

* Checkmark Adornment
Click to check/uncheck. ~=-Click to display the percent complete mini popover. $-Click an unchecked item with a due date
to check it and change its due date to today.

* Tag Image Adornment
~=-Click to display the tags mini popover. If the tag set is “only one tag in set can be active” then if the tag is in a set with 3
or fewer tags within then clicking the tag adornment will cycle through the tags. If more than 3 then a handy popup will
appear so you can choose one of the other tags.

« Start/Due Date Adornment
~\=-Click to display the start/due date mini popover.

+ Rating Stars Adornment
Click to display the ratings popover. ~=-Click to cycle through the ratings. {} Click to cycle in reverse order.

* Priority Adornment
Click to display the priorities popover. ~=-Click to cycle through the priorities. {' Click to cycle in reverse order.

* Bookmark Adornment
Click to display the bookmark colors popover. ~=-Click to cycle through the bookmark colors. {} Click to cycle in reverse
order.

* Jump Action Adornment
Click to perform the jump action.

* Note Adornment
Click to display the Notes window.

Checkmarks

Toggle the display of checkboxes using the on/off switch. Click the adornment itself to check or uncheck the figure.

Figures in Curio which have been completed are displayed with strikethrough and slightly dimmed. You can customize this behavior
if you wish.

Percent Complete

You can set a percent complete value from 0% to 100%. Use the stepper arrows to increment/decrement by 1, or hold Shift and
click to change by 5.

Checking is a shortcut to setting a percent complete of 100%. Likewise, unchecking is the same as a 0% completion.

Via Child Figures

By default if the figure has children under it, like in a list or mind map, then its percent complete value is automatically computed
using the percent complete values of its children.

Via Resources

If the figure has assigned resources then you can specify that the percent complete value is computed using the percent complete
value assigned to each individual resource in the Resources tab.
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Tip
Press {7 X to toggle the visibility of a checkmark for the selected figure. Press X to check or uncheck it.

Mini Popover

Curio has a handy mini popover for setting percent complete which can be handy when you don’t want to bring up the inspector.

* To show the percent complete mini popover: ~=-Click an existing checkmark adornment, or press the » key. Use the
stepper arrows to increment/decrement by 1, or hold Shift and click to change by 5. You can redefine the shortcuts if you

wish.
* To hide the percent complete mini popover: Press the Escape key, or click its little close button.

Status Bar

You can also use the Status Bar to view and quickly enter percent complete values for the selected figures.

Priority and Rating

You can set a priority and a rating to your selected figures via the inspector shelf.

You can also use the Status Bar to view and quickly enter priority and a rating values for the selected figures.

Tags

To view the tags associated with the selected item either click the Meta button in the inspector bar, or see the Meta tab in the
inspector shelf.

Tags are words or phrases that you can define and associate with your items as searchable meta information.

Local and Cross Project Tags

You can create several types of tags:

* Local Project Tags. These are tags that are local to the current project. Perhaps you’re working on a novel so you may have
a tags for greg, clue, and background, to help you quickly find and key figures in your project.

* Cross Project Tags. These are tags that can be used in all your projects. For example, common tags you may want to use
across your projects could include favorite, homework, and question.

* Cross Project Tag Sets. These are tags organized in tag sets that can be used in all your projects. Curio includes several
bundled tags sets like GTD (Getting Things Done) which contains tags like active and waiting on, plus you can create your
own custom tag sets. By convention this might be written in condensed form as GTD/active or GTD/WaitingOn where the
slash is used to separate the tag set from the tag name in the set. Casing and spaces are generally ignored.

Hashtags

By convention, if the tag is in a tag set then In the various tag inspectors you will see tags clearly labeled as described above like
clue, homework, and gtd/active.

If mixed with other meta information or as inline meta tags within a body of text you may see tags as “hashtags” prefixed with a #
hash character. This turns the above tags into  #ciue , #homework , and #gtd/active .
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Tag Names

You are allowed to use any characters and numbers in your tag and tag set names. You may also usethe ~ and - characters,
which permits tags such as united_states and on-hold.

The / character is reserved as a nesting separator for tags within tag sets, like GTD/active.

Sharing Projects with Others

If you share a project you created with others then obviously those users would have access to the local project tags, but what
about your global tag set tags? For instance, say you’ve created a global tag set named Customer with a contained tag of Pepsi,
and used it in multiple projects. If you then share one of those projects, how would that colleague see that tag set tag?

Fortunately, Curio will embed an “extract” of any global tag sets you have referenced in the project so your colleagues will see those
same tag associations. When they view the Meta inspector on their machines those extracted tag sets will be available but in italics
to indicate they cannot delete or otherwise modify those tag sets. However, they can change tag associations from that set — for
example, they can change a figure from GTD/OnHold to GTD/WorkingOn.

Assigning Tags
As you’ll see below, there are a number of ways to assign tags to your figures:
. The tags panel in the Meta inspector on the inspector bar or inspector shelf, as described in this section.

. The right-click context menu’s Tags submenu.
. The tags mini popover via the # hotkey.

A W N =

. Clicking on a figure’s existing image tag adornment, for a tag that’s in an only one at a time tag set, so you can choose a

different tag in that same tag set.
. Typing an inline tag into a text figure (like #special Or #context/home ).

o O

. Entering a tag in the Status Bar (like #special OF #context/home ).
7. Dragging figures between Stack collections that have tags assigned to their title items.

Assign Tags via Typing with Tag Name Completion

You can associate tags with the selected items simply by typing the tag name. A completion list will appear as you type so you can
choose an existing tag, or you can continue typing and press the Return key to create an on-the-fly local project tag, described
below. You don’t have to type tag set prefixes or slash prefixes to find a match. All local and global tags are searched. Separate tags
nested within tag sets using a slash ( crp/active ).

Creating Tags On The Fly

Autocomplete matching will find project tags, cross project tags, and cross project tag sets. Type an unknown tag ( ciue ) and
Curio will create a project tag, prefix it witha / ( /nomeworx ) and it will create a cross project tag, prefix it with an existing tag
set ( gtd/frozen ) and it will create a new tag in that tag set.

Assign Tags via Hierarchical Tag List

You can also associate tags using the tags list, hierarchically grouped by tag set, by clicking the checkbox next to the tag. You can
click the Clear button to clear all tag associations.
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Working with Tag Sets and Tags

Use the tags panel within the Meta inspector to modify or create new tag sets and tags. Tags can either be local to your project (aka
“keyword tags”) or global and available across projects and for grouping purposes in the Status shelf.

Adding Tag Sets and Tags

* Use the add buttons or the right-click context menu to create new tag sets and tags.

Arranging Tag Sets and Tags

The local project tags and cross project tags are always displayed in sorted order. However, tags within the tag sets can be ordered
manually via drag-and-drop, or sorted by choosing Sort Tags In Set via the actions button menu.

You can rearrange the tag sets via drag-and-drop or have them sorted by choosing Sort Tag Sets via the actions button menu.

Promoting Local Tag to Cross Project

You can drag-and-drop a local tag to either the cross project tags or a tag set to promote the tag to a cross project status.
Within the current project all existing tag associations with the previously local tag now refer to the newly promoted global tag.

Note, however, that you cannot perform the opposite move: a global tag cannot become a local tag because that could break other
projects that relied on that global tag.

Renaming Tag Sets and Tags

+ Change a name by double-clicking it.

Deleting Tag Sets and Tags

+ Select a tag set or tag and click the Delete button or press the Delete key.

Importing Tag Sets

+ Use the action button or context menu to import an extracted tag set from a foreign project into your own shareable global
tag sets. For instance, from the example above, if you’re viewing a colleague’s project with that “Tasks” extracted tag set
then you can select it and use the action button to import it into your own global tag sets. All internal identifiers are kept the
same so you can continue to share projects with your colleagues that use that same tag set.

Setting a Tag Emoji or Character Symbol

Assign an emoji or character symbol to a tag:

1. Select a tag.

2. Click the little Character Viewer button to bring up the standard macOS Character Viewer (or click in the text field and type
~38Space).

3. Double-click on an emoji or character symbol and instantly it will be entered as the “image” for the tag.

Emoji are great because they’re perfectly scalable and consume very little disk space for the project.

If you choose a text symbol then use the little color control next to the text field to specify a tinting color for the symbol. This way
you can turn a boring black down arrow symbol into a noticeable red down arrow.
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When a tag has an emoji or symbol then it is displayed as an adornment next to the figure’s other adornments. Use the adornment
size slider to change its size.

To remove a tag emoji or symbol select the contents of the text field and press the Delete key then press the Return key.

Setting a Tag Image

Alternatively you can assign an image to a tag:

1. Select a tag.
2. Drag an image from the Finder to the small image control.

As a note, you can drag multiple PNG or JPEG imagesfrom the Finder into the tags panel to add lots of image tags to an existing
tag set, where their tag names are derived from their file names.

You can download perfect fantastic images for tags from sites like IconFinder or search Google for icon sets for more
recommendations.

As some experimentation it looks like the tag inspector’s macOS-native image control also support some SVG images although not
all. As a workaround you can paste the SVG into the idea space then Copy As > PDF then paste into the tag’s image control.

We list a number of fantastic SVG repositories, may of which also support PNG downloads, in our documentation for SVG image
figures.

When a tag has an image then it is displayed as an adornment next to the figure’s other adornments. Use the adornment size slider
to change its size.

To remove a tag image select the image control and press the Delete key.

Setting a Tag Keyboard Shortcut

All tags in Curio are displayed under the Format > Tags main menu item. This means you can use the macOS System Settings >
Keyboard > App Shortcuts panel to create keyboard shortcuts to any tag, or any other Curio menu item.

For example, if you wanted to assign %2 tothe crp/action tag then you could use the App Shortcuts panel to create a new
Curio app shortcut to the menu  rormat->Tags->GTd->action and assign it tothe +{ra keystroke.

Generally we recommend using ~ {} for your shortcuts to avoid conflicts with existing Curio interface shortcuts.

More info about creating keyboard shortcuts in macOS can be found in this Apple Support document.

Note

If your tag name doesn’t appear as a word anywhere else in Curio’s menus then you can just enter it for the match instead of
the full path to the menu item. For example, action doesn’t appear anywhere else in Curio’s menus so instead of specifying
the full path of Format->Tags->GTD->action YyoOU can just enter action . On the other hand, quit does appear elsewhere in
the menus so you need to use a full menu path to a tag with that name.
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Important

In older versions of Curio, we had our own internal method for assigning and handling tag shortcuts. That method has been
deprecated for better macOS future proofing. If Curio finds older defined keyboard shortcuts then it will export those to a
helpful curio Custom Keyboard shortcuts.txt file on your Desktop. You can use its contents to help you re-create your old
shortcuts using the new technique.

Tag Set Color

To the right of each tag set name in the inspector is a color well control. You can use this to assign a color to the tag set that will be
used to create tag capsule adornments.

If a tag associated with a figure doesn’t have an emoji or image, and if its tag set has an assigned color, then that color will be used
to create a small capsule enclosing the tag name as an adornment alongside the figure.

If your tag name has an emoji within it, then the tag capsule will include that emoji as well.

To remove the coloring just set it to the clear color in the popup color chooser.

Tag Set Color Options

+ Capsule display for tags only occurs if the tag set has an assigned color. However you can also enable this feature even for
those tag sets that don’t have an assigned color by enabling this setting where a default gray color will be used for the
capsules for tag sets with no user-assigned coloring.

» Normally only the tag name itself is displayed within the capsule. You can optionally show the full tagSetName/tagName in
the capsule if you wish via this setting.

One Tag Active

When a tag set is selected, note the ‘tag set only allows one tag to be checked’ checkbox. Checking this option is perfect for those
tag sets which represent a specific state or status. Choosing a tag in this set will automatically turn off the previously associated tag
from this set.

For example, with the Detailed Tasks tag set you are specifying a GTD-style state for that task like pending, active, or done. If the
current state of a figure is active then setting a tag of done will automatically turn off active.

These types of tag sets have a couple of extra ways to assign tags to a figure:

« If your tag set has 3 or fewer tags with images then clicking the tag’s image adornment will cycle through the tags in the set.
« If your tag set has more than 3 tags, then clicking the tag’s image adornment reveals a popup so you can quickly choose the
new tag.

Tag Set Visibility

If you have lots of global tag sets but only some are applicable to the current project, you can now easily hide them so they don’t
clutter up your tag choices.
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There are two ways to do this:

1. You can select a single tag set and uncheck the ‘tag set is visible in this project’ checkbox.
2. You can select multiple tag sets, then right-click to show the context menu (or click the action button) and choose Set
Selected Tag Sets as Hidden. Note you can also set multiple tag sets as visible via the same menu.

Revealing the Hidden Tag Sets

Normally hidden tag sets are not visible, of course. However, you can make them visible by clicking the Show Hidden checkbox or
choosing the Show Hidden Tag Sets context menu item (or via the action button).

Note this is an in-session setting so tag sets marked as hidden will be hidden again when you re-launch.

Assign Figure Tags via Context Menu

Right-click on a figure and choose a tag from the context menu that appears to toggle the tag association.
Assign Figure Tags via Mini Popover
Curio has a handy mini popover for setting tags which can be handy when you don’t want to bring up the inspector.

+ To show the tags mini popover: Option-click an existing tag adornment, or press the u key (for meta) when a figure is
selected. You can redefine the shortcuts if you wish.

* To hide the tags mini popover: Press the Escape key, or click its little close button.

Creating Tags On The Fly

Autocomplete matching will find project tags, cross project tags, and cross project tag sets. Type an unknown tag ( ciue ) and
Curio will create a project tag, prefix it witha / ( /nomeworx ) and it will create a cross project tag, prefix it with an existing tag
set ( gtd/frozen ) and it will create a new tag in that tag set.

Assign Tags via Inline Tags

Inline meta detection is enabled by default. You can toggle this globally via the Format > Default Figure Settings > Detect Inline Meta
menu item, or for a specific figure using the # button in the text inspector.

This means you can enter inline tags anywhere within the contents of a text figure using the 4 prefix, such as #special and
#ctp/active and they will be matched with existing project tags. If you enter an inline tag which is unrecognized Curio will create
the meta element automatically.

Note that matches are case insensitive and spaces should be removed from tag set names and tag names and, if appropriate, a
slash is used to separate a tag set name from the tag name. So, for a tag named On Hold within the Detailed Tasks tag set you

should enter #petailedTasks/OnHold .

| forests have pledged to end deforestation by 2030.
#COP26 #GTD/active @GeorgeB
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Inline tags are useful for those that want to have always visible meta tag associations. After editing, behind the scenes Curio will
associate or disassociate the figure with the given tag as appropriate, as if you had selected it from an inspector.

Tip
If your unknown tag is prefixed witha / , like #/nomework , then Curio will create a cross project tag, else if no prefix then a
local project tag will be created.

Ignored Inline Meta

Automatic inline tag detection will not consider a number-only entity as a new tag. So curio is #1 will not trigger a new tag
detection. However, number tags can be still created in the Status bar or the Tags inspector and then you can enter it as an inline

tag where it will be detected as an existing tag. You can enable new inline number tag detection if you wish.

If you’d like to type something that shouldn’t be interpreted as inline meta then you can escape it with a backslash ( \ ). When
rendered the backslash will be hidden:

A popular hashtag on social media is \#winning. — A popular hashtag on social media is #Winning.

Disabling Inline Meta

You can disable inline meta detection completely for a specific figure via the # button on the text inspector bar or text inspector
panel. You can globally disable automatic detection of inline meta via the Format > Default Figure Settings > Detect Inline Meta
menu item.

You can also right-click on a meta element and via that context menu escape the item (prefixes it with a \ ), disable inline meta
detection for the figure, or disable it globally by default.

Clicking Inline Meta

When you aren’t editing the figure, inline meta tokens are displayed as underlined links. Clicking them will bring up Quick Find to
instantly see other figures with the same meta.

Inline Tags and Renames

If you rename a tag in the tag inspector the inline tags within text figures will update themselves with the new name when the idea
space is re-loaded.

Inline Tags and Adornments

Normally when a figure is associated with a tag that tag’s image is placed alongside the figure as an adornment. However, for inline
tags an adornment is only displayed if an image exists for the tag. You can make it so inline tags never appear as adornments via
advanced settings.

Nested Inline Tags and Other Apps

Many popular apps such as Obsidian, Bear, Notejoy, and Noteplan all use / for nested tags. For example, #crp/active and
#all-countries/United-states . Other apps such as Drafts support , but simply as part of the tag’s name (thus just likea _ or
- ), not as a true hierarchical nesting separator, but it still works.
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Dates

This means you can easily exchange Curio text figure contents to or from those apps and any inline tags within those notes will map
over automatically.

Unfortunately Apple Notes and Agenda don’t support nested tags, and they don’t support the , as part of a tag’s name either.

Fortunately Curio will automatically attempt to match existing tag sets and tag names even if different separators are used. So
pasting text from Apple Notes which has the inline tags #a11-countries-uUnited-states and #apple-ipPhone-Pro Will automatically
match the Curio nested tags al1-countries/United-States and apple/iPhone-Pro . That way you can easily mimic nested tags in
those apps and bring those notes into Curio text figures.

Assign Figure Tags via Status Bar

You can use the Status Bar to view and quickly associate tags with the selected figures, including creating new tags.

Dates

Your figures can have assigned dates for easy task planning. Curio even supports automatic date calculations in collections such as
lists and mind maps so that tasks can have precedence ordering.

Start Date

Enable start dates with the on/off checkbox. Then you can set a start date. The date can be entered directly or you can click the
little calendar button to pick a date.

Optionally Curio can automatically calculate the start date if you wish. Curio’s pretty smart about this and will check to see if it
should be determined by you manually entering a date, or based on when a previous sibling (in a list or mind map) ends, or based
on when a previous sibling starts, or when a parent starts. Or you can directly choose one of those options if you wish. For example,
if an item is the first child in a list then Curio would automatically choose ‘based on when parent starts’. If the item is a middle child
then Curio’s chooses ‘based on when previous sibling ends’.

Due Date

Enable due dates with the on/off checkbox. Then you can set a due date. The date can be entered directly or you can click the little
calendar button to pick a date.

As with start date, Curio can automatically calculate the due date if you wish. In this case, the due date can be determined by you
manually entering a date, or automatically determined when this figure’s children have all ended, or based on the start date plus an
entered duration. If the due date is at midnight then the due date adornment next to the figure reports the day before. For example,
say in the date inspector for a figure you set the start date to June 6th at midnight and the due date to June 8th at midnight, thus it a
2-day duration. The resulting adornment will show “6/6 - 6/7” since that looks more appropriate (i.e. you have to work on the 2-day
task on 6/6 and 6/7). This change was made so it matches what is displayed in applications such as Calendars where the task
would be displayed from 6/6 to 6/7.

Start/Due Date Action Button Menus

Note both the start and due date areas have action button menus which allow you to specify if ‘manually’ should always be used as
the default.
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Via the action button you can also specify your project work schedule including work days and work hours. Curio will use this work
schedule to automatically determine task end dates based on start dates and durations within the current project. For instance, click
to turn off Saturdays and Sundays if you want Curio to ignore weekends when calculating due dates and durations. This same work
schedule is taken under consideration when using the +1 Day, +1 Week, and +1 Month buttons.

The start date action button also allows you to specify what time should be used: either midnight, the current time, or the workday
start.

Duration

Specify a duration for the figure in minutes, hours, days, weeks, months, or years.

Curio can use these durations when computing start and due times for siblings and parents figures in a hierarchical collection such
as a list or mind map.

Note that if the due date is determined by some means other than Start Date + Duration then the duration and most appropriate
duration units will automatically be determined and displayed.

Done Date
The done date is completely independent of a figure’s specified end date. You can think of the former as when the task was actually

done, while the latter is when the task needs to be done.

By default the done date is automatically set when a figure is checked or marked as 100% completed. The reverse is also true, if
you set a done date Curio will make sure the figure is marked as 100% completed and checked if the figure checkmark is visible.

The done date also has an action button menu where you can fine-tune the done date’s automatic setting, and also specify how the
done date time should be reported: start of the day, the end-of-work day as specified by the Workday Schedule (set via the dates
meta actions menu), or the end of day.

Added Date

The added date is set by Curio automatically when you add a figure to an idea space. However, we allow you to change the date if
you'’re trying to mark a specific date of entry for note-taking or research purposes.

Assign Dates via Mini Popover

Curio has a handy mini popover for setting dates which can be handy when you don’t want to bring up the inspector.

* To show the date mini popover: ~=-Click an existing date adornment, or press the b key. You can also press b to
toggle start date or tp to toggle an end date. You can redefine the shortcuts if you wish.

* To hide the date mini popover: Press the Escape key, or click its little close button.

Assign Dates via Status Bar

You can use the Status Bar to view and quickly associate dates and durations for selected figures.

Last Modified Date

You can show the figure’s last modified date as a adornment capsule by enabling this option. The time can be optionally enabled as

well. The color is gray by default but can be overridden with a color hex code.

-180/423 - Copyright © 2025 Zengobi, Inc.


curio://defaults-write?Display%20Last%20Modified%20Time%20In%20Adornment=yes
curio://defaults-write?Last%20Modified%20Adornment%20Color=#44eeee

Resources

Resources

Assign resources to your figures and Curio can perform more advanced task tracking.

Adding Resources to the Project

You can specify a name, email address, and image for each resource either manually or by drag-and-dropping contacts from the
macOS Contacts app directly to the Resources inspector panel.

Deleting Resources

Select one or more resource items then click the Remove button to remove them.

Assigning Resources

Click the resource’s checkbox to actually assign a resource to a figure.

Here you can also double-click the ‘% Complete’ field to enter that person’s percentage complete value for this task. Curio can use
all of these assigned completion values to determine the figure’s overall completion value as noted above in the Meta tab discussion
above.

The resource’s image will be displayed next to figures as an adornment. In a hierarchical collection, such as a mind map or list, you
assign resources to child nodes and the parent nodes automatically inherit them. You cannot assign resources to a parent node
directly unless you uncheck the inherit from children checkbox in the resources inspector.

Assign Resources via Inline Resources

Inline meta detection is enabled by default. You can toggle this globally via the Format > Default Figure Settings > Detect Inline Meta
menu item, or for a specific figure using the # button in the text inspector.

This means you can enter inline resources anywhere within the contents of a text figure using the ¢ prefix, such as egeorge and
esteveJobs and they will be matched with existing project resources. If you enter an inline resource which is unrecognized Curio
will create the meta element automatically.

Note that matches are case insensitive and spaces and commas should be removed from resource names. So, for a resource
named Browning, George you should enter eBrowningGeorge .

Here in this example we have a stylized text figure with some inline tags and an inline resource, @GeorgeB. The inline tags and
resource are underlined, which shows that they have been recognized as inline meta, and clicking them brings up a Quick Find to
search for that meta. Notice that the resource’s associated image was automatically added as an adornment alongside the text.

| forests have pledged to end deforestation by 2030.
#COP26 #GTD/active @GeorgeB

Inline resources are useful for those that want to have always visible meta resource associations even if a resource doesn’t have an
associated image. After editing, behind the scenes Curio will associate or disassociate the figure with the given resource as
appropriate, as if you had selected it from an inspector.
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Ignored Inline Meta

If you’d like to type something that shouldn’t be interpreted as inline meta then you can escape it with a backslash ( \ ). When
rendered the backslash will be hidden:

Definitely check out \@zengobi on Bluesky. —> Definitely check out @zengobi on Bluesky.

Becaues of that backslash before the e Curio knows that the text ezengobi should not be interpreted as an inline resource.

Disabling Inline Meta

You can disable inline meta detection completely for a specific figure via the # button on the text inspector bar or text inspector
panel. You can globally disable automatic detection of inline meta via the Format > Default Figure Settings > Detect Inline Meta
menu item.

You can also right-click on a meta element and via that context menu escape the item (prefixes it with a \ ), disable inline meta
detection for the figure, or disable it globally by default.

Clicking Inline Meta

When you aren’t editing the figure, inline meta tokens are displayed as underlined links. Clicking them will bring up Quick Find to
instantly see other figures with the same meta.

Inline Resources and Renames

If you rename a resource in the resource inspector the inline resources within text figures will update themselves with the new name
when the idea space is re-loaded.

Inline Resources and Adornments

Normally when a figure is associated with a resource that resource’s image, or a generic “person” image, is placed alongside the
figure as an adornment. However, for inline resources an adornment is only displayed if an image exists for the resource, thus
generic “person” images won't appear. You can make it so inline resources never appear as adornments or appear even if generic,
via advanced settings.

Assigning Resources via Status Bar

You can use the Status Bar to view and quickly associate resources with the selected figures, including creating new resources.

Actions

The figure actions inspector can be used to specify what happens when a figure is double-clicked within the idea space.
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Setting an Action

Choose the desired action from the popup menu at the top of the inspector. The choices of action include:

* Default
Do the default double-click action for this figure. For example, for an image figure it would open the image, a URL would go
to the web location in the browser, an asset figure would open the asset file.

* Go to Idea Space
Choose an absolute item like first or last; a relative item like next or previous; or backward or forward in history.

* Open Link
Enter a link that should be opened.

 Create Mail Message
Enter a default ‘to’ and ‘subject’ field. Note that the message will be created and displayed but not actually sent.

* Open File
Choose a file that should be opened.

* Go to Jump Target
Begin by copying a figure or idea space so its jump location will be on the clipboard. then click Retrieve from Clipboard here
to retrieve it.

* Run AppleScript
When you click the Edit button the script associated with the action is dumped to a temp file then Script Editor is launched
to edit it and save to that location. When you click the Update with Edits button Curio retrieves the contents of that temp file
and stores it back into the figure’s action data.

* Do Nothing
Handy when you want to override the default so nothing happens when this figure is double-clicked.

Mac App Store Restriction
Curio from the App Store is unable to support AppleScript actions.

Adornment

By default Curio will show a little adornment next to a figure that has an assigned action. You can specify whether that adornment is
displayed or not.

Editing Figure Text

If you have a figure that has an assigned action, and a visible actions adornment, then double-clicking will edit the figure’s text. To
perform the action you have to click the adornment.

If a figure’s actions adornment is hidden the double-clicking will perform the action. To edit the figure select the figure and press
Return or click-pause-click.

You can make it so double-clicking an adorned figure performs the action instead with this setting.

Custom Data

Curio Professional users can create their own per-project custom data keys, such as Cost and Effort, and then enter figure values
for those keys.

-183/423 - Copyright © 2025 Zengobi, Inc.



Automatic formatting plus prefixes and suffixes are supported as well.

Custom Data vs Custom Variables

A related feature is custom variables. In short:

Custom Data

» Custom data allows you to create project-wide formatted keys, such as Price or Score, and then assign values to those

keys for each figure, adding custom meta data to every figure for searching and export purposes.

» Custom variables are text replacements for variables you create and use throughout your project. For example, you can

create a custom variable named Author and give it a value of George, then use the ({author}} variable markup syntax in

your project’s text figures.

Creating Custom Data Keys

Select any figure then, using the Custom Data inspector panel in the Meta inspector, click the action button menu (or right-click in

the custom data list) and choose Add Key.

Name
Prefix

Suffix
Style

Cost

‘We owe ‘

I

Currency

B

Thousands separator

Decimals 2 B

You can specify an optional prefix and/or suffix, which is prepended/appended to the formatted value, respectively.

In addition to simply treated entered values as text, Curio can perform automatic /ocalized formatting with the following formats:

* Number: 1,234.567

* Percentage: 50%

+ Scientific: 1.23E3

« Currency: $1,234.57

« Currency (Plural): 1,234.57 US dollars
+ Currency (ISO Code): USD 1,234.57

« Currency (Accounting): ($1,234.57)

+ Spell Out: one thousand two hundred thirty-four

* Ordinal: second

Localization of the thousands separator symbol, currency symbol, decimal separator, etc, are all automatically handled by the

macOS locale specified via System Settings > Language & Region settings.
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Modifying Custom Data Keys

Select any figure then, using the Custom Data inspector panel in the Meta inspector, select an existing key then click the action
button menu (or right-click in the custom data list) and choose Modify Key.

Deleting Custom Data Keys

Select any figure then, using the Custom Data inspector panel in the Meta inspector, select an existing key then click the action
button menu (or right-click in the custom data list) and choose Delete Key.

Warning
If you confirm the deletion of a custom data key, any key values associated with figures in the project will be removed as well.

This cannot be undone!

Editing a Figure’s Custom Data Value

Select the figure then, using the Custom Data inspector panel in the Meta inspector, right-click on the item and choose Edit Value,
or double-click on the value for that key.

Custom Data v
| Show only modified entries £ o)
Key Value
Contractor George
Cost We owe $10.50!

Effort 6 hours
Rating 70%

Note you’re editing the “raw” value for that key; don’t type commas or dollar signs or prefixes/suffixes. Once you finish editing Curio
will show the formatted value using the key’s specified formatter settings.

So if editing a percentage value enter the raw number, like “.8”, and the formatter will turn that into “80%” when you finish editing.
Similarly, entering a price as “2.5” will turn into “$2.50” when you finish editing.

Custom Data Adornment

When a figure has a custom data value it will display a special adornment alongside the figure. Hovering over the adornment will

display a tooltip with all the custom data keys and values.

Clear a Figure’s Custom Data Value

Select the figure then, using the Custom Data inspector panel in the Meta inspector, right-click on the item and choose Clear Value,

or double-click on the value for that key and press the Delete key.
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Importing/Exporting Custom Keys
You can easily copy custom keys between projects via the action button menu:
+ Choose Import Keys From Another Project, and then choose the project in the dialog that appears.

+ Choose Export Keys To File to export your keys to a specified file.
» Choose Import Keys From File to import keys from an export file.

Note

Copying idea spaces or figures from one project to another will not automatically construct custom data keys for you in that
other project. You can use the Import Keys From Another Project feature to create those keys, then copy/pasted figures
between projects will reveal those custom data values.

Using Custom Data Keys in Search

The Search shelf support custom data keys as well as a number of operators:

* For text values: Equals, Not Equals

» For numeric values: =, <, <=, >, >=
For example, you can search for where price > 10 OF Ccompleted < 50 .

Note that for percentage values you can search for the percentage (like 50 ), not the raw decimal value ( .5 ).

Search Exports

When exporting Search results your custom data values are also exported in rich text, markdown, and csv. If csv then the raw value
is output, else the formatted value.

Custom Data Variables

New (srigureCustombata} and {%FigureCustombatabelimited} Vvariables can be used within a figure to insert the formatted

contents of the figure’s custom data.
The former, {(srigurecustompata} , Shows them all as a block:

Price: $5.00
Pet: Butternut
Country: US

The latter, (sFigurecustompatabelimited} , Shows them all as a single line with each key/value pair delimited by a semicolon by

default:
Price: $5.00;Pet: Butternut;Country: US

Specific Custom Data Variable

You can also output a specific variable like this: (srigurecustompata:price} and it will be replaced with the variable’s formatted

value.
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Exporting Custom Meta

If exporting meta is enabled during figure export via Share (or Copy) then custom data is included with that export. Exporting figures
as plain and rich text exports include the formatted values for custom data, while markdown output will show the raw values:

#Price="123456789.258" #Name="Santa Claus" .

Importing Custom Meta

Curio will import meta parsed during paste as list or mind map. Matches existing keys with case insensitive search and stripped
spaces.

Example formats supported:

®* Hello there (@data(KeyOne="Value One", KeyTwo="Value Two")

®* Hello there #KeyThree="Value Three" #KeyFour="Value Four"
Note keys must have no spaces, but will match existing custom keys with spaces, and values have to have quotes.

Custom data keys will be created if a suitable key is not found. If custom data keys were created, you can always modify them later
to change casing or add spaces. This automatic key creation auto detects numbers and will set as a decimal number type of
custom data key, although you may have to fine tune the number of decimals and thousands setting. Otherwise created as a key
with text values.

Hierarchical Sum-Ups

In hierarchical collections like lists and mind maps, custom data numeric fields will automatically sum up into parent items.
For example, if you have custom data such as effort=4 , cost=25.50 , etc, then those values will bubble up to their parent nodes.
Negative numbers are allowed, for example to offset an effort or cost.

You can disable this sum-up ability if you wish.

Technical

« Internally if a key has text values then items are stored as strings. Otherwise, if a number format, then a high precision
number ( NsbecimalNumber ) iS used.

* This means entering and viewing numbers will automatically localize as appropriate: 1.234 in the US vs 1,234 in Germany.

« If you switch a key type from text to number then Curio will do its best as it works with existing values to convert on the fly (it
asks the macOS  wsnumberrormatter class to convert it on the fly based on current locale). However, ideally you should stick
with either text or a number from the get-go before entering values everywhere.

+ Known issue: parent items do not clear sum-up values if you delete all children. This gets messy as the parent nodes don’t
know if you previously had children and now you don’t or if you never had children.

Info

The Info inspector is shared with Organizer items so you can find more information in that topic.
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Line

Line

If the selected figure is a line figure then you’ll find more options available to you.

Type

Specify how multi-point lines should be drawn:

« Straight
* Curved
+ Orthogonal

Midpoints

Add one or more midpoints to your line. Note you can also right-click on the line to add a midpoint at that location.
To remove a midpoint, right-click on it and choose to remove it.

To move the midpoint, you can drag it although, especially with curved or orthogonal lines, you may find using the keyboard arrow
keys more reliable. Hold Shift when using the arrow keys to take greater steps.

Tail and Head Arrows

From the two lists you can choose a tail and/or head arrow decoration.

Scale

Set the scale of the arrow decoration which will increase or decrease their size.
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Collection Figures

Collection Figures

A collection figure is a special type of figure that contains, manages, and positions figures within it. Curio includes several bundled
collection figures such as list, mind map, table, index card, pinboard, and album collections, all detailed below.

While a collection figure can contain other figures in general it cannot contain another collection. For example, you can’t place a
table into a mind map or an index card into a list.

Composition Collections

As mentioned above, while in general a collection can’t contain another collection, like putting a list within a mind map, there’s an
exception to this rule.

Curio’s composition collections are specifically designed to contain and organize all sorts of figures including collections and even
other compositions! For example, a tabloid composition can organize the layout of several text figures, a few images, some lists, a
couple of tables, plus a matrix composition which itself contains a grid of text and mind map figures.

When to Use Compositions

The Fundamental Difference

Traditional collections (lists, mind maps, tables, stacks) are designed for specific organizational patterns with their own rules and
constraints. Compositions break free from these limitations—they’re Uber collections that can contain anything, including other
collections and even other compositions.

When Compositions Excel

Complex Multi-Format Documents

Compositions shine when you need to combine different types of information in a single, cohesive layout:

* Research reports that blend text summaries, data tables, mind map analyses, and supporting images
* Project documentation mixing task lists, timelines, reference materials, and visual diagrams
» Meeting notes combining agenda items (lists), discussion topics (mind maps), action items (tables), and supporting files

Dynamic Content Layouts

Unlike static collections, compositions automatically adjust their layout as content changes:

* Newsletters or articles where text, images, and data need to flow together naturally
» Dashboards combining multiple collections (task stacks, priority lists, status tables) that update independently
* Presentations where content needs to reflow as you add, remove, or resize elements
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Collection vs. Composition Decision Points

Hierarchical Information Architecture

When your information needs go beyond what a single collection type can handle:

* Knowledge bases with main topics (tabloid layout) containing detailed breakdowns (matrix grids)
» Course materials with chapter overviews (tabloid) and structured exercises (matrix)
* Product planning with feature categories (tabloid) and detailed specifications (matrix)

Collection vs. Composition Decision Points

Use Traditional Collections When:

* You have a single, consistent data type (all text items — list; all related concepts — mind map)

* You need specific organizational behavior (hierarchical thinking — mind map; sequential tasks — list)

* Your content is uniform in structure (tabular data — table; similar items — stack)
* You want collection-specific features (mind map layouts, list numbering, table calculations)

Use Tabloid Compositions When:

* You need flexible multi-column layouts that adapt to content

* Your document contains mixed content types (text + images + collections)
* You want newspaper/magazine-style flowing layouts

» Content needs to reflow automatically as you edit

Use Matrix Compositions When:

* You need structured grid organization with consistent column relationships
* You’re creating comparison layouts (features vs. products, topics vs. details)
* You want immediate cell editing without complex setup

* You need swim lanes or dashboard-style arrangements

Tabloid Composition
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Curio’s tabloid composition collection permits an
extremely flexible layout of rows and columns which
mimicks the flowing style of newspapers and
magazines.

As a reminder, as a composition collection, tabloid is
able to contain and organize all sorts of figures
including collections and even other compositions!

A tabloid composition is made up of 3 component
types:

1. It starts with one or more independent rows.

2. Each row is made up of one or more columns.

3. Each column is made up of one or more
stacked figures.

So the most basic composition is a single row, with a
single column, with a single figure.

Sample Use Cases

Tabloid Composition

Introducing Composition Figures

/A composition is made up of rows, which contain one or more columns, which contain one or more figures. For example this row has just a single
column with a single figure. Rows are separated from each other with a vertical “row gap” which can be set in the inspector.

Columns are separated from each other by

| This is a new row with 3 columns. |

By default column widths are automatic
based on the width of the composition
figure.

a horizontal “column gap” which can be set
in the inspector.

YYou can drag a figure to the left or
right side of an existing column to
insert a new column.

However you can use the inspector to
enter a specific width for a column in
points, if you wish. The Insert menu reveals fots of
handy keyboard shortcuts to insert
text before or after the current
figure, or in a new column, orin a
new row.

Notice this is a single, multi-paragraph
| textfigure.

Figures within a column are separated from
each other by a vertical “figure gap” which
can be set in the inspector.

You can also rearrange figures
anywhere within the composition
My List via drag and drop.
v 1. An embedded list figure.

a. Within the composition. .

) ¢ 1 Helpful guides will appear as you
b. In a column. 4 il v N drag so you know if you're

2. Pretty slick! inserting as a row, as a column, or
within a column.

Last Year This Year G eorge’s To Do

# of Smiles

# of Frowns

‘ Get feedback. ‘

Use the Insert menu or toolbar button to insert a
new item after the current item within the same
column. Hold Option to insert as a new row.

‘ © Add more. ‘

And of course a text figure can have a simple markdown list like this:
1. Compositions are great.

2. Curio likes markdown.

3. Supercharged productivity!

So you can have an incredible mix of content within a composition.

+ Use a tabloid composition with just a single column in each row. As you edit, insert, or delete contained items, the

composition will neatly and automatically spread them out or pull them back in. Essentially turning itself into a very smart

auto spaced column.

+ Use a tabloid composition to take notes or collect research. Dragging text, images, and collections alongside into additional
columns as needed to create more complex column arrangements more like a newspaper or journal article. Remember each

row independently manages its number of columns and their sizing so you can have one row with a single column while

another might have 5 columns.

Video

Watch a tabloid composition figure demonstration video on our YouTube channel.
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https://youtu.be/ANu3Na8TmQI

Tabloid Composition

Create a Tabloid

+ Use the Insert popover to create a composition via its style and stencil gallery, or use the Insert menu.

Dragging into a Tabloid

As you drag figures over the empty collection, a red bar will appear so you know how your dropped items will be arranged:

+ Thin Red Horizontal Bar with Circles means that a single new row will be created and all figures will be added as stacked
siblings within single new column in that row.

+ Thin Red Vertical Bar with Circles means that a single new row will be created and all figures will be added each as within
its own column within that row.

* Thick Red Horizontal Bar means that new rows will be created for each dropped figure.

Working with Rows

A row spans the entire width of the tabloid composition.

The rows of a composition are separated from each other by a vertical row gap which can be set in the tabloid inspector.

Dragging into a New Row

If you drag a figure into a composition and hover between rows, a thick red bar spanning the width of the row indicates a drop will
insert the figures into a new row.

Using the Row Grabber

If you hover over the left side of a row a grabber will appear which you can click to select all the figures in the row or drag-and-drop
to rearrange rows. If you hold Command (&) when clicking you can select disparate rows or hold Shift ({}) when clicking to select a
range of rows.

Working with Columns
A row can have one or more columns. Each row is independent, so one row could have 3 columns, another 2, and another just 1.

The columns within a row are separated from each other by a horizontal column gap which can be set in the tabloid inspector.

Dragging into a New Column

If you drag a figure into a composition and hover to the left or right of a column, a thin red vertical bar with circles spanning the
height of the column indicates a drop will insert the figure into a new column.

Working with Figures

Each column can have one or more contained figures, which are neatly stacked within the column. The stack is always top-aligned,
the figures cannot be sized to span the height of the row, or aligned to the center or bottom.

The figures within a column are separated from each other by a vertical “figure gap” which can be set in the tabloid inspector.

Dragging into a Figure Column

If you drag a figure into a composition and hover above or below a figure, a thin red horizontal bar with circles spanning the width of
the column indicates a drop will insert the figure into the column figure stack.
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Tabloid Composition

Inserting New Text

If you have an empty composition, double-click anywhere to create a text figure (in a new column and row).

Otherwise, select or edit an existing figure within the composition and use the menu items at the very top of the Insert menu or their
corresponding shortcuts:

* Insert Text After Selected (38<J)

* Insert Text Before Selected ({7 $8+J)

* Insert Text In New Row (\=¥6<J)

* Insert Text In New Column (=1} #<«J)

When editing a text figure, pressing Return («J) inserts an actual return into the text figure allowing you to easily create figures with
multiple paragraphs. If you want to create a new sibling figure use ¥« or one of the other shortcuts mentioned above to insert the
new text figure.

You can optionally tell Curio to make it so Return creates a new figure instead. In that case you could still be able to insert a return

into the text figure by pressing Option-Return (""«J).

Inserting New Figures

Select a figure in the composition and use the Insert menu, the Insert toolbar button and gallery, or a specific collection’s toolbar
button (like the List toolbar button), to insert the figure after the currently selected figure as a sibling within the same column. If more
than one figure is selected then it will place the figure in a new next row under the selected figures.

Note the trick with using the Shift key on a collection toolbar button, like the List toolbar button, to create an instant default styled
collection bypassing the gallery also works with the composition. For example, click Shift-List to get an instant list in the same
column.

Collect a Selection of Figures into a Tabloid Composition

1. Select one or more unlocked figures.

2. Choose Arrange > Collect Into > Tabloid Composition.

3. A new tabloid composition figure containing the selected figures, one row per figure, will be created and centered in the
visible portion of the idea space.

Rearranging ltems Via Keyboard

1. Select one or more figures.

2. Press ~ {11 or ~{ | to move the figures.

3. If you have a row of figures selected then the row will be moved up or down. If all the figures within a column are selected
then the columns will be moved left and right. If figures within a column are selected then they will move up and down within
the column.

Context Menu

Right-click an item in a tabloid composition to perform common operations like inserting rows and columns, and selecting figures.

Navigating using Arrow Keys

You can use arrow keys to navigate between items in the columns and rows. Hold Shift to create selected ranges.
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Tabloid Inspector

Tabloid Inspector

When a tabloid composition figure is selected, the inspector shelf will reveal a new Tabloid tab:

Tabloid

Certain properties are used for the entire tabloid composition.

Row Gap

Set the vertical gap between rows, in points.

Column Gap

Set the horizontal gap between columns, in points.

Figure Gap

Set the vertical gap between figures within a column, in points.

Selected Rows

Certain properties can be set for selected rows. Note this rows are has an actions button menu you can use to perform actions such
as copy, paste, or clear selected row styles.

Row Color

Set a background color for the row. If a color is specified then the height of the row grows by the row gap amount so the coloring
isn’t tightly constrained around the row perimeter.

Row Borders

Set a top, bottom, left, and/or right border color and thickness.

Row Separator

Choose a separator to be drawn after the current row, unless it’s the last row. You can also specify the color of the separator and
whether the separator is the full width of the composition figure or not.

Selected Columns

Certain properties can be set for selected columns.

Column Width

Specify a width for the selected columns.

The default is auto where Curio proportionally distributes the available space between the columns. Alternatively you can specify an
exact width for a column, in points.

When using the inspector to set a column size, if you use the spinner control it normally increases or decreases the width by 1 point.
You can hold Shift when clicking for +10 points, or hold Option for +100 points.
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Matrix Composition

At least once column must be auto so it can act as a flexible filler to maintain the width of the row. If no auto column is found then
the last column will be auto.

If a column contains a figure with a minimum width, like a mind map, wider than the specified column width then that value will be
used instead.

1. The layout algorithm will first determine specified column widths, overriding with a contained figure’s minimum width if
found.

2. Next it will iteratively distribute available space between all auto width columns, borrowing space from some that can
contribute to another if it contains a figure with a minimum width requirement.

3. This iterative process ends once all available space has been distributed to each auto column and they all collectively fill the
entire row’s width.

Selected Figure
You can set a figure’s horizontal alignment (center, left, right) within its column of figures. The default is centered.

Note that some figures (text, most collections) fill the cell completely so the alignment doesn’t impact anything. But if you resize a
contained image, for example, then you can make it align to the left or right if you wish. For a text figure, its width is the full width of
the figure so you’d want to use the paragraph alignment buttons in the text inspector to make those changes.

Matrix Composition

As a reminder, as a composition collection, matrix is
able to contain and organize all sorts of figures Kitty Man Truisms
including collections and even other compositions!

Kitty Man likes to sitin pots. ‘

Matrix permits an easy grid layout of contained items Kitty Man likes warm

weather.

stored in cells within a specified number of columns

and rows. Columns are resizable and extend through
all rows. Contained items are sized to fit within the
column width, with the row heights automatically

Creativity o ivergent Thinking
determined. tru-ism )
a statement that is
obviously true and
Unlike a tabloid composition, a matrix composition’s says nothing new

or interesting

Brainstorm

grid of cells are immediately ready to edit simply by

Problem Solving )oX

double-clicking a cell to enter text. Or, as with any
matrix cell, you can just drag-and-drop or paste

another figure or file on a cell to replace its contents.

Contained text figures fill the entire cell both in width and height and center their text vertically and horizontally by default. Some
contained figures, such as images and tables, can have their heights resized: images resize proportionaly and center themselves
within the cell, a table’s rows will proportionaly resize its rows vertically.

Drag any figure from the idea space or file from the Finder or Library directly onto a cell to replace its contents with the new item, or
drag in between rows to create a new row for that item. You can easily rearrange or copy rows and columns using grab handles. A
default text style can be associated with a matrix composition and/or applied to other text figure cells.
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Matrix Composition

Sample Use Cases

» Use a matrix composition to create a “swim lane” diagram, with text topics in the first column and mind maps detailing each
topic in the second column.

+ Use a matrix composition to create a dashboard of synced stacks or lists, conslidating tasks and action items from your
project’s idea spaces.

Create a Matrix

+ Use the Insert popover to create a composition via its style and stencil gallery, or use the Insert menu.
* The initial matrix will have 2 columns and 1 row, containing 2 placeholder text figures.

Cell Outlines

You might notice after creating a matrix that the cells of the matrix are given light gray outline borders. This way you can instantly tell
how many rows and columns you have. These thin outlines are not drawn if the matrix is not active.

Once a cell has visible content — that is, it has a figure within that has its own border, or fill color, or text/image — then the thin outline
for the cell is no longer drawn as you can easily tell that a cell must exist at that location.

Dragging into a Matrix

You can drag figures or files into any cell within the matrix to replace the contents of that cell.
As you drag figures or files over a matrix, a red glow will appear so you know how your dropped items will be arranged:

* Red Rectangular Glow means dropping will replace the contents of that cell with the dropped figure.

* Red Horizontal Bar with Circles means that a new rows will be created for the given items and the items will appear in
those new rows.

* Red Vertical Bar with Circles means that a single new column will be created and the items will appear in that new column.

Working with Rows

A row spans the entire width of the matrix composition.

The rows of a composition are separated from each other by a vertical row gap which can be set in the matrix inspector.

Row Heights

Row heights are automatically determined based on the enclosed figures, thus the matrix composition figure’s height is
automatically determined as well. As those figures expand or shrink the rows themselves will resize automatically.

Dragging into a New Row

If you drag a figure into a composition and hover between rows, a red horizontal bar spanning the width of the row indicates a drop
will insert the figures into a new row.

Using the Row Grabber

If you hover over the left side of a row a grabber will appear which you can click to select all the figures in the row or drag-and-drop
to rearrange rows. If you hold Command (§8) when clicking you can select disparate rows or hold Shift ({}') when clicking to select a
range of rows.
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Matrix Composition

Working with Columns

A column spans the entire height of the matrix composition.

The columns of a composition are separated from each other by a horizontal column gap which can be set in the matrix inspector.

Column Widths

The contained figures will determine the minimum widths for the columns but you can also resize individual columns or the entire
matrix composition itself to give each column more room.

If you hover between two columns you will see a vertical drag bar appear to resize the width of that column. A drag bar will even
appear for the last column so you can resize it as well.

If you resize the width of the matrix composition figure itself then all the columns will resize proportionally.

The inspector has a distribute button that you can use to distribute the widths of the selected columns (or all columns if the matrix
itself is selected) evenly between those columns.

Dragging into a New Column

If you drag figures into a composition and hover to the left or right of a column, a red vertical bar with circles spanning the height of
the column indicates a drop will insert the figures into a new column, adding rows as necessary for all the figures.

Working with Figures

Each column can have one or more contained figures, which are neatly stacked within the column. The stack is always top-aligned,
the figures cannot be sized to span the height of the row, or aligned to the center or bottom.

The figures within a column are separated from each other by a vertical “figure gap” which can be set in the matrix inspector.

Inserting New Text
An empty cell in a matrix will always have a placeholder text figure. Simply double-click that figure to edit its text.

Otherwise, select or edit an existing figure within the composition and use the menu items at the very top of the Insert menu or their
corresponding shortcuts:

* Insert Text In New Row After Selected (<)
* Insert Text In New Row Before Selected ({]36<J)

When editing a text figure, pressing Return («J) inserts an actual return into the text figure allowing you to easily create figures with
multiple paragraphs. If you want to create a new sibling figure use %< or one of the other shortcuts mentioned above to insert the
new text figure.

Inserting New Figures

Select a figure in the composition and use the Insert menu, the Insert toolbar button and gallery, or a specific collection’s toolbar
button (like the List toolbar button), to insert a figure into the matrix composition. If a placeholder text figure is selected the new
figure will replace the placeholder. Otherwise the new figure will be inserted into a new row after the currently selected figure.
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Matrix Inspector

Note the trick with using the Shift key on a collection toolbar button, like the List toolbar button, to create an instant default styled
collection bypassing the gallery also works with the composition. For example, click Shift-List to get an instant list either replacing
the selected placeholder or in the next row.

Collect a Selection of Figures into a Matrix Composition

1. Select one or more unlocked figures.
2. Choose Arrange > Collect Into > Matrix Composition.
3. A new default matrix composition, with 2 columns, will be created and all selected figures added to the composition.

Rearranging Iltems Via Keyboard

1. Select one or more figures.

2. Press ~ {11 or ~{ | to move the figures.

3. If you have a row of figures selected then the row will be moved up or down. If all the figures within a column are selected
then the columns will be moved left and right. If figures within a column are selected then they will move up and down within

the column.

Context Menu

Right-click an item in a matrix composition to perform common operations like inserting rows and columns, and selecting figures.

Navigating using Arrow Keys

You can use arrow keys to navigate between items in the columns and rows. Hold Shift to create selected ranges.

Matrix Inspector

When a matrix composition figure is selected, the inspector shelf will reveal a new Matrix tab:

Matrix

Certain properties are used for the entire matrix composition.

Columns

Set the number of columns in the matrix.

By default as you add or remove columns the matrix will try to maintain its current width, only resizing if necessary to contain its
figures. If you hold Shift while adjusting the number of columns the matrix will increase or decrease the matrix width.

Rows

Set the number of rows in the matrix.

This will always increase the height of the matrix as the row heights are computed automatically to contain the items within the row.

Column Gap

Set the horizontal gap between columns, in points.
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Lists

Row Gap

Set the vertical gap between rows, in points.

Selected Columns

Certain properties can be set for selected columns.

Column Width

Click the distribute button to evenly distribute the widths of the selected columns (or all columns if the matrix itself is selected).

Selected Cell

You can set a cell’s horizontal alignment (center, left, right) and vertical alignment (center, top, bottom). The default is centered in
both directions.

Note that some figures (text, most collections) fill the cell completely so the alignment doesn’t impact anything. But if you resize a
contained image, for example, then you can make it align to the left or right if you wish. For a text figure, its width is the full width of
the figure so you’d want to use the paragraph and vertical alignment buttons in the text inspector to make those changes.

If the selected cell is a text figure then you can set its style as the default style for text figures. Note this won’t change any current
text figures, only new text figures when columns or rows are added.

You can also apply the selected text figure’s style to all existing text figures.

Lists
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Lists

f

Making to-do lists and outlining ideas is a natural part

A Styled List

of brainstorming. Curio’s List tool makes it a breeze to

generate lists and outlines of any kind right on an idea 1) Here is a list with a different style.

space. And Curio’s lists can contain more than just 2) The look of a list can be customized using
text; you can add images, documents, movies, sound the inspector.

clips, and any other type of figure that Curio supports. 3) Click the Inspector toolbar button to show the

inspector shelf.

4) You can select the list figure itself and
change its fill color, border, color, and font
using the various panels under the
inspector’s Shape tab.

5) Click the inspector’s List tab to see more
options.

v 6) Note the Sibling Styles and Child Coloring
options. These can be used to style
hierarchical levels and children in your list.

a) These items have a checkbox.

b) © And large red text.

7) Use the Tab and Shift-Tab key to indent or
outdent an item in the hierarchy. When
moved to another location either via Tab or
drag-and-drop the item is automatically
styled appropriately. To demonstrate, select
this item and press Tab to indent it where it
will become red with a checkbox. Press Shift-
Tab to outdent it and restore the previous

styling.

Default Styling

ltems created, dropped, or pasted within or into a collection will adopt the style appropriate for destination as determined by the
collection figure’s style. For example, a table style’s information will include the style associated with body cells vs header cells.
Likewise, a mind map style will include stylings for the various hierarchical levels in the mind map. If you drag an item from one
location in the mind map to another location, then it will adopt the styling appropriate for that location. There are advanced settings

you can tweak to change this logic. For example, you can make it so dragging within a table keeps existing styling but dragging
items into a table, from elsewhere, will adopt the appropriate styling.

Context Menu

Right-clicking on a list or a list item will show a context menu with lots of frequent operations so be sure to check it out!

Create a List

+ Use the Insert popover to create a list via its style and stencil gallery, or use the Insert menu.

Insert a New Text Figure as a Next Sibling

1. Select a list item.

-200/423 - Copyright © 2025 Zengobi, Inc.



Lists

2. Insert a next sibling by choosing the Insert > Text Next Sibling menu item or typing $Return. However, following a
convention used in other outliners, if the selected item has a child then this will actually create a new first child.

3. As a shortcut, if you are current editing a list item, you can simply type Return to create a new next sibling. If you want to
actually insert a carriage return within the edited text figure, then type ~“Return.

Insert a New Text Figure as a Previous Sibling

1. Select a list item.
2. Insert a previous sibling by choosing the Insert > Text Previous Sibling menu item or typing ${} Return.
3. As above, you can simply type {} Return to create a new previous sibling.

Insert a New Text Figure as a Child

1. Select a list item.

2. Insert a new first child by choosing the Insert > Text Child menu item or typing #~-Return.

Remove List ltems

1. Select the list items you wish to remove.
2. Press the Delete or Backspace key or choose the Edit > Delete menu item.
3. Any children will automatically be removed as well.

Indenting List Items Via Keyboard

1. Select one or more list figures.

2. Press the Tab key to indent the figures one level.

3. To move a set of figures contained by a list figure to a higher level in the hierarchy, follow the same steps listed above but
press {r Tab on the keyboard.

4. If you want to actually insert a tab within an edited text figure, then type ~-Tab.

Rearranging List Items Via Keyboard

1. Select or edit an item.
2. Press ~ {11 or ~{}'| to move the item up or down through its siblings.

Rearranging List Items Via Drag-And-Drop

1. Select one or more list figures and begin to drag them.

2. As you drag the items around, a line will appear showing you where they will be placed in the list, including their hierarchical
level. Notice that rearranging an item with children also moves the children.

3. Release the mouse button to drop the items into the list. If the Option key was held down during the drag then a copy of the
selected figures will be created.

Sort List Items

1. By default, you can manually rearrange the child nodes of a list parent via drag-and-drop as described above.

2. However, you can also tell Curio to keep those children automatically sorted by title, creation date, modification date, due
date, start date, start date or end date if already started, percent completed, priority, or rating, in either ascending or
descending order. You can specify a secondary sort as well. Make a change to a figure and instantly the figures rearrange
based on the sorting rule.

3. Select one or more sibling items in a list then use the list inspector to select a primary and secondary sort option.
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List Import/Export

Select Multiple Figures Within the List

- Either use the Shift or Command click to click on individual items, or hold Shift or Command and select a range of figures by
clicking and holding on the background of the list and dragging a rubber band selection region around figures.

Collapse or Expand a List

1. Select the list itself or a branch in the list.
2. Do a quick tap of the spacebar to collapse or expand the list. Alternatively, for branches, you can also click the little expand/

collapse widget.

List Import/Export
Add New ltems to a List Via Drag-And-Drop

1. Select figures from elsewhere in Curio, the Finder, or another application and drag them into Curio onto the list figure.

2. As you drag the items around a line will appear showing you where they will be placed in the list, including their hierarchical
level.

3. Release the mouse button to drop the items into the list. If the drag began within Curio, and the Option key was held down
during the drag, then a copy of the selected figures will be created.

4. List figures also support cut, copy, paste, and duplicate for adding and removing figures.

Collect a Selection of Figures into a List

1. Select one or more unlocked figures.
2. Choose Arrange > Collect Into > List.
3. A new list figure containing the selected figures will be created and centered in the visible portion of the idea space.

Convert a Mind Map into a List

1. Select the list figure.
2. Choose Arrange > Convert Into > List.

Prune off a Branch in the List into a Brand New Linked-To List

1. Right-click on a figure in the list and choose Prune To Linked Collection.

2. Curio will then create a new list, of the same style as the current list, where the selected parent becomes the title of the new
list and all of its children will be hierarchically arranged underneath.

3. The children of the original parent are then removed and the original parent itself becomes a jump action which, when
clicked, will zip you to the new collection. The new collection can remain on the current idea space or it can be cut and
pasted onto a different idea space, and the jump action will still track it down. The root of the new collection will
automatically gain a jump action to jump you back to the parent collection when clicked.

Import a Markdown File as a Curio List

1. If you drag in a markdown file containing only a markdown list into your Curio idea space and Curio will ask if it should be
converted into a native list or mind map figure.

2. Choose Insert > File, or drag-and-dropa .md Or .markdown file from the Finder into Curio.

3. Curio will ask you if you which to convert the file into a list figure. Click the “Convert to List” button; otherwise Curio will
simply treat the file as a normal document asset.
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Import an OPML File as a Curio List

1. If you are working with a 3rd party outlining application, such as OmniOutliner, you can bring a list into Curio as a list
collection via OPML import.

2. Choose Insert > File, or drag-and-drop an OPML file from the Finder into Curio.

3. Curio will ask you if you which to convert the file into a list figure. Click the “Convert to List” button; otherwise Curio will

simply treat the file as a normal document asset.

Paste a Text List from the Clipboard as a Curio List

1. Within the 3rd party application, select one or more lines of text and choose Edit > Copy.
2. Within Curio, choose the Edit > Paste As > List menu item. When parsing the list Curio will assume carriage-returns separate

items and tabs indent items.

Export a Curio List as an OPML, Mind Map Format, Text, or Rich Text File

1. Make sure the list figure itself is selected, not a figure within the list.
2. Use the Share toolbar button and choose to export the selected figure as OPML, one of several supported 3rd party mind
mapping formats, text, or RTF. For text and RTF Curio will use carriage-returns and tabs to separate and indent items.

Copy a Curio List as Carriage Return Delimited, Tab-Indented Text

1. Make sure the list figure itself is selected, not a figure within the list.
2. Choose the Edit > Copy As > Text menu item. Both RTF and plain text versions of the text are placed onto the clipboard.

List Inspector Bar

When a list is selected, the inspector bar will reveal new controls so you can customize the look of your list.

* List
Click this button to display the list inspector popover. The same panels are available in the List tab in the inspector shelf.

* Insert Child
Click this button to insert a child text figure under the current figure.

* Insert Sibling
Click this button to insert a next sibling after the current figure. Note if you hold the Option key down the button will change
subtly to indicate that clicking will insert a previous sibling before the current figure.

List Inspector

When a list figure is selected, the inspector shelf will reveal a new List tab:

Layout

Lists can be bulleted, numbered, or with no prefixes whatsoever.

Format

Set the bullets & numbering format for the list and the indented children it contains. By specifying this single property, Curio can

neatly enumerate all the items within your list, regardless of hierarchical level.
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Query

Specify a Search-style query and the list will turn into a smart collection, where the contents of the collection will be determined by

the query itself.

For example, entering a simple query of due < 2w will fill the list with all figures in the project that are due within 2 weeks or a query
of #active will show all items tagged with active.

Here’s a more complex query:

group:prioriy sort:start scope:section progress < 100 and ((start > 1w due < 1m) or #active or @george)

That query will create a list with results hierarchically grouped by priority and sorted by start date filled with all task figures in the
current section that aren’t done that start more than a week from now and due within the next month or figures that are tagged with
active or that are assigned to George.

Choosing a Saved Quick Find Query

Via the actions button next to the query field you can choose a saved Quick Find query. The title of the list will change to the title of
the Quick Find query, if it has one. Note that this isn’t a live connection to the query. If you later change the Quick Find query and re-
save it, this doesn’t impact any existing query-based lists.

Working with Query Collections

The list will be filled with synced figure instances that are connected to the original figures located elsewhere in the project. This way

you can change a result item’s text or the meta attributes, such as due dates and progress, and the changes will be pushed to the
original and any other instances of that original. You can also right-click on the instance and jump to the original figure if you’d like.

You can’t delete or rearrange the ordering of the items as they are both determined by the query itself.

Sorting and Grouping

By default Curio will automatically sort in the most logical method.

For example, if the query is based on due date then it will sort by due date. However, you can specify a sort if you wish, like

due < 2w sort:priority .

Unless you specify a grouping in the query your result will be a flat list. You can specify a grouping, like due < 2w group:due and
the result will be a 2-level hierarchical list with parent grouping nodes.

Refreshing Query Results

The results automatically refresh when the idea space is loaded. You can also right-click and choose Refresh Content, or click the
actions button next to the query in the inspector and choose Refresh Results.

The results will not refresh as you are working with them. This way they don’t suddenly disappear if you change a meta value.
Instead they will wait until the idea space is re-loaded or you force a refresh via right-click or actions button.

Results Limit

There is a safety limit of 100 just so you don’t have a collection explode with hundreds or thousands of items, but this can be
overridden.
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List Inspector

Level

The current level of the currently selected items is based on how many steps away it is from the root. Immediate children of the
central node is at level 1, their children are at level 2. You can specify certain options of all items that exist at a hierarchical level.

Line Spacing

You can increase or decrease the line spacing between siblings. Note that if the list itself is selected then spacing changes impacts
all items in the list. If, however, you have an item within the list selected then the spacing changes will only impact list items at that
hierarchical level.

Custom Numbering/Bullet Format

You can enable a custom number or bullet format for a specific level if you wish. This will override the default. You can enter an
optional prefix character, like a left-parenthesis or bracket, then choose the bullet or number element, then enter a suffix character,
like a right-parenthesis, bracket, or period.

Options
Title

The title for the list is displayed by default but you can turn this off if you wish.

Expanding/Collapsing

Child hierarchical levels can normally be expanded or collapsed via handle disclosure triangles. Those can be disabled as well
whereby the list is always displayed fully expanded.

List Siblings
Styling

Select a figure item within the list then you can:

1. Set Default Style for Level
Set that figure’s style as the default style for new figures added to that hierarchical level, without changing the styling of any
existing figures.

2. Copy Style to Siblings
Copy that figure’s style and apply it to its immediate siblings under the same parent.

3. Copy Style to Level and Set as Default
Copy that figure’s style and apply it to all figures at its hierarchical level (that is, its siblings and cousins) and set that style as
the new default for that level.

4. Copy Style to Level+Children and Set as Default
Copy that figure’s style and apply it to all figures at its hierarchical level and all sub-levels (that is, its siblings, cousins, and all
children) and set that style as the new default for all of those levels.

As a note, if you wish to manually style the list items don’t forget about the very handy Format > Copy Style and Format > Paste
Style menu items. This is a quick way to selectively apply a style to one or more figures.

Start Number

Select one or more siblings and you can then specify the number that should start these nodes under the current parent.
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Sorting

You can specify that siblings should be sorted by title, creation date, modification date, due date, start date, start date or end date if
already started, done date, added date, percent completed, priority, or rating.
You can optionally specify a secondary sort criteria, as well.

If you check the “recursively” checkbox then children of the children will sort themselves with the same sort criteria.

Note, however, if any figure uses a Start Date calculation based on a sibling then sorting will not occur with those children. Why? If,
based on sorting rules, figures jumped around based on title or priority, then at could have an unintended consequence on all your

figure dates! Basically, we’re assuming you placed those figures in specific precedence ordering — buy groceries then make dinner
— and we don’t want an automatic sorting to spontaneously ruin that ordering.

Note
Query-based lists are automatically sorted based on the query so these sorting popups aren’t available if you have a query
specified.

List Children

Colors

Select an item within the list then you can copy that selected figure’s colorings to all of its children. This means the rest of the child’s
style, like the shape borders and font size, will all stay the same but the border color, fill color, and font color will all be replaced with
the colors of its parent. This is a wonderfully quick way to make an entire branch of nodes all have the same color.

You can mark a child item so that it will automatically update its colors if its parent changes at any time. So, unlike the manual color
copying above, this will happen automatically if the parent changes.

Alternatively, if you have a parent selected, you can click a checkbox to make it so children of the selected parent automatically
inherit the colors of their parent. Basically the same effect as #2 above but instead of marking a specific child you can instantly mark
all children, and future children that you add to that parent. Uncheck this option to disable this functionality. You can also perform
this action via the right-click context menu on a list item.

Spread Color Palette
Curio can instantly spread a color palette across all main branches, so that each branch has its own color. Curio includes several

palettes of colors to make it fun to experiment with various palettes. See more notes below regarding branch coloring.

You can also use the actions menu to import and manage color palette files such as Adobe Swatch Exchange ( .ase ) swatch files
from Adobe Color or ColourLovers.

While Adobe Color requires a free Adobe account, once you’ve created the account you can use their site to create, manage, and
download color swatches.

You’ll need to register with ColourLovers, as well, if you’d like to downloaded created color palettes from their site.

The color swatches popup also supports a Curio Color Swatch ( .curiocolorswatch ) file with a carriage-return delimited list of hex
color values (like #aa22ff ) that you can create if you'd like.
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Mind Maps

Branch

A branch is the current node and all of its children, grandchildren, etc.

Apply Default Style to Selected Branch

Re-apply the default style information to the selected figure and to all of its children with just a single click. Useful if a branch has a
mix of styles and formatting.

A Note about Branch Coloring

Your saved list styles can include branch coloring!

If you apply branch colors to the top branches (the main branches under the title) of your list using the list inspector’s automatic
child coloring controls, for example perhaps you spread a color palette, then that branch information will now be stored as a part of
the collection’s style.

After creating new list styles which include branch colors, you can then apply those styles to your existing lists or to new lists and
the top branches will be colored appropriately.

When branch coloring is part of the style, the order of the branch coloring is maintained as you insert or delete top branches. So if
the branches should be red, green, blue, and orange — in that order — then those colors will be enforced as you modify the number
and ordering of branches under the central topic.

Mind Maps

Mind mapping is a wonderful technique for discovering connections between words and ideas, and encourages an easy

brainstorming approach starting with just one idea. This one idea — be it a word, phrase, or image — is expanded upon by adding
associated ideas in a radial fashion around the central idea. You then take each of those associated phrases and list ideas
associated with them.

A mind map’s central figure is called the central topic. This is the main idea or focus of the mind map.

Surrounding the central topic, are the main branches. These are your initial, primary topics or ideas that come to mind when
thinking about the central topic. For example, if the central topic is “Apple” then the branches surrounding it might include “Mac”,
“iPad”, and “iPhone”.

In general, you want to have only a few main branches under the central topic. If you have over a dozen main branches then
consolidating them into 4 to 10 branches would make the resulting mind map much more readable and organized and allow Curio to
optimize the mind map’s layout.

Subtopics can have subtopics, and those can have subtopics, etc, so your resulting branches can be quite large.

Topics and subtopics within Curio can be almost anything, not simply text. For example: images, videos, files, web links, audio
recordings, Mail messages, and more! And, like any figure within Curio, each figure within a mind map can include one or more tags
and other meta data information.
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Default Styling

ltems created, dropped, or pasted within or into a collection will adopt the style appropriate for destination as determined by the
collection figure’s style. For example, a table style’s information will include the style associated with body cells vs header cells.
Likewise, a mind map style will include stylings for the various hierarchical levels in the mind map. If you drag an item from one
location in the mind map to another location, then it will adopt the styling appropriate for that location. There are advanced settings

you can tweak to change this logic. For example, you can make it so dragging within a table keeps existing styling but dragging
items into a table, from elsewhere, will adopt the appropriate styling.

Context Menu

Right-clicking on a mind map or a mind map item will show a context menu with lots of frequent operations so be sure to check it

out!

To Create a Mind Map:

* Use the Insert popover to create a mind map via its style and stencil gallery, or use the Insert menu.

To Insert a New Text Figure as a Next Sibling:

1. Select a list item.

2. Insert a next sibling by choosing the Insert > Text Next Sibling menu item or typing $Return. However, following a
convention used in other outliners, if the selected item has a child then this will actually create a new first child.

3. As a shortcut, if you are current editing a list item, you can simply type Return to create a new next sibling. If you want to
actually insert a carriage return within the edited text figure, then type ~“Return.

To Insert a New Text Figure as a Previous Sibling:

1. Select an item in the mind map.
2. Insert a previous sibling by choosing the Insert > Text Previous Sibling menu item or by typing 31} Return.
3. As above, you can simply type {} Return to create a new previous sibling.

To Insert a New Text Figure as a Child:

1. Select an item in the mind map.
2. Insert a new last child by choosing the Insert > Text Child menu item or by typing $6~-Return.

To Add New Sibling Items to a Mind Map Via Keyboard:

1. Select an item in the mind map.
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2. Press the ¥Return key to create a new next sibling or 81 Return to create a previous sibling of the selected figure. If you are
currently editing an existing figure then you can just press Return or {} Return.

To Add New Child Items to a Mind Map Via Keyboard:

1. Select an item in the mind map.
2. Press the Tab key to create a new child of the selected figure.

To Add New Items to a Mind Map Via Drag-And-Drop:

1. Select figures from elsewhere in Curio, the Finder, or another application and drag them into Curio onto the mind map figure.

2. As you drag the items around the guides described above will appear showing you where they will be placed in the mind
map.

3. Release the mouse button to drop the items into the mind map. If the drag began within Curio, and the Option key was held
down during the drag, then a copy of the selected figures will be created.

4. Mind Map figures also support cut, copy, paste, and duplicate for adding and removing figures.

To Remove Mind Map Items:

1. Select the mind map items you wish to remove.
2. Press the Delete or Backspace key or choose Edit > Delete.
3. Any children will automatically be removed as well.

To Select Multiple Figures Within the Mind Map:

- Either use the Shift or Command click to click on individual items, or hold Shift or Command and select a range of figures by
clicking and holding on the background of the mind map and dragging a rubber band selection region around figures.

Rearranging Mind Map Items Via Keyboard

1. Select or edit an item.
2. Press ~ {11 or ~{ | to move the item up or down through its siblings.

Rearranging Mind Map Items Via Drag-And-Drop:

1. Select one or more mind map figures and begin to drag them.
2. As you drag the items around, and hover over an existing figure, guides will help you determine where they (and their
children) will be placed.
o If you hover the mouse near the top of an existing figure, any red line will appear indicating that, if you drop the items,
they will be inserted as previous siblings to this figure.
o If you hover the mouse near the bottom of an existing figure, a red line will appear indicating that, if you drop the
items, they will be inserted as next siblings to this figure.
° If you hover over the middle of an existing figure, it will glow to indicate that, if you drop the items, they will be added
as new children to this figure.
3. Release the mouse button to drop the items into the mind map. If the Option key was held down during the drag then a copy
of the selected figures will be created.
4. As mentioned in the collection figures overview, when moving figures around they will adopt the styling appropriate for that
location by the collection figure’s style information. If you wish to keep a figure’s existing styling then hold Shift before
dropping the figure.
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Working with Transparent Mind Maps

1. If your mind map has no fill color, Curio supports a kind of transparent selection so you can directly manipulate the mind
map nodes more easily.

2. If either the mind map is unselected or if a node within the mind map is selected, then you can now directly click and drag on
the background of the mind map to “rubber band-select” a range of nodes.

3. If you click and release within the mind map figure but not on a node, then the mind map figure itself will be selected. Once
selected you can then change its inspector properties, or copy it, or drag it, etc.

4. You can now directly click and drag on a node, even if the mind map itself was not already selected, and just start dragging
to immediately move it to a new location.

5. Another way to move the entire mind map is to click and drag the central topic node.

Rearranging List Items Via Keyboard

1. Select or edit an item.
2. Press ~ {11 or ~{}'| to move the item up or down through its siblings.

Sort Mind Map Items

1. By default, you can manually rearrange the child nodes of a mind map parent via drag-and-drop as described above.

2. However, you can also tell Curio to keep those children automatically sorted by title, creation date, modification date, due
date, start date, start date or end date if already started, percent completed, priority, or rating, in either ascending or
descending order. You can specify a secondary sort as well. Make a change to a figure and instantly the figures rearrange
based on the sorting rule.

3. Select one or more sibling items in a mind map then use the mind map inspector to select a primary and secondary sort

option.

Manually Positioning Branches Via Drag-And-Drop:

1. In Curio you can manually position the top, main branches of a radial mind map. That is, those nodes directly under the
central topic. However, Curio will automatically control the positioning of the nodes under each branch.

2. Select the topic figure at the top of a branch under the central topic and drag it.

3. As you drag the item around a target symbol will appear showing you where it will be manually positioned in the mind map.
Other branches that remain as automatically positioned items will automatically adjust their placement to ensure no overlap

OocCcurs.

To Add an Attachment to an Existing Mind Map Text Figure:

1. Right-click on a text figure within your mind map and choose Attach File then choose a file from anywhere on your hard disk
in the dialog that appears. This file can be copied or moved into the project as an embedded asset or referenced as an alias.
2. More information can be found in the Text Figure Attachments section.

To Add a Caption to an Existing Mind Map Image or Asset Figure:

1. Right-click on an asset figure displayed as a preview within your mind map and choose Show Caption.
2. More information can be found in the Display panel of the figure shape inspector section.

To Show a Relationship Line Between Two Different Figures in the Mind Map:

1. Select a figure in the mind map then press # and select a second figure in the mind map.
2. Right-click and choose Add Relationship Line, or click the Add Relationship Line button in the mind map popover.
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3. Anew line — a true Curio line figure in fact — will connect the two figures. This line will be set with a handy midpoint and
have a curved line style so you can grab that midpoint and move it around to bend it any way you wish. As a real line figure
you can completely customize its style using the inspectors.

4. Once you have styled the relationship line the way you like you can create a saved style for it by right-clicking on the line and
choosing Save As Line Style. You can also make this the default relationship line style via the Format > Save as Default Style
for Relationship Line Figure menu item.

5. You can also double-click the line to give it a line label. Don’t forget, the easiest and most accurate way to move a
relationship line label is using the arrow keys on your keyboard. Hold Shift with the arrow keys to move in greater steps.

Mind Map Import/Export

Curio supports several mind mapping file formats for easy import/export.

Note that formatting and layout information such as fonts, shapes, coloring, and positions are not imported or exported. Instead a
default Curio mind map style is applied and the mind map is automatically laid out.

iThoughts

iThoughts is available for both iOS and macOS and Curio supports its .itmz file format. Curio supports many iThoughts properties
including title, note, flags (at least the ones that map to Curio flags), checkmark, percent complete, priority, start date, due date, and
hyperlinks. Curio will also import or export images or other files attached to mind map nodes. Currently, Curio doesn’t support
iThoughts floating topics.

After exporting from Curio into iThoughts, you may need to force a re-layout by tapping the Gear icon > Map Layout then tapping
Vertical then Horizontal.

Mindjet MindManager

Mindjet MindManager’s .mmap format is one of the most popular mind mapping formats and supported by most 3rd party mind
mapping apps on macOS, iOS, and Windows. Curio supports MindManager properties including title, link, note, flags (at least the
ones that map to Curio flags), checkmark, percent complete, priority, start date, due date, and duration. Currently Curio doesn’t
import or export asset files (aka attachments).

MindNode

MindNode is available for both iOS and macOS and Curio supports its .mindnode file format. As of this writing, the MindNode file
format only includes the title of the nodes which Curio can import and export. Currently Curio doesn’t import or export images or
other asset files (aka attachments).

After exporting from Curio into MindNode, you will need to force a re-layout by selecting the central topic node and clicking the Fold
toolbar button then the Unfold button.

iMindMap

iMindMap is available for both iOS and macOS and Curio supports its .inx file format. Curio can import iMindMap title, start/due
date, percent complete, and priority information. Curio can export title, start/due date, and a handful of flags. Currently Curio
doesn’t import or export images or other asset files (aka attachments).

After exporting from Curio into iMindMap, you will need to force a re-layout by clicking the Clean Up button in the toolbar.
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MindMeister and FreeMind

While these formats are not supported directly, there are some techniques you can use discussed below to import and export into
those applications.

Markdown

Youcandraga .md Or .markdown file containing only a markdown list into your Curio idea space and Curio will ask if it should be
converted into a native list or mind map figure.

OPML

Most 3rd party outlining applications, such as OmniOutliner, can export to the simple OPML format. Curio’s import process can
retrieve the title, note, and checkmark.

Import a Mind Map File as a Curio Mind Map

1. Choose Insert > File, or drag-and-drop a supported mind map or outlining file format from the Finder into Curio.
2. Curio will ask you if you which to convert the file into a mind map figure. Click the “Convert to Mind Map” button; otherwise
Curio will simply treat the file as a normal document asset.

Import a Carriage-Return Separated and Tab-Indented List from the Clipboard as a Curio
Mind Map

1. Within the 3rd party application, select one or more lines of text and choose Edit > Copy.
2. Within Curio, choose the Edit > Paste As > Mind Map menu item.

Export a Curio Mind Map

1. Make sure the mind map figure itself is selected, not a figure within the mind map.
2. Use the Share toolbar button and choose to export the selected figure as OPML, Mindjet MindManager, iThoughts,
MindNode, iMindMap, text, or RTF. For text and RTF Curio will use carriage-returns and tabs to separate and indent items.

Collect a Selection of Figures into a Mind Map

. Select one or more unlocked figures.
. Choose the Arrange > Collect into Mind Map menu item.
. A new mind map figure containing the selected figures will be created and centered in the visible portion of the idea space.

B O R A R

. If only one figure was selected, then the new mind map will use that figure as the central topic. If more than one figure was
selected, then the new mind map will have a placeholder text figure as the central topic, and all selected figures will be
added as children to that central figure.

Convert a List into a Mind Map

1. Select the mind map figure.
2. Choose the Arrange > Convert Into > Mind Map menu item.

Prune off a Branch in the Mind Map into a New Mind Map

1. Right-click on a figure in the mind map and choose Prune To Linked Collection.
2. Curio will then create a new mind map, of the same style as the current mind map, where the selected parent becomes the
central topic of the new mind map and all of its children will be hierarchically arranged underneath.
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3. The children of the original parent are then removed and the original parent itself becomes a jump action which, when
clicked, will zip you to the new collection. The new collection can remain on the current idea space or it can be cut and
pasted onto a different idea space, and the jump action will still track it down. The root of the new collection will
automatically gain a jump action to jump you back to the parent collection when clicked.

Import a MindMeister Mind Map

1. In MindMeister, right-click on a node and choose the Copy As > Text menu item then select the text outline that appears in
the popup dialog then use the Edit > Copy menu item to copy it into the clipboard.

2. In Curio, use the the Edit > Paste As > Mind Map or Edit > Paste As > List menu item to paste in a new mind map or list,
respectively. Note that you can select a node in an existing collection and use this same technique to paste the outline as a
new branch.

Export a Curio Mind Map or List into MindMeister

1. In Curio, use the Share toolbar to export a text file containing the selected collection.
2. In MindMeister, click the Import on the main screen and choose the file you created on your hard disk.

Import a FreeMind Mind Map

1. In FreeMind, click on a node and choose Edit > Copy which will place a text outline of the branch hierarchy into the
clipboard.

2. In Curio, use the Edit > Paste As > Mind Map or Edit > Paste As > List menu item to paste in a new mind map or list,
respectively. Note that you can select a node in an existing collection and use this same technique to paste the outline as a
new branch.

Export a Curio Mind Map or List into FreeMind

1. In Curio, use the Edit > Copy As > Text menu item to copy a mind map or list hierarchy into the clipboard as a text outline.
2. In FreeMind, click on a node and choose the Edit > Paste menu item which will paste the hierarchy as a new branch in your
FreeMind mind map.

Mind Map Inspector Bar

When a mind map is selected, the inspector bar will reveal new controls so you can customize the look of your mind map.

* Mind Map
Click this button to display the mind map inspector popover. The same panels are available in the Mind Map tab in the
inspector shelf.

* Insert Child
Click this button to insert a child text figure under the current figure.

* Insert Sibling
Click this button to insert a next sibling after the current figure. Note if you hold the Option key down the button will change
subtly to indicate that clicking will insert a previous sibling before the current figure.

Mind Map Inspector

When a mind map figure is selected, the inspector shelf will reveal a new Mind Map tab:
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Mind Map Inspector

Layout

Curio mind maps can have very different arrangement and line styles.
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Mind Map Inspector

Arrangement

Set the arrangement of the mind map (also available via the mind map’s right-click context menu).
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Arrangement Sample
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Arrangement Sample
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Mind Map Inspector

Arrangement Sample
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Mind Map Inspector

Arrangement Sample
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Mind Map Inspector

Arrangement Sample
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Mind Map Inspector

Arrangement Sample

Vegetables

Tree

Blueberry

You can also switch the arrangement by right-clicking on the mind map.
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Mind Map Inspector

Lines

Choose how the lines should be drawn between nodes (also available via the mind map’s right-click context menu).
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Line Style
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Mind Map Inspector

Line Style Sample
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Choose the thickness of the drawn lines connecting the nodes of the mind map: thin, mediun, or thick. The default is thin. Generally

the thicker lines look much better when using a line style other than straight, such as curved or elbow.

Note that if a node uses the underline shape style then the connecting line will be forced to a thin line, so it can merge cleanly.
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Mind Map Inspector

Query

Specify a Search-style query and the mind map will turn into a smart collection, where the contents of the collection will be

determined by the query itself.

For example, entering a simple query of due < 2w Wil fill the mind map with all figures in the project that are due within 2 weeks or
aquery of #active will show all items tagged with active.

Full details can be found above.

Add Relationship Line

Click the Add Relationship Line button to create a line pointing from a first selected figure to a second selected figure.

Reset Layout

Click the Reset Layout button to reset the entire layout in case you’ve dragged branch nodes around into odd locations.

Mind Map Siblings
Styling

Select a figure item within the mind map then you can:

1. Set Default Style for Level
Set that figure’s style as the default style for new figures added to that hierarchical level, without changing the styling of any
existing figures.

2. Copy Style to Siblings
Copy that figure’s style and apply it to its immediate siblings under the same parent.

3. Copy Style to Level and Set as Default
Copy that figure’s style and apply it to all figures at its hierarchical level (that is, its siblings and cousins) and set that style as
the new default for that level.

4. Copy Style to Level+Children and Set as Default
Copy that figure’s style and apply it to all figures at its hierarchical level and all sub-levels (that is, its siblings, cousins, and all
children) and set that style as the new default for all of those levels.

As a note, if you wish to manually style the mind map items don’t forget about the very handy Format > Copy Style and Format >
Paste Style menu items. This is a quick way to selectively apply a style to one or more figures.

Sorting

You can specify that children should be sorted by title, creation date, modification date, due date, start date, start date or end date if
already started, done date, added date, percent completed, priority, or rating.

You can optionally specify a secondary sort criteria, as well.
If you check the “recursively” checkbox then children of the children will sort themselves with the same sort criteria.

Note, however, if any child figure uses a Start Date calculation based on a sibling then sorting will not occur with those children.
Why? If, based on sorting rules, figures jumped around based on title or priority, then at could have an unintended consequence on
all your figure dates! Basically, we’re assuming you placed those figures in specific precedence ordering — buy groceries then make
dinner — and we don’t want an automatic sorting to spontaneously ruin that ordering.
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Mind Map Inspector

Note
Query-based mind maps are automatically sorted based on the query so these sorting popups aren’t available if you have a
query specified.

Mind Map Children

Colors

Select an item within the mind map then you can copy that selected figure’s colorings to all of its children. This means the rest of the
child’s style, like the shape borders and font size, will all stay the same but the border color, fill color, and font color will all be
replaced with the colors of its parent. This is a wonderfully quick way to make an entire branch of nodes all have the same color.

You can mark a child item so that it will automatically update its colors if its parent changes at any time. So, unlike the manual color
copying above, this will happen automatically if the parent changes.

Alternatively, if you have a parent selected, you can click a checkbox to make it so children of the selected parent automatically
inherit the colors of their parent. Basically the same effect as #2 above but instead of marking a specific child you can instantly mark
all children, and future children that you add to that parent. Uncheck this option to disable this functionality. You can also perform
this action via the right-click context menu on a node.

Spread Color Palette
Curio can instantly spread a color palette across all main branches, so that each branch has its own color. Curio includes several

palettes of colors to make it fun to experiment with various palettes. See more notes below regarding branch coloring.

You can also use the actions menu to import and manage color palette files such as Adobe Swatch Exchange ( .ase ) swatch files
from Adobe Color or ColourLovers.

While Adobe Color requires a free Adobe account, once you've created the account you can use their site to create, manage, and
download color swatches.

You’ll need to register with ColourLovers, as well, if you’d like to downloaded created color palettes from their site.

The color swatches popup also supports a Curio Color Swatch ( .curiocolorswatch ) file with a carriage-return delimited list of hex
color values (like #aa22ff ) that you can create if you'd like.

Branch

A branch is the current node and all of its children, grandchildren, etc.

Branch Boundary

You can enable a boundary region to be drawn around the selected mind map parent and around its children. A boundary is a
wonderful way to highlight a particular branch or sub-branch of your mind map. The color of the boundary is automatically
determined based on the color of the parent figure itself.

Note that boundaries can contain other boundaries if you wish.
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Tables

Apply Default Style to Selected Branch

Re-apply the default style information to the selected figure and to all of its children with just a single click. Useful if a branch has a
mix of styles and formatting.

A Note about Branch Coloring

You can create mind map styles that include branch coloring!

If you apply branch colors to the top branches (the main branches under the central topic) of your mind map using the mind map
inspector’s automatic child coloring controls, for example perhaps you spread a color palette, then that branch information will now
be stored as a part of the collection’s style.

After creating new mind map styles which include branch colors, you can then apply those styles to your existing mind maps or to
new mind maps and the top branches will be colored appropriately.

When branch coloring is part of the style, the order of the branch coloring is maintained as you insert or delete top branches. So if
the branches should be red, green, blue, and orange — in that order — then those colors will be enforced as you modify the number
and ordering of branches under the central topic.

Tables

Curio’s table feature is an excellent way to show a grid

or spreadsheet of data. The data could be several text

figures, numbers, or even complex figures such as Amount of water | liter
images and movies. When you need to show tabular '
Amount of oil 50 ml 50 ml 50 ml
data, tables are the answer.
Amount of
polymer 50g 50¢g 100 g
Stirring? None Moderate Vigorous
Result No clearing Signficant All gone!

Default Styling

ltems created, dropped, or pasted within or into a collection will adopt the style appropriate for destination as determined by the
collection figure’s style. For example, a table style’s information will include the style associated with body cells vs header cells.
Likewise, a mind map style will include stylings for the various hierarchical levels in the mind map. If you drag an item from one
location in the mind map to another location, then it will adopt the styling appropriate for that location. There are advanced settings

you can tweak to change this logic. For example, you can make it so dragging within a table keeps existing styling but dragging
items into a table, from elsewhere, will adopt the appropriate styling.

Context Menu

Right-clicking on a table or a table cell will show a context menu with lots of frequent operations so be sure to check it out!

Create a Table

+ Use the Insert popover to create a table via its style and stencil gallery, or use the Insert menu.
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Tables

Edit a Figure Cell

* Double-click the cell or select it and press the Return key.

Move Between Figure Cells

« Press Tab or {} Tab or move forwards or backwards. You can also use the arrow keys on your keyboard to navigate around
the cells.

Select Specific Figure Cells

1. Select the first cell then hold Shift while clicking the last cell and all the cells within the rectangular region defined by those
two cells will be selected.
2. Or, click on the first cell, then hold Command while clicking other cells to select a disjointed number of cells.

Select Specific Rows or Columns

1. Select the figure cells in the rows or columns you wish to select.
2. Right-click and choose Select Row or Select Column, as appropriate.

Resize Rows or Columns

1. Select the table — or specific rows and columns — and enter values into the Column Width and Row Height fields in the
table Inspector if you want all row and columns to have the same sizing. You can also use the Fit and Distribute to fit or
distribute sizes for selected rows or columns, or for the entire table.

2. Or, hover the mouse over the row and column separating lines such that the mouse pointer becomes a resize pointer. Then
click and drag to resize that row or column. When you resize a row or column using the mouse the table itself will keep its
existing size, unless you hold Shift while resizing then the table itself will resize as well.

3. Or, click on the table then drag one of its resize handles. While the table resizes all rows and columns will resize
proportionally. Note that certain cells may have minimum sizes due to the display of adornments such as checkboxes and
tags.

Fit and Distribute

1. Use the Fit buttons to size the row height or column width to the minimum necessary to show the content on that row or
column.

2. Use the Distribute buttons to make all rows heights or column widths the same.

3. Check the automatically adjust row heights checkbox if you’d like Curio to adjust row heights as necessary to avoid clipping
cell content

Add Rows or Columns

1. Select the table.

2. Use the table inspector to change the number or rows or columns in a table. By default Curio will maintain the table’s current
size. However, if you hold the Shift key while clicking the steppers to change the number of rows or columns, Curio will allow
the table to grow or shrink as needed

Insert Rows or Columns

1. Select the figure cells in the rows or columns you wish the insert to occur.
2. Right-click and choose Add Row Above, Add Row Below, Add Column Before, or Add Column After, as appropriate.
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Table Import/Export

3. As a note, you can also use the ~““ArrowKey to insert rows and columns if a cell is selected (although not being actively
edited), where ArrowKey is the up, down, left, or right arrow keys on your keyboard. Hold the Shift key as well to modify the
table size during the insertion, as described above.

Delete the Contents of Figure Cells

1. Select the figure cells you wish to clear.
2. Press the Delete or Backspace key or choose Edit > Delete.

Delete Specific Rows or Columns

1. Select the figure cells in the rows or columns you wish to delete.

2. Right-click and choose Delete Row or Delete Column, as appropriate.

3. When the deletion occurs the remaining row/columns will increase in size to fill the existing table dimensions. However, if you
hold down the Shift while when choosing the context menu option then Curio will shrink the table figure itself instead.

Rearranging Iltems Via Keyboard

1. Select one or more figures.

2. Press ~ {11 or ~{ | to move the figures.

3. If you have a row of figures selected then the row will be moved up or down. If all the figures within a column are selected
then the columns will be moved left and right. If figures within a column are selected then they will move up and down within

the column.

Table Import/Export

Add New Iltems to a Table or Rearranging Table Items Via Drag-And-Drop

1. Select figures from elsewhere in Curio, the Finder, or another application and drag them into Curio onto the table figure.

2. As you drag the items around the table, the current cell you are hovering over will highlight so you know where the dropped
items will be placed. Note you will be replacing the contents of the hovered-over item with the dropped figures or data.

3. Release the mouse button to drop the items into the table. If the drag started from this table or another table then the added
items will retain their same row and column separation from each other, and Curio will automatically increase the number or
rows or columns as necessary to fit the newly placed items.

4. If the drag started from figures selected on the idea space or from the Finder, then Curio will ask if the items should be filled
into a single column (adding rows as needed), a single row (adding columns as needed), or spread across and then down
(adding rows as needed).

5. Table figure cells also support cut, copy, paste, and duplicate for adding and removing figures.

6. As mentioned in the collection figures overview, when moving figures around they will adopt the styling appropriate for that
location by the collection figure’s style information. For tables this means moving items will adopt the appropriate default cell
style based on the cell type: body, header, etc. If you wish to keep a figure’s existing styling then hold Shift before dropping
the figure.

Drag a Figure out of the Table

+ Simply drag the figure out of the table and you can drop it on the idea space or directly into another collection such as a list
or mind map. The table cell is cleared and replaced with a boilerplate text figure unless Option is held down in which a copy

was generated.
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Table Inspector Bar

Import a CSV File as a Curio Table

1. You can import tabular data from Apple Numbers, Microsoft Excel, or many other 3rd party applications, directly into Curio
as a table collection.

2. Just use that application’s export to CSV (Comma Separated Value) functionality to create an export file, which Curio can
import.

3. Choose Insert > File, or drag-and-drop a CSV file from the Finder into Curio.

4. Curio will ask you if you which to convert the file into a table figure. Click the “Convert to Table” button; otherwise Curio will
simply treat the file as a normal document asset.

Paste a Tab Delimited Information from the Clipboard into a Curio Table

1. Within the 3rd party application, select a range of rows and columns and choose Edit > Copy.
2. Within Curio, choose the Edit > Paste As > Table menu item to paste into the currently selected table or it can automatically
create a new table.

Export a Curio Table

1. Make sure the table figure itself is selected, not a figure within the table.
2. Click the Share toolbar button then, under Share Selected Figure, choose the export format you wish to use, such as text or
CSV.

Copy a Curio Table as Tab Delimited Text

1. Make sure the table figure itself is selected, or a range of cells within the table is selected.
2. Choose the Edit > Copy menu item.

Table Inspector Bar

When a table is selected, the inspector bar will reveal new controls so you can customize the look of your table.

* Table
Click this button to display the table inspector popover. The same panels are available in the Table tab in the inspector shelf.
* Insert Row
Click this button to insert a row above the current row, keeping the table size as-is. Press {} Click to insert above and grow
the table size as necessary. Press ~=-Click to insert below the current row. Press ~={ Click to insert below and grow the table
size as necessary.
* Insert Column
Click this button to insert a column before the current column, keeping the table size as-is. Press 1} Click to insert above and
grow the table size as necessary. Press ~=-Click to insert below the current column. Press ~={} Click to insert below and
grow the table size as necessary.
* Delete Row
Click this button to delete the current row.
* Delete Column
Click this button to delete the current column.
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Table Inspector

Table Inspector

When a table figure is selected, the inspector shelf will reveal a new Table tab:

Dimensions

Change the number of rows and columns in the current table, keeping the size-as is. If you hold Shift when making the change then
the table will grow as needed.

Sizing

Set the size of the selected rows or columns.

Click Fit to resize the selected rows (or columns) so their heights (widths) match the cell with the tallest (widest) content.
Click Distribute to distribute the selected row heights (or column widths) so each has the same height (width).

Click the Automatic adjust row height checkbox if you’d like the rows to automatically and dynamically update their heights based
on their content.

Alternating Row Color

Alternating rows can have an override color specified.

Table Headers & Footers

Click on the appropriate buttons to toggle the visibity of optional header and footer rows and columns.

Table Cells

Select a table cell which has the style you’d like to replicate, then click the appropriate button to replicate that style to certain types
of cells, like all body cells or all header row cells.

This styling information is then saved as part of the table’s overall style definition, thus will be recorded if you save the table style in
your personal style repository.

Index Cards
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Index Cards

. . v Experiment Notes
Curio’s index cards are a fantastic new way to create

shippets of ideas, thoughts, and notes. You can even What an amazing process! As soon as the polymers were sprinkled into
place images and other asset figures on an index card. the contaminated water they immediately started working. Almost instantly

the oil became more solidified and much easier to collect. One catch is

Note that an index card is resizable but not scrollable. that the polymers had to be stirred around the water otherwise the reaction

This means any text that grows past its bounds will be i

automatically clipped when it’s not being edited.

This was done on purpose in the design of the index

v Experiment Notes

card feature. The strength of the real-world index card

is its static size, in contrast to a multipage notebook. It What an amazing process! As soon as the polymers were sprinkled
forces you to make brief notes and think concisely, into the contaminated water they immediately started working.
then to review and arrange your thoughts with the Almost instantly the oil became more solidified and much easier to

resulting stack of cards. collect. One catch is that the polymers had to be stirred around

the water otherwise the reaction wouldnt occur.

Default Styling

ltems created, dropped, or pasted within or into a collection will adopt the style appropriate for destination as determined by the
collection figure’s style. For example, a table style’s information will include the style associated with body cells vs header cells.
Likewise, a mind map style will include stylings for the various hierarchical levels in the mind map. If you drag an item from one
location in the mind map to another location, then it will adopt the styling appropriate for that location. There are advanced settings

you can tweak to change this logic. For example, you can make it so dragging within a table keeps existing styling but dragging
items into a table, from elsewhere, will adopt the appropriate styling.

Create an Index Card

* Use the Insert popover to create a index card via its style and stencil gallery, or use the Insert menu.

Convert a Selection of Figures into Index Cards

1. Select one or more non-collection figures on the idea space.
2. Choose the Arrange > Convert Into > Index Card menu item.

The figures will be transformed into index cards, one card per selected figure.

If the converted figure is an asset figure (such as a file-backed text figure or image figure) then the default title for the index card is
the underlying asset’s file name at the time of the conversion. An advanced setting allows you to change the format of the title to
include path info if you wish.

Edit an Index Card Title or Body Figure

» Double-click the figure within the index card. You can press tab to jump between the title and body areas.

Replace the Contents of an Index Card

* You can drag-and-drop or paste another figure into the body area of an index card. Using this technique an index card can
contain images or any other type of asset figure.
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Index Card Inspector Bar

Collapse or Expand an Index Card

1. Select the index card figure.
2. Do a quick tap of the spacebar to collapse or expand the index card.

Export a Curio Index Card

1. Make sure the index card figure itself is selected, not a figure within the index card.
2. Click the Share toolbar button then, under Share Selected Figure, choose the export format you wish to use.

Copy a Curio Index Card as Text

1. Make sure the index card figure itself is selected, not a figure within the index card.
2. Choose the Edit > Copy As > Text menu item.

Index Card Inspector Bar

When a index card is selected, the inspector bar will reveal new controls so you can customize the look of your index card.

* Index Card
Click this button to display the index card inspector popover. The same panels are available in the Index Card tab in the
inspector shelf.

Index Card Inspector

When a index card figure is selected, the inspector shelf will reveal a new Index Card tab:

Automatic Resize

You could enable automatic resizing of the index card so it automatically grows and shrinks as necessary to hold its content.

Line Coloring

Set the color of the line drawn under the index card title. If you set a none color in the popup color palette then no title line will be
drawn.

Set the color of the lines drawn in the body area of the index card. If you set a none color in the popup color palette then no body
lines will be drawn.

Note you can set other properties such as fonts, font colors, fill colors, etc, using the other inspectors. The index card is made up of
two distinct figures which you can style using the various inspectors: a title figure and a body figure.

Albums
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Albums

Curio’s albums are a great way to create flexible Zengobi Pets
collections of image figures and other asset figures
displayed as previews, such as PDF’s. With the new
preview caption feature mentioned above your images
can have notes and other annotations directly under
the image or preview feature is an excellent way to

Peanut, the sleepy dog, helped us start
Zengobi many moons ago!

show a grid or spreadsheet of data.

An album lays out all contained items in fixed-width
columns. Unlike a table which has fixed-height rows,

albums simply stack items within the columns based = Sl

Our newest addition: Butternut

on the height of each item. The number of columns is

Yes, it's Orangey!

based on the overall width of the album collection Manmalowiwihhentieia)

figure. As you resize the album figure, the number of
columns will be dynamically changed and items will wrap accordingly.

Default Styling

ltems created, dropped, or pasted within or into a collection will adopt the style appropriate for destination as determined by the
collection figure’s style. For example, a table style’s information will include the style associated with body cells vs header cells.
Likewise, a mind map style will include stylings for the various hierarchical levels in the mind map. If you drag an item from one
location in the mind map to another location, then it will adopt the styling appropriate for that location. There are advanced settings

you can tweak to change this logic. For example, you can make it so dragging within a table keeps existing styling but dragging
items into a table, from elsewhere, will adopt the appropriate styling.

Create an Album

+ Use the Insert popover to create an album via its style and stencil gallery, or use the Insert menu.

Convert a Selection of Figures into an Album

1. Select one or more figures on the idea space.
2. Choose Arrange > Collect Into > Album.

Edit a Figure Within an Aloum

» Double-click the figure or select it and press the Return key.

Move Between Figures Within an Album

* Use the arrow keys on your keyboard to navigate around the album.

Add New ltems to an Album or Rearranging Items Via Drag-And-Drop

1. Select figures from elsewhere in Curio, the Finder, or another application and drag them into Curio onto the album figure.

2. As you drag the items around the album, a red drop indicator will indicate whether the items will be placed before or after the
current item.

3. Release the mouse button to drop the items into the album.

4. ltems within albums also support cut, copy, paste, and duplicate for adding and removing figures.
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Album Inspector Bar

Drag a Figure out of the Album

+ Simply drag the figure out of the album and you can drop it on the idea space or directly into another collection such as a list
or mind map.

Change the Number of Columns

» Simply resize the album figure itself and the number of columns will dynamically change to accommodate the new width of
the album.

Delete the Items Within an Album

1. Select the figures you wish to delete.
2. Press the Delete or Backspace key or choose Edit > Delete.

Toggle the Display of an Album Title

+ Select the album — or an item within the album — and use the album Inspector to turn on or off the album title.

Change the Column Size or Spacing

« Select the album — or an item within the album — and use the album Inspector to modify those properties.

Album Inspector Bar

When an album is selected, the inspector bar will reveal new controls so you can customize the look of your album.

* Album
Click this button to display the album inspector popover. The same panels are available in the Album tab in the inspector
shelf.

Album Inspector

Album Arrangement

Choose either:

1. Columns: a packed columns of images. You specify a column width and the contained figures are proportionally sized to
that width then arranged into a packed layout, similar to Pinterest’s.

2. Columns (unpacked): Unpacked columns of images. Like Columns you specify a column width, but instead of packing the
contained figures, each row’s height is based on the tallest item in that row. The result is more like a grid of images in tidy
columns and rows.

3. Rows: Packed rows of images. This arrangement only works with image figures. You specify a row height and the contained
figures are proportionally sized to that height then arranged into a packed layout, similar to Flickr’s. This works very well with
uncaptioned images, but can be a bit finicky with captioned images as text wrapping can jump items between sizes,
although Curio attempts to counter this via iterative refinement.

Column Width

Set the width of the pinboard columns. Curio will then flow the contents as needed.
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Pinboards

Gaps

Set the horizontal and vertical gap spacing between items within the album.

Show Title

Toggle the visibility of the album title.

Copy This Figure Style to All

Select an item in the album, then click this button to copy that figure’s style to all other figures contained within the album.

Pinboards

Think of a pinboard as a container of figures where no
layout or style is imposed on the figures within the Developmenf
collection. You can place items anywhere within the
collection and the collection itself will automatically

grow, if necessary, to handle dropped or pasted
figures. It’s almost like a free-floating mini idea space
in terms of flexibility. And it’s more flexible than a AV chapter More mind
group figure since you can move and resize the marks

contained figures freely and the collection will simply
resize to hold the new items.

Pinboards really shine when used during brainstorming

Product Specification

sessions. You and your team will quickly produce

dozens of ideas, perhaps created using Curio’s sticky

note figure styles. Afterwards, or during breaks, collect

common ideas together in pinboard collections to PDF
annotation
features

quickly organize and visualize the results of your

brainstorm. You can even add ratings, tags, and

priorities or use color coding to quickly identify key

ideas.

A pinboard is a collection figure, like a list, mind map,
or table collection figure. It’s important to remember

that a collection cannot contain another collection.

Default Styling

ltems created, dropped, or pasted within or into a collection will adopt the style appropriate for destination as determined by the
collection figure’s style. For example, a table style’s information will include the style associated with body cells vs header cells.
Likewise, a mind map style will include stylings for the various hierarchical levels in the mind map. If you drag an item from one
location in the mind map to another location, then it will adopt the styling appropriate for that location. There are advanced settings

you can tweak to change this logic. For example, you can make it so dragging within a table keeps existing styling but dragging
items into a table, from elsewhere, will adopt the appropriate styling.
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Pinboards

Create a Pinboard

+ Use the Insert popover to create a pinboard via its style and stencil gallery, or use the Insert menu.

Convert a Selection of Figures into a Pinboard

1. Select one or more figures on the idea space.
2. Choose Arrange > Collect Into > Pinboard.

Edit a Figure Within a Pinboard

+ Double-click the figure or select it and press the Return key.

Create a Text Figure Within a Pinboard

 Double-click the background of the pinboard.

Add New ltems to a Pinboard or Rearranging Items Via Drag-And-Drop

1. Select figures from elsewhere in Curio, the Finder, or another application and drag them into Curio onto the pinboard figure.

2. As you drag the items around the pinboard, you can see exactly where the items will be placed.

3. Release the mouse button to drop the items into the pinboard.

4. ltems within pinboard also support cut, copy, paste, and duplicate for adding and removing figures.

5. The pinboard will automatically expand if necessary to accommodate the added items, unless you disable this feature in the
inspector.

Select Multiple Figures Within the Pinboard

- Either use the Shift or Command click to click on individual items, or hold Shift or Command and select a range of figures by
clicking and holding on the background of the pinboard and dragging a rubber band selection region around figures.

Insert a New Figure into a Pinboard

+ Use the Insert toolbar button to insert a new figure such as a Styled Shape directly into the pinboard. Note, like all collection
figures, a collection figure cannot contain another collection figure. So you can’t add a list to a pinboard, for example.

Drag a Figure out of the Pinboard

+ Simply drag the figure out of the pinboard and you can drop it on the idea space or directly into another collection such as a
list or mind map.

Delete the Items Within a Pinboard

1. Select the figures you wish to delete.
2. Press the Delete or Backspace key or choose Edit > Delete.

Collapse or Expand a Pinboard

1. Select the pinboard figure.
2. Do a quick tap of the spacebar to collapse or expand the pinboard. Note that the pinboard has to have a title to be able to
collapse it.
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Pinboard Inspector Bar

Toggle the Display of a Pinboard Title

+ Select the pinboard — or an item within the pinboard — and use the pinboard Inspector to turn on or off the pinboard title.

Toggle the Pinboard Auto Resize

« Select the pinboard — or an item within the pinboard — and use the pinboard Inspector to toggle pinboard automatic resize.

Pinboard Inspector Bar

When a pinboard is selected, the inspector bar will reveal new controls so you can customize the look of your pinboard.

* Pinboard
Click this button to display the pinboard inspector popover. The same panels are available in the Pinboard tab in the
inspector shelf.

Pinboard Inspector

When a pinboard figure is selected, the inspector shelf will reveal a new Pinboard tab:

Show Title

Toggle the visibility of the pinboard title.

Automatic Resize

You could enable automatic resizing of the pinboard so it automatically grows and shrinks as necessary to hold its content.

Copy This Figure Style to All

Select an item in the pinboard, then click this button to copy that figure’s style to all other figures contained within the pinboard.

Stacks

A stack collection collects all of its contained figures in a neat, vertical

“\ ACTIVE — 3 tasks

stack which is perfect for organizing tasks in a visual manner.

The widths of all contained figures will be increased to the width of the @ @ A<k beta testers for Stack feedback!
stack, appropriately sizing images proportionally. If you resize the stack, ’

the widths of all figures within will resize as well.

; g
Stacks are best suited for organizing text, image, and file asset figures. O @ How about some video tutorials’

(P (=) More Curio documentation.
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Stacks

Default Styling

ltems created, dropped, or pasted within or into a collection will adopt the style appropriate for destination as determined by the
collection figure’s style. For example, a table style’s information will include the style associated with body cells vs header cells.
Likewise, a mind map style will include stylings for the various hierarchical levels in the mind map. If you drag an item from one
location in the mind map to another location, then it will adopt the styling appropriate for that location. There are advanced settings

you can tweak to change this logic. For example, you can make it so dragging within a table keeps existing styling but dragging
items into a table, from elsewhere, will adopt the appropriate styling.

Smart Tag Inheritance on Search and Status

Stacks have two special, very important characteristics when tasks are viewed on the Search and Status shelf:

1. Curio will ignore stack titles in the Status shelf (when grouping by tag) or on the Search shelf (when searching for tags).
2. On both the Status and Search shelves, items within the stack will automatically inherit the title’s tags.

This means you can construct a series of stacks, where the title of the stack has an associated tag, and simply drag-and-drop items
from one stack to another. Those items will instantly inherit the title’s tag and appear in the Status shelf with the correct
associations.

Create a Stack

+ Use the Insert popover to create a stack via its style and stencil gallery, or use the Insert menu.

Convert a Selection of Figures into a Stack

1. Select one or more figures on the idea space.
2. Choose Arrange > Collect Into > Stack.

Edit a Figure Within a Stack

* Double-click the figure or select it and press the Return key.

Create a Text Figure Within a Stack

* Double-click the background of the stack or select an existing figure and press $#Return to create a next sibling or
1r ¥Return to create a previous sibling.

Move Between Figures Within a Stack

 Use the arrow keys on your keyboard to navigate around the stack.

Add New ltems to a Stack or Rearranging Items Via Drag-And-Drop

1. Select figures from elsewhere in Curio, the Finder, or another application and drag them into Curio onto the stack figure.

2. As you drag the items around the stack, you can see exactly where the items will be placed. Note that if the stack is sorted,
see below, then you won’t be able to place an item precisely in the stack as it will be automatically sorted into place once
you release the mouse.

3. Release the mouse button to drop the items into the stack.

4. ltems within stack also support cut, copy, paste, and duplicate for adding and removing figures.

5. The stack will automatically expand if necessary to accommodate the added items.
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Stacks

Select Multiple Figures Within the Stack

- Either use the Shift or Command click to click on individual items, or hold Shift or Command and select a range of figures by
clicking and holding on the background of the stack and dragging a rubber band selection region around figures.

Insert a New Figure into a Stack

+ Use the Insert toolbar button to insert a new figure such as a Styled Shape directly into the stack. Note, like all collection
figures, a collection figure cannot contain another collection figure. So you can’t add a list to a stack, for example.

Drag a Figure out of the Stack

+ Simply drag the figure out of the stack and you can drop it on the idea space or directly into another collection such as a list

or mind map.

Delete the Items Within a Stack

1. Select the figures you wish to delete.
2. Press the Delete or Backspace key or choose Edit > Delete.

Collapse or Expand a Stack

1. Select the stack figure.
2. Do a quick tap of the spacebar to collapse or expand the stack. Note that the stack has to have a title to be able to collapse
it.

Toggle the Display of a Stack Title

+ Select the stack — or an item within the stack — and use the stack Inspector to turn on or off the stack title.

Change the Stack Sorting

1. By default, you can manually rearrange items in the stack. Just drag items up and down the stack to arrange them in any
order you wish.

2. However, you can also tell Curio to keep the stack automatically sorted by title, creation date, modification date, due date,
start date, start date or end date if already started, percent completed, priority, or rating, in either ascending or descending
order. You can specify a secondary sort as well. Make a change to a figure and instantly the figures rearrange based on the
sorting rule.

3. Select the stack — or an item within the stack — then use the stack Inspector to select a primary and secondary sort option.

Export a Curio Stack

1. Make sure the stack figure itself is selected, not a figure within the stack.
2. Click the Share toolbar button then, under Share Selected Figure, choose the export format you wish to use, such as text,
OPML, or a mind map format.
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Stack Inspector Bar

Stack Inspector Bar

When a stack is selected, the inspector bar will reveal new controls so you can customize the look of your stack.

« Stack
Click this button to display the stack inspector popover. The same panels are available in the Stack tab in the inspector shelf.

Stack Inspector

When a stack figure is selected, the inspector shelf will reveal a new Stack tab:

Show Title
Toggle the visibility of the stack title.

Automatically Size

The stack will automatically grow as you add new items, but via this option it can automatically shrink as items are removed.

Query

Specify a Search-style query and the stack will turn into a smart collection, where the contents of the collection will be determined

by the query itself.

For example, entering a simple query of due < 2w Wwill fill the stack with all figures in the project that are due within 2 weeks or a
query of #active will show all items tagged with active.

Full details can be found above. Note that since Stacks can’t show hierarchy you can’t group your results, like you can with lists and
mind maps.

Sorting

Change the automatic sort ordering. By default, you can manually rearrange items in the stack. Just drag items up and down the
stack to arrange them in any order you wish.

However, you can also tell Curio to keep the stack automatically sorted by title, creation date, modification date, due date, start
date, start date or end date if already started, done date, added date, percent completed, priority, or rating. You can specify a
secondary sort as well.

Note
Query-based stacks are automatically sorted based on the query so these sorting popups aren’t available if you have a query
specified.

Copy This Figure Style to All

Select an item in the stack, then click this button to copy that figure’s style to all other figures contained within the stack.
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Shelf

Shelf

The Curio shelf is a popup area located on the right side of the Curio window. Curio includes several shelf modules that run within
that area to help you while you’re working on your project such as the Search shelf to find information.

Inspector

Accessing the Inspector Shelf

You can access the inspector shelf by clicking on the Inspector toolbar button. Go ahead and do it now so you can look at it while
we go over some things.

Context Sensitive
The inspector shelf shows properties of the selected figure or idea space. The inspector panels that appear within the shelf are

context sensitive so, based on what’s selected, the available panels and tabs may change.

For instance, select a text figure and you will see certain tabs at the top of the inspector shelf. Click on a list and a tab titled “List”
will appear with more options. Click on the background of the idea space so no figures are selected and the inspector content will
change to show properties of the idea space, such as background color and dimensions.

Inspector Popovers

As mentioned earlier in this document, you can access many of the same panels via buttons on the inspector bar. In many cases,
those buttons will reveal popovers that appear so you can make property changes, then dismiss the popover when you’re done.
Sometimes popovers are more convenient than the inspector shelf, especially for small laptop screens, because they only take up
room temporarily.

Detachable Popovers

Inspector popovers can also be detached by clicking and dragging on their background to “tear” them off the inspector bar and turn
them into free floating windows. You can drag these small windows anywhere on the screen, or even to a separate screen attached
to your Mac.

Relaunching Curio will automatically restore those same detached popovers.

Search

The Search shelf is discussed in great detail in Search and Quick Find.
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Library

Library

You can access the search shelf by clicking on the Library toolbar button. Go ahead and do it now so you can look at it while we go

over some things.

Library Modules

Based on the edition of Curio you own, you will find several installed library modules listed with tabs at the top of the library shelf.

Let’s begin our tour of the available library modules...

Project

Every project has an internal asset library which manages all aliased and embedded files dragged into Curio.

Generally you use the project library to see what assets are in your library and re-use existing assets. When you use the same asset
more than once in your project it is actually only stored as a single underlying file in the asset library.

To use an asset simply drag-and-drop it out of the library and drop it onto the idea space. This will create an appropriate asset figure
to be associated with the dragged asset. Again, you can use this technique to create numerous asset figures of the same asset and
Curio will efficiently use the same single underlying asset file.

If you select and delete an asset using the Delete key the file will be removed and any asset figure instances of it on any idea spaces
will be removed from your project. You have to confirm the removal of an asset since this cannot be undone.

Show the Project Library

1. Click the Library shelf toolbar button, then click the Project tab at the top of the shelf.
2. You can also right-click on an asset figure on an idea space and choose Reveal in Library to see the associated asset in the
project library.

Add New Files to the Project Library

+ Drag-and-drop one or more files from the Finder to the Project Library view. By default a copy of each file will be embedded
in your project asset library. If Command is held during the drag then the files will be moved to the library. If Option is held
then an alias to each file will be added to the library.

Search the Project Library

« Enter a search phrase in the Search field and press Return.

Filter the Results by Scope

1. Click the Scope popup to change the search scope: the entire project, the current section, the current section tree (meaning
this section and any child sections), the current idea space, the current idea space tree (meaning any child items as well), the
project Archive, the project Trash, only unused (orphaned) assets that aren’t in use in any idea space.

2. Note that the Archive and Trash are only searched if that scope item is selected.
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Project

Filter the Results by File Type

- Click the Kind popup to see only certain types of files. These can include general types such as document, images, or
movies, or specific types such as PDF or Adobe Photoshop files.

Filter the Results by Last Modified Date

+ Click the Modified popup to filter the results based on when they were last modified.

Change the Sort Order

+ Click the Sort By popup to change the sort: title, last modified, date added to Curio, file size.

Duplicate an Asset

« Select the asset and choose Edit > Duplicate. The new asset will be selected and the word “copy” will be appended to the
end of its name.

Rename an Asset

* You can click-click on an asset in the Library to rename it. If the asset is embedded within the project, the underlying asset
file is renamed as well.

Context Menu

Right-click on an asset to perform one of these actions:

* Open
Launch the asset file using the Finder.
* Open With
Choose a specific application to open the asset file.
* Open Link in Browser
If a link is associated with the asset then it will be opened in the default browser such as Safari.
* Reveal in Finder
Reveal the asset file within a Finder window.
* Reveal in Idea Space
Show where the asset is instantiated in one or more idea spaces.
* Embed within Project
Replace an alias to a file into an embedded copy of that file.
- Copy to Curiota
Copy the asset file to the Curiota companion app.
« Copy to Desktop
Copy the asset file to the Desktop.
* Mail as Attachment
Create a new mail message with the selected file as an attachment. If more than one asset is selected then a zip of all the
selected assets will be added as a single attachment.
* Duplicate
Create a copy of the asset and store it in the project library.
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Local

Local

The Local library allows you to browse or search for files on your local hard disk.

You can explore everywhere or only within certain folders that you can specify, which can be useful when collecting data and files
created in other applications.

The Local library can utilize Spotlight’s query service to quickly find files on your hard disk using a number of criteria including text,
tags, modification date, and kind of file. When searching for text Curio can search just file titles or also include the actual content of
the files. For example, use Local to find all images modified in the past 2 weeks. Or all files with a Finder tag School created in the
past month.

Mac App Store Restriction

Curio from the Mac App Store is sandboxed which prevents the Local shelf from performing many operations on your hard
disk. You can give Curio full disk access via System Settings > Privacy & Security > Full Disk Access. Alernatively, you can
simply use the Finder and Spotlight outside of Curio to perform many of the same operations without restriction.

Show the Local Library

« Click the Library shelf toolbar button, then click the Local tab at the top of the shelf.

Browse vs Search

The Local library allows you to either casually browse the folders and files on your hard disk, or perform a Spotlight search to
quickly see a list of files that match that query.

» When the Browse tab is selected, the search field and popups like Scope and Kind are used to filter the displayed files as
you browse the directory hierarchies.

* When the Search tab is selected, they are used to create a Spotlight search query and the results of the query are displayed
as a list.

Browse Columns
If a Finder color has been assigned to a file or folder then that item will have a slight colored tint around it for fast recognition. If

multiple colors are assigned only one will be used.

You can resize the first column and that will be the default column width for new columns, even between launches of Curio.

Optional Preview Column

This column view is very similar to the Finder’s column view. However, in the Finder’s column view, when you select a file a special
preview column is displayed with more details about that file. The Local library doesn’t normally display a preview column for a

selected file, however you can enable the preview column, if you wish. Note in that preview column that the file size is not displayed
for folders or packages.

Search Field

When you enter a search term it is used as a filter when browsing or a Spotlight query when using search.
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Local

Searches are case insensitive and are used for partial word matches, so searching for mac will match files named MacBook Air and
Global Diplomacy.

Finder Tags

If the search phrase begins with a # prefix, such as #rersonal , then you’re searching for Finder tags. Remember, this is case
insensitive SO #personal OF #personal are the same.

Multi-Word Tags

If the Finder tag has multiple words you can use the underscore in place of spaces, such as #vacation plans . This character can
be replaced with a different character, if necessary.

Finder Color Tags

Helpfully, the Finder automatically maps label colors to tags so a search for #red will find items with the red color label.

Combo Queries

Note your search can contain text and tag items, like campaign results #work #projects , which are AND’ed together in the
resulting query.

Search Options
Click the magnifying glass icon within the search field to toggle special options:
+ Search Content: Enable searching within the file contents for the entered search term. This only works when performing
Spotlight searching.

* Include Subfolders: Enable searching the specified scope folder and recursively into subfolders, as well. This may be force
enabled automatically based on the selected scope.

Scope Filter

The scope popup is used to define the “root” of the browsing hierarchy or the Spotlight search query’s scope restriction.

A few folders are included in the scope popup by default including Home for your home directory hierarchy and This Mac which
includes all volumes and all mounted drives connected to your Mac. For non-sandboxed Curio downloaded from the Zengobi
website the popup is automatially filled with additional folders, as well.

Of course Curio can only display files and folders that are within volumes and folders the user has access to. You wouldn’t have
access to files for another user on the same machine, for example.

Also note the Include Subfolders search option mentioned above.

Custom Scope Folders

Via the scope popup you can also add your own scope folders. For example, you might add an iCloud Drive notes folder, your
Dropbox folder, an Obsidian vault, and a special project folder that you use a personal “inbox” for files and snippets to peruse later.

Important
The Local library Spotlight search query feature completely relies on Spotlight, Curio does not perform its own file content
indexing. Therefore if you restrict or disable Spotlight in System Settings then certain locations may not be searchable.
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Local

Kind Filter

Use the Kind popup to see only certain types of files. These can include general types such as document, images, or movies, or
specific types such as PDF or Adobe Photoshop files.

Modified Date Filter

Use the Modified popup to filter the results based on when they were last modified. This is handy if you want to only see files
modified in the past month, for example.

Sort Options

The resulting files can be sorted by file title, last modified date, creation date, or file size.

(When browsing, folders are always listed at the top of the results alphabetically so you can drill down into a subfolder to view the
resulting files in that folder.)

Drag and Drop

To use a file simply drag-and-drop it out of the Local library and drop it onto the idea space. Doing this will embed a copy of the file
into your project.

Hold Option while dragging the file to create an alias to the original file, or hold Command to move the file into your project
(therefore removing it from its original location).

If you select and delete a file from Local using the Delete key the file will be moved to the Trash.

Double-Click to Open

You can double-click a file in Local results to open it.

If the file is within a Curiota collection folder, an Obsidian vault, or a DEVONthink database, then it will be opened in its respective
app, as described below.

Quick Look Preview

Press Spacebar to get a Quick Look preview.

Context Menu

Right-click on an asset to perform one of these actions:

* Open — will open the file as described above.
» Open With — where you can choose a specific application to open the file.
* Reveal in Finder — will reveal the file within a Finder window.

Using Local with Other Apps

Curiota Collections

If you’ve installed Curiota, Curio’s handy companion app, the Local scope popup will also list your Curiota Inbox and any Curiota

collections you’ve created within a separated section giving you easy access to those notes and files.
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Stencils

Obsidian Vaults

You can add Obsidian vaults to the scope popup and they are displayed within a separated section within the popup and with a
special icon. You can then search your Obsidian documents for strings and #tags from within the Local shelf.

Double-clicking a markdown file in the vault hierarchy will open the file within Obsidian.

DEVONthink

Many Curio customers use the popular DEVONthink application to manage vast collections of notes and links.
You can use the Local library’s Spotlight search support to search your DEVONthink data through a clever trick.

While Spotlight is unable to index the large DEVONthink database directly, DEVONthink replicates the metadata information for
every entry in the database into individual, uniquely-named metadata files (ex: EEBFO5E4-82E9-4824-AEOB-6E38A01BDF6F.dt3)
located in a special app support folder (~/Library/Metadata/com.devon-technologies.think3/) which Spotlight is able to index.

When Local uses Spotlight to search for DEVONthink files those uniquely named files are returned and Curio shows the results with
friendly titles.

Additional Notes:

+ Narrow your search specifically to DEVONthink files by choosing “DEVONthink” from the Kind popup.

+ Double-clicking one of those results will launch the metadata file which, in turn, launches DEVONthink, and opens the
appropriate entry in its database.

* Press Spacebar and a Quick Look preview will appear for the selected item, thanks to DEVONthink’s Spotlight plugin.

« If you drag a result from Local into your idea space, the DEVONthink metadata file will be added as an asset figure, and
given a nice title (instead of its messy unique number filename).

Stencils

Of course, you can use the Insert toolbar button to bring up the Figure Styles and Stencils gallery and click to insert a stencil.

However, if you use a lot of stencils, having a shelf where you can very easily drag-and-drop stencils from the shelf to your idea

space is invaluable.

Note that, like the Insert popover’s stencil gallery, the stencil library shelf will display both simple and complex stencils, for single
figure and multiple figure stencils, respectively. The title of the complex stencil will show the number of contained figures within in
parentheses. You can either drag the entire complex stencil into your idea space or double-click to drill into the complex stencil and
drag figures within the complex stencil out.
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Sleuth

Context Menu

Right-click on an asset to perform one of these actions:

- tag name
Choose a checked or unchecked tag name to toggle the tags associated with this stencil.
+ Edit Stencil
To edit the stencil.
* Send to Friend
To email the stencil to a friend.
» Send to Zengobi
To email the stencil to Zengobi if you’d like us to be able to share it with others.

Show the Stencils Library

« Click the Library shelf toolbar button, then click the Stencils tab at the top of the shelf.

Filter the Results by Repository

+ Click the Repository popup to change where to find Stencils. By default Curio will look at bundled figure stencils but you can
choose personal stencils or a stencils in an external repository specified in Curio’s settings. Curio Professional users can
choose to see Master stencils, as well.

Filter the Results by Tag

+ Click the Tag popup to see only those figure stencils associated with specific tags. You can use the actions menu next to this
popup to create new stencil tags. Then right-click on the stencils themselves to associate them with one or more tags. Note
that tags can only be created within your Personal repository.

Change the Sort Order

« Click the Sort By popup to change the sort: title, most recently used, or date added to the repository

Add a Stencil Via the Stencils Library

1. You can drag-and-drop an idea space from the Organizer directly to the Stencils shelf to save the entire contents of the idea
space as a figure stencil.

2. This is in addition to the other methods of creating a stencil such as by right-clicking on a figure and choosing Save as
Figure Stencil.

Delete a Personal or Master Stencil from the Stencils Library

« Select the stencil then press the Delete key.

Sleuth

The Sleuth library is a new, more accessible method for quickly conducting research while working on your Curio project.

- 249/423 - Copyright © 2025 Zengobi, Inc.



Evernote

It provides a subset of the sites the primary Sleuth window supports, that work well within the more compact width of the shelf.
Currently there’s no way to customize the available Sleuth sites that appear in the Sleuth library shelf as they require a bit of testing
to insure smooth operations in that slim area.

To use the Sleuth library simply type in a search term and quickly find images, definitions, synonyms, videos, and much more. Then
drag-and-drop results from the Sleuth shelf directly to your idea space.

Show the Sleuth Library

1. Click the Library shelf toolbar button, then click the Sleuth tab at the top of the shelf.
2. Or, {rClick on the Sleuth toolbar button or press ~=3F (or Edit > Search in Sleuth Shelf).
> The shelf will open if necessary and the Sleuth library will immediately become active.
o Any text that was selected or if a selected figure contains text will immediately become the search phrase for the
Sleuth library and the search will begin.
o This is an incredibly fast way to search for phrases on the internet.

Change the Search Site

+ Click the site popup to change where Sleuth is searching, or click the stepper to walk through the available Sleuth sites.

Changing the Page Zoom

* Choose View > Zoom In (3>), View > Zoom Out (¥8<), or View > Actual Size (380).

« The zoom increments jump through the same percentages as Safari: 50%, 75%, 85%, 100%, 115%, 125%, 150%, 175%,
200%, 250%, 300%.

* The zoom change is only for this session. 100% actual size will be used at next launch.

Evernote

Deprecation Notice

As a notice, Curio’s Evernote shelf has been deprecated. It still works currently but will cease at some point. Evernote isn’t
nearly as popular as it was over a decade ago and that old cloud API has long had issues. Instead just use the native Evernote
Mac client and copy/paste notes from that app into Curio.

Curio integrates seamlessly with Evernote so you can quickly search for snippets you’ve collected outside of Curio and easily drag
and drop those items into your idea spaces.

What Is Evernote?

Evernote is a multi-platform product and service which allows you to easily capture information in any environment using whatever
device or platform you find most convenient, and makes this information accessible and searchable at any time, from anywhere.

Evernote has client applications for macOS, iOS, Microsoft Windows, and a web-based solution. Data collected on any of these
clients are automatically synchronized between each other via the evernote.com service.
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What Is Evernote?

All clients are free and the service is free with some restrictions, although incredibly full-featured for a free product. Users can also
upgrade to a premium service plan for more features. To learn more about Evernote go to https://www.evernote.com.

Yinxiang Biji / 1512 / Evernote China

Curio should connect to Yinxiang Biji, Evernote’s China-based service, automatically using the user’s (a) China-based IP address,
and (b) Chinese locale setting in System Settings > Language & Region.

If this isn’t working then check Curio’s Help > Curio Advanced Settings on ways to force the connection.

Evernote Business

Curio currently does not work with Evernote Business accounts due to complexities in dealing with these types of accounts.

Get an Evernote Account

« If you don’t already have an Evernote account, visit their website https://www.evernote.com

Log into Curio’s Evernote Shelf

1. Once you have your Evernote account click on the Evernote shelf icon within Curio.

2. Enter your Evernote username and password. If requested, this information can be remembered for quick access in the
future.

3. Click the Login button to log into Evernote.

Search for Evernote Iltems

1. All search terms are optional but can include one or more of the following: search text, notebook, tag, kind, and last modified
date. Search text is wildcarded at the end (so searching for the word ever will find evernote , for example) unless the
phrase is quoted.

2. You can also specify how the results should be sorted when displayed and what zoom level should be used for the resulting
preview images.

3. The results are automatically refreshed as you make your selection changes. You may also click the Refresh button to force a
refresh.

Add an Evernote Note to an Idea Space

« Drag the note from the Evernote shelf and drop it into an idea space. When dragging an Evernote note out of the shelf into
your idea space, it is normally copied into your project. You can hold down the Command key while dragging to move it to
your project, automatically removing it from the Evernote cloud.

Add a Link to an Evernote Note to an Idea Space

+ Hold down the Option key and drag the note from the Evernote shelf and drop it into an idea space. This will create an
“evernote://” link that, when clicked, will launch the Evernote Mac client and open the referenced note within that
application.

Use Quick Look on an Evernote Note

* Press the Spacebar to activate Quick Look on the selected Evernote note.
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Automatic Meta Import

Open an Evernote Note

* Double-click an Evernote note in the shelf to open it with the Finder.

Delete an Evernote Note

« Select an Evernote note and press the Delete key to delete it from the Evernote cloud.

Automatic Meta Import

When bringing Evernote notes into Curio certain meta fields are automatically captured.

Tags
Your Evernote tags and notebook names are automatically synchronized into Curio with two special Curio global tag sets: “Evernote

Tags” and “Evernote Notebooks”. These new tag sets can be found in Meta inspector’s Tags panel.

Then, when a note is dragged from the Evernote shelf into the idea space, the Evernote tags and containing notebook names are
mapped their Curio tag counterparts.

This tag mapping feature allows you to use the Curio inspector bar or Search shelf to quickly find figures on your idea spaces
collected via Evernote.

Character Recognition Data

The Evernote service will automatically scan any images for handwritten or typed words.

When an image note is dragged into Curio, that character recognition information is embedded as meta data in the resulting Curio
asset figure. This feature allows you to use Curio’s Search shelf to find those images on your idea spaces using the same search
phrases.

Source URL

If an Evernote note item has a source URL associated with it then the resulting figure will automatically be associated with that URL
as well. Simply double-click the figure in the idea space to open the URL. If the note is a file, like an image file, then right-click and
choose Open File With Finder to open it with the Finder.

Limitations of the Evernote Shelf

The Evernote shelf is currently directional so you cannot make changes to any of your Evernote notes from within Curio. Please use
one of their free clients to make any changes.
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Evernote’s 3rd Party App Rate Limits

Evernote imposes rate limits on all 3rd party apps which limit the number of calls an app can make to the Evernote cloud within a 1-
hour period. Therefore several changes were made to Curio’s Evernote shelf so we greatly reduce the number of calls made to the

Evernote cloud.

+ Curio will no longer automatically download all notes in the selected notebook to the local cache.

* Instead we will only auto-download the first 5 notes in the resulting list. There is now an advanced setting if you wish to
increase this value, although don’t make it too high or you could hit the rate limit.

* When you select any note in the result list, if it isn’t already local, Curio will then immediately download it from the cloud.
Related to this, you can only select a single note at a time to ensure that we only download precisely what the user needs
and we minimize our connections to the Evernote servers.

+ A note will now clearly indicate if it is on the Evernote cloud, is being downloaded, or is in the local cache.

« Instead of downloading the note’s resources and recognition data as separate calls to the cloud the entire note is grabbed
with a single call which is much more efficient.

» Once a note is local you can hit spacebar to preview it, double-click to open it, or drag it to an idea space to embed a copy
of the note in your project.

Evernote hasn’t provided any specifics so we don’t know exactly what these limits are or if the limits are the same for regular vs.
premium users. However, with these changes we have optimized Curio’s Evernote integration as much as possible to greatly reduce
the chance that you’ll hit the limit within 1-hour periods.

Advanced Evernote Customizations

The Evernote shelf supports a few advanced customizations which you can read about in Help > Curio Advanced Settings.

Evernote Reset

If you have issues logging into to Evernote via Curio’s Evernote shelf then launch Keychain Access and search for “Curio Evernote”.
Select the resulting item and press Delete on your keyboard to delete it. That will clear the Evernote login token so you can login

anew within the Evernote shelf.

Status

You can access the status shelf by clicking on the Status toolbar button. Go ahead and do it now so you can look at it while we go

over some things.

Curio’s Status shelf view packs a lot of information into a compact display.

Getting Things Done (GTD)

“Getting Things Done” is a popular method of task management in use today. Using Curio’s built-in GTD tags, you can very easily
implement the “Getting Things Done” methodology within your Curio projects.
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For example, you may have several days of meeting notes spread over multiple idea spaces within a project. At each meeting, you
made a list of action items and tagged them appropriately. Some you may have tagged as active, others nextAction, and still others
waitingOn.

Using the Search shelf view, you can easily find a list of all the items you tagged active. But even better, you can use the Status shelf
view and group your tasks by the GTD tag set. In a single list, you’ll see all the items you tagged with GTD tags, broken down into
each category appropriately. You’ll instantly know what your current active items are, what your next actions are, and what items are
on hold, waiting for input from an external source.

You can use Curio’s tagging system, Search shelf, and Status shelf to implement a wide variety of task management methodologies.

Projects Panel

The top panel of the Status shelf shows your projects grouped in to the same categories that you created either in the Open Project
Gallery described earlier or by using the Add New Category action menu selection.

Under each project title in the top pane, you will see a count of a subset of your tasks in the project. The subset is defined as tasks
that have a start date and you have not yet started or that have a due date and have you have not yet completed. When you start a
task (by setting or completing it to a certain percent) or complete a task, it is not counted in this list. When no tasks are yet to be
started or due on a project, Curio will indicate in the top panel by a statement that No tasks to start or due. The count of tasks in the
top panel is therefore different than what you will see in the bottom pane, where tasks can appear regardless of whether they have
start or due dates and regardless of whether they have been started.

Finally, a color coded jewel to the left of the project title indicates the status of each project. Red indicates tasks are late to begin or
are overdue, magenta indicates a task is starting or due today, purple indicates a task is starting tomorrow, brown indicates a task is
starting or is due within a week, blue indicates a task is starting or is due within a month and green indicates either no tasks or a
task is starting or is due beyond a month.

Tasks Panel

At the bottom you’ll find all the tasks due in either the current project or a category of projects. These tasks can be grouped by start/
due dates, priority, rating, or even a tag set such as flag or GTD state. Each task is displayed with a color-coded status jewel and a
checkmark indicating its current completion date.

Note that a task, as currently defined, is a figure with either (a) a checkbox, (b) a start or due date, or (c) an assigned tag. A tagged
item is considered a task primarily for GTD or Kanban task tracking workflows.

Toolbar Icon

The Status shelf icon displayed on the toolbar has a color-coded indicator dot as well showing the status of the current project. If
green then all’s well, but other colors would alert you so you can click the button to display the Status shelf and see what task
needs your attention.

Projects Panel

How to use the projects panel area of the Status shelf.
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Change the Scope

+ Use the Projects In popup to determine what projects to display either based on a smart category or custom category. See
the Open Project Gallery section described earlier for more details regarding project sections.

Change the Sorting

+ Use the Sort By popup to change how the projects are listed: by status, title, last modified date, or date created.

Adding Projects

1. Drag a project from the Finder into the list to add it to the current custom category.
2. Note this only works with custom categories as the projects listed within smart categories, such as “Recently Opened
Projects”, are determined automatically.

Deleting Projects

+ Select a project and press the Delete key to remove a project from a category. Curio can also send the project to the Trash if
you wish.

Ignoring Projects

1. You may want to ignore tasks in specific projects that are either on hold or simply no longer actively used. You don’t want to
remove those projects from their respective categories but you really don’t want tasks from those projects cluttering up your
Status shelf results or live exports.

2. Right-click on the project in the projects list at the top of the Status shelf and toggle the Ignore Tasks In Project setting.

3. An ignored project’s tasks will no longer appear in the Status task results area or in live exports.

4. You can control whether ignored projects are displayed in the projects list at the top of Status using the Projects In actions
menu’s filtering options.

Assigning Categories to Projects

1. Right-click on a project to associate or disassociate categories with the selected project.
2. Or, use the action button menu to add the current project or a specified project to the current category.

Creating, Modifying, and Deleting Categories

* Use the actions menu to create, rename, or remove project categories.

Switching to a Project

+ Click on the project to load it within the current window.

Opening a Project in a New Window

* ~=-Click on a project to open it in a new window.

Finder Tags

1. As mentioned above in the overview of the Project Gallery, any project categories you associate with your projects will also
have corresponding project category Finder tags as well.

2. For instance, if you associate a project with the categories Active and Personal, then Curio will create “Curio Active” and
“Curio Personal” Finder tags and associate them with the projects.
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3. With category Finder tags, you can now search for categories of projects in the Finder, outside of Curio.
4. Just enter the search tag, such as Curio Active in a Finder window search field and you’ll find all projects associated with
that category.

5. Click the Save button in the Finder window to save the search and even add it to your sidebar for one-click access to those
projects.

Tasks Panel

How to use the tasks panel area of the Status shelf.

Change the Scope

+ Use the Tasks In popup to determine what projects should be searched for tasks. Or you can choose the current project or
the current project’s selected section, section tree, Organizer item, or Organizer item tree.

Changing the Grouping

Choose the desired task grouping from the Group By popup:

+ Date. You can group tasks by “Action ltems” (tasks with a start and/or due date assigned to them, or items that have a
checkbox next to them), by “Start Date”, or by “Due Date”.

* Rating

* Priority

+ Local Project Resources. Only available if Tasks In is set to Only This Project.

* Local Project Tags. Only available if Tasks In is set to Only This Project.

+ Cross Project Tags. Used to group items based on your global, cross project tags.

« Tag Set. For example, you might choose to group tasks by the GTD (“Getting Things Done”) tag set, in which case any tasks
that have been tagged with one or more of the GTD tags will appear under the appropriate tags.

Changing the Sorting

Choose the desired task sorting from the Sort By popup:

* Action Date

« Start Date

* Due Date

- Title

« Percent Complete

+ Rating

* Priority

» Tag Set (sorted by the ordering of the tags in the specified tag set)

+ Project Name (if a project category or All Categorized Projects is selected)

Jump to a Task

1. Click on a task to jump to its location in the project. If the task is from a different project, Curio will automatically switch to
that project.

2. Hold down the Option key while clicking on the task if you want Curio to open the project in a separate window.
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Changing Task Properties (For Tasks in the Opened Project Only)

1. Right-click on the task in the Status shelf and change the item’s associated tags, its percent complete value, its rating, and
its priority.

2. If you’re grouping your tasks by rating, priority, resource, or global/local tag set then you can drag-and-drop tasks between
groups. With resources and tags, Curio will disassociate the figure from the task’s prior grouping and associate it with its
new grouping

Action Button Menu Options

1. Copy all the displayed tasks as text or to export the tasks as an RTF document to disk. This is a very easy way to share
assignments with other team members.

2. Export all task information as markdown for display in a markdown-compatible viewing app.

3. Export all raw task information as CSV file perfect for importing into Apple Numbers or Microsoft Excel. The following fields
are exported: Task Title, Project, Section, Idea Space, Start Date, Due Date, Duration, Duration Units, Percent Complete,
Priority, Rating, Tags, Resources. Duration units are specified using a numeric code: seconds=0, minutes=1, hours=2,
days=3, weeks=4, months=5, years=6.

4. By default, Curio will include items with checkmarks (aka to-do items) which are unchecked but have no start or due dates. If
you want to only include to-do items that have start or due dates then uncheck the “Include items with no start or due dates”
item in the actions menu.

5. By default, Curio will alert you of tasks that have a start date associated with them and it is currently past the start date and
the completion percentage of the task is zero percent. If you don’t want to be warned in this event then uncheck the “Include
items late in starting that are 0% done” item in the actions menu.

6. By default, Curio doesn’t include untagged tasks when you group by tag set or local tags. However, you can enable this by
checking the “Include grouping for untagged tasks” item in the actions menu.

Live Export

Curio can export task reports in real time as you change data within the project.

Setting up Live Export

1. Use the Status shelf’s Tasks In actions menu to manage live export.
1. Enable live export by specifying the folder where the live export reports should be saved.
2. Click the menu again to enable each type of live export you wish to produce. RTF and HTML exports are enabled by
default.
3. Use the same menu to specify the category of projects to export and how they should be grouped.
2. In the background, the Status shelf will keep those live export files automatically up-to-date as tasks and projects are
changed. The export files created in the specified live export folder are named curio Status.rtf , Curio Status.csv , and
curio status.html . If you specify a synced folder, like Dropbox, or a network folder, then those updates will be available to
everyone with access to that folder.

Customizing the HTML Export

1. The resulting HTML is standard, compact, cross-platform, self-contained... and generated using a bundled template file
which you can customize!

2. You can find the template in  /applications/Curio.app/Contents/Resources/Repository/Status Templates/Status Board.html .

3. The template includes placeholder variables which filled out with figure data and the result is then dynamically constructed
and rendered with Javascript.
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4. You can create YOour OWNn status Board.html at ~/Library/Application Support/Curio/Version XX/Repository/Status

Templates/ 0 completely change the look of the report and Curio will use that instead.
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Search

Curio offers several ways to search your project for figures and other items.

1. The Search Shelf shows your query results as a grouped outline so you can peruse or step through several items. You can
even export the results in various formats.

2. The Quick Find popup allows you to instantly find and jump to idea spaces and figures.

3. The Organizer Filter and Smart Filters can be used to filter the items displayed in your project’s Organizer.

Query Expressions

All Curio search mechanisms support a powerful, extensive query language to perform searches.
Your queries can be as simple as:

ipad
Or as complex as:

(ipad or iphone) @Stevel #event #2010 (start > 2010-06-25 or due < 2w) progress < 50 group:priority

Search Shelf

Press #F to bring up the Search shelf, or click the search toolbar button.

Type in your search query, using the helpful keyboard button below the query field to choose meta parameters and optional query
commands.

After a pause or after pressing the Return key your results appear organized below the query.

Click on a result to jump to that item in the idea space. You can also use the up and down arrow keys to step through the results
jumping between the figures in their various idea spaces.

Clearing or Canceling
Click the Clear button to clear the query leaving the Search shelf up so you can type a different query if you'd like.

Alternatively, if you’d like to clear and dismiss the Search shelf you can press $F or press the Escape key (assuming the query text
field still has focus). The query will be cleared and the previously viewed shelf will be restored.

Note that if a query is active it will remain active even if you switch to another shelf. The Search button on the toolbar changes to a
red color so you know a search is active. This way you can use the inspector or other shelf modules to examine found items without
clearing the query results.

Saving and Reusing Queries

When you enter a new query into Search a small Save button becomes visible. Click it and your query is saved for easy reuse.

To reuse a saved query, click the keyboard button in the Search shelf to choose the query from the popup menu that appears.
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If you select a previously saved query from that popup menu then a small Delete button appears, so you can easily delete that
saved query. Or if you make changes to the query text, the button changes to Update so you can update its existing entry.

Exporting Search Results

Click the share button under the query field to copy your result as rich text, or export your search results in rich text, markdown, or
CSV format. You can also export a CSV report of all figure cross references in those results, see References for more details.

Quick Find

Press {} 8F to bring up the Quick Find window, which will appear above the current Curio project window. You may also choose the
Edit > Quick Find menu.

Q. #special or (progress=0 @johnm) or (due < 2m) (save ) @

Complete contract negotiation
Sales update - 8/10/21

Discuss app store approval process
Issues - 0% - 8/16/21 - @JohnM

Finish 2022 projections
Sales update - 25% - 6/23/21-6/26/21 - #DetailedTasks.Active #special - @GeorgeB

After the Quick Find window appears, type in a search query and the window expands to reveal idea spaces and/or figures that
match that query.

Handy Query Pick List

Like the Search shelf there’s a helpful keyboard button next to the Quick Find query field you can use to choose meta parameters
and optional query commands.

Selecting a Search Result

You can directly click on a result or use the arrow keys to highlight a result and press Return, you will then instantly jump to the
selected item. If the Option key is pressed then the item destination will be opened in the secondary split view.

Canceling the Search

Alternatively you can also press Escape or click on the idea space behind the Quick Find window to dismiss Quick Find.

Refreshing the Results

By design, if you bring up Quick Find again within a launch session it will show you the last results without refreshing first. This way
you can make changes to found items between subsequent returns to Quick Find to jump to the next item.

To force a refresh simply press Return to force a re-query, or change the query which will automatically refresh the results.
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Sending the Query to Search

Press $Return to send the Quick Find query to the Search shelf if you’d like to browse through several result items.
Saving and Reusing Queries
When you enter a new query into Quick Find a small Save button becomes visible. Click it and your query is saved for easy reuse.

To reuse a saved query, click Quick Find’s magnifying glass icon or its keyboard button to choose the query from the popup menu
that appears.

If you select a previously saved query from that popup menu then a small Delete button appears, so you can easily delete that
saved query. Or if you make changes to the query text, the button changes to Update so you can update its existing entry.

Organizer Filter

The Organizer Filter and Smart Filters can be used to filter the items displayed in your project’s Organizer using the same query

language as the Search shelf and Quick Find. This functionality is discussed in greater detail here.

Background

Booleans

Terms are AND’ed together by default, so searching for #2021 #personal ecGeorges means that all three terms must match.
You can use or (case-insensitive), such as #personal or @ceorgeB , Orthe || symbol, if you wish.

(Technically not is also supported although generally not very useful. Finding all items where not priority=3 returns a flood of
results.)

Parentheses

Parentheses may be used to assist with the logic, such as #crp/active (#personal or @Georged ). YOU can also nest parentheses if
you wish for more complex logic.

Comparison Operators

Where appropriate the following operators are allowed: >, <, =, =, >=, =, <=, =<, =, < .

And, in certain situations, specifically custom data string values, you can also use the bveginswith and endswith oOperators such

aS #FullName endswith jobs .
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Starting Prefix

Curio looks for special prefixes at the very start of the query which can come in handy:

« - will force the result to be sorted in descending order, ex: - #active .
+ + will force the result to be sorted in ascending order, ex: + #active .

Note there’s a space after the prefix character before the rest of the query text.

Commands

The query can include optional commands that allow you to fine-tune the results.

Commands are in the form command:value suchas sort:due .

Sort

Example: sort:title

By default Curio sorts the results by title, alphabetically in ascending order.

However, it tries to be smart about this. For example, if your search query includes the term priority > 2 then Curio will will

automatically sort the results by priority, and it will do it in descending order since you’re more likely to want to see the high priority

items at the top.

If you simply want to reverse the sort order you can use the special - or + starting prefix described above.

Or you can force Curio to sort by a specific meta property, even if it’s not part of the query, by using the sort command like this:

sort:rating OF sort:-priority .Anoptional + or - value prefix before the field name can be used to force an ascending or

descending sort.

Your sort options are:

* title - thetitle
* start - start date
* due -due date

+ startdue - start date unless already started (by progress > 0) then due date

* done - done date

* added - date added

* modified - date last modified

* progress - progress (percent complete)
* priority - priority

* rating - rating

* kind - kind

* organizer - Organizer order

* #tagsetname - Sorted by the order of the tags in the specified tag set, like sort:#gtda or sort:#/ (the cross project tag

set) or sort:#. (local project tags).
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Group

Example: group:priority

Note
The grouping parameter isn’t currently used by Quick Find, but can be used in the Search shelf and in query-based hierarchical

smart collections such as lists and mind maps.

You can use the group command to organize your results into hierarchical groupings.

For example, group:due Wwill organize the results into groups like Before Today, Today, Tomorrow, Within Week, etc. And
group:priority Will group items into Urgent, High, Medium, etc.

Your group options are:

* title -thetitle

* start - start date

* due -duedate

* startdue - start date unless already started (by progress > 0) then due date

* done - done date

* added - date added

* modified - date last modified

* progress - progress (percent complete)

* priority - priority

* rating - rating

* kind - kind

* organizer - Organizer order

* #tagsetname - grouped in the order of the tags in the specified tag set, like group:#gtd oOr group:#/ (the cross project tag
set).

* none - forces no grouping; useful if you want to override automatic grouping normally applied to query-based hierarchical

smart collections such as lists and mind maps.

Scope

Example: scope:section
By default the Quick Find and Search shelf search the entire project, while the Organizer filter searches the current section.

However, you can modify the scope if you wish using the scope command like this: scope:ideaspace OF scope:s/ .
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Your scope options are:

* project Or / -the entire project

* section Or s -the current section

* section/ Or s/ -the current section and any child sections

* ideaspace Or i -the currentidea space

* ideaspace/ Or i/ -the current idea space and any child idea spaces
* journal - the Journal section

* archive -the Archive section

* trash - the Trash section

Note
By design, searching the entire project does not include the Archive or Trash sections.

Limit
Example: 1imit:10
If you would like to restrict the number of returned items specify a limit value like 1imit:10 .

For Quick Find, the default is unlimited which is the same as specifying 1imit:0 .

For query-based smart collections there is a safety limit of 100, so you don’t have a collection explode with hundreds or thousands

of items, but you can override this for a specific query using the 1init command, or it can be permanently overridden.

Include

Example: include:nocheckbox

Normally Curio excludes certain types of result items when they wouldn’t make sense to include in the results, but you can override
this.

Important
The inciude command must be specified at or near the front of the query.

* instances - instances of synced figures are generally not included in the results, only the original figures, unless you specify
include:instances .

* nocheckbox - When searching for progress (aka percent complete) such as progress=0 Or progress<50 then because that
could include figures with a 0% progress, which is the default for all figures, then Curio only searches those that have a
visible checkbox. However, you can include:nocheckbox and all figures will be included, so you will want to construct query
logic that includes another query element such as a required tag or resource to narrow the results.

If you want to include multiple types then use | to separate them: include:instances|nocheckbox
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Query Terms

Query Terms
Text

ext queries are case-insensitive contains searches efault. This means searching for mac will match “macintosh” and “iMac
Text t t hes by default. Th hing f Il match “ tosh” and “iMac”

and “stomachache” as they all contain “mac”.

What Text is Searched?

With figures, the figure’s title or text content is included in the search, as well as any meta note text, image OCR text, and the URL
path if an URL is associated with the figure. Note that asset document contents are not included.

With Organizer items, such as idea spaces or documents dragged into the Organizer, the item title and any note text is included. The
contents of Organizer documents are not included.

Phrases

You can search for multi-word phrases by using double-quotes, such as "vacBook pro" .

Regular Expressions

You can also use case-insensitive regular expressions (regex) in your text queries, thanks to a helpful / prefix which tell Curio

you’re entering regex.
Curio will auto-remove the slash from the term before performing the query.
For example, searching for /\bmac will match words the start with “mac” such as “macintosh” but not “iMac” or “stomachache”.

Another example, searching for /\vping[0-71 will find all figures that contains the word that starts with “ping” followed by a
numeric between 0 and 7. Thus it will match “ping1” and “ping535” but not “ping8” or “shopping2”.

Resources for regex include Regex Tutorial, Using ICU Regular Expressions, and RegEx101.

As a final example, say you type /steve.*jobs as your query. It will match the text “Steve Jobs”, “Steve P. Jobs”, “Steve Paul
Jobs”, and “Steven Paul Jobs”.

Limitation
Entered regex can’t include a space.

Technical
Internally Curio uses your query to construct a formatted expression which it then passes to nsrredicare to actually perform
the query. NSPredicate’s warcuars expression term is used to handle the regex evaluation so Curio is limited to its regex

capabilities.

Text Within Asset Contents

Example: zengobi curio
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Tags

Specify text within backticks, like find me and Curio will use two mechanisms to find that text within your project’s assets:

1. First SearchKit will be used to search simple text and PDF asset documents embedded within the project.
2. Then Spotlight will be used to search your project’s documents that are located outside the project’s file package (since it
can’t look within the package):
o All aliased asset documents that exist outside the project.
o All assets if your project’s library is located in an external asset library folder.

Spotlight’s mechanism is much more powerful since it can index many more types of documents thanks to its extensible plugin
architecture that Apple and 3rd parties can use. However, Spotlight is limited in that it can’t index any files hidden within a package
folder like Curio’s .curio project package. This is why we have to rely on Apple’s rather antiquated SearchKit system to index
embedded text and PDF files.

Note if your query text is multiple words the search is performed as a complete word phrase.

Tags

Example: #cool Or #gtd/done
Prefix any tags with a # . Note that all tags and tag sets need to be entered with spaces removed, case-insensitive.

* Tags nested within a tag set will need the full tag path specified. For example, you could search for #detailedTasks/onhold
to match a figure or idea space associated with a tag named On Hold within the Detailed Tasks tag set.

* You can also simply search for #onhold or #special and it will find all items with that tag, either as a standalone keyword
tag or as a tag within a tag set.

* You can search for tag set names, like #gtd/ (notethe / suffix), which will find all items associated with any tag in that
tag set. As a shortcut, if the entered tag set name doesn’t coincidentally exist as a tag name you can simply enter #gta if
you wish.

Quick Find and Search both support autocomplete while typing a tag so you can easily find and choose one from the popup that
appears.

Items With Any Tag

You can also find all items that have any tag with the + wildcard by searching for #* .

Pseudo Tags

Curio can, on the fly, associate one or more pseudo tags with your figures and Organizer items to provide additional searching
possibilities.

Figures

* #meta/noted if a figure item has an associated note.

* #meta/rated if a figure has a set rating.

* #meta/prioritized if a figure has a set priority.

* #meta/tagged if a figure item has an associated tag, including inline tags.
* #meta/customdata if @ figure item has associated custom data.

* #meta/action if afigure item has a set action.
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Organizer Label Tags

+ j#meta/unchecked if the figure’s visible checkbox is unchecked with no progress made (progress = 0).
* 4meta/checked if the figure’s visible checkbox is checked and therefore 100% done (progress = 100).
* #meta/notchecked if figure’s visible checkbox is not checked yet (progress < 100).

* 4meta/syncfile if the figure is has an associated sync file.

* #meta/original if the figure has synced figure instances of a figure.

Organizer items

* #meta/noted if an Organizer item has an associated note.
* #meta/tagged if an Organizer item has an associated tag.
* #meta/labeled if an Organizer item is labeled.

* jmeta/pinned if an Organizer item is pinned.

Organizer Label Tags

If you assign an Organizer label to an idea space then a pseudo tag is associated with the item for searching.

For example, assigning Needs Work to an idea space will automatically associate the #rabel/needswork pseudo tag to the idea
space so you can now query for those items.

Custom Data

Example: #country = us

If you’ve created custom figure data, such as “Price” and “First Name”, then you can build queries like #price > 30 and

#firstname=george .
Note the custom data field key has to begin with a # , with spaces removed, case-insensitive.

With text values, the query is case-insensitive. If you have a figure with a custom value of “George” then #firstname=george Or

#firstname beginswith geo Will find it.

Quick Find and Search both support autocomplete while typing a custom data key so you can easily find and choose one from the
popup that appears.

Resources

Example: @george
Prefix any resources witha e .

The full resource name must be specified, spaces removed, case-insensitive. For example, you could search for egeorgeBrowning
to match a figure associated with a resource named George Browning.

Quick Find and Search both support autocomplete while typing a resource so you can easily find and choose one from the popup
that appears.
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Reference Types

Items With Any Resource

You can also find all items that have any resource with the * wildcard by searching for e* .

Reference Types

Items Which Have References of Type

Find any items that have references of the given type.

Example: ~source

For instance, if Figure A has a figure NYTimesExtract as a Source reference then searching for ~source would return Figure A.
Prefix any reference types witha ~ .

The full reference type name must be specified, spaces removed, case-insensitive. For example, you could search for
~rebuttal or “primaryWitness tO match a figure that has a Rebuttal or Primary Witness reference association.

Quick Find and Search both support autocomplete while typing a reference type so you can easily find and choose one from the
popup that appears.

Items Which Have References of Any Type

You can also find all items that have any references with the + wildcard by searching for ~= .
Items Which Are References of Type

You can also find items that are references of the given type.

Example: ="source

Note the use of the = prefix to indicate you’re looking for items that are used as that reference type.

For instance, if Figure A has a figure NYTimesExtract as a Source reference then searching for =“source would return
NYTimesExtract.

Items Which Are References of Any Type

And you can find items that are references of any type.
Example: =+

This would return all items that are themselves any type of reference.

Rating

Example: rating = 5

Query for ratings, such as rating >= 3 to find all figures with 3 or more stars.
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Priority

Priority
Example: priority < 3

Query for priority, such as priority = 5 to find all figures with an urgent priority. The values are as follows: very low (1), low (2),
medium (3), high (4), or urgent (5) priority.

Progress

Example: progress = 0
You can query for figure progress (aka percent complete), such as progress < 100 .

Note that only figures that have a visible checkbox are included when the query could include results where progress is 0 because
that’s the default state for all figures in Curio. If you want to include items with no visible checkbox then start your query with
include:nocheckbox and be sure to include some other query parameter which will filter out regular figures. For example, perhaps a

tag like #gtd/ or aresource like egeorge .

Dates

Example: due < 2w

Curio supports several different date fields: start , due , done , added , modified .

Date values can be entered in standard YYYY-MM-DD format such as due=2021-12-25 Of start>2021-01-01 .
You can also pass numeric values and Curio will compute the date for you:

* start < 2 OF start < 2d returns all items that start within the next 2 days.
* modified > -2w returns all items modified in the past 2 weeks.

* due < 3m returns items due within the next 3 months.

* start < 1y returns items that start within the next year.

Project Milestones

You can also pass a project milestone as long as it’s entered without spaces. For example, if you have a milestone of Beta 1 then
you can find all figures modified after that milestone with modified > petal .

Example: kind = mindmap

Query for asset or figure kind such as «xind = image to find all images or «xinda = ur1 to find all URLs. The not equals ( '=)

operator is also handy so you can search for xind != ideaspace for example.
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Potential values include figure types such as:

* text , url , image , doc OF document , video , audio , webarchive ,

ideaspacelink , folder , 1list , mindmap , table , indexcard

*You can use rigure forany type of figure.

As well as Organizer types such as:

* ideaspace , odoc OF odocument , ofolder , oalias , journal .

* You can use organizer for any type of Organizer item.

File Extension

Example: ext = swift

Query for asset figure file extensions, such as ext=par to find all PDF asset figures.
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Automatic Substitutions

Automatic Substitutions

Curio performs a number of automatic substitutions to allow more readable expressions.

Type This Maps to This Allowing

on = due on 2021-12-25

in >= due in 2 weeks

last >= - added last 2 weeks
past >= - added past 2 weeks
after > due after 2021-12-25
before < due before 2021-12-25
within < due within 1 month
by <= due by 2021-12-25

x day (s) xd due in 2 days

x week (s) XW due in 1 week

x month (s) xm due in 6 months

X year (s) Xy due in 1 year

today 0d due before today
tomorrow 1d due after tomorrow
yesterday -1d due before yesterday
starts start starts before 2021-12-25
starting start starting in 2 weeks
starts today starts = today starts today

starts tomorrow starts = tomorrow starts tomorrow
starts soon starts <= 7d starts soon

due today due = today due today

due soon due <= 7d due soon

due tomorrow due = tomorrow due tomorrow

overdue due < 0 overdue

URL Scheme

Curio supports @ curio://search?query=... URL scheme which will bring up Quick Find with the given query.

Note that the query parameters have to be URL encoded so they are valid within the URL. Use the following mappings to convert
certain special characters into their safe, encoded hex equivalents.

space “ # % & < > @ A
%20 %22 %23 %25 %26 %3C %3E %40 %5E

So, for example, you would encode the query for:

-271/423 - Copyright © 2025 Zengobi, Inc.


https://www.rfc-editor.org/rfc/rfc3986#section-3.4

URL Scheme

"financial results" #Apple/iMac-Pro @Accounting start<2

as

curio://search?query=%22financial%20results%22%20%23Apple%2FiMac-Pro%20%40Accounting%20start%3C2

Online URL encoders can make this easier to do.
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Status Bar

Status Bar

Curio’s Status Bar is located at the bottom of the project window and has an extensible, plugin architecture for displaying and
manipulating Curio data.

Using the Status Bar

While visible by default, you can press #/ to toggle the display of the Status Bar at the bottom of the project window. You may
also choose the View > Show/Hide Status Bar menu.

Tip
Press / to shift keyboard focus to the status bar, revealing it if necessary.

Hover Info

Go to https://www.apple.com/watch/ « 25% done - Oct 15, 2021-Oct 29, 2021 - #Guides.Link #QandA.Correct #special - #Price=$25.99 - @GeorgeB

If you hover the mouse over a figure the Status Bar will display:

+ The double-click action such as opening a file or website or navigating to a different idea space.
» Progress: 253 done

« Start and due dates: oct 15, 2021-0ct 29, 2021

° Priority: Urgent Priority

* Rating: k& %%

. Tags: #GTD/active #special

+ Custom data values: #FullName="Steve Jobs" #Price=$1,234.99"

* Resources: @GeorgeB @SteveJ

Move and Resize Info

If you move or resize a figure then the figure’s origin or dimensions are displayed and updated in real time as you continue moving or

resizing.

x: 123, y: 168

width: 176, height: 149
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Meta Editing

Meta Editing

#Guides.Link #QandA.Correct #special #Price=25.99 @GeorgeB @SteveJ
GeorgeB

JohnM

One of the more powerful modules included with Status Bar is a figure meta data editor.

Begin by selecting one or more figures, and their common meta data will be displayed in the Status Bar. You can then edit the
following meta data and press Return to commit these edits:

Tags

« Specify tags: #special #GTD/active #ProductTypes/hardware
o Prefix with  # .
o Separate tags nested within tag sets using a slash ( #crp/active ).
> Don’t type spaces in tag sets and tag names.
o Upper and lower casing is ignored.
o Autocomplete will appear as you type to assist with entry. You don’t have to type tag set prefixes or slash prefixes to
find a match. All local and global tags are searched.
> You can also type a new local project tag, #details , or global cross project tag with a slash prefix, #/homework , Or
tag for an existing tag set, #gtd/finishea and it will be created automatically.
* Delete existing tags by backspacing over them.

Custom Data

« Specify custom data expressions: #FullName="George Browning" #price=49.99
o Prefix with 4 .
o Don’t type spaces in custom data keys.
o Upper and lower casing is ignored.
o Autocomplete will appear as you type to assist with entry.
o Enter unformatted values, like 1234.99 . Curio will apply the custom date key’s formatting automatically when
displaying the values, like s1,234.99 .
o Use double quotes if the value has a space in it.
+ Delete existing custom data assignments by backspacing over them.

Resources

+ Specify resources: egeorgeB @Stevedobs @BrowningGeorge

o Prefix with e .

> Don’t type spaces or commas in resource names.

o Upper and lower casing is ignored.

o Autocomplete will appear as you type to assist with entry.

> You can also type a new resource nhame, like efred , and it will be created automatically.
+ Delete existing resources by backspacing over them.
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Meta Editing

Progress

« Specify progress percent completed: 30%
o Suffix with = .

+ Alternatively you can enter progress in a verbose way: progress=30
> Note there is no suffix.

+ Values of 0 to 100 are accepted.

* Delete an existing progress by backspacing over it.

Priority
« Specify priority: 5!
o Suffix with 1 .
* Alternatively you can enter priority in a verbose way: priority=5
> Note there is no suffix.
+ Values of 1 (very low) to 5 (urgent) are accepted.
« Alternatively you can enter 1 to 5 exclamation points suchas ', 111, 11111 | orthe priority text, with no spaces, such

as verylow , low , medium , high , urgent .

* Delete an existing priority by backspacing over it.

Rating
* Specify rating: 3*
o Suffix with .
« Alternatively you can enter rating in a verbose way: rating=3
> Note there is no suffix.

* Values of 1 (%) to 5 (%% % % %) are accepted.
« Alternatively you can enter 1 to 5 asterisks or stars such as » , »xx | xxxex Or Kk , kkk , kkkkk .

+ Delete an existing rating by backspacing over it.

Dates

The meta status bar will display figure start and due dates for editing only if they are not automatically determined based on parents,

siblings, children, or durations.

If you decide to specify a start or due date then Curio will make sure the figure is set to manually specified for that date property as

you are forcing a specified value.

Start Date
« Specify start date: 12/25/21
> No prefix.
oUseeither , , . ,or - forseparators: 12/25/21 or 12.25.21 or 12-25-21 are all accepted.

o Leading zero for single digit numerals is optional: o6 or 6 .

o The year, which is optional, can be 2 ( 12/25/21 ) or 4 digits ( 12/25/2021 ). If not specified, the current year is
assumed.

o Automatically determines US-style “month day” ( 12/25 ) or European style “day month” ( 25/12 ) format based on
your System Settings > Language & Region. You may force it to “month day” or “day month” if you wish.

> The year-month-day ISO format ( 2021-12-25 ) is also recognized with slashes, dashes, or dots.

> Note that times cannot be specified, currently.
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Meta Editing

* Delete an existing start date by backspacing over it.

Due Date

« Specify due date: -12/31/21
o Prefix with - .
o Otherwise same rules as above.
* Delete an existing due date by backspacing over it.

Start and Due Dates

 Specify both a start and due date: 12/25/21-12/31/21

> No prefix.

> Same rules as above but the separator between the start and due must be a dash - .

o Since year is optional any of these examples are valid: 12/25-12/31 , 12.25-12.31 , 12-25-12-31 .

o If you generally use a dash as a month-day-year separator then both start and due must either include or not include
the 2 or 4 digit year. You can’t have one with the year and the other without as that would lead to potential parsing
mishaps.

* Delete an existing start and/or due date by backspacing over it.

Duration

If you specify a duration and the due date is not currently set to manually specified then setting a duration will set the due date to
computed based on start date + duration, mirroring the functionality of the duration field in the inspector.

* Specify a duration: 34
o Suffix with a , w, m, vy ,forday, week, month, and year, respectively. These can be overridden (day, week,
month, year) and the same suffix is used in Quick Find’s search queries.
> Note that durations in hours or minutes cannot be specified, currently.
* Delete an existing duration by backspacing over it.
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Sleuth

Sleuth

Curio includes Sleuth, its integrated research assistant to make finding anything on the web fast and fun.

Sleuth can help you research ideas by giving you easy access to almost any search engine available on the Internet. You can quickly
look up images, definitions, rhyming words, translations, and general information related to any topic. You only have to fill in the
search field once, and then visit the sites that most interest you. When you find something you want to remember, simply drag and
drop it into an idea space.

Al Chat Services
Sleuth has support for the chat-based Al services, like ChatGPT. Unlike other Sleuth sites, these services have their own

conversational chat interfaces for interacting with the user so Sleuth’s search field isn’t used. See more notes about these
services below.

Searching in Sleuth

1. Reveal the Sleuth window by clicking the Sleuth toolbar button or choosing the Window > Show Sleuth menu item.

2. Type a word or phrase in the search field located at the top of the Sleuth window.

3. Press Return to perform the search on the currently selected website, or choose a different site from the site popup menu
located to the right of the search field.

4. The search results will be displayed in the bottom part of the Sleuth window. You can explore your search results as you
would any website.

5. You can use the back and forward arrows at the top of the Sleuth window to navigate web pages.

Importing Sleuth Content into Curio

1. Drag images, selected text, and web links from the Sleuth window to any idea space or the project library to save the results
you like.

2. You can grab the URL of the currently displayed page by dragging it from the status area located at the bottom of the Sleuth
window.

Changing the Sleuth Site

1. To see search results for the same word or phrase on a different site, click on the site menu and choose another site.
2. You can also click on the up and down arrows next to the site menu to perform the same search on the previous and next
sites within a category respectively.

Changing the Page Zoom

* Choose View > Zoom In (3>), View > Zoom QOut (88<), or View > Actual Size (£0).

« The zoom increments jump through the same percentages as Safari: 50%, 75%, 85%, 100%, 115%, 125%, 150%, 175%,
200%, 250%, 300%.

 The zoom change is only for this session. 100% actual size will be used at next launch.

Make the Sleuth Window Always Appear on Top of All Other Windows

+ Click the On Top toolbar button on the Sleuth window. Click again to turn off this feature.
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Al Chat Services

Make the Sleuth Window Transparent so You Can See Through It

« Click the Transparency toolbar button on the Sleuth window. Click again to turn off this effect.

Add or Edit Sleuth Sites

+ Click the Customize toolbar button on the Sleuth window, and follow the steps detailed on the next idea space.

Al Chat Services

Sleuth includes support for Al chat services, like ChatGPT and Google Gemini.

Unlike other Sleuth sites, these services have their own conversational chat interfaces for interacting with the user so Sleuth’s
search field isn’t used.

Essentially, for these types of services, Sleuth is simply a handy web view directly to their web-based site, either as a standalone
Sleuth window or from within the convenient Sleuth shelf sidebar. Curio is not accessing the Al service directly via their API.

Many if not all of these services off a free plan, while some offer one or more advanced “plus” or “pro” paid plans offering more
functionality and capabilities which you can subscribe to directly with their service.

@ Important @
» Zengobi does not have access to your queries or history.
« Zengobi is not responsible for a service’s responses or output.
» Zengobi is not involved with sign-up or paid subscriptions to a service.
« Al responses can occasionally make up facts or “hallucinate” outputs.
- It is vital that you read and understand the Terms of Use and Privacy Policy of the Al chat service for their data use and
retention policies before submitting any information to that service.
* Unless these services state otherwise, any data you input could be used to train their Al models.
* Do not submit personally identifiable, confidential, or private information.
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Included Al Chat Services

Service Terms of Use
Claude Terms
ChatGPT Terms
Copilot Terms
DeepSeek Terms

- Terms
Google Gemini

Generative Al Terms

Terms
Google ImageFX

Generative Al Terms

Grok Terms
ro
Terms Enterprise
Grog Terms
Mistral Terms
Perplexity Terms
P Terms
oe
T Subscriber Terms
Qwen Terms

Included AI Chat Services

Privacy Policy Other
Site

Privacy Policy ) )
Responsible Disclosure

Site

FAQ

Privacy Policy ,
Content Policy

Data deletion

Privacy Policy

Privacy Policy Site
FAQ
Privacy Policy Data deletion

See note below

Privacy Policy Google Labs Site

Site

Privacy Policy o
More legal policies

Privacy Policy Site
Privacy Policy Site
Privacy Policy

Privacy Policy Usage Guidelines

Privacy Policy Github

Google Gemini

This first time you login to Google Gemini it may warn you that your browser is not supported. This is because Curio uses an

embedded Web View - it’s not Google Chrome or Safari. You can click Try Again and Google will allow you to continue the login

process.

Sign In With Apple/Google

Several services support sign-in with via the site’s Continue with Apple or Continue with Google buttons and that should work

without issue from within Sleuth.

Sign In Via Email

Some services have an unusual sign-in process where, instead of the typical username and password login, you enter an email

address and they email you a magic login link.

The problem is clicking the emailed login link will open it in your default browser, not Sleuth.
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https://claude.ai
https://www.anthropic.com/terms
https://www.anthropic.com/privacy
https://www.anthropic.com
https://www.anthropic.com/responsible-disclosure-policy
https://chat.openai.com
https://openai.com/api/policies/terms/
https://openai.com/privacy/
https://www.openai.com
https://help.openai.com/en/articles/6783457-what-is-chatgpt
https://labs.openai.com/policies/content-policy
https://help.openai.com/en/articles/6378407-how-can-i-delete-my-account
https://copilot.microsoft.com
https://www.bing.com/new/termsofuse
https://privacy.microsoft.com/en-us/privacystatement
https://chat.deepseek.com
https://cdn.deepseek.com/policies/en-US/deepseek-terms-of-use.html
https://cdn.deepseek.com/policies/en-US/deepseek-privacy-policy.html
https://www.deepseek.com
https://gemini.google.com
https://policies.google.com/terms
https://policies.google.com/terms/generative-ai
https://policies.google.com/privacy
https://gemini.google.com/faq
https://support.google.com/gemini?p=faq_manage_activity
https://aitestkitchen.withgoogle.com/tools/image-fx
https://policies.google.com/terms
https://policies.google.com/terms/generative-ai
https://policies.google.com/privacy
https://labs.google
https://grok.com
https://x.ai/legal/terms-of-service
https://x.ai/legal/terms-of-service-enterprise
https://x.ai/legal/privacy-policy
https://x.ai/legal
https://x.ai/legal
https://groq.com
https://groq.com/terms-of-use/
https://groq.com/privacy-policy/
https://groq.com
https://chat.mistral.ai
https://mistral.ai/terms
https://mistral.ai/terms#privacy-policy
https://mistral.ai
https://www.perplexity.ai
https://www.perplexity.ai/tos
https://www.perplexity.ai/privacy
https://poe.com
https://poe.com/tos
https://poe.com/subscriber_tos
https://poe.com/privacy
https://poe.com/usage_guidelines
https://chat.qwen.ai
https://chat.qwen.ai/legal-agreement/terms-of-service
https://chat.qwen.ai/legal-agreement/privacy-policy
https://qwenlm.github.io

Local LLM Services

So, once you receive that email, use the following trick to validate your login within Sleuth:

1. In the email you will find a Sign In or similar button. Clicking that button would open it in the browser, which doesn’t help
Sleuth, so instead right-click on it and choose Copy Link.

2. Go back to the Sleuth window and in the bottom-left corner replace the displayed link URL with the link URL from your
clipboard then press Return.

3. You should now be signed in and validated for both Sleuth and the Sleuth shelf. Your login will be valid on subsequent re-
launches of Curio as they’ll reuse your stored credentials.

Sign In Via Passkeys

Unfortunately passkeys aren’t supported in web views (an Apple WKWebView limitation), so you have to use a password to gain
access to any service. Lots of developers are hoping Apple adds support for passkeys to web views one day soon.

Local LLM Services

It’'s now possible to run a local LLM service thanks to Apple’s latest blazingly fast Apple Silicon chips, numerous open source LLM
models, and an every-growing field of local LLM app servers.

After finding and configuring your selected service, it can be enabled within Sleuth by setting two specific advanced settings:

1. Specify the action URL for the service.
defaults write com.zengobi.curio "Local LLM URL" -string "http://localhost:11434"

2. Optionally specify the name of the service. If not set then “Local LLM” will be used as the name.
defaults write com.zengobi.curio "Local LLM Name" -string "Pico Al Homelab"

Then relaunch Curio and your Sleuth and Sleuth shelf’s Al section will include an item at the top with your local LLM.

Chat Interface Required

Some local LLM apps, like Pico Al Homelab, include a built-in web server that Curio and even your Safari or Chrome browser can
use to support chatting with a local LLM. Pico Al can also easily install LLM models to your machine with a point and click interface.
This setup allows you to use Sleuth or your browser to chat with any local LLM model in a way similar to how you might use

chatgpt.com.

If you hear of any other great apps similar to Pico Al please |et us know.

OpenAl API Interface

But other more advanced apps, like the very popular LM Studio and Ollama products, currently only have an OpenAl-compatible

APl interface (that is, a /vi/chat/completions endpoint), not a browser-friendly chat interface. Those apps only accept raw API
programmatic queries, so Curio’s Sleuth and your browser can’t connect to them.

If you want to use one of those advanced services you would need to also install a helper service which provides a web interface to
the underlying LLM service. The most popular product of this type is probably Open WebUI.

This is a very dynamic and active field of development so searching for “local IIm web ui” might be the best way to find the latest
and greatest solutions. And it could be that LM Studio and Ollama integrate a web interface as they continue development.
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Bundled Prompts

On a related note, Apple’s MLX team recently suggested this setup if you’d like to use their mix-1m python-based server with Open
WebUI.

Bundled Prompts

When using an Al chat service, the Sleuth window may reveal a small button with a keyboard icon image. When clicked, a popup
menu with several bundled prompts are included that you can use for your conversations with the chatbot.

Including Selected Text

If you hold the = key when choosing some of the prompts, the selected text from your Curio idea space will be included in the
prompt. This makes it handy to, for example, rewrite a selected figure’s text so it sounds more formal. If editing a text figure or an
Organizer text document, or annotating a PDF figure, and a range of text is selected then Curio will use that text. Else if a figure is
selected then it will use that figure’s text.

Customizing Sleuth

Sleuth comes with built-in support for a number of the most popular Internet search sites. It also supports a flexible architecture that

allows you to add additional Internet search sites to its list of supported sites.

Adding your own websites to Curio’s Sleuth tool can be as simple as drag and drop. It all depends on how search information is
sent to the site’s server.

Note that Curio from the Mac App Store does not support remote, insecure nttp Sleuth sites.

GET or POST

An HTML form uses one of two methods to send information via HTTP to the server: GET or POST. When the GET method is used,
all of the search criteria are passed to the server via the request URL. This makes it easy for Sleuth to extract the information
needed directly from the request URL and automatically create a new site.

When the POST method is used, most of the search criteria are passed to the server in the body of the HTTP request. In this
situation, Sleuth is unable to extract the necessary information from the resulting request URL to automatically create a new site.
However, if you’re familiar with HTML and you have access to the HTML code for the search form you want to add to Sleuth, you
can easily create a new site manually.

Add a New Search Site Based on the GET Method

1. In Sleuth’s main window, click on the Customize button (the one with the pencil icon) to switch over to the Sleuth
configuration view.

2. Choose a collection from the list located along the left side of the window.

3. In a web browser of your choosing, go to the desired website’s search page and execute a search for the word “Fish”.
Searching for the word “fish” will allow you to skip step 5.

4. After the search results are returned, drag the resulting URL from your web browser’s address field and drop it into the list of
sites on the right side of the Sleuth window. You can position exactly where you’d like the new site to appear in the list.
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Sleuth Download Support

5. If Sleuth cannot automatically determine your search phrase, a dialog will appear asking you to select which word or phrase
for which you searched. Select the word from the popup menu and click Choose. If your search phrase does not appear in
the list, click None of the Above.

6. The site information form will be displayed with the information Sleuth was able to extract. Type the name you want to give
this site in the Name field.

7. Click Save.

Add a New Search Site Based on the POST Method

1. In Sleuth’s main window, click on the Customize button (the one with the pencil icon) to switch over to the Sleuth
configuration view.

2. Choose a collection from the list located along the left side of the window.

3. Click the “+” button located under the list of sites on the right side of the window to add a new site.

4. In the site information dialog, type a name for the site, type the action URL, select POST from the method popup menu, and
add the necessary input parameters for this search engine.

5. Click Save.

6. The value for the search phrase input parameter should always be set to “% %PHRASE% %”. Sleuth will automatically
replace this value with your search phrase when you execute a search. Take a look at how other sites are configured by
double-clicking on them in the sites list for other examples.

Delete a Custom Sleuth Site

* You can delete the selected site by pressing the Delete key.

Adding Search Site Collections

1. In Sleuth’s main window, click on the Customize button (the one with the pencil icon) to switch over to the Sleuth
configuration view.

2. Click the “+” button located under the list of collections on the left side of the window to add a new collection.

3. Type the name for the new collection.

4. You can populate your new collection by creating new Sleuth sites or by dragging sites from another collection and dropping
them onto your new collection.

5. You can delete the selected collection by pressing the Delete key.

Enabling and Disabling Search Sites and Collections

« Click the checkbox next to the item in the list.

Sleuth Download Support

Sleuth and Sleuth shelf support downloading files in these scenarios:

1. A clicked on link is using an HTML anchor download attribute which indicates the link URL should be downloaded and not
displayed in the browser which is handy for images.

2. A clicked on link has a file extension that could be displayed in the browser but it’s in our special extensions list so we’ll
download it. This list includes pdf,csv,md,zip and can be customized with the Sleuth Download Extensions setting.

3. The clicked on link can’t be displayed in the browser so will trigger a download automatically.
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KidSafe Sleuth

Oddly, the right-click Download Linked File and Download Image menu items don’t initiate a download for whatever reason. They
don’t even trigger a breakpoint in Curio’s code.

As a note, ChatGPT can sometimes offer a link to download a generated output file. However, these links appear to be problematic
even within Safari or Chrome and don’t appear to work in Sleuth, either.

KidSafe Sleuth

Curio’s amazing Sleuth internet research assistant is a quick and easy way to find images, videos, definitions, and other information

on the internet. Since Sleuth can configured to search specific sites and the user simply enters the search phrase, it’s a wonderful

way to restrict access to what a child can see.

Curio has a hidden option which will allow even more restrictive access via a KidSafe setting, which is perfect for school and home

environments.
These restrictions include:

+ Only show KidSafe sites in its sites popup, such as Google Images with SafeSearch instead the normal Google Images.
+ Disallow Sleuth site customization.

* Block any query phrase which contains profanity.

+ Block any query results which contain profanity.

To Enable KidSafe Sleuth

1. Make sure Curio is not running then launch Applications > Utilities > Terminal and type the following and press Return:
defaults write com.zengobi.curio “Sleuth Is KidSafe” -bool yes
2. Or you can just click on this and relaunch.
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Scribbles

Scribbles

The tools palette includes a brush and eraser tool so you can sketch out an idea or drawing.

Inevitably, while brainstorming or thinking through an idea, you may need to sketch something out when the keyboard just won’t do.
Fortunately, Curio has a scribble mode with sketching tools built right in, so you don’t have to stop and launch another application
when inspiration strikes.

Curio comes with several pens and brushes to use when drawing, including a pencil, ballpoint, felt tip, paint brush, and highlighter.
Each stylus has different settings for color, line thickness, and opacity that have been configured to mimic the real world object that
it represents. Using the inspector you can change the color, brush thickness, and opacity of any stylus.

The Scribble “Onionskin”

While sketching, your scribbles will appear on top of all other figures and items on the idea space. The scribble layer acts as an
onionskin appearing on top of your idea space’s figures.

Note
If you have Curio Pro this means your scribbles appear top of all your figure layers. Curio doesn’t currently support a scribbles
per figure layer as the current architecture would make this far too memory intensive.

Keyboard Shortcuts

You can press the B key on your keyboard to quickly choose the brush tool. Press E to choose the eraser.

Apple Pencil

Many of the styluses are also fully pressure-sensitive when used with an iPad with Apple Pencil connected via the macOS Sidecar
feature, or a graphics tablet such as those made by Wacom, whereby the brush size and color saturation may change while you are
drawing based on the pressure applied to the pen.

Curio also supports iPad sketching via Luna and Duet although you need to set a different pressure sensitivity multiplier. And if you

use an XP-Pen tablet then you may need to tweak this setting.

Draw with a Pen or Brush

1. Click on the Brush tool in the toolbar and choose the brush or pen you want to use. Note for super-responsive mouse
handling the idea space will temporarily go into Quick Render mode where shadows are hidden and text rendering is
optimized.

2. You can quickly choose a color from the narrow color palette in the inspector bar or the much larger color palette in the
inspector shelf. On the far left of the inspector bar’s color palette, or at the top of the inspector shelf’s palette, you can see
the current, active color. If you click that color control then you can bring up Apple’s standard color picker to choose any
color.

3. Begin drawing in the idea space. While in scribble mode, you can continue to change the brush attributes or choose a
different brush or pen from the inspector bar.

Erase a Portion of Your Drawing

1. Click on the Eraser tool in the toolbar or inspector bar and “draw” where you want to erase. You can even change the size of
the eraser using the inspector.
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Scribble Inspector

2. Alternatively, you can use the Select tool in the toolbar to drag-select a region then press the Delete key to delete it. You can
hold down the ~- and & keys while dragging to select only your scribble and not any figures or other items on the idea
space.

3. Lastly, if you are using a graphics tablet that has a pen with an eraser tip, you can simply turn the pen over to erase a portion
of your drawing.

Convert a Scribble to an Image Figure

1. Using the Select tool in the toolbar drag-select a region. You can hold down the ~\- and % keys while dragging to select only
your scribble and not any figures or other items on the idea space.

2. Choose Edit > Convert Selection to Image Figure.

3. You now have an image figure that you can treat as a normal figure on the idea space: give it a border, move it above or
below other figures, or even add it to a list or mind map.

Convert a Figure to a Scribble

1. Using the select tool in the toolbar (looks like a mouse arrow pointer) select one or more figures.
2. Choose Edit > Convert Selection to Scribble.
3. You can now use the scribble layer’s pens, brushes, and eraser to modify the figure.

Scribble Inspector

When in scribble mode the inspector bar and inspector shelf changes to reveal handy controls for working with the pens and

brushes.

Brush Palette

Click a brush to activate it. Each brush’s color and inspector settings are independent from each other.

Brush Color

Displays the current brush color. Click to bring up the standard Mac Colors picker.

Color Palette

The scribble inspector displays the full, large-sized 13x10 matrix displaying 10 shades each of grays and colors. The inspector bar
shows a more compact strip with only 5 shades each of grays and colors.

Brush Size, Opacity, and Pressure Sensitivity

Set the size and opacity of the currently selected brush.

Tip
You can change the brush size on-the-fly with the [ and ] keys on your keyboard.

If you’re using a pen-based graphics tablet, like a Wacom tablet or an iPad with Apple Pencil connected via the macOS Sidecar
feature, then the brush size and color can be pressure-sensitive if those toggles are enabled. In that case the specified brush size
and opacity is the maximum size given a maximum amount of pressure.
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Scribble Inspector

Click the Reset Brush to reset the selected brush to its factory defaults.

Restrictions

You can choose whether the scribble on an idea space is printed, exported, or presented.
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Journal

Curio includes an integrated journalling feature. Curio’s project journal feature allows you to log meetings, make class notes, keep a
journal or diary, and much more! All neatly organized, sorted, and managed by Curio with automatic year and month groupings.

Automatic Year/Month Folders and Sorting

Your Journal section is automatically sorted and arranged by Curio, with year and month folders added or removed as necessary for
your entries. Years are displayed in descending order (2021, 2020, 2019), months within each year are in ascending order (January,

February), and entries within each month are in ascending order as well (May 1, May 2, May 3).

Viewing the Journal

1. To begin, either select the Journal section at the top of the Organizer if already visible, or click and hold on the Organizer
sidebar toolbar button and choose the Show Journal Section item in the menu that appears.

2. Your project’s Journal section appears under your normal sections but above the Archive and Trash sections.

3. You can only have a single Journal section per project.

Adding New Journal Entries

1. With Journal mode active, click the Add button to create a new journal entry. Bundled, personal, and master journal
templates are automatically listed within the Add button’s popup or you can choose from the gallery or a blank idea space.

2. Your new journal entry will default to today. You can use the date chooser in the inspector bar to change the journal entry to
a different date.

3. Within the Journal Organizer, Curio automatically creates and titles the encapsulating year and month folders, and the idea

space entries.

Changing Entry Dates

* To change the date associated with a Journal entry, use the date chooser in the inspector bar.

Working with the Journal Section

1. You can rename your Journal section if you’d like, perhaps calling it Class Notes, Lab Observations, or Meetings if that
makes more sense for your project.

2. You can associate a color label via the right-click context menu.

3. You are allowed to delete the Journal section, unlike the special Archive and Trash sections. Select the Journal section and
press the Delete key to delete it.

4. You can also rearrange the Journal section among your other sections, although it can’t be a child under another section nor
can another section be a child of it, and like other sections it has to stay above the Archive and Trash.

5. You can’t rearrange the idea space entries within the Journal section, since they are automatically sorted by the entry date.
Instead, if you'd like to change the date associated with a Journal entry, use the date chooser in the inspector bar.

6. You can drag journal idea space entries and folders from the Journal of one project to the Journal of another, but you can’t
drag the actual Journal section from one project to another.

Journal Entry Titles

1. You can change the date format for Journal entries displayed in the Organizer by right-clicking and choosing a new date
format from the Journal Date Format submenu.
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Journal

. Many popular date formats are included, plus the standard short, medium, long, and full date formats from System Settings
> Language & Region > Advanced > Dates. There are also advanced options to make your own date formats as detailed via
Help > Curio Advanced Settings.

. Note if an Organizer filter is active then a different date format is used since you won’t see the encapsulating year and month
folders. For example, if the entry is normally titled “March 1” then that may not help in a collection of filter results. So, when a
filter is active a more verbose date format is displayed for the entry titles, such as “Sun, Mar 1, 2020”. You can right-click
and override that date format as well via the Journal Date Format submenu or directly then relaunch.

. You can edit an entry’s title in the Organizer by pressing Return on the item, type in a title, then press Return to stop editing.
The resulting custom title will be appended to the formatted date text.

. To remove a custom entry title, simply edit the title again and delete the title text. When you press Return to end editing the

entry’s title will revert back to only the formatted date.

Journal Entry Sorting

+ You can now change the Journal year sorting and, separately, the sorting of the months within each year via the right-click

context menu.

Saving Custom Journal Templates

1.

To create your own journal templates, go into Journal mode, select an existing journal idea space entry that you’d like to
save as a template, then right-click and choose Save As Idea Space Template.

2. Like normal templates, it can be stored as a personal and/or a master template (the latter only if you’re on Curio

Professional).

3. A “Journal” template gallery collection will be created automatically for the new template, if necessary, to help keep them

organized in the idea space gallery. All personal and master journal templates in their respective “dournal” collections will

appear directly in the Add button popup for quick access.

4. As a tip, you may want to use a variable such as IdeaSpaceDateAddedFull instead of IdeaSpaceTitle for your headings

within your journal entry idea spaces if you’d like a specific date format there, instead of one tied to the Organizer’s setting.

Go To Today

Clicking on the Journal’s Go to Today inspector bar button will go to today’s journal entry if it exists, and, if it doesn’t exist, can

create a new entry if a default journal style is set as described below.

Default Journal Idea Space

Just like you can specify a default idea space style or template for your project, you can also use the same technique to specify a

default idea space for your Journal section either just for this project or for all projects.

1. Click on the Journal section to make it active in the Organizer.
2. Reveal the Idea Space Gallery via the Add toolbar button or Organizer > New Idea Space From Gallery menu item.
3. In the gallery, right-click a template or style and choose Set as Default Journal Entry to set it as the new default idea space

Once

style or template for this project’s Journal. You can also specify if this should be the the global default for the Journal
sections in all projects.

set, a special item is added at the top of the Add popover and the Organizer’s right-click context menu, allowing you to

quickly add a default Journal entry idea space to your Organizer. Also simply clicking on the Journal’s Go to Today inspector bar

button will go to today and create a new entry with the default style.
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Masters

In Curio you’ve been able to create your own reusable figure styles & stencils and idea space styles & templates. You can save
these in your personal repository and use them across all of your projects.

You are able to update a style and re-save it to your personal repository. You can then use the updated style with new figures and
apply it to existing figures. Likewise you can update a saved personal stencil or template and then create new instances which will
reflect those changes.

However, existing figures or idea spaces that used one of those personal styles, stencils, or templates aren’t spontaneously updated
throughout all of your projects, as that could get quite messy.

Master Styles, Stencils, and Templates

This changes in Curio Professional with master styles, stencils, and templates. These are private to a specific project which means
Curio can support dynamic updates across all the idea spaces in that project.

Create a “Heading” master figure style, use it across your project. Later change the style to a larger point size and color and the
style change is instantly reflected across all uses of the figure style.

Create a master figure stencil for an web site interface prototype and use it throughout a project, then later update that stencil with a
different fill color and font choices and instantly the change is reflected across the project.

Lastly, create a master idea space template with headings, subheading, and positioned body text. Use it as a basis for dozens of
idea spaces in your project. Later, change the master with additional elements, changed fonts, or repositioned figures, and the
changes is reflected across your project.

Master Styles

A master style is one that is private to your project and, if the master style is updated, then those changes are immediately

broadcast and applied to all idea spaces or figures that adopt that style. A master style can be created from scratch or from an
existing style found in a personal, bundled, or external repository.

If you’re familiar with Pages, Word, or even css then master styles are similar to the style support you see in those apps, where you
can change a style, say for “Heading 1”, and throughout your document all “Heading 1” text items are updated to reflect the new
style.

Note that a style only defines the look of the idea space or figure. It doesn’t include any boilerplate text or images.

Sample Workflow

1. Create a text figure that you’ll use for a heading on an idea space and use the inspector to style it the way you wish with
appropriate colorings, fonts, etc.

2. Right-click on the figure and save the style as a master style named “Heading”.

3. Use the “Heading” style with other text figure instances scattered on idea spaces throughout your project.
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Using the Style Inspector Shelf

4. If you want to change its look, click on an instance, change any properties you wish using the inspector such as font size
and text color, then click the Update button in the Styles inspector. Or, if you wish, you can right-click on the instance and
choose update style from its context menu. You could also choose to reapply the style if you didn’t mean to change its look.

Instantly the style change is broadcast and applied to all figures that adopted that style.

Video
Watch a master figure style demonstration video on our YouTube channel.

Using the Style Inspector Shelf

The Style inspector now includes a Masters option in the repository popup so you can see the styles available in that pseudo-

repository.

Other style inspector shelf changes related to masters include: - Copy to Masters

Right-click on a style that isn’t a master style and choose to Copy to Master to copy the style into a master style and then associate
the selected idea space or figure with that new style. - Delete / Mail

Right-click on a master style to delete it, or mail it to a friend or Zengobi. - Update

A new Update button allows you to instantly update a changed a master or even a personal style with changes. Note that this
performs the same action as right-clicking on the figure or idea space background and choosing Update Style.

Using the Galleries

Within the various idea space and figure galleries you’ll find a new Masters pseudo-repository there which contains all applicable

master styles (and stencils/templates).
Other gallery changes related to masters include:

» Copy to Masters
Right-click on an idea space template, figure stencil, or style that’s not in the Masters repository and choose Copy to
Masters.

* Drag and Drop
Drag-and-drop an idea space template, figure stencil, or style from another repository into the Masters repository folder to
make a copy. You can also drag from Masters to Personal if you wish.

* Delete
Right-click on an idea space template, figure stencil, or style in Masters repository and choose Delete. You may also simply
press the Delete key. Existing instances of a template or stencil will remain as-is.

« Edit
Right-click on a master idea space template or stencil and choose Edit Template / Edit Stencil to switch the Organizer to
masters, select the appropriate master item, and display the template or stencil in the main viewing area for editing. Click the
Done Editing Masters button at the bottom of the masters Organizer to end editing.
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Using Master Styles

Using Master Styles

Create a Master Style

1. Right-click on an idea space in the Organizer, the idea space’s background, or on a figure within an idea space and choose
Save as Style.

2. In the dialog that appears choose whether to create a personal style, a master style, or both a personal and a master style.
Choosing both will allow you to use the style as a master in this project, but also places it into your personal repository so
you can use it in other projects.

Updating a Master Style

1. Make changes to the appearance of your idea space or figure.
2. Right-click on the idea space or figure and choose Update Style or click the Update button on the Style panel in the
inspector shelf.

Reverting or Reapplying an Original Master Style

« If you make changes to an idea space or figure and want to reapply the original master styling for that object then right-click
and choose Reapply Style.

Deleting a Master Style

+ In the Style panel of the inspector shelf, right-click on the style and choose Delete Style.

Sharing a Master Style

« In the Style panel of the inspector shelf, right-click on the style and choose Send to Friend or choose Send to Zengobi if
you’d like to share your style with other Curio customers.

Copying a Master Style into Your Personal Repository

1. If you create a master style that you’d like to use in other projects then you need to copy it into your personal repository.
2. In the Style panel of the inspector shelf, right-click on the style and choose Copy to Personal.

Master Figure Stencils

A master stencil is one that is private to your project and, if the master stencil is updated, then those changes are immediately

broadcast and applied to instances of the stencil.

If you’re familiar with the app Sketch then master stencils are similar to that app’s symbol support, where you can change a symbol,
say for an elaborate Ul component, and throughout your document all instances of that component are updated to reflect the new
changes.

Note that while a style only defines the look of a figure, a stencil can be made up of several figures and include text and images, as
while as the style information associated with each item. When you use a stencil then you are essentially creating and using an
exact copy of the original figure stencil.
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Sample Workflow

1. Create a text figure that you’ll use as a note figure with a special flag adornment, coloring, font, freeform size, and
placeholder text.

2. Right-click on the figure and save the stencil as a master stencil named “Note”.

3. Using the Stencils shelf or the Insert > Styled Shape or Stencil gallery, insert that Note stencil onto idea spaces throughout
your project.

4. Edit the stencil either by right-clicking on an instance of the stencil on the idea space, or on the stencil itself in the Stencils
shelf or insert gallery, or by finding the stencil in the new Masters Organizer, discussed below.

5. Change the look and contents of the stencil then click Done Editing Masters button at the bottom of the masters Organizer
to end editing and broadcast the changes throughout the project to any instances.

Instantly the changes to the stencil are broadcast throughout the project to any instances.

Video
Watch a master figure stencil demonstration video on our YouTube channel.

Overrides

You can make some changes to your stencil instance and they won’t be replaced when you change the master.

* Figure Position
Changes made to the positions of individual figures within a complex master stencil are not broadcast to instances.

* Figure Size
Changes made to the size of a master stencil are broadcast and applied to instances, unless you manually change the size
of an instance. This is handy if you need to change the size of an instance to accommodate more text, for example.

* Figure Text
Changes made to the text contents of figures on the master stencil are broadcast to instances, unless you manually change
the text of an instance.

* Figure Style
Changes made to the style of figures on the master stencil are broadcast to instances, unless you manually change the style
of an instance including font and font size.

Limitations

While figure stencils are quite powerful they do have some limitations:

» Meta data such as tags, resources, dates, percent complete, priority, rating, notes, etc., are not propagated to instances as
merging and conflicts would be difficult to resolve.
* If you delete a figure from a complex master stencil then instances are removed elsewhere in the project. However, if top-
level figures are added to the master then those new figures do not suddenly appear elsewhere in the project.
> Key Exception: If you delete a figure within a grouped figure then that change is reflected elsewhere.
* Newly added or removed items found within collection figure stencils, such as nodes within a mind map, will not be
broadcast to instances.
> Key Exception: If you add a figure within a grouped figure then that change is reflected elsewhere.
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Using the Masters Organizer

Using the Masters Organizer

Click and hold on the Organizer sidebar toolbar button and choose the Show Masters item in the menu that appears. Alternatively
you can also Shift-click the Organizer sidebar toolbar button to instantly show masters. The sidebar toolbar button will change itself
to a highlighted broadcast symbol, which is the symbol Curio uses for masters as changes to masters are broadcast throughout
your project.

The Organizer itself will change to show your project’s master idea space templates. Its background coloring is blue to emphasize
that you are now in a new mode and this isn’t your normal Organizer. Use the tabbed button pair at the bottom to choose between
master idea space templates and master figure stencils.

In general working in the Masters Organizer is similar to the normal Organizer, but here are some notes:

» Master templates and stencils can be rearranged, renamed, and deleted, but they cannot be indented or color-coded.
* Right-click to copy, paste, duplicate, rename, or delete a selected item.

We you are finished making changes to your master templates and stencils you can end editing by either:

1. Clicking the Done Editing Masters button at the bottom of the masters Organizer, or
2. Clicking the highlighted masters icon in the toolbar.

The Organizer toolbar button will change itself back to the standard sidebar icon and the Organizer will be restored to its previous
state.

Using the Stencils Shelf

The Masters option also appears in the Stencils shelf so you can see the stencils available in that pseudo-repository.
Other style inspector shelf changes related to masters include:

» Copy to Masters
Right-click on a stencil that’s not in the Masters repository and choose Copy to Master Stencils.

Using the Galleries

When you click the Insert toolbar button and go into the various figure galleries, you’ll find a Masters pseudo-repository there which
contains all master styles and stencils. Select a master stencil and click the Insert button to insert a new instance of that master into
your idea space. If you later update the stencil then this instance will be updated as well.
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Using Master Stencils

Other gallery changes related to masters include:

» Copy to Masters
Right-click on an idea space template, figure stencil, or style that’s not in the Masters repository and choose Copy to
Masters.

* Drag and Drop
Drag-and-drop an idea space template, figure stencil, or style from another repository into the Masters repository folder to
make a copy. You can also drag from Masters to Personal if you wish.

* Delete
Right-click on an idea space template, figure stencil, or style in Masters repository and choose Delete. You may also simply
press the Delete key. Existing instances of a template or stencil will remain as-is.

* Edit
Right-click on a master idea space template or stencil and choose Edit Template / Edit Stencil to switch the Organizer to
masters, select the appropriate master item, and display the template or stencil in the main viewing area for editing. Click the
Done Editing Masters button at the bottom of the masters Organizer to end editing.

Using Master Stencils

Create a Master Stencil

1. Right-click on a figure within an idea space and choose Save as Figure Stencil.

2. In the dialog that appears choose whether to create a personal stencil, a master stencil, or both a personal and a master
stencil. Choosing both will allow you to use the stencil as a master in this project, but also places it into your personal
repository so you can use it in other projects.

Editing a Master Stencil

1. Right-click on an instance of the stencil on the idea space and choose Edit, or...

2. Right-click on the master stencil itself in the Stencils shelf and choose Edit, or...

3. Click and hold on the Organizer sidebar toolbar button and choose the Show Masters item in the menu that appears, then
find and edit the stencil manually.

4. The Organizer will switch to the Masters Organizer and you will then edit your stencil within an idea space view. Once you
are done, click the Done Editing Masters button at the bottom of the masters Organizer to end editing and broadcast the
changes throughout the project to any instances.

Deleting a Master Stencil

« In the stencil gallery or shelf, right-click on the stencil and choose Delete Stencil.

Sharing a Master Stencil

+ In the stencil gallery or shelf, right-click on the stencil and choose Send to Friend or choose Send to Zengobi if you’d like to

share your stencil with other Curio customers.

Copying a Master Stencil into Your Personal Repository

1. If you create a master stencil that you’d like to use in other projects then you need to copy it into your personal repository.
2. In the stencil gallery or shelf, right-click on the style and choose Copy to Personal.
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Master Idea Space Templates

Master Idea Space Templates

A master idea space template is one that is private to your project and, if the master template is updated, then those changes are

immediately broadcast and applied to instances of the template.

If you’re familiar with Keynote or PowerPoint then master idea space templates are similar to the master slide feature in those apps,
where you can change a particular master slide and throughout your presentation all slides based on that master are updated to
reflect the new changes.

Note that while a style only defines the look of an idea space, an idea space template includes style information and any figures
located on the idea space. When you use a template then you are essentially creating and using an exact copy of the original idea
space template.

Sample Workflow

1. Create an idea space with an appearance and containing the boilerplate figures you would like to use repeatedly throughout
your project.

2. Right-click on the idea space in the Organizer and choose “convert to master” to instantly save the idea space as a master
template and then automatically convert the selected idea space into an instance of that master. Alternatively you can do the
same thing via the “save as template” option from the context menu to show the standard save template dialog.

3. Note that the icon for idea space instance now has a little master-broadcast icon so you know it inherits changes from a
master template.

4. Add new figures to this idea space instance, as you would work with a normal idea space.

5. When you want to create another instance simply click the Add toolbar button and choose the master from the pick list
where all masters are listed at the bottom with the little masters icon, or drill down in the idea space gallery and choose it
from the masters repository.

6. To edit an idea space’s master template, you can

> Hold Option and double-click the idea space in the Organizer to zip right to it, or

o Right-click on the Organizer item and choose “edit master”, or

o Click and hold on the Organizer sidebar toolbar button and choose the Show Masters item in the menu that appears,
then find the master to edit it.

7. Change the look and contents of the master idea space template then click Done Editing Masters button at the bottom of the
masters Organizer to end editing and broadcast the changes throughout the project to any instances.

Instantly the changes to the template are broadcast throughout the project to any instances, which could include other master
templates that are based on this master template.

Video @
Watch a master idea space template demonstration video on our YouTube channel.
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https://youtu.be/SK0n34NlX3U

Overrides

Overrides

You can make some changes to your idea space instance and they won’t be replaced when you change the master.

+ ldea Space Dimensions
Changes made to the dimensions of a master idea space are broadcast and applied to instances, unless you manually
change the dimensions of an instance. Note that width and height are tracked separately so you can grow the idea space
instance vertically and still inherit the width from the master, for example.

* Figure Position
Changes made to the positions of figures on the idea space master are broadcast and applied to instances, unless you
manually change the size of an instance. This is handy if you need to change the size of an instance to accommodate more
text, for example.

* Figure Size
Changes made to the size of figures on the idea space master are broadcast and applied to instances, unless you manually
change the size of an instance. This is handy if you need to change the size of an instance to accommodate more text, for
example.

* Figure Text
Changes made to the text contents of figures on the idea space master are broadcast to instances, unless you manually
change the text of an instance.

* Figure Style
Changes made to the style of figures on the idea space master are broadcast to instances, unless you manually change the
style of an instance including font and font size.

Limitations

While master idea space templates are quite powerful they do have some limitations:

» Newly added or removed items found within collection figures, such as nodes within a mind map, will not be broadcast to

instances.

Warning

While working on a master template it is very important to remember if you delete a top-level figure, or move a top-level figure
into a collection, then when you commit the changes those figures that have not been edited will be deleted from all idea
spaces that inherit from the master. If the inherited figure has been edited then it will remain on the idea space, even if the figure
on the master was deleted, in order to prevent accidental deletion of important data.

Using the Masters Organizer

Click and hold on the Organizer sidebar toolbar button and choose the Show Masters item in the menu that appears. The sidebar
toolbar button will change itself to a highlighted broadcast symbol, which is the symbol Curio uses for masters as changes to
masters are broadcast throughout your project.

The Organizer itself will change to show your project’s master idea space templates. Its background coloring is blue to emphasize
that you are now in a new mode and this isn’t your normal Organizer. Use the tabbed button pair at the bottom to choose between

master idea space templates and master figure stencils.

- 296/423 - Copyright © 2025 Zengobi, Inc.




Adding a Master Template Instance

In general working in the Masters Organizer is similar to the normal Organizer, but here are some notes:

» Master templates and stencils can be rearranged, renamed, and deleted, but they cannot be indented or color-coded.
* Right-click to copy, paste, duplicate, rename, or delete a selected item.

We you are finished making changes to your master templates and stencils you can end editing by either:

1. Clicking the Done Editing Masters button at the bottom of the masters Organizer, or
2. Clicking the highlighted masters icon in the toolbar.

The Organizer toolbar button will change itself back to the standard sidebar icon and the Organizer will be restored to its previous
state.

Adding a Master Template Instance

To add an instance of a master template to your project, click the Add toolbar button you’ll notice that any master templates are
listed at the very bottom of the popup, with the masters “broadcast” symbol on the right side. Choose one and a new idea space
instance of that master template will be added to your project.

Notice when you use a master template to create an idea space, the preview image for the new idea space in the Organizer will
show a little masters broadcast symbol in its lower-right corner. This way you know it’s based on a master template.

Nested Masters
You can create a master template which is itself based on a master template.
Switch over to the Masters Organizer, then create a new master based on an existing master using the Add toolbar button. That new

master will inherit changes made to its “parent” master. You can continue this process so that changes to Master A go to Master B
go to Master C go to...

This might be useful if you define a “Background” idea space master then create duplicates that define “Chapter” and “Slide”
masters. Change the background of Background and instantly all masters change and thus all instances of all of those masters
change.

Using the Galleries

When you click the Add toolbar button and go into the idea space gallery, you’ll find a Masters pseudo-repository there which
contains all master idea space styles and templates. Select a master template and click the Choose button to add a new instance of
the master to your project. If you later update the master template then this instance will be updated as well.
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Tagged Sets of Master Idea Space Templates

Other gallery changes related to masters include:

» Copy to Masters
Right-click on an idea space template, figure stencil, or style that’s not in the Masters repository and choose Copy to
Masters.

* Drag and Drop
Drag-and-drop an idea space template, figure stencil, or style from another repository into the Masters repository folder to
make a copy. You can also drag from Masters to Personal if you wish.

* Delete
Right-click on an idea space template, figure stencil, or style in Masters repository and choose Delete. You may also simply
press the Delete key. Existing instances of a template or stencil will remain as-is.

* Edit
Right-click on a master idea space template or stencil and choose Edit Template / Edit Stencil to switch the Organizer to
masters, select the appropriate master item, and display the template or stencil in the main viewing area for editing. Click the
Done Editing Masters button at the bottom of the masters Organizer to end editing.

Tagged Sets of Master Idea Space Templates

If you create a whole series of master idea spaces for a project and want to re-use them it’s super easy! Just select all the master
idea spaces in the Masters Organizer, right-click and choose to save them to a named tagged set in your personal repository, such
as “Portfolio”. You can choose an existing tag or enter a new name.

Later when you want to use that set, simply choose File > New, select the name of your personal tag set, “Portfolio” in this case,
and click the Use Tagged Set as Masters button. A new project will be created with all the idea spaces in that tagged set preloaded
as master idea space templates.

Master Styles via Master Templates

Say you define that “Heading” master figure style then you apply it to figures on several master idea space templates. Change the
master style and then all master templates update and thus all instances of those master templates update.

Next, say you save your master idea space as a personal idea space template (or perhaps as a tagged set in your personal
repository) then you use that template in another project. If that template becomes a master template then any master styles
embedded within the template will be automatically recovered and available as master styles in the new project.

Note this only happens if the idea space template becomes a master again, simply inserting an instance of the personal template
into your Organizer won'’t recover the master styles. You could do this via tagged sets, described above, or the convert to master
idea space template right-click option in the Organizer.

Using Master Templates

Create a Master Template

1. Right-click on an idea space and choose Save as Master Template, or...
2. In the Masters Organizer, you can create a new master template using the Add toolbar button. With this technique you can
create a master template based on another master template, thus nesting the templates. Changing a “parent” master will
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Using Master Templates

reflect those changes down the line to other masters (recursively), and then refresh all impacted idea spaces that use those
masters.

3. In the Masters Organizer, you can duplicate an existing master template via the Edit > Duplicate menu item. The result is
another master which is an exact copy of the original master.

Editing a Master Template

1. Hold Option and double-click the idea space instance in the Organizer, or...

2. Right-click on the idea space instance in the Organizer and choose Edit, or...

3. Click and hold on the Organizer sidebar toolbar button and choose the Show Masters item in the menu that appears, then
find and edit the template manually.

4. The Organizer will switch to the Masters Organizer where you can edit your master idea space template.

5. Once you are done, simply click the Done Editing Masters button at the bottom of the masters Organizer to end editing to
save and broadcast the changes throughout the project to any instances.

Deleting a Master Template

1. Click and hold on the Organizer sidebar toolbar button and choose the Show Masters item in the menu that appears.
2. Select the master template you wish to delete and press the Delete key. Note that all uses of this master will still remain
intact in your project.

Sharing a Master Template

+ In the add idea space gallery, right-click on the template and choose Send to Friend or choose Send to Zengobi if you’d like
to share your template with other Curio customers.

Copying a Master Template into Your Personal Repository

1. If you create a master template that you’d like to use in other projects then you need to copy it into your personal repository.
2. In the add idea space gallery, right-click on the style and choose Copy to Personal.

Disconnecting from a Master Template

* If you want to disconnect a master template instance from its master then right-click and choose Disconnect from Master.
After confirmation, the idea space will be independent and no longer receive updates from its former master template.

Assigning ldentifiers to Figures to Support Change Master

1. When editing a master template, select a figure and click the Info inspector bar button to bring up the Info inspector popover.
2. There you can enter an identifier such as title, subheading, or body.
3. Curio uses identifiers with the same names across different masters to support the Change Master functionality.

Changing to a Different Master

1. You can change an idea space so it adopts a different master either by right-clicking on the idea space in the Organizer and
choose Change to Master, or click on the new master at the top of the inspector shelf.

2. Note this list of master templates you can change to is filtered to only include other masters which support figures with
identifiers that the user has changed in the current idea space. Therefore if, in your instance, you have changed the “title”
figure then only other masters that contain a “title” figure will available. That way you can’t switch to a master that wouldn’t
support your changed figure.
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Using Master Templates

Creating a Reusable Set of Master Templates for Use in Creating New Projects

1. Click and hold on the Organizer sidebar toolbar button and choose the Show Masters item in the menu that appears.
2. Select all the masters you wish to want to include in the set.

3. Right-click and choose Save to Tagged Set.

4. Enter a new tag or choose an existing tag to add to an existing set.

Using a Tagged Set of Masters When Creating a New Project

1. Choose the File > New menu item to bring up the new project gallery.

2. On the far left, expand the list of templates available under the Personal repository.

3. Select the name of your personal tag set then click the Use Tagged Set as Masters button.

4. A new project will be created with all the idea spaces in that tagged set preloaded as master idea space templates.

Change Masters

Normally you can’t apply an idea space template to an existing idea space, since Curio wouldn’t know what to do with the existing
figures. However, this is indeed possible with master templates and a new figure identifier property.

Recall that a master template defines the style of the idea space and contains boilerplate figures. In many instances you may want
those boilerplate figures to be placeholders (perhaps with “lorem ipsum...” text) that you'll edit and fill in with real data in the
instance of the template.

For instance, you may have master templates with “title” and “body” placeholder text figures but where the figures are positioned
and styled very differently. Perhaps these templates also contain other figures unique to themselves in addition to those placeholder
items. If you create an instance of one of these masters, edit and replace all the placeholders, then realize you wish you had used a
different master, it would be nice if you can click to switch it to the stylings of the other, without having to recreate the whole thing
from scratch.

Identifier
Using the new figure Identifier field, accessible via the figure’s Info inspector, this is now possible. Curio has what it needs to map

placeholders figures from one master to another.

Edit your master templates and give the figures that represent placeholder items appropriate identifier values, such as “title” and
“body”-

Identifier Glow

When you edit an idea space that has figures with locally defined identifiers (that is, not inherited from a master) then those figures
will glow green instead of blue and their tooltips will show their identifiers. This is helpful when you want to quickly make sure
appropriate figures have set identifiers.

Change Master

Click Done to exist editing masters, then create a new instance of one of those masters.

Edit and change the placeholder text as necessary. If you decide you want to change to the different master, notice that the normal
styles area of the inspector shelf shows master templates for the idea space instead. Just click on a different master in the
inspector, or right-click on the idea space in the Organizer and choose Change Master, to instantly change to that master.
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Master Markdown Styles

Behind the scenes, Curio will style the idea space to match the new master’s style, use the identifiers to map figures from the old
master to the new master thus keeping their contents intact, remove any figures that were unique to the old master, add any figures
that are a part of the new master, and leave any figures you added on your own to the instance in place, as is.

As a note, this list of master templates you can change to is filtered to only include other masters which support figures with
identifiers that the user has changed in the current idea space. Therefore if, in your instance, you have changed the “title” figure then
only other masters that contain a “title” figure will available. That way you can’t switch to a master that wouldn’t support your
changed figure.

Master Markdown Styles

Heavy users of markdown will appreciate Curio’s support for master markdown styles.

Using a specified style file, Curio can apply styling attributes to certain markdown elements within a project.

Since Curio’s markdown is rendered within a rich text view, instead of a web view, our file format is a bit different than markdown
styles created using css. However, many of the same features are supported.

Here’s a portion of a sample master markdown style file:

body = font-family:Helvetica Neue;font-size:16;font-color:#666666;
*x = font-color:#ff0000;
*xx = font-color:#00bb00;
sxxk = font-color:#0000ff;
highlight = background-color:rgb(150, @, 255, 0.10);
# = font-family:Helvetica Neue UltraLight;font-size:32;font-color:#376098;
## = font-family:Helvetica; font-size:28;font-color:#ff@off;font-bold:1;
line-spacing:5; paragraph-spacing-after:20;
font-color:#338888; font-italic:1; first-line-head-indent:36; head-indent:36; tail-indent:-36;
" = background-color: #f1ffff; font-color: #00ff00;
" = background-color: #ffflff;

>

It’s a pretty simple text file format:

« Each element ( boday , * , # ,..., ###### , etc)is defined on its own line.
« The font attributes are a semicolon-delimited collection of key/value pairings each separated by a colon.
« Spaces before and after the =, :, and ; are ignored.

When the style file is changed, the updated style changes will be broadcast throughout your project instantly updating all text
figures which use those markdown elements.

Working with the Master Markdown Style File
Edit the Global Master Markdown Style File

Hold Option when clicking the Format menu and you will see the Format > Edit Global Master Markdown Style File menu item. This
allows you to edit the Markdown Styles.txt file in your personal repository ( ~/Library/Application Support/Curio/Version XX/

Repository folder )
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Markdown Style Common Attributes

It defines the default master markdown styles for all Curio projects. Styles defined in that file will be read first, then you can override

or add more styles with your project specific master markdown styles.

Edit a Project’s Master Markdown Style File

1. Use the Format > Edit Master Markdown Style File menu item to edit your project’s master style file in the default editor for

.txt files, such as TextEdit.

2. When you save your changes and switch back to Curio, Curio will automatically notice the updates and re-render your visible

idea spaces and queue up preview regeneration for all project idea spaces just in case they contain markdown as well.

3. If you remove the contents of the style file then the file itself will be automatically removed from the project package when

you switch back to Curio.

Import a Master Markdown Style File into a Project

« Alternatively, if you have an existing markdown style file you wish to use, choose the Format > Import Master Markdown

Style File menu item and the file will be copied into your project and then stylings applied throughout.

Markdown Style Common Attributes

Here are the attributes you can set for many of the markdown elements detailed below:

Attribute Example
font-family:Helvetica

font-size:32
font-color:#ffff00

font-bold:1

font-italic:1

font-underline:1

font-strikethrough:1
font-smallcaps:1

line-height:22
line-height-multiple:1.2
line-spacing:5
paragraph-spacing-before:5

paragraph-spacing-after:2

Small Caps

Description

The specific font face like “Helvetica Neue UltraLight” or general font
family like “Helvetica”.

The font size.

The color for the font, in hex syntax.

Enable bold. Useful if a general font family is specified instead of
specific font face.

Enable italics. Useful if a general font family is specified instead of
specific font face.

Enable underline.

Enable strikethrough.

Enable small caps. Note only a few fonts support small caps, see
details below.

A forced line height in points (default is 0 for automatic).

The natural line height will be multiplied by this value (default is 1).
The additional distance in points between lines (default is 0).

The distance in points before this header (default is 5).

The distance in points after this header (default is 2).

You can enable a small caps setting, as shown above, but note that only a few fonts actually support true small caps. Curio will not

attempt to perform a fake small caps by uppercasing lowercased letters and decreasing their font size.

- 302/423 - Copyright © 2025 Zengobi, Inc.



Markdown Body Text

You can determine which fonts installed on your system support true small caps.

1. Launch TextEdit.
2. Bring up the standard macOS Fonts helper ($T) and then use the actions button to bring up the Typography window.
3. Then select various fonts until the Lower Case option appears in Typography with a Small Capitals value.

For example, Avenir Next and SF Pro support small caps, for example, but the very popular Helvetica font does not.

Markdown Body Text

By default the markdown syntax, like bold, will be applied to whatever font is assigned to the text figure itself.
However, you can define an override body text file like this:

body = font-family:Helvetica Neue;font-size:16; font-color:#666666;

Markdown Italic and Bold Text

Italic ( *sampie* ), bold ( **samp1le** ), and both italic and bold ( ***samp1e*** ) can be styled like this:

*x = font-color:#ff0000;
*xx = font-color:#00bb00;
*xxk = font-color:#0000ff;

Markdown Header Text

The six markdown headers ( # , ..., ###### ) can be styled like this:

# = font-family:Helvetica Neue UltralLight;font-size:32;font-color:#376098;
## = font-family:Helvetica; font-size:28;font-color:#ff0off; font-bold:1;

Markdown Lists

List items ( - ) can be defined with the following additional attributes:

Attribute Example Description
An additional distance in points between a list item’s wrapped lines
(default is 0).

paragraph-spacing-after:20 An additional distance in points between list items (default is 0).
Like this:

line-spacing:5

- = font-color:#333333; font-size:14; line-spacing:5; paragraph-spacing-after:20;
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Markdown Tables

Markdown Tables

Table cells ( table-cel1 ) can be styled with the following additional attributes:

Attribute Example Description
cell-color:#333333 The cell background color.
border-color:#ffffff The cell border color.
border-width:1 The cell border width.

padding:5 The cell padding.
There are other related cell styles which inherit tabie-ce11 values by default but you can override specific values if you wish:

» Header row cells: table-cell-header
» Footer row cells: table-cell-footer

* Left column cells: taple-cel1l-1eft

* Right column cells: table-cell-right

* Alternating row cells: table-cell-alt
Like this:

table-cell = border-color:#d4d9dd;

table-cell-alt = cell-color:#f6f8fa

table-cell-header = cell-color:#666666; border—color:#d4d9dd; font-color:#ffffff; font-size:14; font-bold:1
table-cell-footer = cell-color:#dddddd; font-bold:1

table-cell-left = cell-color:#eeeeee

table-cell-right = cell-color:#eeeeee

Markdown Block Quotes

The style for block quotes ( > ) can be defined with the following additional attributes:

Attribute Example Description
o ) The distance from the leading margin to the beginning of the
first-line-head-indent:36; o i
paragraph'’s first line (default is 18).
The distance from the leading margin to the beginning of lines other
than the first (default is 18).
tail-indent:-36 The distance from the trailing margin (default is -18).

Like this:

head-indent:36

> = font-color:#338888; font-italic:1; first-line-head-indent:36; head-indent:36; tail-indent:-36;

Limitations

Curio’s blockquote styling has some limitations compared to HTML/CSS renderers due to its reliance on the Mac’s internal rich text
framework. For instance, the rich text system doesn’t support a left or right border. Also we’ve been unable to figure out a way of
supporting text which is both indented and background colored. The text system doesn’t want to color the first indent so the result
looks odd.
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Markdown Code Blocks

Markdown Code Blocks

Code b|OCkS( ') and inline code ( ') styles can be defined with the same attributes as described above.

specifically background-color anda font-color’ may be useful.

= background-color:#eeeeee; font-color:#338888;
" = background-color:#eeeeee; font-color:#338888;
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Sharing

Sharing

There are many ways to share, export, print, or present your project data with others.

Share

There are two main method for sharing Curio content with others:

1. The Share toolbar button.
2. The File > Share menu item.

Both show the same popup submenu with sharing options separated into three different sections:

1. Project (or currently selected section),
2. Selected idea spaces,
3. Selected figures.

Recent Sharing Selections

At the very top, Curio first lists the most recent export and mail sharing selections so you can easily choose them again.

- = m o A =
Sh: Recent Shares
' Mail Project As PDF
¥ Export Figure As JPG
Export Idea Space As Rich Text
Export Figure As PNG

Export Figure As PDF

—

Sharing the Project

The next options you see listed are for the currently selected section or project:

+ Exporting all idea spaces as individual plain text, RTF, or image files, as an HTML or PDF export. More information on HTML
exporting is below.

- Mail all idea spaces as a Curio project extract or a PDF file.

« Print all idea spaces. More information on printing is below.

* Begin a slideshow presentation. More information on presentation mode is below.
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Sharing Selected Idea Spaces

Sharing Selected Idea Spaces

The next options you see listed are for the currently selected idea spaces:

» The same export options mentioned above.

- Mail the selected idea spaces as a Curio project extract or a PDF file. You can also select to mail the idea space’s style or
template to a friend or to Zengobi.

« Print the selected idea spaces. More information on printing is below.

Sharing Selected Figures

The last options you see listed are for the currently selected figures:

* You can export the selected figures as a text or RTF file, or a combined JPEG, PNG, or non-paginated PDF image. Based on
the types of figures selected you may see additional options such as CSV exporting for tables and OPML, MindManager, and
iThoughts for mind maps

+ Mail the selected figures as a combined JPEG, PNG, or non-paginated PDF image. You can also select to mail the figure’s
style or stencil to a friend or to Zengobi.

« Share the selected figures as text to any of the configured macOS sharing services such as via Email, Messages, Twitter, or
Facebook.

+ Share the selected figures as an image to any of the configured macOS sharing services such as via Email, Messages,
AirDrop, Twitter, Facebook, or Flickr.

« Print the selected figures or the selected figure’s notes. More information on printing is below.

Mac App Store Restriction

Curio from the Mac App Store is required to use the macOS sharing service to support mailing from within Curio. While this
works very well with Apple’s Mail app, it may not be compatible with all 3rd party mail clients as they have to support the
NSSharingServiceNameComposeEmail sharing service feature. As a workaround you can export to your Desktop and add the
attachment to a manually composed email.

Non-sandboxed Curio supports a customizable AppleScript technique for working directly with most major mail clients.

Exporting Figures as Separate Images

When exporting selected figures as PNG or JPG you have the option of exporting them as separate images.

For example, if you select 3 figures, and you enter the export file name of “Result” they would be exported as “Result 1”7, “Result 27,
“Result 3”, each with an appropriate png Or jpg extension.

You can also specify a string format for a file name such as “Result%03d” and they would be exported as “Result001”, “Result002”,
“Result003”.

Custom Sharing Actions

Curio supports an advanced option where you can configure custom sharing actions to send selected figures directly to other
applications using their app URL schemes.
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Custom Sharing Actions

Share Selected Figure

Export As > |

Custom Actions »2| Drafts Append To 'Notes' Note

Mail As > Obsidian Append To Personal Daily Note
Share As Text Via > OmniFocus Create Task

Share As Image Via > | Things Create Task

Print > " —

E————

To do this you will create a special sharing.json file containing entries that use templated variables and the 3rd party’s URL
scheme to send selected figure information to that application.

The location of your sharing.json file depends on the Curio you have installed:

1. Curio from the Zengobi website:
~/Library/Application Support/Curio/Version XX/Sharing.Jjson
2. Curio from the Mac App Store:

~/Library/Containers/com.zengobi.curio/Data/Library/Application Support/Curio/Version XX/Sharing.json

... where xx is the major version number of your Curio.

3rd Party URL Schemes

Here is a selection of URL schemes you may wish to explore:

* OmniFocus

- Things

* Drafts

+ Obsidian’s Advanced URI URL scheme
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https://culturedcode.com/things/support/articles/2803573/
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Copying

Example

Here is an example sharing.json file which was used to produce the screenshot above:

{
"custom": [

{
"title": "OmniFocus Create Task",
"link": "omnifocus:///add?name={%FigureText}&note={%FigureNote}&defer={%FigureStartDateIS08601}&due={%FigureDueD:
"info": "https://inside.omnifocus.com/url-schemes",
"types": ["figure"]

+

{
"title": "Things Create Task",
"link": "things:///add?title={%FigureText}&notes={%FigureNote}&when={%FigureStartDateIS08601}&tags={%FigureTagNan
"info": "https://culturedcode.com/things/support/articles/2803573/",
"types": ["figure"]

+

{
"title": "Drafts Append To 'Notes' Note",
"link": "drafts://x-callback-url/append?uuid={{DraftsUUID}}&text={%FigureText}",
"info": "https://docs.getdrafts.com/docs/automation/urlschemes",
"types": ["figure"]

+

{
"title": "Obsidian Append To Personal Daily Note",
"1ink": "obsidian://advanced-uri?vault=Personal&daily=true&data={%FigureText}&mode=append",
"info": "https://github.com/Vinzent@3/obsidian-advanced-uri",
"types": ["figure"]

}

1
}

Note the use of:

* Curio variables, like {$FigureText} , {%FigureNote} , and {$FigureTagNames}
« Curio variables with special variable formatters, like {%FigureDuebateIso8601}

» Custom project variables, like {{projectName}} and {{DraftsUUID}}

» Custom figure data values, like {sFigurecustombData:Context}

Note
To prevent endless loops, the variables (sriguretext} and (srigurenote} are only allowed in certain places within Curio,
including here within custom sharing templates.

Tip
Normally the contents of the sharing.json file are loaded and cached at launch. If you are making lots of changes during
testing you may want Curio to reload the file each time you click the Sharing menu.

Copying

The most basic way to extract data is the simple Copy command.

- 309/423 - Copyright © 2025 Zengobi, Inc.


curio://defaults-write?Custom%20Sharing%20Reload%20Always=yes

The Copy menu

The Copy menu

The standard Edit > Copy command is useful in copying figures around your idea spaces. It will also place useful formats based on
the selected figure such as text, image, and link.

It also comes in handy if you want to copy a figure or idea space to use as a jump destination. Then use one of the Edit > Paste As
options such as Jump Action for Selected Figure, Idea Space Link, or Jump Anchor. More info can be found in the Linking Figures
idea space.

If you copy an image figure or image asset from the Library, then you can select another figure and choose Paste As > Attachment
for Selected Text Figure and the image will be displayed as a small attachment above the text figure. More info in the Text Figure
Attachments idea space.

The Copy As menu

Curio’s Edit > Copy As menu has many more options so you can copy precisely what you want to the clipboard, including:

* Plain Text

* Rich Text

» Markdown — more info here.

* PDF

* PNG

+JPG

+ Hyperlink — useful when you want a curio:// hyperlink to a figure or idea space to use elsewhere, even outside of Curio.
« Parent Figure Only — normally when you copy a parent node, in a list or mind map, you can children as well.

The various text copying varieties have some preferences you can set in this Copy As menu:

* Include Notes With Text — when copying figures, any associated figure notes will be copied as well.
* Include Meta With Text — when copying figures, any meta data is included. This is detailed on the next idea space.
* Include Images With Rich Text — when copying figures, any images found in image figures will be copied to as well.

Here’s an example of a figure with its notes and meta copied:

Simple figure (25% complete; % % % % ¥¢; urgent priority; Feb 14, 2018 - Mar 15, 2018 3:00 PM; duration 20 days; Love, Home;
Kat, George) (Some notes for this figure.)

Including Meta in Text Exports

If you have enabled copying or exporting figure meta (via the Edit > Copy As menu or the export dialog, respectively) then Curio will
export meta entries in your plain and rich text exports.

For example:

Simple figure (25% complete; % % % % ¥¢; urgent priority; Feb 14, 2018 - Mar 15, 2018 3:00 PM; duration 20 days; Love, Home;
Kat, George) (Some notes for this figure.)
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Here’s the meta output Curio supports:

Meta Output

50% complete
Yk ko

urgent priority

start 2018-04-15

due 2018-04-25 20:00
2 weeks

Home, NextAction

George, Greg

Dragging

Values

A number from 0
to 100

A number of
stars
Description of
priority

A date with or
without a time
value

A date with or
without a time
value

A duration string

A comma
separated list of
tags

A comma
separated list of
resources

Dragging

Description

If checkmarks visible, the figure’s percent complete.

The figure’s rating value (number of stars).

The figure’s priority from urgent priority to very low
priority.

The figure’s start date (custom date and time
format).

The figure’s due date (same customizations).

The figure’s duration is normally not exported, but
can be enabled.

The figure’s tags. Choose to export just the tag or
tag set and tag: Home or Context.Home.

The figure’s resources. Choose how much of the
resource name to export: George, or
GeorgeBrowning, or George Browning, or

George Browning.

There are several ways to drag items out of Curio to another application.

Drag Assets out of Curio’s Project Library

+ Select one or more assets from the Library and drag them directly to another application.

Drag an Asset Figure out of Curio’s Idea Space

1. Begin by selecting a single asset figure on the idea space.

2. Hold ~={1# (~={} Command) and click and begin dragging the already-selected figure. Notice that instead of dragging the

figure itself around the idea space you are now dragging a file representation of that figure.

3. Now that you’ve started dragging release those keys then continue dragging and drop it anywhere on your Desktop, a

Finder window, or any other application.

4. The sole purpose of that magic 3-key combination is to tell Curio to place the asset figure’s file URL on the dragging

clipboard, instead of tracking a normal figure movement.
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Printing

Important

It’s important to release those keys after you’ve started the drag operation but while you’re still dragging, otherwise the
destination application will try to interpret those keys as a forced move, alias, or copy of the file but Curio only supports a copy
of the file out of the project.

Printing

Curio supports printing your idea spaces, your figures, and your figure notes.

Print Idea Spaces

1. Use the Share toolbar button or choose the File > Print menu then choose whether you want all the idea spaces in the
current section or only the selected idea spaces.
2. Modify your print options in the standard Print dialog that appears.
o Set whether your idea spaces should be scaled to fit a single printed page.
= Optionally rotating the orientation of the page automatically to minimize scaling.
= In the case of very large idea spaces, you can also tell Curio that if the scaling to fit to a single page would
result in a scaling of less than 50% then it should automatically expand to additional pages until it crosses
that threshold so the results aren’t too small.
> Set whether Curio should print the idea space background and grid.
o Specify a header or footer that should appear on the top of each page, see the notes above for those variable
options.
° Enter values for the top, left, bottom and right print margins, or click “Use smallest margins possible” to make your
margins as small as possible, for your printer, and maximize your idea space work area.
3. Pressing the Print button will then send the job to the printer.

Print Organizer Documents

1. Select the documents in the Organizer you wish to print.
2. Choose the File > Print Document menu or right-click and choose Print Document.
3. The application responsible for editing those file types are launched and instructed to immediately print the documents.
4. The method above immediately prints the document in that application.
o If you wish to see that application’s Print dialog first before printing then you need to follow these steps instead:
1. Right-click on the Organizer Document in the Organizer.
2. Choose Open with Finder.
3. Within the launched application choose the File > Print menu item.

Print Figures

1. Select which figures you would like to print.
2. Click the Share toolbar button then choose Print from the Share Selected Figures section of the popup menu.
3. Pressing the Print button will then send the job to the printer.

Print Figure Notes

1. Select one or more figures that have associated notes.
2. Click the Share toolbar button then choose Print Notes from the Share Selected Figures section of the popup menu.

-312/423 - Copyright © 2025 Zengobi, Inc.



Customizing Print Headers and Footers

Print Figure Notes from the Notes Window

1. To make the Notes window appear for a figure you can select the figure and click the Notes button in the inspector bar.
Alternatively you can just click directly on the Notes adornment on the figure itself and the Notes window will appear.

2. Click within the Notes window to make sure it has focus.

3. Choose the File > Print Notes menu item.

4. Pressing the Print button will then send the job to the printer.

Print Figure as Text

1. You may want to print a selection of figures as text, instead of an image representation. This can come in handy if you have a
figure that contains a lot of text and you don’t want to print it as a graphical figure, where it may not paginate nicely onto
pages.

2. Select one or more figures.

3. Click the Share toolbar button then choose Print Figure as Text from the Share Selected Figures section of the popup menu.
This menu item pays attention to the checked state of the Include Figure Notes When Copying/Sharing Text and will
therefore include any figure notes with the printout.

Customizing Print Headers and Footers

When printing idea spaces the Print dialog offers several custom Curio options you can apply. Of note is an optional header footer
that can appear at the top and bottom of the printed pages, respectively.

By default the header is:
{%IdeaSpaceTitle}

Anything within {% and } is considered a variable by Curio. In this case, this variable is dynamically replaced with the title of the idea
space. You can add your own text anywhere outside of that variable string.

By default the footer is:
— {%IdeaSpaceNumberWithSheetInfo} -

This variable is dynamically replaced with the idea space number and optional sheet information. For example, if idea space #26
spans onto 9 sheets of paper then the 3rd sheet would show 26 (3 / 9) as its footer. If only one sheet was required then that
parenthetical information is not printed.
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PDF Export

Header and Footer Variables

Here are all the variables you can use in the header and footer fields:

* {sProjectTitle} - the project’s title.

* {sProjectFilerath} - the project’s file path.

* (ssectionTitle} -the immediate section which owns the idea space.

* (%RootsectionTitle} - the root, top-most section which owns the idea space.

* {sFolderTitle} - the immediate folder which owns the idea space.

* {%RootFolderTitle} - the root, top-most folder which owns the idea space.

* (sIdeaspaceTitle} - the idea space’s title.

* (sJournalsubtitle} - if ajournal idea space entry, then the journal entry’s optional subtitle.

* (sIdeaspaceCount} - this represents the total count of idea spaces that could be printed.

* {sIdeaSpaceNumber} - in the example above: 26, as in #26 out of the total count of idea spaces.

* (%IdeaSpaceSheetNumber} - in the example above: 3, as in the 3rd sheet of paper necessary to output the current idea
space.

* (sIdeaSpaceNumberOfsheets} - in the example above: 9, as in this idea space needs 9 sheets of paper to output its content.
* (3TdeaSpaceNumberWithSheetInfo) - in the example above: 26 (3 /9), as this is page 3 out of 9 for idea space #26. If the idea
space fits on a single page then (21deaspaceNumbernithsheetinfo} IS simply replaced with (21deaspacenumper} . But, if the

idea space spans across multiple sheets it is replaced with: (21deaspaceNumber} ({%IdeaSpaceSheetNumber} /

{%$IdeaSpaceNumberOfSheets} )

PDF Export

Curio supports exporting all or a selection of idea spaces to PDF.

Export Idea Spaces to PDF

1. Use the Share toolbar button or choose the File > Share menu then choose whether you want export the idea spaces in the
current section or only the selected idea spaces.
2. Modify your PDF export options in the Print dialog that appears.
1. Set whether your idea spaces should be scaled to fit a single printed page.
= Optionally rotating the orientation of the page automatically to minimize scaling.
= In the case of very large idea spaces, you can also tell Curio that if the scaling to fit to a single page would
result in a scaling of less than 50% then it should automatically expand to additional pages until it crosses
that threshold so the results aren’t too small.
2. Set whether Curio should include the idea space background and grid.
3. Specify a header or footer that should appear on the top of each page, see the notes in the Printing documentation
for those variable options.
4. Enter values for the top, left, bottom and right print margins, or click “Use smallest margins possible” to make your
margins as small as possible, for your printer, and maximize your idea space work area.
3. Press the Export button to begin the export.

Options

The same options seen when printing discussed above are available in the PDF export dialog as well.
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PDF Outline

PDF Outline

For Curio Professional and Standard, the PDF’s generated using Export as PDF now have an embedded PDF document outline for
easy navigation using PDF viewers that support that standard PDF feature. In Apple’s Preview app, for example, choose View >

Table of Contents to see the PDF’s hierarchical document outline.

The PDF outline is part of the PDF standard so most standards-following PDF readers should support it. Zengobi has tested it with
the macOS Preview and Adobe Reader apps as well as the following iOS apps: Dropbox, Readdle’s PDF Export and PDF Viewer,
Good.iWare’s GoodReader, Branchfire’s iAnnotate PDF, and LiquidText.

Clickable Links

When you export idea spaces via Export as PDF the resulting PDF will have clickable links for:

* Weblink figures, like a URL dropped from a browser into an idea space.

* Figures with URL actions.

» Weblinks and figure URL actions that are inner project hyperlinks (ex: curio://?ideaspace=062...).
« I[dea space links to other inner project idea spaces.

» Jump anchors to inner project locations.

* Figures with jump actions to inner project locations.

« Figures with first, last, previous, or next idea space jump directions.

Limitations

Curio doesn’t generate PDF links for a selection of text within a text figure that has a link attribute. This is a tricky one to solve as (a)
Curio would have to scan all text figures when exporting to find any wstinkattribute attributes which could be very slow, (b) the
resulting range of text may consist of wrapped lines of text complicating the generation of potential PDF annotation link regions.

Note Open PDF in Preview

If instead of exporting as PDF you choose to print then click the print dialog’s button to Open PDF in Preview then Curio isn’t given
that temporary filename so is unable to modify the generated PDF to include the PDF outline or PDF links. So either use print to a

PDF file and then open it, or use export as PDF.

Markdown Export

Curio can export an entire project, selected idea spaces, or specific selected figures as markdown!

The result is pretty awesome: a single markdown file (and optional accompanying assets folder) where your Curio text figures turn in
markdown rich text blocks, your Curio lists, mind maps, and stacks turn into markdown list blocks, Curio tables into markdown
tables, Curio image figures into inline markdown images, asset figures into markdown file links, link figures into markdown links, etc.

You can then view the exported markdown file with your favorite markdown app like Marked or MultiMarkdown Composer.
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Markdown Text

Export Your Project, Selected Idea Spaces, or Selected Figures as Markdown

1. In Curio, select what you want to export then click the Share toolbar button then choose Export As > Markdown.

2. In the dialog that appears you can choose the location for the export and give it a file name for your export. Note that a
single .markdown file will be created with that name containing everything you selected to export.

3. In that same dialog you can optionally specify if you want figure notes and meta exported.

4. You can also specify that images and files should be exported as well. If so, Curio will create folder alongside your
markdown export file which will contain those images and files stored within uniquely named subfolders.

5. Click the Export button and your export will be generated.

Markdown Text

Curio’s markdown converter will convert your rich text figures directly into markdown! Curio uses each figure’s markdown setting in
the text inspector is to determine how to perform this conversion:

» Markdown Rendering is Off
If the markdown inspector button is off then this is a figure which doesn’t contain any entered markdown. So Curio will
automatically convert any rich text attributes to the supported markdown rich text syntax described earlier. For example, if
Curio finds bold text it is turned into **bold**. As a note, to determine if a line of rich text should be a markdown header (ex:
“# header 1”) Curio looks for text where the entire line is bold and of a certain font size. Headers 1 through 6 (i.e. #, ##, ###,
#iHHE, i ####H#) will be created with bold text of size 32, 24, 18, 16, 13, 11, respectively.

» Markdown Rendering is On
If you set the markdown inspector button is on then Curio will take the text figure’s text and leave any existing markdown
that you entered as-is, but it will also conveniently convert any attributed text it finds to markdown’s rich text syntax. So, if a
text figure contains the following text: “This is a mix of *italicized* markdown syntax and bold attributed text.” then will take
that italicized markdown as-is but convert the bold text to **bold**.

Markdown Lists

Curio exports hierarchical data such as lists, mind maps, and stacks as markdown lists, with the following considerations:

» While basic markdown doesn’t support nested lists, many extensions such as MultiMarkdown and CommonMark use tab
indentions to indicate nesting, so Curio supports this as well.

» Markdown only supports simple bullets (via the * markup) and numbering (via the 1. 2. 3. markup) so Curio’s extensive per-
level prefixing is automatically narrowed to those two available options during export.

+ The individual text figures that make up the Curio collection figure are converted into markdown’s rich text syntax as
described above.

- If a list item has line breaks within then those are merged into a single text line for the export.

+ Curio will output the * as the list marker for bullets. You can optionally change this to the - marker if you wish.

* List titles have to be output with a blank line between the title and the actual markdown list, as per markdown rules.
Personally | wish it didn’t need this but, if it’s not there, then lists won’t render correctly.
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Markdown Lists

Mind Map Levels as Markdown Headings

By default, a mind map is exported exactly like a list for all of its hierarchical levels so you might see something like this for a typical

mind map:

- Central Topic
- Parent 1
- Child
- Grandchild
- Parent 2
- Child
- Grandchild

However, when exporting a mind map collection figure, the export as markdown dialog will have an additional option: Use
markdown headings to mind map level with a popup allowing you to choose a level. If a non-zero level is chosen, then hierarchies
up to that level are exported as markdown headings instead of list items. A setting of 2 would result with this export:

# Central Topic
## Parent 1

— Child
- Grandchild

## Parent 2

- Child
- Grandchild

The other difference is for all exported nodes, figure notes are output directly after the figure’s text instead of as a markdown
footnote, as detailed below. For example if Parent 1 and Grandchild had some notes it would look like this:

## Parent 1
Here are some notes.

- Child

— Grandchild
Here are some notes.

Most markdown renderers would then display those notes on the same hierarchical level as the item itself.

This feature is designed to mimic the functionality that was supported in the venerable iThoughts, a popular standalone mind
mapping app that has been discontinued, sadly. However, one key difference is that Curio will still output meta data as markdown

tags on the same line as the figure’s text, as detailed below.
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Markdown Tables

Markdown Tables

Curio exports its tables as markdown tables, with the following considerations:

» While basic markdown doesn’t support tables, many extensions such as MultiMarkdown and Github Flavored Markdown
support a common extended syntax for markdown tables which Curio uses.

« Markdown only supports a header row, so Curio’s footer row and header & footer columns are simply rendered in markdown
as normal cells.

» Markdown column alignment syntax is not output since Curio’s can be individually specified per cell.

« Each row has a leading and trailing pipe (“|”), which some markdown viewers require, but can be disabled.

Markdown Links

In the markdown export dialog you can choose whether to export images and other figure assets. These are exported to a folder
created alongside the resulting markdown file. Each exported figure asset will be contained within uniquely named subfolder to
avoid file name collisions.

By default this assets folder will be named based on the markdown file name. For example, if you specified “Project” for the
exported markdown file, then the assets folder will be named “Project Assets”. You can customize this format string, where a %@

token in the format string, if found, is replaced with the markdown file’s name.

Note the resulting markdown links, like [an image] (Project%20assets/7832-3982/Notes.pages) , Will reference this folder location so
you can’t rename it in the Finder later! Instead you will need to delete the previous export and re-export.

Inline Image Links

For simple image types (png, jpg, etc, but not pdf), Curio will use the ! [title] (path) markdown syntax to show the image inline

on the markdown page (note the exclamation point prefix). Or, if you don’t want to see the inline image, you can export as a normal
markdown link instead. Curio will scale the exported image so it’s the same size as rendered on the idea space, but you can export
the full size image if you wish.

File and URL Links

For all other asset types, Curio will use the [titie] (path) markdown link syntax thus creating a clickable link to the asset. Of
course weblink figures use the [titie] (path) markdown link syntax as well thus creating a clickable link to the site.

Wikilinks

Inner project wikilinks like [[wikilink]] OF [[wikilink|Alt Title]] are converted into standard markdown links of the form
[title] (1ink) during export.

Compatibility

The ability to render and handle these links depends on your markdown viewer, although Marked and MultiMarkdown Composer

seem to handle them beautifully.

Limitations

Note that this feature works for images and files that exist as asset figures. Curio will not parse, extract, and export images that
exist within the rich text content of a Curio text figure.
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Markdown Footnotes

Markdown Footnotes

If you have enabled copying or exporting figure notes (via the Edit > Copy As menu or the export dialog, respectively) then Curio will
export those notes as markdown inline footnotes that Obsidian and Pandoc support.

For example:
This is a figure.A[And this is its note as an inline footnote.]

If you’d prefer the inline footnote format favored by MultiMarkdown and IA Writer, like [~this is a note] , then you can change an
advanced preference.

Meta Export

If you have enabled copying or exporting figure meta (via the Edit > Copy As menu or the export dialog, respectively) then Curio can

export meta data with the figure’s content.

Here’s meta in a normal text export:

Simple figure (25% complete; % % % % ¥¢; urgent priority; Feb 14, 2018 - Mar 15, 2018 3:00 PM; duration 20 days; Love, Home;
Kat, George) (Some notes for this figure.)

And here’s meta in a markdown export:

Simple figure”A[Some notes for this figure.] @progress(25) @rating(4) @priority(1) @start(2018-02-14) @due(2018-03-15 15:00)
@duration(20d) @tags(Love, Home) @resources(Kat, George)
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Meta Export

The special markdown meta format is useful because other apps can import that meta data, including Curio itself.

Markdown Meta Syntax Values Description
@ (50) A number from 0 If checkmarks visible, the figure’s percent complete
rogress
prog to 100 (or @done for 100% if enabled).
) A number from 1 ) )
@rating(3) t0 5 The figure’s rating value (number of stars).
o}
@priority(1) A number from 1 The figure’s priority value from 1 meaning urgent
riori
P Y to5 priority to 5 meaning very low priority.
A date with or ) )
) ) The figure’s start date (custom date and time
@start(2018-04-15) without a time ¢ )
ormat).
value
A date with or
@due(2018-04-25 20:00) without a time The figure’s due date (same customizations).
value
The figure’s duration is output only if
due=start+duration. The abbreviations for year,
@duration(2w) A duration string month, week, day, hour, minute can all be
customized, note that month uses “x” by default
like TaskPaper.
The figure’s tags. Choose to export just the tag or
A comma
, ) tag set and tag: Home or Context.Home. You can
@tags(Home, NextAction) separated list of ,
taas also choose the format: @tags(Home, NextAction),
g or @Home @NextAction, or #Home #NextAction.
The figure’s resources. Choose how much of the
A comma resource name to export: George, or
@resources(George, Greg) separated list of GeorgeBrowning, or George Browning, or
resources George Browning. You can also choose the format:
@resources(George, Greg) or @George @Greg.
) i Inline tags are associated with the figure but remain
#vacation Inline tags )
in the text content.
) Inline resources are associated with the figure but
@steve Inline resources o
remain in the text content.
i ] Obsidian style inline footnotes, multi-lines
A[Some notes for the figure.] A figure’s notes

separated by 3 spaces
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curio://defaults-write?Export-20Markdown-20Use-20Done=yes
curio://defaults-write?Export-20Markdown-20Date-20Format=yyyy-MM-dd
curio://defaults-write?Export-20Markdown-20Time-20Format=HH:mm
curio://defaults-write?Export-20Markdown-20Duration-20Year=y
curio://defaults-write?Export-20Markdown-20Duration-20Month=x
curio://defaults-write?Export-20Markdown-20Duration-20Week=w
curio://defaults-write?Export-20Markdown-20Duration-20Day=d
curio://defaults-write?Export-20Markdown-20Duration-20Hour=h
curio://defaults-write?Export-20Markdown-20Duration-20Minute=m
curio://defaults-write?Export-20Markdown-20Tags-20Full-20Name=0
curio://defaults-write?Export-20Markdown-20Tags-20Full-20Name=1
curio://defaults-write?Export-20Markdown-20Tags-20Format=0
curio://defaults-write?Export-20Markdown-20Tags-20Format=1
curio://defaults-write?Export-20Markdown-20Tags-20Format=2
curio://defaults-write?Export-20Markdown-20Resources-20Full-20Name=0
curio://defaults-write?Export-20Markdown-20Resources-20Full-20Name=1
curio://defaults-write?Export-20Markdown-20Resources-20Full-20Name=2
curio://defaults-write?Export-20Markdown-20Resources-20Full-20Name=3

Meta Import

Meta Import

Special meta text tags are now parsed and extracted when:

« Importing markdown lists and tables via .markdown files or the Edit > Paste As Markdown menu (disable).
« Pasting any type of non-markdown text as lists, mind maps, or tables via the Edit > Paste As menu (disable).

While a meta tag can appear anywhere in the text, a space must prefix each @meta item!
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Meta Import

For example, Curio will parse the meta information if you Edit > Paste As > List some text that looks like this:

Dev Tasks
Code product. @progress(75) @priority(1) @due(2018-02-28) @resources(George)
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Markdown Meta Syntax

@progress(50)

@done

@done(2018-04-25)

@rating(3)

@priority(1)

@start(2018-04-15)

@due(2018-04-25 20:00)

@duration(2w)

@tags(Home, NextAction)

Meta Import

Values Description
A number from 0 ,

The figure’s percent complete.
to 100

From TaskPaper, indicates the task is 100%
complete (enable).

None

A date with or
without a time  The figure’s done date.

value
A number from 1 . )
t05 The figure’s rating value (number of stars).
A number from 1 The figure’s priority value from 1 meaning urgent
to5 priority to 5 meaning very low priority.
The figure’s start date (custom date and time

) format).
A date with or

) i Note that @defer is also supported as an alternate
without a time

valte for OmniFocus support.
The date determination is set to manually specified
since you are specifying a specific date.
A date with or  The figure’s due date (same customizations).
without a time  The date determination is set to manually specified
value since you are specifying a specific date.
The figure’s duration. During import if @duration
exists then @due is ignored as the figure’s due date
A duration string will be .con?puted via due=start+durati.on.. See
@duration in Meta Export. The abbreviations for

year, month, week, day, hour, minute can all be

customized.

The figure’s tags. You can specify a tag either with
just its name (Home), and Curio will find it, or the tag
set and the tag name (Context.Home). Curio ignores

case when searching. Note that tags must already
A comma . ) )
, exist and will not be added dynamically. You can
separated list of ) ) )
; also enable tag parsing for @-signed tags like
ags
9 @Home @NextAction or #-signed tags like #Home

#NextAction. However note that no spaces are
allowed in a tag so you need to concatenate them
together, like @DetailedTasks.InFlight.
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curio://defaults-write?Import-20Meta-20Text-20Use-20Done=yes
curio://defaults-write?Import-20Meta-20Text-20Date-20Format=yyyy-MM-dd
curio://defaults-write?Import-20Meta-20Text-20Time-20Format=HH:mm
curio://defaults-write?Import-20Meta-20Text-20Duration-20Year=y
curio://defaults-write?Import-20Meta-20Text-20Duration-20Month=x
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curio://defaults-write?Import-20Meta-20Text-20Tags-20Format=1
curio://defaults-write?Import-20Meta-20Text-20Tags-20Format=2
curio://defaults-write?Import-20Meta-20Text-20Tags-20Format=2

Notes

Markdown Meta Syntax Values Description
The figure’s resources. You can enter your resource
names either with just first names or full names, with
or without spaces or underscores, and Curio ignores
case when searching, so all of these would work:

A comma george, george_browning, George Browning,
@resources(George, Greg) separated list of GeorgeBrowning. Note that resources must already
resources exist and will not be added dynamically. You can

also enable tag parsing for @-signed tags like
@George @Greg. However note that no spaces are

allowed in a name so concatenate or use an
underscore.

) . Inline tags are associated with the figure but remain
#vacation Inline tags )
in the text content.

i Inline resources are associated with the figure but
@steve Inline resources o
remain in the text content.

Curio does not normally import footnotes by default.
This is because notes lose rich text formatting when
exported so if imported you will lose formatting. If
A[Some notes for the figure.] A figure’s notes that’s okay, and you only use simple text for your
figure notes, then you can enable footnote
importing. Formatted as Obsidian-style inline

footnotes, multi-lines separated by 3 spaces.

Notes

+ By default Curio can match an imported inline tag even if a tag set is not specified. For instance, you can type #active and
if not found as a local or global keyword tag then Curio will scan all tag sets to see if it can find one that contains a tag with
that name. If so it replaces it with the full name like #crp/active . You can disable this if you’'d like.

« Otherwise if an inline tag is not found as an existing tag then a new project-local keyword tag will be created.

TaskPaper Export

Via the Share menu or toolbar button, you can export a selected list, stack, or mind map as a TaskPaper document. Figure meta

information is automatically exported as well.

Note that edone is output for any completed items, and eprogress() for all other items. This includes 0% done, so you will see a
eprogress (0) for unchecked items, so you can perform eprogress searches in TaskPaper, as described below. You can turn this
off if you’d rather only see this tag when progress has been made. If the Done Date meta information is set then that date is output

with the form edone (vyy-mv-pp) .
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TaskPaper Meta Search Tips

TaskPaper Meta Search Tips

Curio will output meta information to TaskPaper using the markdown-style syntax described in Exporting Meta. Thus
eprogress (25) to indicate a task is 25% done and eresources (George, Greg) tO indicate resources.

TaskPaper supports advanced searching queries that can dive into this meta information.

®* (@progress >[n] 20

Find all tasks more than 20% completed (that aren’t done, which would have a @done tag instead of @progress).
®* (@tags contains[l] home

Find all tasks with a tag of Home.
* Qresources contains[l] george

Find all tasks assigned to George.
®* (@due < [d] 2018-06

Find all tasks due before June 2018 (more date tips here and here).
* Q@due <[d] next week and @progress =[n] 0

Find all tasks due in the next week that haven’t been started.
®* (@due <[d] next week except @done

Find all tasks due in the next week that aren’t done.

Export a List, Mind Map, or Stack as TaskPaper

1. Select the list, mind map, or stack figure.
2. Choose the Share button or File > Share menu, then under selected figure choose Export As > TaskPaper.

Importing from TaskPaper

« Click here to learn how to import from TaskPaper.

Sync File

Curio Pro can sync the contents of text figures and list, mind map, stack, and table collection figures to external files, either

bidirectionally, export only, or import only.

That file can be located anywhere including within a cloud-synced folder like iCloud or Dropbox. For example, you can sync a
Vacation to-do list figure with a markdown list file located within a cloud-synced Obsidian vault allowing you to add, remove, modify,
and rearrange items using Obsidian on iOS which are instantly reflected back to your Curio on macOS. Synced list items can
include images and meta such as checkmarks and dates.

When Syncs Occur

When the project is loaded Curio will check for sync file modification and import the changes.

Then while the project is open, the figure and sync file are constantly monitored to export or import changes as appropriate. The file
syncing occurs instantly when a change is detected either to the figure or the sync file. You don’t have to manually refresh the figure
or force a save for the sync to occur.
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Working with Sync Files

Versus File-Backed Text Figures

While this feature is somewhat similar to Curio’s file-backed text figures (FBTF) there are some key differences:

* Text Figures Only
o A FBTF is only for text figures.
o In contrast, a sync file can be established for more complex types like list and table collection figures.
« Text Content Only
o A FBTF only deals with the content of the text figure.
o In contrast, a sync file for figures includes not only the content of each contained item but also any meta information.
For collection figures it also includes the arrangement of its contained figures.
* File Formats
o A FBTF can render many different text formats including na , rtf , and any type of text file.
o In contrast, a sync file can only sync with specific file formats.
» Content Storage
o A FBTF doesn’t store any content of the underlying file’s data within Curio itself. It simply renders the contents of its
backing file. If that file is deleted or missing then Curio can’t render anything.
o In contrast, an item with a sync file stores its data within Curio and syncs those contents with the sync file. If the sync
file is lost or deleted then that’s okay.
+ Bidirectional or One Way
o A FBTF is essentially bidirectional as the file itself is the backing store for the text figure.
o In contrast, a sync file can be bidirectional, export only, or import only. The latter two options are useful if you only
want to export up-to-date contents to a remote file or if you only want an item within Curio to reflect the contents of
the remote file but not change it.

Working with Sync Files

Connecting to a Sync File

+ Option-drag a file into the idea space and Curio will ask if an appropriate figure should be created and sync with that file. For
example, Option-drag in a markdown file containing only a simple list and Curio will ask if a list, mind map, or stack
collection figure should be created and begin syncing with that file.

« Or right-click on an existing figure and choose to sync it with a new or chosen file.

o If syncing with a new file then Curio creates the file, immediately exports the figure to that file, and then begins
bidirectional sync.

o If you choose an existing file then Curio immediately imports that file, replacing the current contents of the figure,
and then begins bidirectional sync.

> You can also specify whether the sync is bidirectional, export only, or import only.

The sync file location is stored internally as an alias to the file. This means when Curio isn’t running, you can move or rename the
sync file and macOS should be able resolve the alias in most situations. If not, you can simply disconnect and re-connect manually.

Changing the Sync File Direction

+ Right-click on a the figure with the sync file and choose Bidirectional, Export Only, or Import Only.

Revealing the Sync File

* Right-click on a the figure with the sync file and choose Reveal in Finder.
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Sync File Formats

Disconnecting the Sync File

+ Right-click on a the figure with the sync file and choose Disconnect Sync File.

Finding Figures with Sync Files

+ Use Quick Find or the Search shelf to search for 4ueta/syncrile or choose Meta Misc > Has Sync File from the typing
button menu.

Undoing a Sync Change

« Curio records a sync import as an undoable change so if you don’t like how a list was updated after a sync import you can
just press #Z to undo it.

Sync File Finder Attributes

When you connect a figure with a sync file that file is given two Finder attributes. These attributes are automatically removed if you
disconnect the figure from the file.

The Curio Sync File Tag

The Curio Sync File Finder tag will be associated with the sync file.
With that tag in place you can find all Curio sync files on your machine:

+ Via a Spotlight query: tag:"curio sync File"
* Or the Finder’s File > Find (38F): Tags matches curio Sync File
* You can also save that query as a Finder Smart Search.

The Where From Attribute

The Where From Finder extended attribute will be set for that file to the curio://... link to the figure.

Then in the Finder you can select the file and choose File > Get Info (88l) and you will see that link in the More Info section. Right-
click on the link and choose Open Link to open that Curio project and jump directly to the figure.

With that extended attribute in place you can find all Curio sync files on your machine:

+ Via a Spotlight query: wherefrom:curio://

* Or the Finder’s File > Find (8F): where From begins with curio://

* You can also save that query as a Finder Smart Search.

« If want to find all sync files that jump to a specific project you can look for curio://projectname instead of just curio:// .

Sync File Formats

Curio syncs with file formats appropriate for the synced item:

* Text figures can sync with markdown ma files.
+ List, mind map, and stack collections can sync with lists in ma files, opm1 files, or taskpaper files.
* Table collections can sync with tables in ma files, csv files, or tsv files.
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Sync File Formats

Markdown is the preferred format as it offers several advantages:

+ Support for rich text attributes via markdown syntax.
« Support for images, such as images within list figures, although images embedded within a rich text figure are not
supported.

« Support for exporting and importing meta attributes such as checked/unchecked state, progress, start/due dates or
duration, tags, priority, rating, resources, and figure notes.

As a tip, if you want to add a web link to the markdown file, you can type the full weblink like https://zengobi.com , and Curio will
automatically turn that into a web link figure and export as a markdown link during the next sync.

Meta Details

As mentioned, generated markdown list items support meta attributes during export and import. Here are some additional notes:

« If the item has a markdown checkbox like [] or [x] and is O percent or 100% done then Curio does not output @progress|().
(force always output)

* Relatedly if in-between 0 and 100 Curio will still output [ ] and not [-] as that’s not a widely used standard. (force output
mixed)

+ @duration is output only if due=start+duration, likewise if @duration is there then @due is ignored and instead due is
computed via due=start+duration.

* Inline tags and resources, like #vacation tgeorge , remain as inline meta and the @tags() and @resources() meta attributes
are used for non-inline tag and resource associations.

* Importing a markdown footnote into a figure’s note is normally disabled but can be enabled as detailed in meta import.

Also csv and tsv supports this meta syntax as well.

Syncing Collections With Sync Files

Syncing a collection like a list or table with a sync file was a very high priority. But we we also wanted to make the resulting sync file
is as user-friendly, clean, and robust as possible with friendly image names and only embedding item identifiers if absolutely
necessary.

Markdown Images and Assets
During sync export, if Curio encounters an image or asset figure, an _assets folder is created and the asset file is copied to that

location.

1. If the file name already exists, like 1mage. pg , then the new image will be give a new name in sequence, like 1nage 2.jpg .
2. A manifest.plist file will be created withinthe assets folder to help map the internal asset ID with its exported name.
3. The generated markdown for this item will include an encoded ID as detailed below.
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curio://defaults-write?Export%20Markdown%20Checkboxed%20Show%20Progress=yes
curio://defaults-write?Export%20Markdown%20Mixed%20Supported=yes
curio://defaults-write?Export%20Markdown%20Mixed%20Supported=yes

Limitations

Markdown Image Size Formats

Standard Markdown doesn’t support image sizes but there are some popular markdown syntax extensions that Curio can support

via the Export Markdown Image Size Format setting:

* Resized export - the default — ! [fred] (fred.jpeq)
No size specification, the exported image is resized to the image figure’s displayed size on the idea space.

* Full size export — ! [fred] (fred.jpeg)
No size specification, the full size image is exported.

* Full size export but sized when rendered using Obsidian syntax — ! [fred|100] (fred.jpegq)

The full size image is exported but sized when rendered using Obsidian width syntax.
* Full size export but sized when rendered using Marked syntax — ! [fred] (fred.jpg =100x)

The full size image is exported but sized when rendered using Marked width syntax.

Markdown ldentifiers

During the sync import process the item’s contents are completely recreated based on the sync file. For example, a synced list will
be cleared and instantly re-filled based on the items within the sync file, as an undoable step.

Because of this Curio will sometimes encode a short identifier within a comment alongside an item. This is used for several
purposes such as re-establishing jumps to figures and re-connecting a figure to its underlying image asset file.

For example, a checklist item with an image may look like this:
- [ 1 '[Image|250](_Assets/Image.png) <!-—id:GnR-—>

That <!--id:enr--> is the comment, which is not visible when rendered by markdown renderers. The cnr short ID is used
internally to find the figure that previously existed within the list. An ID is only exported if Curio deems it necessary to re-establish

certain properties when reconstructing the contents during import.

Limitations

* During import the figure’s contents are completely recreated from the sync file. This means any overriding styles or
attributes made to individual items unsupported by the sync file format will be lost.

* You shouldn’t point mutiple collections to the same underlying sync file due to the possible use of identifiers, detailed
above, which can only work with a single owning collection figure.

Can you connect multiple text figures to the same sync file?

Technically yes, since there are no identifiers embedded within, however there’s a more robust way to do this. Instead of having
multiple text figures simultaneously monitoring and syncing with the same file use Curio’s synced figures feature:

1. Create a text figure that is synced with a file.

2. Copy that figure.

3. Edit > Paste As > Synced Figure Instance, as many times as you’d like, anywhere in the project. (As a tip: if you copy a
synced instance you can simply paste to create another synced instance.)
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HTML Export

That way you change any of the figures and they’ll sync with each other and the original figure will then sync back to the file.
Likewise if you make changes in the file then the original figure will sync import those changes and then update all of the synced
instances throughout your project. This means only one figure is monitoring and syncing with the file which is a more robust
solution.

HTML Export

When it’s time to share your ideas with coworkers, clients, or friends, you can export your idea spaces to HTML files which can be

viewed using a web browser.

The Resulting Output

The result is a single index.nhtm1 file in the specified folder along with contents and bpocuments subfolders. The former contains
full-size images and thumbnail images for each exported idea space. The latter contains any exported assets.

Curio uses an image and accompanying image map to represent each idea space so they will render correctly regardless of
platform, browser, installed fonts, etc. The image maps support jump actions between idea spaces, web link action URLs, and
exported asset files.

The default HTML template Curio uses for exporting works beautifully with the latest Safari, Chrome, Firefox, and Internet Explorer
browsers on both Mac and Windows platforms. Navigation controls appear when the mouse is moved or the device is tapped.
These same controls automatically hide after a few seconds of inactivity. You can also use the arrow keys to step through the
slideshow. The integrated popup navigator allows you to quickly choose a specific idea space in the hierarchy.

The resulting HTML also works perfectly with Safari on your iPad and iPhone devices. Use your fingers to pinch and zoom or pan
around larger idea spaces. Simply tap on an asset figure to open the asset itself. Tap anywhere to show the navigation controls.

If you’ve exported these idea spaces to the same location before, only the modified or new idea spaces and assets will be exported.
This significantly reduces the time it takes to update a previously exported project.

Publish Your Idea Spaces as an HTML Project

. Optionally select specific idea spaces in the Organizer that you wish to publish.
. Choose File > Export As > HTML.
. Click on Export All if you want to export all idea spaces, else click Export Selected to only export the selected idea spaces.

N O R A R

. Choose a location to export the idea spaces. Since exporting to HTML will result in creating multiple files it’s best to create a
new folder for the exported files.

(&)

. Choose the template to use.

6. Choose the image type and select whether idea spaces should be scaled to a max width. For JPEG files, you can also
choose the quality of the resulting images. The better the quality, the larger the file size.

7. Click Export.

Customizing HTML Templates

1. To create your own HTML template for exporting, check out the bundled HTML templates which can be found within the app
itself: /applications/Curio.app/Contents/Resources/Repository/HTML Export Templates .

2. Copy one of the bundled templates to help you get started. Open the index.nhtm1 file in your favorite text editor and check
out the code. Note variables that start with {curio which are dynamically replaced when the template is exported with data.
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Keynote Export

Currently we’re only using two: {curio project_title} and {curio_slides array} . Ihe former is replaced with the project
title, the latter with a big JavaScript array of the resulting slides.

. Now to really understand how this works, do a Curio HTML export of a simple project and check out the resulting exported

index.html file. See how the project title is replaced and the array of slides is generated?

. For your copy of the index.ntm1 template file you can change something simple, such as the CSS style information at the

very top of the file. Or perhaps you want to dig deep and modify both the CSS and JavaScript. It’s all in this index.html
and you can do whatever you want with the output arrays.

. When you’re ready to test out your template you need to place it into a specific folder so Curio can find it. Look in your -/

Library/Application Support/Curio/Version XX/Repository folder and create a new folder inside called “HTML EXpOFt
Templates”. Then, within that folder, create a subfolder and call it something that will identify your new template such as
“Awesome Export”. Then place your custom index.nhtml file into that subfolder.

. When you restart Curio, the HTML Export dialog will find your custom folder and allow you to choose one of your custom

templates.

. As a note, we store the templates with that Repository subfolder because you could share a repository with your entire

company or school.

Keynote Export

While Curio doesn’t support a direct export to Keynote, you can easily create a Keynote presentation using exported images.

Export Your Idea Spaces to Keynote

1.

In Curio, click the Share toolbar button then choose Export As > Image. Choose to export JPG images and also create a new
folder for the output. This is also where you might want to specify a scaled size for each exported image. Then click the
Export button to fill your new folder with image versions of your idea spaces.

. Launch Keynote and choose the White theme and an appropriate slide size in the window that appears when it launches.
. In the Finder, select all of the images that Curio exported and drag-and-drop them to the Slides area on the left side of the

Keynote window. Drop them just above that initial blank slide that Keynote automatically created for you.

. Click on the first slide in the Slides area and then choose Edit > Select All to select all the slides and then click the Change

Master button in the Format inspector and choose Blank.

. Scroll down to the very bottom of the Slides area and select the last slide, which is that initial blank slide auto-created by

Keynote, and press the Delete key to remove it.

PowerPoint Export

While Curio doesn’t support a direct export to PowerPoint, we can use an Automator helper script to assist with the process.

Previously we were able to use an Automator helper script to do this. However, it looks like Apple’s sandboxing restrictions make

this a pain because PowerPoint has to ask you to grant access to every imported image! If you have 100 slides then it’d ask you 100

times for permission!

So, in lieu of that, until they can get this resolved, use this workaround:

1

. Follow the 5 steps on the previous idea space to export your Curio project as a Keynote slideshow.

2. Use Keynote to export as PowerPoint.
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Presentations

That’s it!

Hopefully Microsoft can adjust their Create PowerPoint Picture Slide Shows Automator action to support selecting a folder instead
of multiple files and then you’d only have to grant permission once. But in the meantime you’ll need to go through Keynote.

Presentations

You can show your idea spaces on your computer’s display, or use a projector to share it with a large group. Curio’s integrated

presentation mode with custom transitions is perfect for group brainstorming sessions.

Begin the Presentation

Begin by clicking the Presentation toolbar button, the View > Begin Presentation menu, or using the Share toolbar button.

Begin the Presentation in Window

Choose the View > Begin Presentation in Window menu to begin the presentation in a separate, resizable window, instead of taking
over your entire screen. This is useful if sharing a window with others via Zoom or other conferencing software.

Tip
If you right-click on the toolbar you will find an optional Present in Window toolbar button that you can drag into your toolbar if
you use this feature frequently.

End the Presentation

Press the Escape key.

Context Menu

Right-click on the idea space to show the presentation mode context menu.
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Presenting to an iPad via Sidecar

T First
1 Previous
4 Next
L Last

< Backward

- Forward
& Exit Presentation

v Layer 1
Layer 2

There you can switch to a different active layer, perhaps to select figures on that layer, or toggle the visibility of a layer. Choosing an
already active layer will hide it, choosing one that isn’t active but hidden will make it active and visible. The visibility toggles only
persist while showing that slide. Moving forward or back, or restarting the slideshow will restore visibility to their normal values.

Presenting to an iPad via Sidecar

Apple’s Sidecar feature allows you to present from Curio directly to your iPad! Some tips:

1. Make sure you have the combination of Mac and iPad that work with the Sidecar feature.

2. Use the AirPlay/Sidecar icon menu bar control to connect to your iPad.

3. From that same menu set “Use As Separate Display”.

4. In Curio’s Settings, under the Presentation icon, make sure “Show on secondary display (when connected)” is checked.
5. Begin your presentation in Curio and it will then appear on your iPad’s screen.

Curio’s presentation mode Touch Bar controls will appear on the bottom of the iPad display so you can easily navigate through the

slides by tapping:

If you don’t see them then make sure they are not hidden via the AirPlay/Sidecar menu bar menu.

You can tap on figures within the idea space during presentation mode to expand/collapse collections or highlight items, however
you have to use your Apple Pencil to do this, not your finger.

Note

You can use Sidecar’s “mirror display” instead of “separate display”, and then uncheck the “show on secondary display” option
in Curio’s Settings. However, there seems to be a common macOS bug for some combinations of Mac model, macOS version,
iPad model, and iPadOS version that can result in Touch Bar controls being unresponsive to taps.
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Working with Other Apps

Keyboard Shortcuts

If you’d like to work with apps such as EpicPen and sketch on top of a presentation using the Pencil via Sidecar, then we’ve noticed

that a presentation in a window filled to the screen size works more reliably that an actual full-screen presentation.

In Curio’s Settings, under the Presentation icon, make sure “Present in window fills secondary display (when connected)” is

checked. Then when you begin a presentation in a window, Curio will make sure that window is on the secondary display — your

iPad display via Sidecar — and fills the screen.
You can then use EpicPen’s tool palette:

+ Use EpicPen’s pointer tool to select figures in Curio and use the Touch Bar controls to skip through slides.
» Use EpicPen’s brush tool to draw on the screen using their brushes.

Keyboard Shortcuts

Action

End Presentation

Next idea space

Previous idea space

First idea space

Last idea space

Back in history

Forward in history
Toggle scaling on and off
Zoom Out (experimental)

Zoom In (experimental)

Zoom Actual Size (experimental)

Select a figure

Toggle the expand/collapse of a selected mind

map branch.

Toggle the expand/collapse of a branch and

its children.

Toggle the expand/collapse all branches at

this level.

Open a figure’s asset or perform the figure’s

action
Set a rating

Scroll the idea space

Key

Esc

Right Arrow, Down Arrow, Page Down, Spacebar, Swipe Down (see
gesture handling notes below)

Left Arrow, Up Arrow, Page Up, Swipe Up (see gesture handling notes
below)

Home

End

[, Backspace, Cmd-Left Arrow, Swipe Left
], Cmd-Right Arrow, Swipe Right

S

,or<

.or>

/

Click (when pointer is visible)

Quick Spacebar Tap

Quick ~=Spacebar Tap

Quick {rSpacebar Tap

Double-Click (when pointer is visible)

0 through 5 (when a figure is selected)

Click and drag the background (when pointer is visible)
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Gestures

Gestures

While presenting, the following gestures can be performed on a trackpad:

» Smart Zoom (if enabled in System Settings > Mouse/Trackpad) allows you to double-tap to zoom and restore. This can be

customized via advanced settings.

+ Pinch/expand enables or disables scaling.
« 3-finger swipe up/down goes to the previous/next Organizer item.
- 3-finger swipe left/right goes backwards/forwards in history.

Note that you’ll need to make a change in System Settings > Trackpad > More Gestures so that Curio can actually receive 3-finger

swipes, otherwise the Mac’s system receives them instead.
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Continuity

Continuity

Recent macOS releases have introduced a series of “Continuity” features allowing you to use your iOS device with your Mac. Many
of these features are useful with Curio!

There are lots of specifics including Mac and iOS device compatibility plus Bluetooth and Wi-Fi requirements found in the links
below.

Continuity Camera

Introduced with macOS Mojave, Continuity Camera is a fast way to take a photo directly into Curio.

Via Curio’s Insert main menu or the right-click idea space context menu you can choose Take Photo with your iPhone or iPad, take
the picture using that device, and it will appear, almost magically, as an image figure in your idea space.

Alternatively, you can choose Scan Documents instead, which converts the captured photo into a PDF, which is then plopped into
your idea space. In macOS Big Sur, Continuity Camera gains an enhanced scanning features for clearer scans and automatic

cropping.

Continuity Sketch

Introduced with macOS Catalina, Continuity Sketch is another useful service.

Via the same Insert or right-click context menu, you can choose Add Sketch, then sketch out an idea using your iPhone or iPad.
With an iPad you can use your nifty Apple Pencil if you have one. When you tap Done the result is instantly dropped into your idea
space as an image figure.

Continuity Markup

Introduced with macOS Catalina, Continuity Markup is very useful if you work on PDF documents.

However one key limitation is that it only works with Quick Look from the Finder.

1. To do this with a PDF in Curio you have to perform a quick initial first step: right-click on the PDF figure in Curio and choose
Reveal in Finder.

2. Then in the Finder you can press Spacebar to bring up Quick Look, tap the Markup button, then the Annotate button to
choose your device.

3. Now you can add highlights, draw arrows, sketch notes, type text, add a signature, and more!

4. As you work the changes appear live within the Quick Look preview on the Mac.

5. When you tap Done on your iOS device, then Done in the Quick Look window, then switch back to Curio, your PDF image
figure will automatically refresh to show those new annotations.

Sidecar

Introduced with macOS Catalina, Sidecar allows your iPad+Pencil to mimic a high-end pressure-sensitive graphics tablet such as a

Wacom tablet.

This feature allows you to use your iPad+Pencil to sketch directly into your Curio notebook using Curio’s scribble mode. As far as

Curio’s concerned, it thinks you’ve plugged a graphics tablet directly into your Mac.
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Project Backups

Project Backups

We have thousands of Curio customers around the world who use Curio for their important notebooks: work projects, personal
projects, client designs, doctoral dissertations, class notes, and much, much more. We couldn’t be more thrilled and proud at what
you’re able to create and achieve with Curio.

With such important data please be sure to create project backups. Accidents happen, laptops are dropped or stolen, lightning can
strike, bugs exist, and disk drives do die. Backups are easy to do, take only 5 minutes to implement, and are quite inexpensive for
the peace of mind they provide. Please check out one or more of the options below.

Curio Automatic Backups

We encourage all customers to take advantage of Curio’s built-in support for automatic backups. After setup, projects located within

the specified Projects folder are automatically backed up to the specified Backups folder.

Curio PDF Mirroring

Curio supports a feature called PDF Mirror which will create an automatic, cross-platform PDF representation of your entire project
and store it in a specified destination folder. This special publishing feature can even optionally include all embedded and aliased
assets.

Time Machine

For years macOS has supported a wonderfully integrated backup solution called Time Machine. Every hour all your important
documents and applications are backed up to an external drive which is useful if your primary drive dies.

Whole Disk Backups

You can also implement a whole-disk backup plan with either Carbon Copy Cloner or SuperDuper. Either application can create a

bootable backup disk on an external drive which gives you an exact, up-to-date copy of your internal drive.

Cloud Backups

A remote, cloud backup service is inexpensive and easy to configure, for example BackBlaze.

Sync Services

A syncing service such as iCloud Drive, Dropbox, or Google Drive can be useful as well.

Please note that these are syncing services, not backups, so if you delete a project or if a project is corrupted on one machine they
will sync the deletion or corruption to your other machines.

If you intend to store your projects on a synced folder then we strongly encourage you to view these tips.

One technique that you may want to consider is storing your projects locally but setting Curio’s folder for automatic backups,
described above, to a location on a synced service. For example, your projects folder could be ~/pocuments/curio and your
backups could be set to ~/propbox/curio .
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Cloud Syncing

Cloud Syncing

You can use cloud sync services, such as Dropbox and iCloud, to sync your Curio project files between your machines. However,
it’s very important to follow the guidelines below to minimize the chance of conflicts or partial syncs.

Summary
We recommend keeping your entire Curio projects folder or specific individual project files synced and downloaded on your
machine by using one of the following:
+ iCloud: Right-click on the projects folder or project file and choose Keep Downloaded (on macOS Sequoia 15 and
above) or Download Now (on earlier macOS releases).
* Dropbox: Right-click and choose Make Available Offline. You may also want to change the Dropbox Settings so new
files are always available offline by default.

* OneDrive: Right-click and choose Always Keep on This Device.
* Google Drive: Right-click and choose Available Offline.

Most importantly make sure to give projects time to upload before disconnecting your Mac from the network, and time to

download before opening Curio on your other Mac. The sync icons in the Finder help tremendously. More details below.

Backgrounder

First some definitions to provide more details on how syncing works.

Sync Services

By far the most popular sync services used by Curio customers are iCloud and Dropbox. However, there many other popular
options such as Google Drive, Microsoft OneDrive, and Box Sync, which customers may use to sync their files between machines.

These services work by watching for local file changes and then silently uploading those changes to their cloud servers. They will
also receive notifications from the cloud when file changes are detected there, perhaps from one of your other machines, so the files
can be downloaded to your local machine.

If a problem occurs during this process or if changes are made on multiple computers between syncs then the result is a conflict,
where the service can’t determine how the file should be reconstructed locally.

Curio Package Files

A Curio project file is technically a macOS package file. It may look like normal file, however it’s actually a special kind of folder
containing dozens, hundreds, or even thousands of files and subfolders. Everything contained in your project is organized neatly
within this hidden file hierarchy.

You can carefully explore within a Curio project package by right-clicking on a Curio project file in the Finder and choosing Show
Package Contents to see what’s inside. Just be sure not to change any files you find within.

When considering syncing, this means that all of these files in your project package need to be completely synced when changes
are made. Most operations, such as editing a text figure, or deleting an idea space, might only impact a couple of files within the
project package hierarchy.
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Avoiding Sync Issues

Important

If the entire sync doesn’t complete then you could end up with a mix of old and new internal project files. This can lead to
problems when you then try to download those changes on a different machine. In a worse case scenario Curio could be
unable to open the corrupted project.

Project Lock File

Curio Pro can automatically set up a project lock file alongside your project file when it detects the project is being stored on a
synced service to ensure that more than one person doesn’t attempt to make changes to the project at the same time. You can also
manually enable or disable this feature for specific projects.

Project Password?

If Curio is unable to open a project it assumes the project is encrypted so asks for a project password to decrypt it. However, this
password dialog may also appear for non-encrypted projects if they have been corrupted due to partial sync!

If this happens, force a download and then open the project.

Avoiding Sync Issues

Fortunately there are some steps you can follow to minimize the chance of lost content due to incomplete syncs.

Warning
The key is to make sure everything completely uploads and downloads with the syncing service before disconnecting from the
internet or opening the project. You do not want a partial upload or download sync or corruption can occur.

On Machine #1

1. Make sure to quit Curio so all changes are saved and committed to disk.

2. Allow your sync service time to synchronize changes to the cloud before disconnecting from the Internet. For Dropbox,
simply wait for its icon in the menu bar to stop animating. For iCloud, you can open a Finder window and see if the iCloud
Drive sidebar item has an animating sync icon or if the status text indicates that changes are uploading. Essentially don’t
immediately disconnect from the Internet, give your Mac a few moments to finish the sync.

Note that if you have a large number of changes or added large assets to your project then it may take a few seconds for those
changes to sync up the cloud.

On Machine #2

1. Login and connect to the Internet.

2. Allow your sync service time to synchronize changes from the cloud before launching Curio. This means waiting for that
animating icon to finish. It is very important to wait for all changes to sync down before opening your project.

3. Launch Curio and open your project.

- 339/423 - Copyright © 2025 Zengobi, Inc.



Sync Indicators

Sync Indicators

Most cloud services have handy indicators which can let you know when it’s syncing files between your local drive and the cloud, so

you can wait until the sync is completely finished before disconnecting from the network or launching Curio.

iCloud Sync Indicators

Learn more about iCloud syncing and their icons.

When a file is only in the cloud and not on your local hard disk...

* The icon next to the file looks like this: C¢5
When iCloud is syncing...

’

* When a file begins syncing the icon looks like this: @
* And the iCloud Drive item in the Finder sidebar will show an animating icon: @ iCIOUd Drive O

+ And the Finder status bar (View > Show Status Bar) will show you additional details:
1 of 10 selected, 46.54 GB available on iCloud, uploading 1 item

When iCloud has finished syncing...

- The icon next to the file that has finished syncing looks like this: ¢
* Or, if you are using the right-click Keep Downloaded introduced in macOS Sequoia 15, like this: 0

+ If a file could not be synced the file icon will look like this: &
« If you've run out of storage space on your iCloud the file icon will look like this: @

Dropbox Sync Indicators

Learn more about Dropbox syncing and their icons.

When a file is only in the cloud and not on your local hard disk...
* The icon next to the file looks like this: <¢5
When Dropbox is syncing...

* When a file begins syncing the icon looks like this: @

° And the Dropbox menu bar icon will show an animating icon: 3‘6
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OneDrive Sync Indicators

When Dropbox has finished syncing...

* The icon next to the file that has finished syncing looks like this: 0
* And the Dropbox menu bar icon stops animating and looks like this: 3’3

« If there was an error syncing the file icon will look like this: @

OneDrive Sync Indicators

More information about OneDrive’s icons can be found here.

Google Drive Sync Indicators

More information about Google Drive syncing can be found here with details on where they show sync status information.

Offloaded Files

Many sync services support offloaded files where the file or folder existing primarily in the cloud and is only downloaded to your

local computer when you try to access it.

Examples include:

* iCloud Optimized Mac Storage

* Dropbox Smart Sync

* OneDrive Files On-Demand (more details).

* Google Drive File Stream

These sync services will usually indicate this offloaded status with a little cloud icon next to the file name in the Finder, like
Dropbox’s & icon and iCloud’s ¢7) icon.

Problems with Offloaded Files

Generally this is considered a space-saving feature so that older content is automatically removed if you haven’t needed it in a
while. However, it can cause problems if you go to access that data and either don’t have access to the internet at the moment, or
the content requires a long time to download.

Since Curio’s project package files are technically directory hierarchies, if a sync service decided to offload items within the
hierarchy then that could cause corruption problems.

Force Download

Important
We strongly encourage you to make sure an entire project is downloaded locally before attempting to open it!
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No Sync

To force the service to download a Curio project file you can follow these steps:

+ iCloud: Right-click on the projects folder or project file and choose Keep Downloaded (on macOS Sequoia 15 and above) or
Download Now (on earlier macOS releases).
» Dropbox: Right-click and choose Make Available Offline. You may also want to change the Dropbox Settings so new files

are always available offline by default.
+ OneDrive: Right-click and choose Always Keep on This Device.
» Google Drive: Right-click and choose Available Offline.

The cloud service will download the project file and then you can double-click to open it in Curio.
Alternatively you can simply drag-and-drop the Curio project file to a folder which is not synced such as your Downloads folder.

For Dropbox, we would also recommend using their Settings and setting

No Sync

You can actually direct both iCloud and Dropbox to not sync a specific folder, even if located in normally synced folder hierarchy,

like iCloud’s ~/pocuments folder or Dropbox’s ~/propbox folder. Perhaps you want to make this change temporarily, because
you’re going on a trip, or you wish to turn it off permanently.

« For iCloud, you can rename the folder so it has a .nosync extension such as ~/pocuments/curio.nosync and iCloud will no
longer sync its contents. You can even use this trick to avoid syncing a specific file such as vacation.curio tO
Vacation.nosync.curio .

+ For Dropbox, go into its Settings > Selective Sync and uncheck the folder.

Of course, if you really wish to make this a permanent change then simply drag your curio project documents folder elsewhere,
such as right off the home folder: ~/curio .

Sync Service Limitations

Some cloud services have limitations which may cause issues.

iCloud Drive Limitations

If you use iCloud Drive to share macOS folders or files with other colleagues then if those other users delete a file or folder, they are
instantly removed without going into the Trash or iCloud Drive’s Recently Deleted folder. There is no way to bring them back.

This means if a friend inadvertently deletes one of your shared Curio projects then it cannot be recovered so it is imperative that you
keep separate backups just in case.
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Dropbox Limitations

Dropbox Limitations

At the time of this writing, Dropbox has some limitations that could impact Curio projects:

- Dropbox files and folder names can’t include several different characters including\/ < >:"|? *. or any emojis.

« This could cause a problem if you have, for instance, an idea space title with a vertical bar ‘|’ in it, thus the underlying asset
file would have the same character, and Dropbox will balk at it.

+ Likewise if you drag a file into Curio that has one of those characters in its file name then if your Dropbox is synced with
Dropbox then it could cause errors.

« Curio filters out many “bad” characters from idea space asset file names (\/ < >:” ? * %), but the vertical bar ‘| and emojis
aren’t filtered.

OneDrive Limitations

At the time of this writing, OneDrive has some limitations that could impact Curio projects:

+ OneDrive files and folder names can’t include several different characters including\/<>:"|? *.

- This could cause a problem if you have, for instance, an idea space title with a vertical bar ‘|’ in it, thus the underlying asset
file would have the same character, and OneDrive will balk at it.

« Likewise if you drag a file into Curio that has one of those characters in its file name then if your OneDrive is synced with
OneDrive then it could cause errors.

- Curio filters out many “bad” characters from idea space asset file names (\/ < >:” ? * % ), but the vertical bar ‘| isn’t
filtered.

» OneDrive has a max path length of 400 characters. That sounds like a lot but if you put a Curio project in a deeply nested
subfolder with lots of long folder names, and Curio itself creates files with long 36-character unique ID’s then you could
sneak up on it.

In short, be very careful if using OneDrive.

Box Drive Limitations

While older versions of Box Drive did not support Mac package files, the latest Box Drive now supports Mac package files on

macOS Big Sur and beyond, thus should now support Curio’s project file format. Make sure you’re on the latest version of Box Drive
to ensure maximum compatibility.

Synology Cloud Station Limitations

Synology Cloud Stations do not support macOS aliases so if you create an alias to a file within your idea space, the alias will be

broken when Synology syncs the file.
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Settings

Settings

Curio’s settings can be found via the Curio > Settings menu (was previously called Curio > Preferences).

Tip
In addition to these basic settings there are scores of advanced settings which you can find via the Help > Curio Advanced
Settings menu item!

General

Appearance

Curio’s window chrome, toolbar, inspectors, shelf, Organizer and other interface elements can dynamically change their appearance
based on the dark mode setting in System Settings > General. You can however, override the system setting here within Curio’s
Settings and force a light or dark appearance.

Important
Your idea space content will still abide by the specified coloring and styles set for your idea spaces and figures. Those styles
won't invert or change on-the-fly based on the dark mode setting

Themes

In addition to the simple dark and light mode toggle, Curio includes support for appearance themes, allowing you to change the
look of the Curio user interface even further.

100% v

' Getting Started
B samples
I§ Journal
W Archive

[ vocome oo
|.] Table of Contents

About This Project

In the same appearance popup button allowing you to choose dark or light mode, you will find several color themes that come
bundled with Curio. Change the interface to a palette of blues, bright shades of yellow, or dark shades of black for midnight
workaholics.

Customizing Themes

Curio Professional kicks it up a notch, allowing you to create your own custom themes by combining display properties such as
dark mode; window, Organizer, inspector bar, and shelf background coloring; Organizer text coloring; and even idea space content
background coloring!
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Appearance

How it Works

Curio’s theme support takes advantage of the native macOS light and dark mode automatic coloring, including support for
appropriate text font colors.

For example, you might create a theme that starts with a dark mode style, then replaces the default dark gray coloring with a dark
blue coloring instead. You get the automatic inversion of text colors, thanks to macOS dark mode, combined with custom
background coloring.

Alternatively, begin with a light mode style, then change certain backgrounds to lighter pastels that work with the light mode’s text
coloring.

Creating a Theme

Begin by choosing an interface element or property to modify from the first popup. Many of these are hierarchical in nature so
properties can be inherited.

For example you can choose the dark element and that allows you to toggle the window’s dark mode setting, including any views
within that window. Or you can choose dark.organizer and that allows you to toggle just the dark mode setting for the Organizer

view.

Similarly the ri11 property controls the background fill of the window and all views found within, while fi11.sheif controls the
background fill of just the Shelf.

Depending on the property that you’re changing you will either see a checkbox or color control appear alongside. For example, dar
x is a toggle thus you’ll see a checkbox, while ri11 will show a color control so you can choose a background color.

To get rid of a specified value, set a checkbox to mixed (not unchecked or checked; it has a dash through it) or a color to
transparent. That property will then revert to its default or inherited value.

Content Background Color

Like Pages, Keynote, and other content authorizing apps, Curio’s idea space content does not change based on light/dark mode
setting. Its background is white, by default, with black text coloring, unless overridden by Curio’s many styles.

The rfi1l.content property is unique as we wanted to make sure our themes did not inadvertently impact the visibility of your idea
space content, therefore it does not inherit the global fi11 property.

Since content text coloring will not change dynamically, if you wish to customize fi11.content you should choose a light color that
works well with your content.

Note this background coloring replaces the default white coloring only when viewing content for editing, but not when printing,
exporting, or presenting.

And of course if your idea space background has a color or image set via its style or inspector controls then that color is used
instead.

Saving a Theme

Click the Save button to save a theme with a specified name. If a current theme is active then its name will be suggested as the
name for the new theme allowing you to easily edit and update existing themes.
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App Icon

Delete a Theme

Click the Delete button to delete the current custom theme.

Limitations

Curio’s themes were designed to complement, not replace, the native macOS light/dark modes, as we suspect Apple will release
more appearance modes in the future. So some potential features, such as fine-grained color selections, are not offered.

Also note that dialogs, alerts, popup inspectors, popovers, and others simply abide by the dark mode setting. Only the colors of
the main Curio projects windows and some views within can be customized.

App Icon

This is a fun perk only for Curio sustainers who we sincerely thank for their ongoing support of Curio’s development! ¢
Add some energy to your workflow with a custom icon for your Curio app!

Choose a new icon from the popup and Curio’s app icon will update on the Dock while the app is running and, if possible, its icon
on disk will also change.

Again, this is just a fun perk for Curio sustainers akin to the free tote bag sent by your local public radio station to its sustainers.

Technical

Changing the icon on disk will only work for non-Mac App Store versions of Curio and only if we have write access to the app
itself. This generally means you’re an administrator user on the Mac and it’s installed in the Applications folder, not simply in the
Downloads folder.

Mac App Store Restriction
Sandboxing restrictions prevent us from changing the app icon on disk so the custom icon only appears in the Dock while
Curio is running.

Product Updates

Curio downloaded from the Zengobi website periodically checks in with Zengobi’s server to see if there are any app updates
available, given your license’s free updates end date.

You can optionally sign up for early access beta preview releases if you want to get an insiders peek of what new features are being
developed. These early beta releases may have some bugs, so project backups are a must, but it’s a great way to check out new
functionality and provide early feedback before the official release.

Of course, if your license’s end date for free updates is before the expected release date of an upcoming release, then you will not
have early access to it until you are able to purchase an upgrade to extend your license with another year of free updates.
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Default Projects Folder

Mac App Store Restriction
Updates for Curio obtained from the Mac App Store are handled by macOS. Due to that restriction, you will only have access
to the normal release stream of updates, not the early access previews.

Default Projects Folder

Specify a default folder used when saving Curio projects. The default is ~/pocuments/curio .

Mac App Store Restriction
Sandboxed Curio is unable to automatically set a default projects folder so you must specify it manually by clicking the Choose
button. Note that Curio will have access to all files in the folder you choose.

If you have Curio Professional, then certain advanced feature like external asset libraries and project lock files are only
supported in this default projects folder because Curio needs full access to the files in the folder to support these features.

Backups

Curio can make automatic backups of your Curio projects! This feature can be enabled in the Settings window, where you can also
specify the frequency of the backups and the location where the backups are placed.

If this is enabled then any projects opened from the specified Projects folder will be automatically backed up to the specified
Backups folder.

In addition, you can optionally enable backing up projects in any location, not just the Projects folder.

During project load Curio will see if the backup needs to be refreshed and, if so, copy the current project to the backup folder.

Important
A project backup is only made during project open, not while running. So backups are not created if you’ve left Curio open with
the project loaded for multiple days.

Location of the Backups
By default the backups are stored within a Backups subfolder created under the specified Projects folder. The default Projects folder

iS ~/Documents/curio therefore the resulting default Backups folder is ~/pocuments/cCurio/Backups .

However, you can tell Curio to use a specific backup folder if you wish. This may be handy if you wish to create backups in a very
different location, like a Dropbox folder, for instance.

Per Project Override

Curio Professional customers can override the backup settings for a particular project via its project properties inspector. For
instance, you might have a particularly large project that only needs a backup every 7 days. Or perhaps you have automatic
backups disabled and instead you enable it only for specific projects, even those not located in the standard Projects folder.
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Repositories

Application Support and Personal Repository Folders
Curio will now automatically make periodic backups of its application support and personal repository folders, to ensure the safety

of your styles, stencils, templates, project lists, custom Sleuth sites, saved searches, and much more.

By default this will occur every 5 days although you can change this frequency via the Backup App Support Frequency advanced
setting (see the Help > Curio Advanced Settings menu item). If set to 0 then no backups will occur.

Assuming you’re using the default ~/Library/Application Support/Curio/Version XX location then the backup will be named -~/

Library/Application Support/Curio/Version XX Backup .

If you have overridden the application support folder location and/or personal repository folder, using their respective advanced
settings, then Curio will still make sure those folders are backed up, as well.

Mac App Store Restriction
Sandboxed Curio is unable to set a default project backups folder so you must specify it manually by clicking the Choose
button. Note that Curio will have access to all files in the folder you choose.

Repositories

Curio supports a powerful, extensible shared repository system.

A repository is a folder structure that contains resources such as project templates, idea space templates & styles, figure stencils &
styles, color swatches, external document templates (for Insert > Instant Document), HTML export templates, and Sleuth modules.

Curio includes a bundled repository and your personal repository is automatically created in ~/Library/Application Support/Curio/
Version XX/Repository as you create and save personal styles and templates.

Copying your repository to a publicly available server, such as a using a public Dropbox folder or a network file server, allows you to
share your resources with others. They simply need to add an entry pointing to that repository in their Settings window, re-launch
Curio, and all of your styles and templates will appear in the appropriate galleries and popups.

Adding a Repository

1. Click the plus button to add a new repository.

2. Select a repository and press the Delete key to delete it.

3. Double-click a repository to edit its path.

4. Rearrange the order of the list repositories via drag-and-drop.

5. Clicking the Reveal button will display the repository in a Finder window.
6. All changes to the repositories require a relaunch to take effect.

Presentation

To customize the operation of Curio Professional’s presentation mode you can use the options here.
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Presentation

Scaling Options

Choose whether the idea spaces should be scaled to fit the screen, or if scroll bars should appears as needed to scroll around the
window. If the mouse pointer is visible then you can click anywhere in the idea space to scroll around, as well. You can toggle this
on-the-fly during the presentation by pressing the S key.

Check “Use minimum idea space bounds” if the unused bottom and right portions of the idea space should be cropped off when
the idea space is displayed. If unchecked, then the entire idea space is displayed including unused portions.

When Done Options

Check “Exit presentation after last slide” if the presentation should immediately end if you try to progress past the last slide,
otherwise the presentation will remain on the last slide.

Selection Options

Click the color well to change the selection color that is used to highlight any selected figures (note that the pointer must be visible
to select figures).

Transition Options

You can specify a default transition to use between idea spaces during the presentation. This can be overridden for specific idea
spaces using the idea space’s Transition inspector.

Advanced Options

Curio can automatically pre-collapse mind maps before displaying an idea space in a slideshow presentation. If this would be of
interest to you check out the Presentation PreCollapse Mind Maps setting via Curio’s Help > Curio Advanced Settings menu.
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Advanced Settings

Advanced Settings

Curio’s default settings should be fine for most customers; however, for you power-users out there, Curio has a number of advanced
settings you can explore.

Note
These settings are very fluid and may change in functionality over time.

Important
Most preference settings may require a Curio relaunch before they take effect! 5

How to Change Advanced Settings

1. Via the Curio > Change Advanced Setting Menu (Recommended)

Within Curio, choose the Curio > Change Advanced Setting. You can enter the key you wish to change, like General Open
Previous Project, and its new value, like no. Optionally you can just enter the key and then click to restore its default setting.
Clicking the help button in the top-right corner will bring you to this page in the online documentation.

2. Via Curio Using Clickable Links
Curio supports a special URL scheme for changing or deleting settings. For example:
curio://defaults-write?General Open Previous Project=no

For each setting below, alongside each defauits command you'll find a & link icon which will perform the link version of
that setting.

After clicking that link, your browser may ask you to confirm that you want to launch Curio. Click allow, and Curio will then
show the setting in the same Change Advanced Setting dialog mentioned above, and give you a change to modify the
setting’s new value or reset it to the default value.

3. Via the defaults Terminal Command

Quit Curio, then launch Applications > Utilities > Terminal. In the Terminal window that appears you can copy/paste or type a
series of commands to change or delete a default preference.

To change a setting use the defaults write command:

defaults write com.zengobi.curio "General Open Previous Project" -bool no
A value can be a whole integer number ( -int ), boolean ( -boo1 ), floating point number ( -f10at ), or string ( -string ).
To delete an overridden setting you use the defaults delete command:

defaults delete com.zengobi.curio "General Open Previous Project"
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General

To delete all Curio settings do the following, which will reset Curio to a true, default state.
defaults delete com.zengobi.curio

Potential Issues With defaults

If you’ve ever installed Curio from the Zengobi website and Curio from the Mac App Store then the defaults command can
sometimes get confused. It doesn’t know which preferences you want to change, although seems to prioritize the settings
associated with the sandboxed, Mac App Store Curio, even if you’'ve deleted that version of Curio!

The easiest workaround is to simply use the Change Advanced Setting menu instead, but if you really want to use defaults you
have to tell it which preferences to change:

For Curio from the Zengobi Website (non-sandboxed)

defaults write ~/Library/Preferences/com.zengobi.curio "General Open Previous Project" -bool no

For Curio from the Mac App Store (sandboxed)

defaults write ~/Library/Containers/com.zengobi.curio/Data/Library/Preferences/com.zengobi.curio.plist "General Open Previous

General
Open Untitled

You can prevent Curio from opening a new, untitled project on start-up by changing this setting.

defaults write com.zengobi.curio "General Open Untitled" -bool no Q

Open Previous Project

You can tell Curio to not open previously projects, assuming system-wide window restoration is not enabled in System Settings >
General, by changing this setting.

defaults write com.zengobi.curio "General Open Previous Project" -bool no Q

Center Contents

Normally Curio centers all idea spaces and other Organizer documents in the main content area. If you’d like them placed towards
the top-left corner instead change this setting.

defaults write com.zengobi.curio "Center Contents" -bool no Q
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curio://defaults-write?General%20Open%20Untitled=no
curio://defaults-write?General%20Open%20Previous%20Project=no
curio://defaults-write?Center%20Contents=no

Disable Scroll Elasticity

Disable Scroll Elasticity

Normally Curio will show a bounce back effect when you scroll beyond the bounds of your idea space. If you wish you can turn this
off this setting.

defaults write com.zengobi.curio "Disable Scroll Elasticity" -bool yes éz

Project Auto Lockfile Prefixes

When opening a project file located in a specific tree hierarchy, Curio can automatically use a lock file as necessary to ensure that
only a single person has write access to the file at a time. The following setting can be used to specify a semicolon delimited list of
path prefixes that require lock files.

defaults write com.zengobi.curio "Project Auto Lockfile Prefixes" -string "~/Dropbox/;~/SyncService/" g?

Projects Button Open QuickPick

Normally clicking the Projects toolbar button will show the open project quick pick list, and holding Option while clicking will show
the open project gallery. However, you can reverse this mapping with this setting.

defaults write com.zengobi.curio "Projects Button Open QuickPick" -bool no §2

Project Gallery Add Categories Via Finder Tags Scope

In the Project Gallery, if you right-click in the left sidebar and choose Add Categories Via Finder Tags Curio will use Spotlight to scan
forall .curio projects that it can find and use their Finder tags, like curio active , to create Project Gallery categories, like activ

e .
You can restrict the scope of this scan with some options:

* nome Will only search the user’s home folder hierarchy.
+ computer Will search all local mounted volumes + user home (even if remote).
« path will search only the given path (like /users/gbrowning/Documents ).

defaults write com.zengobi.curio "Project Gallery Add Categories Via Finder Tags Scope" -string "home" §2

Use Old Image Pasteboard Types

Curio is using the modern [nsimage imageTypes] call to detect images pasted from the clipboard. If you’re having problems pasting
in images from an older application then you may need to tell us to use the older, deprecated [nSTmage imagePasteboardTypes]
method.

defaults write com.zengobi.curio "Use 0Old Image Pasteboard Types" -bool yes §2
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curio://defaults-write?Disable%20Scroll%20Elasticity=yes
curio://defaults-write?Project%20Auto%20Lockfile%20Prefixes=~/Dropbox/;~/SyncService/
curio://defaults-write?Projects%20Button%20Open%20QuickPick=no
curio://defaults-write?Project%20Gallery%20Add%20Categories%20Via%20Finder%20Tags%20Scope=home
curio://defaults-write?Use%20Old%20Image%20Pasteboard%20Types=yes

Project Trash Old Backup

Project Trash Old Backup

Normally Curio sends prior backups to the Trash when a new backup is copied from your Projects folder to your Backups folder.
However, you can tell Curio to instantly remove that old backup instead of sending it to your Trash.

defaults write com.zengobi.curio "Project Trash 0Old Backup" -bool no §2

Windows vs Tabs

Curio follows the window vs tabs setting specified in System Settings > Desktop & Doc > Prefer tabs when opening documents.
However, Apple allows you to override the global, system-wide setting by changing an app’s settings directly.

For instance, perhaps for all apps in general you want additional windows to open as windows, not tabs, but in Curio you want
projects to open in tabs. To do this you can set this variable to always. The alternative, to never open in tabs and always open is
windows, is to set it to never.

defaults write com.zengobi.curio "AppleWindowTabbingMode" -string "always" §2

If Curio is running you will need to re-launch to see this change.

Add Tab Option

Choose View > Show Tab Bar menu item if the tab bar isn’t already visible. There’s a + sign at the end of the tab bar so you can
easily add new projects.

By default clicking that button will mimic the File > New menu item (thus new from idea space gallery).

+ Hold Option and click the + button for File > New Blank Project,
+ Hold Option+Shift and click the + button for File > New From Project Template.

Or change this setting to:

+ 1 for new blank by default, then Option=new from idea space gallery, Option+Shift=new from project template,
- 2 for new from project template, then Option=new blank, Option+Shift=new from idea space gallery,
+ 3 for new empty, then Option=new blank, Option+Shift=new from idea space gallery.

defaults write com.zengobi.curio "Add Tab Option" -int O §2

Shortcuts

You can override the one-key shortcuts for several items. Set to empty string if you want to disable the shortcut.

Tool Shortcuts

defaults write com.zengobi.curio "Select Tool Shortcut" -string "v" é?
defaults write com.zengobi.curio "Figure Tool Shortcut" -string "f" §2

defaults write com.zengobi.curio "Text Tool Shortcut" -string "t" §2
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curio://defaults-write?Project%20Trash%20Old%20Backup=no
curio://defaults-write?AppleWindowTabbingMode=always
curio://defaults-write?Add%20Tab%20Option=0
curio://defaults-write?Select%20Tool%20Shortcut=v
curio://defaults-write?Figure%20Tool%20Shortcut=f
curio://defaults-write?Text%20Tool%20Shortcut=t

defaults write com.zengobi.
defaults write com.zengobi.

defaults write com.zengobi.

Shape Shortcuts

defaults write com.zengobi.
defaults write com.zengobi.
defaults write com.zengobi.
defaults write com.zengobi.
defaults write com.zengobi.
defaults write com.zengobi.
defaults write com.zengobi.
defaults write com.zengobi.
defaults write com.zengobi.
defaults write com.zengobi.

defaults write com.zengobi.

Notice the tool shortcuts support one or more modifier key prefixes:

Layer Shortcuts

defaults write com.zengobi.

defaults write com.zengobi.

Snap Shortcuts

defaults write com.zengobi.

defaults write com.zengobi.

Rotation Shortcuts

defaults write com.zengobi.
defaults write com.zengobi.

defaults write com.zengobi.

Grid Shortcuts

defaults write com.zengobi.

defaults write com.zengobi.

Meta Shortcuts

defaults write com.zengobi.
defaults write com.zengobi.
defaults write com.zengobi.
defaults write com.zengobi.
defaults write com.zengobi.

defaults write com.zengobi.

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

"Line Tool Shortcut" -string "1" §2

"Brush Tool Shortcut" -string "b" §2

"Eraser Tool Shortcut" -string "e"

"Decrease

"Increase

"Decrease

"Increase

"Decrease

"Increase

"Decrease

"Increase

"Decrease

"Increase

&

Pen Size Shortcut" -string "["

Pen Size Shortcut" -string "]"

Flag Size Shortcut" -string
Flag Size Shortcut" -string
Corner Shortcut" -string "{"
Corner Shortcut" -string "}"
Margin Shortcut" -string "@{"
Margin Shortcut" -string "@}"
Width Shortcut" -string "~ {"

Width Shortcut" -string ""}"

"Shadow Shortcut" -string "S" é?

"Next Layer Down Shortcut" -string "@["

?

>

nan

S

S D D )

&

&

"Next Layer Up Shortcut" -string "@]" §2

"Edge Snap Shortcut" -string "s"

&
&

"Center Snap Shortcut" -string "c"

®

®

"Rotate Counterclockwise Shortcut" -string "r"

"Rotate Clockwise Shortcut" -string "R" é?

"Zero Rotation Shortcut" -string "z" éQ

"Grid Snap Shortcut" -string "g" §2

"Grid Drawn Shortcut" -string "G" §2

"Toggle Checkbox Value" -string "x"

&

"Poggle Checkbox Visibility" -string "x" &

"Mini Popover Percent Complete" -string "%" Q?
"Mini Popover Tags" -string "#" é?

"Mini Popover Dates" -string "d" §2

"Focus Status Bar" -string "/" §2
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curio://defaults-write?Line%20Tool%20Shortcut=l
curio://defaults-write?Brush%20Tool%20Shortcut=b
curio://defaults-write?Eraser%20Tool%20Shortcut=e
curio://defaults-write?Decrease%20Pen%20Size%20Shortcut=[
curio://defaults-write?Increase%20Pen%20Size%20Shortcut=]
curio://defaults-write?Decrease%20Flag%20Size%20Shortcut=%5E[
curio://defaults-write?Increase%20Flag%20Size%20Shortcut=%5E]
curio://defaults-write?Decrease%20Corner%20Shortcut=%7B
curio://defaults-write?Increase%20Corner%20Shortcut=%7D
curio://defaults-write?Decrease%20Margin%20Shortcut=@%7B
curio://defaults-write?Increase%20Margin%20Shortcut=@%7D
curio://defaults-write?Decrease%20Width%20Shortcut=%5E%7B
curio://defaults-write?Increase%20Width%20Shortcut=%5E%7D
curio://defaults-write?Shadow%20Shortcut=S
curio://defaults-write?Select%20Tool%20Shortcut=@[
curio://defaults-write?Select%20Tool%20Shortcut=@[
curio://defaults-write?Edge%20Snap%20Shortcut=s
curio://defaults-write?Center%20Snap%20Shortcut=c
curio://defaults-write?Rotate%20Counterclockwise%20Shortcut=r
curio://defaults-write?Rotate%20Clockwise%20Shortcut=R
curio://defaults-write?Zero%20Rotation%20Shortcut=z
curio://defaults-write?Grid%20Snap%20Shortcut=g
curio://defaults-write?Grid%20Drawn%20Shortcut=G
curio://defaults-write?Toggle%20Checkbox%20Value=x
curio://defaults-write?Toggle%20Checkbox%20Visibility=X
curio://defaults-write?Mini%20Popover%20Percent%20Complete=-
curio://defaults-write?Mini%20Popover%20Tags=#
curio://defaults-write?Mini%20Popover%20Dates=d
curio://defaults-write?Focus%20Status%20Bar=/

Figures

Misc Shortcuts

defaults write com.zengobi.curio "Insert Figure Shortcut" -string "i" é?

Figures

Styles and Markdown

Normally a figure’s style doesn’t include the state of markdown rendering unless it's enabled for the figure. That way you can apply
styles to any figure and it doesn’t add/remove any markdown attribute.

But if you've explicitly enabled it for a figure, and you save a style with it, then applying it to another figure will for markdown to be
enabled.

But there are several ways to override this logic.

Apply Style Markdown State

This controls whether the markdown state can be modified by style info at all. By default it's ves so any markdown attribute is set
applied but you can force it to be no if you don’t want to touch the markdown state when applying figure styles.

defaults write com.zengobi.curio "Apply Style Markdown State" -bool no §2

Apply Style Reset Markdown If Not Specified

By default it’ll be no (so it leaves markdown rendering as-is) but you can set it to be yes and Curio will reset the markdown
rendering to the default, generally off, if the style does not include markdown info.

defaults write com.zengobi.curio "Apply Style Reset Markdown If Not Specified" -bool yes §2

Style Always Includes Markdown State

By defaultit’s no but you can force it to be yes if you want to force new styles you create to store their markdown setting in the
style dictionary.

defaults write com.zengobi.curio "Style Always Includes Markdown State" -bool yes é?

Markdown Support Emoji

By default Curio’s markdown support looks for markdown emoji syntax like :1aughing: and replaces it with the appropriate emoji
character when rendered. You can disable this functionality if you’d like.

defaults write com.zengobi.curio "Markdown Support Emoji" -bool no Q?

defaults write com.zengobi.curio "Markdown Support Emoji Autocomplete" -bool no éa
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curio://defaults-write?Insert%20Figure%20Shortcut=i
curio://defaults-write?Apply%20Style%20Markdown%20State=no
curio://defaults-write?Apply%20Style%20Reset%20Markdown%20If%20Not%20Specified=yes
curio://defaults-write?Style%20Always%20Includes%20Markdown%20State=yes
curio://defaults-write?Markdown%20Support%20Emoji=no
curio://defaults-write?Markdown%20Support%20Emoji%20Autocomplete=no

Markdown Headings

Markdown Headings

The rendering of single-line text figure that begins with a # as a markdown heading can now be disabled allowing you to create a

text figure that contains simply “# of guests” without triggering a markdown heading render.

defaults write com.zengobi.curio "Markdown Headers Single Line" -bool no g?

Markdown Bullet Lists

Normally the Format > Markdown > Bulleted List menu item uses + for list item prefixes by default, reserving the - for dashed
lists if you decide to enable it, but this be customized to a different character, say - , when dashed lists are disabled and keeping
= as a bullet (or even changing that as well) when dashed lists are enabled.

Note when exporting as markdown the prefix is left as-is so keep in mind that most markdown renderers only support + , - ,or
+ for bullets.

defaults write com.zengobi.curio "Markdown Bullet" -string "\*" éa

defaults write com.zengobi.curio "Markdown Dashed Bullet" -string "\*" é?

Image Figures

When Curio loads the image for an image figure from disk, it uses the Mac’s Core Graphics method to retrieve an image for a given
file no larger than 1500 x 1500, proportionally sized.

For example, given a 4032 x 3024 12 MP HEIC from your iPhone camera, Core Graphics will load and cache a 1500 x 1125 image
instead, allowing much faster initial rendering and reduced memory usage, while still being perfectly suitable for use on idea spaces.

If you resize the image figure to a size larger than that, Curio will simply scale that initially loaded image. Resizing to a smaller size
will cause Curio to re-render from that initial image, consuming even less memory.

Of course, double-clicking the image figure opens the full-sized image in the appropriate application.

You can customize that 1500 x 1500 size — smaller sizes for faster performance, larger sizes for better large scaling — or even set it
to zero if you always want the full-sized image loaded, but keep in mind this may slow down idea space performance when first
loading or resizing.

defaults write com.zengobi.curio "Asset Figure Preview Thumbnail Size" -string "{1500,1500}" §2

defaults write com.zengobi.curio "Asset Figure Preview Thumbnail Size" -string "{0,0}" é?

Huge Images

To better handle super huge images, Curio will first ask Core Graphics if the size of the image is more than 8000 x 8000. If so, Curio
gives Core Graphics permission to return a lower resolution thumbnail than the size requested if one is found embedded within the
image file. This is particularly handy with large camera RAW files and other very high resolution files which may have a smaller
embedded thumbnail for fast retrieval. So Curio will use that thumbnail instead of forcing Core Graphics to load the entire file just to
get a 1500 x 1500 preview. You can customize that 8000 x 8000 cutoff or even set to zero if nothing is too big.

defaults write com.zengobi.curio "Asset Figure Preview Too Huge Size" -string "{8000,8000}" §2

defaults write com.zengobi.curio "Asset Figure Preview Too Huge Size" -string "{0,0}" é?
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https://www.markdownguide.org/basic-syntax/#headings
curio://defaults-write?Markdown%20Headers%20Single%20Line=no
curio://defaults-write?Markdown%20Bullet=*
curio://defaults-write?Markdown%20Dashed%20Bullet=*
curio://defaults-write?Asset%20Figure%20Preview%20Thumbnail%20Size=%7B1500,1500%7D
curio://defaults-write?Asset%20Figure%20Preview%20Thumbnail%20Size=%7B0,0%7D
curio://defaults-write?Asset%20Figure%20Preview%20Too%20Huge%20Size=%7B8000,8000%7D
curio://defaults-write?Asset%20Figure%20Preview%20Too%20Huge%20Size=%7B0,0%7D

Asset Figure Image Size Constraint

Asset Figure Image Size Constraint

Constrain the size of an image dragged onto a Curio idea space to no bigger than the given width and height. That is, once the
image is loaded as described above, Curio can proportionally resize it to an image figure with a specific size if you wish, so it
doesn’t overwhelm your idea space. If set to zero then no resizing is performed.

defaults write com.zengobi.curio "Asset Figure Image Size Constraint" -string "{ 600.0, 400.0 }" Q

defaults write com.zengobi.curio "Asset Figure Image Size Constraint" -string "{ 0,0 }" Q

Asset Figure Preview Size Constraint

Constrain the size of non-image asset figures displayed as previews dragged onto a Curio idea space to no bigger than the given
width and height.

defaults write com.zengobi.curio "Asset Figure Preview Size Constraint" -string "{ 400.0, 400.0 }" (2

Asset Figure Preview Size In Collection Constraint

Constrain the size of non-image asset figures displayed as previews dragged into a Curio collection to no bigger than the given
width and height.

defaults write com.zengobi.curio "Asset Figure Preview Size In Collection Constraint" -string "{ 250.0, 250.0 }" (2

Asset Figure Preview Alias Icon

Curio shows a tiny superimposed alias icon on asset figures displayed as preview if they are at least 64 points in height and width,
are simple rectangular shapes, and aren’t rotated. It can also optionally resize itself if the preview image gets bigger or smaller.

defaults write com.zengobi.curio "Asset Figure Preview Alias Icon" -bool no Q
defaults write com.zengobi.curio "Asset Figure Preview Alias Icon Size" -string "{64, 64}" Q

defaults write com.zengobi.curio "Asset Figure Preview Alias Icon Resizes" -bool no 2

Idea Space Figure Size Constraint

Constrain the size of idea space link figures displayed as previews dragged onto a Curio idea space to no bigger than the given
constraint applied to both the width and height.

defaults write com.zengobi.curio "Idea Space Figure Constraint™ -float 800 (2

Asset Figure Default Stylings For Extensions

Files dragged to the idea space can have certain default stylings when displayed as icons or previews.
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curio://defaults-write?Asset%20Figure%20Image%20Size%20Constraint=%7B%20600.0,%20400.0%20%7D
curio://defaults-write?Asset%20Figure%20Image%20Size%20Constraint=%7B%200,0%20%7D
curio://defaults-write?Asset%20Figure%20Preview%20Size%20Constraint=%7B%20400.0,%20400.0%20%7D
curio://defaults-write?Asset%20Figure%20Preview%20Size%20In%20Collection%20Constraint=%7B%20250.0,%20250.0%20%7D
curio://defaults-write?Asset%20Figure%20Preview%20Alias%20Icon=no
curio://defaults-write?Asset%20Figure%20Preview%20Alias%20Icon%20Size=%7B%2064.0,%2064.0%20%7D
curio://defaults-write?Asset%20Figure%20Preview%20Alias%20Icon%20Resizes=no
curio://defaults-write?Idea%20Space%20Figure%20Constraint=800

File Backed Text Figure Icon Overlay

Displayed as Icons

Normally all asset figures displayed in icon mode share the same default “Document Icon” styling, so they all look similar. This
styling can be overridden via the Format > Set Default Style For Document Icon Figure menu item

However, you can specify that certain extensions have a different default icon styling with a comma-separated list of extensions (all
lowercased!).

For example this setting will make it so png, tiff, and tif files can all have unique default icon stylings set, for example, via the Format
> Set Default Style For PNG Icon Figure menu item:

defaults write com.zengobi.curio "Custom Default Icon Style Extensions" -string "png,tiff,tif" @2
As a note, URL’s are stored as assets with .webloc extensions.

You can set the default state for whether a file dragged into Curio shows as icon or preview via the Format > Default Figure Settings
submenu.

Displayed as Previews

Similarly normally all images or asset figures displayed as previews share the same “Image Figure” styling, with “PDF Image” and
“Equation” as the only exceptions. This styling can be overridden via the Format > Set Default Style For Image Figure menu item

But this can be overridden so that certain extensions have a different default preview styling with a comma-separated list of
extensions (all lowercased!).

For example this setting will make it so png, tiff, and tif files can all have unique default preview stylings set, for example, via the
Format > Set Default Style For PNG Preview Figure menu item:

defaults write com.zengobi.curio "Custom Default Preview Style Extensions" -string "png,tiff,tif" Q?
As a note, URL'’s are stored as assets with .webloc extensions.

You can set the default state for whether a file dragged into Curio shows as icon or preview via the Format > Default Figure Settings
submenu.

File Backed Text Figure Icon Overlay

Curio shows a tiny superimposed text file icon on asset figures displayed as text (aka file backed text figures).

The standard icon identifier ( pub1ic.text ) for this icon can be replaced with another from here although you may need to then
tweak the offset value.

defaults write com.zengobi.curio "File Backed Text Figure Icon Overlay" -bool no §2

defaults write com.zengobi.curio "File Backed Text Figure Icon Size" -string "{10, 10}" §2
defaults write com.zengobi.curio "File Backed Text Figure Icon Offset" -string "{-5, 0}" §2
defaults write com.zengobi.curio "File Backed Text Figure Icon Identifier"™ -string "public.text" §2
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curio://defaults-write?Custom%20Default%20Icon%20Style%20Extensions=png,tiff,tif
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Jump Anchor Size

Jump Anchor Size

A jump anchor has a default size of 16 x 16. You can change this using the following setting.

defaults write com.zengobi.curio "Jump Anchor Size" -string "{32, 32}" Q

Mail Messages

When you drag a message from Mail into Curio we include a special title for the created asset figure with the message’s subject,
from, and date. You can control what we put in the title this setting.

defaults write com.zengobi.curio "Include Mail Subject" -bool yes Q
defaults write com.zengobi.curio "Include Mail From" -bool yes

defaults write com.zengobi.curio "Include Mail Date" -bool yes Q)

Promised Files Delay

Dragging a message from Mail into Curio uses a clipboard operation called a promised file. If you have problems with a particular
message with a large attachment that you drag into Curio then you may need to increase our timeout in accessing that file (which
Mail will place in a temp folder for copying purposes). That will ask Curio to retry for the file after a 1 second pause. If it still doesn’t
work try 2 seconds and that should definitely take care of it. (The default is a 0.1 second delay.)

defaults write com.zengobi.curio "Promised Files Delay" -float 1.0 Q

Min Distribution Gap

When horizontally or vertically distributing figures via the Arrange menu, Curio will normally leave no gap between the figures. If you

want a gap then enter a value here.

defaults write com.zengobi.curio "Min Distribution Gap" -float 10.0 Q

Asset Figure Text Width Constraint

Constrain the width of a text figure as you start typing on an idea space or within a mind map.

defaults write com.zengobi.curio "Asset Figure Text Width Constraint" -float 600.0 Q

defaults write com.zengobi.curio "Asset Figure Text Width Constraint Mindmap" -float 250.0 Q)

List Title

The default title for a list.

defaults write com.zengobi.curio "List Title" -string "My List" Q
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curio://defaults-write?Jump%20Anchor%20Size=%7B32,%2032%7D
curio://defaults-write?Include%20Mail%20Subject=yes
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List Title Is Visible

List Title Is Visible

Determines whether a new list has a title. This is also set if you choose Format > Save As Default Style for List Figure.

defaults write com.zengobi.curio "List Title Is Visible" -bool yes §2

Import Collapsed

By default after importing a mind map or list and converting into a native collection Curio shows the result fully expanded. You can
make them collapsed by default if you wish.

defaults write com.zengobi.curio "Import Mind Map Collapsed" -bool yes §2

defaults write com.zengobi.curio "Import List Collapsed" -bool yes Q?

Index Card Widget Expand Brings to Front

If you use the index card’s expand/collapse widget to expand, it can be automatically be brought to the front.

defaults write com.zengobi.curio "Index Card Widget Expand Brings to Front" -bool yes é?

Convert Into Index Card Title Format

Using Arrange > Convert Into > Index Card you can convert standalone figures on the idea space into one or more index cards. If
the selected figure is an asset figure then the title of the index card is the filename of the underlying asset file.

You can change this to a different format where 0=none, 1=Fred, 2=Fred.md, 3=~/Documents/Fred.md. The default is 2.

Note if the file is embedded in the project then if you request format 3 then it will only show the filename without the path, since an
embedded file path is quite long.

defaults write com.zengobi.curio "Convert Into Index Card Title Format" -int 2 é?

Fonts

By default Curio’s font pickers show all user fonts as returned by the macOS system, which is what Apple suggests that we do by
default. However, you can change this to show all fonts installed on your system if you wish:

defaults write com.zengobi.curio "Fonts Show All" -bool yes §2

By default Curio’s font pickers show your fonts marked as favorites in the standard macOS font chooser (via T) at the very top of

the list of fonts. You can disable that feature:

defaults write com.zengobi.curio "Fonts Show Favorites" -bool no §2
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curio://defaults-write?List%20Title%20Is%20Visible=yes
curio://defaults-write?Import%20Mind%20Map%20Collapsed=yes
curio://defaults-write?Import%20List%20Collapsed=yes
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SuperSubscript Percentage

SuperSubscript Percentage

The percentage used to reduce the current character font size when generating a super or subscript. The default is 0.75, thus 75%
of the font’s current size.

defaults write com.zengobi.curio "SuperSubscript Percentage" -float 0.75 §?

Priority

You can override the default text displayed for tooltips and in the Status shelf for priorities.

defaults write com.zengobi.curio "Priority None" -string "None" g?

defaults write com.zengobi.curio "Priority Very Low" -string "Very Low" éQ

defaults write com.zengobi.curio "Priority Low" -string "Low" éz
defaults write com.zengobi.curio "Priority Medium" -string "Medium" Q?
defaults write com.zengobi.curio "Priority High" -string "High" §?

defaults write com.zengobi.curio "Priority Urgent" -string "Urgent" ép

Adornment Icons

You can override the default adornment icons, such as the priority and checked icons, by placing a specifically named par or
png replacement file in your app support folder.

For instance, to replace the rriorityl icon which is the “very low priority” flag icon you would place either a priorityl.pdf oOr
priorityl.png into this folder:

~/Library/Application Support/Curio/Version XX/Repository/Icons/
...where xx is your current Curio version. Curio will automatically migrate those files between subsequent major version releases.

Here are the adornment names you can replace (case sensitive): Bookmark, Checked0, Checked25, Checked50, Checked75,
Checked100, Checked125, Checked375, Checked625, Checked875, CheckedMixed, CustomData, JumpAction, Note, Person,
Persons, Priority1, Priority2, Priority3, Priority4, Priority5, References, Star, Tag.

Instant Insert Figure Popover

This setting will make it so the Insert Figure popover doesn’t animate between the galleries.

defaults write com.zengobi.curio "Instant Insert Figure Popover" -bool yes §2

Enter Ends Editing

Normally hitting the Enter key on the numeric keypad (not the main Return key) will end editing of the current text figure. You can
disable that feature via this setting.

defaults write com.zengobi.curio "Enter Ends Editing" -bool no é?
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curio://defaults-write?SuperSubscript%20Percentage=0.75
curio://defaults-write?Priority%20None=None
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Return Ends Editing

Return Ends Editing

Normally hitting the Return key on the keyboard (not the Enter key on the numeric keypad) inserts a return. You can make it so
Return ends editing instead. To insert a return you’ll have to type Option-Return instead.

defaults write com.zengobi.curio "Return Ends Editing" -bool yes Q

Text Blinking Cursor

If you have a weird issue when editing text figures where the blinking text cursor disappears then you may want try this option:
defaults write com.zengobi.curio "Text Editing Draw Into Layer" -bool no Q)

This rare issue has cropped up for some customers especially if on a non-Retina display and/or at certain idea space zoom settings.
See this forums post for more details.

Default Styling for Figures Dropped/Pasted Into Collections

When pasting or dropping items within or into a collection, Curio will default to adopt the styling appropriate for placement in the
destination collection.

However, the Shift key can be used to reverse this logic. That is, simply hold Shift while dropping, or press Command-Shift-V, or
hold Shift when choosing Edit > Paste, and Curio will keep the figure’s styling as-is instead of adopting the destination’s default

styling.

Examples

« If you move a list or mind map branch — via cut/copy/paste or drag-and-drop — from level 5 to level 1 then it will adopt that
level 1 styling to show off its promotion.

* Moving a figure from a mind map’s “orange branch” to the “green branch” will force the node to adopt the green branch
styling.

* Moving a figure from one mind map styled with Chiclets to a different mind map styled with Chalkboard will adopt that
destination’s styling.

- Dragging figures from the idea space or bringing in data from outside of Curio into a collection will adopt the destination’s
styling.

+ But, if you cut a table cell and then hold down Shift while pasting then it will keep its styling, instead of adopting the styling
for that destination table cell.

« Likewise if you drag a branch in a mind map and, before releasing, you hold Shift, then the branch will keep its coloring as-is
instead of adopting the default level or branch style.

Overrides

You can override the default adopt vs. keep value based on (a) whether you’re dropping/pasting within the same collection vs. into
another collection, (b) the specific collection type of the following choices: wnist , Mind Map , Table , Stack , Pinboard , Album ,

Index Card .

For example, this will make it so anything you drag into or within a mind map will not adopt the styling and thus keep its existing

styling:
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defaults write com.zengobi.curio "Adopt Style Into Mind Map" -bool no §2

defaults write com.zengobi.curio "Adopt Style Within Mind Map" -bool no §2

Mind Map Arrangement

And this will make it so anything you do within the table will not adopt, but dragging items into a table will still adopt:

defaults write com.zengobi.
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curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio

curio
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Override the Overrides

Don’t forget: even your override can be overridden on-the-fly by simply holding down the Shift key.

"Adopt

"Adopt

"Adopt

"Adopt

"Adopt

"Adopt

"Adopt

"Adopt

"Adopt

"Adopt

"Adopt

"Adopt

"Adopt

"Adopt

"Adopt

Style Within Table" -bool no §?

Style Into List" -bool no §2

Style Within List" -bool no &

Style Into Mind Map" -bool no §2

Style Within Mind Map" -bool no §2

Style Into Table" -bool no é?

Style Within Table" -bool no g?

Style Into Stack" -bool no é?

Style Within Stack" -bool no g?

Style Into Pinboard" -bool no é?

Style Within Pinboard" -bool no g?

Style Into Album" -bool no é?

Style Within Album" -bool no §?

Style Into Index Card" -bool no g?

Style Within Index Card" -bool no Q?

Mind Map Arrangement

The default arrangement for a new mind map. 1=radial, 2=right, 3=left, 4=bottom-up, 5=top-down, 6=org chart. This is also set if

you choose Format > Save As Default Style for Mind Map Figure.

defaults write com.zengobi.curio "Mindmap Arrangement" -int 1 Q?

Mindmap Rebalance After Collapsing

Normally a mind map will rebalance itself after you collapse a node. Turning this off will leave the mind map as-is after collapsing

nodes.

defaults write com.zengobi.curio "Mindmap Rebalance After Collapsing” -bool no é?
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Mindmap Gaps and Offsets

Mindmap Gaps and Offsets

These are low-level gaps and offsets that Curio’s mind map algorithm uses.
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zengobi.
zengobi.
zengobi.
.zengobi.
zengobi.
zengobi.
zengobi.
zengobi.
.zengobi.
zengobi.

zengobi.

curio

curio
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curio
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"Mindmap
"Mindmap
"Mindmap
"Mindmap
"Mindmap
"Mindmap
"Mindmap
"Mindmap
"Mindmap
"Mindmap

"Mindmap

Line Length
Gap Between
Gap Between

Gap Between

Sibling Border Test Amount Min" -float 3 éQ

To Top Branches" -float 30 §2
Top Branches" -float 20 é?
Children" -float 10 &

Parent And Children" -float 30 é?

Sibling Border Test Amount Max" -float 20 §2

OrgChart Vertical Gap Between Root And Top Branches" -float 40

D

OrgChart Horizontal Gap Between Top Branches" -float 25 ‘§?

OrgChart Horizontal Gap Between Parent And Children" -float 25 é?

OrgChart Vertical Gap Between Parent And Children" -float 30 §2

OrgChart Vertical Gap Between Children" -float 10 é?

& Experimental setting to increase the gap between branches with more than one child:

defaults write

com.zengobi.curio

"Mindmap Gap Between Branches" -float 20 é?

Table Initial Headers and Footers

Determines whether headers and footers are displayed when creating a new table.

defaults write

defaults write

defaults write

defaults write

com.

com.

com.

com.

zengobi.
zengobi.
zengobi.

zengobi.

curio

curio

curio

curio

"Table Initial Header Row" -bool yes ‘Q?

"Table Initial Header Column" -bool yes
"Table Initial Footer Row" -bool yes éQ

"Table Initial Footer Column" -bool yes é?

R

Table Return Edits Next Row

Normally when you press Return in a table cell Curio simply inserts the return into the cell, much like how Keynote’s tables work. If

you’d rather edit the cell in the next row, more like Numbers or Excel, then you can use this setting.

defaults write com.zengobi.curio "Table Return Edits Next Row" -bool yes §?

Stack Return Creates Sibling

Normally when you press Return in a Stack cell Curio creates a new sibling underneath, much like how mind maps and lists work. If

you’d rather insert the return into the current figure then you can use this setting.

Once you disable Return, you can still create siblings with $Return or by double-clicking the background area of the Stack.

defaults write com.zengobi.curio "Stack Return Creates Sibling" -bool no §§?
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Composition Minimim Widths

Composition Minimim Widths

When a composition determines smallest widths for items in a column it bases those minimums on the figure types. For instance,
images and asset figures displayed as preview have a minimum width of 200 points. So if you try to make a column smaller than
one of those internal widths the composition may override with one of those minimums.

You can override these minimums if you’d like to create very narrow columns.

defaults write com.zengobi.curio "AssetFigure Preview Min Width" -int 200 g?
defaults write com.zengobi.curio "AssetFigure Icon Min Width" -int 200 é?

defaults write com.zengobi.curio "TextFigure Min Width" -int 100 é?

Note that some types of figures have their own minimum widths that cannot be overridden. For example, a mind map placed into a
composition will enforce the minimumm width it needs to display the content of its contained items.

Figure Popup Inspector Tabs

You can specify the tabs that appear in the figure inspector popup window. Case sensitive choices include Style, Text, Shape,
Extras, Geometry. Enter the tab labels as a comma separated list with no spaces.

defaults write com.zengobi.curio "Figure Popup Inspector Tabs" -string "Shape,Extras,Geometry" §?

Figure Show Complete Bounds

The figure Geometry inspector now shows the figure bounds without inflating those bounds for enclosed adornments or captions,
as it did prior to Curio 11. If you wish to see those “complete bounds” instead you can use this setting.

defaults write com.zengobi.curio "Figure Show Complete Bounds" -bool yes §?

Figure Show Bounds Origin

The figure Geometry inspector shows the minimum (smallest) X and minimum (smallest) Y coordinate for the selected figure. Thus if
you rotate a figure it will be the smallest X and smallest Y, as measured from the top/left corner of the idea space, of that rotated
object. If you’d rather see the actual internal origin of the figure, regardless of rotation, then use this setting.

defaults write com.zengobi.curio "Figure Show Bounds Origin" -bool yes §2

Syncing Image Figure Title and Caption

If you rename an image figure while in icon mode, then if the image figure also has a caption that matches the previous old title, then
the caption will be updated to reflect the new image title. That way they can stay in sync. You can always change the caption to
something independent if you’d like and the sync will stop. You can disable this feature if you'd like.

defaults write com.zengobi.curio "Sync Title To Caption" -bool no é?
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GrabWebArchive Format

The opposite does not happen by default: changing a caption doesn’t sync to the image’s title, since the caption can be a
paragraph, and the image title generally matches the underlying asset file’s title. However, if you wish, you can enable syncing
caption changes to the figure’s title (if it matches the previous old caption) and thus the underlying asset’s file title. Just be mindful
of the length of your captions.

defaults write com.zengobi.curio "Sync Caption To Title" -bool yes ﬁ

GrabWebArchive Format

Normally Curio will create a PDF when you right-click on a web link figure and choose Grab Web Archive. You can customize this
setting in Terminal where O=paginated pdf, 1=pdf image, 2=webarchive.

defaults write com.zengobi.curio "GrabWebArchive Format" -int 0 Q)

Pinboard Auto Resizes

Normally Curio automatically resizes pinboards as you add more content. You can turn this off if you wish.

defaults write com.zengobi.curio "Pinboard Auto Resizes" -bool no é)

Stack Auto Size

Normally Curio expands a stack collection as you add more, but it doesn’t automatically shrink it when you remove items. You can
tell Curio to shrink as well via this setting.

defaults write com.zengobi.curio "Stack Is Auto Size" -bool yes Q

Collapse To Title

Normally when you collapse a list or mind map figure (by selecting the collection figure itself and hitting spacebar) it collapses but
keeps the parent nodes under the title still visible. You can tell Curio to collapse all the way to the title with these settings.

defaults write com.zengobi.curio "List Collapse To Title" -bool yes Q

defaults write com.zengobi.curio "Mind Map Collapse To Title" -bool yes Q

Direct Click

When working with collection figures, the first click selects the collection itself and, now that the collection is active, subsequent
clicks will select items with the collection. Some collection layouts support direct clicking on contained items even if the collection
itself is not active. If the click doesn’t hit an item within then the collection itself is selected, as usual.
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Link Color and Underline

defaults write com.zengobi.curio "List Allows Direct Click" -bool yes §2
defaults write com.zengobi.curio "Mindmap Allows Direct Click" -bool yes g?

defaults write com.zengobi.curio "Album Allows Direct Click" -bool yes é?

defaults write com.zengobi.curio "Pinboard Allows Direct Click" -bool yes éD

defaults write com.zengobi.curio "Stack Allows Direct Click" -bool yes §2

Link Color and Underline

By default Curio will no longer force a link color which means links will match the figure’s text color although still underlined.

You can force a specific color, if you wish, either with a hex code like #ffoo00 or a friendly name like 1inx , which is the shade of
blue that Apple uses for links, or iue , which is the true blue (aka #0000ff) that Curio previously used.

defaults write com.zengobi.curio "Link Color" -string "#££0000" g?

defaults write com.zengobi.curio "Link Underline" -bool no Q?

Locked Figures Allow Adornment Clicks

Normally Curio ignores clicks on adornments associated with locked figures. You can change this with this setting.

defaults write com.zengobi.curio "Locked Figures Allow Adornment Clicks" -bool yes éz

Shift Bypasses Galleries

Normally if you click on a collection toolbar button, such as List or Mind Map, then see the gallery for that collection, while holding
Shift and clicking on the toolbar button will instantly insert that collection with the default style. This setting will reverse that Shift

logic.

defaults write com.zengobi.curio "Shift Bypasses Galleries" -bool no §2

Lines

(See the Idea Graphs section below for settings specific to lines used in the creation of idea graphs.)

When drawing lines, the default is a straight line. You can make it so lines are drawn as curved lines by default:
defaults write com.zengobi.curio "Insert Line Type" -int 1 Q)

Note that the line won’t curve until you either:

1. Connect at least one endpoint to another figure, then Curio can internally create the midpoints necessary to render an
elegant, swoopy curved line.

2. Or, right-click within the line and choose Insert Midpoint to add one or more midpoints, and Curio will curve the line through
all the points.
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curio://defaults-write?Connected%20Line%20Width=1

Idea Graphs

Idea Graphs

Many of Curio’s idea graph line defaults can be customized.
The default line width:
defaults write com.zengobi.curio "Connected Line Width" -int 1 §2
The default line scale:
defaults write com.zengobi.curio "Connected Line Scale" -int 1 g?
The default line color:
defaults write com.zengobi.curio "Connected Line Color" -string "#££0000" §2
The default line type can be straight (0), curved (1), or orthogonal (2):
defaults write com.zengobi.curio "Connected Line Type" -int 1 §2
A midpoint can be automatically added:
defaults write com.zengobi.curio "Connected Line Add Midpoint" -bool yes ‘ég

The default line dash pattern (when Command+Shift+Option is pressed) is a 2 (meaning 2 pixels on, 2 pixels off, repeat). The dash
pattern is of the format: pixelsOn{,pixelsOff,pixelsOn,pixelsOff}, such as “5,3,2,3,2,3".

defaults write com.zengobi.curio "Connected Line Dash Pattern" -string "2,3" §2

You can also change whether the head or tail decoration is filled or hollow, and determine which decoration is used for the head or
tail. The choice of decorations are: “Winged”, “Arrow”, “Triangle”, “Box”, “Circle”, “Stop”.

defaults write com.zengobi.curio "Connected Line Head Filled" -bool no §2
defaults write com.zengobi.curio "Connected Line Tail Filled" -bool no §2
defaults write com.zengobi.curio "Connected Line Head Decoration" -string "Winged" é?

defaults write com.zengobi.curio "Connected Line Tail Decoration" -string "Triangle" éz

Idea Graph Lines From Resize Handles

If you Option-drag on a figure’s resize handle Curio will generate a directional line on-the-fly allowing you to easily connect it to
another figure via Sticky Lines.

The specific style (color, width, scale, etc) of the connecting line can be customized as described above.

In addition, several characteristics of this generated line can be also be customized as described below.

The line type is nondirectional with no arrowheads (0), directional with one arrowhead (1), or bidirectional with two arrowheads (2):
defaults write com.zengobi.curio "Connected Line Resize Handle Arrowheads" —int 1 &

As described in Sticky Lines, the line originating (tail) points towards the center of the originating figure (0), sticks to the closest
connection point (1), or sticks to this specific connection point (2, the default):
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Shapes

defaults write com.zengobi.curio "Connected Line Resize Handle Snap" -int 0 §2
The line is dashed:
defaults write com.zengobi.curio "Connected Line Resize Handle Dashed" -bool no §2

Idea Graph Lines From Insert > Line

If you select two figures then choose an option from the main menu’s Insert > Line submenu, Curio will create the appropriate
nondirectional, directional, or bidirectional connecting line between the two figures.

The specific style (color, width, scale, etc) of the connecting line can be customized as described above.

As described in Sticky Lines, the tail and head snap points can point towards the center of the figures (0, the default) or stick to the
closest connection points (1):

defaults write com.zengobi.curio "Connected Line Menu Snap" -int 0 @2
The line is dashed:

defaults write com.zengobi.curio "Connected Line Menu Dashed" -bool no §2

Shapes

You can redefine the ordering of shapes in the toolbar, inspector, and Basic Shapes gallery shown within Curio. Here’s the default.

defaults write com.zengobi.curio "Shapes" -string
"Rectangle, RoundedRect,Octagon, Hexagon, Pentagon, House,Underline, Brackets, VerticalBrackets, Trapezoid, TrapezoidFlipped, Semicircl
e,Oval,Capsule, TriangleLeft, TriangleRight, Triangle, TriangleFlipped, Diamond, Cloud, Speech, ArrowLeft, ArrowRight, ArrowUp, ArrowDown

,ArrowLeftRight, ArrowUpDown,Cross, SignpostLeft, SignpostRight, Parallelagram, SlopedRect,Cylinder, Document,Note" éz

Figure Style Gallery Light

To accurately render previews for figure styles, the various figure galleries (the figure mini-gallery in the inspector shelf, the larger
Apply Style (via right-click on figure) gallery, and the Insert figure galleries) are all forced to have a light-mode background, to better
match the idea space itself which is also a forced light-mode background. You can disable this so the galleries use a dark mode

background if your system is dark mode with this setting.

defaults write com.zengobi.curio "Figure Style Gallery Light" -bool no §§2

Shadow Color

By default the shadow color in Curio is black at 75% opacity. You can set this to a different default value using a rgba (hexred,
hexGreen, hexBlue, opacityFraction) Value. Note the hex values do not have preceding # signs.

defaults write com.zengobi.curio "Shadow Color" -string "rgba(aa,bb,cc,0.2)" é?
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Jagged Shape Replacement

Jagged Shape Replacement

Since support for the Jagged shape was removed in Curio 8 it is dynamically replaced with another shape. In Curio 8 we replaced it
with the Cloud shape but this could conflict with any existing true Cloud shapes in a diagram or flowchart. So in Curio 11 we’re
replacing it with the brand new House shape. You can customize the shape using any of the following values: Rectangle,
RoundedRect, Octagon, Hexagon, Pentagon, House, Underline, Brackets, VerticalBrackets, Trapezoid, TrapezoidFlipped,
Semicircle, Oval, Capsule, TriangleLeft, TriangleRight, Triangle, TriangleFlipped, Diamond, Cloud, Speech, ArrowLeft, ArrowRight,
ArrowUp, ArrowDown, ArrowLeftRight, ArrowUpDown, Cross, SignpostLeft, SignpostRight, Parallelagram, SlopedRect, Cylinder,
Document, Note.

defaults write com.zengobi.curio "Jagged Shape Replacement" -string "House" ﬁ

WebView User Agent

Curio’s various embedded web views, while driven by Apple’s WebKit framework, can mimic a specific browser for compatibility
with some sites. In general Curio’s custom user agent is set to the latest Safari user agent string, which seems to maximize
compatibility with various sites, although this may change in a given build of Curio.

A handy reference of user agents is WhatlsMyBrowser’s latest user agents on macOS.

While you hopefully don’t need to tweak this user agent value, Google’s sites, in particular, can show odd error messages which can
cause issues. For instance, at the time of this writing:

- If Curio web views are using the Safari user agent, you can login to Google’s services and use Google Docs. However,
Google Sheets will show an error.

- If using the Chrome user agent then you won’t be able to login to Google’s services, but if you’re already logged in then both
Google Docs and Sheets will work just fine.

« If you set the user agent to nothing, an empty string, then no custom user agent is used. With this you can login to Google’s
services and use both Google Docs and Sheets, but you’ll have to dismiss an innocuous but annoying warning telling you to
upgrade your browser.

defaults write com.zengobi.curio "WebView User Agent" -string "" é)

Importantly, Apple no longer allows cookies to be shared between web views and Safari, for security reasons. Thus you can’t login
with Safari and expect web views within Curio to use those same cookied credentials.

Capture WebView Opacity

Normally when a live WebView is not active the placeholder screenshot image is slightly dimmed, so you know it’s inactive. You can
set this opacity level to anything you wish, including 1.0 if you don’t want it dimmed at all.

defaults write com.zengobi.curio "Capture WebView Opacity" -float 1.0 Q

YouTube Size

You can change the default, initial size for inserted YouTube videos with this setting.
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Vimeo Size

defaults write com.zengobi.curio "YouTube Size" -string "{ 640.0, 360.0 }" §2

Vimeo Size

You can change the default, initial size for inserted Vimeo videos with this setting.

defaults write com.zengobi.curio "Vimeo Size" -string "{ 640.0, 360.0 }" Q?

Dim Video WebView Poster Images

Normally video WebViews, like Vimeo and YouTube videos, are dimmed, like all other WebViews, when the WebView itself is not
active. You can make it so the placeholder image isn’t dimmed with this option.

defaults write com.zengobi.curio "Dim Video WebView Poster Images" -bool no §§z

Play Media Key

For audio and video asset figures the media bar appears in the inspector bar area to control playback. Curio also supports the Play/
Pause key on macOS keyboards to start or pause playback.

We didn’t want to interfere with the normal Play button as that’s used globally to control Apple Music or Spotify, so by default you
have to hold Shift when pressing Play to trigger the play or pause within Curio.

However, you can specify one or more modifier keys to be pressed with the Play key. Modifier strings include command , control ,
option ,and shift . They can be listed in any order, with or without delimiters like spaces or plus signs.

If you set it to nothing then the Play key without any modifiers will play/pause.
For example, here’s how you would specify that Control+Command must be pressed with the Play key:

defaults write com.zengobi.curio "Play Media Modifiers" -string "Control+Command" Q?

Movie Controller Style

For normal media files, Curio will display inline controls overlaid on the media viewer to control playback with a handy scrubber. You
can customize this with this setting where 0=none, 1=inline (default), 2=floating, 3=minimal.

defaults write com.zengobi.curio "Movie Controller Style" -int 0 é?

Movie Poster Percentage

Curio will show the poster frame if one is specified via the Media actions menu, else an offset into the movie based on the start and
end of the movie (which can be overridden via the Media actions menu). You can specify the percentage (from 0 to 100) which is
used, along with the start and end times, to determine the frame to use as the poster: O=start frame (default), 25=25% of the way
through the movie, 50=middle frame, 100=last frame.
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Media Playback Timer

defaults write com.zengobi.curio "Movie Poster Percentage" -int 50 §2

Media Playback Timer

Normally Curio uses a 0.01 second timer when updating the media playback counter. For those wanting to control this value
manually you can use this setting.

defaults write com.zengobi.curio "Media Playback Timer" -float 0.03 é?

Auto Inflate

Normally certain shapes (Cloud, Diamond, Hexagon, Octagon, Oval, Semicircle, Speech, Trapezoid, TrapezoidFlipped, Triangle,
TriangleFlipped, TriangleLeft, TriangleRight) are set to auto inflate their bounds automatically to minimize the amount of clipping that
could occur to any text or image within the shape. The result is a nicer looking resulting shape without you having to fidget with
margins or things like that. This can be toggled off and back on within the Shape inspector. However, you can also set the default to
be off for a specific shape for those that like absolute control of the shape from the get-go. Note that you can still toggle it on in the
inspector if you wish.

defaults write com.zengobi.curio "Auto Inflate Triangle" -bool no §2
You can also turn it off by default for all shapes that support auto inflate.

defaults write com.zengobi.curio "Auto Inflate" -bool no ég

Create Linked Idea Space

The Create Linked Idea Space feature supports several customizations.
By default:

« For the title of the new idea space, any returns found within the source text figure’s content will be removed and length
beyond 40 characters truncated.

» The new idea space will have the same style as the current idea space, alternatively it can be blank.

+ A “back figure” will be created on the new idea space, titled the same as the source idea space, with an action which jumps
back to the source idea space, alternatively it can jump back to the source figure on the source idea space.

defaults write com.zengobi.curio "Create Linked Idea Space Title Remove Returns" -bool yes Q?
defaults write com.zengobi.curio "Create Linked Idea Space Title Max Length" -int 40 §2
defaults write com.zengobi.curio "Create Linked Idea Space Blank" -bool no §2

defaults write com.zengobi.curio "Create Linked Idea Space Back Figure" -bool yes Q?

defaults write com.zengobi.curio "Create Linked Idea Space Back To Source Figure" -bool no Q?
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Meta

Meta

Actions Adornment

If you have a figure that has an assigned action, and a visible actions adornment, then double-clicking will edit the figure’s text. To

perform the action you have to click the adornment.

If a figure’s actions adornment is hidden the double-clicking will still perform the action. To edit the figure select the figure and press
Return or click-pause-click.

You can make it so double-clicking an adorned figure performs the action instead with this setting:

defaults write com.zengobi.curio "Double Click Adorned Figure Edits" -bool no Q?

Tag Adornments

If a text figure has inline tags within its content, then an adornment for that tag can be displayed:

* Never (value of 0).
+ Only if the tag has a set image (value of 1, the default).

defaults write com.zengobi.curio "Flags Show Inline Tags" -int 1 §2

Resource Adornments

Normally when a figure is associated with a resource that resource’s image, or a generic “person” image, is placed alongside the
figure as an adornment. You can turn off the display of generic icons if you wish.

defaults write com.zengobi.curio "Flags Show Generic Resource" -bool no é?
If a text figure has inline resources within its content, then an adornment for that resource can be displayed:

* Never (value of 0).
+ Only if the resource has a set image (value of 1, the default).
« If the resource has a set image else a generic image is used (value of 2). Note the global setting above can override this.

defaults write com.zengobi.curio "Flags Show Inline Resources" -int 1 ég

Tasks Completed Strikethrough

Checkmarked tasks in Curio which have been completed are now displayed with strikethrough and slightly dimmed.

defaults write com.zengobi.curio "Tasks Completed Strikethrough" -bool no §2
defaults write com.zengobi.curio "Tasks Completed Dim" -bool no g?

defaults write com.zengobi.curio "Tasks Completed Dim Opacity" -float 0.5 é?
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Figure Percent Complete To From Children

Figure Percent Complete To From Children

Normally percentage complete (checkmarks) automatically propagate changes to and from children. You can change this if you
change this setting.

defaults write com.zengobi.curio "Figure Percent Complete To From Children" -bool no ﬁ

Figure Percent Complete From Resources

Normally if a figure has assigned resources with percentages then those percentages determine the percentage complete for the
figure itself. You can change this if you change this setting.

defaults write com.zengobi.curio "Figure Percent Complete From Resources" -bool no Q)

Rating Shortcuts

Normally pressing 0, 1, 2, 3, 4, 5 will assign that rating to the selected figures. You can disable this shortcut via this setting.

defaults write com.zengobi.curio "Rating Shortcuts" -bool no ﬁ

Clear All Meta

By default the new Format > Clear All Meta menu item resets all meta fields. This can be customized by changing this setting.

defaults write com.zengobi.curio "Clear All Meta Leaves Percent Complete" -bool yes Q
defaults write com.zengobi.curio "Clear All Meta Leaves Checkmark" -bool yes Q
defaults write com.zengobi.curio "Clear All Meta Leaves Rating" -bool yes Q
defaults write com.zengobi.curio "Clear All Meta Leaves Priority" -bool yes Q
defaults write com.zengobi.curio "Clear All Meta Leaves Start Date" -bool yes Q
defaults write com.zengobi.curio "Clear All Meta Leaves Due Date" -bool yes (2
defaults write com.zengobi.curio "Clear All Meta Leaves Duration" -bool yes Q
defaults write com.zengobi.curio "Clear All Meta Leaves Resources" -bool yes Q
defaults write com.zengobi.curio "Clear All Meta Leaves Tags" -bool yes Q
defaults write com.zengobi.curio "Clear All Meta Leaves Actions" -bool yes \’2
defaults write com.zengobi.curio "Clear All Meta Leaves Notes" -bool yes Q

defaults write com.zengobi.curio "Clear All Meta Leaves Decorations" -bool yes Q

Display Year In Adornment

Normally Curio does not show a year in the date adornment. If you wish to show the year then enter this.

defaults write com.zengobi.curio "Display Year In Adornment" -bool yes (2
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Display Time In Adornment

Display Time In Adornment

Normally if either the start or due date have a non-midnight time Curio will show the time in the date adornment. You can disable
this if you’d like.

defaults write com.zengobi.curio "Display Time In Adornment" -bool no Q

Date Adornment Format

Or you can simply override the date adornment format entirely using a date format string. For example, this will format it like won

4/8/14 .

defaults write com.zengobi.curio "Date Adornment Format" -string "E d/M/yy" Q

Date Adornment Font Fixed Pitch

Normally Curio uses the standard macOS “user” font (Helevetica, usually) for the start/due date adornment on figures. Alternatively
you can switch to a fixed pitch font.

defaults write com.zengobi.curio "Date Adornment Font Fixed Pitch" -bool yes Q

Start Date Now

Normally the start date is today, meaning today at midnight (00:00). But you can specify that the current date including the current
hour and minute are used instead.

defaults write com.zengobi.curio "Start Date Now" -bool yes Q

Display Actual Due Date

Normally if the due date for a figure is at midnight (00:00:00) then Curio will show the due date adornment with the previous day
since you have that entire previous day to complete the task, as it’s due precisely at midnight. This is similar to how an app like
Calendar shows dates so the displayed adornment matches what you see if you have Calendar syncing enabled. If, however, you
want to see the actual set due date in the adornment then use this setting.

defaults write com.zengobi.curio "Display Actual Due Date" -bool yes Q

Reminder Due Date Midnight Adjust

If a figure has a due date at midnight on a date then normally the synced task in Reminders has that same date and time. However,
you can use this setting to ask Curio to adjust the resulting Reminders task to 23:59:59 the previous day if you wish.

defaults write com.zengobi.curio "Reminder Due Date Midnight Adjust" -bool yes Q
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Start Date Technique

Start Date Technique

The default start date technique unit is automatic. You can change this to another value: O=automatic, 1=manual, 2=after previous
sibling due, 3=parent start, 4=previous sibling start.

defaults write com.zengobi.curio "Start Date Technique" -int 0 Q)

Due Date Technique

The default due date technique unit is automatic. You can change this to another value: O=automatic, 1=manual, 2=from children,
3=start+duration.

defaults write com.zengobi.curio "Due Date Technique" -int 0 Q

Duration Units

The default duration unit is days. You can change this to another value: minutes=1, hours=2, days=3, weeks=4, months=5, years=6.

defaults write com.zengobi.curio "Duration Units" -int 3 Q

Search Asset Types

You can enter any custom asset file extension types that will be made available in the Library > Project shelf.

defaults write com.zengobi.curio "Search Asset Types" -string "XCode files;.m, .h, .xcodeproj;iMovie movies;.iMovieProject" Q

Embed Tags Extract File

Normally Curio embeds a copy of any global tag sets that you reference within the project package. This way other colleagues, that
wouldn’t have access to your global tags, can see and change tag associations. You can disable this functionality if you wish.

defaults write com.zengobi.curio "Embed Tags Extract File" -bool no Q)

Notes Font

The Notes window can have a default font and font size (both have to be set). This will not replace any existing note formatting.

defaults write com.zengobi.curio "Notes Font" -string "Menlo" Q

defaults write com.zengobi.curio "Notes Font Size" -int 15 Q

Notes Window Color

The Notes window normally has a slight yellow coloring to look like a yellow notepad. You can change this color with this setting.

defaults write com.zengobi.curio "Notes Window Color" -string "#ffffff" Q
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Notes Window Inset

Notes Window Inset

The Notes window has a slight inset to text isn’t crammed into the top-left corner. You can adjust this inset with this setting.

defaults write com.zengobi.curio "Notes Window Inset" -string "{ 50.0, 50.0 }" §2

More Notes Window Options

Here are several more options for the Notes window. You will need to relaunch Curio for these to take effect.

defaults write com.zengobi.curio "Notes Window Check Spelling As You Type" -bool yes é?
defaults write com.zengobi.curio "Notes Window Check Grammar With Spelling" -bool no @2
defaults write com.zengobi.curio "Notes Window Correct Spelling Automatically" -bool no g?
defaults write com.zengobi.curio "Notes Window Text Replacement" -bool yes é?

defaults write com.zengobi.curio "Notes Window Smart Quotes" -bool yes é?

defaults write com.zengobi.curio "Notes Window Smart Links" -bool yes §2

defaults write com.zengobi.curio "Notes Window Smart Dashes" -bool yes §2

defaults write com.zengobi.curio "Notes Window Show Ruler" -bool yes g?

Contacts Access

Curio no longer asks for Contacts access unless you drag in or launch a vCard file. In addition, Curio no longer automatically adds
you as an available Resource in new projects. Likewise your full name is no longer added to the Dropbox lock file (instead we just
use your OS username). You can override those defaults with these settings.

defaults write com.zengobi.curio "Add Me To New Projects" -bool yes é?

defaults write com.zengobi.curio "Lockfile Uses Me" -bool yes §?

Idea Space

Insert Space

When you choose an Insert > Space menu item, Curio will create the given number of pixels of empty space around the selected
figures or around the idea space if nothing is selected.

defaults write com.zengobi.curio "Insert Space Around Selection" -int 100 é?

defaults write com.zengobi.curio "Insert Space" -int 500 §2

Idea Space Spacebar QuickLook Sensitivity

If a figure is selected an idea space and you quickly tap on the spacebar then we show a Quick Look preview. If you hold down the
spacebar we turn the mouse pointer into a Photoshop-like scrolling hand. You can change how quickly you must tap but adjusting
this timeout given in seconds.
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Ruler Measurement Units

defaults write com.zengobi.curio "Idea Space Spacebar QuickLook Sensitivity" -float 0.15 §2

Ruler Measurement Units

Normally the ruler in Curio (visible via the View > Show Ruler menu item) shows dimensions in points. You can optionally set the
ruler to a different measurement unit such as inches or centimeters. You can also set a ruler measurement unit specifically for text
editing. To change the units enter a case-sensitive unit such as 1nches , centimeters , Of Points .

defaults write com.zengobi.curio "Ruler Units" -string "Inches" g?

defaults write com.zengobi.curio "Editing Units" -string "Inches" §2

Selection Glow

Normally Curio shows a slight glow around selected figures including a blue glow for normal figures, pink for an instance of an
original figure, purple for original figures that have instances, and gray for locked figures.

You can allow selection glows, for special cases like the pink and purple glows mentioned above, but customize the normal blue
glow conditions.

The default for the normal glow is a smart mode (2) where Curio determines if a glow should automatically like if the figure is
unbordered and unfilled, or is contained within a collection, otherwise no blue glow will happen for the figure and you will just see
selection handles. You can set it to 1 to make it so all normal glows happen for all selected figures, or set it to 0 if no blue selection
glow should happen, just selection handles.

defaults write com.zengobi.curio "Selection Normal Glow" -int 1 §2
You can turn off all selection glows (even for locked figures, figure instances, etc) if you wish with this setting:

defaults write com.zengobi.curio "Selection Glow" -bool yes §2

Fast Render

A new rendering optimization kicks in when you:

* Drag figures to move them,

+ Scribble with a brush or eraser,

* Make a rubberband selection of multiple figures,
+ Pinch or scroll wheel zooming.

During those events figure shadows are suppressed until the event concludes. Shadows are one of the slowest bottlenecks during
rendering. This optimization has a massive performance impact especially when working with idea spaces with numerous shadowed

figures.

You can turn off fast rendering in specific modes and/or tweak the delay time before normal rendering is restored.

defaults write com.zengobi.curio "Fast Render When Scroll Zooming" -bool no §2
defaults write com.zengobi.curio "Fast Render When Scroll Zooming Delay" -int 1 §2

defaults write com.zengobi.curio "Fast Render When Pinching" -bool no §2
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Swipe Gesture

defaults write com.zengobi.curio "Fast Render When Pinching Delay" -int 1 §2
defaults write com.zengobi.curio "Fast Render When Scribbling" -bool no gg
defaults write com.zengobi.curio "Fast Render When Moving" -bool no é?
defaults write com.zengobi.curio "Fast Render When Rubberbanding” -bool no é?

Swipe Gesture

Possible values for Idea Space Swipe Handler are 0 which means left/right swiping will now go previous/next in sequence and if
Shift or Command is held then swipes left/right will go back/forward in history, 1 means left/right swiping will now go back/forward
in history and if Shift or Command is held then swipes left/right will go previous/next in sequence.

defaults write com.zengobi.curio "Idea Space Ignore Swipe Gesture" -bool yes Q?

defaults write com.zengobi.curio "Idea Space Swipe Handler" -int 0 g?

Zoom Customizations

Zoom Gestures

Curio supports the pinch to zoom gesture by default, but ignores pinch gestures for zooming if they are too subtle. You can change
how sensitive Curio is to zooming (0.008 is the default, make very slightly larger like to 0.01 for even less sensitive) or even turn it off
entirely if you change this setting.

defaults write com.zengobi.curio "Idea Space Ignore Magnify Gesture" -bool yes §2

defaults write com.zengobi.curio "Idea Space Magnify Gesture Minimum Sensitivity" -float 0.003 §?

Quick Zoom

Quick Zoom can be used to zoom out so the entire idea space is scaled to fit, or zoom in so you can get a closeup of your work.

defaults write com.zengobi.curio "Quick Zoom Shortcut" -string "gq" §2
defaults write com.zengobi.curio "Quick Zoom In Shortcut" -string "Q" CQ

defaults write com.zengobi.curio "Quick Zoom In Factor" -float 2.0 éz

Smart Zoom

Smart Zoom is a feature supported by macOS, if enabled via System Settings > Mouse/Trackpad > Point & Click > Smart Zoom.
Double-tap on your mouse or trackpad to zoom. Then double-tap again to restore the zoom.

By default, Curio will Smart Zoom to the figure you’re hovering over, else the point you’re hovering over, similar to how Smart Zoom
works in Safari.

defaults write com.zengobi.curio "Idea Space Ignore Smart Magnify" -bool yes é?

defaults write com.zengobi.curio "Idea Space Smart Magnify Zoom To Selection" -bool yes g?
defaults write com.zengobi.curio "Idea Space Smart Magnify Zoom To Hover Figure" -bool yes é?
defaults write com.zengobi.curio "Idea Space Smart Magnify Zoom To Hover Point" -bool yes é?

defaults write com.zengobi.curio "Idea Space Smart Magnify Zoom Max Factor" -float 4 §2
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Inline PDF Annotations

Delta

When zooming with the scroll wheel or pinch gesture Curio steps through the tiny 1% increments below 125%, then 10%
increments to just under 200%, then 10% at 200% and beyond. If you wish to fine tune these increments then you can do so here.

defaults write com.zengobi.curio "Zoom Tiny Increment" -float 0.01 Qg
defaults write com.zengobi.curio "Zoom Small Increment" -float 0.1 Q?

defaults write com.zengobi.curio "Zoom Big Increment" -float 0.1 §2

defaults write com.zengobi.curio "Zoom Small Start" -float 1.25 59

defaults write com.zengobi.curio "Zoom Big Start" -float 2.0 é?

Inline PDF Annotations

Normally double-clicking on a PDF launches it in your PDF viewer, like Preview. Holding Option while double-clicking will go into
annotation mode right there on the idea space. If you wish double-clicking to go into annotations mode directly you can change this
setting.

defaults write com.zengobi.curio "Double Click Inline PDF Annotations" -bool no é?

PDF Annotation Colors

Curio’s built-in PDF annotation editor allow for some customization of colors. However, note that currently the button images used in
the inspector bar highlight buttons cannot be changed so if you customize a color you might want to aim for the same family (i.e. a
customized color for the yellow highlight button should ideally be yellow-ish).

defaults write com.zengobi.curio "PDF Editor Yellow Highlight Color" -string "#F7DA34" §?
defaults write com.zengobi.curio "PDF Editor Green Highlight Color" -string "#B2E427" §2
defaults write com.zengobi.curio "PDF Editor Blue Highlight Color" -string "#76A1EF" §2
defaults write com.zengobi.curio "PDF Editor Pink Highlight Color" -string "#EF6BB1" é?
defaults write com.zengobi.curio "PDF Editor Purple Highlight Color" -string "#C686ED" §?
defaults write com.zengobi.curio "PDF Editor Strikethrough Color" -string "#FF0100" é?

defaults write com.zengobi.curio "PDF Editor Underline Color" -string "#027F00" §2

Ignore Bundled Instant Document Templates

If you don’t want Curio to show bundled instant document templates then apply this setting.

defaults write com.zengobi.curio "Ignore Bundled Instant Document Templates" -bool yes g?

Ideaspace Print Auto Expand Threshold

When printing Curio can fit the current idea space to page and rotate the idea space to minimize scaling. It can also auto expand to
additional pages if necessary to further minimize scaling if the resulting scaling value is too small (which can happen with especially
large idea spaces). The default threshold scaling factor is 50%, where any scaling less than that amount will add additional pages,
but you can change this setting.
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defaults write com.zengobi.curio "Ideaspace Print Auto Expand Threshold" -int 50 §2

Figure Tooltips
Tooltips When Status Bar Hidden

Curio can display certain information in the Status Bar, if it’s visible, otherwise it will display it in a tooltip unless you disable this

feature as detailed below.

When hovering over a figure, a compilation of meta info is displayed.

defaults write com.zengobi.curio "Figure Tooltip Info" -bool no Q?

When resizing a figure by dragging its resize handle, its size information is displayed.

defaults write com.zengobi.curio "Figure Tooltip Resize" -bool no §2

Figure Tooltips

When rotating a figure by holding Command and dragging its resize handle, its rotation angle information is displayed.

defaults write com.zengobi.curio "Figure Tooltip Rotate" -bool no §2

Tooltips Independent of Status Bar

Some tooltips display regardless of Status Bar state, although this can be customized:

When hovering over a figure’s flag adornment, like a due date adornment, the flag’s tooltip is displayed. This is on by default. See

below for toggling on or off specific tooltips.

defaults write com.zengobi.curio "Figure Tooltip Flags" -bool no §2

When dragging figures around, the position information is displayed as a tooltip. This is off by default.

defaults write com.zengobi.curio "Figure Tooltip Move" -bool no é?

When dragging a line endpoint or midpiont, a snap help tooltip is displayed. This is on by default.

defaults write com.zengobi.curio "Figure Tooltip Line Points" -bool no §2

Adornment Tooltips

If the above Figure Tooltip Flags is on then you can still customize the display of specific tooltips.
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Percent Complete" -bool no §2
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Ideaspace Flip Tiled Image

Ideaspace Flip Tiled Image

macOS Sonoma 14 has an odd issue where tiled images used as idea space backgrounds are suddenly flipped. Apple fixed this in
macOS Sequoia 15. Curio running on macOS Sonoma 14 will pre-flip the image to work around the issue. You can also control this

via a new setting:

defaults write com.zengobi.curio "Ideaspace Flip Tiled Image" -bool yes Q)

Idea Space Previews

Preview Extension

If PDF Mirror is enabled then Curio will always use the PDF format. However, when PDF Mirror is not enabled Curio automatically
determines the best format to use based on an idea space’s contents. You can however, force a preview extension instead, either
“pdf!! or ijg!!.

®

defaults write com.zengobi.curio "Preview Extension" -string jpg

Preview Cropped Side

Normally when generating a preview, Curio will crop everything past 5000 pixels to right or below. In other words, you only see the
top-left 5000x5000 portion of the idea space. You can make this smaller (to save disk space) or larger (to see more of the preview)
as you wish.

defaults write com.zengobi.curio "Preview Cropped Side" -int 1000 Q

Preview Test Override PDF with JPEG KB

After generating a PDF preview, if larger than 100 KB, Curio will quickly see if a JPEG version is more compact. You can change this
cutoff with this setting.

defaults write com.zengobi.curio "Preview Test Override PDF with JPEG KB" -int 100 Q)

Preview Use PDF for Bitmap

If Curio has a PDF preview then it normally generates the JPEG directly from that PDF data. You can tell it to regenerate it from

scratch if you wish.

defaults write com.zengobi.curio "Preview Use PDF for Bitmap" -bool no Q

Preview Test Override PDF with JPEG Percentage

After generating that test JPEG, Curio will use it instead of the PDF only if the resulting JPEG file size is at least 70% of the size of
the PDF file.
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Preview Scaled Percent

defaults write com.zengobi.curio "Preview Test Override PDF with JPEG Percentage" -int 70 Q

Preview Scaled Percent

If Curio generates a JPEG preview, you can force it to scale to a given percent value. Otherwise, the default is Curio will calculate
the percentage on the fly based on the size of the idea space and the settings below.

defaults write com.zengobi.curio "Preview Scaled Percent" -int 50 Q

Preview Scaled Min Side Upper

Curio will scale the resulting JPEG preview so it has a minimum width or height of 1024 pixels. For example, 1024x1356 or
2352x1024. You can change that minimum side if you wish, for instance 512 would create smaller previews.

defaults write com.zengobi.curio "Preview Scaled Min Side Upper" -int 512 Q

Preview Scaled Percent Ceiling

Once it scales it to a minimum side, you can make Curio scale it further if you wish. For instance, if an idea space is already close to
1024 in width or height then it wouldn’t scale very much. You can tell Curio to at least scale it by 70% this setting.

defaults write com.zengobi.curio "Preview Scaled Percent Ceiling" -int 70 Q

Preview Scaled Percent Floor

If a calculated JPEG scaling factor is too small then Curio imposes a floor scaling, which is 20% by default. We didn’t want a
calculated scaling value to get too tiny.

defaults write com.zengobi.curio "Preview Scaled Percent Floor" -int 20 Q

Preview Output Retina

Curio normally creates non-Retina previews as they’re just fine for a preview. If you have a Retina Mac and really want Retina
previews, which will greatly increase the size of the resulting preview images, then you can enable this.

defaults write com.zengobi.curio "Preview Output Retina" -bool yes Q

Preview JPEG Compression Factor

When generating a JPEG idea space preview file Curio uses a 0.5 compression factor. You can choose a less aggressive value
closer to 1.0, like 0.8, or a more aggressive compression closer to 0.0, like 0.3, this setting.

defaults write com.zengobi.curio "Preview JPEG Compression Factor" -float 0.5 Q
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Preview Compress PDF

Preview Compress PDF

If Curio is generating PDF’s they are normally compressed with a simple ColorSync filter. You can ask Curio to not perform this PDF

compression this setting.

defaults write com.zengobi.curio "Preview Compress PDF" -bool no Q

Preview Background Refresh

Curio normally updates the preview for the active idea space in the background even while you are editing the idea space. Generally
these previews are very quick to generate and, if they are slow for a particular idea space, Curio will automatically refresh the
preview much less frequently. This is key because, for a very brief moment, interactions with the idea space are locked so the
preview can complete. However, if you regularly construct very complex idea spaces you can disable background refresh entirely. If
disabled the only time Curio will force a preview generation is when you leave the idea space and go to another or close the project.

defaults write com.zengobi.curio "Preview Background Refresh" -bool no Q

Preview Immediately Store Thumbnails If None

Back in Curio 10.3, Curio began storing a tiny, compressed JPEG thumbnail of the idea space within the idea space’s data file so it
can be used to quickly render the Organizer display. If the thumbnail is not there, Curio has to read the potentially large PDF preview
file for the idea space and generate the thumbnail on the fly. The embedded thumbnail is automatically updated when you save
changes to an idea space. By default, older projects will also stored updated thumbnails for their idea spaces when the project is
loaded even if the user doesn’t manually touch a particular idea space, unless you turn off this feature this setting.

defaults write com.zengobi.curio "Preview Immediately Store Thumbnails If None" -bool no ﬁ

Preview Generator On Load

Curio scans your entire project when it is loaded to see if any idea spaces have out-of-date previews and then generates them on a
background thread. If you would like to disable this then change this setting.

defaults write com.zengobi.curio "Preview Generator On Load" -bool no Q

Preview Generator Force Update

You can force Curio to regenerate all the previews for a project by setting this preference then opening a project. Use in combination
with Preview Generator Log to watch the preview generation background progress in Console but it should only take a few seconds
to complete. Then close the project and turn off this preference.

defaults write com.zengobi.curio "Preview Generator Force Update" -bool yes Q
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Preview Generator Log

Preview Generator Log

If you would like to see what the idea space preview generator is doing in the background then change this setting. Log messages
are sent to Applications > Utilities > Console.

defaults write com.zengobi.curio "Preview Generator Log" -bool yes §2

Organizer

Idea Space Title

The idea space title can be Untitled (which is the default), a custom string, a date, or a custom date format (date format string).

If Idea Space Title is 0 then it will be either the default text (“Untitled”) or custom text if Idea Space Title Text is also set.

If Idea Space Title is 1 then it will be either the default date format (the long format defined in System Settings) or a custom date

format if Idea Space Title Date Format is also set.

defaults write com.zengobi.curio "Idea Space Title" -int 0 Q?
defaults write com.zengobi.curio "Idea Space Title Text" -string "Ideas" g?
defaults write com.zengobi.curio "Idea Space Title" -int 1 éQ

defaults write com.zengobi.curio "Idea Space Title Date Format" -string "E d/M/yy h:mm a" éz

Folder Title

The folder title can be Untitled, a custom string, a date (which is the default), or a custom date format (date format string).

If Folder Title is O then it will be either the default text (“Untitled”) or custom text if Folder Title Text is also set.

If Folder Title is 1 then it will be either the default date format (the long format defined in System Settings) or a custom date format if
Folder Title Date Format is also set.

defaults write com.zengobi.curio "Folder Title" -int O §2
defaults write com.zengobi.curio "Folder Title Text" -string "Ideas" §2
defaults write com.zengobi.curio "Folder Title" -int 1 59

defaults write com.zengobi.curio "Folder Title Date Format" -string "E d/M/yy h:mm a" é?

Rename New lIdea Space

After creating a new idea space it is, by default, not ready for editing so you can quickly put items into your newly created idea
space. If you’d like to be immediately placed into edit mode then do the following. This feature is most useful when using the Add
button’s power-user modifiers: hold Option when clicking Add to create a blank idea space, or hold Shift when clicking Add to
create an idea space with the same style/template as the current idea space.

defaults write com.zengobi.curio "Organizer Rename New Idea Space" -bool yes Q?
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Rename New Folder

Rename New Folder

After creating a new folder you are placed in edit mode so you can instantly rename it. You can turn this off if you wish.

defaults write com.zengobi.curio "Organizer Rename New Folder" -bool no §2

Journal Sort

Normally Journal years are sorted in descending order, while the months within those years are sorted in ascending order. You can

override this by right-clicking on a Journal item and changing the Journal sort.

If the sort is changed for a project then this is also reflected into the global default and will override both new and existing projects.

You can customize this if you wish.

defaults

defaults

defaults

defaults

defaults

Organizer Preview Size

write

write

write

write

write

com.zengobi.
com.zengobi.
com.zengobi.
com.zengobi.

com.zengobi.

curio

curio

curio

curio

curio

"Journal

"Journal

"Journal

"Journal

"Journal

Sort

Sort

Sort

Sort

Sort

Years Descending" -bool yes

RIS

Months Descending" -bool no

Set Global" -bool yes g?

R

New Match Global" -bool yes

Existing Match Global" -bool yes é?

You can change the Organizer’s default preview size:

Preview Size Defaults Value

None
Small
Medium
Large
XLarge

[0 &

5 &
[10
[50°
[75'

@

1D D

defaults write com.zengobi.curio "Organizer Preview Image Size Hint" -int 0 Q?

Organizer Show Sections

The Organizer’s sections area at the top doesn’t show by default, but you can change this.

defaults write com.zengobi.curio "Organizer Show Sections" -bool yes é?

Organizer Show Filter

The Organizer’s filter area at the bottom doesn’t show by default, but you can change this.

defaults write com.zengobi.curio "Organizer Show Filter" -bool yes é?
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Organizer PDF Display Mode

Organizer PDF Display Mode

If you drag a PDF file into the Organizer it normally scrolls in single-page continuous mode. If you wish you can set it to single-page
at a time by setting this value to 0.

defaults write com.zengobi.curio "Organizer PDF Display Mode" -int 1 Q

Organizer Display HTML In WebView

Normally if a local HTML file is dragged to the Organizer as an Organizer Document then the raw source text will be displayed within
an editable text editor. If you wish to render the HTML in a WebView instead, which is how web URLs are shown, then change this

setting.

defaults write com.zengobi.curio "Organizer Display HTML In WebView" -bool yes Q

Organizer Display Non Text Extensions

Normally any plain or rich text document added to the Organizer is opened for editing directly within Curio. If you wish certain file
types, such as doc or docs, to be opened as a Quick Look view instead (to insure that no formatting is lost) then specify a comma-
separated list of extensions that Curio should skip.

defaults write com.zengobi.curio "Organizer Display Non Text Extensions" -string "doc,docx" Q

Organizer Display Read Only Text Extensions

You may want Curio to only provide read-only access to certain text file extensions dragged to the Organizer, like if you use Nisus
which has custom RTF stylings which the Mac’s built-in framework for RTF editing (which Curio uses) would strip out.

defaults write com.zengobi.curio "Organizer Display Read Only Text Extensions" -string "rtf" &

Organizer Plain Text Document Font

When showing plain text, like markdown, as Organizer documents Curio has a default font and font size that it uses, which you can

override.

defaults write com.zengobi.curio "Organizer Plain Text Document Font" -string "Menlo" Q

defaults write com.zengobi.curio "Organizer Plain Text Document Font Size" -int 12 Q

Organizer Font Size

This is the size of the font the Organizer area uses for item titles. The default is 12.
defaults write com.zengobi.curio "Organizer Font Size" -int 12 Q

This is the size of the font the Sections area uses for item titles. The default is 13.
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RTF View Color

defaults write com.zengobi.curio "Sections Font Size" -int 13 §2

RTF View Color

The RTF Organizer document view normally has a white background. You can change this color with this setting.

defaults write com.zengobi.curio "RTF View Color" -string "#ffffff" Q?

RTF View Inset

The RTF Organizer document has a slight inset to text isn’t crammed into the top-left corner. You can adjust this inset with this
setting.

defaults write com.zengobi.curio "RTF View Inset" -string "{ 50.0, 50.0 }" é?

Quick Find
Quick Find Typing Timeout

Normally Quick Find waits 1 second after the last keystroke before beginning a query. You can press Return to instantly begin the

search, or you can change the timeout.

defaults write com.zengobi.curio "Quick Find Typing Timeout" -float 1.0 Q?

Search

Search Results Export

When exporting your search results as text or markdown you can now customize the title and specify additional header information
in the output, with support for several new variables:

* ({ssearchouery} = the search query

* (%searchGrouping} = the search grouping

* {scurrentDateTime} = the current date and time
* (sprojectTitle} = the project’s title

* (sprojectURL) = the project’s URL link

defaults write com.zengobi.curio "Search Results Export Title" -string "Search Results Grouped by {%SearchGrouping}" é?

defaults write com.zengobi.curio "Search Results Export Text Header" -string "Project: {%ProjectTitle}\nDate:

{%CurrentDateTime}\nQuery: {%SearchQuery}" §2
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Search Auto Refresh Results

defaults write com.zengobi.curio "Search Results Export Markdown Header" -string "Project: [{%ProjectTitle}] ({%ProjectURL})

\nDate: {%CurrentDateTime}\nQuery: {%SearchQuery}" Q

Search Auto Refresh Results

While viewing search results if figures are changed, deleted, or created then the results automatically refresh. This auto refresh
feature can be disabled.

defaults write com.zengobi.curio "Search Auto Refresh Results" -bool no Q

Search Hash Is Tag Prefix

Normally if you search for a word with a # (aka hash or pound sign) prefix then it assumes the text is a tag name and searches for
tags. If you don’t want the has prefix to represent a tag then this feature can be disabled.

defaults write com.zengobi.curio "Search Hash Is Tag Prefix" -bool no é)

Use SearchKit

If you don’t want Curio to search the contents of your project assets then change this setting.

defaults write com.zengobi.curio "Use SearchKit" -bool no Q

SearchKit Ignore Extensions

SearchKit normally scans most file types but you can add additional file extensions that it should ignore via a comma-separated list.

defaults write com.zengobi.curio "SearchKit Ignore Extensions" -string "nb,sib" Q

SearchKit Log

If you have problems searching within asset contents then turn on SearchKit logging.

defaults write com.zengobi.curio "SearchKit Log" -bool yes Q

Search Into PDF Pages

If you don’t want Curio to search the within the PDF pages to find out specifically which pages match the query text then change
this setting.

defaults write com.zengobi.curio "Search Into PDF Pages" -bool no Q
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Search Tags Inherit Idea Space Tags

Search Tags Inherit Idea Space Tags

Prior to Curio 12, figures on an idea space would automatically inherit tags associated with the idea space itself. This no longer
occurs since this inheritance was not obvious.

defaults write com.zengobi.curio "Search Tags Inherit Idea Space Tags" -bool no Q?

Assets

Asset Resolve Alias

If you don’t want Curio to ask you to resolve every broken alias in your project then change this setting.

defaults write com.zengobi.curio "Asset Resolve Alias" -bool no §2

Embed Assets

Normally we embed files dragged into Curio, unless Option is held down during the drag. If you’d like to reverse this logic then
change this setting.

defaults write com.zengobi.curio "Embed Assets" -bool no §2

Force Alias To Folders

Normally if you drag a folder into Curio we insert it as an alias, regardless of whether the Option key is pressed or not. We do this
primarily to reduce confusion: while an embedded or aliased folder is considered an asset in Curio, the contents of the folder are
not, so you cannot tag, search, or do anything with those contained files within Curio but only via the Finder instead. By forcing
folders to be an alias, the folder truly lives outside of Curio and it makes sense that the contained files are not true Curio assets. If,
however, you wish to allow embedded folders and understand that while the folder and its contents exist within your Curio project’s
package the contents are not true assets, and where, like dragged-in files, they will be added as embedded copies by default and
aliases only if Option is held down during the drag, then change this setting.

defaults write com.zengobi.curio "Force Alias To Folders" -bool no é?

Asset Default Title Show Extension

When you drag a file into Curio its default title is normally the file name without its extension. You can make titles include the file
extension if you wish.

defaults write com.zengobi.curio "Asset Default Title Show Extension" -bool yes §2
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Non-Media File Extensions

Non-Media File Extensions

Normally Curio asks QuickTime via Apple’s QTKit if a given file dragged into Curio is a media file. On some rare systems, QTKit
appears to be a bit too aggressive for unknown reasons so Curio may believe a boring text file dropped into Curio is a movie file. If
you want to add extensions for Curio to treat as non-media files then change this setting.

defaults write com.zengobi.curio "Additional Non Media Files" -string "nb,config" Q

Asset Max File Name Length

When renaming the title of an asset or asset figure, Curio will try to rename the underlying asset file as well, if it’s embedded. It filters
out non-OS-safe characters, of course, but we can also clip it to a max file name length. By default this max length is 255
characters, which is the max supported by OS X, but you can set it to a smaller value if you need those asset files to work with other
3rd party applications or services that may not work with such long file names.

defaults write com.zengobi.curio "Asset Max File Name Length" -int 50 é)

Delete Last Use Action

Normally when you delete an asset figure in Curio, if it is not being used by any other figure within your project, then Curio will
automatically send that item to the Trash since it is no longer needed. However, using the following setting you can tell Curio to ask
you before discarding the asset (value=0), leave it in your Library as an Unused Asset (value=1), or move it to the Trash (value=2).

defaults write com.zengobi.curio "Delete Last Use Action" -int 2 i)

Assetlibrary Log Level

Watch what the internal asset library is doing. Log messages are sent to Applications > Utilities > Console. The value of 3 is the max
detail log level.

defaults write com.zengobi.curio "AssetLibrary Log Level" -int 3 é)

Extensions Ignore Title Changes

Normally if you rename the title of an asset figure on an idea space or asset in the library, Curio will also rename the underlying file,
thus keeping the title and file name in sync. However, you can specify a comma separated list of file extensions that don’t rename
when the title is renamed.

defaults write com.zengobi.curio "Extensions Ignore Title Changes" -string "mov,mp4" Q
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Library

Library

Library Autorefresh

Curio’s project library shelf allows you to view assets in the current section or idea space. Normally the results are not refreshed
automatically if you change to a different section or Organizer item in case you want to drag a resulting item from the Library to a
different area of your project. You can force a refresh by clicking the refresh icon on the library shelf or you can tell Curio to
autorefresh automatically based on section changes or Organizer changes using these settings.

defaults write com.zengobi.curio "Section Selects Autorefresh Library" -bool yes éz

defaults write com.zengobi.curio "Organizer Selects Autorefresh Library" -bool yes §2

Local Library

Dragging from the Local Library shelf normally follows that global Embed Assets setting mentioned above, although you can
override drags specifically from the Local Library so they are aliased instead.

defaults write com.zengobi.curio "Local Library Drag Embed" -bool no §2
Text files dragged in from the Local Library shelf can come in as file-backed text figures.

defaults write com.zengobi.curio "Local Library Import Text Files As File Backed Text Figures" -bool no é?

Curiota

Curiota Note Prepend Title

Curio normally automatically prepends the Curiota note title (if it exists) onto the note body if dragged in from the Local shelf.

defaults write com.zengobi.curio "Curiota Note Prepend Title" -bool no é?

Curiota Note Bold Title

If prepending the note title, as mentioned above, then Curio normally makes that title a bold version of the same font used in the

note itself.

defaults write com.zengobi.curio "Curiota Note Bold Title" -bool no Q?

Curiota Extensions to Text Figures

If you drag a Curiota Note into Curio via the Local library shelf, Curio will convert that note (technically a RTF or RTFD file) into a
native Curio text figure. But if you drag in other types of files that you’ve stored within Curiota, Curio creates file asset figures
instead. However, you can tell Curio to treat certain file extensions differently when dragged in from Curiota and text figures will be

created instead.
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Scribble

defaults write com.zengobi.curio "Curiota Extensions to Text Figures" -string "rtf,rtfd, txt,md" Q

Scribble

Scribble Pressure Multiplier

You can now customize the multiplier Curio applies to any pressures via a tablet or iPad connected via the macOS Continuity

feature. We’ve noticed, that at least with our iPad Pro and Pencil 1, that a value of 5 is perfect for sketching via Sidecar, while a
value of 1.3 is better for sketching via Luna, Duet, or Wacom. You may need to fine tune this value given your specific hardware
setup.

defaults write com.zengobi.curio "Scribble Pressure Multiplier" -float 5 Q

defaults write com.zengobi.curio "Scribble Pressure Multiplier" -float 1.3 Q

Brush Crosshair

Curio will use the crosshair cursor when scribbling with brushes 2 pixels wide or smaller. You can now change that by changing this
setting.

defaults write com.zengobi.curio "Use Crosshair For Small Brush" -bool no ﬁ

defaults write com.zengobi.curio "Brush Crosshair At Size" -float 2.0 é)

Brush Log Level

You can enable brush logging if you are having some odd issues with the scribble tools.

defaults write com.zengobi.curio "Brush Log Level" -int 1 Q)

Table of Contents
ToC Text Only At Level

By default, Curio includes previews until hierarchical level 3 when it switches to text only entries.

defaults write com.zengobi.curio "ToC Text Only At Level" -int 3 ﬁ

ToC Text Only At Max Children

If a Table of Contents parent node has a max number of children or more, then those children will be text only. For example, if a
particular parent has 75 children then perhaps text-only is fine, but another with only 12 children can show icons. If 0, the default,
then this check is not performed.
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ToC Collapse At Level

defaults write com.zengobi.curio "ToC Text Only At Max Children" -int 50 Q)

ToC Collapse At Level

By default, Curio automatically collapses the 2nd hierarchical level in the Table of Contents. If you’d like to see more, simply click a
parent’s expand widget to see those child items.

defaults write com.zengobi.curio "ToC Collapse At Level" -int 2 Q

ToC Stop At Level

By default, Curio includes the first 3 hierarchical levels in the Table of Contents. For complex projects, reducing the number of levels
can make generation faster. Note that Curio may throttle the specified value if a massive number of entries would be created, see
below for more details.

defaults write com.zengobi.curio "ToC Stop At Level" -int 3 é)

ToC Stop At Level At Max Figures

As a safety catch, regardless of what the user has specified in the inspector, to avoid generating a massively large list or mind map,
Curio will automatically reduce the included levels to try to bring the number of entries in the entire collection to no more than 200
entries, which is the default. So if 3 levels has 350 entries, and pruning to 2 still leaves 220, then will prune back to level 1 (the
minimum). If 0, then all levels are included regardless of how large the resulting collection becomes. Keep in mind, 200 entries at
roughly 40 pixels tall per entry, the resulting list would be roughly 8,000 pixels tall!

defaults write com.zengobi.curio "ToC Stop At Level At Max Figures" -int 200 Q

ToC Title

The title of the Table of Contents is the dynamic variable {%ldeaSpaceTitle}, by default, so it reflects the title of its containing idea
space.

defaults write com.zengobi.curio "ToC Title" -string "{%IdeaSpaceTitle}" ﬁ

Spread PDF
Spread PDF Limit

Spreading a PDF within an idea space normally limits the number of pages in the PDF to 20 so that the resulting idea space isn’t too

large, mainly for memory reasons. You can change this limit if you change this setting.

defaults write com.zengobi.curio "Spread PDF Limit" -int 20 Q
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Spread PDF Horizontal and Vertical Gap

Spread PDF Horizontal and Vertical Gap

Spreading a PDF within an idea space normally uses a gap of 50 points between duplicated figures in the horizontal and vertical
directions. You can change this limit if you change this setting.

defaults write com.zengobi.curio "Spread PDF Horizontal Gap" -int 50 Q

defaults write com.zengobi.curio "Spread PDF Vertical Gap" -int 50 Q)

Import, Export, & Sync

Markdown Text Import Convert To Figure

When you drag a markdown file into Curio it can convert it into a text figure or asset figure and asks you this via a popup alert. If you
suppress the alert by checking the don’t ask me again checkbox then Curio doesn’t show the alert in the future and automatically
performs your last chosen action.

If you want to reset this so you see the alert once again do this:

[defaults delete com.zengobi.curio “Markdown Text Import Convert To Figure™ &

Smart Paste

Like Apple’s Notes and Microsoft’s Word, Curio now supports a smarter paste by default.

Now when pasting into a Curio text figure, any pasted rich text will match the surrounding text style including font, font size, and
text color while still transferring specific attributes (links, bold, italics, strikethrough, baseline, attachments, superscript). This is a
definite step up from pasting as plain text as you would lose all of those attributes.

You can still use Paste As > Rich Text if you want all the attributes.

Disabling Smart Paste as Default Paste

Alternatively, you can restore the normal paste operation by disabling smart paste by default and use the Smart Paste menu item
under Paste As only when you need it:

defaults write com.zengobi.curio "Smart Paste" -bool no Q

Customizing Smart Paste

This is a bit advanced but you can also customize which attribute keys are included in smart paste.

Here are the attributes smart paste includes by default: ~Nsront , NSattachment , NSLink , NSBaselineOffset , NSStrikethrough ,

NSSuperScript .
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Some notes on those default attributes:

* You may be confused why wsront is in there as the font itself is not transferred over. The reason is so Curio can get the
bold and/or italics traits from the pasted text’s font then apply that to the figure’s font. So the font itself is not used, just the
bold/italic traits.

 Image attachments and links are copied over.

* Baseline offsets help with subscript and superscript. The additional wnssuperscript may have been used instead of baseline
so that’s included, too. (There is N0 wssubscript , just FYL.)

And here are the optional attributes you may want to add: wscolor , NsBackgroundColor , NSUnderline , NSUnderlineColor ,

NSStrikethroughColor .
Some notes on why those weren’t added by default:

* The foreground text color may be hard to see with certain figure fill colors.

* The background text highlight color may be hard to see with certain figure fill colors or text colors.

 The underline related attributes may be hard to see with certain fill colors and conflict with the automatic link underlining and
coloring.

« The strikethrough color may be hard to see with certain figure fill colors.

An example: if you wanted to keep text colors then you can do this:
defaults write com.zengobi.curio "Smart Paste Add Attributes" -string "NSColor" Q
And if you wanted to remove image attachments you could do this:
defaults write com.zengobi.curio "Smart Paste Remove Attributes" -string "NSAttachment" Q)

Both of those customizations take a comma separated list of attributes that you want to add or remove.

Smart Paste URL

You can copy an URL, like from the location bar of your browser, or an URL string and paste it on selected text within a text figure
and that text will turn into a link to that URL.

You can disable this feature entirely or just disable support for URL strings with these settings:

defaults write com.zengobi.curio "Smart Paste URL" -bool no Q)

defaults write com.zengobi.curio "Smart Paste URL String" -bool no Q

This can also create a markdown syntax link if markdown is enabled.

Colored Rich Text

Normally the coloring of text is maintained when you copy or export rich text. That way if you copy red text, it will paste as red text
in another application. However if the text was white, perhaps because it was in a mind map node that was a dark color, then, by
default, Curio will change its coloring on the clipboard to black so it’s visible when you paste it into another application (which
presumably has a white background, like TextEdit, Word, or Pages). You can turn off this feature if you wish, you can also tell Curio
to always force a black coloring for copied text.
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Export Rich List Uses Multi Tabs

defaults write com.zengobi.curio "Copy Rich Text Force Black Text If White" -bool no Q

defaults write com.zengobi.curio "Copy Rich Text Force Black Text" -bool yes Q

Export Rich List Uses Multi Tabs

Normally when you copy a hierarchical collection, like a list or mind map, as rich text Curio will use one or more tabs to indicate the
hierarchical level of each line item.

Alternatively, Curio can always output a single tab and adjust each item’s rich text ruler indention distance instead.

defaults write com.zengobi.curio "Export Rich List Uses Multi Tabs" -bool no Q

PDF Export

Normally when you export a Curio project as a PDF any curio:// links that would jump to destination figures or idea spaces within
the same project are converted into PDF page jumps, so clicking the link in the PDF will jump to that destination’s page within the

same PDF.

However, if you’d rather leave the curio:// link as is, so clicking it in the PDF would launch Curio and jump to that location in the
actual Curio project, then you can make this change:

defaults write com.zengobi.curio "PDF Export Add Links" -bool no Q

CSV Import Encoding

Text files can be encoded in a number of formats, such as macOS Roman and UTF-8. This encoding is key when Curio tries to

import a CSV for display as a table.

The default assumed encoding is the venerable macOS Roman ( nsMacosromanstringEncoding ) Which has a value of 30 and seems
to be the most reliable. You can also try telling Curio to assume the file is UTF-8 encoded by setting this override to 4

( NSUTF8StringEncoding )

There are a number of other encodings you can try if you’re having difficulties with a certain CSV file.

defaults write com.zengobi.curio "CSV Import Encoding" -int 30 Q)

Export CSV UTF16LittleEndianBOM

Table exporting as CSV usually outputs everything in the Unicode UTF-8 standard. However, Microsoft Excel apparently has
problems with that format and international characters may not appear correctly. You can change Curio’s export format to UTF-16
which works with Excel if you change this setting.

defaults write com.zengobi.curio "Export CSV UTFlé6LittleEndianBOM" -bool yes Q)
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Asset Image Scan OCR

Asset Image Scan OCR

Normally when images are dropped into Curio it will use Apple’s Vision framework to do Optical Character Recognition on the
images to extract text. Then the Search shelf and Quick Find can be used to find text that appear on your images.

The scanning of OCR data happens in the background and takes just a moment. However, you can disable this feature if you'd like
with this setting.

defaults write com.zengobi.curio "Asset Image Scan OCR" -bool no Q

Image Export Retina

On Retina Macs Curio will create 144 DPI image exports so they are optimized for those systems, instead of regular 72 DPI images.
Image exports will appear to be large on non-Retina systems unless the image viewer honors the image’s DPI setting. If you wish to
force Curio to output non-Retina (72 DPI) images on Retina systems then change this setting.

defaults write com.zengobi.curio "Image Export Retina" -bool no ﬁ

Equation Force Scale Local PDF

When rendering equations as PDF Curio has to ask WebKit for a rendered PDF of the WebView then crop it appropriately. If your
main screen is non-Retina or you have a mix of Retina and non-Retina screens then you could encounter an issue where the
cropped results is a blank equation. This setting will fix that issue.

defaults write com.zengobi.curio "Equation Force Scale Local PDF" -bool yes ﬁ

HTML Image Export Retina

On Retina Macs Curio will create 144 DPI HTML imagemap exports and image exports so they are optimized for those systems,
instead of regular 72 DPI images. The HTML imagemap will still look extremely good on non-Retina systems thanks to the HTML
img height and width tags added to the HTML export templates and the browser’s built-in scaling. Image exports will appear to be
large on non-Retina systems unless the image viewer honors the image’s DPI setting. If you wish to force Curio to output non-Retina
(72 DPI) images on Retina systems then change this setting.

defaults write com.zengobi.curio "HTML Image Export Retina" -bool no Q

Calendar Sync

You can set several defaults for Calendar and Reminders syncing including the default Calendar and Reminders list to sync to.

Note that you still need to manually enable syncing for a new project via the Sync inspector. However, once enabled Curio will
automatically find the specified default Calendar and Reminders list to sync to.

defaults write com.zengobi.curio "Calendar Sync Default Calendar Name" -string "Curio" Q
defaults write com.zengobi.curio "Calendar Sync Default Reminders Name" -string "Curio Tasks" Q

defaults write com.zengobi.curio "Calendar Sync Prefix With Project Name" -bool yes é)
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defaults write com.zengobi.curio
defaults write com.zengobi.curio

defaults write com.zengobi.curio

Status Shelf

The Status shelf has a few settings you can override.

defaults write com.zengobi.curio

Status Shelf

"Calendar Sync Prefix With Collection Name" -bool yes §?

"Calendar Sync Ignore Synced Figure Instances" -bool yes §2

"Calendar Sync Name Includes Source" -bool yes é?

"Status Ignore Synced Figure Instances" -bool yes §2

Copy As Hyperlink

You can tell Curio to not include the title at all, so only the URL is copied:

defaults write com.zengobi.curio "Copy As Hyperlink Includes Title" -bool no Q?

See Hyperlink Title below for options on how you can customize the hyperlink title.

Copy As Markdown Link

Markdown links are of the form

has a left or right parenthesis those are left as-is, as well.

[title] (1ink) . If the title has a left or right bracket those are currently left as-is. Likewise if the link

Your preferred markdown renderer may be able to handle those just fine, however your renderer may want brackets escaped, like \

[ and \]

defaults

defaults

defaults

defaults

and your links escaped with \( and

write

write

write

write

com.

com.

com.

com.

zengobi.

zengobi

zengobi.

zengobi.

curio

.curio

curio

curio

"Markdown

"Markdown

"Markdown

"Markdown

URL

URL

URL

URL

\) oreven s28 and

%29 .

S

Title Escape Left Bracket" -string "\[" §2

Title Escape Right Bracket" -string "\]" é?

Link Escape Left Paren" -string "\ (" é?

Link Escape Right Paren" -string "\)" §2

See Hyperlink Title below for options on how you can customize the hyperlink title.

Hyperlink Title

You can customize what’s included in a hyperlink, wikilink, or jump link title which is normally of the form “ProjectTitle/

IdeaspaceTitle/FigureTitle”.

Customize the “/” separator between project, section, idea space, and figure:

defaults write com.zengobi.curio "Hyperlink Title Separator" -string "/" §?

Project’s Title

Choose to not include the project title:

defaults write com.zengobi.curio "Hyperlink Title Includes Project" -bool no Q?
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Export Markdown Checkmarks

Idea Space’s Title

For the idea space Curio will take the entire title, including punctuation.
Figure’s Title
If a figure hyperlink is getting created, choose to not include the idea space title:
defaults write com.zengobi.curio "Hyperlink Figure Title Includes Idea Space" -bool no g?

For the figure’s title just the first sentence is grabbed by default (1), or you can change it to the first line (2), or the whole thing but
new lines turned into spaces (3):

defaults write com.zengobi.curio "Hyperlink Figure Title Technique" -int 1 é?
Any trailing punctuation are removed from the figure title by default:

defaults write com.zengobi.curio "Hyperlink Figure Title Remove Ending Punctuation" -bool yes §2
Any inline meta, such as #tag oOr egresource , are removed from the figure title by default:

defaults write com.zengobi.curio "Hyperlink Figure Title Remove Inline Meta" -bool yes §?
The figure title is truncated at 30 characters by default and an ellipsis is added:

defaults write com.zengobi.curio "Hyperlink Figure Title Max Length" -int 30 §§?

defaults write com.zengobi.curio "Hyperlink Figure Title Truncate Add Ellipsis" -bool yes §2

Export Markdown Checkmarks

If items have checkmarks Curio will export markdown suchas [ 1 and (x] which some extended markdown parsers support.

defaults write com.zengobi.curio "Export Markdown Checkmarks" -bool no é?

defaults write com.zengobi.curio "Export Markdown Unchecked" -string "[ 1" §2
defaults write com.zengobi.curio "Export Markdown Checked" -string "[x]" §2
defaults write com.zengobi.curio "Export Markdown Mixed" -string "[-]" §2

Export Markdown Other

If exporting for import into OmniFocus you might want Curio to use edefer instead of estart for start dates:
defaults write com.zengobi.curio "Export Markdown Use Defer" -bool yes §2
If exporting for import into TaskPaper you might want Curio to use edone instead of eprogress for percent complete progress:

defaults write com.zengobi.curio "Export Markdown Use Done" -bool yes Q?

Markdown Inline Footnotes

As shown below, Curio can export a figure’s notes into a special inline markdown footnote.
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Markdown Note Replace New Line

Curio can optionally import footnotes, but this is disabled by default. This is because notes lose rich text formatting when exported
so if imported you will lose formatting. If that’s okay, and you only use simple text for your figure notes, then you can enable
footnote importing.

defaults write com.zengobi.curio "Import Footnotes Into Notes" -bool yes é?

Markdown Inline Footnote Format

Normally Curio outputs figure notes as markdown inline footnotes compatible with the popular Obsidian/Pandoc/markdown-it

format, like ~[This is a note]

However, you can also ask Curio to use the MultiMarkdown renderer which is used in many apps, such as IA Writer: [~This is a

note]

defaults write com.zengobi.curio "Export Markdown Note Footnote Format" -int 0 §2

Markdown Note Replace New Line

When exporting markdown within the inline footnote described above, Curio normally replaces any new lines (aka a \n) with 3
spaces, converting multi-line notes into a single, long line of concatenated sentences.

For example a multi-line note for a figure like this:

This is a test.
A second line.

Would turn into a footnote like this:

~[This is a test. A second line.]

You can customize what string is used for replacement instead of those 3 spaces.
Some ideas:

+ One space would essentially convert multi-line notes into a single, long line of concatenated sentences.

« Two spaces might be workable if you normally type 1 space between sentences, then 2 would indicate a new line.

« Three spaces might be workable if you normally type 2 spaces between sentences, then 3 would indicate a new line.
* The 9] character is easy to type in macOS: Option-7.

» The «J character looks great.

We chose three spaces as that seems like a safe solution.

If you choose anything other than a single space, then when importing or syncing figures multi-line notes can be restored when
imported as the custom string is converted back into a new line.

defaults write com.zengobi.curio "Export Markdown Note Replace New Line" -string " " §§2
defaults write com.zengobi.curio "Export Markdown Note Replace New Line" -string " " Q?
defaults write com.zengobi.curio "Export Markdown Note Replace New Line" -string " " 3§2

defaults write com.zengobi.curio "Export Markdown Note Replace New Line" -string "q" §2

defaults write com.zengobi.curio "Export Markdown Note Replace New Line" -string "<J" Q?
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Export Note Prefix and Suffix

Export Note Prefix and Suffix

When exporting figures, if note exporting is enabled, then notes are generally delimited with special character strings which you can

override.
defaults write com.zengobi.curio "Export Text Note Prefix" -string " (" Q?
defaults write com.zengobi.curio "Export Text Note Suffix" -string ")" é?

defaults write com.zengobi.curio "Export Rich Text Note Prefix" -string "

| &
&

defaults write com.zengobi.curio "Export Rich Text Note Suffix" -string ")°'

defaults write com.zengobi.curio "Export Markdown Note Prefix" -string "\["" g?

defaults write com.zengobi.curio "Export Markdown Note Suffix" -string "\]" é?

Export ASCII Filenames

Make the filenames generated via image and HTML export safe, ASCII (7-bit) characters by changing this setting.

defaults write com.zengobi.curio "Export ASCII Filenames" -bool yes §2

Copy Text Outline Note Keep CRLF

Normally the mind map and list text outline exporters strip carriage returns contained in figure notes. However, you can tell Curio to
leave them in by changing this setting.

defaults write com.zengobi.curio "Copy Text Outline Note Keep CRLF" -bool yes g?

MindNode Exports As Package

Normally Curio will export a mind map as a MindNode file in zipped format. Alternatively you can ask Curio to export as an OS X
package file if you wish. In both cases the resulting file extension is .mindnode.

defaults write com.zengobi.curio "MindNode Exports As Package" -bool yes §?

AV Session Preset

By default Curio will use the AVCaptureSessionPresetMedium internal setting for making audio and video recordings which is
medium quality and size. You can tell Curio to use a different preset, such as a higher-resolution preset for larger video and better
quality audio.

defaults write com.zengobi.curio "AV Session Preset" -string "AVCaptureSessionPresetHigh" §2

-402/423 - Copyright © 2025 Zengobi, Inc.


curio://defaults-write?Export%20Text%20Note%20Prefix=-20(
curio://defaults-write?Export%20Text%20Note%20Suffix=)
curio://defaults-write?Export%20Rich%20Text%20Note%20Prefix=-20(
curio://defaults-write?Export%20Rich%20Text%20Note%20Suffix=)
curio://defaults-write?Export%20Markdown%20Note%20Prefix=[%5E
curio://defaults-write?Export%20Markdown%20Note%20Suffix=]
curio://defaults-write?Export%20ASCII%20Filenames=yes
curio://defaults-write?Copy%20Text%20Outline%20Note%20Keep%20CRLF=yes
curio://defaults-write?MindNode%20Exports%20As%20Package=yes
curio://defaults-write?AV%20Session%20Preset=AVCaptureSessionPresetHigh

Default Mail Client (Only For Non-Mac App Store Curio)

Default Mail Client (Only For Non-Mac App Store Curio)

Normally Curio determines the default mail client by asking the system. The official way to set your mail client is to launch Mail,
choose Mail > Settings and change the Default mail reader. Alternatively you can tell Curio to use a specific client, assuming we
support it. Currently we support the following mail clients using AppleScript: Mail, Outlook, Entourage, Eudora, Postbox, Airmail,
and MailMate.

defaults write com.zengobi.curio "Use Mail App" -string "Postbox" Q

Custom Mail Script (Only For Non-Mac App Store Curio)

As mentioned above, Curio uses AppleScript to communicate with mail clients that it supports. You can supply a custom script if
you wish by placing a scripts/cCreateMessage.applescript file in your Curio application support folder and then setting the
foIIowing. You can see Curio’s bundled SCI’iptS in /Applications/Curio.app/Contents/Frameworks/GGCore. framework/Versions/A/

Resources/Scripts .

defaults write com.zengobi.curio "Custom Mail Scripts" -bool yes é)

PDF Mirror

By default the PDF Mirror feature exports sections with the name of the form  *projectName*-*sectionName*.pdf , SUcCh as pepsi-
sales.pdf . However, you can customize it so it includes the section index in the resulting name like pepsi-001-sales.pdf with a
minimum number of digits, which is handy if you’d like to maintain the same ordering in the Finder as you see within Curio.

defaults write com.zengobi.curio "Publish PDF Section Filename Index" -bool yes Q

defaults write com.zengobi.curio "Publish PDF Section Filename Index Min Digits" -int 3 Q

Presentation Mode

Presentation PreCollapse Mind Maps

Before Curio displays an idea space during presentation mode it can pre-collapse all mind maps if you wish.

defaults write com.zengobi.curio "Presentation PreCollapse Mind Maps" -bool yes Q

Smart Zoom

Smart Zoom is a feature supported by macOS, if enabled via System Settings > Mouse/Trackpad > Point & Click > Smart Zoom.
Double-tap on your mouse or trackpad to zoom. Then double-tap again to restore the zoom.

Smart Zoom during presentation mode will apply a multiplier to the current slide’s magnification with the result constrained to a min
and max scaling factor.

Note if the slide is already magnified past the max scaling factor then Smart Zoom isn’t activated.
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Evernote

defaults write com.zengobi.curio "Presentation Ignore Smart Magnify" -bool yes Q
defaults write com.zengobi.curio "Presentation Smart Magnify Zoom Multiplier" -float 2

defaults write com.zengobi.curio "Presentation Smart Magnify Zoom Min Factor" -float 2

RRRARS

defaults write com.zengobi.curio "Presentation Smart Magnify Zoom Max Factor" -float 4

Evernote

Deprecation Notice
As a notice, Curio’s support for Evernote will cease at some point. Evernote isn’t nearly as popular as it was over a decade ago
and that old API has long had issues.

Evernote Supported

If you really don’t want to see the Evernote shelf you can turn it off.

defaults write com.zengobi.curio "Evernote Supported" -bool no Q

Evernote Check Installed

Before potentially allowing Evernote support Curio will see if Evernote is installed. If not then the Evernote shelf tab won’t appear in

Curio. You can disable this install check if you’d like.

defaults write com.zengobi.curio "Evernote Check Installed" -bool no ﬁ

Evernote Assign Notebook Tag

Optionally Curio can create a global tag set called “Evernote” and create and assign a tag that matches the Evernote notebook the
note originated from and any tags associated with the note. You can control this feature with these settings:

defaults write com.zengobi.curio "Evernote Assign Notebook Tag" -bool no Q

defaults write com.zengobi.curio "Evernote Assign Note Tags" -bool no ﬁ

Evernote Results Limit

Normally Curio will only return up to 500 matches in an Evernote notebook, based on the entered search and sorting criteria.

defaults write com.zengobi.curio "Evernote Results Limit" -int 500 Q
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Evernote Results Limit

Evernote Results Limit

Normally Curio will only automatically download and cache the first 5 notes in a result set, in order to minimize the number of
requests hitting Evernote’s server. We will also download any note when it is selected. To increase the download limit use this
setting but don’t make it too high or you could hit Evernote’s 3rd Party App Rate Limits.

defaults write com.zengobi.curio "Evernote Auto Download Limit" -int 5 Q

Evernote Request Thumbnails

Curio will normally request note thumbnails from the Evernote cloud. Set this to no if you only want local icons instead.

defaults write com.zengobi.curio "Evernote Request Thumbnails" -bool no Q

Evernote Note URL

Curio will normally add an attribution line to any text dragged in from the Evernote shelf so you can easily get back to the original
note in the Evernote Mac client. However, this attribute line addition can be disabled if you wish.

defaults write com.zengobi.curio "Evernote Note URL" -bool no Q

Evernote Force Host

This setting can be used to force a connection to the app.yinxiang.com service, instead of www.evernote.com, if the automatic
mechanism for doing so (based on IP address and locale) is not working.

defaults write com.zengobi.curio "Evernote Force Host" -string "app.yinxiang.com" Q

Evernote Log Level

Watch what the Evernote shelf is doing. Log messages are sent to Applications > Utilities > Console. The value of 2 is the max detail
log level.

defaults write com.zengobi.curio "Evernote Log Level" -int 2 é)

Sleuth
Sleuth Is KidSafe

If you wish Sleuth to only show kid-safe websites and enable the built-in profanity filter then change this setting.

defaults write com.zengobi.curio "Sleuth Is KidSafe" -bool yes Q
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Sleuth History Size

Sleuth History Size

Specify the number of entries in Sleuth’s history by changing this setting.

defaults write com.zengobi.curio "Sleuth History Size" -int 10 §2

Support Folders

Applicable only in Curio from Zengobi’s website, not from the Mac App Store due to sandboxing restrictions.

Personal Repository Folder

By default your Curio personal repository of tags, idea space templates, stencils, etc, isat ~/vibrary/application Support/Curio/
rRepository . However, if you would like to change this to something else, like a synced Dropbox folder, then move it over there and
change this setting.

Note that if you want the Curio Spotlight plugin to find your tags and include them in its index generation then it needs to be pointed
to the new location as well.

1. Quit Curio on all of your Macs that you intend to sync.
2. On Your Main Mac:
1. In the Finder, choose Go > Go to Folder and paste this in: ~/Library/application Support/Curio .
2. Open another Finder window and go to your Dropbox folder.
3. Create a folder in Dropbox named “Curio”, thus its path is ~/propbox/curio .
4. Drag-and-drop the Repository folder from within the ~/1nibrary/application Support/Curio/Version xx/ folder to the
Dropbox’s Curio folder, thereby creating ~/propbox/curio/Repository .
5. Launch Applications > Utilities > Terminal and type this: defaults write com.zengobi.curio "Personal Repository
Folder" -string "~/Dropbox/Curio/Repository"
6. When you relaunch Curio it will automatically migrate your repository files into a Version XX subfolder within the
Repository folder then connect to the files.
3. On your other Macs launch Applications > Utilities > Terminal and type this: defaults write com.zengobi.curio "Personal

Repository Folder" -string "~/Dropbox/Curio/Repository"

That’s it! Now all your Macs are pointing to the same personal repository folder which exists on Dropbox instead of the default
location.

Note that the repository override should point to the Repository folder itself, not a Version XX subfolder. Curio will look for and
manage the Version XX folder automatically so that Curio 11 looks within Version 11 and Curio 12 will look within Version 12.

Sharing Your Personal Repository Folder with Others

1. Follow the steps above to relocate your personal repository folder to Dropbox.
2. In the Finder, right-click on the Repository folder in Dropbox and choose Share. You will be taken to Dropbox’s website
where you can invite others to have access to that folder.
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Application Support Folder

3. When others accept your share invitation they will see a new shared folder titled “Repository” appear within their Dropbox
folder.

4. They are able to rename and even move this folder elsewhere within their Dropbox folder hierarchy. For example, if your
name is Tom then perhaps they rename “Repository” to “Tom” and move it into @ ~/propbox/shared Repositories folder .
Even though the folder has been renamed and moved it is still connected to and syncing with Tom’s original Repository
folder.

5. Next, they launch Curio and bring up the Settings window and add a new external repository by choosing the ~/propbox/
Shared Repositories/Tom folder.

6. When they relaunch Curio, your styles, stencils, and templates will now be available on your friend’s machine. As you add
new styles and stencils they will sync to everyone sharing your repository.

Application Support Folder

By default your personal Curio application support folder is at ~/nibrary/application Support/curio . However, if you would like to
change this to something else, like a synced Dropbox folder, then move it over there and change this setting.

Warning

This is more drastic than just overriding the Personal Repository Folder as described above, since you’d be sharing everything
that goes into Curio’s app support folder including project gallery and Status shelf project categories and lists, temporary
documents, and other items. The Personal Repository Folder may be a better choice for most users.

Note that if you want the Curio Spotlight plugin to find your tags and include them in its index generation then it needs to be pointed
to the new location as well.

. Quit Curio on all of your Macs that you intend to sync.

. On Your Main Mac:

. In the Finder, choose Go > Go to Folder and paste this in: ~/Library/application Support .

. Open another Finder window and go to your Dropbox folder.

. Create a folder in Dropbox named “Application Support”, thus its path is ~/propbox/application Support .

oo Ok WON =

. Drag-and-drop the Curio folder from Library’s Application Support folder to the Dropbox’s Application Support folder,
thereby creating ~/propbox/Application Support/Curio .
7. Launch Applications > Utilities > Terminal and type this: defaults write com.zengobi.curio "Application Support Folder" -
string "~/Dropbox/Application Support/Curio"
8. On your other Macs launch Applications > Utilities > Terminal and type this:
defaults write com.zengobi.curio "Application Support Folder" -string "~/Dropbox/Application Support/Curio"
9. That’s it! Now all your Macs are pointing to the same application support folder which exists on Dropbox instead of the
default location.
10. Note that the application support override should point to the Curio folder itself, not a Version XX subfolder. Curio will look
for and manage the Version XX folder automatically so that Curio 11 looks within Version 11 and Curio 12 will look within
Version 12.

Network Installations

Applicable only in Curio from Zengobi’s website, not from the Mac App Store due to sandboxing restrictions.
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The Network Folder

The Network Folder

Curio finds its support files on the network via the network path settings in your Curio’s Settings window.
The default network SUppOI’t folder for Curio is: /Network/Library/Application Support/Curio/Version XX
(Where version xx is replaced with the current major version number like version 11 Or version 12 .)

To begin, copy your /Library/Application Support/Curio/vVersion xx folder on the administrator’s hard disk to that network
location. It will contain the license registration information necessary for the clients to validate their installation.

You should configure all client Macs to automatically mount that folder as a network share point. macOS Server includes helpers
such as autofs to make automatically mounting share points for clients easier. The details are specific to your network and macOS
version so check with your network administrator and Apple’s documentation to set this up.

To specify a different network install folder (note that Version XX is automatically appended to any specified path):

defaults write com.zengobi.curio "Network Application Support Folder" -string "/Network/Library/Application Support/Curio/"

Additional Settings for Network Installs

To disable automatic Curio update checks

By default Curio checks Zengobi’s servers every day to see if an update is available. This can be disabled this setting:

defaults write com.zengobi.curio "SUEnableAutomaticChecks" -bool no

To modify the days left warning for expiring license keys

If you enter an expiring license key such as an annual site license then at launch Curio will warn you when the license will be
expiring soon, and thus when Curio will stop working. The default is when there are 60 days left before expiring. You can change
that value if you feel you need more or less time to get purchase approval and acquire an updated license key.

defaults write com.zengobi.curio "License Days Left Warning" -int 60

To enable KidSafe Sleuth

As described earlier, Sleuth can be restricted specifically for school and home environments:
defaults write com.zengobi.curio "Sleuth Is KidSafe" -bool yes
After enabling Sleuth will:

+ Only show KidSafe sites in its search sites popup, such as Google Images with SafeSearch instead the normal Google
Image search.

+ Disallow Sleuth site customization.

* Block any query phrase which contain profanity.

« Block any query results which contain profanity.
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Keyboard Shortcuts

Keyboard Shortcuts

In addition to standard menu shortcuts, such as S to save, Curio supports a large number of keyboard shortcuts you can use to

be more productive.

3 = Command, ~\- = Option, ~ = Control, { = Shift, & = Delete, «J = Return, ® = Escape

Customizing Shortcuts

Some shortcuts can be customized with Curio’s Advanced Settings.
In addition, you can make your own custom keyboard shortcuts to any menu item within Curio, including figures styles and
stencils displayed in the Format and Insert main menus, using System Settings > Keyboard > Shortcuts > App Shortcuts. A

handy tutorial can be found here.

Views

Action

Show/Hide Organizer
Show/Hide Shelf

Show/Hide Organizer and Shelf
Show idea space at actual size
Quick zoom out to fit

Quick zoom in

Dismiss an open inspector popover

Zoom both split views

Zoom both split views to actual size

Shortcut

11 %80 (zero)

20 (zero)

=11 %0 (zero) or * (backtick)

#0 or double-click zoom slider if in toolbar

Hold down Q

Hold down {}Q

» (Escape)

Hold {} and use the zoom popup toolbar control, the zoom toolbar

slider, or the Zoom to Actual Size, Zoom to Fit, or Zoom to Width
menu items to zoom both the primary view and the secondary view.

Hold {} while double-clicking or ~=-clicking the zoom slider will set
both the primary view and the secondary view to actual size.
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Mouse/Trackpad

Mouse/Trackpad

Action Shortcut
Pan Scroll with mouse or trackpad;
or hold down Spacebar then click and drag to pan
Outward pinch gesture with trackpad;
Zoom in or “=¥Scroll Up;
or hold down Spacebar, then hold down &, then click to zoom
Inward pinch gesture with trackpad;
Zoom out or “=#¥Scroll Down;

or hold down Spacebar, then hold down -, then click to zoom

R ) Outward pinch gesture with trackpad;
Zoom in within gallery windows
or ~=¥Scroll Up

o . Inward pinch gesture with trackpad;
Zoom out within gallery windows
or \=8Scroll Down

Smart Zoom (if enabled in System Settings) Double tap to zoom, double tap again to restore

Files

Action Shortcut

Embed a copy of a file into Curio Drag file from Finder to an idea space
Move file into Curio #¥Drag file from Finder to an idea space
Create an alias to a file within Curio ~\-Drag file from Finder to an idea space

Select a single asset figure, ~={} #8Drag the figure and notice you are
Drag a copy of the asset file associated with a now dragging its file representation, release the keys while still
figure out of Curio continuing to drag, then drop the file on the Finder, Desktop, or other
application

Tools

Action Shortcut

Select tool » (Escape)
Figure tool F
Texttool T
Linetool L
Brush tool B

Eraser tool E
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Layers

Layers

Action Shortcut
Change the active layer to the next layer down ~{

Change the active layer to the next layerup 7}

Figure Snapping

Action Shortcut
Toggle edge snap guide S
Toggle center snap guide C
Toggle snap to grid G
Show/Hide grid TG

Figure Navigating

Action Shortcut
Select the next figure on the idea space >

If editing a figure, select the next editable

~—- (or enable » and 1)

figure on the idea space
Select the previous figure on the idea space  {} -

If editing a figure, select the previous editable

~{}— (or enable - and 1} )

figure on the idea space
If Tab is used to navigate and you want to

]
insert a tab while editing a figure

Figure Nudging

Action Shortcut

Arrow keys (if grid is not enabled)

Move object by one pixel

~“Arrow or {}Arrow keys (if grid is enabled)

Arrow keys (if grid is enabled)

Move object by one grid space

~“Arrow or {}Arrow keys (if grid is not enabled)

Move object to next grid intersection ~=1} Arrow keys
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Figure Sizing

Figure Sizing

Action Shortcut

Resize object Drag selection handle

1rDrag handle (note that some items, like images, default to resizing

Constrain aspect ratio when resizing object .
proportionally)

Drag out a sticky connecting line ~Drag selection handle

Resize image to its natural size, but no wider

than the right edge of the idea space

Resize image to its natural size, expanding the
idea space if necessary

Reload the full, non-optimized image from

disk, then resize it to its natural size, ~°N
expanding the idea space if necessary

Figure Rotating

Action Shortcut

Rotate object ¥Drag selection handle
Rotate object 45° R

Rotate object -45° {} R

Rotate object 1° ~R

Rotate object -1° ~={'R

Rotate object to 0°Z

Figure Selection

Action Shortcut

Add (or remove) selected object to previously ) i
) 1 Click, $-Click
selected objects

Add (or remove) selected range to previously
_ 1rDrag, $Drag
selected objects

Constrain selected range to figure layer ~-Drag
Constrain selected range to scribble layer ~¥Drag
Bring figure to front ~=-Click
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Figure Copying

Figure Copying

Action Shortcut
Cut selected text or object #X
Copy selected text or object $C
Paste selected text or object 8V
Duplicate object ~_Drag or $D

Delete selected object &

Figure Meta

Action

Toggle status bar visibility

Set keyboard focus on status bar

Toggle checkbox visibility

Toggle checkbox checked/unchecked state
Show the percent complete menu

Show the percent complete mini popover
Set percent complete to 10% through 100%
and show checkbox

Set priority to none, very low, low, medium,
high, urgent

Set rating from 0 to 5 stars

Show the dates mini popover

Toggle start date

Toggle due date

Show the tags mini popover

When editing tag emoji field, display the
standard Mac OS Character Viewer popover
to insert an emoji or Unicode symbol
Toggle notes window visibility

Increase the adornment flag size

Decrease the adornment flag size

Shortcut

38/

/

X

X

~\c-click checkmark adornment

P (or ~=1r-click checkmark adornment)

1 through 0

20 through ~5

110 through {}5

D (or ~c-click date adornment)
~D

D

M (for meta)
~¥Spacebar
8\

"

Al
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Figure Miscellaneous

Figure Miscellaneous

Action Shortcut

Play/pause a selected media figure ﬁ@
Open a figure’s asset, go to the figure’s jump
target, or activate in-place browsing or editing Double-Click on figure
of movies, WebViews, or PDFs
(b)gjvn;:; figure’s asset bypassing in-place ~-Double-Click on figure
Edit the text or caption of the selected figure,
else activate and play a selected video figure
shown as preview or audio figure, or activate a «J or {} «J to skip editing
PDF figure shown as preview, or activate a live
web view figure
Deactivate an activated video or audio figure,
PDF figure, or live web view figure (if the site’s
) » (Escape)
not capturing keystrokes), or stop the
playback of an audio media figure
Show Insert popover menu I
. ) Spacebar if not a parent node in a list or mind map, else
Show Quick Look Preview
~\-{} Spacebar
Toggle shadow S
Flip through a series of overlapping figures ~=Scroll with mouse hovering over overlapping figures
Decrease the pen size used for borders and
lines

Increase the pen size used for borders and

lines

Decrease the adornment flag size N
Increase the adornment flag size N
Decrease the figure corner {
Increase the figure corner }
Decrease the figure margin ~{
Increase the figure margin ~\}
Decrease the figure width N
Increase the figure width A}
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Brush & Pens

Brush & Pens

Action Shortcut

Decrease the brush size when painting [

Increase the brush size when painting ]

Text Editing

Action

Edit the text or caption of the selected figure

Create a new text figure

Create a new text figure with a certain width

Create text figure under selected object
Create text figure over selected object
Enter a carriage return while editing
End text editing

Idea Graphs

Shortcut
<

Click on the idea space background if the Text tool is active, else
double-click if the Select tool is active

Click and drag on the idea space background if the Text tool is active,
else double-click and drag if the Select tool is active

Hed

T8

R

» (Escape)

Action

Create a connected text figure with directional

line

Create a connected text figure with
bidirectional line

Create a connected text figure with
nondirectional line

Quickly connect one figure to another with
directional line

Quickly connect one figure to another with
bidirectional line

Quickly connect one figure to another with
nondirectional line

Shortcut

While editing an existing text figure, 3-Click on the idea space
background

While editing an existing text figure, {7 -Click on the idea space
background

While editing an existing text figure, ~=3-Click on the idea space
background

Drag one figure on another while holding &

Drag one figure on another while holding 1} &

Drag one figure on another while holding ~=%
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Lines

Lines

Action Shortcut

Snap line to 45 degree increment 1 (while dragging endpoint)

Add another point to a line currently being

Hold ~= while releasing mouse button then click for the next point
created

Add another point to an existing line Right-click on the line and choose Insert Midpoint

Stick line endpoint to a location within a target ) . )
. ¥ (while dragging endpoint)
igure

Freely position line endpoint (will not stick to

' ~ (while dragging endpoint)
another figure)
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List Collections

List Collections

Action

Edit selected item

Stop editing item

Delete selected item
Create next text sibling
Create previous text sibling
Create child

Create parent

Split the text at the current cursor position and

make new sibling

Enter a carriage return while editing

Indent a collection figure (turn figure into a

child)

Outdent a collection figure (turn figure into a

parent)

Insert a tab while editing

Toggle the expand/collapse of a branch

Toggle the expand/collapse of a branch and

its children

Toggle the expand/collapse all branches at

this level

Shortcut
U

» (Escape)

<

¥ or H if editing
1188 or {1 if editing
R

T\

AN

N

> Or ~{}—

T=or e

]

Quick Spacebar Tap

Quick ~=Spacebar Tap or ~=-Click the expand/collapse widget

Quick {rSpacebar Tap or {} Click the expand/collapse widget

Move the selected figures above their siblings {1

Move the selected figures below their siblings 1} |

Adopt the branch style when moving nodes  Press {} right before dropping

Create a connected list figure with directional

line
Create a connected list figure with
bidirectional line

Create a connected list figure with
nondirectional line

Select an existing list figure, $-Click on idea space background

Select an existing list figure, {} %-Click on idea space background

Select an existing list figure, ~238-Click on idea space background
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Mind Map Collections

Mind Map Collections

Action

Edit selected item
Stop editing item
Delete selected item

Create next text sibling

Create previous text sibling

Create child

Create parent

Split the text at the current cursor position and

make new sibling

Enter a carriage return while editing

Indent a collection figure (turn figure into a

child)

Outdent a collection figure (turn figure into a

parent)

Toggle the expand/collapse of a branch

Toggle the expand/collapse of a branch and

its children

Toggle the expand/collapse all branches at

this level

Move the selected figures above their siblings
Move the selected figures below their siblings
Adopt the branch style when moving nodes

Create a connected mind map figure with

directional line

Create a connected mind map figure with

bidirectional line

Create a connected mind map figure with

nondirectional line

Shortcut

<

» (Escape)

<

¥ or H if editing
1188 or {1 if editing
- Oor "+

T =or 1 \"¥<J

AND
N

"B or o

~ge—or ~ e
Quick Spacebar Tap

Quick ~=Spacebar Tap or ~=-Click the expand/collapse widget

Quick {rSpacebar Tap or {7 Click the expand/collapse widget

~1

~

Press 1} right before dropping

Select an existing mind map figure, -Click on idea space
background

Select an existing mind map figure, {1 #-Click on idea space
background

Select an existing mind map figure, ~=3-Click on idea space
background
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Table Collections

Table Collections

Action Shortcut
Edit selected item D

Stop editing item » (Escape)
Delete selected item &

Edit the next item >

Edit the previous item e

Enter a carriage return while editing N

Resize just a row or column, without resizing o
~-Drag row or column divider

entire table

Add Row Above Select cell, press ~“Up
Add Row Above and Resize Table Select cell, press =1} Up
Add Row Below Select cell, press ~“Down
Add Row Below and Resize Table Select cell, press ~={r Down
Add Column Before Select cell, press ~Left
Add Column Before and Resize Table Select cell, press ~=1} Left
Add Column After Select cell, press ~“Right
Add Column After and Resize Table Select cell, press =1} Right

Create a connected table figure with o . . )
o ) Select an existing table figure, $-Click on idea space background
directional line

Create a connected table figure with o . ) .
o ) ) Select an existing table figure, {}8-Click on idea space background
bidirectional line

Create a connected table figure with o . ) )
o ) Select an existing table figure, ~=3-Click on idea space background
nondirectional line
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Index Card Collections

Index Card Collections

Action

Edit selected item

Stop editing item

Delete selected item

Move between the title and body fields
Insert a tab while editing

Toggle the expand/collapse of the index card

Create a connected index card figure with
directional line

Create a connected index card figure with
bidirectional line

Create a connected index card figure with

Shortcut

i

» (Escape)

<

1, {1

Y

Quick Spacebar Tap (while the index card or its title is selected)

Select an existing index card figure, 3-Click on idea space
background

Select an existing index card figure, {7 8-Click on idea space
background

Select an existing index card figure, ~23-Click on idea space

nondirectional line background
Album Collections

Action Shortcut
Edit selected item s

Stop editing item

Delete selected item
Toggle the expand/collapse of the album

Create a connected album figure with
directional line

Create a connected album figure with
bidirectional line

Create a connected album figure with
nondirectional line

» (Escape)
=

Quick Spacebar Tap (while the album is selected, note this is only
possible if the pinboard has a title)

Select an existing album figure, $-Click on idea space background

Select an existing album figure, {}3-Click on idea space background

Select an existing album figure, ~=#-Click on idea space background
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Pinboard Collections

Pinboard Collections

Action
Edit selected item
Stop editing item

Delete selected item
Toggle the expand/collapse of the pinboard

Create a connected pinboard figure with
directional line

Create a connected pinboard figure with
bidirectional line

Create a connected pinboard figure with

Shortcut
i

» (Escape)
<

Quick Spacebar Tap (while the pinboard is selected, note this is only
possible if the pinboard has a title)

Select an existing pinboard figure, #-Click on idea space background

Select an existing pinboard figure, {7 8-Click on idea space
background

Select an existing pinboard figure, ~=3-Click on idea space

nondirectional line background
Stack Collections

Action Shortcut
Edit selected item ~J

Stop editing item

Delete selected item

Create next text sibling

Create previous text sibling

Move the selected figures above their siblings

Move the selected figures below their siblings
Toggle the expand/collapse of the stack

Create a connected stack figure with
directional line

Create a connected stack figure with
bidirectional line

Create a connected stack figure with
nondirectional line

® (Escape)

<&

¥, orjust «J if editing

118, or just {+ < if editing

~ 1

~

Quick Spacebar Tap (while the stack is selected, note this is only
possible if the stack has a title)

Select an existing stack figure, $-Click on idea space background

Select an existing stack figure, {7 8-Click on idea space background

Select an existing stack figure, ~“§-Click on idea space background
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Organizer

Organizer

Action Shortcut
Rename an Organizer item «J, Enter
Indent Organizer items to the right >
Move indented Organizer items to the left T
Extend selection to the selected Organizer )
. 11 Click
item
Add the selected range to previously selected

o {rDrag
Organizer items
Add (or remove) selected Organizer item to s Click

-Clic

previously selected Organizer items
Select next Organizer item 1, or 8] if the Organizer doesn’t have focus

Extend selection to the next Organizer item T

Select previous Organizer item 1, or 71 if the Organizer doesn’t have focus
Extend selection to the previous Organizer

item o

Delete selected Organizer items &

Create new blank or default idea space ~\=-Click the Add toolbar button

Create new idea space with same style/ )
1} Click the Add toolbar button
template as current

Create a copy of an Organizer item ~“Drag the item to a destination location
Create an alias to an Organizer item ~“¥Drag the item to a destination location
Collapse selected Organizer item —
Collapse selected Organizer item and all child
Organizer items ~
Expand selected Organizer item —
Expand selected Organizer item and all child
Organizer items ~
Scroll down a “page” of Organizer items
without changing the selection Page Down
Scroll up a “page” of Organizer items without
Page Up

changing the selection
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Presentation Mode

Presentation Mode

Action Shortcut
End the presentation » (Escape)
Go to the next slide —, |, Page Down, |, Click when mouse cursor is hidden

) ) «—, 1, Page Up, $1, ~=-Click (or Right-Click) when mouse cursor is
Go to the previous slide

hidden
Go to the first slide Home
Go to the last slide End
Go back in history [, Backspace, $«
Go forward in history ], ®—

Toggle the expand/collapse of a selected mind _
Quick Spacebar Tap
map branch

Toggle the expand/collapse of a selected mind _
) ) Quick ~=Spacebar Tap
map branch and its children

Toggle the expand/collapse all selected mind )
) Quick {}Spacebar Tap
map branches at this level

Toggle scaling mode S

Zoom Out (experimental) ,0r <

Zoom In (experimental) .or>

Zoom Actual Size (experimental) /

Scroll the idea space Click and drag on the background or use mouse or trackpad scrolling
Select a figure Click on figure

Open a figure’s asset or go to the figure’s ) i
Double-Click on figure

jump target
Play/pause a selected media figure Spacebar
Set a rating 0 through 5 (when a figure is selected)
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