Curio 7.4.1 Release Notes

Release Date

May 2, 2011

Requirements

Curio requires Mac OS X v10.5 (Leopard), Mac OS X v10.6 (Snow Leopard), or Mac OS X v10.7 (Lion) on PowerPC or Intel machines.

Notable Tweaks

Notable Fixes