Curio 5.4.5 Release Notes

Release Date

August 29, 2009

Requirements

Curio requires Mac OS X v10.5 (Leopard) or Mac OS X v10.6 (Snow Leopard). Mac OS X v10.4 (Tiger) is no longer supported!

Notable Fixes