Title

Curio 5.3 Release Notes

Release Date

November 18, 2008

Requirements

Curio requires Mac OS X v10.5 (Leopard) or above. Mac OS X v10.4 (Tiger) is no longer supported!

Important Changes From Earlier Versions! PLEASE READ!

  1. You can now expand and collapse a parent node in a list or mind map hierarchy by tapping the spacebar.
  2. You can now activate Quick Look for any asset figure except for parent nodes in a collection simply by tapping the spacebar. Option-Spacebar still works in all cases as well.
  3. You can now insert a mind map child item by pressing the tab key, just like other mind mappers such as MindMeister and FreeMind.

New Features

Custom Print Headers and Footers

Via Curio's Idea Space Preferences, you can now set the format of the print header and footer to contain any text you want. This is perfect for adding boilerplate text such as "Confidential" to every printed (or PDF exported) page. In addition, the following variables, shown with an example output, will be dynamically replaced as appropriate.

  1. {%ProjectTitle} = My Project Name
  2. {%IdeaSpaceTitle} = This Idea Space Title
  3. {%IdeaSpaceNumber} = 2

AquaMinds NoteTaker NTML Importer

Curio now supports importing NoteTaker notebooks.

  1. In NoteTaker, choose File > Export NTML > Notebook.
  2. In the resulting dialog make sure "Include Local Attachments" is CHECKED but make sure "Separate Pages Files" is UNCHECKED. In the XSL Transform popup, "NTML" should be selected. Then type in a name to save the export under and click Save.
  3. This will create a folder on your hard disk.
  4. Now launch Curio 5.3 and either create a new project or open a project you want to import your NoteTaker notebook into. The sections and pages of the NoteTaker notebook will be inserted after the currently selected idea space.
  5. Choose File > Import > NoteTaker NTML Folder and choose your exported folder then click Import.
  6. That's it.

There are some limitations of the importer as follows:

  1. For speed reasons, none of the generated idea spaces have previews that show up in the Organizer. However, the preview will magically appear as you step through the idea spaces manually.
  2. NoteTaker supports a mix of text and graphics within the same "cell". Curio doesn't support that. So we turn those into sibling entries in the resulting list.
  3. No text style information is transferred over. All lists are in the default list style within Curio.
  4. Internally referencing links are not transferred over.

Convert List <-> Mind Map

Via the Arrange > Convert Into menu you can convert lists into mind maps and vice versa. Note that the style formatting is reset to the default list or mind map style, as appropriate.

Export As Text Outline and RTF Outline

Via the Edit > Export As > Text Outline and Edit > Export As > RTF Outline menu items you can now export the selected list or mind map as a carriage-return delimited, tab-indented outline structure in either plain text or rich text, respectively.

MindMeister's import will accept the output of Export As Text Outline so you can easily transfer a mind map up to their service.

Paste a Text Outline as a Mind Map

If you have a text outline in the clipboard, Curio's new Paste As > Mind Map, you can now create a new mind map or add a new branch to an existing mind map.

OmniOutliner's Copy command, MindMeister's Copy as Text command, and FreeMind's Copy command will place this type of information into the clipboard for easy pasting into Curio.

On a related note, Curio's Copy As > Text Outline can be used to bring an outline into FreeMind simply by pasting.

Screen Snapshot Auto Hide

Curio will now automatically hide itself when using the Snapshot toolbar item, that way Curio is out of the way when you want to grab part of the screen. When you finish your snapshot, Curio will automatically unhide itself. You can disable this auto hide feature via the Snapshot toolbar item's popup menu which appears if you press and hold the mouse button on the toolbar item.

Even Smarter Spread PDF

Spread PDF will now start the spread based on the page number displayed in the first PDF figure. For example, set the PDF figure to display page 25 and Spread PDF will spread from page 25 through the number of pages in the PDF.

Notable Fixes