Curio 5.0 Release Notes

Release Date

August 13, 2008

Requirements

Curio requires Mac OS X v10.5 (Leopard) or above. Mac OS X v10.4 (Tiger) is no longer supported!

Editions

Unless otherwise specified any features listed are in all editions of Curio. Features only available in certain editions will be listed with color-coded words like this [ProStandard]. So, for example, [Pro], means that the feature is available only in the Professional edition of Curio.

Important Notice To Upgraders

  1. Curio requires Mac OS X v10.5 (Leopard) or above. Mac OS X v10.4 (Tiger) is no longer supported!
  2. Curio K-12 Edition has been dropped. K-12's Restrictions features have been added as the new Parental Controls preference panel in Standard and Pro editions.
  3. Curio now assumes files added to projects are to be embedded into the project, not aliased. If you want to create an alias to a file, simply hold down the Option key while dragging in the item.
  4. The backtick (tilde) key now shows/hides both the Organizer and the Shelf.
  5. Curio lists are now enabled with level styles automatically. This means changes made to a figure at one hierarchical level are immediately reflected to all other figures at that level. This makes it very easy to create styled lists. If you wish to disable this functionality you can uncheck the "Support level styles" checkbox in the Style inspector, or check one of the "Except for..." checkboxes within the same inspector. You can find more information about level styles in the Creating and Using Figure Styles section of the Curio User Manual.

New Features

With Curio 5, we tackled many of the most requested features along with adding incredibly useful project and task management features to make Curio the ultimate digital notebook.

Status Shelf [Pro]

Your Curio project notebooks may contain dozens or hundreds of to-do items and multi-day tasks. Or, perhaps you're using Curio's customizable tag sets to categorize your tasks with Getting Things Done tags or other custom tags.

But how can you quickly find what you need to be working on? Are you behind schedule? Were you supposed to begin something but are late?

With Curio 5, you can now see at-a-glance your current project status with the new Status shelf module.

Behind the scenes, Curio is constantly scanning your project for all events (figures with start dates with or without checkmarks) and to-do tasks (figures with just due dates or checkmarked figures without start dates) to see what's due and what needs to be started.

Glance at the shelf and you'll see a little color-coded iChat-like jewel:

You can hover the mouse over the jewel and a tooltip appears letting you know exactly what's due or what needs to be started. Click it to activate the Status shelf to see color-coded bar graphs providing a quick big picture rollup, with ordered lists below detailing what items need your attention.

You can change the Search criteria so the lists are showing status information for this project only, or for all projects in a specific Project Center category, or for all tracked projects. And you can change the lists to group items based start date or due date, or on a specific tag set, like GTD, so you can see what's active and what's on hold.

Within the list, click on an item to jump over to that figure; Curio will automatically open that figure's containing project if necessary.

Idea Space Templates Shelf [Pro]

With Curio 5's new Idea Space Templates shelf, you can create a library of your favorite idea space styles.

Simply drag the idea space you'd like to store as a template from the Organizer directly into the Idea Space Templates shelf. To use a template, you can use any of these techniques:

  1. Double-click the template item to create a new idea space with that style as a sibling under the current idea space.
  2. Drag an template item from the shelf into any location within the Organizer.
  3. Click and hold the New toolbar button and select one of the most recently used idea space templates.

Within the Idea Space Templates shelf, you can create collections to easily organize your templates. A template can be categorized by more than one collection, for example "Favorites" and "Note Pages". Categorize a template by right-clicking on it and choosing a collection name. You can also sort the selected collection by idea space title, date added, or by most recently used.

You can share idea space templates that you create by selecting one or idea spaces in the templates shelf and right-clicking to access the context menu where you can either mail them to a friend or send them to Zengobi for inclusion in the Curio Community Center.

Expandable / Collapsible List and Mind Map Hierarchies

Certainly one of the top requests received here at Zengobi, so we're very happy to announce both lists and mind maps support expanding and collapsing.

Figure Styles and Style Inspector

The mind map and list style controls have been replaced with an all new, super easy-to-use Style Inspector which can be used with all types of figures.

The Style inspector supports four types of figures:

  1. Line Figure
  2. List Figure
  3. Mind Map Figure
  4. Basic Figure (i.e. any figure that isn't one of the above)

Creating a style is easy: just create one of the above figures, modify it to look exactly the way you want it to, then click on the Action menu in the Style inspector to save it.

You should note that the title of the Style inspector changes to reflect the type of figure selected. So, if you have a figure within a mind map selected then it will say "Style - Basic Figure", whereas if you have the mind map figure itself selected it will say "Style - Mind Map".

Using the Action menu, you can also mail the currently selected style to a friend, or send it to Zengobi for inclusion in the Curio Community Center.

To use a style, simply select one or more figures and select an available style using either the Style inspector or the style popup on the new Inspector Bar.

Level Styles

Collection figures, such as lists and mind map figures, support level styles which can be enabled using the Style inspector. When level styles are enabled, changing the attributes associated with a figure within the collection will automatically change all the same attributes for all figures at that same hierarchical level. This makes it incredibly easy to quickly define a mind map or list style.

Level styles are enabled by default for mind maps, as they tend to have the same style for figures at particular levels. On the other hand, level style are disabled by default for lists, as they are more likely to contain a mix of styles even within the same level.

Note, that you can also selectively disable figure styles for all items on a certain level (ex: the entire mind map supports level styles except for level 3) or just for specific selected figures (ex: a particular figure ignores level styles and can have a custom style to really stand out).

Project Center with Status Indicators and Custom Icons

The Project Center shows the same jewel information described above for the Status shelf along with a summary status line. Now, you can easily see how all of your projects are doing simply by glancing at the Project Center.

Hover the mouse cursor over an item to find out specifically what is due or needs to be started.

Plus, Project Center now supports custom icons for each project. For example, for a Biology class Curio project, find your textbook on Amazon.com and drag-and-drop the image directly into the image well in the Project Properties dialog. Now your project will be listed in the Project Center with its instantly recognizable book icon.

iCal Synchronization

Another very popular request from our customers!

In a project's Project Properties window, you will now see a Sync tab where you can enable iCal synchronization and your events and tasks will be mirrored within iCal. The synchronization is bi-directional, so if you check off a to-do task in iCal, it will be updated within Curio, for example.

When enabled, iCal synchronization will create a new iCal calendar specifically for this Curio project. Since each project has its own calendar this makes resetting the sync much easier via the Reset Calendar button within Curio. Also you can use iCal's publishing feature to publish specific project calendars to MobileMe (aka .Mac) or a private WebDAV server for all to see.

Figures with a start date are converted into iCal events, meaning they appear on the calendar display within iCal. However, as events, that means they don't have a checkbox to mark it as completed, or a priority selection.

Otherwise, all other appropriate figures, specifically those with checkboxes and no start dates or those with just due dates, are converted into iCal tasks, meaning they appear in the To Do Items panel within iCal. As tasks, they have checkboxes and priorities which reflect the states specified for the figure within Curio.

Titles, notes, and URL's are bi-directionally synchronized for all items. Additionally, for events, the start and due dates are synchronized, and for tasks, due date, priority, and "task completed" values are synchronized.

From the Sync Project Properties tab you can also specify if and when iCal reminders are set for synchronized events and tasks.

Inspector Bar

This may be the first visual change you notice with Curio 5: a new Inspector Bar right under the toolbar which gives you immediate access to the most common figure attributes.

With the Inspector Bar, you can change these attributes for the selected figures:

  1. Figure style.
  2. Font name, size, and foreground color.
  3. Shape and border color
  4. Fill color, shadow, and gradient.
  5. Meta information such as tags, flags, percent complete, priority, rating, and start and due dates.

WebView Figures and Google Docs Integration

You can create WebView figures three different ways:

  1. Via the Insert > WebView menu item.
  2. Via the Insert > Google Docs menu item.
  3. Click on an URL figure and set it to be displayed as a preview via the Asset Figure Inspector.

When double-clicked, the cached preview becomes a live WebView control, complete with mini toolbar, allowing you to browse completely within Curio. With the WebView's mini toolbar, you can also fine tune and set the URL associated with the figure.

Scrapbook Shelf

The Scrapbook, which used to be Pro-only and somewhat hidden in the Library, has been converted into a much more graphical shelf module and is now available for all editions of Curio.

Like the new Idea Space Templates feature, you can create custom collections of Scrapbook items to quickly find specific types of assets. For example, you might create "Contracts", "Logos", and "Letterhead" collection tags to easily categorize your Scrapbook assets.

Additionally, Snippets have been merged with the Scrapbook simply as uncategorized assets.

Color Coded Date Adornments

Date adornments are now enabled by default for all figures which have a start and/or due date, which means you can see these dates at a glance to the side of the figure.

Plus these adornments are color-coded just like the status jewels in the Project Center and Status Shelf, so you can see instantly what you need to tackle next.

Spread PDF

This is a feature request we received from several students across the country almost simultaneously.

Say a professor gives you a 50 page PDF with slides for today's lecture. You want to pull that into Curio and annotate the pages while you're taking notes. Here's how Curio 5 makes that a piece of cake:

  1. Create a new idea space titled with today's date, for example: "September 15, 2008" (which you filled in using the Insert > Date menu, naturally).
  2. Drag the PDF into the idea space and arrange it on the left side of the page.
  3. On the right side, create a empty list figure for key points, with a fixed-width text field below that for additional notes as that slide is discussed.
  4. Next, choose the Organizer > Spread PDF menu item.

In an instant, Curio quickly creates 49 additional idea spaces using that first idea space as a template. Each subsequent idea space will show the next page in the PDF. Everything is all set for you to take notes and use the sketching tools to make annotations right on the PDF image.

On that first idea space, you could have duplicated the PDF figure multiple times where each duplicate showed a different page within the PDF (via the Asset Figure inspector). So, for example, you could put pages 1, 2, and 3 on that first PDF. Then, when you selected Spread PDF, Curio would have created only the number of idea spaces need to show each triplet of pages.

Search Shelf Results List

The Search shelf has a brand new addition: a search results list!

When you perform a search you have to click the Begin Search button to actually initiate the search, instead of searching immediately as you were typing or selecting items. Note that pressing Return while in the search for text field will also automatically initiate the search.

After the search is performed, a new results list appears showing all the figures that match the given search criteria. You can group the search results in many ways including by idea space, start date, due date, last modified date, rating, priority, asset type, or even by a tag set such as GTD or Context. Single click on an item to jump to its location in the project.

Transitions Inspector [Pro]

You can now set the slideshow transition to use during Presentation mode for each individual idea space, using the new Transitions inspector.

The default is still specified in the Presentation panel in the Curio Preferences dialog. But, using the new inspector, you can override this default for specific idea spaces to give your presentation a bit of pizazz!

You can select a native transition, a Core Image transition, or a Quartz Composer transition. And, as before, you can even create your own custom Quartz Composer compositions and place them in your ~/Application Support/Curio/Transitions directory and they'll be available within Curio.

Share Specific Idea Spaces

You can now mail only selected idea spaces via File > Mail As > Curio Project and clicking on the Mail Selected button.

The specified idea spaces are copied into a temporary project, with all assets embedded, which is then zipped up and added to an email message. This makes it super-easy to share idea spaces with friends and colleagues.

Idea Space Links and Cross-Project Jumping

You can now drag an idea space from the Organizer into an idea space to get an Idea Space Link.

This figure shows the preview of the dragged-in idea space unless (a) it's the current idea space, in which case it shows a distinctive "you are here" icon, or (b) the idea space is from an external project, in which case it shows a distinctive "external project" icon.

An Idea Space Link behaves like any other figure in Curio, so you can add it to mind maps, lists, or anything else. Double-clicking the idea space link will jump you over to that idea space.

And, yes, that means Curio now supports cross-project jump anchors and jump actions, in addition to the new idea space links. You now have three ways to jump around within a project or across projects.

More Quick Look Support

All asset figures now support being displayed as a preview (via the Asset Figure Inspector). When this is enabled, a Quick Look-generated thumbnail will be used as the preview image.

Now you can easily see the contents of a Word document, Mail message, or other file within the idea space without having to launch it.

And, as always, if the asset figure is displayed as an icon & title and the icon size is 128x128 pixels or larger then a Quick Look-generated thumbnail will be used for the icon.

In addition, the Option-Spacebar method for bringing up the Quick Look preview popup window is now much slicker and more integrated into Curio.

Multi-touch Support

If you have one of the newer Apple laptops that support multi-touch gestures then you can take advantage of the following gestures.

Parental Controls

You can now restrict the capabilities of Curio using the Parental Controls panel accessible via Curio Preferences.

After authenticating yourself, you can disable Sleuth or Dossier customization and make Sleuth automatically block searches and/or search results that contain profanity. The profanity list is pre-loaded with approximately 200 phrases and can be customized to block additional phrases or permit currently blocked phrases.

You can also switch the bundled Sleuth sites so sites appropriate for children (i.e. KidSafe) are listed instead of the default Pro or Standard Sleuth sites.

Scribble Inspector Improvements

By popular request, you can now switch between brushes from within the scribble inspector. And all changes made to a brush, including color, size, and opacity are now stored to disk and restored when Curio is restarted. Clicking the Reset Brush button will reset the selected brush to its default attributes.

Pro Features Now In Standard

We've migrated a number of features that were formally Pro-only so they exist in Standard as well.

  1. Instant Document Templates via the Insert > Create Document menu item.
  2. Scrapbook for easily reusing assets in different projects.
  3. AppleScript figure actions.
  4. Customizable Sleuth.
  5. Full screen and mini mode via the Window > Layout menu item.
  6. Project and idea space sharing using email via the File > Mail As menu item.

Other Features

Notable Fixes